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DESIGN TIME REPORTING

The IBRM database is the repository for content created in RateManager. Data is stored in a
proprietary format. A design time reporting feature has been added to the IBRM database that
allows for access to the IBRM data in a relational data structure and format that can be used for
reporting. Data can be extracted and evaluated by a third party reporting tool.

The Insbridge Reporting Doc zip file contains detailed documentation that describes what data is
available, the relationships of all data elements, how the data should be accessed, and a sample
report that can be created using the available data.

Read only permissions are required to create a connection to the design time reporting feature.
Contact your system administrator to request permissions.

To access the design time reporting feature, a third party tool, such as Microsoft Excel, can be
used to create a connection to the IBRM database and download data.

Insbridge User Reporting Schema

The Insbridge User Reporting Schema offers a reporting view into the Insbridge RateManager
(IBRM) database.

This data is available to any standard SQL Server Database reporting software. Please contact
your IT department for your reporting options.
Reporting View Categories
Program Explorer Reporting Views
Universals Reporting Views
GlobalsReporting Views
LocalsReporting Views
Summary Reporting Views

General Reporting Views

Table Variable Data Views

See the Insbridge Reporting Doc zip for more information.
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Setting Up

A Reporting script must be run from within the RateManager application. Running db update
scripts requires admin permissions.

On the DB Updates screen, the current version will be highlighted and the status will be Current.
The updates below the current version will be grayed out. These updates cannot be run again.
Current updates can be re-run if necessary. You will receive an error message if you attempt to
run a lower version update. Any version update above the current version will also be grayed out
but will be available for executing.

New installations may show the latest version as current but still have only the Tools option
available. You may have to run the current script again. To see if you have complete access, click
File>Reload to refresh the system.
Navigate to the Tools->Database->Updates.
1. The Updates tab is displayed. Select the database you want to view from the Show
updates for drop down. The database updates for your selection is listed. The last
column, the Status column, shows you which update is the Current one installed.

2. For safety, run or rerun the IBRM and IB_CLIENT scripts before running the Reporting
script.

3. Run the reporting script. The Reporting script must be run last.

ORACLE" Insurance Insbridge RateManager

File Modules  Tools Help

Home () DB Updates X
@ DB Updates
: L?, Execute Update Script LE Cpen Update Script Save lpdate Script to File E]lj} Refresh
Show updates foI:I REPORTING v
Scapt Release Date Database Status
v05.02.00.00 6/1/2016 IERM

4. Click File->Reload to refresh the system.
5. Return to the Tools menu and Open Setup->Reporting Data Model
6. Click the Update Reporting Views.

This option updates the algorithm steps in the Reporting Data Model. This option only needs to
be run once. After it has been run, the data should be in sync.
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Insbridge Reporting Doc zip

7. Download the Insbridge Reporting Doc zip from the documentation download on Oracle
Cloud delivery or the Oracle Technical Network. Extract to a location on your local
machine.

8. Open the file and locate the Index.html file.

. » Computer + Data(D:) » Products » Insbri

Edit View Tools Help
Organize » & Open - Print Bum New folder - 0 @
Loana + Name - Date modified Type Size
l b 412 1. businessinfo 7/20/2015 745 PM  File folder
k48 1. datatypes 7/20/20157:45PM  File folder
& 19 . domains 7/20/20154:25PM  File folder
& 50 ) 1. logical 7/20/20157:45 PM  File folder
11 Reporting 1. mapping 7/20/20154:25PM  File folder
Ju InsbridgeReportingDacs 1 pm 7/20/2015745PM  File folder
(B instlstion Guideszip 1 rdbms 7/20/20154:25PM  File folder
& Callouts el 7/20/20154:25PM  File folder
& configxmi file 1. table 7/20/2015738 PM  File folder
ki Creating aRate 1. table - Copy 7/20/20156:44 PM  File folder
& Custom XML - | ChangeRequests.local 7/20/2015745PM  LOCAL File 1KB
Lo Custom XML file dbdoc.css 7/20/2015548 PM  Cascading Style ... IKB
& ES %% dbdoc.js 7/20/2015 548 PM  JScript Script File 12KB
& Guides [=) di_settingsxml 7/20/20157:51PM XML Document 19KB
& Basic | dmd_open.local 7/20/2015745PM  LOCAL File 1KB
& Batch & empty.html 7/20/2015 5:48 PM__ HTML Document 1 KB
& Callowts || 2l indexhtmi 7/20/2015 748 M HTML Document 1kl
& configmifile B nodeType himT TIOTI0TS So PN T Document TRE
& Creating aRate B round_textpng 7/20/2015548 M PNG image 1KB
. Custom XML
. Custom XML file
. Internationalization
-
——
_/@ indexhtml Date modified: 7/20/2015 7:48 PM Date crested: 10/6/2015 11:26 AM
J HTML Document Size: 567 bytes

9. Right click and Open with Internet Explorer.

10. This opens the Insbridge Reporting Details screen.
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E— [EE———— e ey~
@a D:\Products\Insbridge\5.04ReportingiInsbridgeReportingDocShindex.html L~c |@ D:\ProductsiInsbridge\5.0N... * | | "Ln} f? {‘é}

Eile Edit View Favorites Tools Help
Insbridge Runtime Reporting PR : G RAMS
Views 2 - - =
Programs entered in the Insbridge application.
Filter Reporting Views by: [ columns |
COLUMN NAME DATA TYPE NULLABLE DATA DEFAULT COLUMN ID COMMENTS
DOMAIN_TYPE_ID INTEGER No null 1 A unique identifier indicating the Domain Type
Reporting Views Data Model DOMAIN_TYPE_MAME NVARCHAR(50) Mo null 2 The Domain Type Name
DOMAIN TYPES DOMAIN_ID INTEGER No null 3 A unique identifier indicating the Domain
DOMAINS DOMAIN_NAME MVARCHAR(SD)  Yes null 4 The Domain Name
PROJECTS
PRODUCTS PROJECT_IDY INTEGER. Yes null 5 A unigue identifier indicating the Project
PROGRAM FOLDERS PRIJ_MODEL_ID INTEGER Yes null 6 A unique identifier indicating the Project Model
PROGRAMS PRI_MODEL_VER INTEGER Yes null 7 The Project Model Version
PROGRAM VERSIONS PROJECT_NAME MVARCHAR(SD)  No null 8 The Project Name
NOTES = —
CATEGORIES PRODUCT_ID INTEGER Yes null 9 A unigue identifier indicating the Product
INSTRUCTIONS PRODUCT_NAME NVARCHAR(SD)  Yes null 10 The Product Name
ALL TABIE VARS FOLDER_ID INTEGER Yes null 11 A unique identifier indicating the Folder
ALL TABLE QUALIFIERS FOLDER_NAME WVARCHAR(SD)  Yes null 12 The Folder Name
TAELE VAR VIEWE PROGRAM_FOLDER NVARCHAR(S63) e 1 13 The Py Folde
UNIVERSAL ALGORITHMS < s n S0 EIFE L
UNIVERSAL CALCULATED VARS PROGRAM_ID INTEGER Yes null 14 A unique identifier indicating the Program
UNIVERSAL CONSTANTS PROGRAM_NAME NVARCHAR(100)  Yes null 15 The Program Name
UNIVERSAL FIELD VARS TYPE INTEGER No null 16 The Type
UNIVERSAL FILTER RULES DATE_LAST_MODIFIED ~ SMALLDATETIME Mo null 17 The Date Last Modified
UNIVERSAL REPORT MASTER - =
UNIVERSAL RESULTS STATE_ID INTEGER Yes null 18 A unigue identifier indicating the State
UNIVERSAL TABLE VARS COUNTRY_ID INTEGER Yes null 19 A unique identifier indicating the Country
GLOBAL ALGORITHMS XSL_INPUT NTEXT Yes null 20 The XSL Input
GLOBAL CALCULATED VARS ¥5L_OUTPUT WTEXT Yes null 21 The XSL Output
GLOBAL COMSTANTS
GLOBAL DRIVER ASSIGNMENT DATE_MASK. NVARCHAR(20)  Yes null 2 The Date Mask
GLOBAL FIELD VARS CULTURE MVARCHAR(S0)  MNo null 23 The Culture
GLOBAL FILTER RULES DECIMAL_SYMBOL MVARCHAR(10)  MNo null 24 The Decimal Symbol
GLOBAL REPORT MASTER GROUP_SYMBOL NVARCHAR(10) No null 25 The Group Symbal
GLOBAL RESULTS
GLOBAL TABLE VARS . ; . .
GLOBAL VERSIONING DATA Copyright © 2015, Oracle and/or its affiliates. All rights reserved.
GLOBAL VERSIONING QUALIFIERS
LOCAL ALGORITHMS
LOCAL CALCULATED VARS
LOCAL DRIVER ASSIGNMENT N
LOCAL FILTER RULES
I

11. The left side is the views you can select. Click a view to see the details that are
presented. In this example, the Programs view was selected. On the right is a listing of
columns and column details.

The left side of the Insbridge Reporting Doc lists the available views.

The right side is the naming convention for the view.

12. You can leave this screen open while you work with the data. It is a good reference.

13. Close the screen when you are finished.

Setting Up a Connection to SQL Server Example
1. In Excel, select the Data tab.

2. Under Get External Data, select From Other sources.

3. Select SQL Server
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4. Enter the server name and your database credentials. You must have at least read-only

access.

i g = = - =
j@, He-e ) Bookl [Compatibility Mode] - Microsoft Excel
i‘j - . -
—/’ Home Insert Page Layout Formulas Data Review Wiew Acrobat
= B 5 = ﬁ 5] connections 4l ﬁ \L]_" {x Clear = g_‘g
_[_'f,g @ =1 = 3" Properties Lt oy Reapply
From From From JFrom Othe| Existing Refresh o %l Sort Filter YL Textto  Remove
Access  Web  Text J Sources - || Connections All- == Edit Links J? Advanced || columns Duplicat
Get E 5 From SQL Server ort & Filter
Al = Create a connection to a SQL Server table, Import data
- into Excel as a Table or PivotTable report,
A B B From Analysis Services H 1 K
1 :I _L,,J Create a connection to a SQL Server Analysis Services cube, |
H Import data into Excel as a Table or PivotTable report.
2 »  From XML Data Import
3 ﬁ Open or map a XML file into Excel
- I From Data Connection Wizard
3 j Import data for an unlisted format by using the Data
& — Connection Wizard and OLEDB.
7 ;] From Microsoft Query
= Import data for an unlisted format by using the Microsoft
8 e Query Wizard and ODBC.
9

-

Data Connection Wizard

Connect to Database Server

Enter the information required to connect to the database server,

1. Server name: |pMDatabase
2. Log on credentials
(7 Use Windows Authentication

(@ Use the following User Mame and Password

User Mame: | dbReportsReader

Password: esssssss

Cancel H < Back ][ Mext =

5. Select the IBRM database. The available table will be populated.
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Data Connection Wizard

Select Database and Table
Select the Database and Table/Cube which contains the data you want.

Select the database that contains the data you want:

master hd
DC53_P_NEW A
IE CLIEMT AL il
.
IBSR_184 LNX

IBSR_184 WIN

IBSR. 407 WIN o

Cancel H < Back ext

2

6. Select a table with an Owner of REPORTING. These are the design time reporting views
available.

-

Data Connection Wizard

Select Database and Table
Select the Database and Table/Cube which contains the data you want.

Select the database that contains the data you want:

IBRM_AI E

Connect to a spedfic table:

T ——

Mame Cwner Description Modified  Created i
ALL_TABLE_QUALIFIERS REPORTIMG 8/27/2015 .
ALL TABLE_VARS REPORTING 8/27/2015 [
CATEGORIES REPORTING B/27/2015
DOMAIN_TYPES REPORTING 8/27/2015
DOMAINS REPORTING B8/27/2015
GLOBAL_ALGORITHMS REPORTING B8/27/2015
GLDBAL CALCULATED WARS REPORTIMG a/27f2015 . 7
1| 1] [ 3

Cancel ] [ < Back ][ Mext = ] [ Einish

2

7. If you click next, the data connection file can be saved.
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-

Data Connection Wizard

Save Data Connection File and Finish

Enter a name and description for your new Data Connection file, and press Finish to
save,

File Mame:
RMDatabase IBRM_AI ALL_TABLE_VARS.odc

[7] save pazsword in file
Diescription:

(To help others understand what your data connection paints to)

Friendly Mame:
RMDatabase IBRM_AI ALL_TABLE_WARS
Search Keywords:

[ Always attempt to use this file to refresh data

Excel Services: | Authentication Settings... ]

[ Cancel H < Back

8. If you click Finish, the data will be downloaded but the connection will not be saved.

9. Select how you want to view the data.

Import Data I. ? ﬁ]

Select how you want to view this data in your workbook,
j (@) Table
iz () PivotTable Report
ﬂ:f_'| () PivotChart and PivotTable Report

o

Es| Only Create Connection
Where do you want to put the data?
(@ Existing worksheet:

Ssas]

() Mew worksheet

-

’P[uperties... ] [ K ] [ Cancel ]

10. You may be required to log in again.
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11. The data will be presented. This data can be shared and manipulated as needed.
Algorithms will have steps presented in a readable format.

E;_,\ Ha-&-)= Book3 [Compatibility Modle] - Microsoft Excel Table Tools E‘%
- Home Insert Page Layout Formulas Data Review View Atrobat Design @ - 7 X
Table Name: [iz] summarize with FivotTable 3 ﬂ & Properties ¥ Header Row First Column
Table_RMDatzba: | [ Remove Duplicates - pen in Br Total Row Last Column
= = Export Refresh ,,
T Resize Table || [ Convert to Range - ~ &5 Unlink 9| Banded Rows [ Banded Columns
Properties Taols External Table Data Table Style Options Table Styles
a2 - [
A B C D E F G H
[l prs_woner_io B3probuct name BllproGram i BIproG NAME  BllTasie variABLE NAME B3 TaBLE VERsioN BlLookup vaRs 1D Bl DATA TvPy
2 llAuto 0 AUTO GLOBAL Usage Code 3 260 =
3 1 Auto 0 AUTO GLOBAL Va_Alookup_Table 1 272
4 1 Auto 0 AUTO GLOBAL UsageCode_5 * 280 I
o 1 Auto 0 AUTO GLOBAL Usage Code SCHD A 1 290
6 1 Auto 0 AUTO GLOBAL UsageCode 6 % 300
7 1 Auto 0 AUTO GLOBAL AM_Audio_Code 1 311
8 1 Auto 0 AUTO GLOBAL Option_Code * 320
3 1 Auto 0 AUTO GLOBAL Option_Fee 1 320
10 1 Auto 623458624 ModelAutolnsurance CSLBaseRate 3 5001 2
11 1 Auto 1 5001 2
12 1 Auto del * 5001 2
13 1 Auto 1 5001 2
14 1 Auto Ct E 5001 2
15 1 Auto C 1 5001 2
16 1 Auto 623458624 ModelAutolnsurance BIClassFactor 1 5002 2 i
17 1 Auto 623458624 ModelAutolnsurance PDClassFactor 1 5002 2
18 1 Auto 623458624 ModelAutolnsurance CSLClassFactor 3 5002 2
19 1 Auto 623458624 ModelAutolnsurance MPClassFactor 1 5002 2
20 1 Auto 623458624 ModelAutolnsurance CompClassFactor 1 5002 2
n 1 Auto 623458624 ModelAutolnsurance CollClassFactor 1 5002 2
22 1 Auto 3 5003 2 I
23 1 Auto C 1 5003 2
21 1 Auto 623458624 ModelAutolnsurance CollsymFactor 1 5003 2
25! 1 Auto Copy of Model CSLBaseRate i) 22
26 1 Auto Copy of 1 232
27 1 Auto Copy of PD 1 22 |
28 1 Auto Copy of 1 22
29 1 Auto Copy of Model C ) 22
30 1 Auto Copy of C 1 22 |
31 1 Auto Copy of BIC 1 32
H 4« » H| sheetl ~Sheet? “Sheet3 %) 0| I 0
Ready = 0 T

For more information regarding the columns and information presented, please see the Insbridge
Reporting Doc zip.

If you saved your connection, you can access the table at a later time by clicking the Existing
Connections under Get External Data.
Permissions Error

If you do not have the proper permissions an error message is presented.

Microsoft Office Excel lﬂ._hj

[DBMETLIE] [ConnectionOpen (Connect()).]S0L Server does not exist or access denied.
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Contacting Support

If you need assistance with an Oracle Insurance Insbridge Enterprise Rating System product,
please log a Service Request using My Oracle Support at https://support.oracle.com/.

Oracle customers have access to electronic support through My Oracle Support. For information,
visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit
http://www.oracle.com/pls/topic/lookup?ctx=acc&id=trs if you are hearing impaired.

Address any additional inquiries to:

Oracle Corporation
World Headquarters
500 Oracle Parkway
Begvxood Shores, CA 94065

Worldwide Inquiries:
Phone: +1.650.506.7000
Fax: +1.650.506.7200
oracle.com

10
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