Oracle Enterprise Manager Administrator's Guide Go to Product Documentation Library
Library
Go to books for this product
Product
Go to Contents for this book
Contents
Go to Index
Index



Go to previous file in sequence Go to next file in sequence

Managing and Moving Data


This chapter describes how to use Oracle Data Manager wizards to transfer data to and from an Oracle database. It also includes a discussion of the Data Manager tasks that can be submitted with the Job Scheduling system. The topics in this chapter are:

This chapter assumes that you have read Chapter 7, "Overview of the Database Tools", and that you are familiar with the interface elements of the database tools.

For more information on the tasks Data Manager performs, see the sections on the Export, Import and SQL*Loader utilities in Oracle Server Utilities. For information about standard elements of your operating system, see your operating system-specific documentation.

Starting Data Manager

To start Data Manager, select a database object from the Navigator tree list. Then click on the Data Manager icon in the Applications Launch Palette, or choose Applications and then Oracle Data Manager from the Tools menu.

Note: You can change the database connection with the Change Database Connection option in the File menu. For information, see Application Menus on page 7-8.

Data Manager Window

After Data Manager has successfully connected to a database, the Users container displays in a tree list on the left side of the Data Manager window. The Users container is located in the database that Data Manager is connected to. An individual user container can be expanded to show the tables that the user owns.

The display on the right side of the window is determined by the object selected on the left side of the screen. The right side may contain a multi-column list, property sheet, or other information.

For general information, see:

An example of a Data Manager window is shown in Figure 14-1, "Oracle Data Manager".

Figure 14-1 Oracle Data Manager

Data Manager Menus

Oracle Data Manager includes the standard menus, File, View, Log, and Help, plus the Data menu. For information on the standard menus, see Application Menus on page 7-8.

The Data menu includes the Export, Import, and Load wizard options for:

Context-sensitive menus may also be active when you press the right mouse button to select a specific object from the navigator or the multi-column list. This feature provides quick access to a subset of the menu options provided in the menu bars.

Data Manager Icons

The objects in the tree list are identified by various icons. In the listing:

Exporting Data to a File

Data Manager Export is used to the transfer data from an Oracle database to an operating system file in Oracle-binary format. Files in this proprietary format can only be read by using the Import component of Data Manager. Export files can be used to transfer data between databases or used as backups.

To export data from a database with the Data Manager Export wizard:

See the Data Manager Export online help for information on the individual pages of the Export wizard.

Remote File Option

This option specifies that the file is on the remote machine that contains the connected database. This option uses the Job Scheduling system and is only available when the Console is running.

BUFFER and RECORDLENGTH Defaults

When running the Export wizard, note that the default values for certain parameters are operating-system specific. Specifically, the BUFFER parameter defaults to a value of 4K under Windows NT and the RECORDLENGTH parameter defaults to 2K.

Importing Data from a File

Data Manager Import is used to transfer data from an export file to an Oracle database. Import can only read data that has been created with the Export component of Data Manager.

To import data to a database with the Data Manager Import wizard:

See the Data Manager Import online help for information on the individual pages of the Import wizard.

Remote File Option

This option specifies that the file is on the remote machine that contains the connected database. This option uses the Job Scheduling system and is only available when the Console is running.

BUFFER and RECORDLENGTH Defaults

When running the Data Manager, note that the default values for certain parameters are operating-system specific. Specifically, the BUFFER parameter defaults to a value of 4K under Windows NT and the RECORDLENGTH parameter defaults to 2K.

Loading Data from an External File

Data Manager Load is used to transfer data to an Oracle database from files that have a different format from export files. Often these are delimited text files. Using a control file, you specify how the data is stored externally and how it is to be loaded into the database.

To load data into a database with the Data Manager Load wizard:

See the Data Manager Load online help for information on the individual pages of the Load wizard.

Note:

You must supply a control filename to load data. For information on control files, see the Oracle Server Utilities Guide.

Remote File Option

This option specifies that the file is on the remote machine that contains the connected database. This option uses the Job Scheduling system and is only available when the Console is running.

Data Manager Tasks

The Export, Import, and Load tasks are set up and submitted with the Oracle Enterprise Manager Job Scheduling system and executed by Oracle Enterprise Manager Intelligent Agents residing on managed hosts.

The Data Manager tasks are selected in the Task page of the Create Job property sheet. The parameters are defined in the Parameters page of the Create Job property sheet. These parameters are similar to the options available when using the Data Manager wizards. For information on the specific parameters for the Export, Import, and Load job tasks, see the online help for the Data Manager tasks.

For information on using the Job Scheduling system, see Chapter 4, "Job Scheduling". For information on specific job tasks, see the online help for Predefined Job Tasks.




Go to previous file in sequence Go to next file in sequence
Prev Next
Oracle
Copyright © 1997 Oracle Corporation.
All Rights Reserved.
Go to Product Documentation Library
Library
Go to books for this product
Product
Go to Contents for this book
Contents
Go to Index
Index