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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Implementation Guide provides general descriptions of the setup and 
configuration tasks required to implement Oracle Telephony Manager successfully. 

This preface explains how this Implementation Guide is organized and introduces 
other sources of information that can help you.

Intended Audience
This guide is aimed at anyone who is tasked with implementing Oracle Telephony 
Manager, including:

■ Database Administrators

■ System Administrators

■ Technical Specialists

This guide assumes you have the following prerequisites:

1. Understanding of computer-telephony integration (CTI)

2. Understanding of call center technology

3. Understanding of the company business processes

4. Understanding of Oracle Applications, Release 11i

5. Understanding of Oracle Workflow
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Structure
This manual contains the following sections:

■ Considerations for Planning an Implementation Project

■ Typical Release Dependencies

■ Related Documentation and Resources

■ Upgrading from Oracle Telephony Manager 3i

■ Setting Up Oracle Telephony Manager

■ Setting Up Rules-Based Routing for Inbound Calls and Email

■ Setting Up Workflow-Based Routing for Inbound Calls and Email

■ Setting Profile Options

■ System Profile Options

■ Configuring and Testing Integration Points

■ Testing an Implementation Project

Related Documents
For more information, see the following manuals:

■ Oracle Applications Concepts

■ Oracle Applications Product Update Notes, Release 11i

■ Oracle Applications Release Notes, Release 11i

■ Oracle Applications Installation Update Notes

■ Installing Oracle Applications, Release 11i

■ Maintaining Oracle Applications, Release 11i

■ Upgrading Oracle Applications, Release 11i

■ Oracle Applications System Administrator’s Guide

■ Oracle Applications User’s Guide

■ Oracle Workflow Guide

■ Implementing CRM Applications

■ Oracle Telephony Manager Concepts and Procedures
viii



■ Oracle Telephony Manager Technical Reference Manual
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Implementing Oracle Telephony Manager

This guide provides general descriptions of the setup and configuration tasks 
required to implement OTM successfully. It includes an overview with list of steps 
to follow to set up OTM, and includes detailed instructions on completing setup 
tasks in each OTM setup window.

This guide contains the following information:

■ Considerations for Planning an Implementation Project

■ Typical Release Dependencies

■ Related Documentation and Resources

■ Upgrading from Oracle Telephony Manager 3i

■ Setting Up Oracle Telephony Manager

■ Setting Profile Options

■ Configuring and Testing Integration Points

■ Testing an Implementation Project
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Considerations for Planning an Implementation Project
This topic includes the following information:

■ Purpose for Planning an Implementation

■ Business Requirements Mapping

■ Application Architecture

■ Overview of a Typical Business Processes

Purpose for Planning an Implementation
Implementing Oracle Telephony Manager is a complex process that requires 
knowledge of a variety of technologies and processes. Persons implementing Oracle 
Telephony Manager should have a working knowledge of Oracle Forms, HTML, 
Java, and the installation platform (Windows NT or Unix). In addition, an 
understanding of the operational requirements of an interaction center and basic 
telephony functionality is required.

Oracle Telephony Manager implementation planning requires that you take a 
careful and detailed look at the following areas:

■ Verifying Operational Requirements: This is the preliminary step in the 
implementation. The PBX/ACD CTI enabler configuration must be complete 
and the appropriate Oracle Call Center Connectors installed and configured. 
This integration should be tested and functional before configuring Oracle 
Telephony Manager.

■ Installing and Connecting Servers: Also as part of the operational 
requirements, the servers and workstations to support Oracle Telephony 
Manager are installed and connected to the network. The consultant will need 
to work with the customer to determine the server architecture including the 
number of machines and which services will run them.

■ Installing Oracle Telephony Manager: Oracle Telephony Manager is installed 
on the various machines. 

■ Configuring Oracle Telephony Manager: Oracle Telephony Manager is then 
configured for the interaction center environment.

The consultant will need to work with the customer to determine if OTM will 
run in a passive or active routing mode. If OTM will run in an active routing 
mode and Advanced Inbound will be implemented, each of the various 
inbound media routes and call classifications will need to be defined and 
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configured. This may include routing for inbound telephone calls, inbound calls 
handled by the IVR, inbound eMail, and web callbacks.

In addition to defining the media routing, there may be special treatment 
required while media items are in queue that will need to be defined and 
configured. Queue treatments are only available when OTM is in an active 
routing mode and Advanced Inbound is being implemented.

If OTM is being implemented in an active routing mode, the route target groups 
will need to be defined. The target groups are the groups of agents that are 
allowed to be the recipient of a routed media item. Any agent that is not part of 
a target group for a particular media type will not be able to access that media 
type through the Universal Work Queue. For example, agents that are not part 
of any group servicing eMail will not see inbound eMail work.

■ Testing Oracle Telephony Manager: Finally, with all software installed and 
operating, Oracle Telephony Manager is put through the operational testing 
step to verify that it meets the operational requirements. 

Business Requirements Mapping
Oracle Telephony Manager is a prerequisite for providing:

■ CTI support and Softphone 

■ IVR Integration

■ Sophisticated routing across multiple media channels

■ Enhanced queuing, call treatment and overflow functionality

■ Pre-integrated with Oracle E-Business Suite applications

■ Essential call center functionality includes:

– Inbound and outbound telephony

– Out-of-the box ACD/PBX connectivity with multiple ACDs and CTI 
enablers

– Agent Softphone

– ANI & DNIS screen-pops

– Call and data transfer

■ Additional interaction center functionality provided includes:

– Multi-media support, telephone, Email and web callBacks
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– Intelligent out-of-the-box routing provides rules, skills and records-based 
routing

– Static and dynamic routing capabilities

– Best agent for given interaction is routed the interaction, telephone calls, 
email and web call backs

– Integration to IVRs provides additional data for enhanced routing and 
screen-pops

– Advanced queuing provides enhanced treatment, overflow and group 
queuing of calls

– Support for web callBacks

Application Architecture
Oracle Telephony Manager (OTM) is the platform for all Oracle interaction center 
and telephony applications. OTM translates the proprietary ACD/PBX protocol of 
telephony communications into computer-compatible language, and routes calls to 
the designated telephones and computers used by call center agents. 

Required third-party CTI middleware provide the interface between the customer’s 
proprietary PBX/ACD CTI link and our interaction center applications (Call Center 
Connectors and Oracle Telephony Manager). Third-party enablers, such as 
Dialogic’s CT-Connect, allow server API integration for CTI messaging. The 
integration between the third-party middleware, the Call Center Connectors server, 
and Oracle Telephony Manager allow standardization of CTI functionality and 
protect the customer’s Oracle application from the proprietary differences between 
PBX/ACD platforms.

An OTM interaction center is represented by a logical grouping of interaction center 
processes called a server group. The number of server applications in a server group 
will depend on the specific processes used in a particular interaction center.
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 The following types of server processes may be included in a server group:

Advanced Outbound Proxy Server is a server process for integrating the Oracle 
interaction center with advanced outbound telephony (Oracle Campaign Plus and 
Oracle Predictive).

Fulfillment Server is a server process for integrating the Oracle interaction center 
with Oracle 1-to-1 Fulfillment.

iCenter Server is a server process for integrating the Oracle interaction center with 
Oracle eMail Center.

Inbound Telephony Server is a server process which monitors and forwards 
inbound telephony and web callback requests to Telephony Manager Server. The 
Inbound Telephony Server is required when running OTM in active mode, routing 
inbound telephony and/or web callback requests. If OTM will be run in passive 
mode or if there is only outbound telephony, you do not need the Inbound 
Telephony Server process. This service may or may not run on the same machine as 
the OTM service, depending on the size of the interaction center.

Interaction Blending Server is a server process for integrating with Oracle 
Interaction Blending.
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Routing Server is a server process for the routing component of the Oracle 
interaction center. The Routing Server is only used with inbound telephony and/or 
inbound eMail with eMail Center and then only if you are running OTM in the 
active routing mode. If OTM will be run in passive mode or if there is only 
outbound telephony, you do not need the Routing service. This server may or may 
not run on the same machine as the Telephony Manager Server, depending on the 
size of the interaction center. In release 11.5.1, you can have up to three Routing 
Servers and each of them can be distributed on separate server machines as dictated 
by the size of the interaction center and the inbound call and mail volumes being 
handled.

Server Monitor is a server process for monitoring and coordinating other Oracle 
interaction center servers. The Server Monitor monitors and launches any of the 
other telephony and requester server processes. These include Telephony Manager 
Server, Inbound Telephony Server, Routing Server, Telephony Media Controller, and 
iCenter Server. The Server Monitor is optional, but it is recommended that you use 
it for fault tolerance purposes. You must choose on which server machine to install 
and run the server and there is only one per server group. The remote service 
startup capability uses the Server Launcher that is automatically installed on any 
machine with one of the telephony or requester services. There is one and only 
Server Launcher per machine regardless of the number of telephony/requester 
servers running on the machine.

Telephony Manager Server is a server process for the queuing and media control 
component of the Oracle interaction center. Generally, there is one Telephony 
Manager server for a single center. However, if there are multiple businesses with 
data segregation in a single center, you may have a Telephony Manager server for 
each business. The Telephony Manager server handles the queuing and distribution 
of media items.

Telephony Media Controller is a server process for the distributed component of 
the Oracle interaction center. You will only need to register the Telephony Media 
Controller if you are running OTM in distributed mode. If OTM is being run in 
standalone mode, you do not need to register this server process.

Universal Work Queue Server is a server process for integrating desktop 
applications with media providers.

Overview of a Typical Business Processes
A media-processing example is an eMail message that needs to be routed to an 
agent. An eMail event representing the mail message will be received from eMail 
Center for processing by the Oracle Telephony Manager request layer. OTM 
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generates an eMail media item which is then passed to the distribution layer where 
a routing request and decision can be made. 

Once the routing decision is made the media item is queued up, the Universal Work 
Queue is notified (as is Interaction Blending if it is running), and it will appear as a 
work item to an available and qualified agent or group of agents. When an agent 
selects the work item, the media item is de-queued. 

A telephony media item works the same way except that it is received from the 
ACD and when an agent selects and receives the work item, the call is sent to the 
agent’s phone set.
Implementing Oracle Telephony Manager 7
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Typical Release Dependencies
This topic include the following information:

■ Related Products and Components

■ Implementation Starting Point

■ Considerations and Constraints of Interactions with Other Types of Products

Related Products and Components
OTM integrates with Universal Work Queue, Interaction Blending (if implemented), 
Routing (if Advanced Inbound is implemented), Call Center Connectors, eMail 
Center, and any web application with a "call me" form enabled to generate web 
callbacks. OTM receives information from IVR Integrator through the Call Center 
Connectors server. OTM and the SoftPhone are integrated through UWQ. OTM also 
integrates with Workflow via the Routing Server.

Call Center Connectors are required and must be installed and configured for 
telephony control functionality. eMail Center is required and must be installed and 
configured for eMail control functionality. Universal Work Queue is required and 
must be installed and configured for integration to the applications running in the 
agent work area. The CRM Foundation (Resource Manager) must be installed and 
at least one test agent configured. 

Implementation Starting Point
This guide assumes that the interaction center is using a Oracle certified or 
supported switch, that the switch interfaces to an Oracle certified or supported CTI 
middleware, and that Oracle Call Center Connectors has been installed and 
configured.

This guide also assume that Oracle Applications 11i, the Call Center Java middle 
tier, and Oracle Telephony Manager have been installed.

Considerations and Constraints of Interactions with Other Types of Products
Oracle Telephony Manager has several implementation dependencies. This 
includes:

■ Customer’s PBX/ACD switch must be certified and/or supported through the 
interaction center’s PBX Integration Program.
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– For OTM, release 11.5.1, supported PBX/ACDs include Lucent Definity G3 
and Nortel Meridian.

– For OTM, release 11.5.2, supported PBX/ACDs include Lucent Definity G3, 
Nortel Meridian, Siemens Hicom (US version), and Alcatel 4400.

– Additional switches are supported quarterly and/or at point/patch 
releases.

– All PBX/ACDs are not compatible and may not be supported.

– The PBX/ACD matrix includes references to specific PBX models and 
software releases as well as information on PBX platforms supported via 
specific third-party CTI enabler software.

■ The customer’s PBX must be interfaced to an Oracle certified/supported 
third-party CTI Middleware. CTI Middleware is purchased by the customer 
directly from the supported third-party vendor and must be 
installed/implemented in accordance with the third-party CTI vendor 
specifications.

– For Oracle Telephony Manager, release 11.5.1, supported CTI Middleware 
include Dialogic’s CT Connect.

– For Oracle Telephony Manager, release 11.5.2, supported CTI Middleware 
include Dialogic’s CT-Connect and Cisco ICM CTI Server (formerly GeoTel).

– For Oracle Telephony Manager release 11.5.3, support CTI Middleware 
includes Dialogic’s CT-Connect, Cisco ICM CTI Server (formerly GeoTel), 
Nortel Symposium Call Center Server, and Siemens Hicom (international 
version).

– Additional PBX/middleware combinations are supported quarterly and/or 
at point/patch releases.

– For information about approved third-party CTI middleware see the Oracle 
Call Center Switch (ACD) Support at the locations referenced above.

■ OTM is also dependent on the proper installation of Oracle Call Center 
Connectors, a CTI server product included in the Advanced Inbound product 
module group. Call Center Connectors integrates the customer’s approved 
third-party CTI middleware to the Oracle Telephony Manager server. For 
complete details on installing the Oracle Call Center Connectors server see the 
documentation, Installing Oracle Call Center Connectors

Since the proper implementation of Oracle Telephony Manager is dependent on the 
proper versions and installation of third-party customer-provided equipment for 
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requisite CTI functionality the following considerations should be considered prior 
to beginning the implementation:

■ Does the Customer have a PBX/ACD switch that has been certified by Oracle?

■ Is the PBX/ACD the model, software release and does it have the proper 
PBX-based CTI interfaces or links?

■ Has the customer purchases and installed/implemented an approved 
third-party CTI middleware?

■ Has the PBX and CTI middleware been fully tested and operation on the 
customer’s ethernet LAN?

■ Have the PBX Application Notes been referenced and the list of supported CTI 
functions tested.
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Related Documentation and Resources
There are several locations within the Oracle intranet where you can find 
information on Oracle Telephony Manager and how to implement Oracle 
Telephony Manager. Following is a listing of many of these resources:

Implementing CRM Applications  Describes manual post-installation steps for 
selected Customer Relationship Management (CRM) modules.

Oracle Call Center Applications Setup Describes the installation of the Oracle 
Telephony Manager server processes. 

Oracle Telephony Manager Technical Reference Manual Provides information 
about the Oracle Telephony Manager schema.

Oracle Call Center Technology Technical Reference Manual Provides information 
about the Oracle Call Center (not a module) schema.

Installing Oracle Call Center Connectors Provides information about installing 
and configuring Oracle Call Center Connectors.
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Upgrading from Oracle Telephony Manager 3i
Use this procedure to upgrade Oracle Telephony Manager 3i to Oracle Telephony 
Manager 11i.

Prerequisites
Upgrading from an earlier version of Oracle Telephony Manager. The earlier 
versions are CRM 3i, CRM 3.1.1 and CRM 3.1.2 and any patches to these releases.

Steps
1. Install Oracle Applications 11i, release 11.5.1.

2. Do the following in any order:

■ Install CRM Family Pack 1.

■ Install the Upgrade patch 1336084. 

Note: Patch 1336084, which can be applied either before or after 
installing CRM Family Pack 1, needs to be applied only once. 
However, it must be applied before installing Oracle Applications 
11i, release 11.5.2.
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Setting Up Oracle Telephony Manager
Follow the steps in the following chart to set up OTM. The chart shows you where 
to read in detail about the setup step. The Window Name(s) column shows you in 
which window(s) to perform the step, and if the window is available only if you use 
a specific responsibility or product. The Required column shows you if the step is 
required, optional, required with defaults, or conditionally required.

Step 
Number Required? OTM Setup Step Description Window Name(s) AIW Reference

❏ Step 1 Required Define the Oracle interaction center server 
group.

See: Defining an Oracle Interaction Center 
Server Group

Server Locator 
window, Server 
Group tab

NA

❏ Step 2 Required Define and configure the Oracle interaction 
center server processes.

See: Configuring Oracle Interaction Center 
Server Processes

Server Locator 
window, Server tab

NA

❏ Step 3 Required Define and configure the CTI middleware.

See: Configuring the CTI Middleware 

Call Center 
Administration 
window, 
Middleware tab

NA

❏ Step 4 Optional Define the interaction center telesets.

See: Defining Interaction Center Telesets

Call Center 
Administration 
window, Teleset 
tab

NA

❏ Step 5 Optional Map the inbound IVR data to fields in 
Oracle Applications.

See: Mapping Inbound Data to Oracle 
Applications Fields

Call Center 
Administration 
window, IVR 
Mapping tab

NA

❏ Step 6 Optional Set up routing for inbound calls or email.

See: Setting Up Routing for Inbound Calls 
and Email

Routing 
Administration 
window or 
Workflow Builder

NA
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Defining an Oracle Interaction Center Server Group
An Oracle interaction center is represented by a logical grouping of interaction 
center processes called a server group. If there are multiple interaction centers or if 
separate lines of business are operating in the same interaction center, then there 
can be multiple server groups. Once the server group is defined, you can configure 
the individual interaction center processes in the group. (See Configuring Oracle 
Interaction Center Server Processes.)

Use this procedure to define a server group.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.

2. From the File menu, choose New.

3. In the Server Group tab, enter a unique name for the server group, the location 
of the server group, and a description of the server group.

Server Location Window: Server Group Tab: Server Group Registration Area

4. From the File menu, choose Save.
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Configuring Oracle Interaction Center Server Processes
Oracle interaction center processes, such as routing, are governed by individual 
server applications. A logical grouping of server processes is called a server group. 
(See Defining an Oracle Interaction Center Server Group.) 

The number of server applications in a server group will depend on the specific 
processes used in a particular interaction center. The following types of server 
processes may be included in a server group:

■ Advanced Outbound Proxy Server

■ Fulfillment Server

■ iCenter Server

■ Inbound Telephony Server

■ Interaction Blending Server

■ Routing Server

■ Server Monitor

■ Telephony Manager Server

■ Telephony Media Controller

■ Universal Work Queue Server

For a detailed description of each server process, see Application Architecture.

The server applications may run on one or more server machines. Each server 
process is configured individually. The configuration information is recorded in the 
Call Center schema. 

Use this procedure to configure an Oracle interaction center server process.

Prerequisites
❏ Define the Oracle interaction center server group. For more information, see 

Defining an Oracle Interaction Center Server Group.

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.
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b. Click Server Admin.

The Server Locator window appears.

2. In the Server Group tab, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Server tab.

4. If necessary, choose File > New.

5. In the Server Registration area, identify the server process.

Server Locator Window: Server Tab: Server Registration Area

a. Enter a unique name for the server process.

b. Enter the location of the server process.

c. From the Type Name list, select the server process type.

For a detailed description of each server process, see Application 
Architecture.
16 Oracle Telephony Manager Implementation Guide



Setting Up Oracle Telephony Manager
d. From the Member Group Name list, select the server group for this server 
process.

e. From the Using Group Name list, select any other server group that can use 
this server process.

6. In the Server Parameter area, configure the parameters for the selected server 
process type.

Each row in the table corresponds to an Oracle interaction center server 
parameter.

Server Locator Window: Server Tab: Server Parameter Area

a. From the Parameter Name list, select a parameter.

The parameters listed in the Parameter Name list depend on the type of 
server process selected from the Server Type list. For information about 
server type parameters, see Guidelines below.

b. Enter a value for the parameter.

7. From the File menu, choose Save.

8. To configure another interaction center server process, repeat steps 5 through 7.

Note: There are no parameters that must be defined for Advanced 
Outbound Proxy Server, Fulfillment Server, iCenter Server, Routing 
Server, and Server Monitor.

Note: Be sure to provide a value for all required parameters for 
the selected server process.
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Guidelines
Use the following guidelines to determine:

■ Inbound Telephony Server Parameters

■ Telephony Manager Server Parameters

■ Telephony Media Controller Parameters

Inbound Telephony Server Parameters Refer to the following table for a 
description of Inbound Telephony Server parameters.

Telephony Manager Server Parameters Refer to the following table for a 
description of Telephony Manager Server parameters.

Name Required? Description Sample Value

OTM_SERVER_NAME Required Server name of the Telephony Manager Server to 
which this server is associated.

SampleOTMServer

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server.

SampleMWConfig

WEB_CALL_PORT Required if 
using web 
callback

Port used to listen for web call-back requests. If 
left blank, the default port 888 is used. This 
number must match the OTM Server Port field in 
the iSupport Admin UI -> Support tab -> Call Me 
sub-tab.

888

Name Required? Description Example

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server. 

MWConfig

DEFAULT_TIMEOUT Optional Default timeout for re-route in minutes. For 
example, when this parameter is set to 5, a media 
item will be re-routed if it has been waiting in 
queue for more than 5 minutes.

5

IB_SERVER_NAME Optional Server name of the Interaction Blending Server IBServer

MQA_MODE Optional TRUE/FALSE parameter. TRUE if multiple queue 
mode is on. Applicable to Nortel switch only.

TRUE

PASSIVE_MODE Optional TRUE/FALSE parameter. TRUE if passive mode is 
on.

FALSE

ROUTE_SERVER_1 Required 
for active 
mode only

Server name of Routing Server RouteServer1
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Telephony Media Controller Parameters Refer to the following table for a 
description of Telephony Media Controller Server parameters.

ROUTE_SERVER_2 Optional Alternate Routing Server for load balancing RouteServer2

ROUTE_SERVER_3 Optional Alternate Routing Server for load balancing RouteServer3

STANDALONE Optional TRUE/FALSE parameter. TRUE if Telephony 
Manager is running in STANDALONE mode. 
FALSE if running in DISTRIBUTED mode.

TRUE

Telephony Media Controller Parameters

Field Name Required Description Example

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server. 

MWConfig

OTM_SERVER_NAME Required Server name of the Telephony Manager Server. SampleOTM

MQA_MODE Optional TRUE/FALSE parameter. TRUE if multiple queue 
mode is on. Applicable to Nortel switch only. 

TRUE

PASSIVE_MODE Optional TRUE/FALSE parameter. TRUE if passive mode is 
on.

FALSE

Name Required? Description Example
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Configuring the CTI Middleware
CTI (computer telephony integration) middleware enables Oracle Telephony 
Manager and the Inbound Telephony Server to control telephony devices (for 
example, agent phones and telesets) and shared telephony resources (for example, 
phone switches and PBX/ACD).

Use this procedure to configure the CTI enabler for the interaction center.

Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Middleware tab.

4. In the Middleware Configuration area, specify your middleware.

Call Center Administration Window: Middleware Tab: Middleware Configuration Area

a. Enter a unique name for the middleware configuration.
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b. From the Middleware Type list, select the middleware type.

For information about valid middleware types, see Middleware Types.

c. Enter the IP address of the machine hosting Call Center Connectors, for 
example, Oracle Call Center Connectors or Prospect CTI Server.

d. Enter the port number of the middleware server, for example, Oracle Call 
Center Connectors or Prospect CTI Server.

5. In the Middleware Parameter area, configure the parameters for the selected 
middleware type.

Each row in the table corresponds to an Oracle interaction center server 
parameter.

Call Center Administration Window: Middleware Tab: Middleware Parameters Area

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of middleware 
selected from the Middleware Type list. For information about server type 
parameters, see Guidelines below.

b. Enter a value for the parameter.

Note: Check the port number against the configuration of the 
middleware server. For Oracle Call Center Connectors, default port 
number is 3201. For Prospect CTI Server, the default port number is 
9001.
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6. From the File menu, choose Save.

Guidelines
Use the following guidelines to determine:

■ Middleware Types

■ Middleware Parameters for Connectors for CT-Connect or Connectors for 
CT-Connect (CompuCALL Variant)

■ Middleware Parameters for Connectors for Cisco ICM (GeoTe)l

■ Middleware Parameters for Prospect Aspect

Middleware Types Refer to the following table for a description of middleware 
types.

Note: Be sure to provide a value for all required parameters for 
the selected middleware type.

Middleware Type Middleware Server CTI Enabler Server (Middleware) Switch (PBX/ACD)

Connectors for CT-Connect Oracle Call Center Connectors Dialogic CT-Connect ■ Alcatel 4400

■ Lucent Definity G3

■ Nortel Meridian

■ Nortel Symposium 
Call Center Server

■ Siemens HICOM 
(US and 
international)

Connectors for CT-Connect 
(CompuCALL Variant)

Oracle Call Center Connectors Dialogic CT-Connect for CompuCall ■ Nortel DMS100

■ Nortel SL100

Connectors for GeoTel Oracle Call Center Connectors Cisco ICM CTI Server (formerly 
GeoTel)

■ Aspect

■ Lucent Definity G3

■ Nortel Meridian

Prospect Aspect Prospect CTI Server N/A ■ Aspect
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Middleware Parameters for Connectors for CT-Connect or Connectors for 
CT-Connect (CompuCALL Variant) Refer to the following table for a description of 
middleware parameters for Connectors for CT-Connect or Connectors for 
CT-Connect (CompuCALL Variant).

Field Name Required Description Sample Value

CTI Enabler IP Address Required IP address of the CT-Connect server. 123.45.67.890

PBX Name Required Link logical identifier defined in CT-Connect 
configuration to represent the CTI link between 
CT-Connect and the switch.

ctc_nortel
ctc_lucent

PBX Type Required PBX type. Enter:

■ A - Lucent Definity

■ M - Nortel Meridian or Symposium Call Center 
Server

■ S - Siemens HICOM

■ C - Alcatel 4400

■ X - Nortel DMS100/SL100.

A

Middleware Server Info 1 Required Enter the value ncacn_ip_tcp as the identifier for 
the network protocol used between Oracle Call 
Center Connectors and CT-Connect.

Enter ncacn_ip_tcp 
for TCP/IP (actual 
value)

Route Points Set 1

Route Points Set 2

Route Points Set 3

Route Points Set 4

Route Points Set 5

Required if 
using active 
mode

Devices within the PBX/ACD where inbound calls 
are initially received and route requests are issued.

■ Lucent Definity

Enter one or more vector directory numbers 
(VDN), separated by commas. The format is:

vdn[,vdn...]

■ Nortel Meridian:

Enter one or more CDN-immediate treatment 
pair(s), separated by commas. (CDN stands for 
Control Directory Number; the immediate 
treatment of an inbound call arriving at a CDN 
can be ringback or music). The format is:

cdn:treatment[,cdn:treatment...]

The format for treatment is:

##{R|M#musicRouteNumber}

■ Siemens HiCom and Alcatel 4400:

Enter one or more pilot number(s), separated by 
commas. The format is:

pilotNumber[,pilotNumber...]

There is a 256 maximum character limit. You can 
configure as many route points in each Route Points 
Set X field as the 256-character limit permits.

7400

7400,7500

7520:##R

7530:##M#02

7400
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Middleware Parameters for Connectors for Cisco ICM (GeoTe)l Refer to the 
following table for a description of middleware parameters for Connectors for Cisco 
ICM (GeoTel).

Outgoing Prefix Required if 
using web 
callback

Numeric prefix dialed to place outside calls. Check 
against the configuration of the PBX.

9

International Dialing Prefix Required if 
using web 
callback

Numeric prefix dialed for placing international calls. 011 (from within the 
USA)

Site Country Code Required if 
using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code Required if 
using web 
callback

The area code for the site where the PBX is located. 650

IVR Server Name Required if 
using IVR 
Integrator

The PCDCE name of the IVR Integrator server. Check 
against PCDCE configuration.

SampleIVR

Field Name Required Description Sample Value

CTI Enabler IP Address Required IP address of the Cisco ICM CTI server (Server A). 123.45.67.890

Middleware Server Info 1 Required Port number of the Cisco ICM CTI server (Port A). 42027

Middleware Server Info 2 Required IP address of the Cisco ICM CTI server (Server B). 123.45.67.890

Middleware Server Info 3 Required Port number of the Cisco ICM CTI server (Port B). 42027

PBX Name Required Peripheral ID defined in Cisco ICM CTI server for 
the PBX of interest.

5008

PBX Type Required PBX type.

■ A - Lucent Definity

■ M - Nortel Meridian

■ P - Aspect

A

Outgoing Prefix Required if 
using web 
callback

Numeric prefix dialed to place an outside call. 
Check against the configuration of the PBX.

9

Field Name Required Description Sample Value
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International Dialing 
Prefix

Required if 
using web 
callback

Numeric prefix dialed for placing international calls. 011

Site Country Code Required if 
using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code Required if 
using web 
callback

The area code for the site where the PBX is located. 650

Field Name Required Description Sample Value
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Middleware Parameters for Prospect Aspect Refer to the following table for a 
description of middleware parameters for Prospect Aspect.

Field Name Required Description Sample Value

Inbound CCT Required Number of the CCT (Call Control Table) that 
handles inbound customer calls.

1

Internal App ID Required Application ID that is associated with internal calls. 2

Internal CCT Required Number that sets the CCT (Call Control Table) for 
agent-to-agent calls.

2

Outbound App ID Required Application ID that is associated with outbound 
calls.

3

Outbound CCT Required Number that sets the CCT (Call Control Table) for 
outbound calls.

3

Outgoing Prefix Required if 
using web 
callback

Numeric prefix dialed to place an outside call. 
Check against the configuration of the PBX.

9

Predictive App ID Optional Application ID that is associated with predictive 
calls.

4

Route CCT Required Number of the CCT (Call Control Table) specifying 
how routed calls are distributed.

50
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Defining Interaction Center Telesets
Use this procedure to configure Oracle Telephony Manager for use with a teleset. 
You can integrate Oracle Telephony Manager with the following teleset types:

■ Lucent

■ Nortel

■ Siemens

■ Alcatel

■ Aspect

Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Teleset tab.

4. In the Teleset Configuration area, create a teleset definition for each teleset in 
the interaction center.

Each row in the table corresponds to one teleset in the interaction center.
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Call Center Administration Window: Teleset Tab: Teleset Configuration Area

a. In the Teleset Name field, enter a unique name for the teleset (for example, 
Nortel7701).

b. In the Hardware Number field, enter a unique identifier for this teleset (for 
example, 7701).

Oracle recommends that you follow the convention of using the primary 
extension number of the teleset.

c. From the Teleset Type list, select the vendor name for the teleset (for 
example, Nortel).

5. In the Line Configuration for Teleset area, configure the line configuration for 
each teleset definition.

You can configure a maximum of three lines per teleset, one line each for Line 
Index 1, 2, or 3. The line configuration will depend on the type of teleset. For 
information about teleset line configurations, see Guidelines below

Call Center Administration Window: Teleset Tab: Line Configuration for Teleset Area

a. In the Teleset Configuration area, select the row for the teleset that you 
want to configure.

b. In the Line Configuration for Teleset area, select a line index from the Line 
Index list.

c. Enter the extension for the line index.
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6. From the File menu, choose Save.

Guidelines
Refer to the following table to determine the teleset line configuration for a 
particular teleset type.

Teleset Line Configuration

Lucent You can configure two or three lines for each teleset -- as many 
lines as there are call appearances on the actual teleset. Enter 
the same teleset extension number (station number in the 
Extension field for all line indexes.

Nortel You must configure exactly two lines: 

■ For Line Index 1, enter the DN (Directory Number) in the 
Extension field. This corresponds to the Single Call 
Ringing key on the actual teleset.

■ For Line Index 2, enter the ACD DN in the Extension field. 
This corresponds to the Automatic Call Distribution key 
on the actual teleset.

Aspect For Prospect CTI Server, you must configure exactly one line 
for each teleset. Enter the teleset phone number in the 
Extension field for Line Index 1.

For CIsco ICM CTI Server (formerly Geotel), configure three 
lines for each teleset. Enter the same teleset extension number 
for all line indexes.

Siemens For Prospect CTI Server, configure exactly one line for each 
teleset. Enter the primary extension number in the Extension 
field for Line Index 1. 

Alcatel You must configure exactly one line for each teleset. Enter the 
teleset phone number in the Extension field for Line Index 1.
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Mapping Inbound Data to Oracle Applications Fields
For interaction centers equipped with an IVR (Interactive Voice Response) unit, data 
collected by the IVR can be passed via IVR Integrator to Oracle Applications in the 
form of name-value pairs. Oracle Applications can make use of this data to generate 
a more complete and meaningful screen pop on the agent desktop.

Use this procedure to map the name associated with a value in an IVR data packet 
to a field in Oracle Applications.

Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the IVR Mapping tab.

Each row in the table corresponds to the mapping of one data item in the IVR 
data packet to one field in Oracle Applications.
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Call Center Administration Window: IVR Mapping Tab

4. For each piece of IVR data that you want to map to a field in Oracle 
Applications, do the following:

a. In the ACD IVR cell, enter or select the name of the IVR field.

b. In the Oracle Field cell, enter or select an Oracle Applications field name.

5. From the File menu, choose Save.

Setting Up Telephony Parameters
For each call center agent resource, you need to set up one or more telephony 
parameters. This can be done in the CRM Resource Manager responsibility, 
Resource form, Interaction Center tab, Telephony Parameters section. Which 
telephony parameters are required and what values to specify depend on the types 
of switch and CTI middleware in use in the call center.

The following tables provide specific instructions for each supported 
switch-middleware combination.

Telephony Parameters for Lucent Definity with CT-Connect

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, if any, as defined in the PBX 
admin.

34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181
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Telephony Parameters for Lucent Definity with Cisco ICM CTI Server (formerly GeoTel)

Telephony Parameters for Nortel Meridian or Sympostium Call Center Server with 
CT-Connect

Telephony Parameters for Nortel Meridian with Cisco ICM CTI Server (formerly GeoTel)

Telephony Parameters for Aspect with Cisco ICM CTI Server

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 1 (Require only when the switch is in login ID mode) 
Agent’s ACD login ID, as defined in the PBX admin

1001

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46
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Telephony Parameters for Siemens Hicom with CT-Connect

Telephony Parameters for Alcatel 4400 with CT-Connect

Setting Up Routing for Inbound Calls and Email
The Routing Server is the server process for the routing component of the Oracle 
interaction center. The Routing Server is used in the following scenarios:

■ With Inbound Telephony only if you are running Oracle Telephony Manager in 
the active routing mode

■ With Inbound eMail in Oracle eMail Center

The Oracle routing module has two basic types of routing which are used for 
different situations based on the requirements of the configuration: rules based 
routing and workflow based routing.

Rules Based Routing
Rules based routing is the simplest and fastest routing to use, but it is also the least 
flexible.   This would probably handle the lions share of the routing logic in a 
normal company.

The principal is that each media interaction has a lot of information attached to it, 
such as the media type, time of day (TOD), ANI, DNIS and possibly some 
information coming from an IVR or Webpage.   All of this information is available 
to be made into rules within rules based routing.

To use this interaction data you create a rule. You select a key A, such as MediaType, 
TOD or DNIS from the ‘key’ pulldown list. Then you enter the value which you 
want to compare the key B against, such as 5:00pm.   You then pick the group of 
agents G1 you want to send the media item to if the rule evaluates to true.   

Field Name Description Sample Value

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 40027

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 0000

ACD Data 2 Agent phone number, as defined in the PBX admin. 3551

ACD Queue Agent’s processing group number, as defined in the PBX 
admin.

3700
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You have now created a rule that logically says:   If the ‘key A’ equals the ‘value X’, 
then send it to the group of agents G1. 

You can then add a second rule, or add another condition to the first rule.

If the ‘key A’ equals the ‘value X’, send to group G1

If the ‘key B’ equals the ‘value X’ AND ‘key D’ equals ‘value Y’ send to group G2

An example: A company has a special phone number for it’s biggest accounts, that 
phone number is "1-800-444-4357". They wish to make a rule that anytime anyone 
has called 1-800-444-4357 they go the special group of agents (say group 5).   This is 
the simple type of routing request that can easily be handled by rules based routing.   
DNIS is the telephony name for the number a customer dialed to reach you, so you 
use the pulldown to select the key DNIS. Use the modifier pulldown and select ‘=’. 
Enter the value "1-800-444-4357" into the field.   Enter group 5 for the route 
destination.

Advantages:

■ Routing rules return quickly

■ Very easy to configure and intuitive

■ No technical skill necessary to configure rules

Disadvantages:

■ Cannot setup complex series of ANDs and Ors

■ Not as easily customized as workflow routing

See Setting Up Rules-Based Routing for Inbound Calls and Email.

Workflow Based Routing
Workflow based routing is the most flexible, and relies upon the power of the 
Oracle workflow engine.   This is the full function routing, which relies upon the 
database and uses pre-defined nodes which access the business data from the CRM 
business apps.    

The input to workflow based routing is the same as it was for rules based routing, 
all information about the interaction is available in key-value pairs.   Media data is 
available such as "ANI : 655-3458" or "MediaType : Email" and any IVR data is 
available as well "BugID : 6091549".   These values are available to nodes, which 
then perform logic in a workflow which decides who are the possible recipients of a 
call. These are the routing recipients.
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Example 1: If you want to route a call to the agent who to this Sales account, you 
could perform that type of functionality with the workflow.   A workflow node is 
pre-built and shipped with the product which takes the account number as input 
and returns the list of agents associated with that account within the CRM sales 
application. Since that node already exists, it would be dragged into the workflow 
and dropped in to create the logic desired.   Dozens of nodes are shipped pre-built 
and pre-integrated across CRM products.

Example 2: You can also create a custom node which performs most any action you 
can write into a PL/SQL function.   Lets say they wanted to retrieve all agents who 
had been with the company more than 1 year.   This is not something we ship out of 
the box, but a consultant could write a PL/SQL procedure which took today’s date, 
went into the HR views and returned a list of all agents who had been here over 1 
year.   This could then be wrapped into a workflow node, saved and dropped into 
any future workflows that customer might have.   

Advantages:

■ Pre-built nodes with pre-built integration to CRM

■ Drag and drop functionality

■ Uses a workflow engine, so there is a visible representation of the logic

■ Can be used to perform any type of complex logic

■ Able to be customized, so a customer can write their own nodes

■ Little technical ability necessary to configure nodes.

Disadvantages:

■ Request must travel to the database and back

■ Normally has an overhead of at least 50ms

■ Technical skill needed to write custom nodes

See Setting Up Workflow-Based Routing for Inbound Calls and Email.
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Setting Up Rules-Based Routing for Inbound Calls and Email
Follow the steps in the following chart to set up OTM rules-based routing. The chart 
shows you where to read in detail about the setup step. The Window Names(s) 
column shows you in which window(s) you perform the step, and if the window is 
available only if you use a specific responsibility or product. The Required column 
shows you if the step is required, optional, required with defaults, or conditionally 
required.

Step 
Number Required? OTM Setup Step Description Window Name(s) AIW Reference

❏ Step 1 Required 
for 
rules-based 
routing

Define a group.

See: Defining Groups

Define Groups 
window; Dynamic 
Groups window

NA

❏ Step 2 Required 
for 
rules-based 
routing

Define a route.

See: Defining Routes

Routing 
Administration 
window

NA

❏ Step 3 Required 
for 
rules-based 
routing

Define the route priorities.

See: Defining Route Priorities

Routing Priority 
window

NA

❏ Step 4 Required 
for 
rules-based 
routing

Define the classifications.

See: Defining Classifications

Classification 
Administration 
window

NA
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Defining Groups
There are two types or groups for rules-based routing: static and dynamic. A static 
group requires that you manually edit information about individual group 
members. In a dynamic group, the database automatically updates information 
about individual group members.

For procedures, see:

■ Defining a Static Group

■ Defining a Dynamic Group

Defining a Static Group
Use this procedure to configure a static group for routing.

Prerequisites
None

Steps
1. Navigate to the Define Groups window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

b. Click Static Groups.

The Define Groups window appears.
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Routing Administration Window: Static Groups Button: Define Groups Window

Guidelines
When configuring static groups, use the following guidelines:

■ The Group Number and Group Name must be unique. 

■ If you want to prevent an agent from being shared with other groups, check the 
Exclusive Flag box to indicate that the agent belongs exclusively to this group.

■ You cannot create member records without choosing a Parent Group. 

■ When defining a static/dynamic group for Routing, the usage of the group 
should be set to ’Call Center’ so that the group will be available in the Routing 
Admin LOV for static/dynamic groups. 

Defining a Dynamic Group
Use this procedure to configure a dynamic group for routing.

Prerequisites
None
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Steps
1. Navigate to the Dynamic Groups window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

b. Click Dynamic Groups.

The Dynamic Groups window appears.

Routing Administration Window: Dynamic Groups Button: Dynamic Groups Window

2. If necessary, choose File > New.

3. Enter a unique name for the group.

4. From the Usage list, select the usage of the list.

5. Optionally, enter a description of the list.

6. Optionally, in the Active Dates area, select or enter the start and end date for the 
use of the group in routing.
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7. Enter the SQL statement that selects the members of the group.

8. Click Check Syntax.

If the SQL statement is invalid, then an error message appears. If the SQL 
statement is valid, then no message appears.

9. From the File menu, choose Save.

Guidelines
■ When defining a static/dynamic group for Routing, the usage of the group 

should be set to ’Call Center’ so that the group will be available in the Routing 
Admin LOV for static/dynamic groups. 

Defining Routes
A route definition identifies the potential groups or members to which a call may be 
routed and the call parameters (such as ANI) to be used in determining the 
destination of a call.

There are two types of routes for rules-based routing: static and dynamic. Static 
routing is based on data stored in cache. Dynamic routing is based on PL/SQL 
queries. Static routing is faster, but dynamic routing is more flexible. 

For procedures, see:

■ Defining a Static Route

■ Defining a Dynamic Route

Defining a Static Route
Use this procedure to define a static route.

Prerequisites
❏ Define a group. For more information, see Defining Groups.

Note: If the route server cannot determine agents from the 
defined destinations, then the server routes the call to the default 
destination defined for the route.
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Steps
1. Navigate to the Routing Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

2. If necessary, choose File > New.

3. In the Route Definition area, identify the route.

Routing Administration Window: Route Definition Area

a. Enter a unique name to describe the route.

b. From the Route Type list, select Static.

c. Optionally, enter the description of the static route.

d. If this route uses the Oracle Applications database, select Application 
Database.

e. If this route does not use the Oracle Applications database, select Non 
Application Database and enter the database driver and URL.

4. On the Route Destinations tab, select the groups to which calls may be routed.
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Routing Administration Window: Route Destinations Tab (Static)

5. On the Route Rules tab, define the parameters expected in an incoming call.

Routing Administration Window: Route Rules Tab

a. From the Key list, select a key (for example, ANI).

b. Enter the value for the selected key (for example, 888-555-1234).

6. From the File menu, choose Save.

Defining a Dynamic Route
Use this procedure to define a dynamic route.

Prerequisites
None
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Steps
1. Navigate to the Routing Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

2. If necessary, choose File > New.

3. In the Route Definition area, identify the route.

Routing Administration Window: Route Definition Area

a. Enter a unique name to describe the route.

b. From the Route Type list, select Dynamic.

c. From the Default Destination list, select the default destination to be use 
when the Routing Server cannot determine a destination based on the 
procedure parameters.

d. Enter the description of the dynamic route.

e. If this route uses the Oracle Applications database, select Application 
Database.

f. If this route does not use the Oracle Applications database, select Non 
Application Database and enter the database driver and URL.

4. On the Route Destinations tab, define the procedure that is to be used to derive 
the destination for call.
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Routing Administration Window: Route Destinations Tab (Dynamic)

a. In the Dynamic Destination area, enter the name of the procedure 
(Package.Procedure) that is to be used to derive the destination for call.

b. In the Procedure Parameters area, identify the parameters for the 
procedure.

Sequence is a generated number that indicates the sequence of the 
parameter.

5. On the Route Rules tab, define the rules for the route.

Routing Administration Window: Route Rules Tab

a. From the Key list, select a key (for example, ANI).
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b. Enter the value for the selected key (for example, 888-555-1234).

6. From the File menu, choose Save.

Defining Route Priorities
You can define and change the priority of route definitions. Changing the value of a 
route priority affects the values of other route priorities. If you increase the value of 
a priority, then the priorities of all the routes with a value equal to or greater than 
the original value decrease by one. If you decrease the value of a priority, then the 
value of all the routes with a value equal to or less than the original value increase 
by one. For example, if you decrease 6 to 3, then 3 increases to 4, 4 increases to 5, 
and so on. If you increase 3 to 6, then 4 decreases to 3, 3 decreases to 2, and so on.

Use this procedure to set the priority for a route.

Prerequisites
None

Steps
1. Navigate to the Routing Priority window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Priority Administration.

The Routing Priority window appears.

Routing Administration Window: Route Priority Button: Routing Priority Window
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2. From the Priority list, select a priority.

3. Click Change Priority.

4. From the File menu, choose Save.

Defining Classifications
Classifications specify how to identify and route particular types of calls that are 
associated with the selected Route ID. Classifications are of two types: literal and 
database procedure. A literal classification is a string. A database procedure 
classification is a stored procedure. 

Classification rules can determine the route that a call must take, or a classification 
rule can designate a call as a classification for reports or for screen pops. Every 
classification must have rules that define the conditions under which the 
classification occurs. When a call meets all these conditions, the classification is the 
result and the call is routed accordingly. 

In an example scenario, if a request to route ANI of 800 is a classification for Gold 
Card customer, then the resulting route destination could be the priority group.

A classification can have multiple rules associated with it. An individual route can 
have multiple destinations, which can be either static or dynamic. Every route has a 
sequence of a Key and a Value whose relationship is determined by one of the 
available Operations (=, !=, >, >=, <, <=).

If an incoming routing request results in a new classification, the new classification 
is added to the route request as one of the parameters. The server tries to find a new 
route based on this route request. 

For example, if the classification rules in the preceding table result in adding the 
new classification rule CLASSIFICATION=GOLD to the classification request, then 
a new route is determined based on the new rule.

For procedures, see:

■ Defining a Literal Classification

■ Defining a Database Procedure Classification

Note: If you configure a classification rule that results in a new 
rule, then you will need a route that is defined for that new rule.
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Defining a Literal Classification
Use this procedure to define a literal classification.

Prerequisites
None

Steps
1. Navigate to the Classification Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Classification Administration.

The Classification Administration window appears.

2. If necessary, choose File > New.

3. In the Classification Definition area, define the classification.

Classification Administration Window: Classification Definition Area

a. Enter a unique name to describe the classification.

b. From the Type list, select Literal.

c. Enter the maximum amount of time, in seconds, that the Routing Server 
should spend trying to determine the destination.

d. If this classification uses the Oracle Applications database, select 
Application Database.

e. If this classification does not use the Oracle Applications database, select 
Non Application Database and enter the database driver and URL.

4. On the Classification Rules tab, define the rules for routing based on the keys 
identified in the route definition.
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Classification Administration Window: Classification Rules Tab

a. From the Key list, select a key.

b. From the Operation list, select an operator.

c. Enter the value for the selected key.

5. From the File menu, choose Save.

Defining a Database Procedure Classification
Classifications specify how to identify and route particular types of calls that are 
associated with the selected Route ID. A database procedure classification is a 
stored procedure. The following conditions apply.

Prerequisites
None

Steps
1. Navigate to the Classification Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Classification Administration.

The Classification Administration window appears.

Note: A key used in a classification rule must be the same as that 
identified in the route rules definition.
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2. In the Classification Definition area, define the classification.

Classification Administration Window: Classification Definition Area

a. Enter the name of the database procedure.

b. From the Type list, select Database Procedure.

c. Enter the maximum amount of time, in seconds, that the Routing Server 
should spend trying to determine the destination.

d. If this classification uses the Oracle Applications database, select 
Application Database.

e. If this classification does not use the Oracle Applications database, select 
Non Application Database and enter the database driver and URL.

3. On the Classification Rules tab, define the rules for routing based on the keys 
identified in the route definition.

Note: The name of the classification is not verified against the 
stored procedures. Be sure to enter the correct procedure name.
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Classification Administration Window: Classification Rules Tab

a. From the Key list, select a key.

b. From the Operation list, select an operator.

c. Enter the value for the selected key.

4. On the Classification Parameters tab, identify the parameters for the database 
procedure.

Classification Administration Window: Classification Parameters Tab (Dynamic)

a. From the Parameter list, select a parameter.

Note: A key used in a classification rule must be the same as that 
identified in the route rules definition.
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b. From the Datatype list, select the data type of the parameter (for example, 
VARCHAR).

c. From the Direction list, select the direction of the parameter (for example, 
IN).

Sequence is a generated number that indicates the sequence of the 
parameter.

5. From the File menu, choose Save.
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Setting Up Workflow-Based Routing for Inbound Calls and Email
With Oracle Workflow Builder 2.5, you can use drag-and-drop routing functions to 
implement and administer the Call Routing screen. 

To create and configure a route path using the Oracle Workflow Builder-based Call 
Routing screen, you need to have a thorough understanding of Oracle Workflow 
Builder.

All Oracle Workflow Builder processes are associated with an item type. An item 
type can include one or more processes. When you save your work in Oracle 
Workflow Builder, you actually save everything associated with the item type that is 
currently selected. You can save an item type to a database or a flat file, and 
similarly load an item type into Oracle Workflow Builder from a database or a flat 
file. Opening an item type automatically retrieves all the attributes, messages, 
lookups, notifications, functions, and processes associated with that item type.

See:

■ Accessing the Call Route Item Type

■ Applying a Pre-Defined Route

■ Running a Pre-Defined Routing Process

■ Modifying a Process

■ Designating Start and End Activities

■ Adding a New Node to a Process

■ Creating a New Process Route

■ Administering Call Routing Filters

■ Administering Call Center Environmental Conditions

■ Setting Time and Date Rules

■ Deriving Rules for the Customer Initialization Phase

■ Deriving Rules for the Customer Product Initialization Phase

■ Deriving Rules for the Product Initialization Phase

■ Deriving Rules for Telesales Routing

■ Deriving Rules for Banking Routing
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Accessing the Call Route Item Type
To open the Oracle Workflow Builder Call Route item type, use the following 
procedure.

Prerequisites
None

Steps
1. Launch Oracle Workflow Builder.

2. Open the database connection. 

3. From the Show Item Types window, choose Call Route > Show.

Applying a Pre-Defined Route
Oracle Workflow Builder includes routing process examples that you can apply as 
your call center routing process or you can use as templates to build your own routing 
processes.

Use this procedure to access a pre-defined routing processes.

Prerequisite
None

Steps
1. From the navigator tree, click Call Route Item type.

2. Expand the Processes folder to see a list of available pre-defined processes. 
Oracle Telephony Manager includes pre-defined example routes.

3. Double-click on the process name to view.

Running a Pre-Defined Routing Process
To run a pre-defined routing process with Oracle Workflow Builder, use the 
following procedure.

Prerequisites
None
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Steps
1. From the Attributes folder, choose The Selected Process.

The Oracle Workflow Navigator Control Properties window appears.

2. In the Default Value field, enter the name of the process that you want to run.

3. Choose OK.

Modifying a Process
The Process window in Oracle Workflow Builder graphically represents the 
activities (icons) and transitions (arrows) for a particular process. Notification, 
function, and process activities make up the nodes of a process. 

If a process contains a process activity in its diagram, then that process activity is 
known as a subprocess. To display information on the subprocess in a separate 
Process window, double-click on the subprocess activity node in the parent Process 
window.

Each activity is a node, a logical step that contributes toward the completion of a 
process. Nodes contain stored procedures that operate on parameters. The 
GetAgents node routes information to a database table, invokes a stored procedure 
and returns the results. The database may return up to ten parameters, each 
parameter being an agent.

You can drag and drop activities from the navigator tree into the Process window. 
Define transitions between activities by drawing arrows from one activity to the 
next using the secondary mouse button.

Designating Start and End Activities
Each Oracle Workflow Builder process must have a Start activity that identifies the 
beginning point of the process. You may designate any node from which it is logical 
to begin the process as a Start activity. An End activity should return a result that 
represents the result of the completion of the process. 

Prerequisite
None

Steps
1. Right click the icon that you wish to change.

2. Choose Properties. 
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3. Using the Start/End pull-down list, change the step in the process.

4. Indicate if the current node is a start or end activity in your process by choosing 
START or END, respectively. The default is NORMAL, which means neither. 
You may have multiple START and END nodes in your process. 

A Start activity is marked (Start) and has a small green arrow in its activity icon. 
An End activity is marked (End) and has a red arrow in its activity icon.

5. For an END node, if the overall process activity has a result type associated 
with it, you must also select a value for the final process result. The list of 
values for the final process result derive from the lookup type defined as the 
process activity’s result type.

Adding a New Node to a Process
From the Oracle Workflow Builder Process window, create a new node by dragging 
and dropping a function or process activity from the navigator tree into the Process 
window. Use functions to fine-tune the route. The activity you drag must belong to 
the same data store as the process to which you drag it.

If you use the right mouse button menu New Activity in the Process window to 
create a new node, the property pages for the node appear. Select the name of the 
item type and activity in the Activities property page. If you create a node by 
dragging and dropping an activity from the navigator tree into the process window, 
then double-click on the node to display the property pages so you can further 
specify the details of the node.

If the node is a function activity and the function activity has activity attributes, you 
can assign values to those activity attributes by choosing the Attribute Values tab to 
display the Attribute Values property page.

If the node is a process activity, then a small subprocess overlay icon appears over 
the upper right corner of process activity icon. The subprocess overlay icon 
identifies the node as a subprocess within the process diagram.

Creating a New Process Route
Use this procedure to create a new process route with Oracle Workflow Builder.

Prerequisite
None
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Steps
1. Select the Processes folder and right mouse click to create a new process.

2. When the Oracle Workflow Navigator Control Properties dialog box appears, 
select the Activities tab and:

a. Enter a unique Internal Name.

b. Enter the Display Name. 

c. Enter a Description of your new route.

d. Leave the Result Type as None.

3. From Standard Functions, drag the Start activity to the new Process window.

4. From Call Route Functions, drag the Get Agents activity to the window.

5. From Call Routing Filters, CCT Environmental Conditions, Customer 
Initialization Phase, Customer Product Initialization, Product Initialization 
Phase, and Standard Item Types, drag and drop the activities you want to use in 
routing the calls to the appropriate agent.

Administering Call Routing Filters
Use Oracle Workflow Builder Call Routing Filters to route calls only to those agents 
who meet the filter criteria. Refer to the following table for a description of call 
routing filters.

Call Routing Filter Description

Competency - Language 
Filter

Ensures that only those agents who are competent in the 
language selected by the customer answer the call. Requires that 
a language selection be made at the IVRU.

Competency - 
Knowledge Filter

Ensures that only those agents who are competent in the area of 
expertise selected by the customer answer the call. Requires that 
an area of expertise selection be made at the IVRU.

Competency - Product 
Filter

Used to ensure that only those agents who are competent in the 
product selected by the customer answer the call. Requires that a 
product selection be made at the IVRU.

Customer Product Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular ‘Customer Product’ 
combination answer the call. Requires that the ‘Derive Customer 
Product ID’ sub-process be completed before this activity in the 
routing workflow process.
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Customer ID Filter This filter is used to ensure that only those agents who are 
assigned to handle this particular customer answer the call. 
Requires that the ‘Derive Customer ID’ sub-process be 
completed before this activity in the routing workflow process.

Problem Code Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular ‘Problem Code’ answer the 
call. Requires that a problem code selection be made at the 
IVRU.

Product ID Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular product answer the call. 
Requires that the ‘Derive Product ID’ sub-process be completed 
before this activity in the routing workflow process. 

Request Owner Filter This filter is used to ensure that the call is routed to the agent 
who owns the ‘Service Request’, when the customer is calling 
about the particular ‘Service Request’. Requires that a service 
request number selection be made at the IVRU.

System Type Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular ‘System Type’ answer the call. 
Requires that a serial number be input from the IVRU.

Telesales Agent Account 
Filter 

This filter is used to retrieve the agents for a customer based on 
the account ID. 

Telesales Agent 
Opportunity Filter 

This filter is used to retrieve the agents for a given sales 
opportunity. 

Telesales Agent Territory 
Filter

This filter is used to retrieve the agents for a customer based on 
their territory.

Agents from Dynamic 
Group Name

This filter is used to retrieve the agents returned based on the 
dynamic group_name

Agents from Dynamic 
Group Number

This filter is used to retrieve the agents based on the dynamic 
group number

Agents from static group 
name

This filter returns agents based on a static group name

Agents from static group 
number

This filter returns agents based on static group number.

Agents not in dynamic 
group name

This filter returns agents not in dynamic group name

Agents not in dynamic 
group number

This filter returns agents not in dynamic group number

Call Routing Filter Description
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Administering Call Center Environmental Conditions
Call Center Environmental Conditions refers to the routing rules based on the date 
and time of the call.

Setting Time and Date Rules
In Oracle Workflow Builder, for each of these attributes, the relevant value is 
specified after you drag the node onto the process diagram. 

Use the following procedure to set time and date rules.

Prerequisites
None

Steps
1. In the process diagram, double click on the node icon to open the node 

properties sheet.

The property page for the node appears.

2. Choose the Attribute Values tab.

The Attribute Values property page for the node appears.

3. Choose the applicable attribute or attributes and enter them in the Value field.

4. Choose Apply to save your changes or choose OK to save your changes and 
close the Property page.

Guidelines
Refer to the following table for a description of time and date rules.

Agents not in static 
group name

This filter returns agents not in static group name

Agents not in static 
group number

This filter returns agents not in static group number.

All logged in agents This filter returns a list of all logged in agents

Call Routing Filter Description
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Deriving Rules for the Customer Initialization Phase
The Oracle Workflow Builder Customer initialization phase derives Customer ID 
information from the caller’s responses to the IVR. The phase is represented by the 
Derive Customer ID sub-process, which you drag onto the process diagram.

You can drag the following rules for derivation of Customer ID onto the Derive 
Customer ID sub-process. You can also use these rules directly in the Routing 
process diagram.

Refer to the following table for a description of customer initialization phase rules.

Rule Description

Between Two Dates? If the current date falls between the start and end dates 
specified, this rule returns a Yes, otherwise it returns a No. 

During Business Hours? If the call is received during business hours, this rule returns a 
Yes, otherwise it returns a No. 

Get Day of the Month? This rule returns the current day of the month as a number. You 
can use this rule to handle special, but not contiguous, days of 
the month differently.

Get Day of the Week? This rule returns the current day of the week. You can use this 
rule to handle weekends or certain days of the week differently.

Is It After Specified Date? If the current date is after the specified date, this rule returns a 
Yes, otherwise it returns a No. 

Is It Before Specified 
Date?

If the current date is before the specified date, this rule returns a 
Yes, otherwise it returns a No. 

Is It After Specified 
Time?

If the current time of day is after the specified time of day, this 
rule returns a Yes, otherwise it returns a No. 

Is It Before Specified 
Time?

If the current time of day is before the specified time of day, this 
rule returns a Yes, otherwise it returns a No. 

Rule Description

Customer ID Exists? If the customer ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Customer ID’ sub-process, will allow for a quick exit 
from the sub-process without applying any derivation rules if 
the Customer ID is already known.
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Deriving Rules for the Customer Product Initialization Phase
The Oracle Workflow Builder Customer Product initialization phase derives the 
Customer Product ID information from caller’s responses to the IVRU. The phase is 
represented by the Derive Customer Product ID sub-process, which you drag onto 
the process diagram.

You can drag the following rules for derivation of Customer Product ID onto the 
Derive Customer Product ID sub-process. You can also use these rules directly in 
the Routing process diagram.

Refer to the following table for a description of customer product initialization 
phase rules.

Can Get Customer ID 
from Invoice Num?

If the customer ID can be derived from the Invoice Num, this 
rule derives the Customer ID and returns a Yes, otherwise it 
returns a No.

Can Get Customer ID 
from Order Num?

If the customer ID can be derived from the Order Num, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Can Get Customer ID 
from PO Num?

If the customer ID can be derived from the PO Num, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Can Get Customer ID 
from Request Num?

If the customer ID can be derived from the Request Num, this 
rule derives the Customer ID and returns a Yes, otherwise it 
returns a No.

Can Get Customer ID 
from RMA Num?

If the customer ID can be derived from the RMA Num, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Can Get Customer ID 
from Serial Num?

If the customer ID can be derived from the Serial Num, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Can Get Customer ID 
from System Name?

If the customer ID can be derived from the System Name, this 
rule derives the Customer ID and returns a Yes, otherwise it 
returns a No.

Rule Description
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Deriving Rules for the Product Initialization Phase
The Oracle Workflow Builder Product initialization phase derives the Product ID 
information from the caller’s responses to the IVR. The phase is represented by the 
Derive Product ID sub-process, which you drag onto the process diagram.

You can drag the following rules for derivation of Product ID onto the Derive 
Product ID sub-process. You can also use these rules directly in the Routing process 
diagram.

Refer to the following table for a description of product initialization phase rules.

Rule Description

Customer Product ID 
Exists?

If the customer product ID is already known, this rule returns a 
Yes, otherwise it returns a No. Using this as the first rule in the 
Derive Customer Product ID sub-process, will allow for a quick 
exit from the sub-process without applying any derivation rules 
if the Customer Product ID is already known.

Can Get Customer 
Product ID from 
Reference Num?

If the customer product ID can be derived from the Reference 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Can Get Customer 
Product ID from Request 
Num?

If the customer product ID can be derived from the Request 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Can Get Customer 
Product ID from Serial 
Num?

If the customer product ID can be derived from the Serial 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Rule Description

Product ID Exists? If the product ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Product ID’ sub-process, will allow for a quick exit from 
the sub-process without applying any derivation rules if the 
Product ID is already known.

Can Get Product ID from 
Reference Num?

If the product ID can be derived from the Reference Number, 
this rule derives the Product ID and returns a Yes, otherwise it 
returns a No.

Can Get Product ID from 
Request Num?

If the product ID can be derived from the Request Number, this 
rule derives the Product ID and returns a Yes, otherwise it 
returns a No.
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Deriving Rules for Telesales Routing 
The Oracle Workflow Builder routing functions for Oracle Telesales derive the 
Customer ID information from the caller’s responses to the IVR. The phase is 
represented by the Derive Telesales Customer ID sub-process, which you drag onto 
the process diagram.

You can drag the following rules for derivation of Customer ID onto the Derive 
Telesales Customer ID sub-process. You can also use these rules directly in the 
Routing process diagram.

Refer to the following table for a description of Oracle Telesales routing rules.

Deriving Rules for Banking Routing 
The Oracle Workflow Builder routing functions for Oracle Banking Center derive 
the group information from the caller’s responses to the IVR. You can also use these 
rule functions directly in the Routing process diagram.

Refer to the following table for a description of Oracle Banking Center routing rules.

Can Get Product ID from 
Serial Num?

If the product ID can be derived from the Serial Number, this 
rule derives the Product ID and returns a Yes, otherwise it 
returns a No.

Rule Description

Customer ID from 
Address ID?

If the customer ID can be derived from the Address ID, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Customer ID from ANI? If the customer ID can be derived from the ANI, this rule derives 
the Customer ID and returns a Yes, otherwise it returns a No.

Customer ID Exists? If the Customer ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Telesales Customer ID’ sub-process, will allow for a 
quick exit from the sub-process without applying any derivation 
rules if the Product ID is already known.

Rule Description

Group from Bank Branch If the group can be derived from the Bank Branch, this rule 
derives the Agent Ids based on the group.

Rule Description
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Setting Profile Options
There are no system profile options to set for Oracle Telephony Manager.

Configuring and Testing Integration Points
When implementing and troubleshooting Oracle Telephony Manager, consideration 
should be given to the PBX components being configured and operational. 
Troubleshooting should begin at the third-party CTI middleware layer and progress 
up through the stack.

It is important to verify proper configuration of the PBX CTI link and its 
communication to the CTI middleware and, subsequently, to the Oracle Call Center 
Connectors server.

In some cases, troubleshooting CTI issues must include the customer’s PBX/CTI 
engineer to ensure proper configuration on the PBX and its proprietary CTI link.

Testing an Implementation Project

Restarting the Server Monitor
If the Server Monitor goes down and you restart it, all clients of the Server Monitor 
automatically re-register with the Server Monitor and other servers. The server 
launcher also automatically reconnects when the Server Monitor restarts.

Starting Servers
When you need monitoring, Oracle suggests that you start the Server Monitor first. 
When the Server Monitor is in use, you can start the Inbound Telephony Server 
before starting Oracle Telephony Manager.

Group from Bank ID If the group can be derived from the Bank Id, this rule derives 
the Agent Ids based on the group.

Group from Profitability If the group can be derived from profitability, this rule derives 
the Agent Ids based on the group.

Rule Description
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When the Server Monitor is not in use, Oracle Telephony Manager must be running 
before you can start the Inbound Telephony Server. If you start the server monitor at 
any time after startup, the monitored servers will automatically connect to it.

Monitored servers detect when the server monitor starts and by default connect to 
the server monitor within five minutes. To change this connect default value specify 
the sm_reconnect_interval parameter in the SERVER.INI file and the SMI.INI 
file.

Starting the Server Monitor
On Windows NT, Oracle recommends that you start the Server Monitor as the 
service OracleServerMonitor_ServerName. To start the server monitor in 
console window, run the batch file SM.BAT from

   the home directory.

On UNIX, to start the server monitor, run the script file SM.SH.

Starting the Server Launcher
The server launcher performs remote startup of the server monitor. The server 
launcher is installed automatically in the installation of any call center server. The 
server launcher must run on every machine that a) runs any call center and 
telephony server and b) requires remote startup. When the server monitor notifies 

the server launcher, the server launcher starts an NT service on Windows NT and 
starts a background process on UNIX.

Starting the Server Monitor Command Line
To access the Server Monitor commands, you need to start another command line.

On Windows NT, run the file SMCMD.BAT.

On UNIX, run the file SMCMD.SH.

Administering Server Monitor Commands
Refer to the following table for a description of command line commands for 
administering the Server Monitor.
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Auto-Restart of Servers with the Server Monitor
You can configure your servers to be re-started automatically on a crash. Currently 
only the Inbound Telephony Server, the Oracle Telephony Manager, the Oracle 
Telephony Media Controller(s), the Email Center server, the Oracle Routing 
Server(s) connect to the server monitor and can avail of this fault tolerance 
functionality. The Oracle Server Launcher must be running on every node that has 
any of the aforementioned servers connected to the server monitor. By default Server 
Monitor is configured to restart all servers automatically on a crash. To disable 
auto-restart for all servers set the parameter AUTO_RESTART_DISABLED to TRUE 
in the SM.INI file. To disable auto- restart for a specific server set the parameter 
AUTO_RESTART_DISABLED to TRUE in the servers init file (SVR.INI). Example 
configurations for init files follow:

Configuration 1 
auto_restart_disabled=true in sm.ini

Result: No server will be restarted automatically.

Configuration 2
auto_restart_disabled=false in sm.ini

Command Definition

HELP Display the server monitor commands.

SHUTDOWN Shutdown the server monitor and server monitor command 
line tool.

STATUS Display server monitor status information.

GC Initiate server monitor Garbage Collect.

RSTART(serverName) Start a remote server.

RSTOP(serverName) Stop a remote server.

RSTATUS(serverName) Show the status of a remote server.

RSTATUS Display the status of all servers that are monitored by the 
server monitor.

RLIST Display a list of servers installed on different hosts.

STOPCMDLINE Stop the command line interface.
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auto_restart_disabled=true in ors.ini (the Oracle Routing Servers init file), auto_
restart_disabled=false in otm.ini (the Oracle Telephony Managers init file)

Result: If the Oracle Routing Server crashes, it will not be restarted automatically

Restarting a Crashed Server Application
Before you restart a crashed server application on the same server, you need to wait 
the length of time equal to the server refresh rate, which is currently one minute. If 

you restart sooner, you will receive the error message Server by name 
"ServerName" is already running. If you shut down the Windows NT 
service or, on Solaris, invoke the “shutdown” command off the command line 
interface, you do not need to wait before restarting.

Configuring Oracle Telephony Manager to Run in Passive Mode
When run in passive mode, Oracle Telephony Manager bypasses any routing rules. 
Passive mode is typically used when a call center prefers traditional ACD routing 
features and/or the statistics and reporting tools of a switch vendor.

In passive mode, the ACD/PBX system completely handles the routing and 
queueing of inbound calls. Oracle Telephony Manager does not monitor or respond 
to routing requests from the switch, and skill-based routing is essentially inactive. 
As calls arrive at the agents’ extensions, Oracle Telephony Manager monitors the 
calls and captures any associated data (for example, ANI or DNIS) for screen pops.

For Nortel Meridian only, when Oracle Telephony Manager is in passive mode, the 
ACD/PBX system routes inbound calls and delivers then to the ACD DN, also 
known as the Automatic Call Distribution key, on the teleset. When Oracle 
Telephony Manager is in active mode, skill-based routing directs inbound calls to 
the DN (Directory Number), also known as the Single Call Ringing key, on the 
teleset.

Use this procedure to configure Oracle Telephony Manager to run in passive mode.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.
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a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the PASSIVE_MODE parameter 
to TRUE.

Configuring Telephony Manager to Run in Active Mode
Use this procedure to configure Oracle Telephony Manager to run in active mode.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the PASSIVE_MODE parameter 
to FALSE.

Connecting Inbound Telephony Server to Oracle Telephony Manager
Inbound Telephony Server is a server process which monitors and forwards 
inbound telephony and web callback requests to Telephony Manager Server (OTM). 
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The Inbound Telephony Server is required when running OTM in active mode, 
routing inbound telephony and/or web callback requests.

To configure Inbound Telephony Server to connect to OTM, configure the parameter 
OTM_SERVER_NAME with the appropriate Telephony Manager Server name.

Configuring Oracle Telephony Manager to Run in Standalone Mode
Standalone Oracle Telephony Manager is a single server application that handles 
both media queueing and media control. Standalone configuration is suitable for 
call centers with fewer than 300 agents, and is easier to maintain than distributed 
configurations.

Use this procedure to configure Oracle Telephony Manager to run in standalone 
mode. 

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the STANDALONE parameter to 
TRUE.

Configuring Oracle Telephony Manager to Run in Distributed Mode
Distributed configuration can support call centers with more than 1000 agents, and 
has better scalability than standalone configuration. A distributed Oracle Telephony 
Manager system consists of one media queue server application, that is, Oracle 
Telephony Manager, and one or more media controller server applications, that is, 
Telephony Media Controller.
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Use this procedure to configure Oracle Telephony Manager to run in distributed 
mode. 

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the STANDALONE parameter to 
FALSE.

Configuring Media Controller to Run in Distributed Mode
Use this procedure to configure Oracle Telephony Media Controller to run in 
distributed mode. 

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window appears.

b. Click Server Admin.

The Server Locator window appears.
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2. Select the Server tab.

3. Run a query to display a Telephony Media Controller in the same server group 
as the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the OTM_SERVER_NAME 
parameter to the server name of the Telephony Manager Server.

Connecting Oracle Telephony Manager to Routing Servers
You can configure up to three routing servers per Oracle Telephony Manager. A 
load-balancing algorithm distributes the calls among the routing servers. 

To configure Oracle Telephony Manager to connect to routing servers, configure the 
parameter ROUTING_SERVER_1, ROUTING_SERVER_2, ROUTING_SERVER_3 
with the appropriate routing server names. 
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