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Preface

Welcome to the Oracle Customer Relationship Management, Release 11i, suite of 
applications.

This Implementation Guide provides general descriptions of the setup and 
configuration tasks required to implement Oracle Telephony Manager successfully. 

This preface explains how this Implementation Guide is organized and introduces 
other sources of information that can help you.

Intended Audience
This guide is aimed at anyone who is tasked with implementing Oracle Telephony 
Manager, including:

■ Database Administrators

■ System Administrators

■ Technical Specialists

This guide assumes you have the following prerequisites:

1. Understanding of computer-telephony integration (CTI)

2. Understanding of call center technology

3. Understanding of the company business processes

4. Understanding of Oracle Applications, Release 11i

5. Understanding of Oracle Workflow
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Structure
This manual contains the following sections:

■ Considerations for Planning an Implementation Project

■ Typical Release Dependencies

■ Related Documentation and Resources

■ Upgrading from Oracle Telephony Manager 3i

■ Setting Up Oracle Telephony Manager

■ Setting Up Rules-Based Routing for Inbound Calls and Email

■ Setting Up Workflow-Based Routing for Inbound Calls and Email

■ Setting Profile Options

■ System Profile Options

■ Configuring and Testing Integration Points

■ Testing an Implementation Project

Related Documents
For more information, see the following manuals:

■ Oracle Applications Concepts

■ Oracle Applications Product Update Notes, Release 11i

■ Oracle Applications Release Notes, Release 11i

■ Oracle Applications Installation Update Notes

■ Installing Oracle Applications, Release 11i

■ Maintaining Oracle Applications, Release 11i

■ Upgrading Oracle Applications, Release 11i

■ Oracle Applications System Administrator’s Guide

■ Oracle Applications User’s Guide

■ Oracle Workflow Guide

■ Implementing CRM Applications

■ Oracle Telephony Manager Concepts and Procedures
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■ Oracle Telephony Manager Technical Reference Manual
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Implementing Oracle Telephony Manager

This guide provides general descriptions of the setup and configuration tasks 
required to implement OTM successfully. It includes an overview with list of steps 
to follow to set up OTM, and includes detailed instructions on completing setup 
tasks in each OTM setup window.

This guide contains the following information:

■ Considerations for Planning an Implementation Project

■ Related Documentation and Resources

■ Setting Up Oracle Telephony Manager

■ Setting System Profile Options

■ Configuring and Testing Integration Points

■ Testing an Implementation Project
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Considerations for Planning an Implementation Project
Considerations for Planning an Implementation Project
This topic includes the following information:

■ Purpose for Planning an Implementation

■ Business Requirements Mapping

■ Application Architecture

■ Overview of a Typical Business Process

Purpose for Planning an Implementation
Implementing Oracle Telephony Manager is a complex process that requires 
knowledge of a variety of technologies and processes. The implementation of 
Oracle Telephony Manager requires working knowledge of Oracle Forms, HTML, 
Java, and the installation platform (Windows NT or Unix). In addition, an 
understanding of the operational requirements of an interaction center and basic 
telephony functionality is required.

Oracle Telephony Manager implementation planning requires that you take a 
careful and detailed look at the following areas:

■ Verifying Operational Requirements: This is the preliminary step in the 
implementation. The PBX/ACD CTI enabler configuration must be complete 
and the appropriate Oracle Call Center Connectors installed and configured. 
This integration should be tested and functional before configuring Oracle 
Telephony Manager.

■ Installing and Connecting Servers: Also as part of the operational 
requirements, the servers and workstations to support Oracle Telephony 
Manager are installed and connected to the network. The consultant will need 
to work with the customer to determine the server architecture including the 
number of machines and which services will run them.

■ Installing Oracle Telephony Manager: Oracle Telephony Manager and other 
related server components are installed on the various machines. 

■ Configuring Oracle Telephony Manager: Oracle Telephony Manager is then 
configured for the interaction center environment. The consultant will need to 
work with the customer to determine if OTM will run in a passive or active 
routing mode. 

■ Active mode: In active mode, Oracle Telephony Manager routes calls 
according to defined rules. Active mode is the default mode of operation. In 
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active mode, Oracle Telephony Manager uses skills-based routing, a dynamic 
call routing intelligence that delivers inbound calls to an agent who is 
appropriately skilled to meet the needs of the caller. 

If OTM will run in an active routing mode and Advanced Inbound will be 
implemented, each of the various inbound media routes and call 
classifications will need to be defined and configured. This may include 
routing for inbound telephone calls, inbound calls handled by the IVR, 
inbound eMail, and web callbacks. 

In addition to defining the media routing, there may be special treatment 
required while media items are in queue that will need to be defined and 
configured. Queue treatments are only available when OTM is in an active 
routing mode and Advanced Inbound is being implemented. 

If OTM is being implemented in an active routing mode, the route target 
groups will need to be defined. The target groups are the groups of agents 
that are allowed to be the recipient of a routed media item. Any agent that 
is not part of a target group for a particular media type will not be able to 
access that media type through the Universal Work Queue. For example, 
agents that are not part of any group servicing eMail will not see inbound 
eMail work.

For Nortel Meridian, when Oracle Telephony Manager is in active mode, 
skill-based routing directs inbound calls to the DN (Directory Number), 
also known as the Single Call Ringing key, on the teleset

■ Passive mode: Passive mode instructs Oracle Telephony Manager to bypass 
any routing rules. Passive mode is typically used when an interaction 
center prefers traditional ACD routing features and/or the statistics and 
reporting tools of a switch vendor.

In passive mode, the ACD/PBX system completely handles the routing and 
queueing of inbound calls. Oracle Telephony Manager does not monitor or 
respond to routing requests from the switch, and skill-based routing is 
essentially inactive. As calls arrive at the agents’ extensions, Oracle 
Telephony Manager monitors the calls and captures any associated data (for 
example, ANI or DNIS) for screen pops.

For Nortel Meridian only, when Oracle Telephony Manager is in passive 
mode, the ACD/PBX system routes inbound calls and delivers then to the 
ACD DN, also known as the Automatic Call Distribution key, on the teleset. 
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■ Testing Oracle Telephony Manager: Finally, with all software installed and 
operating, Oracle Telephony Manager is put through the operational testing 
step to verify that it meets the operational requirements. 

Business Requirements Mapping
Oracle Telephony Manager is a prerequisite for providing:

■ CTI support and Softphone 

■ IVR Integration

■ Sophisticated routing across multiple media channels

■ Enhanced queuing, call treatment and overflow functionality

■ Pre-integrated with Oracle E-Business Suite applications

■ Essential interaction center functionality includes:

– Inbound and outbound telephony

– Out-of-the box ACD/PBX connectivity with multiple ACDs and CTI 
enablers

– Agent Softphone

– ANI & DNIS screen-pops

– Call and data transfer

■ Additional interaction center functionality provided includes:

– Multi-media support, telephone, Email and web callbacks

– Intelligent out-of-the-box routing provides rules, skills and records-based 
routing

– Static and dynamic routing capabilities

– Best agent for given interaction is routed the interaction, telephone calls, 
email and web call backs

– Integration to IVRs provides additional data for enhanced routing and 
screen-pops

– Advanced queuing provides enhanced treatment, overflow and group 
queuing of calls

– Support for web callBacks
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Application Architecture
Oracle Telephony Manager (OTM) is the platform for all Oracle interaction center 
and telephony applications. OTM translates the proprietary ACD/PBX protocol of 
telephony communications into computer-compatible language, and routes calls to 
the designated telephones and computers used by interaction center agents. 

Required third-party CTI middleware provide the interface between the customer’s 
proprietary PBX/ACD CTI link and our interaction center applications (Call Center 
Connectors and Oracle Telephony Manager). Third-party enablers, such as 
Dialogic’s CT-Connect, allow server API integration for CTI messaging. The 
integration between the third-party middleware, the Call Center Connectors server, 
and Oracle Telephony Manager allow standardization of CTI functionality and 
protect the customer’s Oracle application from the proprietary differences between 
PBX/ACD platforms.

An OTM interaction center is represented by a logical grouping of interaction center 
processes called a server group. The number of server applications in a server group 
will depend on the specific processes used in a particular interaction center.
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 The following types of server processes may be included in a server group:

Advanced Outbound Proxy Server is a server process for integrating the Oracle 
interaction center with advanced outbound telephony (Oracle Campaign Plus and 
Oracle Predictive).

Fulfillment Server is a server process for integrating the Oracle interaction center 
with Oracle 1-to-1 Fulfillment.

eMail Center Server is a server process for integrating the Oracle interaction center 
with Oracle eMail Center.

Inbound Telephony Server is a server process which monitors and forwards 
inbound telephony and web callback requests to Telephony Manager Server. The 
Inbound Telephony Server is required when running OTM in active mode, routing 
inbound telephony and/or web callback requests. If OTM will be run in passive 
mode or if there is only outbound telephony, you do not need the Inbound 
Telephony Server process. This service may or may not run on the same machine as 
the OTM service, depending on the size of the interaction center.

Interaction Blending Server is a server process for integrating with Oracle 
Interaction Blending.
6 Oracle Telephony Manager Implementation Guide
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Routing Server is a server process for the routing component of the Oracle 
interaction center. The Routing Server determines which agent(s)/agent groups 
receive a new interaction. The routing can be skill and/or rule based. The routes are 
defined for various media parameters.

The Routing Server is always used with inbound email with eMail Center. The 
Routing Server is only used with inbound telephony if you are running OTM in the 
active mode. If OTM will be run in passive mode or if there is only outbound 
telephony, you do not need the Routing service. This server may or may not run on 
the same machine as the Telephony Manager Server, depending on the size of the 
interaction center. You can have up to three Routing Servers, each of which can be 
distributed on separate server machines as dictated by the size of the interaction 
center and the inbound call and mail volumes being handled.

Server Monitor is a server process for monitoring and coordinating other Oracle 
interaction center servers. The Server Monitor monitors and launches any of the 
other telephony and requester server processes. These include Telephony Manager 
Server, Inbound Telephony Server, Routing Server, Telephony Media Controller, and 
iCenter Server. The Server Monitor is optional, but it is recommended that you use 
it for fault tolerance purposes. You must choose on which server machine to install 
and run the server and there is only one per server group. The remote service 
startup capability uses the Server Launcher that is automatically installed on any 
machine with one of the telephony or requester services. There is one and only 
Server Launcher per machine regardless of the number of telephony/requester 
servers running on the machine.

Telephony Manager Server is a server process for the queuing and media control 
component of the Oracle interaction center. Generally, there is one Telephony 
Manager server for a single interaction center. However, if there are multiple 
businesses with data segregation in a single center, you may have a Telephony 
Manager server for each business. The Telephony Manager server handles the 
queuing and distribution of media items.

The Oracle Telephony Manager maintains the agent distribution queues and agent 
states for any Interaction Center. It also provides access to a common routing 
engine. OTM is media independent and can route all types of interactions (email, 
telephony, faxes, web calls) to the interaction center agents.

Telephony Media Controller is an optional server process that can share the 
processing load of the Oracle Telephony Manager server. To help increase the 
scalability of the system, Oracle recommends that you start the Telephony Media 
Controller processes on separate physical machines. Each Oracle Telephony Media 
Controller process needs to have its own name and configuration.
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Universal Work Queue Server is a server process for integrating desktop 
applications with media providers.

Oracle Telephony Manager (OTM)
The Oracle Telephony Manager maintains the agent distribution queues and agent 
states for any Interaction Center. It also provides access to a common routing 
engine. OTM is media independent and can route all types of interactions (email, 
telephony, faxes, web calls) to the interaction center agents.

Known Limitations
Only one OTM server can exist per Interaction Center.

Platform Dependencies
A Java Server; Runs on Solaris and NT platforms.

Configuration Options
There is a 1:1 relationship between an OTM and the eMail Center Server; however, 
the rest of the eMail Center modules are shared.

Overview of a Typical Business Process
A media-processing example is an eMail message that needs to be routed to an 
agent. An eMail event representing the mail message will be received from eMail 
Center for processing by the Oracle Telephony Manager request layer. OTM 
generates an eMail media item which is then passed to the distribution layer where 
a routing request and decision can be made.

Once the routing decision is made the media item is queued up, the Universal Work 
Queue is notified (as is Interaction Blending if it is running), and it will appear as a 
work item to an available and qualified agent or group of agents. When an agent 
selects the work item, the media item is de-queued. 

A telephony media item works the same way except that it is received from the 
ACD and when an agent selects and receives the work item, the call is sent to the 
agent’s phone set.0Typical Release Dependencies

This topic include the following information:

■ Related Products and Components

■ Implementation Starting Point
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■ Considerations and Constraints of Interactions with Other Types of Products

Related Products and Components
OTM integrates with Oracle Universal Work Queue (UWQ), Interaction Blending (if 
implemented), Routing (if Advanced Inbound is implemented), Oracle Call Center 
Connectors, Oracle eMail Center, and Oracle eCommerce applications, such as 
Oracle iSupport and Oracle iStore, with a call me form enabled to generate web 
callbacks. OTM receives information from IVR Integrator through the Call Center 
Connectors server. OTM and the SoftPhone are integrated through UWQ. OTM also 
integrates with Workflow via the Routing Server.

Call Center Connectors are required and must be installed and configured for 
telephony control functionality. eMail Center is required and must be installed and 
configured for eMail control functionality. Universal Work Queue is required and 
must be installed and configured for integration to the applications running in the 
agent work area. The CRM Foundation (Resource Manager) must be installed and 
at least one test agent configured. 

Implementation Starting Point
This guide assumes that the interaction center is using a Oracle certified or 
supported switch, that the switch interfaces to an Oracle certified or supported CTI 
middleware, and that Oracle Call Center Connectors has been installed and 
configured.

This guide also assumes that Oracle Applications 11i, the Call Center Java middle 
tier, and Oracle Telephony Manager have been installed.

Considerations and Constraints of Interactions with Other Types of Products
Oracle Telephony Manager has several implementation dependencies. This 
includes:

■ Customer’s PBX/ACD switch must be certified and/or supported through the 
interaction center’s PBX Integration Program.

– For OTM, release 11.5.1, supported PBX/ACDs include Lucent Definity G3 
and Nortel Meridian.

– For OTM, release 11.5.2, supported PBX/ACDs include Lucent Definity G3, 
Nortel Meridian, Siemens Hicom (US version), and Alcatel 4400.
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– Additional switches are supported quarterly and/or at point/patch 
releases.

– All PBX/ACDs are not compatible and may not be supported.

– The PBX/ACD matrix includes references to specific PBX models and 
software releases as well as information on PBX platforms supported via 
specific third-party CTI enabler software.

■ The customer’s PBX must be interfaced to an Oracle certified/supported 
third-party CTI Middleware. CTI Middleware is purchased by the customer 
directly from the supported third-party vendor and must be 
installed/implemented in accordance with the third-party CTI vendor 
specifications.

– For Oracle Telephony Manager, release 11.5.1, supported CTI Middleware 
include Dialogic’s CT Connect.

– For Oracle Telephony Manager, release 11.5.2, supported CTI Middleware 
include Dialogic’s CT-Connect and Cisco ICM CTI Server (formerly GeoTel).

– For Oracle Telephony Manager release 11.5.3, support CTI Middleware 
includes Dialogic’s CT-Connect, Cisco ICM CTI Server (formerly GeoTel), 
Nortel Symposium Call Center Server, and Siemens Hicom (international 
version).

– Additional PBX/middleware combinations are supported quarterly and/or 
at point/patch releases.

– For information about approved third-party CTI middleware see the Oracle 
Call Center Switch (ACD) Support at the locations referenced above.

■ OTM is also dependent on the proper installation of Oracle Call Center 
Connectors, a CTI server product included in the Advanced Inbound product 
module group. Call Center Connectors integrates the customer’s approved 
third-party CTI middleware to the Oracle Telephony Manager server. For 
complete details on installing the Oracle Call Center Connectors server see the 
documentation, Installing Oracle Call Center Connectors

Since the proper implementation of Oracle Telephony Manager is dependent on the 
proper versions and installation of third-party customer-provided equipment for 
requisite CTI functionality the following considerations should be considered prior 
to beginning the implementation:

■ Does the Customer have a PBX/ACD switch that has been certified by Oracle?
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■ Is the PBX/ACD the model, software release and does it have the proper 
PBX-based CTI interfaces or links?

■ Has the customer purchases and installed/implemented an approved 
third-party CTI middleware?

■ Has the PBX and CTI middleware been fully tested and operation on the 
customer’s ethernet LAN?

■ Have the PBX Application Notes been referenced and the list of supported CTI 
functions tested.
Implementing Oracle Telephony Manager 11
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Related Documentation and Resources
There are several locations within the Oracle intranet where you can find 
information on Oracle Telephony Manager and how to implement Oracle 
Telephony Manager. Following is a listing of many of these resources:

Implementing CRM Applications  Describes manual post-installation steps for 
selected Customer Relationship Management (CRM) modules.

Oracle Call Center Applications Setup Describes the installation of the Oracle 
Telephony Manager server processes. 

Oracle Telephony Manager Technical Reference Manual Provides information 
about the Oracle Telephony Manager schema.

Oracle Call Center Technology Technical Reference Manual Provides information 
about the Oracle Call Center (not a module) schema.

Installing Oracle Call Center Connectors Provides information about installing 
and configuring Oracle Call Center Connectors.
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Setting Up Oracle Telephony Manager
Follow the steps in the following chart to set up OTM. The chart shows you where 
to read in detail about the setup step. The Window Name(s) column shows you in 
which window(s) to perform the step, and if the window is available only if you use 
a specific responsibility or product.

Step 
Number Required? OTM Setup Step Description Window Name(s)

❏ Step 1 Required for 
telephony

Oracle Call Center Connectors and 
dependencies

See: Oracle Call Center Connectors 
Installation Guide

NA

❏ Step 2 Required for IVR 
integration

Install Oracle IVR Integrator and 
dependencies

See: Oracle IVR Integrator Installation Guide

NA

❏ Step 3 Required Define the Oracle interaction center server 
group.

See: Defining an Oracle Interaction Center 
Server Group

Server Locator 
window, Server 
Group tab

❏ Step 4 Required Define and configure the Oracle interaction 
center server processes.

See: Configuring Oracle Interaction Center 
Server Processes

Server Locator 
window, Server tab

❏ Step 5 Required Define and configure the CTI middleware.

See: Configuring the CTI Middleware 

Call Center 
Administration 
window, 
Middleware tab

❏ Step 6 Optional Define the interaction center telesets.

See: Defining Interaction Center Telesets

Call Center 
Administration 
window, Teleset 
tab

❏ Step 7 Optional Map the inbound IVR data to fields in 
Oracle Applications.

See: Mapping Inbound Data to Oracle 
Applications Fields

Call Center 
Administration 
window, IVR 
Mapping tab

❏ Step 8 Required Create an Advanced Inbound User

See: Creating an Oracle Advanced Inbound 
User
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Defining an Oracle Interaction Center Server Group
An Oracle interaction center is represented by a logical grouping of interaction 
center processes called a server group. If there are multiple interaction centers or if 
separate lines of business are operating in the same interaction center, then there 
can be multiple server groups. Once the server group is defined, you can configure 
the individual interaction center processes in the group. (See Configuring Oracle 
Interaction Center Server Processes.)

Use this procedure to define a server group.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. From the File menu, choose New.

3. In the Server Group tab, enter a unique name for the server group, the location 
of the server group, and a description of the server group.

❏ Step 9 Optional Set up routing for inbound calls or email.

See: Configuring Call Routing

Routing 
Administration 
window or 
Workflow Builder

Step 
Number Required? OTM Setup Step Description Window Name(s)
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Server Location Window: Server Group Tab: Server Group Registration Area

4. From the File menu, choose Save.

Configuring Oracle Interaction Center Server Processes
Oracle interaction center processes, such as routing, are governed by individual 
server applications. A logical grouping of server processes is called a server group. 
(See Defining an Oracle Interaction Center Server Group.) 

The number of server applications in a server group will depend on the specific 
processes used in a particular interaction center. The following types of server 
processes may be included in a server group:

■ Advanced Outbound Proxy Server

■ eMail Center Server

■ Inbound Telephony Server

■ Interaction Blending Server

■ Routing Server

■ Server Monitor

■ Telephony Manager

■ Telephony Media Controller

■ Universal Work Queue Server

For a detailed description of each server process, see Application Architecture.

The server applications may run on one or more server machines. Each server 
process is configured individually.

If you are implementing Advanced Inbound telephony in active mode, you need 
the following servers:
Implementing Oracle Telephony Manager 15
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■ Inbound Telephony Server

■ Interaction Blending Server (does not need to be configured unless blending is 
used)

■ Routing Server

■ Server Monitor

■ Telephony Manager

■ Telephony Media Controller

■ Universal Work Queue Server

If you are implementing Advanced Inbound telephony in passive mode, you need 
the following servers:

■ Inbound Telephony Server (required only if Web Callback functionality is 
enabled)

■ Server Monitor

■ Telephony Manager

■ Telephony Media Controller

■ Universal Work Queue Server

If you are implementing Advanced Outbound, you need the following servers:

■ Advanced Outbound Proxy Server

■ Inbound Telephony Server

■ Interaction Blending Server (does not need to be configured unless blending is 
used)

Note: Large volume call center configurations may require OTM 
to be run with one or more Telephony Media Controllers. 
Telephony Media Controller is an optional server process that can 
share the processing load of the Oracle Telephony Manager server. 
To help increase the scalability of the system, Oracle recommends 
that you install and start the Telephony Media Controller processes 
on separate physical machines. Each Oracle Telephony Media 
Controller process needs to have its own distinct name and 
configuration within the interaction server group.
16 Oracle Telephony Manager Implementation Guide
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■ Routing Server

■ Server Monitor

■ Telephony Manager

■ Telephony Media Controller

■ Universal Work Queue Server

If you are implementing eMail Center, you need the following servers:

■ eMail Center Server

■ Interaction Blending Server (does not need to be configured unless blending is 
used)

■ Routing Server

■ Server Monitor

■ Telephony Manager

■ Telephony Media Controller

■ Universal Work Queue Server

Prerequisites
❏ Define the Oracle interaction center server group. For more information, see 

Defining an Oracle Interaction Center Server Group.

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. In the Server Group tab, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.
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c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Server tab.

4. If necessary, choose File > New.

5. In the Server Registration area, identify the server process.

Server Locator Window: Server Tab: Server Registration Area

a. Server Name: This is a mandatory field. Enter a name by which to identify 
the server. This is the user-defined name that you entered while installing 
the server. The name you enter here must be the same name that you 
entered in the Enter the Component Name window when defining the server 
name for your server. 

b. Server Location: This field is optional. Enter the location of your server.

c. Type Name: This is a mandatory field. Use the list of values to select the 
server type that matches the server that you are defining. For example, if 
the server name is Oracle_OTM, the server type would be Telephony 
Manager.

d. Member Group Name: This mandatory field defaults to the name of the 
server group for which you are defining servers.
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e. Using Group Name: This is an optional field. Do not enter a value in this 
field. 

f. DNS Name and IP Address: The values for these fields will be 
automatically assigned after Advanced Inbound is run for the first time.

g. User Address: This field is optional and is used to specify the IP address of 
the server machine. In general, you do not need to enter a value for this 
field. This field value is used when the server is running on a machine with 
DHCP or multihomed network configuration, in which case, normal DNS 
lookup would fail and the IP address would have to have been explicitly 
specified, thus enabling the client to properly connect to the server.

h. Description: This field is optional and is used to add a description of the 
server.

6. In the Server Parameter region, enter values if you are configuring the Oracle 
Telephony Manager server, Inbound Telephony server, Oracle Telephony Media 
Controller server, or Oracle Universal Work Queue server.

Server Locator Window: Server Tab: Server Parameter Area
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. 

Inbound Telephony Server Parameters Refer to the following table for a 
description of Inbound Telephony Server parameters.

Telephony Manager Server Parameters Refer to the following table for a 
description of Telephony Manager Server parameters.

Note: For specific Universal Work Queue parameters, refer to the 
Oracle Universal Work Queue Implementation Guide.

Name Required? Description Sample Value

OTM_SERVER_NAME Required Server name of the Telephony Manager Server to 
which this server is associated.

SampleOTMServer

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server.

SampleMWConfig

WEB_CALL_PORT Required if 
using web 
callback

Port used to listen for web call-back requests. If 
left blank, the default port 888 is used. This 
number must match the OTM Server Port field in 
the iSupport Admin UI -> Support tab -> Call Me 
sub-tab.

888

Name Required? Description Example

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server. 

MWConfig

DEFAULT_TIMEOUT Optional Default timeout for re-route in minutes. For 
example, when this parameter is set to 5, a media 
item will be re-routed if it has been waiting in 
queue for more than 5 minutes.

5

IB_SERVER_NAME Optional Server name of the Interaction Blending Server IBServer

MQA_MODE Optional TRUE/FALSE parameter. TRUE if multiple queue 
mode is on. Applicable to Nortel switch only.

TRUE

PASSIVE_MODE Optional TRUE/FALSE parameter. TRUE if passive mode is 
on.

FALSE

ROUTE_SERVER_1 Required 
for active 
mode only

Server name of Routing Server RouteServer1

ROUTE_SERVER_2 Optional Additional Routing Server for load balancing RouteServer2

ROUTE_SERVER_3 Optional Additional Routing Server for load balancing RouteServer3

STANDALONE Optional TRUE/FALSE parameter. TRUE if Telephony 
Manager is running in STANDALONE mode. 
FALSE if running in DISTRIBUTED mode.

TRUE
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Telephony Media Controller Parameters Refer to the following table for a 
description of Telephony Media Controller Server parameters.

7. From the File menu, select Save.

8. Repeat steps 2–7 to define all the servers in your Call Center server group.

9. To configure another interaction center server process, repeat steps 5 through 
10.

Configuring the CTI Middleware
CTI (computer telephony integration) middleware enables Oracle Telephony 
Manager and the Inbound Telephony Server to control telephony devices (for 
example, agent phones and telesets) and shared telephony resources (for example, 
phone switches and PBX/ACD).

Use this procedure to configure the CTI enabler for the interaction center.

Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

Note: You can currently support up to three routing servers for an 
OTM. OTM sends work to each routing server on a round-robin 
basis.

Telephony Media Controller Parameters

Field Name Required Description Example

TELE_MIDDLEWARE_CONFIG Required Configuration name of the middleware used by 
this server. 

MWConfig

OTM_SERVER_NAME Required Server name of the Telephony Manager Server. SampleOTM

MQA_MODE Optional TRUE/FALSE parameter. TRUE if multiple queue 
mode is on. Applicable to Nortel switch only. 

TRUE

PASSIVE_MODE Optional TRUE/FALSE parameter. TRUE if passive mode is 
on.

FALSE
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a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Middleware tab.

4. In the Middleware Configuration area, specify your middleware.

Call Center Administration Window: Middleware Tab: Middleware Configuration Area

a. Enter a unique name for the middleware configuration.

b. From the Middleware Type list, select the middleware type.
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Middleware Types Refer to the following table for a description of middleware 
types.

c. Enter the IP address of the machine hosting Call Center Connectors, for 
example, Oracle Call Center Connectors or Prospect CTI Server.

d. Enter the port number of the middleware server, for example, Oracle Call 
Center Connectors or Prospect CTI Server.

5. In the Middleware Parameter area, configure the parameters for the selected 
middleware type.

Each row in the table corresponds to an Oracle interaction center server 
parameter.

Middleware Type Middleware Server CTI Enabler Server (Middleware) Switch (PBX/ACD)

Dialogic CT-Connect Oracle Call Center Connectors Dialogic CT-Connect ■ Alcatel 4400

■ Avaya (Lucent) 
Definity G3

■ Nortel Meridian

■ Nortel Symposium 
Call Center Server

■ Siemens HICOM 
(US and 
international)

Cisco ICM/Enterprise CTI Oracle Call Center Connectors Cisco ICM CTI Server ■ Aspect

■ Avaya (Lucent) 
Definity G3

■ Nortel Meridian

Note: Check the port number against the configuration of the 
middleware server. For Oracle Call Center Connectors, default port 
number is 3201.
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Call Center Administration Window: Middleware Tab: Middleware Parameters Area

a. From the Name list, select a parameter.

The parameters listed in the Name list depend on the type of middleware 
selected from the Middleware Type list. For information about server type 
parameters, see Guidelines below.

b. Enter a value for the parameter.

Middleware Parameters for Dialogic CT-Connect Refer to the following table for a 
description of middleware parameters for CT-Connect.

Field Name Required Description Sample Value

CTI Enabler IP Address Required IP address of the CT-Connect server. 123.45.67.890

PBX Name Required Link logical identifier defined in CT-Connect 
configuration to represent the CTI link between 
CT-Connect and the switch.

ctc_nortel
ctc_lucent

PBX Type Required PBX type. Enter:

■ A - Lucent Definity

■ M - Nortel Meridian or Symposium Call Center 
Server

■ S - Siemens HICOM

■ C - Alcatel 4400

A

Middleware Server Info 1 Required Enter the value ncacn_ip_tcp as the identifier for 
the network protocol used between Oracle Call 
Center Connectors and CT-Connect.

Enter ncacn_ip_tcp 
for TCP/IP (actual 
value)
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Middleware Parameters for Cisco ICM (GeoTel) Refer to the following table for a 
description of middleware parameters for Cisco ICM.

Route Points Set 1

Route Points Set 2

Route Points Set 3

Route Points Set 4

Route Points Set 5

Required if 
using active 
mode

Devices within the PBX/ACD where inbound calls 
are initially received and route requests are issued.

■ Lucent Definity

Enter one or more vector directory numbers 
(VDN), separated by commas. The format is:

vdn[,vdn...]

■ Nortel Meridian:

Enter one or more CDN-immediate treatment 
pair(s), separated by commas. (CDN stands for 
Control Directory Number; the immediate 
treatment of an inbound call arriving at a CDN 
can be ringback or music). The format is:

cdn:treatment[,cdn:treatment...]

The format for treatment is:

##{R|M#musicRouteNumber}

■ Siemens HiCom and Alcatel 4400:

Enter one or more pilot number(s), separated by 
commas. The format is:

pilotNumber[,pilotNumber...]

There is a 256 maximum character limit. You can 
configure as many route points in each Route Points 
Set X field as the 256-character limit permits.

7400

7400,7500

7520:##R

7530:##M#02

7400

Outgoing Prefix Required if 
using web 
callback

Numeric prefix dialed to place outside calls. Check 
against the configuration of the PBX.

9

International Dialing Prefix Required if 
using web 
callback

Numeric prefix dialed for placing international calls. 011 (from within the 
USA)

Site Country Code Required if 
using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code Required if 
using web 
callback

The area code for the site where the PBX is located. 650

IVR Server Name Required if 
using IVR 
Integrator

The PCDCE name of the IVR Integrator server. Check 
against PCDCE configuration.

SAMPLEIVR (IVR 
server values must be 
in uppercase)

Field Name Required Description Sample Value
Implementing Oracle Telephony Manager 25



Setting Up Oracle Telephony Manager
6. From the File menu, choose Save.

Defining Interaction Center Telesets
Use this procedure to configure Oracle Telephony Manager for use with a teleset. 
You can integrate Oracle Telephony Manager with the following teleset types:

■ Lucent

■ Nortel

■ Aspect

Field Name Required Description Sample Value

CTI Enabler IP Address Required IP address of the Cisco ICM CTI server (Server A). 123.45.67.890

Middleware Server Info 1 Required Port number of the Cisco ICM CTI server (Port A). 42027

Middleware Server Info 2 Required IP address of the Cisco ICM CTI server (Server B). 123.45.67.890

Middleware Server Info 3 Required Port number of the Cisco ICM CTI server (Port B). 42027

PBX Name Required Peripheral ID defined in Cisco ICM CTI server for 
the PBX of interest.

5008

PBX Type Required PBX type.

■ A - Lucent Definity

■ M - Nortel Meridian

■ P - Aspect

A

Outgoing Prefix Required if 
using web 
callback

Numeric prefix dialed to place an outside call. 
Check against the configuration of the PBX.

9

International Dialing 
Prefix

Required if 
using web 
callback

Numeric prefix dialed for placing international calls. 011

Site Country Code Required if 
using web 
callback

The country code for the site where the PBX is 
located.

1

Site Area Code Required if 
using web 
callback

The area code for the site where the PBX is located. 650

Note: Be sure to provide a value for all required parameters for 
the selected middleware type. Values entered into the Value fields 
are not checked for validity.
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■ Siemens

■ Alcatel

Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the Teleset tab.

4. In the Teleset Configuration area, create a teleset definition for each teleset in 
the interaction center.

Each row in the table corresponds to one teleset in the interaction center.

a. In the Teleset Name field, enter a unique name for the teleset (for example, 
Nortel7701).

b. In the Hardware Number field, enter a unique identifier for this teleset (for 
example, 7701).

Oracle recommends that you follow the convention of using the primary 
extension number of the teleset.

c. From the Teleset Type list, select the vendor name for the teleset (for 
example, Nortel).

See the graphic below for an example.
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Call Center Administration Window: Teleset Tab

5. In the Line Configuration for Teleset area, configure the line configuration for 
each teleset definition.

See the graphic above for an example.

You can configure a maximum of three lines per teleset, one line each for Line 
Index 1, 2, or 3. The line configuration will depend on the type of teleset. For 
information about teleset line configurations, see Guidelines below:

Guidelines
Refer to the following table to determine the teleset line configuration for a 
particular teleset type.
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a. In the Teleset Configuration area, select the row for the teleset that you 
want to configure.

b. In the Line Configuration for Teleset area, select a line index from the Line 
Index list.

c. Enter the extension for the line index.

6. From the File menu, choose Save.

Mapping Inbound Data to Oracle Applications Fields
Data collected by an interactive voice response (IVR) or web callback can be passed 
by Oracle IVR Integrator to Oracle Applications in the form of name-value pairs. 
Oracle Applications can use this data to generate a more complete and meaningful 
screen pop on the agent desktop.

Use the following procedure to map the name associated with a value in an IVR 
data packet to a field in Oracle Applications.

Teleset Line Configuration

Lucent You can configure two or three lines for each teleset -- as many 
lines as there are call appearances on the actual teleset. Enter 
the same teleset extension number (station number) in the 
Extension field for all line indexes.

Nortel You must configure exactly two lines: 

■ For Line Index 1, enter the DN (Directory Number) in the 
Extension field. This corresponds to the Single Call 
Ringing key on the actual teleset.

■ For Line Index 2, enter the ACD DN in the Extension field. 
This corresponds to the Automatic Call Distribution key 
on the actual teleset.

Aspect Configure three lines for each teleset. Enter the same teleset 
extension number for all line indexes.

Siemens You must configure exactly one line for each teleset. Enter the 
teleset phone number in the Extension field for Line Index 1.

Alcatel You must configure exactly one line for each teleset. Enter the 
teleset phone number in the Extension field for Line Index 1.
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Prerequisites
❏ Define the Oracle interaction center server group. See Defining an Oracle 

Interaction Center Server Group.

Steps
1. Navigate to the Call Center Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

2. If necessary, find your server group.

a. Choose View > Query by Example > Enter to invoke the query entry mode.

b. Enter your query.

c. Choose View > Query by Example > Run to find the matching server 
groups.

3. Select the IVR Mapping tab.

Each row in the table corresponds to the mapping of one data item in the IVR 
data packet to one field in Oracle Applications.

Call Center Administration Window: IVR Mapping Tab

4. For each piece of IVR data that you want to map to a field in Oracle 
Applications, do the following:
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a. In the ACD IVR cell, enter or select the name of the IVR field.

b. In the Oracle Field cell, enter or select an Oracle Applications field name.

5. From the File menu, choose Save.

Creating an Oracle Advanced Inbound User
Follow the steps in the following table to create an Oracle Advanced Inbound agent. 
The Required column indicates whether a step is required. The Setup Step 
Description column describes a high-level step and, where applicable, provides a 
reference to a more detailed topic in this document. The Responsibility column 
indicates the Oracle Applications user account responsibility required to complete 
the step. The Navigation column provides the path for navigating to the necessary 
window.

Step 
Number Required? Setup Step Description Responsibility Navigation

❏ Step 1 Required Create an employee.

See: Creating an Employee in Oracle Human 
Resource Management Systems

<country code>_
HRMS_
MANAGER

People > Enter 
and Maintain

❏ Step 2 Required Create an Oracle Applications user account 
for the employee.

See: Creating an Oracle Applications User 
Account for an Employee

SYSTEM_
ADMINISTRATOR

Security > User 
> Define

❏ Step 3 Required Configure the Oracle Universal Work 
Queue profile options for the user account.

See: Configuring Universal Work Queue 
Profile Options for a User

SYSTEM_
ADMINISTRATOR

Profiles > 
System

❏ Step 4 Required Create a CRM (Customer Relationship 
Management) resource for the employee.

See: Creating a CRM Resource for an 
Employee

JTF_RESOURCE_
MANAGER

Maintain 
Resources > 
Import 
Resources

❏ Step 5 Required Configure interaction centers parameters 
for the CRM resource.

See: Configuring Interaction Center Roles 
and Parameters for a CRM Resource

JTF_RESOURCE_
MANAGER

Maintain 
Resources > 
Resource
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Creating an Employee in Oracle Human Resource Management Systems

Use this procedure to create an employee in Oracle Human Resource Management 
Systems (HRMS).

Prerequisites
❏ Review Managing People Using Oracle HRMS.

❏ Obtain an Oracle Applications user account with access to the <country code>_
HRMS_MANAGER (for example, US HRMS Manager) responsibility.

Steps
1. If necessary, select the HRMS Manager responsibility.

2. In the Navigator window, on the Functions tab, choose People > Enter and 
Maintain.

The Find Person window appears.

3. Click New.

The People window appears.

4. Enter the information for the new person.

The following fields are required:

■ Last (Name)

■ Gender

■ Type

■ Employee (Number)

5. From the File menu, choose Save.

Note: If you do not have Oracle Human Resource Management 
Systems, use CRM Resource Manager to create an employee in 
CRM.

Note: In the Type field, select Employee.
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Guidelines
In the following example, Newton Taliaferro is a person in Oracle HRMS. He has a 
type of Employee. His employee number is 821709.

See Also
■ Creating an Oracle Applications User Account for an Employee

■ Configuring Universal Work Queue Profile Options for a User

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource
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Creating an Oracle Applications User Account for an Employee
Use this procedure to create an Oracle Applications user account and to associate a 
person in Oracle Human Resource Management Systems (HRMS) with a user 
account.

Prerequisites
❏ Review Oracle Applications Systems Administrator’s Guide.

❏ Obtain an Oracle Applications user account with access to the SYSTEM_
ADMINISTRATOR (System Administrator) responsibility.

Steps
1. If necessary, select the System Administrator responsibility.

2. In the Navigator window, on the Functions tab, choose Security > User > 
Define.

The User window appears.

3. In the User Name field, enter the name of the user account.

4. In the Password field, enter the password for the user account and then enter 
the password again to verify it.

5. In the Person field, select the employee to be associated with the user account.

6. In the Responsibilities tab, add the following responsibilities:

Note: This is a temporary password. When the user logs into 
Oracle Applications for the first time, the message "Your password 
has expired" appears. The Password Update window allows the 
user to enter a new password.

To do this... Add this responsibility...

Create ? and access an Oracle Telephony Manager 
view from Oracle Support

Create ? and access an Oracle Telephony Manager 
view from Oracle Support

Create ? and access an Oracle Telephony Manager 
view from Oracle Support
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7. From the File menu, choose Save.

Guidelines
In the following example, NTALIAFE is an Oracle Applications user account. 
Newton Taliaferro, an employee in Oracle HRMS, is associated with the NTALIAFE 
user account. A user who logs in to Oracle Applications using the NTALIAFE user 
account will have access to functions associated the Customer Support 
responsibility.

Access email via Oracle eMail Center

To do this... Add this responsibility...
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See Also
■  Creating an Employee in Oracle Human Resource Management Systems

■ Configuring Universal Work Queue Profile Options for a User

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

Configuring Universal Work Queue Profile Options for a User
Oracle Telephony Manager assigns work to agents based on the Oracle Universal 
Work Queue user profile options set in the agent’s user account. Use Oracle 
Universal Work Queue profile options to:

■ Specify whether the client network layer attempts to use the system's proxy 
server, or a direct connection to the UWQ server

■ If using Oracle Interaction Blending, specify the blending style for the agent 
(Oracle Interaction Blending ensures service levels across multiple channels)

■ Enable or disable access to a particular type of work for a specific agent

■ Enable or disable automatic launching of the client-side plugin for media tasks

■ Change the order of the queues in the Oracle Universal Work Queue view

Prerequisites
❏ Review Oracle Applications Systems Administrator’s Guide.

❏ Obtain an Oracle Applications user account with access to the SYSTEM_
ADMINISTRATOR (System Administrator) responsibility.

Steps
1. If necessary, select the System Administrator responsibility.

2. In the Navigator window, on the Functions tab, choose Profiles > System.

The Find System Profile Values window appears.

3. Select the User check box.

4. Type the user name in the field adjacent to the User check box (for example, 
ABCDEF).

5. Select the Profiles with No Values check box.

6. In the Profiles field, type IEU%.
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7. Click Find.

The System Profiles window appears.

8. Enable or disable access to a particular type of work.

Select Yes to enable access to a type of work; otherwise, select No.

The default queue determination process is dynamic by nature, so we cannot 
simply say the default is Y or N.

When the user logs in, we see what Interaction Center they’re in (a.k.a. Server 
Group). This is set in the CRM Resource configuration form, under the 
Interaction Center tab. We know which types of servers support which types of 
media by using other (internal) configuration tables.

Based on this lookup, the user is deemed to be “eligible” to work on any Queue 
type that the servers in his group can support. Therefore, if only OTM were in 
his group, he would be eligible to work on: Inbound Telephony, Inbound Email, 
Web Callbacks.

If this processing is not desired, then our determination process can be affected 
by setting the Queue access to N for any that you don’t want. This can be done 
for the whole site, a specific user, etc., per User Profile functionality.

9. Enable or disable automatic launching of the client-side plugin for media tasks.

Select Yes to enable automatic launching of the client-side plugin; otherwise, 
select No.

Normally, the client plug-ins are loaded based on the media types each user is 
eligible to work on. The mentality being that there’s no sense in launching 
Softphone, for example, if the user cannot even work on any telephony work.

Just in case there are situations in which we need a particular client plug-in 
loaded regardless of our determination, these overrides were provided.

To enable or disable access to... Set this profile option...

Inbound Email IEU: Queue: Inbound Email

Inbound Telephony IEU: Queue: Inbound Telephony

Outbound Telephony IEU: Queue: Outbound Telephony

Web Callback IEU: Queue: Web Callback
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If any override is set to Y, then we’ll load it even if we don’t think we need to. 
Setting it to N is ignored.

10. Modify the order of the queues displayed on the Oracle Universal Work Queue 
desktop.

For each IEU: Queue Order profile option, select a value between 1 and 26 to set 
the order of the queue. Queues are displayed in ascending order of the profile 
option value on the Oracle Universal Work Queue desktop.

11. From the File menu, choose Save.

Guidelines
In the following example, all users at this site have access to telephony media and 
email media by default. 

To automatically launch... Set this profile option...

eMail Center client IEU: Media: Email

Softphone IEU: Media: Telephony
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See Also
■  Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Oracle Applications User Account for an Employee

■ Creating a CRM Resource for an Employee

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

Creating a CRM Resource for an Employee
Use this procedure to create a Customer Relationship Management (CRM) resource 
based on a person in Oracle Human Resource Management Systems (HRMS).

Prerequisites
❏ Review Oracle CRM Foundation Concepts and Procedures.

❏ Obtain an Oracle Applications user account with access to the JTF_RESOURCE_
MANAGER (CRM Resource Manager) responsibility.
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Steps
1. If necessary, select the CRM Resource Manager responsibility.

2. In the Navigator window, on the Functions tab, choose Maintain Resources > 
Import Resources.

The Selection Criteria window appears.

3. In the Resource Category field, select Employee.

4. Enter any additional selection criteria.

5. Click Search.

Employees that meet the search criteria are listed in the Search Results area. The 
Select check boxes for the matching employees are automatically selected.

6. Clear the Select check boxes of the employees for which you do not want to 
create a CRM resource.

7. Click Create Resource.

The Default Values window appears. Use the Default Values window to apply a 
(Resource) Start Date, (Resource) End Date, Role, Role Start Date, and Role End 
Date to the resources that you want to create. You can also add or modify this 
information in the resource details later.

8. To apply default values to the selected resources, enter the information and then 
click OK; otherwise click Cancel.

The Selected Resources window appears. A transaction number is associated 
with each resource created during this transactions. More than one resource can 
have the same transaction number. In the Comments field, "New Record" 
indicates that a new resource will be created for the employee.

 The Select check boxes for the matching employees are automatically selected.

9. Clear the Select check boxes of the employees for which you do not want to 
create a CRM resource.

10. To confirm the creation of the resources, click Save Resources.

11. To view the details for a resource, click Details.

Guidelines
In the following example, the selection criteria for creating a resource is:

■ Resource Category: Employee
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■ (Employee) Number: 821709

The Search Results area lists Newton Taliaferro, an employee in Oracle HRMS.

The resource details show the name of the employee and the user account 
associated with the employee. Every CRM resource has a resource number (see the 
Number field in the Resource window). If resource information is imported based 
on an employee in Oracle HRMS, then the CRM resource also has a transaction 
number (see the Transaction Number fields in the Resource window). 
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See Also
■  Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Oracle Applications User Account for an Employee

■ Configuring Universal Work Queue Profile Options for a User

■ Configuring Interaction Center Roles and Parameters for a CRM Resource

Configuring Interaction Center Roles and Parameters for a CRM Resource
Use this procedure to configure the interaction center roles and parameters for a 
CRM (Customer Relationship Management) resource. You need to specify the 
following information for the CRM resource:

■ CRM roles
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■ Interaction center server group

■ Telephony parameters

■ Email parameters

Prerequisites
❏ Review Oracle CRM Foundation Concepts and Procedures.

❏ Obtain an Oracle Applications user account with access to the JTF_RESOURCE_
MANGER (CRM Resource Manager) responsibility.

Steps
1. If necessary, select the CRM Resource Manager responsibility.

2. In the Navigator window, on the Functions tab, choose Maintain Resources > 
Resources.

The Find window appears.

3. Enter any additional selection criteria.

4. Click Search.

The Resource window is displayed.

5. In the Roles tab, assign an interaction center role.

a. In the Role Type field, select Callcenter.

b. In the Role field, select the role.

The list of available roles is determined by the selected role type.

Guidelines
In the following example, Newton Taliaferro has a role of Call Center Agent. 
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6. In the Interaction Center tab, specify the interaction center parameters.

a. In the Interaction Center field, select the interaction center server group for 
this interaction center resource.

b. For telephony:

The telephony parameters that are required and the values to specify 
depend on the types of switch and CTI middleware in use in the interaction 
center.

The following tables provide specific instructions for each supported 
switch-middleware combination.

Telephony Parameters for Lucent Definity with CT-Connect
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Telephony Parameters for Lucent Definity with Cisco ICM CTI Server (GeoTel)

Telephony Parameters for Nortel Meridian or Symposium Call Center Server with 
CT-Connect

Telephony Parameters for Nortel Meridian with Cisco ICM CTI Server (GeoTel)

Telephony Parameters for Aspect with Cisco ICM CTI Server

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, if any, as defined in the PBX 
admin.

34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 34181

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 34181

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 1 (Require only when the switch is in login ID mode) 
Agent’s ACD login ID, as defined in the PBX admin

1001

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 1001

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 1001
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Telephony Parameters for Siemens Hicom with CT-Connect

Telephony Parameters for Alcatel 4400 with CT-Connect

c. For email:

From the drop-down list in the Email Account field, select the desired 
Email Account. Select Default from the drop-down list for the Parameter 
field and click the Value field to select the default value (IEM_DEFAULT_
VALUE).

In the Roles tab, select Call Center from the drop-down list for Role Type 
and select Call Center Agent or Call Center Supervisor or Call Center 
Manager from the drop-down list for Roles. This is required for integration 
with the Routing Server.

7. From the File menu, choose Save.

In the following example, the interaction center server group called Robert_Lucent_
QA is assigned to the resource.

ACD Queue Agent’s skill group number, as defined in the PBX 
admin.

46

Field Name Description Sample Value

ACD Data 2 Agent’s ACD login ID, as defined in the PBX admin. 40027

Field Name Description Sample Value

ACD Data 1 Agent’s ACD password, as defined in the PBX admin. 0000

ACD Data 2 Agent phone number, as defined in the PBX admin. 3551

ACD Queue Agent’s processing group number, as defined in the PBX 
admin.

3700

Note: Use the default values for all tabs except the Interaction 
Center tab and the Roles tab. Do not perform any changes to the 
other tabs unless explicitly directed to do so.

Field Name Description Sample Value
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See Also
■  Creating an Employee in Oracle Human Resource Management Systems

■ Creating an Oracle Applications User Account for an Employee

■ Configuring Universal Work Queue Profile Options for a User

■ Creating a CRM Resource for an Employee

Configuring Call Routing
The call routing server consists of three components: classification, routing, and 
workflow.

Prerequisites
■ Configure employees in Oracle Human Resources Management System 

(HRMS).
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■ Set up the employees as CRM Resources and configure them as Call Center 
Resources in Resource Manager.

■ Configure the Routing Server in the Server Locator window.

Setting Up Routing for Inbound Calls
The Routing Server is the server process for the routing component of the Oracle 
interaction center. The Routing Server is used in the following scenarios:

■ With Inbound Telephony only if you are running Oracle Telephony Manager in 
the active routing mode

■ With Inbound eMail in Oracle eMail Center

The Oracle routing module has two basic types of routing which are used for 
different situations based on the requirements of the configuration: rules based 
routing and workflow based routing.
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Setting Up Routing for Inbound Calls and Email
Use the steps in the following chart to set up routing. The Window Names(s) 
column shows you in which window(s) to perform the step, and whether the 
window is available only if you use a specific responsibility or product. The 
Required column shows whether the step is required, optional, required with 
defaults, or conditionally required. The chart also indicates where you may read 
detailed instructions about the setup step.

Defining Routing Classifications
Classifications specify which business application is launched on the agent desktop 
and how an interaction is listed in the UWQ screen. Classifications are of two types: 
literal and database procedure. A literal classification assigns the string specified to 
be the classification of an interaction. A database procedure classification derives 
the classification value from a stored procedure and then assigns it to an interaction. 

Step 
Number Required? OTM Setup Step Description Window Name(s)

❏ Step 1 Required Define the classifications.

See: Defining Routing Classifications

Classification 
Administration window

❏ Step 2 Required 
only for 
static 
routing

Define a group.

See: Defining Groups

Define Groups window; 
Dynamic Groups window

❏ Step 3 Required Define a route.

See: Defining Routes

Routing Administration 
window

❏ Step 4 Required Define the route priorities.

See: Defining Route Priorities

Routing Priority window

❏ Step 5 Required 
only for 
workflow 
based 
routing

Set up Workflow Based Routing for 
Inbound Calls and Email

See: Setting Up Workflow-Based Routing for 
Inbound Calls and Email
Implementing Oracle Telephony Manager 49



Setting Up Oracle Telephony Manager
Every classification is defined by a set of rules. These rules define the conditions 
under which the classification occurs. For example, if Customer Name=Oracle 
Corporation and DNIS=18005551234, then the classification=Gold Support.

If multiple rules are associated with a classification, all the rules must be satisfied 
for the classification to be considered a match. Every classification rule has a Key 
and a Value whose relationship is defined by one of the available Operations (=, !=, 
>, >=, <, <=).

Routing Classification Engine

For procedures, see:

■ Defining a Literal Classification

Note: Routing Classification is different from Email Classification. 
Email classification is the intent of the email. Routing Classification 
determines how an interaction is tracked in UWQ and Business 
Intelligence, and which business application is popped when the 
media arrives on the desktop.
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■ Defining a Database Procedure Classification

Defining a Literal Classification  

Use this procedure to define a literal classification.

Prerequisites
None

Steps
1. Navigate to the Classification Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Classification Administration.

The Classification Administration window appears.

2. If necessary, choose File > New.

3. In the Classification Definition area, define the classification.

a. Enter a unique name to describe the classification.

b. From the Type list, select Literal.

c. In the Time Out field, enter the number of minutes you want to use as your 
time out period.

After a media item is routed, it waits in the OTM queues for one of the 
agents in the group to become available. The Time Out field sets the 
maximum length of time that the media item waits in the OTM queues. By 
the end of that period, if an agent does not become available, the media 
item is sent back to the Routing server to be re-routed to another group of 
agents. The Time Out field is set in minutes.

For inbound email, if you do not want the email to be rerouted for a long 
period, Oracle recommends that you enter the number 100000 in this field.

d. Choose the default Application Database.

See the graphic below for an example.
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Classification Administration Window: Classification Definition area

4. On the Classification Rules tab, define the rules for classifications. You can 
define multiple rules for a classification. The Classification Engine used "AND" 
relations to evaluate thee rules.

a. From the Key list, select a key.

b. From the Operation list, select an operator.

c. Enter the value for the selected key.

5. From the File menu, choose Save.

Defining a Database Procedure Classification  

Use this procedure to define a database procedure classification.

Prerequisites
None

Steps
1. Navigate to the Classification Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Classification Administration.

The Classification Administration window appears.

2. In the Classification Definition area, define the classification.

a. Enter the name of the database PLSQL function that will determine the 
classification of the media item, for example, GET_CLASSIFICATION_
FROM_SUBJECT. The function should return the value for Classification.
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b. From the Type list, select Database Procedure.

c. In the Time Out field, enter the number of minutes you want to use as your 
time out period.

After a media item is routed, it waits in the OTM queues for one of the 
agents in the group to become available. The Time Out field sets the 
maximum length of time that the media item waits in the OTM queues. By 
the end of that period, if an agent does not become available, the media 
item is sent back to the Routing server to be re-routed to another group of 
agents. The Time Out field is set in minutes.

For inbound email, if you do not want the email to be rerouted for a long 
period, Oracle recommends that you enter the number 100000 in this field.

d. Choose the default Application Database.

e. If the following condition is true, select Non Application Database:

The PL/SQL procedure that determines the classification is stored in the 
Non Applications database. Also, enter a Database Driver and Database 
URL for the Non Application database.

3. On the Classification Rules tab, define the rules for classification. You can define 
multiple rules for a classification. The Classification Engine uses "AND" 
relations to evaluate these rules.

a. From the Key list, select a key.

b. From the Operation list, select an operator.

c. Enter the Value for the selected key.

4. In the Classification Parameters tab, enter the following parameters:

Parameter: The name of the parameter for the procedure.

Value: Choose the Value from the list of values, or enter a custom value for 
this parameter.

Data Type: Choose the Data Type of the parameter from the list of values.

Direction: Choose the direction of the parameter from the list of values.

Note: The value entered in the Classification field is not verified 
against the stored procedures. Be sure to enter the correct 
procedure name.
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Sequence: A generated number that indicates the position of the parameter 
in the PL/SQL procedure. Verify that the accuracy of the parameter 
Sequence.

Define all parameters for the procedure.

5. From the File menu, choose Save.

Defining Groups
There are two types of groups: static and dynamic. A static group requires that you 
manually manage the group membership. In a dynamic group, group membership 
is managed automatically as the result of a SQL query.

For procedures, see:

■ Defining a Static Group

■ Defining a Dynamic Group

Defining a Static Group  

Use this procedure to configure a static group.

Prerequisites
None

Steps
1. Navigate to the Define Groups window. You can also access the Define Groups 

form from the Resource Manager Responsibility.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

b. Click Static Groups.

The Define Groups window appears.

2. In the Name field, enter a unique descriptive name for the group.
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3. In the Active Dates area, select or enter the Start Date.

4. To assign agents exclusively to this group, check the Exclusive Flag box. This 
means the agent may not be a member of any other group.

5. Click the Members tab.

6. In the Category field, select Employee from the list of values.

7. In the Number field, select the resource number of the appropriate agent. You 
can assign as many group members as you want.

The Name and Operating Unit fields are populated automatically.

8. Click the Usages tab.

9. In the Usage field, select Call Center from the list of values.

10. Optionally, if you want to define this group as a sub-group of another static 
group, click the Relations tab.

a. Select the Group Number from the list of values in the Group Number 
field.

b. In the Relation Type field, select the default value Parent Group.

c. In the Active Dates area, select or enter the Start Date.

Note: The Accounting Code and Email Address fields are not 
required.

Caution: Enter an End Date only if you want to terminate the 
group. If you do not have at least one active group, the routing will 
fail.

Note: When defining a static/dynamic group for Routing, the 
usage of the group should be set to “Call Center” so that the group 
will be available in the Routing Admin LOV for static/dynamic 
groups.
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11. Select File > Save.

Defining a Dynamic Group  

Use this procedure to configure a dynamic group for routing.

Prerequisites
None

Steps
1. Navigate to the Dynamic Groups window. You can also access the Dynamic 

Groups form from the Resource Manager Responsibility.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

b. Click Dynamic Groups.

The Dynamic Groups window appears.

2. If necessary, choose File > New.

3. Enter a unique name for the group.

4. In the Usage field, select Call Center from the list of values.

5. Optionally, enter a free text description of the group.

6. In the Active Dates area, select or enter the Start Date. 

Caution: Enter an End Date only if you want to terminate the 
relation between the parent group and the sub-group.

Note: When defining a static/dynamic group for Routing, the 
usage of the group should be set to “Call Center” so that the group 
will be available in the Routing Admin LOV for static/dynamic 
groups.
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7. Enter the SQL statement that selects the members of the group. The SQL 
statement must return only a list of resource IDs.

8. Click Check Syntax.

If the SQL statement is invalid, then an error message appears. If the SQL 
statement is valid, then no message appears. This does not check that the return 
values are valid, only that the SQL is well formed.

9. From the File menu, choose Save.

Defining Routes
A route definition identifies the potential groups or members to which an 
interaction may be routed and the parameters (such as Email User Name or 
Telephony DNIS) to be used in determining the destination of the interaction.

There are two types of rules-based routing, static and dynamic. Static routing is 
faster, but dynamic routing is more flexible.

Static routing consists of rules defined in the routing administration form, which 
then direct the interaction to either a static or a dynamic group. An example of a 
static route would be “if the email user name = support then route to Group A”. 
Group A could be either a static group or a dynamic group. As defined in the 
previous section, a static group is cached by the routing server and a dynamic 
group is evaluated by a SQL query.

Dynamic routing consists of rules defined in the routing administration form, which 
then direct the email to either a PL/SQL procedure or the routing workflow.   The 
rule itself is similar to static routing, but the destination of the rule is different. An 
example of the first type would be “if the email user name = support then route to 
the agents returned by the PL/SQL procedure ‘CUST_GET_AGENTS’”.

An example of using the routing workflow would be “if the email user name = 
support then route to the agents returned by the routing workflow ‘CCT_
ROUTINGWORKFLOW_PUB.LAUNCH_WORKFLOW_VERSION5’ “.

For procedures, see:

■ Defining a Static Route

Caution: Enter an End Date only if you want to terminate the 
group. If you do not have at least one active group, the routing will 
fail.
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■ Defining a Dynamic Route

Defining a Static Route  

Use this procedure to define a static route.

Prerequisites
Define a static group or a dynamic group. For more information, see Defining 
Groups.

Steps
1. Navigate to the Routing Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Server Administration.

The Routing Administration window appears.

2. If necessary, choose File > New.

3. In the Route Definition area:

a. Enter a unique name to describe the route.

b. From the Route Type list, select Static.

c. In the Default Destination field, select a group (static or dynamic) from the 
list of values.

d. Optionally, enter the free text Description of the static route.

e. For static routes, select the default Application Database.

4. On the Route Rules tab, define the rules for the route. You can define multiple 
rules for a route. Routing Server uses "AND" relations to evaluate these rules.

a. From the Key list, select a key (for example, Email User Name).

b. Enter the value for the selected key (for example, Support).

Note: If the routing server cannot determine agents from the 
defined destinations, then the server routes the media item to the 
agents defined in the Default Destination.
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Routing Administration Window: Route Definition Area

5. On the Route Destinations tab, select the static groups or dynamic groups to 
which email may be routed.

6. From the File menu, choose Save.

Defining a Dynamic Route  

Use this procedure to define a dynamic route.

Prerequisites
None

Steps
1. Navigate to the Routing Administration window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Administration.

The Routing Administration window appears.

2. If necessary, choose File > New.

3. In the Route Definition area, identify the route.

a. Enter a unique name to describe the route.

Note: Chaining rules is only available for ‘and’ relations. For 
example, a rule can be “if X=Y and A=B” but not “if X=Y or A=B”.
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b. From the Route Type list, select Dynamic.

c. In the Default Destination field, select a group (static or dynamic) from the 
list of values.

d. Optionally, enter a description of the dynamic route.

e. If either of the following conditions is true, select Application Database:

The PL/SQL procedure that is the route destination is stored in the Oracle 
Applications database.

OR

The routing workflow is the route destination.

f. If the following condition is true, select Non Application Database: The 
PL/SQL procedure that is the route destination is stored in the Non 
Applications database. Also, enter a Database Driver and Database URL 
for the Non Application database.

Routing Administration Window: Route Definition Area

4. On the Route Rules tab, define the rules for the route. You can define multiple 
rules for a route. Routing Server uses "AND" relations to evaluate these rules.

a. From the Key list, select a key (for example, Email User Name).

b. Enter the value for the selected key (for example, Support).

Note: If the routing server cannot determine agents from the 
defined destinations, then the server routes the MEDIA ITEM to the 
agents defined in the Default Destination.
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5. On the Route Destinations tab:

a. In the Dynamic Destination area, enter the name of the custom procedure 
(Package.Procedure) that will be used to derive the list of agents for this 
email. The custom procedure must have an output parameter for returning 
the list of agents. The parameter must return nothing but a semi-colon 
delimited list of agents.

OR

Select the routing workflow from LOV.

b. If you are using a custom procedure, in the Procedure Parameters area, 
enter the procedure parameters. Doing this allows the system to know 
about each input and output parameter for your custom procedure.

Parameter: The name of the parameter for the procedure (either input 
and/or output).

Value: Choose the Value from the list of values, or enter a custom value for 
this parameter.

Data Type: Choose the Data Type of the parameter from the list of values.

Direction: Choose the direction of the parameter from the list of values to 
determine if it is an input and/or output parameter. 

Sequence: A generated number that indicates the position of the parameter 
in the PL/SQL procedure. Verify that the accuracy of the parameter 
Sequence.

Define all parameters for the procedure.

6. From the File menu, choose Save.

See also:
Setting up Workflow Based Routing for Inbound Calls and Email

Note: One of the parameters for the custom procedure must be an 
output parameter returning the list of agents. From the LOV, select 
occtAgentID as the value for this parameter. This parameter must 
return only a semi-colon delimited list of agents.
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Defining Route Priorities
You can define and change the priority of route definitions. Logically, the route 
rules will be evaluated in order of priority, starting with number 1. The first route 
rule which evaluates as true will determine the routing destination - starting with 
number 1, then number 2, and so on.

Changing the priority of a route affects the priority level of other routes. If you 
increase the priority of a route, then the priorities of all the routes with a priority 
equal to or greater than the original decrease by one. For example, if you increase 3 
to 6, then the original 4 decreases to 3, the original 5 decreases to 4, the original 6 
decreases to 5. If you decrease the priority of a route, then the priority of all the 
routes with a priority equal to or less than the original priority increases by one. For 
example, if you decrease 6 to 3, then the original 3 increases to 4, the original 4 
increases to 5, and the original 5 increases to 6.

Use the following procedure to set the priority for a route.

Prerequisites
None

Steps
1. Navigate to the Routing Priority window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Routing Priority Administration.

The Routing Priority window appears.

2. From the Priority list of values, select a priority.

3. Click Change Priority.

4. From the File menu, choose Save.

Setting Up Workflow-Based Routing for Inbound Calls and Email
Workflow based routing is the most flexible routing. This is full-function routing, 
which relies upon the database and uses pre-defined nodes that access business 
data from the Oracle business applications.

Note: By default, newly defined routes have the lowest priority 
among the existing routes.
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All routing information about the interaction is available in key-value pairs. Media 
data (for example, ANI: 655-3458 or MediaType: Email) and IVR data (for example, 
BugID: 6091549) are available to nodes. The nodes perform logic in a workflow that 
determines the recipients of a call and routes the call to those recipients.

Example 1: If you want to route a call to the agent who has a detailed knowledge of 
a particular product, you could create that functionality with the workflow. A 
workflow node that takes the Customer Product ID and returns a list of agents 
associated with that product within the CRM Territory Manager is pre-built and 
shipped with this product. Since that node already exists, it would be dragged into 
the workflow and dropped in to create the desired logic.

Example 2: You can also create a custom node that performs most any action you 
can write into a PL/SQL function, for example, to identify all agents who have been 
with a company more than one year. In this example, a custom PL/SQL procedure 
could compare today’s date with a list of agents from the Human Resources 
database. The result could then be wrapped into a workflow node, saved and 
dropped into future workflows.

Advantages:

■ Pre-built nodes with pre-built integration to CRM

■ Drag and drop functionality

■ Workflow engine, so there is a visible representation of the logic

■ Can be used to perform any type of complex logic

■ Able to be customized, so a customer can write their own nodes

■ Little technical ability necessary to configure nodes.

Disadvantages:

■ Request must travel to the database and back

■ Normally has an overhead of at least 50ms

■ Technical skill needed to write custom nodes

With Oracle Workflow Builder 2.5, you can use drag-and-drop routing functions to 
implement and administer the Call Routing screen. 

To create and configure a route path using the Oracle Workflow Builder-based Call 
Routing screen, you need to have a thorough understanding of Oracle Workflow 
Builder.
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All Oracle Workflow Builder processes are associated with an item type. An item 
type can include one or more processes. When you save your work in Oracle 
Workflow Builder, you actually save everything associated with the item type that is 
currently selected. You can save an item type to a database or a flat file, and 
similarly load an item type into Oracle Workflow Builder from a database or a flat 
file. Opening an item type automatically retrieves all the attributes, messages, 
lookups, notifications, functions, and processes associated with that item type.

See:

■ Accessing the Call Route Item Type

■ Applying a Pre-Defined Route

■ Running a Pre-Defined Routing Process

■ Modifying a Process

■ Designating Start and End Activities

■ Adding a New Node to a Process

■ Creating a New Process Route

■ Administering Call Routing Filters

■ Setting Time and Date Rules

■ Deriving Rules for the Customer Initialization Phase

■ Deriving Rules for the Customer Product Initialization Phase

■ Deriving Rules for the Product Initialization Phase

■ Deriving Rules for Telesales Routing

■ Deriving Rules for Banking Center Routing

Accessing the Call Route Item Type  

To open the Oracle Workflow Builder Call Route item type, use the following 
procedure.

Prerequisites
None

Steps
1. Launch Oracle Workflow Builder.
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2. Open the database connection by entering the username, password and connect 
string for the database, then click OK. 

3. From the Show Item Types window, choose Call Route from the Hidden 
section. Click Show. 

Call Route should appear on the Visible section.

4. Click OK.

Applying a Pre-Defined Route  

Oracle Workflow Builder includes routing process examples that you can apply as 
your interaction center routing process or you can use as templates to build your 
own routing processes.

Use this procedure to access a pre-defined routing process.

Prerequisite
None

Steps
1. From the navigator tree, click Call Route Item type.

2. Expand the Processes folder to see a list of available pre-defined processes. 
Oracle Telephony Manager includes pre-defined example routes.

3. Double-click on the process name to view.

Running a Pre-Defined Routing Process  

To run a pre-defined routing process with Oracle Workflow Builder, use the 
following procedure.

Prerequisites
None

Steps
1. From the Call Route Item Type, drill down to the Attributes folder.

2. Double-click The Selected Process.

The Oracle Workflow Navigator Control Properties window opens.
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3. In the Default Value field, type the internal name of the process that you want 
to run.

4. Click OK.

Modifying a Process  

The Process window in Oracle Workflow Builder graphically represents the 
activities (icons) and transitions (arrows) for a particular process. Notification, 
function, and process activities make up the nodes of a process. 

If a process contains a process activity in its diagram, then that process activity is 
known as a subprocess. To display information on the subprocess in a separate 
Process window, double-click on the subprocess activity node in the parent Process 
window.

Each activity is a node, a logical step that contributes toward the completion of a 
process. Nodes contain stored procedures that operate on parameters. The 
GetAgents node routes information to a database table, invokes a stored procedure 
and returns the results.

You can drag and drop activities from the navigator tree into the Process window. 
Define transitions between activities by drawing arrows from one activity to the 
next using the secondary mouse button.

Designating Start and End Activities  

Each Oracle Workflow Builder process must have a Start activity that identifies the 
beginning point of the process. You may designate any node from which it is logical 
to begin the process as a Start activity. An End activity should return a result that 
represents the result of the completion of the process. 

Prerequisite
None

Steps
1. Right click the icon that you wish to change.

2. Choose Properties.

3. Click the Node tab.

4. Using the Start/End pull-down list, change the step in the process.
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5. Indicate whether the current node is a start or end activity in the process by 
choosing START or END, respectively. The default is NORMAL. A process may 
have multiple START and END nodes.

A Start activity is marked (Start) and has a small green arrow in its activity icon. 
An End activity is marked (End) and has a red arrow in its activity icon.

6. For an END node, if the overall process activity has a result type associated 
with it, you must also select a value for the final process result. The list of 
values for the final process result derive from the lookup type defined as the 
process activity’s result type.

Adding a New Node to a Process  

From the Oracle Workflow Builder Process window, create a new node by dragging 
and dropping a function or process activity from the navigator tree into the Process 
window. Use functions to fine-tune the route. The activity you drag must belong to 
the same data store as the process to which you drag it.

If you use the right mouse button menu New Activity in the Process window to 
create a new node, the property pages for the node appear. Select the name of the 
item type and activity in the Activities property page. If you create a node by 
dragging and dropping an activity from the navigator tree into the process window, 
then double-click on the node to display the property pages so you can further 
specify the details of the node.

If the node is a function activity that has activity attributes, you can assign values to 
those activity attributes by choosing the Attribute Values tab to display the 
Attribute Values property page.

If the node is a process activity, then a small subprocess overlay icon appears over 
the upper right corner of process activity icon. The subprocess overlay icon 
identifies the node as a subprocess within the process diagram.

Creating a New Process Route  

Use this procedure to create a new process route with Oracle Workflow Builder.

Prerequisite
None

Steps
1. Select the Processes folder and right mouse click to create a new process.
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2. When the Oracle Workflow Navigator Control Properties dialog box opens, 
select the Activities tab and:

a. Enter a unique Internal Name.

b. Enter the Display Name. 

c. Enter a Description of your new route.

d. Leave the Result Type as None.

e. Set the process to Runable.

f. Click OK.

3. From Standard Functions, drag the Start activity to the new Process window.

4. From Call Route Functions, drag the Get Agents activity to the window.

5. From Call Routing Filters, CCT Environmental Conditions, Customer 
Initialization Phase, Customer Product Initialization, Product Initialization 
Phase, and Standard Item Types, drag and drop the activities you want to use in 
routing the calls to the appropriate agent.

Administering Call Routing Filters  

Use Oracle Workflow Builder Call Routing Filters to route calls only to those agents 
who meet the filter criteria. Refer to the following table for a description of call 
routing filters.

Caution: If the selected Process is not set as Runable, Workflow 
Routing will generate an error at runtime.

Call Routing Filter Description

Competency - Language 
Filter

Ensures that only those agents who are competent in the 
language selected by the customer answer the call. Requires that 
a language selection be made at the IVRU.

1. Language competencies should be created using the Oracle 
Human Resources Manager>Competence Type form.

2. Agents should be assigned language competencies in the 
Create Employees form.

3. Requires that a language selection should be made at the 
IVRU.
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Competency - 
Knowledge Filter

Ensures that only those agents who are competent in the area of 
expertise selected by the customer answer the call. 

1. Knowledge Competencies should be created using Oracle 
Human Resources> Competencies form. These 
competencies should be assigned to Competence Type 
Knowledge using Oracle Human Resources > Competence 
Type form.

2. Agents should be assigned knowledge competencies in the 
Create Employees form.

3. Requires that an area of expertise selection be made at the 
IVRU.

Competency - Product 
Filter

Used to ensure that only those agents who are competent in the 
product selected by the customer answer the call.

1. Product Competencies should be created using Oracle 
Human Resources> Competencies form. These 
competencies should be assigned to Competence Type 
Product using Oracle Human Resources > Competence 
Type form.

2. Agents should be assigned product competencies in the 
Create Employees form.

3. Requires that a product selection be made at the IVRU.

Customer Product Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular ‘Customer Product’ 
combination answer the call. Requires that the ‘Derive Customer 
Product ID’ sub-process be completed before this activity in the 
routing workflow process.

Customer ID Filter This filter is used to ensure that only those agents who are 
assigned to handle this particular customer answer the call. 
Requires that the ‘Derive Customer ID’ sub-process be 
completed before this activity in the routing workflow process.

Problem Code Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular ‘Problem Code’ answer the 
call. Requires that a problem code selection be made at the 
IVRU.

Product ID Filter This filter is used to ensure that only those agents who are 
assigned to handle the particular product answer the call. 
Requires that the ‘Derive Product ID’ sub-process be completed 
before this activity in the routing workflow process. 

Call Routing Filter Description
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Setting Time and Date Rules  

In Oracle Workflow Builder, for each of these attributes, the relevant value is 
specified after you drag the node onto the process diagram. 

Use the following procedure to set time and date rules.

Guidelines
Refer to the following table for a description of time and date rules.

Request Owner Filter This filter is used to ensure that the call is routed to the agent 
who owns the ‘Service Request’, when the customer is calling 
about the particular ‘Service Request’. Requires that a service 
request number selection be made at the IVRU.

Agents from Dynamic 
Group Name

This filter is used to retrieve the agents returned based on the 
dynamic group_name

Agents from Dynamic 
Group Number

This filter is used to retrieve the agents based on the dynamic 
group number

Agents from static group 
name

This filter returns agents based on a static group name

Agents from static group 
number

This filter returns agents based on static group number.

Agents not in dynamic 
group name

This filter returns agents not in dynamic group name

Agents not in dynamic 
group number

This filter returns agents not in dynamic group number

Agents not in static 
group name

This filter returns agents not in static group name

Agents not in static 
group number

This filter returns agents not in static group number.

All logged in agents This filter returns a list of all logged in agents

Rule Description

Between Two Dates? If the current date falls between the start and end dates 
specified, this rule returns a Yes, otherwise it returns a No. 

Call Routing Filter Description
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Prerequisites
None

Steps
1. In the process diagram, double click on the node icon to open the node 

properties sheet.

The property page for the node opens.

2. Choose the Attribute Values tab.

The Attribute Values property page for the node appears.

3. Choose the applicable attribute or attributes and enter them in the Value field.

4. Choose Apply to save your changes or choose OK to save your changes and 
close the Property page.

Deriving Rules for the Customer Initialization Phase  

The Oracle Workflow Builder Customer initialization phase derives Customer ID 
information from the caller’s responses to the IVR. The phase is represented by the 
Derive Customer ID sub-process, which you drag onto the process diagram.

During Business Hours? If the call is received during business hours, this rule returns a 
Yes, otherwise it returns a No. 

Get Day of the Month? This rule returns the current day of the month as a number. You 
can use this rule to handle special, but not contiguous, days of 
the month differently.

Get Day of the Week? This rule returns the current day of the week. You can use this 
rule to handle weekends or certain days of the week differently.

Is It After Specified Date? If the current date is after the specified date, this rule returns a 
Yes, otherwise it returns a No. 

Is It Before Specified 
Date?

If the current date is before the specified date, this rule returns a 
Yes, otherwise it returns a No. 

Is It After Specified 
Time?

If the current time of day is after the specified time of day, this 
rule returns a Yes, otherwise it returns a No. 

Is It Before Specified 
Time?

If the current time of day is before the specified time of day, this 
rule returns a Yes, otherwise it returns a No. 

Rule Description
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You can drag the following rules for derivation of Customer ID onto the Derive 
Customer ID sub-process. You can also use these rules directly in the Routing 
process diagram.

Refer to the following table for a description of customer initialization phase rules.

Deriving Rules for the Customer Product Initialization Phase  

The Oracle Workflow Builder Customer Product initialization phase derives the 
Customer Product ID information from caller’s responses to the IVRU. The phase is 
represented by the Derive Customer Product ID sub-process, which you drag onto 
the process diagram.

You can drag the following rules for derivation of Customer Product ID onto the 
Derive Customer Product ID sub-process. You can also use these rules directly in 
the Routing process diagram.

Refer to the following table for a description of customer product initialization 
phase rules.

Rule Description

Customer ID Exists? If the customer ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Customer ID’ sub-process, will allow for a quick exit 
from the sub-process without applying any derivation rules if 
the Customer ID is already known.

Can Get Customer ID 
from Invoice Num?

If the customer ID can be derived from the Invoice Num, this 
rule derives the Customer ID and returns a Yes, otherwise it 
returns a No.

Can Get Customer ID 
from Serial Num?

If the customer ID can be derived from the Serial Num, this rule 
derives the Customer ID and returns a Yes, otherwise it returns a 
No.

Can Get Customer ID 
from System Name?

If the customer ID can be derived from the System Name, this 
rule derives the Customer ID and returns a Yes, otherwise it 
returns a No.

Rule Description

Customer Product ID 
Exists?

If the customer product ID is already known, this rule returns a 
Yes, otherwise it returns a No. Using this as the first rule in the 
Derive Customer Product ID sub-process, will allow for a quick 
exit from the sub-process without applying any derivation rules 
if the Customer Product ID is already known.
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Deriving Rules for the Product Initialization Phase  

The Oracle Workflow Builder Product initialization phase derives the Product ID 
information from the caller’s responses to the IVR. The phase is represented by the 
Derive Product ID sub-process, which you drag onto the process diagram.

You can drag the following rules for derivation of Product ID onto the Derive 
Product ID sub-process. You can also use these rules directly in the Routing process 
diagram.

Refer to the following table for a description of product initialization phase rules.

Deriving Rules for Telesales Routing   

Can Get Customer 
Product ID from 
Reference Num?

If the customer product ID can be derived from the Reference 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Can Get Customer 
Product ID from Request 
Num?

If the customer product ID can be derived from the Request 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Can Get Customer 
Product ID from Serial 
Num?

If the customer product ID can be derived from the Serial 
Number, this rule derives the Customer Product ID and returns 
a Yes, otherwise it returns a No.

Rule Description

Product ID Exists? If the product ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Product ID’ sub-process, will allow for a quick exit from 
the sub-process without applying any derivation rules if the 
Product ID is already known.

Can Get Product ID from 
Reference Num?

If the product ID can be derived from the Reference Number, 
this rule derives the Product ID and returns a Yes, otherwise it 
returns a No.

Can Get Product ID from 
Request Num?

If the product ID can be derived from the Request Number, this 
rule derives the Product ID and returns a Yes, otherwise it 
returns a No.

Can Get Product ID from 
Serial Num?

If the product ID can be derived from the Serial Number, this 
rule derives the Product ID and returns a Yes, otherwise it 
returns a No.

Rule Description
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The Oracle Workflow Builder routing functions for Oracle Telesales derive the 
Customer ID information from the caller’s responses to the IVR. The phase is 
represented by the Derive Telesales Customer ID sub-process, which you drag onto 
the process diagram.

You can drag the following rules for derivation of Customer ID onto the Derive 
Telesales Customer ID sub-process. You can also use these rules directly in the 
Routing process diagram.

Refer to the following table for a description of Oracle Telesales routing rules.

Deriving Rules for Banking Center Routing   

The Oracle Workflow Builder routing functions for Oracle Banking Center derive 
the group information from the caller’s responses to the IVR. You can also use these 
rule functions directly in the Routing process diagram.

Refer to the following table for a description of Oracle Banking Center routing rules.

Setting System Profile Options
There are no system profile options for Oracle Telephony Manager.

Rule Description

Customer ID Exists? If the Customer ID is already known, this rule returns a Yes, 
otherwise it returns a No. Using this as the first rule in the 
‘Derive Telesales Customer ID’ sub-process, will allow for a 
quick exit from the sub-process without applying any derivation 
rules if the Product ID is already known.

Rule Description

Group from Bank Branch If the group can be derived from the Bank Branch, this rule 
derives the Agent Ids based on the group.

Group from Bank ID If the group can be derived from the Bank Id, this rule derives 
the Agent Ids based on the group.

Group from Profitability If the group can be derived from profitability, this rule derives 
the Agent Ids based on the group.
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Configuring and Testing Integration Points
When implementing and troubleshooting Oracle Telephony Manager, consideration 
should be given to the PBX components being configured and operational. 
Troubleshooting should begin at the third-party CTI middleware layer and progress 
up through the stack.

It is important to verify proper configuration of the PBX CTI link and its 
communication to the CTI middleware and, subsequently, to the Oracle Call Center 
Connectors server.

In some cases, troubleshooting CTI issues must include the customer’s PBX/CTI 
engineer to ensure proper configuration on the PBX and its proprietary CTI link.

Testing an Implementation Project

Restarting the Server Monitor
If the Server Monitor goes down and you restart it, all clients of the Server Monitor 
automatically re-register with the Server Monitor and other servers. The server 
launcher also automatically reconnects when the Server Monitor restarts.

Starting Servers
When you need monitoring, Oracle suggests that you start the Server Monitor first. 
When the Server Monitor is in use, you can start the Inbound Telephony Server 
before starting Oracle Telephony Manager.

When the Server Monitor is not in use, Oracle Telephony Manager must be running 
before you can start the Inbound Telephony Server. If you start the server monitor at 
any time after startup, the monitored servers will automatically connect to it.

Monitored servers detect when the server monitor starts and by default connect to 
the server monitor within five minutes. To change this connect default value specify 
the sm_reconnect_interval parameter in the SERVER.INI file and the SMI.INI 
file.

Starting the Server Monitor
On Windows NT, Oracle recommends that you start the Server Monitor as the 
service OracleServerMonitor_ServerName. To start the server monitor in 
console window, run the batch file SM.BAT from
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   the home directory.

On UNIX, to start the server monitor, run the script file SM.SH.

Starting the Server Launcher
The server launcher performs remote startup of the server monitor. The server 
launcher is installed automatically in the installation of any interaction center 
server. The server launcher must run on every machine that a) runs any interaction 
center and telephony server and b) requires remote startup. When the server 
monitor notifies 

the server launcher, the server launcher starts an NT service on Windows NT and 
starts a background process on UNIX.

Starting the Server Monitor Command Line
To access the Server Monitor commands, you need to start another command line.

On Windows NT, run the file SMCMD.BAT.

On UNIX, run the file SMCMD.SH.

Administering Server Monitor Commands
Refer to the following table for a description of command line commands for 
administering the Server Monitor.

Command Definition

HELP Display the server monitor commands.

SHUTDOWN Shutdown the server monitor and server monitor command 
line tool.

STATUS Display server monitor status information.

GC Initiate server monitor Garbage Collect.

RSTART(serverName) Start a remote server.

RSTOP(serverName) Stop a remote server.

RSTATUS(serverName) Show the status of a remote server.

RSTATUS Display the status of all servers that are monitored by the 
server monitor.
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Auto-Restarting Servers with the Server Monitor
You can configure your servers to be re-started automatically on a crash. Currently 
only the Inbound Telephony Server, the Oracle Telephony Manager, the Oracle 
Telephony Media Controller(s), the Email Center server, the Oracle Routing 
Server(s) connect to the server monitor and can avail of this fault tolerance 
functionality. The Oracle Server Launcher must be running on every node that has 
any of the aforementioned servers connected to the server monitor. By default Server 
Monitor is configured to restart all servers automatically on a crash. To disable 
auto-restart for all servers set the parameter AUTO_RESTART_DISABLED to TRUE 
in the SM.INI file. To disable auto- restart for a specific server set the parameter 
AUTO_RESTART_DISABLED to TRUE in the servers init file (SVR.INI). Example 
configurations for init files follow:

Configuration 1 
auto_restart_disabled=true in sm.ini

Result: No server will be restarted automatically.

Configuration 2
auto_restart_disabled=false in sm.ini

auto_restart_disabled=true in ors.ini (the Oracle Routing Servers init file), auto_
restart_disabled=false in otm.ini (the Oracle Telephony Managers init file)

Result: If the Oracle Routing Server crashes, it will not be restarted automatically

Restarting a Crashed Server Application
Before you restart a crashed server application on the same server, you need to wait 
the length of time equal to the server refresh rate, which is currently one minute. If 

you restart sooner, you will receive the error message Server by name 
"ServerName" is already running. If you shut down the Windows NT 
service or, on Solaris, invoke the “shutdown” command off the command line 
interface, you do not need to wait before restarting.

RLIST Display a list of servers installed on different hosts.

STOPCMDLINE Stop the command line interface.

Command Definition
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Configuring Oracle Telephony Manager to Run in Passive Mode
Use this procedure to configure Oracle Telephony Manager to run in passive mode.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. Select the Server tab.

3. Run a query to display the instance of Oracle Telephony Manager.

4. In the Server Parameters area, set the value of the PASSIVE_MODE parameter 
to TRUE.

Configuring Oracle Telephony Manager to Run in Active Mode
Use this procedure to configure Oracle Telephony Manager to run in active mode.

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. Select the Server tab.
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3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the PASSIVE_MODE parameter 
to FALSE.

Connecting Inbound Telephony Server to Oracle Telephony Manager
Inbound Telephony Server is a server process which monitors and forwards 
inbound telephony and web callback requests to Telephony Manager Server (OTM). 
The Inbound Telephony Server is required when running OTM in active mode, 
routing inbound telephony and/or web callback requests.

To configure Inbound Telephony Server to connect to OTM, configure the parameter 
OTM_SERVER_NAME with the appropriate Telephony Manager Server name.

Configuring Oracle Telephony Manager to Run in Standalone Mode
Standalone Oracle Telephony Manager is a single server application that handles 
both media queueing and media control. Standalone configuration is suitable for 
interaction centers with fewer than 300 agents, and is easier to maintain than 
distributed configurations.

Use this procedure to configure Oracle Telephony Manager to run in standalone 
mode. 

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.
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4. In the Server Parameters area, set the value of the STANDALONE parameter to 
TRUE.

Configuring Oracle Telephony Manager to Run in Distributed Mode
Distributed configuration can support interaction centers with more than 1000 
agents, and has better scalability than standalone configuration. A distributed 
Oracle Telephony Manager system consists of one media queue server application, 
that is, Oracle Telephony Manager, and one or more media controller server 
applications, that is, Telephony Media Controller.

Use this procedure to configure Oracle Telephony Manager to run in distributed 
mode. 

Prerequisites
None

Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. Select the Server tab.

3. Run a query to display the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the STANDALONE parameter to 
FALSE.

Configuring Media Controller to Run in Distributed Mode
Use this procedure to configure Oracle Telephony Media Controller to run in 
distributed mode. 

Prerequisites
None
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Steps
1. Navigate to the Server Locator window.

a. In the Navigator window, on the Functions tab, choose Call Center Admin 
> Call Center Administration.

The Call Center Administration window opens.

b. Click Server Admin.

The Server Locator window opens.

2. Select the Server tab.

3. Run a query to display a Telephony Media Controller in the same server group 
as the Telephony Manager of interest.

4. In the Server Parameters area, set the value of the OTM_SERVER_NAME 
parameter to the server name of the Telephony Manager Server.

Connecting Oracle Telephony Manager to Routing Servers
You can configure up to three routing servers per Oracle Telephony Manager. A 
load-balancing algorithm distributes the calls among the routing servers. 

To configure Oracle Telephony Manager to connect to routing servers, configure the 
parameter ROUTING_SERVER_1, ROUTING_SERVER_2, ROUTING_SERVER_3 
with the appropriate routing server names. 
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