Skip Headers
Oracle® Database Gateway for WebSphere MQ Installation and User's Guide
11g Release 1 (11.1)

B31286-03
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Index
Index
Go to Master Index
Master Index
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

3 Requirements

This chapter provides information about the hardware and software required for the installation of Oracle Database Gateway for WebSphere MQ and the recommended online documentation. It contains the following sections:

3.1 Hardware Requirements

The following table contains the hardware requirements for Oracle Database Gateway for WebSphere MQ.

Hardware Items Required for AIX-Based Systems Required for HP 9000 Series HP_UX Required for Solaris Required for Linux/32 Required for MS Windows XP Systems Required for MS Windows 2003 Systems
CPU IBM RS/6000 AIX-Based System Processor HP 9000 Series 700 or 800 processor for HP-UX 11.0 Sun Solaris Operating System (SPARC) Processor Red Hat Linux AS 2.4 Intel Architecture 32 bit Intel Pentium III or compatible Intel Pentium or compatible
Disk space 1 GB 1 GB 1 GB 1 GB 300 MB 300 MB
Memory 256 MB 256 MB 256 MB 256 MB 256 MB 256 MB
Swap space 512 MB or twice the amount of RAM, whichever is greater 512 MB or twice the amount of RAM, whichever is greater 512 MB or twice the amount of RAM, whichever is greater 512 MB or twice the amount of RAM, whichever is greater NA NA

3.2 Software Requirements

The following table contains the software requirements for Oracle Database Gateway for WebSphere MQ.

Platform Requirement WebSphere MQ Server Software
AIX-Based Systems 64-bit only

AIX 5L version 5.3, Maintenance Level 02 or later

OS Patches:

Check with your software vendor for current maintenance requirements.

When the gateway resides on the same system as the WebSphere MQ server software, then WebSphere MQ for AIX version 5 release 5.1 or later is required. When the gateway resides on a different system than the WebSphere MQ server software, then WebSphere MQ Client for AIX version 5 release 5.1 or later is required on the gateway system.
HP 9000 Series 700 or 800 (HP-UX) 64-bit only

HP-UX 11i v2 (11.23) or HP-UX 11i v3 (11.31)

OS Patches:

Check with your software vendor for current maintenance requirements.

When the gateway resides on the same system as the WebSphere MQ server software, then WebSphere MQ for HP 9000 version 5 release 5.1 or later is required. When the gateway resides on a different system than the WebSphere MQ server software, then WebSphere MQ Client for HP 9000 version 5 release 5.1 or later is required on the gateway system.
Sun Solaris Operating System (SPARC) 32-bit OS only (32-bit or 64-bit hardware)

Solaris 9 Update 6 or laterSolaris 10

OS Patches:

Check with your software vendor for current maintenance requirements.

When the gateway resides on the same system as the WebSphere MQ server software, then WebSphere MQ for Sun Solaris version 5 release 5.1 or later is required. When the gateway resides on a different system than the WebSphere MQ server software, then WebSphere MQ Client for Sun Solaris version 5 release 5.1 or later is required on the gateway system.
Linux/32 32-bit OS only

Oracle Enterprise Linux 4.0

Oracle Enterprise Linux 5.0

Red Hat Enterprise Linux 4.0

Red Hat Enterprise Linux 5.0

SUSE Linux Enterprise Server 10.0

OS Patches:

Check with your software vendor for current maintenance requirements

When the gateway resides on the same system as the WebSphere MQ server software, then WebSphere MQ for IA Linux/32 version 5 release 5.2 or later is required. When the gateway resides on a different system than the WebSphere MQ server software, then WebSphere MQ Client for IA Linux/32 version 5 release 5.2 or later is required on the gateway system.
MS Windows XP Professional MS Windows XP Professional version 2002

The latest service pack for your operating system, MS Windows XP Professional (Service Pack 2)

When the gateway resides on the same system as the WebSphere MQ server software, or when the gateway resides on a different system than the WebSphere MQ server software, WebSphere MQ version 5.2 or later is required on the gateway system.
MS Windows 2003 Systems MS Windows 2003, Version 2003

The latest service pack for your operating system, MS Windows 2000 (Service Pack 1)

When the gateway resides on the same system as the WebSphere MQ server software, or when the gateway resides on a different system than the WebSphere MQ server software, WebSphere MQ version 5.2 or later is required on the gateway system

Set the ulimit value for the maximum number of open files per process to 1024 or greater:

prompt> ulimit -n 1024

Note:

All IBM software must be installed before the gateway software is installed. For example, if WebSphere MQ software is not installed before OG4MQ, then the product link fails.

3.3 Oracle Database

The Oracle database requires the latest patch set for Oracle Database 11g.