System Requirements

Oracle Data Provider for .NET requires the following:

  • Windows operating system

    • 32-bit: Windows Vista (Business, Enterprise, and Ultimate Editions), Windows Server 2003, Windows Server 2003 R2, Windows 2000 or Windows XP Professional Edition.

      Oracle supports 32-bit ODP.NET on x86, AMD64, and Intel EM64T processors on these operating systems.

    • 64 bit: Windows Vista x64 (Business, Enterprise, and Ultimate Editions), Windows Server 2003 x64, Windows Server 2003 R2 x64, or Windows XP x64.

      Oracle supports 32-bit ODP.NET and 64-bit ODP.NET for Windows x64 on these operating systems.

    • 64-bit: Windows Server 2003 for Itanium-based systems.

      Oracle supports 64-bit ODP.NET for Itanium on this operating system.

  • Microsoft .NET Framework 1.0 or later.

    For .NET Framework 2.0-specific features, ODP.NET 10.2.0.2.20 or later is required

    64-bit Windows platforms support only 64-bit .NET Framework for version 2.0 and higher. Thus, 64-bit ODP.NET only supports 64-bit .NET Framework 2.0 or higher. The first 64-bit ODP.NET version is 10.2.0.3.02 on both Windows x64 and Itanium.

  • Access to Oracle9i Database Release 2 or later.

  • Oracle Client release 11.1 and Oracle Net Services (included with ODP.NET Software).

Additional requirements are the following:

  • Beginning with ODP.NET 10.2.0.2, two versions of the provider are available:

    • ODP.NET for .NET Framework 1.x

    • ODP.NET for .NET Framework 2.0 and 3.0

    ODP.NET for .NET Framework 2.0 and 3.0 supports ADO.NET 1.x and higher features.

    ODP.NET for .NET Framework 2.0 supports both ADO.NET 1.x and ADO.NET 2.0 features. The API section of this guide indicates the .NET Framework requirement for each class, method, and property, in the class requirement sections and in the declarations.

  • Applications using Microsoft Enterprise Services transactions require Oracle Services for Microsoft Transaction Server release 11.1.

  • Applications using OracleXmlStream and OracleXmlType classes with schema-based XMLType require access to Oracle Database 10g release 1 (10.1) or later.

See Also: