Siebel Reports Administration Guide > Reports with Group Sections > Example—Creating a Report with a Group Break >

Creating a New Report Object Definition in Siebel Tools

Each report design normally has its own report object definition in Siebel Tools and a corresponding data supply library file. In Creating a Simple List Report the report object definition was created from scratch. In this example, you copy an existing report object definition (and children) and change some property values.

To create a new report object definition in Siebel Tools by copying

  1. In Siebel Tools, navigate to the Report object type in the Object Explorer and select the Opportunity List - Current Query report object definition in the Object List Editor.

    Lock the Report project (choose Tools > Lock Project).

  2. Choose Edit > Copy Record.

    This creates a new report object definition, with the same set of children as the original, and duplicated property settings.

  3. Change the following property settings in the new report object definition (the other property settings do not need to be changed):
    • Name. Test Group Report

      This is the name used to refer to the report structure in Siebel Tools, for instance when you add the report to the Reports menu for a view.

    • Access Base DB Name. GROUPRPT

      This specifies that GROUPRPT.rox will be the name of the report executable invoked when this report object definition is invoked from the Reports menu in a view.

    • Menu Text. Sales Stage - Test

      This is the text that will appear in the Reports menu for a view when this report is included in the view through the use of a view report object definition.

    • Template Name. GROUPRPT

      Specifies the name to be used for the generated data supply library file when the Generate Actuate Report option is invoked for this report object definition.

    • Sort Specification. Sales Stage

      Sorts the opportunity records into sales stage order, which is necessary for the group breaks to work correctly. This specification is translated into corresponding code in the datastream methods.

  4. Export to a data supply library file by choosing Tools > Utilities > Generate Actuate Report.

    This generates a data supply ROL file, named according to the value in the Template Name property, in the \Siebdev\RPTSRC\LIB folder (or equivalent on your system).

  5. Unlock the Report project.
  6. Navigate to the View object type in the Object Explorer.
  7. In the Object List Editor, locate the Opportunity List View object definition. In the Object Explorer, expand View and click on View Report.

    This is the My Opportunities view in the Opportunities screen.

  8. Lock the Oppty (SSE) project.
  9. Add a view report object definition in the Object List Editor. Enter the name "Test Group Report" (match spelling and spacing exactly) and a sequence number that is 1 greater than any other sequence number in the list.
  10. Select Repository > Compile and recompile the repository. Move the resulting SRF file to \Siebdev\OBJECTS\ENU (or the equivalent location on your system).
  11. Unlock the Oppty (SSE) project.
Siebel Reports Administration Guide