Developing and Deploying Siebel Business Applications > Getting Started with Siebel Tools > Using Siebel Tools >

Windows in Siebel Tools

Most of the work you do in Siebel Tools is through the Object Explorer Window, the Object List Editor, or the Object Properties Window. Each of these windows is described in the following sections.

Object Explorer

The Object Explorer is your starting point for working with object definitions. You use it to navigate through the Siebel object type hierarchy. It shows you the top level object types and lets you to expand them to reveal their child object types. You can also click the Flat tab to view object types listed alphabetically in a nonhierarchical structure. The Project drop-down list lets you display the object types for locked projects or a particular project only.

Not every top level object appears in the Object Explorer by default. You can display or hide object types by setting your Development Tools Options. Choose View > Options and then click the Object Explorer tab. Add or remove objects from the list of visible objects. Figure 8 shows the Object Explorer.

Figure 8. Object Explorer
Click for full size image

Object List Editor

The Object List Editor appears to the right of the Object Explorer. It lists the object definitions for the object type selected in the Object Explorer. For example, in Figure 9 the Object List Editor displays the object definitions for the Applet object type. Use the Object List Editor to create, modify, or delete object definitions.

Figure 9. Object List Editor
Click for full size image

Object Properties Window

The Properties Window displays the property values for the object definition selected in the Object List Editor. It provides you with property definitions at a glance. The property window is often more convenient than the Object List Editor when you view or edit objects that have many properties. You can show or hide the properties window by doing the following.

To show the Properties window

  • Choose View > Windows > Properties window.

To hide the Properties window

  • In the Properties window shown in Figure 10, right-click and then choose Hide.
Figure 10. Properties Window
Click for full size image


Siebel Tools includes many wizards that guide you through the process of creating new object definitions. Wizards assist you by prompting for key information necessary to define a particular object, such as an applet or a view. Then, based on the information entered, it creates the object definition and any related object definitions.

You do not have to use wizards to create objects. You can also create objects by adding records in the Object List Editor. But this requires thorough knowledge of the Siebel Object Model hierarchy. This guide uses wizards wherever possible.

To open a New Object Wizard

  1. Choose File > New Object.

    The New Object Wizards dialog box appears, as shown in the following illustration.

    Click for full size image
  2. Choose an object to create.

    The selected wizard opens.

Developing and Deploying Siebel Business Applications Copyright © 2006, Oracle. All rights reserved.