Developing and Deploying Siebel Business Applications > Getting Started in the User Interface Layer > Configuring NREC's Activity Applets >

Removing Fields (List Columns and Controls) from the User Interface

You can remove fields from the user interface using the Web Layout Editor. For each field (list columns or controls) that you do not want to be displayed, you delete it from the Web template. This unbinds the list column or control from the Web template. The objects remain intact as child objects of the applet, but they are not rendered in the user interface at run time.

To remove fields from the user interface

  1. In the Object Explorer, select the Applet object type.
  2. In the Object List Editor, select Activity Detail Applet (SCW).
  3. Lock the project locally by choosing Tools > Lock Project.
  4. Change the Project property from Activity (SCW) to NREC Configuration.

    NOTE:  You need to have your target browser set before you can open the Web Layout Editor. Read Setting Your Target Browser. Make sure the Application drop-down menu is set to All Applications.

  5. Right-click and then choose Edit Web Layout.

    The Web Layout Editor appears with the Base mode of the applet displayed.

  6. Pull down the Mode menu (in the Toolbar) and choose 3: Edit as shown in the following illustration.
    Click for full size image
  7. In the Web Layout Editor, delete the following fields: Account, Duration, and % Complete. Each field has two controls: a label (mapped to a symbolic string) and a field (mapped to a field in the database).
    1. Select a control or use Control while clicking to select multiple controls.
    2. Right-click and then choose Delete.
    3. (Optional) Move the End field to the position formerly occupied by the Duration field. To determine where to place the field, see the mock-up in Figure 15.
  8. Choose File > Save.
  9. To verify how the applet renders in the user interface, in the Web Layout Editor, right-click and then choose Preview. To turn off the preview, right-click and then choose Preview.
  10. Choose File > Close.
Developing and Deploying Siebel Business Applications Copyright © 2006, Oracle. All rights reserved.