Using Siebel Tools > About the Siebel Tools User Interface > About the Siebel Tools Menu Bar >

File Menu

Table 3 describes the options available on the File menu for repository and object management.

Table 3.  File Menu Options
Menu Option

Open Repository

When multiple repositories are present in the development directory, the menu option provides the means to open a repository other than the currently open one.
The repository chosen using File > Open Repository becomes the default repository opened each time Siebel Tools is launched.

New Object

Invokes the New Object Wizard for the creation of a list applet, form applet, chart applet, tree applet, business component, report, table, command, pick list, MVG, or view.


Closes the Object List Editor.


Saves changes in the current editing window when you are editing Layout, Menu, or Basic Scripts.

Save All

Saves changes in all open editing windows.


Imports text from an external text file into the Siebel VB Editor window. This text should be in an SBL file format. SBL format is generated when it is exported from the Siebel VB editor.


Allows you to create a text file in delimited or HTML format that lists the property values of an objects or all objects currently displayed in the Object List Editor.

Print Setup

Changes the printer and printing options for printing object visualization view diagrams.

Print Preview

Opens a print preview window for display of an object visualization view.


Prints the active object visualization view diagram.


Closes Siebel Tools.

Using Siebel Tools