Using Siebel Tools > Working With Strings and Other Locale-Specific Data >

Finding Untranslated Text Strings

You can use the Locale Management Utility to find text strings in the repository that have not been translated or need to be retranslated because the source string has changed since the last translation.

NOTE:  The LMU performs search and comparison functions at the object level, not the attribute level. Therefore, if a locale object contains multiple string attributes, the search function returns all strings contained in the locale object, even if only one of them has been translated.

To find and export untranslated strings

  1. Choose Tools > Utilities > Locale Management.

    The Locale Management dialog box appears.

  2. In the Options tab, under Languages, select the source language and the target languages.
  3. Under Objects, select the applications or projects that you want to localize.
  4. Click the Untranslated Strings tab.
  5. To display strings that have been marked as Redo, select the Report string attributes of objects marked with 'redo' flag check box.

    The Redo flag is marked when a record in the repository has been changed since the last time export occurred and therefore may need to be translated again.

    For more information about Redo, see Identifying Objects Modified Since the Last Export.

  6. Click Find Strings.

    The Locale Management Utility searches through the string attributes of objects in the selected applications or projects and displays the ones that have not been translated and, if the Report string attributes of objects marked with the 'redo' flag check box was selected, the strings that need to be retranslated are also displayed.

  7. After you find untranslated strings you can perform the following tasks:
    • Find the views that the untranslated strings belong to by clicking the Find View button.
    • Go to the parent object of the string in the Object Explorer by selecting a string, and then clicking Go To.
    • Export all untranslated strings to a .txt or .xliff file by clicking Export.
Using Siebel Tools