Using Siebel Tools > Working With Strings and Other Locale-Specific Data >

Identifying Objects Modified Since the Last Export

You can use the Locale Management Utility to identify objects that have been modified in the repository since the last time you exported strings. This is useful when your development and localization efforts occur simultaneously. It helps you keep strings in the repository sychronized with the strings that have been exported to a file for localization.

You can search for modified objects using the following two methods:

  • Base your search on a specific date.
  • Compare objects in the repository with objects in a source file, such as results.txt.

NOTE:  When you base your search on a specific date, and run the search by clicking the Start button, all records returned for a modified project are marked as "Redo," regardless of whether a particular locale attribute has changed. This is because the LMU searches for changes at the object level (the base record), not the attribute level.

To identify modified objects

  1. Choose Tools > Utilities > Locale Management.

    The Locale Management Utility appears.

  2. In the Options tab, under Languages, select a source language and a target language.
  3. Click the Modified Objects tab.
  4. Define the search criteria you want to use:
    • Select the Changed since check box and then specify a date after which you want to find modified objects.
    • Select the Different from file check box and then specify the file to compare the repository against.
  5. Do one of the following:
    • Click Start to find records that match the search criteria, display the results, and flag records returned in the search as Redo. Redo indicates that a record has been changed since the last time export occurred and therefore may need to be retranslated.
    • Click Preview to find records that match the search criteria and display the results. Preview does not mark records as Redo.
  6. After you have identified modified objects, you can perform the following tasks:
    • Click Save to save a result set in a log file.
    • Click Go To to open the Object Explorer and go to the parent object of the string or attribute.

      NOTE:  The Load button allows you to import a result set from a previously saved file. After loading the result set in the display window, you can perform Save or Goto operations on those records.

Using Siebel Tools