Using Siebel Tools > Managing Repositories >

Reviewing Information About the Current Repository

The About SRF option on the Siebel Tools Help menu provides version, compilation, and path information about the current repository.

To review information about the current repository

  • In Siebel Tools, choose Help > About SRF.

    The About Repository File window appears and displays the following information.


Internal version

Version number maintained internally at Siebel that changes only when the internal format of the SRF file changes, such as at the time of a major release. It has no significance for customer developers.

User version

Reserved for use by Siebel Anywhere, which maintains this number when kits are created that upgrade the SRF file. The value is read when a version check occurs.

Full compile option button

Select to display information about the most recent full compilation in the Compile Information fields.

Last incremental compile option button

Select to display information about the most recent incremental compilation. If there have been no incremental compilations since the last full compilation, this option button is unavailable.


Date of the last compilation—incremental or full, as specified in the option buttons.

Machine name

Name of the client computer on which the SRF file was compiled.


Language code of the language specified for user interface translation.

User name

User name (that is, the Microsoft Windows logon name) of the user who compiled the repository.


Repository name of the repository that was current when the compilation was run, generally Siebel repository.

Tools version

The version number and build number of the Siebel Tools software used to compile the repository. This is useful information for Siebel Technical Services if they are helping you in resolving a problem with your configuration.

Schema version

Database schema version of the database from which the repository was compiled.

File name.

Name and path of the SRF file being used internally to define the Siebel Tools application, generally located in C:\sea7xx\tools\objects.

Using Siebel Tools