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Introduction
This guide will help you use Actuate e.Report Designer Professional to customize, 
enhance, and create new Siebel reports.

NOTE: Actuate e.Report Designer Professional is a component of the Siebel Reports 
Server that requires a separate license. Please contact your Siebel sales 
representative for more information. 

This book will be useful primarily to people whose title or job description matches 
one of the following: 

This guide expects a familiarity with object-oriented concepts and understanding of 
the Siebel object model, including business objects, business components, and 
report object definitions.

You should also be familiar with report writing in Actuate e.Report Designer 
Professional. The Siebel object model is described in Siebel Tools Reference on the 
Siebel Bookshelf. Actuate concepts are covered in Designing e.Reports and 
Developing Advanced e.Reports in the Actuate documentation suite. This 
documentation is located on the Siebel eBusiness Third-Party Bookshelf CD-ROM 
under Actuate.

Siebel Application 
Developers 

Persons who plan, implement, and configure Siebel eBusiness 
Applications, possibly adding new functionality.

Siebel Reports 
Administrators

Persons responsible for setting up users and maintaining the 
Actuate components used with Siebel Reports Server. 
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How This Guide Is Organized
How This Guide Is Organized
The guide explains concepts used to customize and develop new Siebel reports.

The first chapters of this guide cover installing the Siebel Reports Server using 
Actuate’s e.Reporting Server and Siebel Report Server Access. The installation 
instructions cover the Microsoft Windows and the UNIX operating systems. The 
next chapter explains how the report encyclopedia is restructured to allow for better 
response time and performance of the Reports Server.

The next group of chapters, starting with Chapter 4, “Getting Started,” of this guide 
provides an overview of report implementation and describes the run-time and 
programming models.

The subsequent two chapters walk the reader through two different report 
implementation scenarios, from easiest to most comprehensive:

■ Making minor changes to library components that affect all reports

■ Creating a new report from scratch

The next group of chapters explains how to implement various advanced report 
design features:

■ Group reports

■ Master-detail reports

■ Using composite datastreams

■ Sorting records in memory for sorts on multi-value fields and many-to-many 
data

■ Incorporating graphics in reports

The next chapters of this guide focus on Smart Reports, a class of complex reports 
with special configuration issues, and parameterized reports.

Following the report implementation chapters, the next chapters describe features 
used for reporting in the Siebel Clients. Also covered in a separate chapter is 
information on the screens that users might use while using the Reports Server.
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How This Guide Is Organized
The last section of this guide includes appendices that provide reference 
information on specific libraries and methods. Also provided is reference 
information on the list of values used with Smart Reports.

NOTE: This guide does not duplicate information presented in the documentation 
provided by Actuate Software Corporation. You need to be familiar with the material 
in Using e.Reports and Developing Advanced e.Reports manuals before using this 
guide. For more information about these and other Actuate manuals, see the Siebel 
eBusiness Third-Party Bookshelf under Actuate. You will also need Actuate e.Report 
Designer Professional, Siebel Tools, and at least one Siebel application installed on 
your computer to work through the examples. Also of interest is Designing 
e.Reports, which explains how to use Actuate e.Report Designer.
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Revision History
Revision History
Siebel Reports Administration Guide, Version 7.5, Rev B

NOTE: Reports Administration Guide 7.5, Rev. A included installation information 
specifically for HP-UX platform users.

Additional Changes

■ Updated the Siebel Reports Server installation instructions in Chapter 1, 
“Installing the Siebel Reports Server for Microsoft Windows” and Chapter 2, 
“Installing the Siebel Reports Server for UNIX.”

■ Updated instructions for creating reports in Actuate e.Report Designer 
Professional in “Creating a Report Design in Actuate e.Report Designer 
Professional” sections throughout book.

Table 1. Changes Made in Rev. B for January 2003 Bookshelf

Revision Topic

Moved the installation of the Actuate 
e.Report Designer Professional and the 
Actuate e.Report Designer to end of Siebel 
Reports installation.

Chapter 1, “Installing the Siebel Reports 
Server for Microsoft Windows.”

Added back information on the Siebel 
Reports Server Utility that was originally 
included in the Siebel Server Installation 
Guide for Microsoft Windows for release 
7.0.3.

“Installing Siebel Reports Server Utility” 
on page 52.

Added an example script for the SyncOne 
business method that gives the outcome of 
running SyncOne.

“Report Business Service Input 
Parameters” on page 346.

Added information for importing the Siebel 
Reports files for Siebel Industry Applications 
during the postinstallation steps for the 
Siebel Report Server Access.

“Importing the Siebel Report Files to the 
Report Encyclopedia” on page 67 section 
in Chapter 2, “Installing the Siebel Reports 
Server for UNIX.” 
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Installing the Siebel Reports Server for
Microsoft Windows 1
This chapter describes how to install the Siebel Reports Server and related 
components. For more information, see the system requirements and supported 
platforms documentation for your Siebel application.

In Siebel 7.5, the same instance of the Siebel Reports Server allows for the 
generation of reports in multiple languages.

The Actuate e.Reporting Server no longer runs reports based on the regional settings 
of the host machine. Instead, it refers to the localemap.xml file (located in the \etc 
folder of the Actuate e.Reporting Server installation directory). For more 
information, see the “Configuring Locales” section in the Administering Actuate 
e.Reporting System manual located on the Siebel eBusiness Third-Party Bookshelf 
under Actuate.

The Siebel Reports Server can be deployed in a mixed platform environment. 
Therefore, deployments can include a Siebel Server in UNIX with a Reports Server 
in Windows, or a Siebel Server in Windows with a Reports Server in UNIX. 
However, administrators should be careful and use the appropriate instructions 
(UNIX or Windows) while installing the Reports Server in mixed environments.

The installation of the Siebel Reports Server consists of several tasks to be 
completed by the Siebel Reports Administrator. The tasks are listed below.

1 Before installing the Reports Server, set up a windows account for the Reports 
Administrator. See “Preinstallation Tasks” on page 21.

2 Install Actuate e.Reporting Server. See “Installing the Actuate e.Reporting 
Server” on page 25.

3 Install Actuate Management Console. See “Installing the Actuate Management 
Console” on page 26.

4 Install Actuate Active Portal. See “Installing the Actuate Active Portal” on 
page 28.
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5 Install Siebel Report Server Access on the same machine as the Actuate 
e.Reporting Server. See “Installing the Siebel Report Server Access” on page 30.

6 Enable the Reports Server for the Dedicated Web Client. See “Enabling the Siebel 
Reports Server with the Dedicated Web Client” on page 38. 

7 Enable the Reports Server for the Web Client. See “Enabling the Siebel Reports 
Server with the Web Client” on page 40.

8 Synchronize the Reports Administrator to the Reports Server. See 
“Synchronizing the Reports Administrator” on page 43.

9 Synchronize Reports Server users. See “Synchronizing Reports Server Users” on 
page 44.

10 Verify Siebel Reports Server from the Dedicated Web Client. See “Testing the 
Siebel Reports Server from the Dedicated Web Client” on page 45.

11 Verify Siebel Reports Server from the Web Client. See “Testing the Siebel Reports 
Server from the Web Client” on page 46.

12 Install Actuate e.Report Designer Professional (optional). See “Installing Actuate 
e.Report Designer Professional” on page 47.

13 Install Actuate e.Report Designer (optional). See “Installing Actuate e.Report 
Designer” on page 48.

14 Install Siebel Reports Server Utility. See “Installing Siebel Reports Server Utility” 
on page 52.
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About the Siebel Reports Server
About the Siebel Reports Server
In a Windows environment, the Siebel Reports Server consists of the following 
components:

■ Actuate e.Reporting Server. Generates and manages live report documents. 
Actuate e.Reporting Server also contains the Report Encyclopedia, a shared 
repository that stores report items along with related data, such as access 
privileges and request queues.

■ Actuate Management Console. Manages one or more Actuate e.Reporting Servers 
and Report Encyclopedias. Actuate Management Console also controls user 
privileges. 

The Actuate Management Console replaces the Actuate Administrator Desktop.

■ Actuate Active Portal. Provides access to the Siebel Reports Server from the World 
Wide Web using JavaScript and JavaTM Server Page (JSP) tags. Using Actuate 
Active Portal, you can access and work with reports through any Web browser.

The Actuate Active Portal replaces the Actuate ReportCast.

For more information about these Actuate products, see the Siebel eBusiness 
Third-Party Bookshelf.

■ Siebel Report Server Access. A Siebel application integration component that 
provides access to Siebel data for report generation. This component also 
includes Siebel report executables, Siebel Active Portal templates, and Active 
Portal security extension library.
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About the Siebel Reports Server
For designing reports for use in Siebel applications, you may install the following 
components on a Windows client:

■ Actuate e.Report Designer Professional (Optional). Used by professional developers 
of structured content to design, build, and distribute report object designs and 
components throughout the enterprise. The Actuate Basic Language and Actuate 
Foundation Class Library support customizing capabilities.

■ Actuate e.Report Designer (Optional). Lets you design and build reports using its 
graphical user interface. This application complements e.Report Designer 
Professional and is used by business users to design and distribute a variety of 
reports. No programming is required. This application supports both modifying 
complex reports and using components from libraries.

For more information about these Actuate products, see the Siebel eBusiness 
Third-Party Bookshelf.
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Preinstallation Tasks
Preinstallation Tasks
For important preinstallation considerations, see the section titled “Configuring an 
e.Reporting System user account” in Installing Actuate e.Reporting System guide. 
(This guide is available on the Siebel eBusiness Third-Party Bookshelf under 
Actuate.) Read this section carefully and discuss it with your system administrator 
so that an account for the Siebel Reports Server can be allocated.

Note the following information when installing the Actuate e.Reporting System:

■ Starting with Siebel 7.5, a separate license key is required when installing the 
Actuate e.Reporting Server.

If you have the Siebel Reports Server license and have not received the Actuate 
license key letter, contact Siebel Technical Support to request the Actuate license 
key referencing Alert 557: Siebel eBusiness Applications version 7.5 - Installation 
of Reports Server Software.

■ The servlet and JavaSever Page container used with the Actuate e.Reporting 
System is the Actuate HTTP service.

The Actuate HTTP service is included in the installations for the Actuate 
Management Console and the Actuate Active Portal.

With the Siebel eBusiness Application, the Actuate Management Console and 
the Actuate Active Portal can not be integrated with an application server.

■ The Actuate open security application that uses the Lightweight Directory 
Access Protocol (LDAP) is not supported for use with the Siebel eBusiness 
application.

■ With the Siebel eBusiness Application, installing the Actuate e.Reporting System 
in a cluster environment is not supported.
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Preinstallation Tasks
Before installing the Actuate components on your machine, install the Java 
Development Kit (JDK), and establish a new system variable. The JDK is required 
for Actuate e.Reporting Server, Actuate Management Console, and Actuate Active 
Portal.

NOTE: These instructions assume that the Actuate components are installed on one 
machine. If the Actuate components are installed on multiple machines make sure 
that JDK is installed on all of these machines.

To install the Java Development Kit

1 Insert the Windows Server Ancillary Programs, Language (where Language is the 
Language Pack you want to deploy) CD 1 of 3 into your CD-ROM drive.

2 In Windows Explorer, navigate to the following directory:

Thirdpty\actuate\language\dist\j2se

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click j2sdk-1_3_1_03-win.exe.

Follow the remaining installation steps from the InstallShield Wizard. After the JDK 
install is complete, an environment variable, JAVA_HOME, needs to be defined.

To set the JAVA_HOME variable

1 From the Windows Desktop, right-click My Computer and choose Properties > 
Advanced > Environment Variables.

2 Click New in System variables section.

3 In the New System Variable pop-up window, type JAVA_HOME as the Variable 
Name.

4 While still in the New System Variable pop-up window, type the path for the JDK 
(for example, C:\jdk1.3.1_03) as the Variable Value. Click OK.

5 Continue clicking OK until you exit System Properties.
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Preinstallation Tasks
At a later point, you will need to use this variable. For now, continue with the 
installation of the Actuate e.Reporting Server.

CAUTION: To install Siebel eBusiness Applications, you must have 50-100 MB of disk 
space on your system drive (usually your C: drive) even if you intend to install 
Siebel eBusiness Applications onto another drive.
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Siebel Reports Server Installation
Siebel Reports Server Installation
To achieve the best performance, Siebel Systems recommends that Actuate 
e.Reporting Server be installed on a dedicated machine. Siebel Systems also 
recommends that Actuate Active Portal and Actuate Management Console be 
installed on the same machine.

Install the Siebel Reports Server and its associated applications in the following 
order:

Server

■ Actuate e.Reporting Server

■ Actuate Management Console

■ Actuate Active Portal

■ Siebel Report Server Access

Client

■ Actuate e.Report Designer Professional (Optional)

■ Actuate e.Report Designer (Optional)

NOTE: The following installation instructions apply whether all components of the 
Siebel Reports Server are installed on the same machine or on multiple machines. 
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Siebel Reports Server Installation
Installing the Actuate e.Reporting Server
Use the following instructions to install the Actuate e.Reporting Server, accepting 
any defaults.

Siebel Systems recommends that the defaults presented during the Actuate 
e.Reporting Serve installation be accepted. If the defaults are not selected, errors 
could occur that will affect the performance of the Siebel Reports Server.

To install the Actuate e.Reporting Server

1 Insert the Windows Server Ancillary Programs, Language (where Language is the 
Language Pack you want to deploy) CD 1 of 3 into the CD-ROM drive.

2 In Windows Explorer, navigate to the following directory:

Thirdpty\actuate\language\ereportserver

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click Setup.exe.

Guidelines for the Actuate e.Reporting Server Installation
During the installation of the Actuate e.Reporting Server, you should take note of 
the following:

■ On the Setup Type screen, choose Typical.

Installing the Actuate e.Reporting System in a cluster environment (a custom 
installation) is not supported for use with Siebel applications.

■ On the Specify Profiles screen, type a services profile user name and password. 
This is the e.Reporting System user account mentioned in the “Preinstallation 
Tasks” on page 21.

Siebel Systems suggests that you accept the default to automatically start the 
Actuate e.Reporting Server when the Process Management Daemon is started.

By setting this, you will not have to manually start the e.Reporting Server after 
starting the Process Management Daemon.
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Siebel Reports Server Installation
■ On the Configure Actuate System Administration Password screen, type a user-
specified password for the Actuate system administrator.

System Administration is accessed through the Actuate Management Console.

The system administration password entered here is the one used when logging 
into the System Administration from the Management Console. The default user 
name is Administrator.

To start or stop the e.Reporting Server Services, see Administering Actuate 
e.Reporting System manual on the Siebel eBusiness Third-Party Bookshelf.

Upgrading from an Earlier Actuate e.Reporting Server Version
The Actuate utility acupgrade can be used for upgrading an e.Reporting Server 
Report Encyclopedia volume from an earlier Actuate version to the current version. 
For more information, see the “Working with e.Reporting Server utilities” chapter 
in the Administering Actuate e.Reporting System manual on the Siebel eBusiness 
Third-Party Bookshelf.

NOTE: For optimal performance, see the “Optimizing e.Reporting Server 
performance” section in the Administering Actuate e.Reporting System manual on 
the Siebel eBusiness Third-Party Bookshelf.

Installing the Actuate Management Console
Actuate Management Console offers the capability to manage one or more Actuate 
e.Reporting Servers and Report Encyclopedias.

You can install Actuate Management Console on any supported Windows machine 
on your network.

Siebel Systems recommends that the defaults presented during the Actuate 
Management Console installation be accepted. If the defaults are not selected, 
errors could occur that will affect the performance of the Siebel Reports Server.

To install the Actuate Management Console

1 Insert the Windows Server Ancillary Programs, Language (where Language is the 
Language Pack you want to deploy) CD 1 of 3 into the CD-ROM drive.
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2 Navigate to the following directory:

Thirdpty\actuate\language\mgmtconsole

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click Setup.exe.

Guidelines for the Actuate Management Console Installation
During the installation of the Actuate Management Console, you should take note 
of the following:

■ On the Setup Type screen, choose Typical.

■ On the Deployment Options screen, accept the default of using the Actuate 
HTTP service as the deployment option.

Using a different application server with the Actuate e.Reprting System is not 
supported.

■ On the same screen, accept the default to automatically configure the 
deployment choice to run this product.

■ When Next is clicked, you might see a Question dialog box stating that the 
Actuate HTTP service is not found in the location specified on the 
Deployment Options screen. 

Click Yes to allow the setup to install the Actuate HTTP service in the 
previously specified location.

■ On the Actuate HTTP Service Information screen, you can accept the default, 
8080, as the port number.

This is the port number that you will use to connect to when accessing the HTTP 
service.

You may choose to designate a different port number. For more information, see 
Installing Actuate e.Reporting System manual on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.
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■ On the Account Name screen, when specifying the account information to be 
used when running the Actuate HTTP service, type the same information used 
on the Specify Profiles screen of the Actuate e.Reporting Server installation (see 
“Guidelines for the Actuate e.Reporting Server Installation” on page 25).

■ On the Server Configuration screen, accept the Host name and port number 
defaults for the Process Management Daemon and e.Reporting Server 
Configuration.

You may choose to designate a different port number. For more information, see 
Installing Actuate e.Reporting System manual on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.

■ On the Context Path screen, accept the default of acadmin as the context path.

NOTE: Siebel Systems recommends that the context path, acadmin, not be 
changed. This context path is integrated into the Siebel application.

Installing the Actuate Active Portal
Actuate Active Portal provides access to the Siebel Reports Server from the World 
Wide Web. Using Actuate Active Portal, you can access and work with reports 
through a Web browser.

Siebel Systems recommends that the defaults presented during the Actuate Active 
Portal installation be accepted. If the defaults are not selected, errors could occur 
that will affect the performance of the Siebel Reports Server.

To install the Actuate Active Portal

1 Insert the Windows Server Ancillary Programs, Language (where Language is the 
Language Pack you want to deploy) CD 1 of 3 into the CD-ROM drive.

2 Navigate to the following directory:

Thirdpty\actuate\language\activeportal

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click Setup.exe.
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Guidelines for the Actuate Active Portal Installation
During the installation of the Actuate Active Portal, you should take note of the 
following:

■ On the Setup Type screen, choose Typical.

■ On the Deployment Options screen, accept the default of using the Actuate 
HTTP service as the deployment option.

Using a different application server with the Actuate e.Reprting System is not 
supported.

■ On the same screen, accept the default to automatically configure the 
deployment choice to run this product.

■ When Next is clicked, you might see a Question dialog box stating that the 
Actuate HTTP service already exists and where the installation is located. 

If installing Active Portal on the same machine as the Management Console, 
click Yes to use the existing installation of the Actuate HTTP service.

■ On the e.Reporting Server Information screen, you can accept the default, 8000, 
as the port number.

The host name and the port number are used by Active Portal to contact the 
e.Reporting Server.

You may choose to designate a different port number. For more information, see 
Installing Actuate e.Reporting System manual on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.

■ On the Context Path screen, accept the default of acweb as the context path.

NOTE: Siebel Systems recommends that the context path, acweb, not be changed. 
This context path is integrated into the Siebel application. If changed, you will 
not be able to view reports over the Internet.
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Installing the Siebel Report Server Access
Siebel Report Server Access consists of libraries used by the Actuate e.Reporting 
Server to communicate with the Siebel Server. 

You must install Siebel Report Server Access on the same machine on which you 
installed Actuate e.Reporting Server. Siebel Report Server Access will also 
automatically import report executable files into the Report Encyclopedia.

Siebel Report Server Access also contains customized Active Portal templates and 
the Active Portal Security Extension library.

Install the Siebel Report Server Access using the user account set up during the 
Actuate e.Reporting Server installation.

CAUTION: Before starting the installation, make sure that Tomcat and the Actuate 
Process Management Daemon are stopped.

To install the Siebel Report Server Access

1 Insert the Windows Server Programs, Siebel Enterprise Server, Base CD-ROM into 
the CD-ROM drive.

2 In Windows Explorer, navigate to the ses directory and double-click setup.exe. 

3 At the Installer Welcome window, click Next.

The installer prompts you to choose the installation directory for the Siebel 
application.

By default, setup installs Siebel Server software in the C:\ drive in a directory 
named sea7xx. If desired, you may choose a different drive for installation.
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To choose a different directory

■ Click Browse. 

or

■ Type the drive and directory location that you recorded in Appendix A, 
“Deployment Planning Worksheet” of the Siebel Server Installation Guide for 
the operating system you are using.

NOTE: This directory name must not contain spaces, although underscores are 
allowed.

4 Click Next. 

The installer prompts you to select the component that you want to install.

5 Choose from the following options:

■ Install all the servers for which your organization has a license key at once 
by selecting all the check boxes.

CAUTION: Some products installable through the All function have 
preinstallation requirements, which if not met, will make their installation 
pointless. Before selecting the All function, review the installation 
instructions for each component you plan to install.

or

■ Select just the Siebel Report Server Access for installation and configuration. 
(You would have installed and configured the other server components 
individually before installing the Siebel Report Server Access.)

Click Next.

NOTE: If you install all licensed components at once, the SES Installer and the 
Siebel Software Configuration Wizard will prompt you for the installation 
parameters of each component individually and in the sequence required.

The installer prompts you to select the type of installation setup you prefer.
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6 Choose the Typical setup option and click Next.

NOTE: There are three options (Typical, Compact, and Custom) available from the 
Setup Options screen. For the Siebel Reports Server, only Typical is a valid 
selection.

The Installer language selection screen appears. 

7 Confirm the Language Pack you are installing for the Siebel Report Server Access 
and click Next. 

Servers are installed, at a minimum, with a base language and, optionally, with 
one or more additional languages.

NOTE: Unless your database is Unicode enabled, Siebel Systems does not support 
installation of any language other than U.S. English on top of a base Japanese, 
Simplified Chinese, Traditional Chinese, or Korean Language Pack. 

The installer program performs a validation check to make sure that installation 
prerequisites are met. 

If they are not, a prompt appears stating which installation requirement is not 
met, such as, installation of Microsoft Data Access Components (MDAC), for 
example.

The installer prompts you that the setup program will install program shortcuts 
to your Program menu with the name Siebel Enterprise Server 7.x.x.

NOTE: To override the default action and install the program icons to a different 
Program folder in the list under Existing Folders, type the name for that folder.

The installer displays the location into which it will install the Siebel Report 
Server Access and any other servers you have elected to install. It also displays 
the file size.
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8 If this is acceptable, click Next. Otherwise, click Back to adjust your installation 
parameters or location.

The installer proceeds to install the specified files.

After the install, a warning screen appears stating: 

Setup did not find the “language” language pack on the current 
media. Please insert the CD containing the “language” language 
pack and select “setup.exe” file from the “language” folder.

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

Click OK.

9 Remove the current CD from the drive and insert the Windows Server Programs, 
Siebel Enterprise Server, Language CD-ROM (where Language stands for the 
Language Pack you want to deploy, such as enu for U.S. English) into the CD-
ROM drive of the same server.

10 In Windows Explorer, navigate to the ses\language directory (where language 
stands for the Language Pack you want to deploy, such as enu for U.S. English) 
and double-click setup.exe.

After the language pack installation is complete, a warning screen appears 
stating:

Please re-insert the base CD and browse to the “setup.exe” file 
to enable setup to continue.

Click OK.

11 Reinsert the Windows Server Programs, Siebel Enterprise Server, Base CD-ROM 
into the CD-ROM drive.

12 In Windows Explorer, navigate to the ses directory and double-click setup.exe to 
continue with the Siebel Reports Server Access installation.

13 The Installer screen appears. Click Finish.
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Postinstallation Tasks for the Siebel Report Server Access
After installing Siebel Report Server Access, you must perform the following tasks:

■ “Configuring the Active Portal Template Files”

■ “Setting Up the Active Portal Security Extension Library” on page 35

■ “Setting Actuate e.Reporting Server Parameters” on page 36

NOTE: For running reports in Chinese (Simplified and Traditional), Korean and ENU 
certified languages, the Arial Unicode MS font needs to be installed under 
C:\Windows\Fonts on the Windows machine running the Reports Server.

Configuring the Active Portal Template Files
The customized Siebel Active Portal templates will overwrite the ones installed with 
Actuate Active Portal.

To configure the Active Portal Template Files

1 Navigate to the following directory under Siebel Report Server Access 
installation; for example, C:\sea75x\rptsrvr\BIN\RPTCAST\language.

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English

2 Double-click the rptcast.zip file and extract the files to the Active Portal directory 
(for example, C:\Actuate6\ActivePortal).
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3 Access the Active Portal login page by typing the URL
http://activeportalmachinename:8080/acweb/login.jsp.

Where:

activeportalmachinename = the name of the machine where Actuate Active 
Portal is installed.

You should see the Siebel logo on the Actuate Active Portal login page.

NOTE: The administrator should make sure that all users clear their browser cache 
after the template files are applied.

Setting Up the Active Portal Security Extension Library
This library enables the Siebel Reports Server Single Sign-On, which allows users to 
view reports without having to manually log onto the Reports Server. 

To set up the Active Portal Security Extension Library

1 Stop Tomcat from the Windows Services panel.

2 Navigate to the rptsrvr\BIN\RPTCAST folder (the Siebel Reports Server 
installation folder) and move the siebel.jar file to the following location:

Actuate6\Activeportal\WEB-INF\lib

3 In the same Siebel Reports Server installation folder find the swewase.dll file and 
do the following:

a Create the folder Native under Actuate6\tomcat\bin.

b Move the swewase.dll file to this folder.

4 Delete the Standalone folder in the Actuate6\tomcat\work directory. 

5 Start Tomcat.

NOTE: After setting up Active Portal Extension Library, you are no longer able to log 
into Active Portal by typing the URL http://
ActuateHTTPServiceMachineName:ActuateHTTPServicePortNumber/acweb/
login.jsp. The Actuate HTTP service port number is by default 8080.
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Setting Actuate e.Reporting Server Parameters
Siebel Systems strongly recommends that the Reports Server administrator set the 
Actuate e.Reporting Server parameter ReportingServices  - Number of Requests 
Before Recycling Processes to 100 to avoid memory leaks. 

For instructions on how to modify this Actuate e.Reporting Server parameter, see 
the section titled “Setting advanced server properties” in Administering Actuate 
e.Reporting System guide. This guide is located in PDF format on the Siebel 
eBusiness Third-Party Bookshelf under Actuate.

NOTE: You will find this and other parameters for the Actuate e.Reporting Server by 
opening the Actuate Management Console, logging into System Administration, 
selecting a Server, and selecting the Advanced tab.
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Postinstallation Tasks for the Siebel Reports Server
Perform the following postinstallation tasks to make Siebel Reports Server available 
for users on Siebel Web Clients:

■ “Synchronizing Locale-Sensitive Parameters”

■ “Changing the Time Zone on the Reports Server Machine” on page 37

■ “Enabling the Siebel Reports Server with the Dedicated Web Client” on page 38

■ “Enabling the Siebel Reports Server with the Web Client” on page 40

■ “Synchronizing the Reports Administrator” on page 43

■ “Synchronizing Reports Server Users” on page 44

■ “Testing the Siebel Reports Server from the Dedicated Web Client” on page 45

■ “Testing the Siebel Reports Server from the Web Client” on page 46

Synchronizing Locale-Sensitive Parameters
For the Reports Server to format reports based on user-specified locale, the locale 
definitions in localemap.xml file should match the equivalent parameters in the 
Siebel Application Object Manager.

For more information about locale-sensitive parameters, see Global Deployment 
Guide on the Siebel Bookshelf.

Changing the Time Zone on the Reports Server Machine
If the administrator changes the time zone on the Reports Server machine, Actuate 
services should be restarted for the changes to take effect.
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Enabling the Siebel Reports Server with the Dedicated Web Client
This section describes how to modify Siebel Web Client files, such as siebel.cfg and 
uagent.cfg, on the Dedicated Web Client to run with the Siebel Reports Server.

To configure the Siebel Application Object Manager files

1 Navigate to the BIN\language subdirectory of your Siebel eBusiness 
Applications installation directory.

Where:

language = the Siebel code for the Language Pack you installed; for example, 
ENU for U.S. English.

2 Locate and open the appropriate configuration (CFG) file.

3 Using your default text editor, edit the following parameters in the [Siebel] and 
[ActuateReports] sections.

[Siebel]

EnableFQDN = TRUE

Where:

EnableFQDN is the setting that enables the processing of requests to Web sites 
even if the user does not provide the fully qualified domain name.

FQDN = name of local host followed by domain name

Where:

FQDN stands for Fully Qualified Domain Name. An example of a fully qualified 
domain name would be ebiz.siebel.com.

For more information about EnableFQDN and FQDN, see “Editing the Web 
Server Extension Configuration File” in the Siebel Server Installation Guide for 
the operating system you are using.
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The local host is the machine where the Dedicated Web Client is installed 
(example: localhost.Siebel.com)

[ActuateReports]

EnableReportServer = TRUE

ReportServerHost = name of the Reports Server machine followed by SOAP 
(Simple Object Access Protocol) server port number (example: server1:8000).

ReportCastHost = name of the Active Portal machine followed by domain 
name and the Tomcat port number (example: server1.siebel.com:8080).

ReportCastDomain = domain name for the Active Portal machine (example: 
siebel.com).

ProtocolName = name of protocol to use for viewing reports (example: HTTP 
or HTTPS).

RoxDir = /Siebel Reports/

ConnectString = siebel.TCPIP.none.NONE://
GatewayServerName:PortNumber/EnterpriseServerName/
XXXOBJMGR_language/SiebelServerName

Where:

siebel.TCPIP = the networking protocol

none (first instance) = the encryption type chosen

NONE (second instance) = data compression method chosen

GatewayServerName = the name of your Siebel Gateway Server

PortNumber = the listening port number (default is 2320)

EnterpriseServerName = the name of your Siebel Enterprise Server

XXXOBJMGR_language = the type of Object Manager and language pack for the 
Siebel eBusiness application you are installing, for example:

SCCOBJMGR_enu for U.S. English Siebel Call Center Object Manager

SSEOBJMGR_enu for U.S. English Siebel Sales Object Manager
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SiebelServerName = the name of your Siebel Server

NOTE: When deploying the Reports Server with a load-balanced Siebel Server, the 
Reports Server must be installed separately on a machine that does not have a 
Siebel Server installed.

Enabling the Siebel Reports Server with the Web Client
This section describes how to set up the various parameters for enabling Siebel 
Reports Server for the Web client. 

To set the parameters at the component level

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 Select the component for which you need to enable Reports Server parameters.

3 Select the Component Parameters tab.

4 Set parameter values in the Current value column for the following parameters 
and Save.

NOTE: The Siebel Server has to be restarted for these parameters to take effect.

Actuate Server Enable Flag = TRUE

Actuate Server Report Server Host = name of the Reports Server machine 
followed by SOAP (Simple Object Access Protocol) server port number 
(example: server1:8000).

Actuate Server Report Cast Host = name of Active Portal machine 
followed by domain name and Tomcat port number (example: 
server1.siebel.com:8080).

Actuate Report Cast Domain = domain name for the Active Portal machine 
(example: siebel.com).

Actuate Server Network Protocol Name = name of protocol to use for 
viewing reports (example: HTTP or HTTPS).
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Actuate Server Connect String = siebel.TCPIP.none.NONE://
GatewayServerName:PortNumber/EnterpriseServerName/
XXXOBJMGR_language/SiebelServerName

Where:

siebel.TCPIP = the networking protocol

none (first instance) = the encryption type chosen

NONE (second instance) = data compression method chosen

GatewayServerName = name of your Siebel Gateway Server

PortNumber = the listening port number (default is 2320)

EnterpriseServerName = name of your Siebel Enterprise Server

XXXOBJMGR_language = type of Object Manager for the Siebel eBusiness 
application you are installing, for example:

SCCOBJMGR_enu for U.S. English Siebel Call Center Object Manager

SSEOBJMGR_enu for U.S. English Siebel Sales Object Manager

SiebelServerName = the name of your Siebel Server

NOTE: When deploying the Reports Server with a load-balanced Siebel Server, the 
Reports Server must be installed separately on a machine that does not have a 
Siebel Server installed.

Actuate Server Rox Directory = /Siebel Reports/

Actuate Server Poll Wait Limit = time limit (in seconds) after which 
polling stops for interactively run reports.
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The Actuate Server Poll Wait Limit parameter defines a duration, at the 
component level, in seconds, after which application control is returned to the 
user, regardless of whether report generation has completed or not. This 
provision avoids the client having to wait for an indefinite time period after 
submitting long-running reports.

NOTE: The administrator should advise users that they can override the 
component level setting of Actuate Server Poll Wait limit. This is done by 
choosing View > User Preferences > Behavior to set the Run Report Time Limit 
parameter from the application-level menu.

See Siebel Server Administration Guide for more information on how to modify 
application object manager parameters.

The parameters described in the following procedure must be set in the eapps.cfg 
file, found under the \BIN subdirectory of the Siebel Web Server Extensions 
installation, for the Siebel Reports sign-on to work.

To set the parameters in the eapps.cfg file

1 Navigate to the file eapps.cfg under, for example, \sea750\eappweb\bin.

2 Using a text editor, open eapps.cfg and locate the [Defaults] section.
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3 Set the following parameter values as shown below:

EnableFQDN = TRUE

Where:

EnableFQDN is the setting that enables the processing of requests to Web sites 
even if the user does not provide the fully qualified domain name.

FQDN = machine name followed by domain name

Where:

FQDN stands for Fully Qualified Domain Name. An example of a fully 
qualified domain name would be ebiz.siebel.com.

For more information about EnableFQDN and FQDN, see “Editing the Web 
Server Extension Configuration File” in the Siebel Server Installation Guide 
for the operating system you are using.

Synchronizing the Reports Administrator
The Reports Administrator must create an account on the Actuate e.Reporting 
Server, using an account name that has Siebel administrator privileges, and assign 
the administrative role to that account by using Actuate Management Console. 

NOTE: The administrator should review the Administering Actuate e.Reporting 
System manual before setting up an account for the administrator using Actuate 
Management Console.

To set up an administrator in Actuate Management Console

1 Navigating from the Start menu, open Actuate Management Console.

2 Choose Administrator as the user name, connect to an appropriate encyclopedia 
volume, type the appropriate password, and click Log In.

3 In the left pane, select Users.

4 In the right pane, click Create User.

The User Properties window appears.
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5 On the General tab, type the administrator’s login name in the name field. For 
example, type SADMIN.

Do not make an entry in the Password field, leaving the field blank.

6 Complete any other fields, as needed, and click Apply.

7 While still in the User Properties window, click the Roles tab.

8 Assign the Administrator role to the account (SADMIN) created in Step 5, and 
click OK.

To synchronize Reports Administrator on the Reports Server

1 Login to Siebel eBusiness Application as the same administrative user 
(SADMIN) and from the application level menu select View > Site Map > 
Application Administration > Reports Server Administrator Profile.

2 Do not make an entry in the Enter the current password in the Report Server 
field, leaving the field blank.

3 Type a password of your choice in the Enter New Password field and click Save.

The Report Administrator's account is synchronized on the Reports Server. The 
administrator can now synchronize the accounts of all other Siebel users.

Synchronizing Reports Server Users
Synchronization is the process of creating accounts for Siebel users on Actuate 
e.Reporting Server and is required for users to run, schedule, and view reports in 
Reports Server views.

To synchronize Reports Server users

1 Log into the Siebel eBusiness application as the Siebel Reports Administrator 
and from the application-level menu selects View > Site Map > Reports
Server > User Administration.

NOTE: The recommendation is to synchronize users in smaller buckets, 
particularly when a large number of users is synchronized. 
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2 With the first user highlighted, click Synchronize One. 

The Siebel Users window appears.

3 Type the Reports Administrator user name and password.

A confirmation message, stating that the user was successfully added to the 
Reports Server, appears in the Siebel Users window.

4 For the remaining users, click Synchronize All. 

NOTE: You will not see the Siebel Users login window again as long as you remain 
in the same view.

After the users have been synchronized, a confirmation window appears, 
displaying the total number of new user accounts added to the Reports Server. 
This confirmation message may also include the number of users already found 
to exist on the Reports Server. 

5 If users are being synchronized in smaller buckets repeat Step 4.

NOTE: If the database is refreshed, the Siebel Reports administrator should perform 
the user synchronization again to make sure that the Reports Server passwords for 
these users, which are stored in the Siebel Database, match what is stored in the 
Actuate e.Reporting Server.

Testing the Siebel Reports Server from the Dedicated Web Client
Follow the instructions below to test Siebel Reports Server from the Dedicated Web 
Client.

To test the Siebel Reports Server from the Dedicated Web Client

1 Start any Siebel eBusiness application from the Mobile Web Client (for example, 
Siebel Sales) and connect to the server. 

The application’s home page appears.

2 From the application-level menu, choose View > Site Map > Account > My 
Accounts. 
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3 From the application-level menu, select View > Reports.

4 On the drop-down list, select Account List and click Schedule. 

The Schedule Report dialog box appears.

5 Indicate that you want to schedule the report for later, specify the date, time, and 
frequency and click Finish.

6 From the application-level menu, choose View > Site Map > Reports Server > 
Schedule Requests.

The scheduled request appears in the view, indicating the scheduled date, time, 
and other information.

If the request does not appear, check the order and location in which the Siebel 
Reports Server components are installed, as described earlier in this chapter.

Testing the Siebel Reports Server from the Web Client
Follow the instructions below to test the Siebel Reports Server from the Siebel Web 
Client.

To test Siebel Reports Server from the Web Client

1 Start any Siebel eBusiness Application (for example, Siebel Sales). 

The application’s home page appears.

2 From the application-level menu, choose View > Site Map > Account > My 
Accounts. 

3 From the application-level menu, choose View > Reports.

4 On the drop-down list, select Account List and click Run Now. 

5 The program starts generating the report and displays the output in your browser 
window. 

If the report does not appear, check the order and location in which the Siebel 
Reports Server components are installed, as described earlier in this chapter.
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Installing Actuate e.Report Designer Professional
Actuate e.Report Designer Professional offers developers of structured content for 
the Windows platform the added capability of designing, building, and distributing 
report object designs and components throughout the enterprise.

You can install Actuate e.Report Designer Professional on any client machine.

NOTE: Installation of Actuate e.Report Designer Professional is not required to run 
the Siebel Reports Server.

To install Actuate e.Report Designer Professional

1 Insert the Web Client Ancillary Programs CD 1 of 2 into your CD-ROM drive of 
your chosen computer.

2 Navigate to the following directory:

Thirdpty\actuate\language\erdpro

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click Setup.exe.

For the remaining installation steps, refer to Installing e.Report Designer 
Professional release 6 on the Siebel eBusiness Third-Party Bookshelf under 
Actuate.

Postinstallation Task for Actuate e.Report Designer Professional
After Actuate e.Report Designer Professional is installed, the setting for Internal 
Basic source encoding must be set to Unicode (UCS-2LE). To make sure that Internal 
Basic source encoding is set properly, perform the following task.
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To make sure Internal Basic source encoding is set properly

1 From the Start menu, open Actuate e.Report Designer Professional.

2 From the menu, choose View > Options and click the General tab. 

3 In the Internal Basic source encoding section, make sure that Unicode (UCS-2LE) 
is selected.

Installing Actuate e.Report Designer
Actuate e.Report Designer lets developers for the Windows platform design and 
create reports, using its graphical user interface.

You may install Actuate e.Report Designer on any client machine.

NOTE: Installation of Actuate e.Report Designer is not required to run the Siebel 
Reports Server.

To install Actuate e.Report Designer

1 Insert the Web Client Ancillary Programs CD 1 of 2 into your CD-ROM drive of 
your chosen computer.

2 Navigate to the following directory:

Thirdpty\actuate\language\erd

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Double-click Setup.exe.

For the remaining installation steps, refer to Installing e.Report Designer release 
6 on the Siebel eBusiness Third-Party Bookshelf under Actuate.
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Postinstallation Tasks for Actuate e.Report Designer
The following are the postinstallation steps for Actuate e.Report Designer.

Setting Internal Basic Source Encoding
After Actuate e.Report Designer is installed, the setting for Internal Basic source 
encoding must be set to Unicode (UCS-2LE). To make sure that Internal Basic source 
encoding is set properly, perform the same task as stated earlier.

To make sure Internal Basic source encoding is set properly

1 From the Start menu, open Actuate e.Report Designer.

2 From the menu, choose View > Options and click the General tab. 

3 In the Internal Basic source encoding section, make sure that Unicode (UCS-2LE) 
is selected.

Creating Reports Using Siebel Report Libraries
To create reports using Siebel Report Libraries (sssiebel.rol file) in Actuate e.Report 
Designer, perform the following tasks.

The Actuate solution to enable Siebel reporting in Actuate e.Report Designer is 
based on two files, siebel_report_building.xml and wizard.rod.

These files reside on the system drive. The following locations are examples of 
where to locate these files:

■ C:\sea7.x.x\tools\RPTSRC\siebel_report_building.xml

■ C:\sea7.x.x\tools\RPTSRC\STANDARD\wizard.rod

Using these files, administrators can use Actuate e.Report Designer without any 
additional changes. 

You can also develop simple reports in Actuate e.Report Designer, based on new or 
existing reports.
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To create a new report in Actuate e.Report Designer

1 Open Actuate e.Report Designer.

2 Navigate to the siebel_report_building.xml file:

a From the menu, choose View > Options. 

b Click File Settings and in the Configuration file section, click browse button 
(...). 

c From the Locate Configuration File window, navigate to the 
siebel_report_building.xml file and click Open.

3 While still in the Options window, choose the Global Search Path tab.

a Click New. 

b Click browse button (...) and navigate to the following location:

C:\sea7.x.x\RPTSRC\language\LIB file

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

c Click Open.

d Click OK to close the Options window.

4 Select File > New > Siebel Report Template.

5 Include custom libraries and controls in the same manner as for Actuate e.Report 
Designer Professional.
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To enable an existing report in Actuate e.Report Designer

1 To enable existing projects, first perform Step 1 through Step 3 from “To create 
a new report in Actuate e.Report Designer”.

2 From the menu, choose File > Open to select an existing Siebel report.

NOTE: No way exists to recompile ROX files separately with the exception of 
clicking the run button from the tool bar in Actuate e.Report Designer.

Custom controls and custom code must be added in Actuate e.Report Designer 
Professional first before using them in Actuate e.Report Designer.

Adding Sorting to Reports
You can add sorting and grouping capability to a report designed with Actuate 
e.Report Designer by using a custom ROL prepared in Actuate e.Report Designer 
Professional (for example, aclist_sorteable.rol for account list report). The ROL file 
is based on slightly modified Siebel Tools-generated ROL that includes 
ssMemoryDataSorter on top of an existing DataStream (see Figure 1). This allows 
you to build entire reports enabled with wizard-based sorting and grouping.

Figure 1. Account List Report ROL File
Version 7.5, Rev B Siebel Reports Administration Guide 51



Installing the Siebel Reports Server for Microsoft Windows

Postinstallation Tasks for the Siebel Reports Server
To add sorting to a report

1 Remove the dummy (or existing DataStream) data source.

2 Choose Tools > Library Organizer and include aclist_sorteable.rol (as an 
example) that was created in Actuate e.Report Designer Professional.

3 Drag and drop the Memory Sort control in the data stream slot of the Report 
section.

4 Choose Tools > Sorting & Grouping.

5 The Grouping tab of the Sorting and Grouping dialog box displays the fields 
available for grouping. These are fields in those report tables and views that 
have not yet been specified as group keys.

6 On the left side of the dialog box, double-click the field to group, or select the 
field and click >.

7 Actuate e.Report Designer adds a grouping field, removing the field from both 
the Available Fields list and the detail frame of the report.

Installing Siebel Reports Server Utility
Siebel Reports Server Utility is an executable program that can be used to remove 
completed request notifications accumulated in the Report Encyclopedia. This 
utility should reside on the same machine where the Actuate e.Reporting Server is 
installed.

To install Siebel Reports Server Utility

1 Insert the Web Client Ancillary Programs CD 1 of 2 into your CD-ROM drive of 
your chosen computer.

2 Navigate to the following directory:

Thirdpty\actuate\language\actutil
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3 Copy actcleanup6.exe to a machine where the Actuate e.Reporting Server is 
installed.

Place the copy of actcleanup6.exe into the \bin directory of the Actuate 
e.Reporting Server, for example C:\Actuate6\Server\bin.

The usage of actcleanup6.exe is as follows:

actcleanup6 -l username1;username2;...;usernamex -d n -u login 
name -p password -m report server machine name

-l Required. Completed request notifications will be cleaned up for the list of users 
specified. User names are separated by a semicolon (;) only (no spaces). If all 
completed request notifications are to be erased, enter ALLUSERS.

-d Optional. Completed request notifications which are n days or older will be 
cleaned up. The n must represent a non-negative integer. If -d is not specified, 
all completed request notifications will be cleaned up.

-u Required. Login name of the Reports Server administrator.

-p Required. Password of the Reports Server administrator.

-m Required. Reports Server machine name.

NOTE: When -d option is used, ALLUSERS will not include user Administrator.

This program must run on a Windows machine where the Actuate e.Reporting 
Server is installed.
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This chapter describes how to install the Siebel Reports Server and related 
components. For more information, see the system requirements and supported 
platforms documentation for your Siebel application.

In Siebel 7.5, the same instance of the Siebel Reports Server allows for the 
generation of reports in multiple languages.

The Actuate e.Reporting Server no longer runs reports based on the regional settings 
of the host machine. Instead, it refers to the localemap.xml file (located in the etc 
folder of the Actuate e.Reporting Server installation directory). For more 
information, see the “Configuring Locales” section in Administering Actuate 
e.Reporting System manual located on the Siebel eBusiness Third-Party Bookshelf 
under Actuate.

The Siebel Reports Server can be deployed in a mixed platform environment. 
Therefore, deployments can include a Siebel Server in UNIX with a Reports Server 
in Windows, or a Siebel Server in Windows with a Reports Server in UNIX. 
However, administrators should be careful and use the appropriate instructions 
(UNIX or Windows) while installing the Reports Server in mixed environments.

The installation of the Siebel Reports Server consists of several tasks to be 
completed by the Siebel Reports Administrator. The tasks are listed below.

1 Before installing Siebel Reports Server, set up a UNIX account for the Reports 
Administrator. See “Preinstallation Tasks” on page 58.

2 Install Actuate e.Reporting Server. See “Installing the Actuate e.Reporting 
Server” on page 60.

3 Install Actuate Management Console. See “Installing the Actuate Management 
Console” on page 62.

4 Install Actuate Active Portal. See “Installing the Actuate Active Portal” on 
page 63.
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5 Install Siebel Report Server Access. See “Installing the Siebel Report Server 
Access” on page 64.

6 Enable the Reports Server for the Dedicated Web Client. See “Enabling the Siebel 
Reports Server with the Dedicated Web Client” on page 72.

7 Enable the Reports Server for the Web Client. See “Enabling the Siebel Reports 
Server with the Web Client” on page 75.

8 Synchronize the Reports Administrator on the Actuate e.Reporting Server. See 
“Synchronizing the Reports Administrator” on page 77.

9 Synchronize Reports Server users on the Actuate e.Reporting Server. See 
“Synchronizing Reports Server Users” on page 79.

10 Verify Siebel Reports Server on the Dedicated Web Client. See “Testing the Siebel 
Reports Server from the Dedicated Web Client” on page 80.

11 Verify Siebel Reports Server on the Web Client. See “Testing the Siebel Reports 
Server from Web Client” on page 81.
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About the Siebel Reports Server
In a UNIX environment, the Siebel Reports Server consists of the following 
components:

■ Actuate e.Reporting Server. Generates and manages live report documents. 
Actuate e.Reporting Server also contains the Report Encyclopedia, a shared 
repository that stores report items along with related data, such as access 
privileges and request queues.

■ Actuate Management Console. Manages one or more Actuate e.Reporting Servers 
and Report Encyclopedias. Actuate Management Console also controls user 
privileges. 

The Actuate Management Console replaces the Actuate Administrator Desktop.

■ Actuate Active Portal. Provides access to the Siebel Reports Server from the World 
Wide Web using JavaScript and JavaTM Server Page (JSP) tags. Using Actuate 
Active Portal, you can access and work with reports through any Web browser.

The Actuate Active Portal replaces the Actuate ReportCast.

For more information about these Actuate products, see the Siebel eBusiness 
Third-Party Bookshelf.

■ Siebel Report Server Access. A Siebel application integration component that 
provides access to Siebel data for report generation. This component also 
includes Siebel report executables, Siebel Active Portal templates, and Active 
Portal security extension library.

NOTE: In addition to these components, the administrator may also install Actuate 
e.Report Designer Professional and (optionally) Actuate e.Report Designer in a 
Windows environment.

The description of these components, their installation, and usage is available in 
Chapter 1, “Installing the Siebel Reports Server for Microsoft Windows.”
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Preinstallation Tasks
For important preinstallation considerations, see the section titled “Configuring an 
e.Reporting System user account” in Installing Actuate e.Reporting System guide for 
the operating system that you have installed. (This guide is available in PDF format 
on the Siebel eBusiness Third-Party Bookshelf under Actuate.) Read this section 
carefully and discuss it with your system administrator so that an account for the 
Siebel Reports Server can be allocated.

Note the following information when installing the Actuate e.Reporting System:

■ Starting with Siebel 7.5, a separate license key is required when installing the 
Actuate e.Reporting Server.

If you have the Siebel Reports Server license and have not received the Actuate 
license key letter, contact Siebel Technical Support to request the Actuate license 
key referencing Alert 557: Siebel eBusiness Applications version 7.5 - Installation 
of Reports Server Software.

■ The servlet and JavaSever Page container used with the Actuate e.Reporting 
System is the Actuate HTTP service.

The Actuate HTTP service is included in the installations for the Actuate 
Management Console and the Actuate Active Portal.

With the Siebel eBusiness Application, the Actuate Management Console and 
the Actuate Active Portal can not be integrated with an application server.

Before installing the Actuate components on your machine, install the Java 
Development Kit (JDK), and establish a new system variable. The JDK is required 
for Actuate e.Reporting Server, Actuate Management Console and Actuate Active 
Portal.

NOTE: These instructions assume that the Actuate components are installed on one 
machine. If the Actuate components are installed on multiple machines make sure 
that JDK is installed on all of these machines.
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To install the Java Development Kit

1 Insert the UNIX_OS Server Ancillary Programs, Language CD 1 of 2 into your CD-
ROM drive.

Where:

UNIX_OS indicates the type of UNIX being installed

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

2 Navigate to the following directory:

Thirdpty/actuate/language/dist/j2se

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

3 Depending on the type of UNIX being installed, do one of the following:

For Solaris

Enter the following command at the command prompt:

./j2sdk-1_3_1-solsparc.sh

For AIX

a Copy Java131.rte.tar to a writable directory.

b Navigate to the writable directory where Java131.rte.tar was copied.   

c Enter the following two commands at the command prompt:

❏ tar -xvf Java131.rte.tar

❏ smitty install
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Siebel Reports Server Installation
To achieve the best performance, Siebel Systems recommends that Actuate 
e.Reporting Server be installed on a dedicated machine. Siebel Systems also 
recommends that Actuate Active Portal and Actuate Management Console be 
installed on the same machine.

Install the Siebel Reports Server and its associated applications in the following 
order:

■ Actuate e.Reporting Server

■ Actuate Management Console

■ Actuate Active Portal

■ Siebel Report Server Access 

NOTE: The following installation instructions apply whether all components of the 
Siebel Reports Server are installed on the same machine or on multiple machines. 

Installing the Actuate e.Reporting Server
Use the following instructions to install the Actuate e.Reporting Server.

To install the Actuate e.Reporting Server

1 Insert the UNIX_OS Server Ancillary Programs CD 1 of 2 into your CD-ROM drive.

Where:

UNIX_OS indicates the type of UNIX being installed
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2 Navigate to the following directory:

Thirdpty/actuate/language/ereportserver

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

For the remaining installation steps, refer to Installing Actuate e.Reporting 
System manual on the Siebel eBusiness Third-Party Bookshelf under Actuate.

Steps during the installation process

Perform the following steps during the installation process:

1 Bypass all questions regarding database drivers / clients by entering n.

2 When prompted regarding the Java e.Report driver, enter y.

3 When prompted regarding X-Server, enter the number l for “Actuate supplied X-
Frame Buffer.”

NOTE: Please note that numbers 2 and  3 are required to correctly display charts in 
reports.

Actuate e.Reporting Server Postinstallation Task
After installing the Actuate e.Reporting Server, you must install TrueType fonts in 
order to view reports in PDF format. For instructions on installing TrueType fonts, 
please see the section “Using TrueType fonts” in e.Reporting for Multiple Locales 
guide. This guide is available in PDF format on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.

Below are the TrueType fonts required by Siebel reports:

■ ARIAL.TTF

■ ARIALBD.TTF

■ ARIALBI.TTF
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■ ARIALUNI.TTF

NOTE: To view reports in PDF format in Actuate 6, please make sure that you are 
using the Adobe Acrobat Reader 5.

Upgrading from an Earlier Actuate e.Reporting Server Version
The Actuate utility acupgrade can be used for upgrading an e.Reporting Server 
Report Encyclopedia volume from an earlier Actuate version to the current version. 
For more information, see the “Working with e.Reporting Server utilities” chapter 
in the Administering Actuate e.Reporting System manual on the Siebel eBusiness 
Third-Party Bookshelf.

Installing the Actuate Management Console
Actuate Management Console offers the capability to manage one or more Actuate 
e.Reporting Servers and Report Encyclopedias.

To install the Actuate Management Console

1 Insert the UNIX_OS Server Ancillary Programs CD 1 of 2 into your CD-ROM drive.

Where:

UNIX_OS indicates the type of UNIX being installed

2 Navigate to the following directory:

Thirdpty/actuate/language/mgmtconsole

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

For the remaining installation steps, refer to Installing Actuate e.Reporting System 
manual on the Siebel eBusiness Third-Party Bookshelf under Actuate.
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Guidelines for the Actuate Management Console Installation
During the installation of the Actuate Management Console, you will need to make 
note of the following:

■ When prompted for the context root, enter acadmin.

NOTE: Siebel Systems recommends that the context root, acadmin, not be 
changed. This context root is integrated into the Siebel application.

Installing the Actuate Active Portal
Actuate Active Portal provides access to the Siebel Reports Server from the World 
Wide Web. Using Actuate Active Portal, you can access and work with reports 
through Web browsers.

To install the Actuate Active Portal

1 Insert the UNIX_OS Server Ancillary Programs CD 1 of 2 into your CD-ROM drive.

Where:

UNIX_OS indicates the type of UNIX being installed

2 Navigate to the following directory:

Thirdpty/actuate/language/activeportal

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

For the remaining installation steps, refer to Installing Actuate e.Reporting System 
manual on the Siebel eBusiness Third-Party Bookshelf under Actuate.

NOTE: When installing the Active Portal on the same machine as the Management 
Console, specify the absolute path when prompted for the location of Tomcat (for 
example, /export/home/actuate/jakarta_tomcat_4.0.2).
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Guidelines for the Actuate Active Portal Installation
During the installation of the Actuate Active Portal, you should take note of the 
following:

■ When prompted for the context root, enter acweb.

NOTE: Siebel Systems recommends that the context root, acweb, not be changed. 
This context root is integrated into the Siebel application. If changed, you will 
not be able to view reports over the Internet.

Installing the Siebel Report Server Access
Siebel Report Server Access consists of libraries used by the Actuate e.Reporting 
Server to communicate with the Siebel Server. 

You must install Siebel Report Server Access on the same machine on which you 
installed Actuate e.Reporting Server. 

Siebel Report Server Access also contains report executables, customized Active 
Portal templates, and the Active Portal Security Extension library.

Install the Siebel Report Server Access using the user account set up during the 
Actuate e.Reporting Server installation.

CAUTION: Before starting the installation, make sure that Tomcat and the Actuate 
Process Management Daemon are stopped.

To install the Siebel Report Server Access

1 Create an environment variable, AC_SERVER_HOME, in the account's profile 
file or cshrc file that points to this directory.

For example, in the profile file, input:

AC_SERVER_HOME=/export/home/actuate/AcServer
export AC_SERVER_HOME

In the cshrc file, input:

setenv AC_SERVER_HOME /export/home/actuate/AcServer
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2 Insert the UNIX_OS Server Programs, Siebel Enterprise Server, Base CD-ROM into 
the CD-ROM drive.

Where:

UNIX_OS indicates the type of UNIX being installed

3 Navigate to the ses directory.

4 To start the SES installer process enter the following command:

./setupUNIX_OS 

Where:

UNIX_OS indicates the type of UNIX being installed

The Installer Welcome window appears. 

Click Next.

5 Verify the products to be installed and click Next.

The Installer path screen appears.

6 Enter the fully qualified path to the installation directory and click Next.

The Installer product selection screen appears.

7 Choose to install the Siebel Report Server Access and click Next.

The Installer setup type screen appears.

8 Choose the Typical setup option and click Next.

The Installer language selection screen appears. 

NOTE: There are three options (Typical, Compact, and Custom) available from the 
Setup Options screen. For the Siebel Reports Server, only Typical is a valid 
selection.
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9 Choose the languages to be installed and click Next.

The Install Selected Language Packs screen appears. 

NOTE: Additional languages can be installed at a later date, if desired. When 
installing languages at a later date, you must also reinstall any patches that have 
been run on the directory.

10 Insert the appropriate language CD and navigate to the selected language. Clear 
the filter dialog to make sure that you can see the appropriate files. Navigate to 
ses/language/setup.jar

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

NOTE: If installing more than one language and both languages are on the same 
CD, you will not be prompted for the second language. If the languages are on 
different CDs, you will be prompted to change CDs. 

The Installer Language Pack progress screen appears. When the Language Pack 
has completed, you are prompted to change CDs. 

11 Clear the filter dialog to make sure that you can see the appropriate files and 
navigate to ses/setupUNIX_OS.

Where:

UNIX_OS indicates the type of UNIX being installed

Click Next.

12 The InstallShield Wizard Complete screen appears. Click Finish to complete the 
installation.

NOTE: SIEBEL_HOME, SIEBEL_ROOT and SIEBEL_PLATFORM are no longer set as 
environment variables on the Reports Server host. As of Siebel 7, these variables are 
set in the rptsrvr.cfg file.
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Postinstallation Tasks for the Siebel Report Server Access
After installing Siebel Report Server Access, you must perform the following tasks:

■ “Importing the Siebel Report Files to the Report Encyclopedia”

■ “Configuring Active Portal Template Files” on page 69

■ “Setting Up the Active Portal Security Extension Library” on page 70

■ “Setting Actuate e.Reporting Server Parameters” on page 71

From here onward, refer to the Siebel Report Server Access installation directory (for 
example, /export/home/sea) as SIEBEL_RPT_SRVR_ROOT, the Actuate e.Reporting 
Server installation directory (for example, /export/home/actuate/AcServer) as 
AC_SERVER_HOME, the Actuate Active Portal installation directory (for example, /
export/home/actuate/activeportal) as ACTIVEPORTAL_HOME, and Tomcat 
installation directory (for example, /export/home/actuate/jakarta-tomcat-4.0.2) as 
TOMCAT_HOME.

Importing the Siebel Report Files to the Report Encyclopedia
After you install Siebel Report Server Access, you must import the Siebel Report 
executables (the ROX files) to the Report Encyclopedia. 

To import the Siebel Reports Server files

1 Shut down the Actuate e.Reporting Server using the instructions in 
Administering Actuate e.Reporting System guide. 

This guide is available in PDF format on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.

2 Navigate to ACTUATE_HOME/bin and at the command prompt, enter the 
following command:

acimport -vol VOLUME_NAME -path AC_SERVER_HOME/etc -if "Siebel 
Reports" -force -from SIEBEL_RPT_SRVR_ROOT/rptsrvr/reports/
volume
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3 From AC_SERVER_HOME/bin and at the command prompt, enter the following 
command:

acimport -vol VOLUME_NAME -path AC_SERVER_HOME/etc -if "Siebel 
Reports/LANGUAGE" -force -from SIEBEL_RPT_SRVR_ROOT/rptsrvr/
reports/language/volume

Where:

VOLUME_NAME = Name of the target volume.

LANGUAGE = the Siebel code, in upper case, for the Language Pack you are 
installing for this server; for example, ENU for U.S. English

language = the Siebel code, in lower case, for the Language Pack you are 
installing for this server; for example, enu for U.S. English

If error messages appear, see Actuate’s Administering Actuate e.Reporting 
System guide for troubleshooting procedures. This book is available in PDF 
format on the Siebel eBusiness Third-Party Bookshelf under Actuate.

NOTE: If you are installing the Reports Server for use with Siebel Industry 
Applications (such as Siebel eFinance and Siebel eGovernment), you will need 
to complete Step 4 and Step 5 on page 69 before proceeding to Step 6 on 
page 69.

If you are not installing a Siebel Industry application, you will proceed directly 
to Step 6 on page 69.

4 Navigate to AC_SERVER_HOME/bin and at the command prompt, enter the 
following command:

acimport -vol VOLUME_NAME -path AC_SERVER_HOME/etc -if "Siebel 
Reports" -force -from SIEBEL_RPT_SRVR_ROOT/rptsrvr/reportssia/
volume_sia
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5 From AC_SERVER_HOME/bin and at the command prompt, enter the following 
command:

acimport -vol VOLUME_NAME -path AC_SERVER_HOME/etc -if "Siebel 
Reports/LANGUAGE" -force -from SIEBEL_RPT_SRVR_ROOT/rptsrvr/
reports/languagesia/volume_sia

Where:

VOLUME_NAME = Name of the target volume.

LANGUAGE = the Siebel code, in upper case, for the Language Pack you are 
installing for this server; for example, ENU for U.S. English

language = the Siebel code, in lower case, for the Language Pack you are 
installing for this server; for example, enu for U.S. English

If error messages appear, see Actuate’s Administering Actuate e.Reporting 
System guide for troubleshooting procedures. This book is available in PDF 
format on the Siebel eBusiness Third-Party Bookshelf under Actuate.

6 Start the Actuate e.Reporting Server by entering:

AC_SERVER_HOME/bin/start_srvr.sh

Configuring Active Portal Template Files
The customized Siebel Active Portal templates will overwrite the ones installed with 
Actuate Active Portal.

To configure Active Portal Template files

1 Navigate to ACTIVEPORTAL_HOME.

2 Enter:

uncompress -c SIEBEL_RPT_SRVR_ROOT/rptsrvr/rptcast/rptcast.tar.Z 
| tar xvf -

NOTE: The administrator should make sure that all users clear their browser 
cache after reloading the templates.
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3 Clear the Tomcat cache using the following instructions.

a Make sure that the environment variable JAVA_HOME is set and pointed to 
the Java/Software Development Kit (JDK/SDK) installation directory, for 
example, /usr/java.

b Stop Tomcat by entering:

TOMCAT_HOME/bin/shutdown.sh

c Remove Tomcat cache by navigating to TOMCAT_HOME/work directory and 
at the command prompt enter:

rm -r *

d Start Tomcat by entering:

TOMCAT_HOME/bin/startup.sh

4 Access the Active Portal login page by typing the URL
http://activeportalmachinename:8080/acweb/login.jsp.

Where:

activeportalmachinename = the name of the machine where Actuate Active 
Portal is installed

You should see the Siebel logo on the Actuate Active Portal login page.

Setting Up the Active Portal Security Extension Library
This library enables the Siebel Reports Server Single Sign-On, which allows users to 
view reports without having to manually log onto the Reports Server.

To set up the Active Portal Security Extension Library

1 Navigate to the following location:

ACTIVEPORTAL_HOME/WEB-INF/lib

2 Enter:

cp SIEBEL_RPT_SRVR_ROOT/rptsrvr/rptcast/siebel.jar .
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3 Navigate to the following location:

TOMCAT_HOME/bin

4 Enter:

cp SIEBEL_RPT_SRVR_ROOT/rptsrvr/rptcast/libswewase.so .

5 For AIX:

a Locate the file setclasspath.sh under AC_SERVER_HOME/actuate/jakarta-
tomcat-4.0.2/bin.

b Search for JAVA_OPTS, and enter:

-Djava.library.path=AC_SERVER_HOME/actuate/jakarta-tomcat-
4.0.2/bin.

6 Clear Tomcat cache using the instructions in “Configuring Active Portal 
Template Files” on page 69.

NOTE: After setting up Active Portal Extension Library, you are no longer able to log 
into Active Portal by typing the URL http://
ActuateHTTPServiceMachineName:ActuateHTTPServicePortNumber/acweb/
login.jsp. The Actuate HTTP service port number is by default 8080.

Setting Actuate e.Reporting Server Parameters
Siebel Systems strongly recommends that the Reports Server administrator set the 
Actuate e.Reporting Server parameter ReportingServices  - Number of Requests 
Before Recycling Processes to 100 to avoid memory leaks. 

For instructions on how to modify this Actuate e.Reporting Server parameter, see 
the section titled “Setting advanced server properties” in Administering Actuate 
e.Reporting System guide. This guide is located in PDF format on the Siebel 
eBusiness Third-Party Bookshelf under Actuate.

NOTE: Find this and other parameters for the Actuate e.Reporting Server by opening 
the Actuate Management Console, logging into System Administration, selecting a 
Server, and selecting the Advanced tab.
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Postinstallation Tasks for the Siebel Reports Server
Perform the following postinstallation tasks to make Siebel Reports Server available 
for users and to confirm proper installation:

■ “Synchronizing Locale-Sensitive Parameters”

■ “Changing the Time Zone on the Reports Server Machine”

■ “Enabling the Siebel Reports Server with the Dedicated Web Client”

■ “Enabling the Siebel Reports Server with the Web Client” on page 75

■ “Synchronizing the Reports Administrator” on page 77

■ “Synchronizing Reports Server Users” on page 79

■ “Testing the Siebel Reports Server from the Dedicated Web Client” on page 80

■ “Testing the Siebel Reports Server from Web Client” on page 81

Synchronizing Locale-Sensitive Parameters
For the Reports Server to format reports based on user-specified locale definitions 
in the localemap.xml file, the locale should match the equivalent parameters in the 
Siebel Application Object Manager.

For more information about locale-sensitive parameters, see Global Deployment 
Guide on the Siebel Bookshelf.

Changing the Time Zone on the Reports Server Machine
If the administrator changes the time zone on the Reports Server machine, the 
Actuate e.Reporting Server should be restarted in order for the changes to take 
effect.

Enabling the Siebel Reports Server with the Dedicated Web Client
This section describes how to modify Siebel Web Client files, such as siebel.cfg and 
uagent.cfg, on the Dedicated Web Client to run with Siebel Reports Server.
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To configure the Siebel Application Object Manager files

1 Navigate to the BIN\language subdirectory of your Siebel eBusiness 
Applications installation directory.

Where:

language = the Siebel code for the Language Pack you installed; for example, 
enu for U.S. English.

2 Locate and open the appropriate configuration (CFG)file.

3 Using your default text editor, edit the following parameters in the [Siebel] and 
[ActuateReports] sections.

[SIEBEL]

EnableFQDN = TRUE

Where:

EnableFQDN is the setting that enables the processing of requests to Web sites 
even if the user does not provide the fully qualified domain name.

FQDN = name of local host followed by domain name

Where:

FQDN stands for Fully Qualified Domain Name. An example of a fully qualified 
domain name would be ebiz.siebel.com.

For more information about EnableFQDN and FQDN, see “Editing the Web 
Server Extension Configuration File” in the Siebel Server Installation Guide for 
the operating system you are using.

The local host is the machine where the Dedicated Web Client is installed 
(example: localhost.Siebel.com).

[ActuateReports]

EnableReportServer = TRUE

ReportServerHost = name of the Reports Server machine followed by SOAP 
(Simple Object Access Protocol) server port number (example: server1:8000). 
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ReportCastHost = name of Active Portal machine followed by domain name 
and Tomcat port number (example: server1.siebel.com:8080).

ReportCastDomain = domain name for the Active Portal machine (example: 
siebel.com).

ProtocolName = name of protocol to use for viewing reports (example: HTTP 
or HTTPS).

RoxDir = /Siebel Reports/

ConnectString = siebel.TCPIP.none.NONE://
GatewayServerName:PortNumber/EnterpriseServerName/
XXXOBJMGR_language/SiebelServerName

Where:

siebel.TCPIP = the networking protocol

none (first instance) = the encryption type chosen

NONE (second instance) = data compression method chosen

GatewayServerName = the name of your Siebel Gateway Server

PortNumber = the listening port number (default is 2320)

EnterpriseServerName = the name of your Siebel Enterprise Server

XXXOBJMGR_language = the type of Object Manager and language pack for the 
Siebel eBusiness application you are installing, for example:

SCCOBJMGR_enu for U.S. English Siebel Call Center Object Manager

SSEOBJMGR_enu for U.S. English Siebel Sales Object Manager

SiebelServerName = the name of your Siebel Server

NOTE: When deploying the Reports Server with a load-balanced Siebel Server, the 
Reports Server must be installed separately on a machine that does not have a 
Siebel Server.
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Enabling the Siebel Reports Server with the Web Client
This section describes how to set up the various parameters for enabling Siebel 
Reports Server for the Web client.

To set the parameters at the component level

1 From the application-level menu, select View > Site Map > Server 
Administration screen >Server Components.

2 Select the component for which you need to enable Reports Server parameters.

3 Click the Component Parameters tab.

4 Set parameter values in the Current value column for the following parameters 
and Save.

NOTE: The Siebel Server has to be restarted for these parameters to take effect.

Actuate Server Enable Flag = TRUE

Actuate Server Report Server Host = name of the Reports Server machine 
followed by the SOAP (Simple Object Access Protocol) server port number 
(example: server1:8000).

Actuate Server Report Cast Host = Name of Active Portal machine 
followed by domain name and Tomcat port number (example: 
server1.siebel.com:8080).

Actuate Report Cast Domain = Domain name for the Active Portal machine 
(example: siebel.com).

Actuate Server Network Protocol Name = name of protocol to use for 
viewing reports (example: HTTP or HTTPS).

Actuate Server Connect String = siebel.TCPIP.none.NONE://
GatewayServerName:PortNumber/EnterpriseServerName/
XXXOBJMGR_language/SiebelServerName

Where:

siebel.TCPIP = the networking protocol
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none (first instance) = the encryption type chosen

NONE (second instance) = the data compression method chosen

GatewayServerName = the name of your Siebel Gateway Server

PortNumber = the listening port number (default is 2320)

EnterpriseServerName = the name of your Siebel Enterprise Server

XXXOBJMGR_language = type of Object Manager for the Siebel eBusiness 
application you are installing, for example:

SCCOBJMGR_enu for U.S. English Siebel Call Center Object Manager

SSEOBJMGR_enu for U.S. English Siebel Sales Object Manager

SiebelServerName = the name of your Siebel Server

NOTE: When deploying the Reports Server with a load-balanced Siebel Server, the 
Reports Server must be installed separately on a machine that does not have a 
Siebel Server.

Actuate Server Rox Directory = /Siebel Reports/

Actuate Server Poll Wait Limit = time limit (in seconds) after which 
polling stops for interactively run reports.

The Actuate Server Poll Wait Limit parameter defines a duration in 
seconds, at the component level, after which application control is returned to 
the user, regardless of whether report generation has completed or not. This 
provision avoids the client having to wait for an indefinite time period after 
submitting long-running reports.

NOTE: The administrator should advise end users that they can override the 
component level setting of Actuate Server Poll Wait limit Parameter. This is done 
by choosing View > User Preferences > Behavior to set the Run Report Time 
Limit parameter from the application-level menu.
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See Siebel Server Administration Guide for more information on how to modify 
Application Object Manager parameters.

The following parameters need to be set in the eapps.cfg file, which can be found 
under the BIN subdirectory of the Siebel Web Server Extensions installation, in 
order for the single sign-on for reports to work.

To set the parameters in the eapps.cfg file

1 Navigate to the file eapps.cfg under, for example, /export/home/sea750/
eappweb/bin.

2 Using a text editor, open eapps.cfg and locate the [Defaults] section.

3 Set the following parameter values as shown below:

EnableFQDN = TRUE

EnableFQDN is the setting that enables the processing of requests to Web sites 
even if the user does not provide the fully qualified domain name.

FQDN = machine name followed by domain name

Where:

FQDN stands for Fully Qualified Domain Name. An example of a fully qualified 
domain name would be ebiz.siebel.com.

For more information about EnableFQDN and FQDN, see “Editing the Web 
Server Extension Configuration File” in the Siebel Server Installation Guide for 
the operating system you are using.

Synchronizing the Reports Administrator
The Reports Administrator needs to create an account on the Actuate e.Reporting 
Server using an account name that has Siebel administrator privileges, and assign 
the administrative role to that account by using Actuate Management Console.

NOTE: The administrator should review the Administering Actuate e.Reporting 
System manual before setting up an account for the administrator using Actuate 
Management Console.
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To set up an administrator in Actuate Management Console

1 Navigating from the Start menu, open Actuate Management Console.

2 Choose Administrator as the user name, connect to an appropriate encyclopedia 
volume, type the appropriate password, and click Log In.

3 In the left pane, select Users.

4 In the right pane, click Create User.

The User Properties window appears.

5 On the General tab, type the administrator’s login name in the name field. For 
example, type SADMIN.

Do not make an entry in the Password field, leaving the field blank.

6 Complete any other fields, as needed, and click Apply.

7 While still in the User Properties window, click the Roles tab.

8 Assign the Administrator role to the account (SADMIN) created in Step 5, and 
click OK.

To synchronize the Reports Administrator on the Reports Server

1 Login to Siebel eBusiness Application as the same administrative user 
(SADMIN) and from the application level menu select View > Site Map > 
Application Administration > Reports Server Admin Profile.

2 Do not make an entry in the Enter the current password in the Report Server 
field, leaving the field blank.

3 Type a password of your choice in the Enter New Password field and click Save.

The Report Administrator's account is synchronized on the Reports Server. The 
administrator can now synchronize the accounts of all other Siebel users.
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Synchronizing Reports Server Users
Synchronization is the process of creating accounts for Siebel users on Actuate 
e.Reporting Server and is required for users to run, schedule, and view reports in 
Reports Server views.

To synchronize Reports Server users

1 Log into the Siebel eBusiness application as the Siebel Reports Administrator 
and from the application-level menu selects View > Site Map > Reports Server 
> User Administration.

NOTE: The recommendation is to synchronize users in smaller buckets, 
particularly when a large number of users is synchronized. 

2 With the first user highlighted, click Synchronize One. 

The Siebel Users window appears.

3 Type the Reports Administrator name and password.

A confirmation message, stating that the user was successfully added to the 
Reports Server, appears in the Siebel Users window.

4 For the remaining users, click Synchronize All. 

NOTE: You will not see the Siebel Users login window again as long as you remain 
in the same view.

After the users have been synchronized, a confirmation window appears, 
displaying the total number of new user accounts added to the Reports Server. 
This confirmation message may also include the number of users already found 
to exist on the Reports Server. 

5 If users are being synchronized in smaller buckets repeat Step 4.

NOTE: If the database is refreshed, the Siebel Reports administrator should perform 
the user synchronization again to make sure that the Reports Server passwords for 
these users, which are stored in the Siebel Database, match what is stored in the 
Actuate e.Reporting Server.
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Testing the Siebel Reports Server from the Dedicated Web Client
Follow the instructions below to test Siebel Reports Server from the Dedicated Web 
Client.

To test the Siebel Reports Server from the Dedicated Web Client

1 Start any Siebel eBusiness Application from the Mobile Web Client (for example, 
Siebel Sales) and connect to server. 

The application’s home page appears.

2 From the application-level menu, choose View > Site Map > Account > My 
Accounts.

3 From the application-level menu, choose View > Reports.

4 From the drop-down list, select Account List and click Schedule.

The Schedule Report dialog box appears.

5 Indicate that you want to schedule the report for later, specify the date, time, and 
frequency. Click Finish.

6 From the application-level menu, choose View > Site Map > Reports Server > 
Schedule Requests.

The scheduled request appears in the view, indicating the scheduled date, time, 
and other information.

If the request does not appear, check the order and location in which the Siebel 
Reports Server components are installed, as described earlier in this chapter.
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Testing the Siebel Reports Server from Web Client
Follow the instructions below to test the Siebel Reports Server from the Siebel Web 
Client.

To test the Siebel Reports Server from the Web Client

1 Start any Siebel eBusiness Application (for example, Siebel Sales).

The application’s home page appears.

2 From the application-level menu, choose View > Site Map > Account > My 
Accounts.

3 From the application-level menu, choose View > Reports.

4 From the drop-down list, select Account List and click Run Now.

The program starts generating the report and displays the output in your browser 
window.

NOTE: If the report does not appear, check the order and location in which the 
Siebel Reports Server components are installed, as described earlier in this 
chapter.
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This topic describes the process to restructure the Reports Server Encyclopedia.

Overview 
The folders for reports users are created in the Reports Server encyclopedia at the 
root level. Therefore, synchronizing 5000 reports users will result in creating 5000 
folders at the root level of the encyclopedia. Actuate strongly recommends that 
folders at the root level of the encyclopedia be minimized to assure better response 
time and performance of the Reports Server. Therefore, Siebel Systems Inc. created 
a utility to automatically restructure the encyclopedia so that only a small number 
of folders exist at the root level. Each of the root-level folders contains a certain 
number of user folders as chosen by the administrator. The following section 
describes the installation and usage of this utility.
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Installing the Utility for Restructuring Report 
Encyclopedia

The following steps describe the installation of the actrestruct6.exe utility:

To install the actrestruct6.exe utility

1 Insert the Web Client Ancillary Programs CD 1 of 2 into the CD-ROM drive of a 
Windows machine.

2 Navigate to the following directory:

Thirdpty\actuate\language\actutil\actrestruct6.exe

Where:

language = the code for the language pack you installed; enu for all languages.

3 Copy actrestruct6.exe into the \bin directory of the Actuate e.Reporting Server 
folder, for example C:\Actuate6\Server\bin\.
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Restructuring the Report Encyclopedia
The following describes the usage of the actrestruct6.exe utility.

The administrator should run the utility actrestruct6.exe from a Windows 
Command prompt on a machine where Actuate Management Console is installed. 
The syntax for running this utility is:

actrestruct6.exe -u <user name> -p <password> -m <machine> - n 
<starting folder> -r <root level folders> -s <subfolders>

The following examples represent sample usage scenarios.

Example 1: The administrator synchronizes 8,000 users on the Reports Server and 
then run the actrestruct6.exe utility as shown below:

actrestruct6.exe -u administrator -p admin -m Server1 -n 1 -r 40 
-s 400

Flag Type Description

-u Required Reports Server administrator login name.

-p Required Reports Server administrator password.

-m Required Reports Server host name.

-n Optional Integer specifying the root-level folder to start with for creating 
subfolders. If omitted, subfolders will be created starting with the first 
root-level user folder. 

It is important to specify an appropriate value for this parameter if this 
utility is run periodically.

-r Optional Number of root-level folders (of the form foldernnn) that will be 
created. Existing folders will not be affected. Default value is 50. 

-s Optional Number of subfolders per root-level folder. Default value is 250.
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Result:

Forty folders are created at the root level in the Server1 Reports Server encyclopedia 
of the form folder001, folder002, …., folder040. Each of these root level folders 
contains the folders of 400 users. The first 400 user folders are created in folder001, 
the next 400 user folders are created in folder002 and so on. The root-level folders 
are created first, so all 40 folders will be created at the root level. However, only 20 
of them will be used to create subfolders. The remaining root-level folders can be 
used to populate subfolders when this utility is run subsequent times.

Example 2: A couple of weeks later, 500 new employees join the company. As usual, 
the administrator synchronizes these 500 users on the Reports Server. Then, the 
administrator run the actrestruct6.exe utility using the following command.

actrestruct6.exe -u administrator -p admin -m Server1 -n 21 -s 400 

Result:

At the root level in the Reports Server encyclopedia of Server1, folder021 and 
folder022 are used to create subfolders for the new users. The folder021 contains 
the first 400 user folders, and folder022 contains the remaining 100 user folders.

NOTE: In Example 2, if the administrator specifies -n 20, 400 new user folders will be 
added to folder020, which will then contain 800 folders. The folder021 will contain 
the remaining 100 user folders.
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Siebel applications ship with standard reports. To modify these reports or add new 
reports, you need to use Siebel Tools and Actuate e.Report Designer Professional as 
described in this topic.

You create and modify reports in two locations:

■ In Siebel Tools, by creating and modifying Report or other object definitions and 
setting properties within them. These object definitions are executed at run time. 

■ In Actuate e.Report Designer Professional, by creating and modifying ROD 
Report Object Design (ROD) files, which are then compiled and executed.

Although changes may be made only in Siebel Tools or in Actuate e.Report Designer 
Professional, frequently report redesign work requires making changes and 
additions in both places. 

Siebel Tools modifications use the Report, Report Field, Report Locale, Sub Report, 
Sub Report Field, View Report, and View Report Locale object types. These 
modifications affect the following areas: 

■ Defining the structure of the data exported from the Siebel application to the 
Actuate report, which the Actuate report receives into its datastreams

■ Attaching reports to the Reports menu for specific views

ROD file modifications in Actuate e.Report Designer Professional alter various 
classes and subclasses that define report behavior, appearance, data acquisition, 
and so on for one report.
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Actuate e.Report Designer Professional is a visual design editor from which object-
oriented Actuate BASIC code is generated and compiled from the report design 
(ROD file) and referenced library classes (ROL, or Report Object Library, files) into 
an executable report program. The resulting executable program is an ROX (Report 
Object Executable) file. When the executable program is run, the result is an 
instance file containing both report specifications and data. The instance file is in 
ROI (Report Object Instance) format, suitable for display in the Actuate Viewer on 
a Microsoft Windows client (Mobile Web Client). When the instance file is 
requested by a Web browser (directly from the Reports Server in Web client and 
dedicated Web client environments), it is converted to browser-specific DHTML 
format from the ROI. This is illustrated in Figure 2.

Figure 2. Actuate Report Generation and Display Steps
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As shown in Figure 2 on page 88, the ROI file generated by the Run Now operation 
can be sent directly to the Siebel Reports Server for long-term storage and 
availability. The ROI file is also accessed by Web browsers and thin clients. When 
in the Siebel Web Client, the user specifies whether immediate display or Reports 
Server processing is required when requesting the report. 

Development Environment
This section summarizes certain features of the Actuate development environment 
as they apply to Siebel reports. The specifics of using Actuate e.Report Designer 
Professional are explained in greater detail in Developing Advanced e.Reports, in the 
Actuate documentation set.

Actuate File Types
Actuate uses or generates files of the following nine types: 

■ ROD (Report Object Design). An ROD file is a report layout file. An ROD file exists 
for each standard report, and you create a new ROD file for each new report you 
create. The ROD files for the standard reports are provided with Siebel Tools.

■ ROL (Report Object Library). An ROL file is a library file. A library file contains 
reusable components you can add to design files. Since you can subclass, copy, 
or reference objects from libraries, you usually can reuse existing ones, and you 
do not have to understand how to construct them.

■ BAS (BASIC source code). A BAS file is generated during the build and 
compilation processes. It is generated from the ROD file being compiled and 
from all included library modules from ROL files. It is an intermediate file format 
used in the subsequent compilation step and is not directly modified by the 
developer. A BAS file can also be used to implement reusable Actuate BASIC 
routines for inclusion in report designs. 

■ ROX (Report Object Executable). An ROX file is an executable report, that is, a 
compiled ROD file. When you run a report, the Siebel application executes the 
ROX file. Note that Siebel applications include ROX files for the standard reports. 
When you customize standard reports or create new reports, you need to replace 
the corresponding ROX files or add them to the appropriate directory to make 
them available to the Siebel application.
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■ ROI (Report Object Instance). An instance file is what the user sees when the 
report is running in the Actuate window in the Siebel application. You interact 
with an instance file only when saving a report or when viewing it using an 
external viewer (Siebel Mobile Web Client mode).

■ ROV (Report Parameter Values). The parameter values file contains a report 
request's parameter definitions and values. Actuate creates the parameter values 
file automatically when users issue a request. The user enters parameter values 
in the Application screen (see parameterized reports documentation) then the 
information is written to a parameter values file, which can then be used to 
generate a report based on the specified parameter values.

■ ROP (Report Object Parameter). A file that contains a list of report parameters used 
by an open server report. 

■ ROW (Report Object Web). A structured storage file that contains bitmap, 
graphics, HTML information, and other information needed for an e.report. 
Report object web files are created by the Actuate e.Reporting Server and can be 
used only in the Report Encyclopedia.

NOTE: If a control is not seen properly, or seems to have disappeared, in the ROI 
file, review how the control is placed in the ROD file. Check the positioning, the 
size, and whether the control is overlapping another control. However, even if 
the control has the correct position or size, it still may not be seen properly in 
the ROI file. For more information about this, please review Technical Note 233 
on Siebel SupportWeb.

■ DHTML (Web page). A DHTML file is what the user sees when the report is 
obtained from the Reports Server using a Web browser (Siebel Web Client 
mode).
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Directory Structure
Actuate files in the Siebel environment reside in the following subdirectories of the 
Siebel development and client directories:

■ Executables Directory. C:\Siebel_client\reports\language_code. In the typical 
installation for English-speaking users, this is C:\Siebel\reports\enu. Report 
executables (ROX files) must appear in this directory to run. Note that if your 
installation directory for Siebel applications is not C:\Siebel, this will be the 
\reports subdirectory of the directory where the Siebel eBusiness Applications 
software resides. If multiple languages are supported, a separate subdirectory of 
\reports is provided for each and is identified by its language code, such as 
C:\Siebel\reports\deu or C:\Siebel\reports\fra.

■ Development Directory. C:\Siebel_development\rptsrc\language_code. Rptsrc is 
the development directory; it holds ROD and ROL files. In the typical installation, 
this is C:\Siebdev\rptsrc. It is divided into subdirectories by language. New 
reports that you create should be placed here, in the \language_code 
subdirectory. Each language subdirectory is further divided into \standard and 
\lib, such as C:\Siebdev\rptsrc\enu\standard and C:\Siebdev\rptsrc\enu\lib. 

■ Standard Reports Directory. 
C:\Siebel_development\rptsrc\language_code\standard. An example is 
C:\Siebdev\rptsrc\enu\standard. This subdirectory is where the design files for 
the standard reports are located. Do not place custom reports in this directory; 
use \language_code instead or create a subdirectory of \language_code called 
\custom or something similar.

■ Libraries Directory. C:\Siebel_development\rptsrc\language_code\lib. An example 
is C:\Siebdev\rptsrc\enu\lib. The datastream (source data definition) files are 
located here. These are generated from within Siebel Tools. This folder also 
contains the library files that are used by all Siebel reports, such as sssiebel.rol, 
sscustom.rol, and so on.

You develop the ROD file in the standard reports directory or the development 
directory, depending on whether you are modifying a standard report or creating a 
new report. You compile the finished design in Actuate e.Report Designer 
Professional and move the resulting ROX file to the executables directory. Initially, 
you would deploy the ROX file on your own computer for testing. When it is ready 
to be deployed, the ROX file goes to this location on each client computer.
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Actuate Libraries
Every Siebel report, whether standard or custom, includes the following libraries:

■ sssiebel.rol. This is also known as the Siebel library. It is derived from afc.rol and 
contains all the base classes for the sscustom library. It is automatically included 
as a part of sscustom.rol. Do not modify the contents of sssiebel.rol.

■ sscustom.rol. This is also known as the Custom library. It is derived from the 
sssiebel.rol library. You can make modifications in sscustom.rol to make global 
changes to fonts, headings, and so on that impact all reports. While making 
modifications is accepted, this file is not to be used as a scratch pad. Before 
making any changes to this library, make a backup copy of the out-of-the-box 
sscustom.rol file. Do not delete any files from this directory. You will frequently 
incorporate subclassed or copied objects from sscustom.rol into report design 
files you are creating or modifying.

■ <reportname>.rol. This is your data supply library file; there is one for each 
Actuate report used by your Siebel application. For example, the ACLIST 
(Account List) report will have a datastream file called Aclist.rol. The data 
supply library file is automatically generated by Siebel Tools for the currently 
selected report object definition when you choose the Generate Actuate Report 
option from the Tools menu.

■ sssiebel.bas. This is also known as the sssiebel BASIC file. It is a BASIC source 
code file containing methods used by all Siebel reports, especially for object and 
data interfaces between Siebel and Actuate. It is included in all standard reports 
by default and must be included in custom reports so that they work correctly 
for server reporting.
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Figure 3 illustrates the inheritance structure of components in a report design file.

 

The classes in the sssiebel.rol library are derived from the Actuate Foundation Class 
library. As shown in Figure 3, the classes in sscustom.rol are derived from 
sssiebel.rol classes. The sssiebel.rol library is a system layer providing a link 
between Actuate and Siebel applications. sssiebel.rol is reserved for Siebel product 
enhancements and should not be modified by a developer. The sscustom.rol library 
is provided for modifications by developers, although you will use most of its 
components unmodified in your report designs. You should never modify the 
sssiebel.rol library, only the sscustom.rol library.

NOTE: Components from afc.rol (and or components from the Actuate e.Report 
Designer Professional toolbar) and sssiebel.rol should not be used by report 
developers for designing Siebel-Actuate reports. When developing Siebel 
application reports, only use the sscustom.rol library.

Figure 3. Inheritance Structure of Components in a Siebel Report
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Actuate Design Files
An ROD file is a report design file. It defines the layout, structure, and behavior of 
a report. The ROD files for the standard Siebel reports are provided with Siebel 
Tools. A design file is modified in the main window of the Actuate e.Report Designer 
Professional software, called the Design Editor window. The design file for the 
Opportunity Summary report (Opsum.rod) as it appears in the Design Editor is 
shown in Figure 4.

 

The Design Editor window consists of a structure tree on the left and a layout grid 
on the right. The structure tree is populated with components. The nodes (also 
called slots) that hold these components can be of various types according to their 
use and behavior in the report. Specialized icons identify the types of their 
corresponding components. Of particular interest are the following node types in 
the structure:

■ Report node. Identifies the current report. This is the top-level component 
(OPSUM in Figure 4).

■ Content node. Identifies where the content is coming from in some portion of the 
report and how it is laid out. A content node often contains page header, before, 
content, after, and page footer nodes, which correspond to frames (rectangular 
report areas) in which visual report elements can be laid out. 

Figure 4. Report Design for a Siebel Report in the Design Editor
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■ Datastream node. Identifies the source of data. In reports for Siebel applications, 
this is a set of rows corresponding to a current view; its columns are from one 
or more business components. The datastream node in the structure actually 
points to an external library file, which is generated from Siebel Tools based on 
the contents of report (and child) object definitions in Siebel Tools. 

■ Pagelist node. Holds general page layout information for the report and generally 
is also obtained from an external library file that is common to all the reports.

Recall that Actuate is an object-oriented software product. Each of the icons in the 
structure tree represents an object, which can have child objects (as illustrated in 
the tree) and which has a properties list that you can edit. You may note the 
similarity to Siebel Object Explorer.

The class assigned to an object in Actuate determines its behavior. When new 
objects are created, or moved from one location to another, you need to be careful 
not to alter the relationship between an object and its current class, except when 
you are explicitly told to do so. The following three concepts are related to changing 
the relationship between an object and its class:

■ Subclassing. Subclassing an object results in the creation of its own class. This 
class is based on and linked to the class of the original object. All updates to the 
original object are inherited by your new object, except for updates to the parts 
you have changed in the subclass. This technique is commonly used in Siebel 
reports so that your reports inherit new behavior as Siebel products are 
upgraded.

■ Referencing. Referencing means referring to an existing component rather than 
creating a new component. You use a reference when an existing component 
meets your needs and you want to use it exactly as it is, no matter how it might 
change in the future.

■ Copying. You can copy a component from one part of a report design to another. 
After you copy a component, it has no relationship to the component from 
which it was copied.

See the information on concepts in Developing Advanced e.Reports in the Actuate 
e.Report Designer Professional documentation for a review of Actuate concepts.
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How the Siebel Application and Actuate Interact
In Siebel Web Client, the report instance is obtained by the client in DHTML rather 
than ROI format, and the report is viewed using a Web browser child window. In 
Siebel Mobile Web Client, the Actuate Viewer is called the Siebel Report Viewer. 

NOTE: The Siebel Report Viewer does not allow configuring of the menu items on the 
actual viewer.

The current business object (obtained from the view) and the current query create 
a context that determines which data is sent to the report. In Mobile Web Client 
reporting mode in Windows, the data is passed through variables across the 
interface between the Siebel application and the embedded Actuate viewer, and it 
is accessed using methods in the report design. In Web Client reporting mode, the 
object interface is between the Object Manager and the Reports Server.

When the user chooses the report from the Reports Server tab, a corresponding 
report executable (ROX file) is invoked locally and the resulting instance (ROI file) 
is displayed. When the user is running a report from Siebel Web Client, the report 
executable is invoked on the Reports Server at the appropriate time, and the 
instance is stored on the Reports Server. It may also be obtained automatically from 
the Reports Server for local display, depending on the environment and the user’s 
request.
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Each menu option available in the view exists because a view report object 
definition is present as a child of the view object definition. Each view report object 
definition references a report object definition, which in turn references a report 
name. This is shown in Figure 5.

The reports available for execution by the Siebel application, in ROX format, are 
stored by locale in C:\Siebel_client\reports\language_code. 

The language code is that of the current locale, specified in the CFG file used in 
invoking the application. For example, U.S. English report executables are in 
C:\Siebel\reports\enu, and this is the directory from which identified report 
executables are obtained when U.S. English is the current language; that is, the 
Language parameter in the application’s CFG file is unspecified or set to ENU. 
Additional locale-specific report executables reside in distinct directories, one 
directory per locale. For example, a \deu folder contains German-language report 
executables. 

Figure 5. Implementation of Menu Options in a View
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Run-Time Behavior
You can demonstrate the relationships (in Dedicated Web Client reporting mode) 
among a Siebel application, the Actuate software components, and an Actuate 
report designed for the Siebel environment.

To see the relationship between a Siebel report and the Actuate and Siebel 
software

1 If a Siebel application is running on your desktop, close it. Open the Actuate 
e.Report Designer Professional software.

2 Choose File >Open and navigate to Aclist.rod in C:\Siebdev\rptsrc\enu.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

3 Click the run button to compile and execute the report.

You see an error message such as:

OLE Server couldn’t be started.

4 Click OK. 

You see another error message such as:

This message is available only in English: A fatal error has 
occurred while generating the report. Please contact your 
administrator.

5 Close this error message box and halt the report execution.

6 Open Siebel Sales from the Start menu.

7 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities.

The wrong view is intentionally being opened to demonstrate the result.
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8 Return to Actuate e.Report Designer Professional with the Siebel application still 
open.

9 Run the report again by clicking the run button.

This time you see a different message, such as:

Finishing...
Idle
There is no data to display.

10 Close the Actuate Output message box and return to Siebel Sales. 

11 From the application-level menu, choose View > Site Map > Accounts > My 
Accounts.

12 Return to Actuate e.Report Designer Professional and click the run button.

This time, the Account List report should run successfully.

This exercise demonstrates that a Siebel report does not run locally in Actuate 
unless two conditions are met:

■ A Siebel application is running, making the Siebel software available as an OLE 
container.

■ The current view in the application is based on the correct business object for 
supplying data to the report being run. In the case of the example, a report listing 
account data requires that a view based on the Accounts business object be 
active.

Since a user executes Siebel reports only from the views in which they are designed 
to be run, these kinds of errors do not occur in a properly configured Siebel 
application.

Note that when the user restricts the data in the view with a query, only the data 
meeting the query constraints appears in the report. The Siebel application passes 
only the data from the current query to the Actuate viewer.
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Run-Time Report Parameters
Table 1 describes the parameters passed through the report request to the Siebel 
Object Manager when the report is initiated. The report will not run if parameters 
are not defined correctly. For more information, see “baseReport” on page 405.

Table 1. Report Parameters

Report Parameter Description

ssActiveRowId Active row-id of primary business component for the report. Used 
for current-record-only reports.

ssBookmark Contains information about business component state, including 
queries, when the report request is submitted.

ssBusObjectName Name of the business object corresponding to the active view.

ssLanguage Language code.

ssOLEServer Specifies the OLE server to connect to in order to obtain data 
displayed in the report. In version 7.0, OLE server is 
TWSiebel.SiebelWEBApplication.1 for interactively generated 
reports in Mobile Web Client and Siebel Report Server Access for 
server-based reports.

ssPassword Siebel password.

ssPositionId The current position Id of the user.

ssSearchSpec Search specification. Set in Tools or in the report design.

ssSiebelSever Siebel Server connect string. Used for the client to establish 
connection with the Siebel Server.

ssSortSpec Sort specification. Set in the report design.

ssUserName Siebel user name.

ssViewMode Used for setting view mode on the Siebel Server side during report 
generation. Based on current view from which report is submitted or 
value set using Tools.
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Data Definition for Reports
The ROD file for a Siebel report must reference its datastream components from an 
ROL file, rather than through the data source and query definition processes used 
for non-Siebel reports in Actuate. This is because the Actuate viewer is obtaining 
data through the Siebel object interface rather than by directly accessing the 
database. This is consistent with Siebel standards for making sure that data access 
is always at the business object level, rather than data object level.

The structure of the exported data must be consistent between the Siebel 
application and the Actuate executable so that the data will be usable by the report. 
To accomplish this, the structure of the data for each report is defined in Siebel Tools 
using a report object definition and its children. It is then exported to a datastream 
file in ROL format using the Generate Actuate Report option in the Tools menu in 
Siebel Tools. The name of the ROL file to be generated is specified in the Template 
Name property in the report object definition in Siebel Tools.

The relationships between the names of the data supply ROL, report design, and 
executable files are explained in Table 2.

Table 2. Relationships Between ROL, ROD, and ROX Filenames

File How Used Where Name Is Specified

Data supply (ROL) file Generated from Siebel Tools 
and loaded into ROD file as 
an included module.

Template Name property of the 
report object definition.

Report design (ROD) file Specifies the layout and 
behavior of the report; 
subsequently compiled into 
an ROX file.

Identified to the Siebel 
application using the Access 
Base DB Name property of the 
report object definition. 
Originally created in Actuate 
e.Report Designer Professional.

Executable (ROX) file Runs the report when 
executed.

Automatically receives the same 
name as the ROD, except for the 
filename extension.
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The generated ROL file, by convention, has the same name as the ROD file into 
which it is intended to be incorporated. For example, the Opportunities - Summary 
report object definition specifies the name OPSUM in both the Template Name and 
Access Base DB Name properties, and the corresponding report design file is 
Opsum.rod. When a data supply library file is exported from Siebel Tools for this 
report, it is given the name Opsum.rol because of the Template Name setting. When 
the ROD file is compiled, the resulting executable is given the name Opsum.rox by 
Actuate e.Report Designer Professional. When the Siebel application invokes the 
executable from the view, the file it invokes is Opsum.rox because of the Access 
Base DB Name setting.

NOTE: It is not required that the data supply ROL filename match the filename of the 
ROD file into which it is incorporated. However, it is good design practice to have a 
separate data supply ROL file for each ROD file and to match the names where 
possible.

Data Supply ROL Files
All ROL files contain reusable components that can be subclassed into design files 
in Actuate e.Report Designer Professional. For example, a report design subclasses 
design elements such as label, text, and frame controls from sscustom.rol, as 
described in Chapter 5, “Global Report Modifications.” The incorporation of a data 
supply library file into the corresponding design file is a special application of this 
subclassing methodology. A report design subclasses the datastream component 
from the corresponding data supply ROL file. 

The datastream component contains methods for accessing the necessary report 
data from the correct business object through the Siebel object interface. One or 
more data row components are defined for use by the datastream, each specifying 
the list of fields for a business component whose records are to be retrieved. The 
logic for the datastream component fetches and deletes instances of the data row 
until all records in the current query (and subqueries, if applicable) have been 
obtained and processed into the report. 

You can view the contents of the datastream and data row components in a report 
design using the Method Editor and the Component Editor.
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To view the contents of a datastream component

1 Open a standard Siebel report in Actuate e.Report Designer Professional, for 
example, Actlist.rod in C:\Siebdev\rptsrc\enu\standard.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

2 Expand the main report section component and double-click the datastream 
component.

The Component Editor window appears. 

3 Click the Methods tab.

4 Choose Start in the method picklist at the upper left in the window.

The text for the datastream’s Start method appears in the Method Editor 
window.

5 Examine the code for this method. Notice that this code activates each exported 
field in the business component.

6 Select Fetch in the Method picklist and examine the code for the Fetch method. 
Notice that the code obtains the value for each exported field.

The data supply library file for a report is loaded into the report design file by 
invoking the Tools > Library Organizer menu option in Actuate e.Report Designer 
Professional. Its datastream and data row components subclass the AcDataSource 
and AcDataRow components in the Actuate Foundation Class library, respectively. 
The methods in the data supply library file override corresponding methods in the 
foundation class library. The contents of these methods are generated code, 
produced from the list of report fields and other report object definition properties 
and children in Siebel Tools.
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To view the contents of a data row component

1 If you have not already opened a standard Siebel report, follow Step 1 on 
page 103 in the previous procedure.

2 Expand the datastream component in the component tree and select the data 
row component.

3 Right-click the data row component and select Properties in the pop-up window. 

The Component Editor window opens.

4 Click the Variables tab.

The list of variables defined in the data row appears.

Notice that all the variable names are in black, rather than gray, except for 
RowNumber. This indicates that these variables are defined locally in the class 
code, rather than inherited from the parent AcDataRow class.

Notice too that the names of the variables are modified field names from the 
business component. The prefix ss has been added to each, and spaces and 
special characters have been replaced with underscore (_) characters.

The automatic definition of a set of variables, corresponding to the list of exported 
report fields, is the role of part of the generated code in the data supply library.
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Siebel Report Object Types
The following object types are used in Siebel Tools to define the structure of the data 
for each report and are used to generate the data supply ROL file for that report:

■ Report object type. A report object definition provides the high-level properties 
for one report. Report properties identify the filenames of the generated data 
supply library and the report executable, the business component name, the 
report type (Actuate or Access), and so on. The property types:

■ Business Component property. This specifies the business component whose 
data is used in the main report. The business component of the subreport is 
specified in the subreport object definition.

■ Template Name property. This is the name of the data supply library generated 
in Siebel Tools (without the ROL extension) that supplies information to 
Actuate about the report. This property is left blank for Access reports. It is 
also left blank for custom Actuate reports in which the data supply library 
file is too complex to generate from Siebel Tools and must be created as 
program code.

■ Access Base DB Name property. For Actuate reports, this is the name of the 
executable file (without the ROX extension) that the Siebel application will 
run when the report is selected. For Access reports, this is the MDB 
(database) file that contains the report specification.

■ Class property. The CSSActuateReportViewer class identifies an Actuate 
report. The CSSAccessReport class identifies an Access report. The CSSReport 
class identifies a report that is generated as a delimited text file for Microsoft 
Excel or Crystal Reports.
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■ Search Specification property. The conditional expression used to retrieve a 
subset of records. If a search specification is defined in the report object 
definition and you want to run the report from Actuate e.Report Designer 
Professional, the search specification does not pass through from Siebel 
Tools. To check if the search specification is working, you will have to run it 
from the Siebel application.

NOTE: The same result occurs if the Current Record Only property (a type of 
search specification) is defined. Setting this property to TRUE does not pass 
through to Actuate e.Report Designer Professional from Siebel Tools.

Also, if you set a search specification on your parent datastream in Actuate 
Start(), this search spec will override the dynamic view query results in the 
report and look through all the records in the business component.

■ Sort Specification property. You can set a sort specification in a report object 
definition to send the rows to Actuate through the datastream in sorted order. 
Otherwise, the rows are sent in the sort order on the current view. Ordering 
the data coming from the Siebel application will, at a minimum, improve 
performance when the report runs, and may be required to make the report 
work.

NOTE: Setting a search or sort specification property is also possible for 
subreports.

■ Menu Text property. The menu text to appear in the Reports menu when this 
report is included in the active view by means of a view report object 
definition.

■ Client Only property. Determines whether a report is available to Siebel thin 
clients and for server-mode reporting. If TRUE, the report is available only 
for client-mode reporting on a dedicated client. If FALSE, the report is 
available for both client-mode and server-mode reporting on either dedicated 
or thin clients.

■ Parameter Applet property. The name of a parameter entry pop-up applet 
created in Siebel Tools.
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■ Report Field object type. A report field object definition identifies one field to be 
included in the report from the report’s business component. In Actuate reports, 
the list of report field object definitions is incorporated into the data supply 
library file when it is generated. For a field to appear in the datastream, and 
hence in the report when it is run, it must be included as a report field object 
definition for the report in Siebel Tools. You can list more report fields than are 
actually used in the report. Note, however, that the system retrieves all listed 
fields, so listing unused fields needlessly degrades report performance. Each 
field in the ROL file is a variable on the child data row component of a 
datastream.

■ Report Locale object type. A report field object definition that identifies the 
language-specific overrides associated with the Report object type.

■ Sub Report object type. A subreport object definition that uses data from a detail 
business component and contains information to manage a detail portion of a 
master-detail report. One datastream component is included in the data supply 
ROL file for the main report and for each subreport child of the report. Each 
detail datastream component is generated from a subreport object definition and 
its subreport field children.

■ Sub Report Field object type. A subreport field object definition identifies one field 
to be included in the subreport from the subreport’s business component. The 
list of subreport field object definitions goes into the subreport datastream 
component as variables in the data row. 

The following object types are used to attach a specific report, as defined in its 
report object definition, to a specific view:

■ View Report object type. A view report object definition creates an association 
between a report object definition and a view, causing that report to be available 
in the Reports menu when the view is active.

■ View Report Locale object type. A view report object definition that identifies the 
language-specific overrides associated with the View Report object type.

NOTE: In Actuate, an apostrophe indicates that code after it will be read as 
comments. As a result, a field name in any of the report objects that contains an 
apostrophe will result in compilation errors.
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You can also create Report objects using the New Report wizard in Siebel Tools. As 
displayed in Figure 6, you will provide the following information:

■ From a drop-down list, select the project the report will be a part.

■ Input a new, unique name for the report.

■ From a drop-down list, select the business component the report will use to 
build the output.

■ Input the text to be displayed in the Reports menu for the report.

This wizard has only one page. When you click Finish, you are taken to the report 
you just created in the Object List Editor, where you can further configure the new 
Report object.

For more information about wizards, see Siebel Tools Reference.

Figure 6. Report Wizard
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In addition to report object types, virtual business components may be used to 
create reports. Virtual business components allow you to represent external data as 
a business component within a Siebel application. They also allow the use of 
business services to transfer data. For more information about virtual business 
components, see Siebel Tools Reference and Overview: Siebel eBusiness Application 
Integration Volume I.

NOTE: For information on the set of properties for these object types, see object types 
on Siebel Tools Online Help.

Additional Siebel-Actuate Reporting Issues
This section covers various additional issues that pertain to reporting in Siebel 
applications.

Installation
Note the following points about software installation:

■ Actuate e.Report Designer Professional is installed on a Windows client PC from 
the Siebel Windows client CD-ROM. Follow the instructions in Installing Actuate 
e.Report Designer Professional Release 6, in the Actuate documentation set on the 
Siebel eBusiness Third-Party Bookshelf.

■ Installation of the Report Server components is described in Chapter 1, 
“Installing the Siebel Reports Server for Microsoft Windows” or Chapter 2, 
“Installing the Siebel Reports Server for UNIX” depending on the operating 
system you are using.

■ Actuate Report Viewer is automatically installed with a Siebel application when 
loading the Mobile Web Client environment.

■ Siebel Reports Server, as of release 7.5, allows running reports in multiple 
languages using the same instance of the Reports Server. Unlike in previous 
versions, there is no need to deploy a language-specific Reports Server on 
separate machines. 
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You should also be aware of the following configuration file parameters in tools.cfg 
(the configuration file for Siebel Tools):

■ ActuateeRDProDir. Specifies the location of the Actuate e.Report Designer 
Professional software.

■ TemplateDestDir. Specifies the directory location where data supply library files 
are created when they are exported from Siebel Tools. The default is 
C:\Siebdev\rptsrc\enu\lib.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

The following parameter in the configuration file for each Siebel application should 
be set as indicated:

■ EnableOLEAutomation. By default, this is set to TRUE. This setting allows local 
generation of Siebel reports. Note that this is the case even if you do not have or 
use the Siebel Object Interfaces feature.

Upgrading Custom Reports
Upgrading custom reports involves a short process to complete. The following steps 
will need to be completed for each custom report you have created.

Before starting, make sure that Actuate e.Report Designer Professional version 6.0 
is installed on your machine. The following upgrade instructions are specifically for 
Siebel Reports 6.0. For more information, read Upgrading to Actuate e.Reporting 
Suite 6 in the Actuate documentation section on the Siebel eBusiness Third-Party 
Bookshelf.

To upgrade a custom report to version 7.x for Actuate 6

1 Using an existing custom report from version 6.0, retrieve an ROD (report 
design) file.
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2 Generate an ROL (report library) file from Siebel Tools.

a In Siebel Tools, navigate to Reports and select a desired report.

b From the Tools menu, select the Generate Actuate Report option.

3 Place the ROD file and the generated ROL file (and other necessary libraries) in 
a directory on your machine.

4 Open the ROD file in Actuate e.Report Designer Professional.

5 Compile the report to generate an ROX (report executable) file by selecting the 
Build option from the Report menu.

NOTE: Regarding upgrading of the sscustom.rol file from one release to the next, the 
format of the file is upgraded, but any custom changes are not. After an upgrade 
you have to manually add any changes and adjustments to the new version of the 
sscustom.rol.

Upgrading Forecasting Reports
Forecasting reports no longer require special design techniques to create. These 
reports can be created using Siebel Tools and Actuate e.Report Designer Professional 
like other custom reports that are described in this book.

The modifications made to Forecasting in this release necessitate creating new 
forecasting reports. The data from the 6.x forecasting reports can be converted to 
Siebel 7.x. However, the forecasting reports themselves are not upgradable. 

For more information on forecasting see Siebel Forecasting Guide.
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Migration of Non-Actuate Reports
Previously designed custom reports in other reporting applications than Actuate 
accessed data either using a ODBC data source or an external file that is populated 
when the user navigates to a specific view in Siebel eBusiness Applications. 
However, such data access is useful only with client-side reporting and can not be 
used while running server-based reports in the Web Client. Further, report 
generation and viewing through the Web browser is easier and more convenient 
with server-based reporting, particularly for business users running the applications 
in the Web Client from anywhere. Therefore, all custom reports designed in 
reporting applications other than in Actuate should be redesigned and implemented 
using this guide with Siebel Tools and Actuate e.Reporting Designer Professional. 

While running reports in the Web Client, data access for reports is possible through 
a custom Siebel-Actuate integration layer from Siebel business objects layer. The 
same configured business object layer provides data to both the Siebel application 
user interface and to Siebel report generation processes. Therefore, the business 
logic built around the underlying tables can be reused consistently across all reports 
enhancing the access of context specific data, and eliminating the need for high-
maintenance SQL queries or custom code. Accessing data from Siebel business 
objects also enables convenient migration of custom reports and ongoing 
administration of visibility rules.

Maintaining the Actuate e.Reporting Server
The administrator should perform certain on-going maintenance tasks to assure the 
continued performance of the Actuate e.Reporting Server. In addition to maintaining 
the Report Server performance, the administrator should perform user 
administration, which includes setting up users and roles, creating and modifying 
their preferences, configuring printers, creating auto-archive policies, and 
maintaining security of the encyclopedia. For details of administration tasks please 
refer to Administering Actuate e.Reporting System manual on the Siebel eBusiness 
Third-Party Bookshelf under Actuate.

Managing process groups. The administrator may create new Factory/View/Print 
Process Groups as part of managing report server resources. The administrator may 
increase the number of factory processes to have multiple reports generated 
simultaneously. Please see Administering Actuate e.Reporting System for more 
details.
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Port configuration. The administrator may need to open more free ports to Report 
Server (particularly in a firewall environment) to enhance the number of concurrent 
user connections for report generation and viewing. Actuate’s Administering 
Actuate e.Reporting System describes port configuration both for report generation 
and viewing.

Deleting completed requests. The administrator may modify the user preferences in 
the Actuate Management Console to have the completed request notifications 
deleted automatically upon report generation or after a certain length of time. 
However, this effort might be cumbersome with a large number of users, and an 
automated process can be used instead.

Periodically, the administrator may run the utility actcleanup6.exe as described in 
the “Installing Siebel Reports Server Utility” on page 52.

Additionally, the administrator may purge completed request notifications more 
frequently. See Actuate’s Administering Actuate e.Reporting System for more 
information.

Periodic shutdown. The Actuate e.Reporting Server maintains a lookup table of the 
contents of the encyclopedia and updates this table when the report server is shut 
down and restarted. The lookup table size increases with the number of completed 
request notifications, report files (ROI), users, or roles. The lookup table does not 
always automatically decrease in size when these are deleted unless the report 
server is restarted. Therefore, the administrator should periodically shut down and 
restart Actuate services (in Windows) and processes (in AIX and Solaris).
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Dynamic Versus Static Reports
Dynamic and static reports are two classifications of reports based on the Dynamic 
View setting in Siebel Tools. These two classifications are described as follows:

■ Dynamic reports. Reports with a Dynamic View property setting of TRUE. A 
dynamic report displays the records in the view from which it is started and 
includes only those records that are displayed through the current query. All 
standard Siebel reports are, by default, dynamic.

■ Static reports. Reports with a Dynamic View property setting of FALSE. A static 
report ignores the current query and queries the entire business component, 
subject to the user’s visibility. This is useful only when the view’s data is too 
limited for the report, which may be true of certain management reports. Also,   
reporting on information independently of what is being displayed in the view 
is another reason for running a static report. You specify the business object, sort 
specification, search specification, and view mode for a static report directly in 
the report object definition. Otherwise, these properties are left blank.

NOTE: If the main report business component has a search or sort specification 
property, or uses a field that is not already active, its query must be reexecuted. 
Also, a parent business component for a report will still use a sort specification 
property, even though it has an asterisk that says for Static reports. 

You should make sure the Dynamic View property is set to TRUE for custom 
reports you create, unless static behavior is what you want.

Currently it is not possible to create a static report (a report where the Dynamic 
View property is FALSE, and the Business Object and View Mode properties are 
not blank) and then run this report on the Siebel Reports Server. This is a result 
of the following reasons:

■ The business object passed to the Siebel Reports Server is always of the view 
from where the report was requested.

■ The Siebel application will block the report request when one tries to execute 
a report whose business object entered is different than the one of the current 
view.
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Using a Datastream Twice
Two sequential report sections can use the same datastream. However, this 
approach generates the “Operation is not allowed on sql object in forward only 
mode” error message. The workaround is to comment out the SetForwardOnly 
mode statement in the ROL’s Fetch method. This approach will negatively impact 
the performance of the report. The datastream is read once each time it is executed. 

Another approach is to retrieve the data once and store the rows in a global list 
variable that can be used as the datasource of subsequent report sections. The steps 
to accomplish this, with a few modifications, are described in Chapter 10, “Sorting 
Records in Memory.”

sssiebel.bas and Migration Considerations
The sssiebel.bas BASIC file must be included in all report design files for Siebel 
reports. This is because some object interface methods are in use that are referenced 
in this file.

NOTE: In general, the sssiebel.bas file is automatically loaded when the sssiebel.rol 
file is loaded for a report. A manual loading of this file is usually not necessary. 
However, in some cases (such as in legacy design or a lost association with 
sssiebel.rol), the user may need to include sssiebel.bas if indicated by Actuate.

Another important migration consideration is that data supply ROL files must be 
generated from Siebel Tools version 7.x to work correctly with server reporting. You 
must regenerate the data supply ROL files for all your custom report design files.

Backing Up Report Design and Library Files
You should create a set of development directories for report source files—
particularly report design files and library files—to make sure that older versions 
are not overwritten. Ideally, you should employ source code control software for 
this purpose. When modifications are made repeatedly to a single set of source files 
in one location, possibly by multiple developers, you risk the loss of report design 
and development effort. A system for backing up source files and retaining earlier 
versions significantly reduces this risk.
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Emailing a Report
You can send a report instance (ROI) file to another Siebel user for viewing. The 
recipient opens the Srviewer.exe application (located in C:\Siebel\bin), clicks the 
Open File button, and navigates to the desired ROI file. This opens the report 
instance in the Actuate Report Viewer.

It is not necessary for a Siebel application to be running or for the recipient to have 
the view or data used in generating the report. This is because an ROI file is self-
contained.

However, the Srviewer.exe program cannot be sent to a non-Siebel user. It requires 
that certain DLL files be installed as well as the executable. 

For non-Siebel users who require electronic copies of report output, you can employ 
one of these alternatives:

■ Create a report that looks acceptable in HTML and send it as an HTML file. Be 
aware that there are limitations such as printability, the entire report being a 
single HTML page, and so on. 

■ If the report output is present on the Reports Server, download it in PDF format 
and send the file. 

■ For local reports, if you have the appropriate Adobe PDF printer driver installed, 
you can generate a PDF file by printing with that driver and then emailing the 
resulting file.

NOTE: To enable email notification from the Actuate e.Reporting Server, Microsoft 
Exchange Server must be used as the email Server. Email notification will not work 
if a standard SMTP email server is used. For more information, see Administering 
Actuate e.Reporting System manual on the Siebel eBusiness Third-Party Bookshelf.
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Printing
If you set the paper size in the report design, the setting is ignored when the report 
is printed. The report will always use the default setting in the print setup. Also, the 
setting in the report design can only take effect if the Actuate API is used. However, 
the use of Actuate APIs is not recommended in Siebel eBusiness applications.

Also, if the default page size is changed on the Page Setup from Letter to Legal, 
when in the report viewer, the change will only last as long as your PC is not 
rebooted or restarted. If you restart, the default paper size reverts back to Letter. 
This behavior is relevant in the Mobile Web Client environment, which uses the 
Siebel Report Viewer.

For more information regarding printing, see Actuate’s Using e.Reports manual on 
the Siebel eBusiness Third-Party Bookshelf under Actuate.
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Global customization applies to all reports, rather than to a single report. It is 
accomplished by making changes to components in the sscustom library and 
propagating those changes to all the reports that use those components.

Global layout customization provides a good introduction to Siebel report 
customization because it is relatively quick and straightforward and generally 
involves modifications to a small number of property settings. Typical global 
modifications are those made to the header or footer, such as putting a different 
company name or logo in the header. Another global modification might be setting 
a different default font size and style for all reports.

A change to a library component is a global report modification because it affects 
all the reports that use that component. You always make global modifications in 
the sscustom library. For example, if you edit the font property of the ssLbl (label) 
component in the sscustom library, any part of a report that uses ssLbl will use the 
new font that you specified. You must recompile each report for the change to affect 
that report.

The procedures in this chapter demonstrate how to modify the page layout objects 
in the sscustom library, then recompile one report so that the global layout change 
is applied in that report. Two example procedures are provided:

■ Changing the font that is used on all the text and label controls throughout the 
reports

■ Changing the company logo that is used on all the reports

NOTE: After a global report modification, recompiling reports in batches is possible 
using the Actuate e.Reporting Designer Professional executable, Erdpro.exe. For 
more information, see “Upgrading reports to Actuate 6” in Upgrading to Actuate 
e.Reporting Suite 6 on the Siebel eBusiness Third-Party Bookshelf. 
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You can change the font that is used on all the text and label controls throughout 
the reports. You change the Font.FaceName property on the ssTxt (text) library 
control and on the ssLbl (label) library control, as shown in the following steps. All 
report text and label controls are derived from ssTxt and ssLbl.

In order to make and test the appropriate changes, you will need to: 

■ Open a report design file.

■ Edit the label and text controls in sscustom.

■ Compile and run the report.

■ Save the changes to sscustom.

To open a report design file and the corresponding Siebel view

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Accounts > My 
Accounts. 

This step is necessary so that Siebel data can be communicated to the Actuate 
report when the report is tested.

3 Open the Actuate e.Report Designer Professional software from the Start menu. 

4 Choose File > Open, then locate and select Aclist.rod in the 
C:\Siebel\rptsrc\enu\standard folder. 

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

The Design Editor window displays the Account List report design.
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To edit the label and text controls in sscustom

1 Click the library browser button.

The Choose Included Module dialog box appears as shown in the following 
figure.

The library browser button and the Choose Included Module dialog box are for 
opening one of the libraries that has been included in the report design. For this 
example, the library for Account List (aclist.rol) is included. The sscustom and 
sssiebel libraries are included in all reports. 
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2 Select sscustom.rol and click OK.

As shown in the following figure, the Library Browser window for sscustom.rol 
appears.

The Library Browser window displays all of the library components available in 
the library you opened, in this case sscustom.rol. This library contains such 
components as ssLbl and ssTxt that are modified in the following steps.
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3 Right-click the ssLbl component and select Properties. 

The Component Editor window appears, displaying the property settings for 
ssLbl as seen in the following figure.

The Component Editor window has four tabs—Properties, Methods, Variables, 
and Class:

■ Properties tab. Identifies the property setting for each property defined for the 
current component. Property settings can be changed in this tabbed page.

■ Methods tab. Lists the Actuate BASIC methods defined for the component.

■ Variables tab. Lists the variables defined for the component.

■ Class tab. Identifies the class name and superclass of the component, and the 
module where it resides (usually either the report design file or an included 
library).

4 Find and expand the Font property in the Property Editor.

The Font.FaceName property becomes visible.

5 Change the value of Font.FaceName from Arial to Arial Narrow and click Apply.
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6 Click the Library Browser window to make it active.

You do this to choose a different library component to change its properties.

7 Click the ssTxt component in the Library Browser window.

The Component Editor window now shows ssTxt property settings.

8 Repeat Step 4 and Step 5 on page 123 for ssTxt and close the Component Editor 
and Library Browser windows.

To compile and run the report

1 In Actuate e.Report Designer Professional, click the run button.

The run button invokes the report build, compilation, and execution processes. 
You can also invoke these processes, collectively or individually, from the Report 
menu in Actuate e.Report Designer Professional.

2 The Actuate e.Report Designer Professional dialog box appears with the 
following caution, “(t)he design has been modified. Do you want to compile 
first.”

Click Yes. 

As the following figure represents, the Requester dialog box appears containing 
a listing of the parameters for the report such as ssOLEServer and ssPassword.
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3 Click OK to accept the defaults.

This provides the means to communicate parameter values to the report. 

The report is generated and appears in the Actuate e.Report Designer 
Professional window.

To save the changes to sscustom

1 Close the report. 

2 If the Save Modified Modules dialog box appears, this is to notify you that 
sscustom has been modified and to ask if you want to save the changes. 

Click Yes.

3 Close Actuate e.Report Designer Professional.

4 Copy the Aclist.rox file from the development directory 
(C:\Siebel_development\reports\language_code\standard) to the executables 
directory (C:\Siebel_client\reports\language_code).

5 In Siebel Sales, select Account List from the Reports menu. 

The revised Account List report appears in the browser screen. 

For your change to sscustom to affect other reports, you will need to recompile 
those reports.
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You can change the company logo that is used in all the reports. You change the 
fileName property of the ssLblSiebel control, as described in the procedures in this 
section.

To make and test the appropriate changes, you will need to:

■ Open a report design file.

■ Edit the ssLblsbl component in sscustom.

■ Compile and run the report.

■ Save the changes to sscustom.

To open a report design file and the corresponding Siebel view

1 Open Siebel Sales.

2 From the application-level menu, choose > View > Site Map > Accounts > 
My Accounts.

3 Open the Actuate e.Report Designer Professional software from the Start menu. 

4 Choose File > Open. 

5 Locate and select Aclist.rod in the C:\Siebel\rptsrc\enu\standard folder. 

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

The Design Editor window displays the Account List report design.
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To edit the label and text controls in sscustom

1 Click the library browser button.

The Choose Included Module dialog box appears.

2 Select sscustom.rol and click OK.

The Library Browser window for sscustom appears.

3 Locate and expand ssReport, PageList, and PageStyle.

4 Right-click the ssLblSiebel component and select Properties. 

The Component Editor appears.

5 Replace the filename specified in the fileName property.

You can use a graphic file with your company’s logo to replace the Siebel logo 
graphic. Recompiled reports will now display your company’s logo.

NOTE: If there is no logo bitmap for your company, choose any existing bitmap 
file in the C:\Siebdev\rptsrc\language\standard (where language stands for the 
Language Pack you want to deploy, such as enu for U.S. English) directory for 
demonstration purposes. You will need to change the property setting back to 
sslogo5.bmp and recompile later.

6 Click Apply, and save the changes. 

7 Click Close to close the Component Editor, and then close the Library Browser 
window.

To compile and run the report

1 Click the run button to compile and run the report.

2 Click OK in the Requester dialog box to accept the defaults.

The report is generated and appears in the Actuate e.Report Designer 
Professional window.
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To save the changes to sscustom

1 Close the report, then close the report design.

2 Copy the Aclist.rox file from the development directory to the executables 
directory.

3 In Siebel Sales, click View > Reports.

The Reports window appears.

4 From the drop-down list in the Reports window, select Account List.

5 Click Run.

The revised Account List report appears in the browser window.

The majority of Siebel reports are produced using a landscape orientation 
(ssLblSiebel control from ssPage pagestyle). For reports that use a portrait 
orientation, you use ssLblSiebelP from ssPagePortrait. All other instructions remain 
the same.
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New report creation involves putting together report elements from scratch in 
Actuate e.Report Designer Professional. It is the most commonly employed 
technique for satisfying the custom reporting requirements of an organization. 
There are also some shortcut techniques, discussed at the end of this chapter, to 
speed up the creation of a new custom report.

Creating a New Report Versus Subclassing a Design
New report creation is in contrast to report subclassing. You create a new report 
when your requirements are not satisfied by any existing report and there are 
significant differences between your desired report and any existing report. You 
obtain a new report by subclassing when the differences between your new report 
and an existing report are minor and you want the new report to include any 
upgrades made to the old one.

The following are some situations in which you create a new report:

■ When the list of fields in the report’s object definitions differs from that in the 
existing report by more than a small number of fields.

■ When the component structure of the report differs from those of related reports 
for example, with the addition or removal of a group section or subreport.

NOTE: Group sections are described in Chapter 7, “Reports with Group Sections.” 
Subreports are described in Chapter 8, “Master-Detail Reports.”

■ When the custom report uses a new business component.
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The following are some situations in which you subclass an existing report design:

■ When you are deploying multiple similar versions of the same report showing 
slightly different data to different categories of users.

■ When two reports show the same data but present it differently.
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How a Simple List Report Works
Figure 7 illustrates the structure of a simple list report.

This list report includes the following major components:

■ Report Design. This is the top-level component in a report; it corresponds to the 
ROD file in which it resides. In a simple report, you do not need to modify the 
top-level component; you only add child components to it. In a more complex 
design, you may add global variables to the report design component. 

■ Report Section. A report section groups together components that define the 
source of data, physical layout, and behavior of a master report or subreport. 

■ DataStream. A datastream component defines the source of data for a report 
section. In simple Siebel reports, the datastream always consists of the contents 
of the data supply library (ROL) file, which defines the transfer of data from a 
Siebel view to the Actuate report. In more complex reports, additional 
datastreams may manipulate the data obtained from the library datastream.

Figure 7. Simple List Report Structure
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■ Page Header Frame. A frame is a rectangular layout area for data controls, labels, 
and other visual components. The contents of the page header frame are 
displayed at the beginning of each new page. In a simple list report, the page 
header shows only the column headings for the report columns. In a more 
complex report with group breaks, the page header shows group break 
information, such as the account name and location for each group of 
opportunities by account.

■ Content Frame. The content frame defines the layout of one report row. Each data 
record that is obtained through the datastream is formatted according to the 
layout of data controls in the content frame. 

■ Pagelist Section. The pagelist section defines the page layout of the report, 
including information to be presented at the top and bottom of the page, such 
as the report name, page number, and company logo. It also defines the area of 
the page that can be used for presenting data generated in report sections. You 
incorporate a standard Siebel report pagelist component and make modifications 
to a few properties, such as the report title.

Examining an Existing List Report
To learn more about the configuration of a simple list report, it is helpful to open a 
standard Siebel report of this type in Actuate e.Report Designer Professional and 
study it. A good report to study for this purpose is the Activity List report, which is 
invoked from a view in the Activities screen (typically the My Activities view). You 
should examine the report output in Siebel Sales, and the report design in Actuate 
e.Report Designer Professional, leaving both open to compare them.

To generate the Activity List report in Siebel Sales

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Activities > My 
Activities.

3 Click View > Reports.

The Reports window appears.

4 From the drop-down list, select Activity List.

Click Run Now.
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The Activity List report appears in the browser window.

To open the report design for the Activity List report

1 Open Actuate e.Report Designer Professional.

2 Choose File > Open from the menu bar.

3 In the Open dialog box, navigate to the C:\Siebdev\rptsrc\language\standard 
folder (or the equivalent on your computer) and choose Actlist.rod.

NOTE: Actlist.rod is not to be confused with Aclist.rod, which is the Account List 
report. The correct one to open here is the Activity List report—Actlist.rod.

Figure 8 shows the Actlist.rod report design file in Actuate e.Report Designer 
Professional.

Explore the report design, expanding and closing folders in the tree diagram on the 
left, comparing design elements to the corresponding features in the report output, 
and right-clicking components to view their property lists.

Notice some features of this report design:

■ Component names that are light gray are being referenced in a library. 
Component names in black have been subclassed, making them available for 
local modification in the report without affecting the original. The same color 
scheme is used for methods. The name of a method (in the Methods tab in the 
Properties window for a component) that has been locally modified is black. The 
names of unmodified methods obtained from the superclass of the component 
are light gray.

Figure 8. Activity List Report Design
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■ The name of the datastream component, ssActionQuery, is gray, indicating that 
it is referenced, not local. If you open the Properties window for this component 
and click the Class tab, you can see that the original is in the Aclist.rol library 
file. Aclist.rol is the data supply library file generated from Siebel Tools.

■ If you expand the datastream component, you can see that it has a child data 
row component, ssActionDataRow. This, too, is referenced rather than local, and 
comes with ssActionQuery from the data supply library file. If you open the 
Properties window for ssActionDataRow and click the Variables tab, you can see 
that the data row component consists of variables (such as ssAccount_Location, 
ssAccount_Name, and ssContact_First_Name) that are derived from the list of 
fields in the business component record supplying the data. 

NOTE: Specifically, these fields are generated from the list of report field children 
of the report object definition from which the data supply ROL file is generated.

All the data definition work for the report design is handled for you after you 
create your report and report field object definitions and generate the ROL file in 
Siebel Tools. In simple reports, the generated datastream is incorporated into 
your report design without modification, and you do not need to do anything 
else to set up data transfer between your Siebel application and Actuate.

■ If you expand the page header component (ssFrmACLISTHdr) and its child 
content frame (ssFrmBlueBack1), you can see how all the column heading labels 
and the blue line above them are defined. When you click a visual element in 
the layout pane or the structure pane, it is selected in both places. View the 
property list for one of the labels to see how its text, font, and other physical 
attributes are set up. Gray property text is the default from the parent object 
(ssLblHead in the sscustom.rol library); black text has been changed from the 
default.
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■ Click the library browser button. In the Choose Included Module window, 
double-click sscustom.rol. The listed components are library components; they 
serve as building blocks for your report. Browse through the list of library 
components in the sscustom library and compare them to similarly derived 
components in the report design. 

Generally, any items that you need to incorporate into a simple report are 
derived from generic components in the sscustom.rol library (except the 
datastream, which comes from the data supply library). These library 
components generally require only minor modification after they are introduced 
into the report design. In Actlist.rod, the labels, text controls, content frames, 
horizontal lines, and pagelist are derived from library components in 
sscustom.rol.

You can now close or minimize the sscustom.rol Library Browser window.

■ Expand the main content frame (ssFrmACTLISTContent). The child objects of 
this frame are all data controls. A data control displays the value in a field (or 
fields) obtained through the datastream. Open the Properties window for one of 
the data controls and note the setting in the ValueExp property. The ValueExp 
property holds the expression that determines what is displayed in the text 
control.

In the next section, you will create a similar report design yourself.
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In this example, you create an opportunity list report. It lists the account name, 
opportunity name, expected revenue amount, and close date for every visible 
opportunity record. The resulting report will look like the one shown in Figure 9.

The following tasks are required to create the report:

■ Create and export a new report object definition (and children) in Siebel Tools.

■ Create a report design in Actuate.

■ Add data control and label elements to the design.

■ Compile and test the report.

Figure 9. Example Report
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Creating a New Report Object Definition in Siebel Tools
Each report design, whether custom or standard, normally has its own report object 
definition in Siebel Tools and a corresponding data supply library file. Report (and 
child) object definitions and exported datastream libraries are explained in “Data 
Definition for Reports” on page 101. 

In this example, you create a report object definition and children from scratch. An 
alternative approach is discussed in “Copying a Report Object Definition” on 
page 151.

To create a new report object definition (and children) in Siebel Tools

1 Open Siebel Tools. Navigate to the Report object type in the Object Explorer. 
Lock the Report project before proceeding to the next step. See Project in Step 3 
for more information. 

2 Click any record in the Object List Editor. Add a report record by choosing
Edit > New Record.

3 In the new report record in the Object List Editor, enter properties as follows:

■ Name. Test Report

This is the name used to refer to the report structure in Siebel Tools, for 
instance when you add the report to the Reports menu for a view.

■ Project. Report

The Report project is standard for Siebel Sales. Report (SSV) is typically used 
for Siebel Service. Report projects are usually tied to specific Siebel 
applications.

■ Access Base DB Name. TESTREPT 

This specifies that Testrept.rox will be the name of the report executable 
invoked when this report object definition is invoked from the Reports menu 
in a view. 

NOTE: Capitalization is not required, although this value for standard reports 
is capitalized.
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■ Business Component. Opportunity 

The business component specified here is one that provides the records for 
the main report. Subreports (in more advanced reports) have their own 
business components.

■ Class. CSSActuateReportViewer

This specifies that the report is an Actuate report. The other options in the 
picklist (CSSAccessReport, CSSCrystalReport, and CSSReport) specify other 
reporting software.

■ Menu Text. Test Report

This is the text that will appear in the Reports menu for a view when this 
report is included in the view through the use of a view report object 
definition.

■ Template Name. TESTREPT 

Specifies the name to be used for the generated data supply library file when 
the Generate Actuate Report option is invoked for this report object 
definition. 

NOTE: Capitalization is not required, although the values of this property for 
standard reports are capitalized.
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4 Expand the Report object type in the Object Explorer tree and click the Report 
Field child object type to select it. 

Add a report field object definition by choosing Edit > New Record. Click the 
Field property. In the Field pick applet, choose Name.

The Business Component property setting in the parent report object definition 
determines which fields can be included as report fields—namely, fields in that 
business component. Each report field object definition that you add as a child 
of the report defines a field that will be exported in the data supply library.

NOTE: A business component must be active before you can query a field in that 
business component. If the business component is not active, the field will not 
appear in the Reports Field dialog box.

Repeat this step for the Account, Revenue, and Close Date fields. 

You can type in the name rather than looking it up in the pick applet. Match the 
spelling exactly.

5 Click the parent object definition (Test Report) in the upper Object List Editor 
window. Choose Tools > Utilities > Generate Actuate Report.

This generates a data supply ROL file, named according to the value in the 
Template Name property, in the C:\Siebdev\rptsrc\enu\lib folder (or the 
equivalent on your system).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

6 Navigate to the View object type in the Object Explorer.

7 In the Object List Editor, locate the Opportunity List View object definition. In 
the Object Explorer, expand View and click on View Report.

This is the My Opportunities view in the Opportunities screen. You will add the 
new report to the Reports menu for this view.
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8 Add a view report object definition in the Object List Editor. Enter the name “Test 
Report” (match spelling and spacing exactly) and a sequence number that is 
greater by 1 than any other sequence number in the list.

The name that you specify identifies the report object definition that defines the 
report, including the menu text to display and the report executable to invoke. 
The sequence number specifies the report’s position in the menu relative to 
other reports.

9 Choose Repository > Compile and recompile the repository. Move the resulting 
SRF file to C:\Siebel\objects or the equivalent location on your system. 

This last step is necessary for your addition to the Reports menu for the 
Opportunity List view to be recognized. Repository compilation is not necessary 
for generating the data supply ROL file.
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Creating a Report Design in Actuate e.Report Designer Professional
A report design file defines the layout and behavior for one report. In this exercise, 
a new report design is created from scratch, using library components.

To create a report design file in Actuate e.Report Designer Professional

1 Open Actuate e.Report Designer Professional.

2 Choose File > New. In the Create New Report window, select Blank Report and 
click OK. 

A blank design report appears.

3 Delete the following components from the structure tree. 

NOTE: You will need to expand the Content - Report section on the structure pane 
to see the components.

■ Connection component. This is a predefined connection that is not used to 
create Siebel reports.

■ DataStream component. This component will be replaced with the datastream 
created in Siebel Tools.

■ Content - Frame component. This component will be replaced with a 
subclassed frame.

4 Choose Tools > Library Organizer and click More.

The Include Library window appears.

a Click Browse and navigate to C:\Siebdev\rptsrc\enu\lib (or equivalent), 
choose sssiebel.rol, and click Open. Click OK to close the Include Library 
window.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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b Repeat this step for the files sscustom.rol and Testrept.rol.

The files sssiebel.rol and sscustom.rol are required libraries for all Siebel 
standard and custom reports. Testrept.rol is the data supply ROL file that you 
generated from Siebel Tools; it will define the way data is transferred to the new 
report.

5 Enter the following information for the report:

a Title. Test Opportunity Report

❏ Expand the PageList slot until you see the Content - ReportTitle slot.

❏ Right-click on the Content - ReportTitle slot and select Properties. 

The ReportTitle - Component Editor appears.

❏ On the Properties tab, scroll down to Text and input Test Opportunity 
Report as the title for the report.

❏ Close the ReportTitle - Component Editor.

This value is used in the window title for the report table of contents in the 
report viewer.

b Filename. C:\Siebdev\rptsrc\enu\Testrept.rod

For example, this is the filename and folder location where the report design 
file you are creating will be saved. Because this is a custom report, it should 
not be stored in the same folder as the standard reports (...\enu\standard), 
and ROD files also should not be saved in the same folder as the library files 
(...\enu\lib). You can either save the file directly in ...\enu or create a new 
subfolder of \enu called \enu\custom (or equivalent). 

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

■ Choose File > Save and input the filename to be used for this report.
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c Report Root Name. Testrept

This specifies the name of the top-level report design object in the design file. 

❏ Right-click on the top-level object (default name NewReportApp) and 
select Rename. 

The Rename window appears. 

❏ For the new name, input Testrept. 

The name must be the same as the name used for the ROD file you saved in 
Step b on page 142 (without the ROD extension).

6 Choose File > Save. Specify Testrept.rod in the ...\enu (or ...\enu\custom) 
folder.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

Remember to save the design file periodically as you work.

7 Double-click the Testrept (top level) icon in the structure tree. 

a In the Component Editor window, click the Class tab. 

b Change the Super Class value from AcReportSection to ssRpt.

This is an important step. Siebel reports must inherit from ssRpt (the Siebel 
standard report) instead of directly from AcReportSection (Actuate report). ssRpt 
is provided in sscustom.rol and inherits from baseReport from sssiebel.rol. 

NOTE: You cannot perform this step until you have included the sssiebel.rol 
library.

Two components are automatically added to the report when you change the 
report’s class: a report section (Report) and a pagelist section (ssPageList).
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8 Make sure that the Show Empty Slots option in View > Options is checked.

You may want to deselect this option at a later time if you find the display of 
empty slots in the structure tree and layout pane distracting. For now, the empty 
slots must be visible because components will be dragged onto them from the 
sscustom library.

9 Expand the top-level report component. 

a Right-click the report section child component in the structure tree (Report) 
and select Slot Information. 

The Single Structure Reference window appears.

b Change Name in the Contents section to ssRpt and click Close. 

c Right-click the report section child component now named ssRpt1 and click 
Subclass. Click Close.

You must subclass each component you introduce into the report if you plan on 
modifying the component. Otherwise, the system will not allow your changes.

10 Right-click the report section component (ssRpt1) and click Rename. Change the 
name to ssRptOpportunity.

It is good design practice to employ naming conventions for components in your 
reports and to give them meaningful names. The ssRpt prefix indicates that this 
is a report section based on the ssRpt library component. The Opportunity suffix 
identifies this as the master report section in which opportunity records are 
displayed.

11 Click the library browser button and open the sscustom.rol library. From the 
Library Browser window, drag and drop the ssFrm component onto the Content 
slot. 

This creates a frame that defines what appears in each report row. The frame is 
a child of the report section component.

a Right-click the new frame (ssFrm) and select Slot Information. On the Single 
Structure Reference window, click Subclass. Click Close.

b Right-click the same frame and select Rename. Rename it 
ssFrmOpportunityContent. Close the Library Browser window.
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12 Click the library browser button and choose Testrept.rol in the dialog box. 

The Library Browser window opens, displaying the contents of Testrept.rol, 
which is the data supply library you generated in Siebel Tools.

13 Drag and drop the datastream component (ssOpportunityQuery) from the 
Library Browser window onto the DataStream slot in the Design Editor. Close the 
Library Browser window.

The datastream component is now a child of the report section component. The 
datastream defines the way data is supplied to generate report rows. Each data 
record generates one report row in the parent report section. Note that you do 
not subclass the datastream component, because it is used in the report in 
unmodified form.

When making changes in Siebel Tools for a report originally designed in Actuate 
e.Report Designer Professional and regenerating an ROL file, be aware of the 
following: 

■ Make sure that the ROD file that uses the ROL file is not open in Actuate e.Report 
Designer Professional. 

■ If any report fields are deleted, make sure to remove the fields from your Actuate 
report as well.

■ Changes made to the ROL file are valid only for that instance of the ROL file. The 
changes will need to be entered again. However, if the changes are locally 
subclassed, they are safely stored in the ROD file.
Version 7.5, Rev B Siebel Reports Administration Guide 145



Creating a Simple List Report

Example—Creating a Simple List Report
Adding Label and Data Elements to the Design
At this point, you have created the report design file and three of its key structural 
components: the report design (root), the report section, and the pagelist. You have 
also obtained the datasource, by reference, from the datasource library file that you 
previously generated, and put it in the report section whose data it will supply. Now 
you create a frame for the page header to define the elements that appear at the top 
of each page, and a main content frame to define the elements that appear in each 
report row.

To add text and label elements to the design

1 Drag and drop the ssTxt component from the Library Browser window onto the 
empty Content child slot of the content frame (ssFrmOpportunityContent). 

The Component Properties dialog box appears.

2 In the Component Properties dialog box, select the ssName field from the 
datastream by clicking it in the drop-down list, then click OK to dismiss the 
Component Properties dialog box.

You specify the source of data for a data control in the ValueExp property.

3 Resize the new data control on the layout grid to make it the appropriate size for 
name data (if it is too narrow, the name will be truncated).

Right-click the data control and select Rename in the menu. Give the text control 
a unique descriptive name, in this case txtOpportunity. 

You generally obtain the prefix in a report design component from somewhere 
in the name of its parent library component. The txt prefix (from ssTxt) is a 
reasonable standard for dynamic data controls derived from ssTxt and is 
consistent with naming in standard reports.
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4 Right-click the data control and select Properties in the menu. Check the 
CanGrow property to verify that it is set to TRUE. 

When this property is TRUE, multiple-line values in the business component 
fields print as multiple-line values in the report. When it is FALSE, only the first 
line of each value prints. 

NOTE: When possible, use the Default button in the Component Editor window 
to reset a property such as CanGrow to its default (TRUE in this case) rather than 
entering the value manually. This helps to keep the inheritance intact by 
eliminating unnecessary subclassing.

5 Repeat Step 3 on page 146 through Step 7 to add the following:

■ A control called txtAccount based on the ssAccount datastream variable

■ A control called txtRevenue based on ssRevenue_Formatted

■ A control called txtCloseDate based on ssClose_Date 

Note that you drop the ssTxt component on the parent content frame 
(ssFrmOpportunityContent) because there are no empty child slots for the 
purpose. Also note that you need to reposition each data control in the layout 
pane to the right after it is created.

6 Drag and drop the ssFrmBlueBack library component onto the empty page 
header slot. Subclass the new frame component (using the subclassing 
instructions from “Creating a Report Design in Actuate e.Report Designer 
Professional” on page 141) and rename it ssFrmOpportunityHeader.

The page header will contain the column headings. Bold white column heading 
labels on a blue-green background are standard in Siebel reports and give your 
custom report the same appearance.

7 Drag and drop the ssLblHead component onto the page header frame 
(ssFrmOpportunityHeader), once each to create the labels indicated below. Set 
the Text property for each label as indicated. You will need to resize, reposition, 
and rename each label after it is created. Each label should be aligned vertically 
with the corresponding data control:

■ A label called lblOpportunity, with a Text property value of Opportunity

■ A label called lblAccount, with a Text property value of Account
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■ A label called lblRevenue, with a Text property value of Revenue

■ A label called lblCloseDate, with a Text property value of Close Date

8 Set the AlternateLines attribute of the ssFrmOpportunityContent frame to 1. A 
line separator is automatically added to each displayed content row frame.

The separator line creates a demarcation between report rows.

9 Right-click the top-level report component and choose Properties. Enter a value 
of Test Report in the ssReportTitle property. 

This defines the title to be printed in the blue-green area on the upper left.

Compiling and Testing the Report
The report must be built and compiled in Actuate e.Report Designer Professional for 
you to run it. Then it can be debugged locally in Actuate e.Report Designer 
Professional and, when it is ready to be deployed, the executable version of the 
report is moved to the folder where Siebel applications obtain their report 
executables.

To compile and install the report

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities. 

Make sure that the desired query is active.

The appropriate application and view must be open for the report to obtain 
records. Also, the set of records displayed in the view is the set of records that 
is used in the report.
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3 In Actuate e.Report Designer Professional, click the run button.

The report appears in the Web browser. You can test your report as you develop 
it in Actuate. Note that the report displays the data records in the same order in 
which they are displayed in the Siebel application. If the Actuate Output window 
displays an error message indicating that no data is available for the report, 
make sure that your Siebel application has queried the appropriate records and 
that the cursor is positioned on the first record.

NOTE: If the cursor is positioned on a record other than the first one, not all 
records will be displayed. This is because of the Forward Only mode of the 
query. 

4 Make corrections to the report design as necessary and recompile as often as 
required.

NOTE: While making corrections to the report, if you need to review the Actuate 
Output window for the previous error message, go to View > Output Window 
or use the hotkey Alt-v followed by w.

5 Use Microsoft Windows Explorer to copy the Testrept.rox file from 
C:\Siebdev\rptsrc\enu (or equivalent) to C:\Siebel\reports\enu (or equivalent).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

6 In Siebel Sales, choose View > Reports.

The Report window appears.
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7 From the drop-down list in the Report window select Test Report.

8 Click Run Now.

The report should appear in Siebel Sales. If there are problems, verify the 
following:

■ If there is no Test Report option in the Reports menu, verify that the My 
Opportunities view is active. If the correct view is active, your problem lies 
in the configuration of the view report object definition that defines this 
menu option. Make sure that it is a child of the correct view (Opportunity 
List view).

■ If a message appears that the Siebel application cannot find the report, verify 
that you have moved the executable to the correct folder.
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Alternative Report Creation Strategies
The procedure outlined in the preceding sections is one approach to creating a new 
custom report. There are alternative approaches to part or all of the process. Some 
of these are explained briefly in the sections that follow.

Copying a Report Object Definition
The procedure for creating a new report object definition (and children) in Siebel 
Tools, described in “Creating a New Report Object Definition in Siebel Tools” on 
page 137, may prove cumbersome when a new set of object definitions needs to be 
created that is very similar to an existing one and the existing one is complex. An 
alternative is to copy the desired report object definition. This creates a new one 
with the same property settings, child report field, and subreport object definitions. 

To copy an existing report object definition and children

1 In Siebel Tools, navigate to the Report object type and the report object definition 
you want to copy.

2 Lock the Report project (choose Repository > Lock Project).

3 Choose Edit > Copy Record.

This creates a new report object definition with the same set of children and 
duplicated property settings. The exceptions are the Menu Text and Name 
properties, which you must specify. You should also change the Template Name 
and Access Base DB name settings, so that the data supply library and 
executable report have different names from those in the original.

4 Make alterations as necessary to the new report object definition and children.

5 Export to a data supply library file by choosing Tools > Generate Actuate Report.

6 Unlock the Report project.
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Copying a Report Design
An Actuate report design (ROD) file can be copied to a new file (with a different 
name) using Windows Explorer or the File > Save As option in Actuate e.Report 
Designer Professional. Actuate treats the new design as independent from the 
original, but maintains all relationships with included libraries. 

This is a desirable approach when you wish to reuse many of the design elements 
in an existing report design, but have various modifications to make. This is a 
common situation, and you will find this technique valuable.

After you copy an existing report design, make the following modifications to the 
new report design:

■ Make a copy of the original report design definition with a new name, as 
described in “Copying a Report Object Definition” on page 151. Remove the 
existing datastream from the report design, and drag and drop the new one onto 
the report design from the new data supply library file. This is an important step 
because it is impractical to have two report designs sharing a single datastream 
and a single report object definition.

■ Make sure that the report object definition has the correct settings in the 
Template Design and Access Base DB Name properties corresponding to the new 
report design.

■ Rename the top-level report component. This is not a critical step, but it helps 
you orient yourself when you are working on each report in Actuate e.Report 
Designer Professional.

Using a Custom Component Library
If you create a design component and child components that will prove useful in 
similar reports, you can create a custom component library that allows you to reuse 
these components. An example of a custom component library is the ssQuote.rol 
library used in various quote reports, including Quotestd.rod, Quotepro.rod, and 
Quosum.rod. 

Typically, this technique is used to reuse page header, page footer, or content frames 
containing a number of labels and data controls, but any component and its 
children can be published in this fashion for reuse.
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To create a custom component library

1 Open the report design that contains the components you want to publish in the 
custom library.

2 Choose Tools > Library Organizer. 

The Library Organizer window appears.

a Click New.

b Specify the destination folder (this should be C:\Siebdev\rptsrc\enu\lib or 
equivalent) and filename (the filename should begin with ss, to designate it 
as a Siebel custom library and distinguish its name from those of the 
datastream libraries). Click Save.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

c Click OK on the Library Organizer window.

The Library Browser window opens for the new library, containing only the top-
level library component.

3 Drag and drop the desired parent component from the report design (such as a 
content frame) onto the top-level library component. 

The Component Drop dialog box appears.

4 Click the Publish the component radio button and click OK.

The component that you published and its children are added to the library. 
Their names in the report design file are changed to light gray, indicating that 
they are now subclassed components from the version in the library.

5 Move other components to the library from this file and other report design files.
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This chapter discusses the use of group sections to create reports with group breaks. 
Group breaks are the points in a list of records where the value changes in a key 
field, resulting in special processing—usually including the printing of a new 
heading, and sometimes a page break. For example, in a list of accounts, you may 
want a heading displaying the account name before the group of records for each 
account. A change in the account name field between records triggers a new 
heading. 
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Using Group Sections Overview
In Siebel reports, group break behavior is implemented through the use of a group 
section component in the report design. 

Note that the business component records must be sorted with the group field as 
the primary sort key (generally in the Sort Specification property of the report object 
definition, if it is different from the default sort order for the business component). 
Otherwise, the records do not group properly.

Note also that a group section is for clustering records of a single business 
component, based on a field or fields in that business component. This is a different 
scenario from listing detail records of another business component for each master 
business component record. The latter scenario requires configuration of a master-
detail report, as described in Chapter 8, “Master-Detail Reports.” This does not 
preclude the use of group sections within a master-detail report, either at the master 
level or in one or more of the subreports.

This following examples represent reports using single group sections. Group 
sections can also be placed inside another group section, known as nesting groups. 
Nesting groups are created by placing the outermost group section in the Content 
slot of a report section. For more information, see “Working with Sections” in 
Developing Advanced e.Reports manual on the Siebel eBusiness Third-Party 
Bookshelf under Actuate.
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How a Group Section Works
Figure 10 illustrates the structure of a simple report that employs a group section.

This includes the following major components:

■ Report Design. This is the top-level component in a report; it corresponds to the 
ROD file in which it resides. There are no special features of the report design 
component for group reports.

■ Report Section. A report section groups together components that define the 
source of data, physical layout, and behavior of a master report or subreport. 
The group section is a child of the report section whose records the group section 
will cluster.

Figure 10. Group Report Structure
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■ DataStream. The datastream component defines the source of data for the report 
section. There are no special features of a datastream for a grouped report 
section, other than the requirement that the data be sorted with the group field 
as the primary sort key.

■ Group Section. The group section component implements grouping and group 
break behavior for the records in its parent report section. The group section has 
a Key property that defines the field that determines how the records are 
grouped, and other properties that define grouping behavior, such as whether 
each group break causes a page break.

■ Page Header Frame. In a report section with a group section, the page header 
frame is a child of the group section, not of the report section. The contents of 
the page header frame are displayed at the beginning of each new group, in 
addition to the beginning of each page. The page header contains group break 
information, such as the sales stage name for each group of opportunities by 
sales stage.

■ Content Frame. The content frame defines the layout of one report row, as it does 
in a nongrouped report section. However, it is a child of the group section, rather 
than of the report section.

■ After Section. The After section defines what appears in the report following each 
group. This section can be omitted or used to display group totals. See “Group 
Totals” on page 174 for details.

Examining a Report with a Group Section
To learn more about the configuration of a simple grouped report, it is helpful to 
open a standard Siebel report of this type in Actuate e.Report Designer Professional 
and study it. A good report to study for this purpose is the Contacts By State 
parameterized report, which is invoked from a view in the Contacts screen 
(typically the My Contacts view). You should examine the report output in Siebel 
Sales, and the report design in Actuate e.Report Designer Professional, leaving both 
open to compare them.

To generate the Contacts By State report in Siebel Sales

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Contacts > My 
Contacts. 
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3 While in the My Contacts view, from the application-level menu, choose View 
> Reports. 

4 From the drop-down menu, select Contacts By Category and click Run Now.

The Contact By Category Parameters window appears. 

5 From the Sort by drop-down menu, select State, and click Finish.

The Contacts By State report appears.

To open the report design for the Contacts By State report

1 Open Actuate e.Report Designer Professional.

2 Choose File > Open.

3 In the Open dialog box, navigate to the C:\Siebdev\rptsrc\enu\standard folder 
(or the equivalent on your computer) and choose cntcat.rod.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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Figure 11 shows the cntcat.rod report design file in Actuate e.Report Designer 
Professional.

Explore the report design, compare design elements to the corresponding features 
in the report output, and right-click components to view their property lists.

Notice the following features of this report design:

■ The group section component, ssGrpState, has child page header and content 
frames. These are ssFrmCONTACTHeader1 and ssFrmCONTACTContent. These 
frames are subclassed from the ssCntct.rol custom component library because 
the same header and content frames are used in most of the contact reports. For 
more information on custom component libraries, see “Using a Custom 
Component Library” on page 152.

■ If you expand the page header component (ssFrmCONTACTHeader1), you will 
see a child content frame (ssFrmBlueBack1). If you expand the child content 
frame, you see the column heading labels that appear in the page header. 

■ Another child component of the page header is a data control called 
ssTxtCONTACTHeader1. When you select this control in the component tree, it 
is also selected in the layout pane (the sample text in the control says Subclass 
Me).

Figure 11. Contacts By State Report Design
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■ The page header data control (ssTxtCONTACTHeader1) displays the state name 
abbreviation for each new state. You can see this in the generated report in Siebel 
Sales. The property in the data control that configures this behavior is ValueExp. 
The value of this property is ssState, which is the datastream variable 
corresponding to the State field in the Contact business component.

■ If you examine the properties in the group section component (ssGrpState), you 
will notice that it has a Key property and that this property has a setting of 
ssState. The Key property value in the group section component determines 
when a sort break occurs, namely when there is a change in the value in the 
corresponding field between business component records. The change in group 
key values triggers the redisplay of the page header with new values.

In the next section, you will create a similar report design yourself.
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Example—Creating a Report with a Group Break
In this example, you create an opportunity list report in which the opportunity 
records are grouped by sales stage. It lists the opportunity name, account name, 
expected revenue amount, and close date for each opportunity record, and displays 
the sales stage in the page header before each group of opportunity records with 
that sales stage. As stated, the resulting report will look like the one in Figure 12.

The following tasks are required to create the report:

■ Create and export a new report object definition (and children) in Siebel Tools.

■ Create a report design in Actuate e.Report Designer Professional.

■ Add data control and label elements to the design.

■ Compile and test the report.

Figure 12. Example Report with a Group Break
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Creating a New Report Object Definition in Siebel Tools
Each report design normally has its own report object definition in Siebel Tools and 
a corresponding data supply library file. In Chapter 6, “Creating a Simple List 
Report,” the report object definition was created from scratch. In this example, you 
copy an existing report object definition (and children) and change some property 
values. 

To create a new report object definition in Siebel Tools by copying

1 In Siebel Tools, navigate to the Report object type in the Object Explorer and 
select the Opportunity List - Current Query report object definition in the Object 
List Editor.

Lock the Report project (choose Repository > Lock Project).

2 Choose Edit > Copy Record.

This creates a new report object definition, with the same set of children as the 
original, and duplicated property settings. 

3 Change the following property settings in the new report object definition (the 
other property settings do not need to be changed):

■ Name. Test Group Report

This is the name used to refer to the report structure in Siebel Tools, for 
instance when you add the report to the Reports menu for a view.

■ Access Base DB Name. GROUPRPT 

This specifies that GROUPRPT.rox will be the name of the report executable 
invoked when this report object definition is invoked from the Reports menu 
in a view. 

■ Menu Text. Sales Stage - Test

This is the text that will appear in the Reports menu for a view when this 
report is included in the view through the use of a view report object 
definition.
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■ Template Name. GROUPRPT 

Specifies the name to be used for the generated data supply library file when 
the Generate Actuate Report option is invoked for this report object 
definition.

■ Sort Specification. Sales Stage

Sorts the opportunity records into sales stage order, which is necessary for 
the group breaks to work correctly. This specification is translated into 
corresponding code in the datastream methods.

4 Export to a data supply library file by choosing Tools > Utilities > Generate 
Actuate Report.

This generates a data supply ROL file, named according to the value in the 
Template Name property, in the C:\Siebdev\rptsrc\enu\lib folder (or equivalent 
on your system). 

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

5 Unlock the Report project.

6 Navigate to the View object type in the Object Explorer.

7 In the Object List Editor, locate the Opportunity List View object definition. In 
the Object Explorer, expand View and click on View Report.

This is the My Opportunities view in the Opportunities screen. 

8 Add a view report object definition in the Object List Editor. Enter the name “Test 
Group Report” (match spelling and spacing exactly) and a sequence number that 
is 1 greater than any other sequence number in the list.

9 Select Repository > Compile and recompile the repository. Move the resulting 
SRF file to C:\Siebel\objects (or the equivalent location on your system). 
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Creating a Report Design in Actuate e.Report Designer Professional
In this exercise, a new report design is created from scratch, using library 
components.

To create a report design file in Actuate e.Report Designer Professional

1 Open Actuate e.Report Designer Professional. 

2 Choose File > New. In the Create New Report dialog box, select Blank Report 
and click OK.

A blank design report appears.

3 Delete the following components from the structure tree. 

NOTE: You will need to expand the Content - Report section on the structure pane 
to see the components.

■ Connection component. This is a predefined connection that is not used to 
create Siebel reports.

■ DataStream component. This component will be replaced with the datastream 
created in Siebel Tools.

■ Content - Frame component. This component will be replaced with a 
subclassed frame.

4 Choose Tools > Library Organizer and click More.

The Include Library window appears.
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a Click Browse and navigate to C:\Siebdev\rptsrc\enu\lib (or equivalent), 
choose sssiebel.rol, and click Open. Click OK to close the Include Library 
window.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

b Repeat this step for the files sscustom.rol and Grouprpt.rol.

5 Enter the following information for the report:

a Title. Grouped Opportunity Report

❏ Expand the PageList slot until you see the Content - ReportTitle slot.

❏ Right-click on the Content - ReportTitle slot and select Properties. 

The ReportTitle - Component Editor appears.

❏ On the Properties tab, scroll down to Text and input Test Opportunity 
Report as the title for the report.

❏ Close the ReportTitle - Component Editor.

This value is used in the window title for the report table of contents in the 
report viewer.
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b Filename. C:\Siebdev\rptsrc\enu\Grouprpt.rod

This is the filename and folder location where the report design file you are 
creating will be saved. Because this is a custom report, it should not be stored 
in the same folder as the standard reports (...\enu\standard), and ROD files 
also should not be saved in the same folder as the library files (...\enu\lib). 
You can either save the file directly in ...\enu or create a new subfolder of 
\enu called \enu\custom (or equivalent). 

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

❏ Choose File > Save and input the filename to be used for this report.

c Report Root Name. Grouprpt

This specifies the name of the top-level report design object in the design file. 

❏ Right-click on the top-level object (default name NewReportApp) and 
select Rename. 

The Rename pop-up window appears. 

❏ For the new name, input Grouprpt. 

The name must be the same as the name used for the ROD file you saved in 
Step b on page 167 (without the ROD extension).
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6 Choose File > Save. Specify Grouprpt.rod in the ...\enu (or ...\enu\custom) 
folder.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

Remember to save the design file periodically as you work.

7 Double-click the Grouprpt (top level) icon in the structure tree. 

a In the Component Editor window, click the Class tab. 

b Change the Super Class value from AcReportSection to ssRpt.

This is an important step. Siebel reports must inherit from ssRpt (the Siebel 
standard report) instead of directly from AcReportSection (Actuate report). ssRpt 
is provided in sscustom.rol and inherits from baseReport from sssiebel.rol. 

NOTE: You cannot perform this step until you have included the sssiebel.rol 
library.

Two components are automatically added to the report when you change the 
report’s class, a report section (Report) and a pagelist section (ssPageList).

8 Make sure that the Show Empty Slots option in View > Options is checked.

You may want to deselect this option at a later time if you find the display of 
empty slots in the structure tree and layout pane distracting. For now, the empty 
slots must be visible because components will be dragged onto them from the 
sscustom library.

9 Expand the top-level report component. 

a Right-click the report section child component in the structure tree (Report) 
and select Slot Information. 

The Single Structure Reference pop-up window appears.
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b Change Name in the Contents section to ssRpt and click Close. 

c Right-click the report section child component now named ssRpt1 and click 
Subclass.

You must subclass each component you introduce into the report if you plan on 
modifying the component. Otherwise, the system will not allow your changes.

10 Right-click the report section component (ssRpt1) and click Rename. Change the 
name to ssRptOpportunity.

11 Expand the report section component (ssRptOpportunity). Click the library 
browser button and choose sscustom.rol. Drag and drop the ssGrp library 
component onto the Content child slot of the report section.

12 Right-click the group section component (ssGrp) and select Slot Information. On 
the Single Structure Reference pop-up window, click Subclass. Click Close. 

13 Right-click the group section component (ssGrp1) and click Rename. Change the 
name to ssGrpStage.

14 Drag an ssFrm control from the Library Browser window onto the group 
section’s Content slot. Repeat Step 12 and Step 13 to rename the subclassed 
frame ssFrmOpportunityContent.

15 Right-click the group section component (ssGrpStage) and click Properties. In 
the Key property, enter ssSales_Stage. Close the Component Editor window.

16 Drag and drop the ssFrm component from the Library Browser window onto the 
group section’s PageHeader slot. 

17 Repeating Step 12 and Step 13, subclass the frame and rename it 
ssFrmStageHeader. 

18 Close the Library Browser window.

19 Click the library browser button and choose Grouprpt.rol in the dialog box. 

The Library Browser window opens, displaying the contents of Grouprpt.rol, the 
data supply library you generated in Siebel Tools.

20 Drag and drop the datastream component (ssOpportunityQuery) from the 
Library Browser window onto the DataStream slot in the Design Editor, then 
close the Library Browser window.

The datastream component is now a child of the report section component.
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Adding Label and Data Elements to the Design
Now you add data controls in the content frame (for each report row) and column 
heading labels in the page header (for each page break or sort break). You also 
define a sales stage control in the page header to display the sales stage with each 
group or page break.

To add text and label elements

1 Click the library browser button and select sscustom.rol in the Choose Included 
Module dialog box.

2 Drag and drop the ssTxt component from the Library Browser window onto the 
empty Content child slot of the content frame (ssFrmOpportunityContent). 

The Component Properties dialog box appears.

3 In the Component Properties dialog box, select the ssName field from the 
datastream by clicking it in the drop-down list, then click OK to dismiss the 
Component Properties window.

4 Resize the new data control on the layout grid to the appropriate size for 
opportunity name data (if it is too narrow, the name will be truncated).

5 Right-click the data control and select Rename from the pop-up menu, then give 
the text control a unique descriptive name (in this case, txtOpportunity). 

6 Right-click the data control and select Properties from the pop-up menu, then 
check the CanGrow property to verify that it is set to TRUE. 

When this property is TRUE, multiple-line values in the business component 
fields print as multiple-line values in the report. When it is FALSE, only the first 
line of each value prints. 

7 Repeat Step 2 through Step 6 to add the following:

■ A control called txtAccount based on ssAccount

■ A control called txtCloseDate based on ssClose_Date 

Note that you need to reposition each data control in the layout pane to the right 
after it is created.
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8 Drag and drop the ssCur component from the Library Browser window onto the 
content frame ssFrmOpportunityContent. 

The Component Properties dialog box appears.

9 In the Component Properties dialog box, select the ssRevenue field from the 
datastream. 

10 Close the Component Properties dialog box, resize and reposition the currency 
control on the layout grid, and rename it curRevenue. 

A currency data control is used rather than a text data control when monetary 
values are to be displayed. This causes correct display and alignment. 

NOTE: The approach described here for currency display is adequate for a test 
report. However, Siebel reports in version 7.0 will use txtCurrency custom 
control from sscustom.rol to make calculated currency values localizable 
(formatted according to user locale). If currency does not require calculation 
then the currency formatted field from the data supply library must be used in 
the regular ssTxt control instead.

11 Enlarge the page header frame (ssFrmStageHeader) vertically by dragging one of 
its handles so that it is about twice its original height.

Additional space will be required for a divider line and the sales stage data 
control.

12 Drag and drop the LineControl library component onto the page header frame 
(ssFrmStageHeader), and rename it LineSeparator.

13 Drag and drop the ssTxtSectionHeadM library component onto the page header 
slot, and in the Component Editor window, specify ssSales_Stage in the 
ValueExp property.

This text control is for display of the sales stage in the page header. It has a 
larger, bold font and is maroon.

14 Subclass the new data control component and rename it ssTxtStageName, then 
widen the control in the layout pane so that it is large enough to hold sales stage 
names.
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15 Drag and drop the ssFrmBlueBack library component onto the page header slot. 

It subclasses automatically. 

16 Rename this frame component ssFrmOpportunityHeader and expand it to reveal 
the child slot.

This frame will contain the column headings. 

17 Drag and drop the ssLblHead component onto the page header frame 
ssFrmOpportunityHeader, once each to create the labels listed below. 

18 Set the Text property for each label as indicated. 

You will need to resize, reposition, and rename each label after it is created. Each 
label should align vertically with the corresponding data control:

■ A label called lblOpportunity, with a Text property value of Opportunity

■ A label called lblAccount, with a Text property value of Account

■ A label called lblCloseDate, with a Text property value of Close Date

■ A label called lblRevenue, with a Text property value of Revenue

19 Drag and drop the LineControl component onto the ssFrmStageHeader frame 
and rename it LineSeparator. 

20 Reposition the line in the layout pane so that it is above the sales stage data 
control.

The separator line creates a demarcation between report rows.

21 Right-click the top-level report component and choose Properties, then enter a 
value of Group Test Report in the ssReportTitle property. 
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Compiling and Testing the Report
The report is built, compiled, and run in Actuate e.Report Designer Professional. 
Then it can be debugged locally in Actuate e.Report Designer Professional; when it 
is ready to be deployed, the executable version of the report is moved to the folder 
where Siebel applications obtain their report executables.

To compile and install the report

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities.

Make sure that the desired query is active.

3 In Actuate e.Report Designer Professional, click the run button.

The report displays in the browser window. 

4 Make corrections to the report design as necessary and recompile as often as 
required.

5 Use Windows Explorer to copy the Grouprpt.rox file from C:\Siebdev\rptsrc\enu 
(or equivalent) to C:\Siebel\reports\enu (or equivalent).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

6 In Siebel Sales, from the application-level menu, choose View > Reports.

7 From the drop-down list in the Reports window, select Sales Stage - Test and 
click Run Now.

The report should appear in the browser window. If there are problems, check 
the configuration of the report and view report object definitions in Siebel Tools.
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Group totals can appear beneath one or more numeric report columns, at the end 
of each group section. They provide subtotals within each group for monetary and 
quantity fields. A grand total of these fields can appear at the end of the report.

Group total data controls are configured in the child After frame of the group 
section. A group total control sums the values of a datastream variable in all the 
report rows in the group. To accomplish this, the Sum function is used. The scope 
of a Sum function within the After frame of a group section is limited to the records 
in that group. For additional information on the Sum function, see the information 
on frames and controls in Developing Advanced e.Reports.

This example uses the report created in “Example—Creating a Report with a Group 
Break” on page 162. A group total control is added to the After section of the 
ssGroupStage group section. It enables totaling of the revenue values for each 
group. 

To add revenue totals to the group section

1 Click the library browser button. In the Choose Included Module dialog box, 
select sscustom.rol. 

2 Drag and drop the ssFrm component from the Library Browser window onto the 
group section’s child After section. Subclass the frame following the instructions 
from Step 12 and Step 13 on page 169 of “Creating a Report Design in Actuate 
e.Report Designer Professional” and rename it ssFrmGroupTotals.

3 Enlarge the frame vertically in the layout pane to about twice its original height. 

4 Drag and drop the ssCur component from the Library Browser window onto the 
ssFrmGroupTotals frame. Specify the following as the ValueExp:

Sum(Val([ssRevenue]))

NOTE: The above expression works only in ENU locale. To make it locale 
compliant tcCurrency control must be used.

5 Rename the new ssCur component curGroupRevenueTot. Reposition it in the 
layout frame so that it is aligned with the revenue column of the report. 
174 Siebel Reports Administration Guide Version 7.5, Rev B



Reports with Group Sections

Group Totals
6 Drag and drop the LineControl component from the Library Browser window 
onto the ssFrmGroupTotals frame and rename it LineTotal, then reposition it 
vertically in the layout pane so that it is above the revenue total control and 
narrow the line (using the left handle) so that it occupies only the space above 
the total control.

7 Save the report design, recompile, and test.

To add a final total to the report

1 Drag and drop the ssFrm component from the Library Browser window onto the 
child After slot of the report section (ssReportOpportunity), then subclass it 
following the instructions from Step 12 and Step 13 on page 169 of “Creating a 
Report Design in Actuate e.Report Designer Professional” and rename it 
ssFrmReportTotals.

2 Enlarge the frame vertically in the layout pane to about twice its original height. 

3 Drag and drop the ssCur component from the Library Browser window onto the 
ssFrmReportTotals frame and specify the following as the ValueExp:

Sum(Val([ssRevenue]))

NOTE: The above expression works only in ENU locale. To make it locale 
compliant tcCurrency control must be used.

4 Rename the new ssCur component curReportRevenueTot, then reposition it in 
the layout frame so that it is aligned with the revenue column of the report. 

5 Drag and drop the LineControl component from the Library Browser window 
onto the ssFrmReportTotals frame and rename it LineRptTotal, then reposition it 
vertically in the layout pane so that it is above the revenue total control and 
narrow the line (using the left handle) so that it occupies only the space above 
the total control.

6 Drag and drop the ssLblb component from the Library Browser window onto the 
ssFrmReportTotals frame and rename it lblRptTotal. 
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7 Reposition it to the immediate left of the revenue total control and set its Text 
property to Grand Total.

8 Save the report design, recompile, and test.

NOTE: An ssCur component assumes that all amounts are in local currency, as set 
in the Regional Settings in the Windows Control Panel. See “Display of Revenue 
Information” on page 388 for more information.
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This chapter explains how to create master-detail reports. A master-detail report 
displays a list of detail business component records for each record in a master 
business component, to which the master and detail business components have a 
one-to-many relationship. It is similar to a master-detail view in a Siebel 
application, in that detail records are displayed for each master record. Unlike a 
master-detail view, a master-detail report lists detail records for all master records 
at once, rather than for one master record at a time.

A report with record lists for a detail business component is said to contain a 
subreport. In some ways this term is misleading, because it implies the presence of 
one list of detail records. In fact, there is one list of detail records (one subreport) 
following each master record. However, in both Siebel Tools and the report design, 
a single subreport is specified, with the result that one list of detail records appears 
for each master.
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An example of a master-detail report is the Service Request Activity (All) report in 
Siebel Service, shown in Figure 13.

This report provides master information for each service request, followed by the 
list of activities for that service request. Each service request begins on its own page. 
This report is analyzed in “How Master-Detail Reports Work” on page 180.

A master-detail report can also have multiple subreports. In this case, a list of detail 
records appears for each of a number of business components for each master 
record. For example, the Account Service Profile report provides three lists for each 
account master record: customer survey responses, opportunities, and service 
requests. A report with two subreports is described in “Example—Creating a 
Master-Detail Report” on page 185. Master-detail reports with multiple subreports 
are common among the Siebel standard reports.

When starting a master-detail report, no need exists to start the report from a view 
where all business components used in the report are present. Having the master 
business component in the view of the report is enough for the report to retrieve all 
the child or grandchild records. 

Figure 13. Service Request Activity (All) Report
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The only requirement is that all business components used in the report should 
have been added to the business object used by the view from where the report is 
started. Also, the business components should use the correct links to establish the 
proper relationships among them, as an Actuate report retrieves the data using the 
Siebel Business Object Layer.

If a Multi Value Field (MVF) is included in a report, only the first record is displayed. 
In order to display all the records from an MVF in the report, a subreport should be 
created in Tools under the associated Report object. The subreport should be based 
on the business component that contains the MVF to be displayed. Make sure that 
this business component is included in the business object pertaining to the Report 
object. If the business component is not already included in the business object, it 
should be included after defining an appropriate link.

This information is also valid for indirect MVFs. For example, consider the case 
where the business address (an MVF) of an Account associated with an Opportunity 
should be displayed in the report. The business addresses in the MVF are not 
directly related to the Opportunity, but the Account that it is associated with it. To 
display all the records in the business address MVF as a subreport, first create a link 
between Business Address business component and Opportunity business 
component using Account Id as the source field. Then include Business Address 
business component under Opportunity business object. Create a subreport with 
Business Address business component under the Report object and include the 
necessary MVF to display.
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How Master-Detail Reports Work
Figure 14 illustrates the structure of a master-detail report in Actuate.

Figure 14. Structure of a Master-Detail Report
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This includes the following major components:

■ Report Design. This is the top-level component in a report and corresponds to the 
ROD file in which it resides. There are no special features of the report design 
component for master-detail reports.

■ Master Report Section. The master report section defines the data acquisition for 
and display of each master record and, through its child components, defines the 
subreports.

■ Master Datastream. The master datastream component defines the source of data 
for the master records. A separate datastream is defined in each subreport to 
obtain the detail data. As in group reports, the data must be sorted with the 
group field as the primary sort key.

■ Group Section. The group section component implements grouping and group 
break behavior for the master records in its parent report section. This behavior 
is defined in the group section’s Key property and other properties, such as 
PageBreakBefore. The subreports are children of the group section component.

■ Sequential Section. A sequential section causes its child section components to 
execute one after another in sequence. In a master-detail report, this causes the 
Before frame to execute before the first subreport section, followed by each 
additional subreport section if any are present.

■ Before Section. This section holds the frame that appears once for each master 
record, displaying master information before the subreports.

■ Subreport Report Section. Each subreport section defines one subreport in the 
master-detail report. It has its own datastream and content frames, defined with 
child components.

■ Subreport Datastream. Each detail datastream provides data to the detail records 
in one subreport (its parent report section). The data is obtained through a 
subquery on the master business component query, requesting all detail records 
for the current master record.

■ Subreport Page Header Frame. In a subreport report section, the page header frame 
defines the heading information for the subreport records. This normally 
includes a title identifying the subreport and column heading labels to appear 
above the subreport records.

■ Subreport Content Frame. The content frame defines the layout of one subreport 
row.
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To learn more about the configuration of a simple master-detail report, it is helpful 
to open a standard Siebel report of this type. A good report to study for this purpose 
is the Service Request Activity (All) report, which is invoked from a filter in the 
Service screen in Siebel Service (typically the My Service Requests filter). You 
should examine the report output in Siebel Service, and the report design in Actuate 
e.Report Designer Professional, leaving both open to compare them.

To generate the Service Request Activity (All) report in Siebel Service

1 Open Siebel Service.

2 From the application-level menu, choose View > Site Map > Service > My 
Service Requests.

3 While in the My Service Requests view, choose View > Reports from the 
application-level menu.

4 From the drop-down list in the Reports window, select Service Request Activity 
(All) and click Run Now.

The Service Request Activity (All) report appears in the browser window, as shown 
in Figure 13 on page 178. 

To open the report design for the Service Request Activity (All) report

1 Open Actuate e.Report Designer Professional.

2 Choose File > Open.

3 In the Open dialog box, navigate to the C:\Siebdev\rptsrc\enu\standard folder 
(or the equivalent on your computer) and choose srvreqaa.rod.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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Figure 15 shows the srvreqaa.rod report design file in Actuate e.Report Designer 
Professional.

Explore the report design, compare design elements to the corresponding features 
in the report output, and right-click components to view their property lists.

Notice the following features of this report design:

■ There is a page break before each new service request (master) record. This is 
configured with a value of TRUE for the PageBreakBefore property of the group 
section component (ssGrpRowID).

■ The Before frame in the group section, and the page header and content frames 
in the report section, are published components obtained from the ssSrvReq.rol 
custom component library. The contents of these frames are used identically in 
the two reports that list activities by service request.

Figure 15. Service Request Activity (All) Report Design
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■ The two datastreams, one (ssService_RequestQuery) in the master report and 
one (ssActionQuery_1) in the activity subreport, are obtained from the data 
supply library file, srvreqaa.rol. In the data supply library file for a master-detail 
report, one datastream is provided for the master report and one for each 
subreport.

Additional useful information is obtained by viewing the report object definition 
(and children) for this report in Siebel Tools.

To view the report object definition and children in Siebel Tools

1 Open Siebel Tools. 

2 Navigate to the Report object type in the Object Explorer and expand it.

Note the two child object types, Report Field and Sub Report. 

3 In the Reports window in the Object List Editor, navigate to the Service Request 
Activity - All object definition. 

4 Click on the Sub Report object type in the Object Explorer. A second Object List 
Editor window opens, displaying subreport child object definitions of the current 
parent report, as shown in the following figure.

The Service Request Activity - All report has one child subreport object 
definition: Action. The Action subreport object definition defines the activity 
subreport.

Notice that the business component property setting for the Action subreport is 
Action. There is no separate report name, because a subreport in Actuate is 
internal to the report design that uses the subreport object definition’s parent.
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5 Expand the Sub Report object type and select Sub Report Field. Notice the list of 
fields defined as children of the Action subreport object definition.

Subreport field object definitions perform the same role for a subreport as report 
field object definitions do for a report—namely, defining fields to export to the 
report or subreport from the specified business component. 

Example—Creating a Master-Detail Report
In this example, an account report is created, using Actuate e.Report Designer 
Professional, that provides an opportunity list and a contact list for each account. 
The following tasks are required to create the report:

■ Create and export a new report object definition (and children) in Siebel Tools.

■ Create a custom component library.

■ Create a report design in Actuate e.Report Designer Professional.

■ Add datastreams to the report design.

■ Add frame, data control, and label elements to the design.

■ Compile and test the report.

Creating a New Report Object Definition in Siebel Tools
Each report design normally has its own report object definition in Siebel Tools and 
a corresponding data supply library file. In Chapter 7, “Reports with Group 
Sections,” the report object definition was copied from an existing one, and minor 
changes were made. In this example, the same technique is employed to save time, 
but more changes are made. 
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To create a new report object definition in Siebel Tools by copying

1 Open Siebel Tools. Verify that the Account business object has Opportunity and 
Contact detail business components relative to the Account (master) business 
component.

This is an unnecessary step in this example, but one you should employ as a 
precaution when using less common business component relationships. The 
master-detail relationships specified by the business object components and 
links in the business object are necessary for any master-detail datastream 
relationship to work.

The hierarchy of the reports and subreports must be in accordance with the 
configuration previously done (business object and its business component with 
the proper links). 

NOTE: The correct approach is to use only the driving business component in a 
view as the main datastream in the report, because problems may arise 
otherwise.

2 Navigate to the Report object type in the Object Explorer. Expand this object type 
to reveal the child Sub Report object type. 

3 Locate and select the Account Summary object definition in the Object List 
Editor window for reports.

Notice that this report has seven subreport children, including Opportunity and 
Contact. Any account report object definition with these latter two subreports 
would have sufficed. You will copy this report object definition and delete the 
unwanted child subreports.

a Lock the Report project (choose Repository >Lock Project).

b With the Account Summary object definition selected, choose Edit > Copy 
Record.

A new report object definition is created with empty Name and Menu Text 
properties and a set of children and properties otherwise matching the 
original.
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4 Change the following property settings in the new report object definition (the 
other property settings do not need to be changed):

■ Name. Account - Opty/Contact Detail

This is the name used to refer to the report structure in Siebel Tools, for 
instance when you add the report to the Reports menu for a view.

■ Access Base DB Name. ACOPCOM 

This specifies that Acopcom.rox will be the name of the report executable 
invoked when this report object definition is invoked from the Reports menu 
in a view. 

■ Menu Text. Account - Opportunity/Contact Detail

This is the text that will appear in the Reports menu for a view when this 
report is included in the view through the use of a view report object 
definition.

■ Template Name. ACOPCOM 

Specifies the name to be used for the generated data supply library file when 
the Generate Actuate Report option is invoked for this report object 
definition.

■ Sort Specification. (blank)

By default, sorts the account records into account name order, which is 
necessary for the group breaks to work correctly. Alternatively, you could 
specify a value of Account. 

5 Navigate to the Sub Report list in the Object List Editor for the new report object 
definition. 

6 Delete all the subreport object definitions, using Edit > Delete Record, except 
Opportunity and Contact.

7 Expand the Sub Report Fields object definition for the Opportunity subreport. 

8 Add the following subreport fields if they are not already present: City, Close 
Date, Description, Name, Postal Code, Rep%, Revenue, Sales Rep, and Sales 
Stage.
Version 7.5, Rev B Siebel Reports Administration Guide 187



Master-Detail Reports

Example—Creating a Master-Detail Report
9 Export to a data supply library file by choosing Tools > Generate Actuate Report.

This generates a data supply ROL file, named according to the value in the 
Template Name property, in the C:\Siebdev\rptsrc\enu\lib folder (or equivalent 
on your system). 

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

10 Unlock the Report project and navigate to the View object type in the Object 
Explorer.

a In the Object List Editor, locate the Account List View object definition. In the 
Object Explorer, expand View and click View Report.

This is the My Accounts view in the Accounts screen. 

b Add a View Report object definition in the Object List Editor. 

Enter the name “Account - Opty/Contact Detail” (match spelling and spacing 
exactly). 

c Add a sequence number that is greater by 1 than any other sequence number 
in the list.

11 Choose Repository > Compile and recompile the repository. Move the resulting 
SRF file to C:\Siebel\objects (or the equivalent location on your system). 

Creating a Custom Component Library
In this exercise, a new report design is created using library components. 
Components from other report designs and custom libraries are used where possible 
to shorten the design time. Custom component libraries are described in “Using a 
Custom Component Library” on page 152. A custom library already exists with 
opportunity detail frame information: ssOppt.rol. However, the account master and 
contact detail frame layouts need to be published to a new custom component 
library from an existing report design, in this case srvreqaa.rod.
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To create a custom component library with account master and contact detail 
frames

1 Open the srvreqaa.rod (Service Request Activity - All) report design in Actuate 
e.Report Designer Professional.

2 Choose Tools > Library Organizer > New Library. Specify the name sssrvreq.rol 
and the path C:\Siebdev\rptsrc\enu\lib.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

3 Drag and drop the following frames from the srvreqaa report design into the 
sssrvreq.rol custom library (choose the Publish The Component option for each 
in the Drop Component dialog box):

■ ssFrmHeadSection. This is the Before frame for the group section, and 
displays account header information.

■ ssFrmContactsBefore.

■ ssFrmContactsContent.

4 Close the srvreqaa.rod report design and click the Save All button when 
prompted to save the report design and library.

The srvreqaa.rod report and your new Account - Opportunity/Contact Detail report 
will share frame components from this library. If any customizations need to take 
place in either report, the component is subclassed first to keep the changes local 
to one report. 
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Creating a Report Design in Actuate e.Report Designer Professional
Now the new report design is created and the major structural components are 
added.

To create a master-detail report design in Actuate e.Report Designer Professional

1 Open Actuate e.Report Designer Professional.

2 Choose File > New. In the Create New Report window, select Blank Report and 
click OK. 

A blank design report appears.

NOTE: Another option for creating a master-detail report design can be found in 
the postinstallation tasks for Actuate e.Report Designer section in Chapter 1, 
“Installing the Siebel Reports Server for Microsoft Windows.”

3 Delete the following components from the structure tree. 

NOTE: You will need to expand the Content - Report section on the structure pane 
to see the components.

■ Connection component. This is a predefined connection that is not used to 
create Siebel reports.

■ DataStream component. This component will be replaced with the datastream 
created in Siebel Tools.

■ Content - Frame component. This component will be replaced with a 
subclassed frame.

4 Choose Tools > Library Organizer and click More.

The Include Library window appears.
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a Click Browse and navigate to C:\Siebdev\rptsrc\enu\lib (or equivalent), 
choose sssiebel.rol, and click Open. Click OK to close the Include Library 
window.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

b Repeat this step for the files sscustom.rol, sssrvreq.rol, and Acopcon.rol.

5 Enter the following information for the report:

■ Title. Account - Opty/Contact Detail

■ Filename. C:\Siebdev\rptsrc\enu\Acopcon.rod 

This is the filename and folder location where the report design file you are 
creating will be saved. If you have a \custom subfolder of ...\enu, save it 
there instead. 

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

■ Report Root Name. Acopcon

This specifies the name of the top-level report design object in the design file.
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6 Choose File > Save. Specify Acopcon.rod in the ...\enu (or ...\enu\custom) 
folder.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

Remember to save the design file periodically as you work.

7 Double-click the Acopcon (top-level) icon in the structure tree (or right-click it 
and select Properties). 

a In the Component Editor window, click the Class tab. 

b Change the Super Class value from AcReportSection to ssRpt. 

This is an important step. Siebel reports must inherit from ssRpt (the Siebel 
standard report) instead of directly from AcReportSection (Actuate report). ssRpt 
is provided in sscustom.rol and inherits from baseReport from sssiebel.rol. 

NOTE: You cannot perform this step until you have included the sssiebel.rol 
library.

Two components are automatically added to the report when you change the 
report’s class: a report section (ssRpt) and a pagelist section (ssPageList).

8 Make sure that the Show Empty Slots option in View >Options is checked.

9 Expand the top-level report component. 

a Right-click the report section child component in the structure tree (Report) 
and select Slot Information. 

The Single Structure Reference window appears.

b Change Name in the Contents section to ssRpt and click Close.

c Right-click the report section component (ssRpt1) and click Subclass. 

d Right-click the report section (ssRpt1) and click Rename. Change the name 
to ssRptAccount.
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10 Expand the report section component (ssRptAccount). 

a Click the library button and click sscustom.rol. 

b Drag and drop the ssGrp library component onto the Content child slot of the 
report section.

11 Right-click the group section component (ssGrp) and subclass following Step 9 
on page 192. 

a Right-click the group section component (ssGrp1) and click Rename. 

b Change the name to ssGrpAccount.

c Right-click the group section component (ssGrpAccount) and click 
Properties. In the Key property, enter ssName. 

d Close the Component Editor window.

12 Drag and drop the ssSeq library component from the Library Browser window 
to the content section (ssGrpAccount). When prompted, click Use As Content.

This provides the sequential section that causes the subreports to execute in 
sequence.

13 Subclass the sequential section and rename it ssSeqAccount.

a Drag and drop the ssRpt library component onto the sequential section. 
Subclass following Step 9 on page 192 and rename it ssRptOpportunity. 
Expand this report component.

b Drag and drop the ssRpt library component onto the sequential section again. 
Subclass this report component following Step 9 on page 192 and rename it 
ssRptContact. Expand this report component.

14 Close the Library Browser window.
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Adding Datastreams to the Report Design
Three datastreams are added to report sections in the report design from the data 
supply library, one each for the master report and the two subreports.

To add datastreams to the report design

1 Click the library browser button and select Acopcon.rol. 

2 Drag and drop the ssAccountQuery library component onto the DataStream slot 
beneath the master report section, ssRptAccount.

3 Drag and drop the ssOpportunityQuery_1 library component onto the 
DataStream slot beneath the opportunity detail report section, 
ssRptOpportunity.

4 Drag and drop the ssContactQuery_2 library component onto the DataStream 
slot beneath the contact detail report section, ssRptContact.

5 Close the Library Browser window.

Adding Frame, Data Control, and Label Elements to the Design
Many of these elements will be obtained from two custom component libraries, one 
of which you have already created.

To add frame, data control, and label elements

1 Click the library browser button and in the Choose Included Module dialog box, 
select sssrvreq.rol.

2 Drag and drop the ssFrmHeadSection library component onto the Before child 
slot of the group section, ssGrpAccount. 

3 Collapse the component subtree for ssFrmHeadSection by clicking its minus-
sign icon.

Component subtrees for headers and detail rows are distracting in expanded 
format and should be collapsed for visual clarity and ease of navigation.

4 Drag and drop the ssFrmContactBefore library component onto the page header 
child slot of the contact subreport section, ssRptContact, then collapse the 
component subtree for ssFrmContactBefore.
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5 Close the Library Browser window, and choose Tools > Library Organizer. 

Select ssOppt.rol in the ...\enu\library folder.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

This custom component library is used in opportunity reports; it has the page 
header and detail line needed for the opportunity subreport you are creating.

6 Drag and drop the ssOppHeader library component onto the page header child 
slot of the opportunity subreport section, ssRptOpportunity, then collapse the 
component subtree for ssOppHeader.

7 Drag and drop the ssOppRowNoAddress library component onto the Content 
child slot of the opportunity subreport section, ssRptOpportunity, then collapse 
the component subtree for ssOppRowNoAddress. 

Close the Library Browser window.

8 Locate and expand the page header child frame of the ssRptOpportunity report 
section, then subclass this page header frame (ssOppHeader) and rename it 
ssFrmOpportunityPage.

You need to make some modifications to this page header.

9 Select the ssTxtOPPTHeadM child data control of ssFrmOpportunityPage and 
delete it. 

10 Open the sscustom.rol library and drag and drop the ssLblSectionHead 
component from the Library Browser window onto the ssFrmOpportunityPage 
page header.

11 Rename the new section head label ssLblOpportunityHead, then resize and 
reposition the header label so that it is comparable to the one for contacts. 

Close the Library Browser window.

12 Select the ssFrmOPSTATEHeader content frame in ssFrmOpportunityPage, then 
subclass it and rename it ssFrmOpportunityHeader. 
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13 Expand ssFrmOpportunityHeader to show its child label components.

You will delete the account label from this header and the detail data row that 
appears beneath it because the account is already displayed in the master report.

14 Select the ssLblAccount label child of ssFrmOpportunityHeader and delete it.

15 Subclass each of the remaining label children of ssFrmOpportunityHeader and 
drag them to the left to fill up the space emptied by deleting ssLblAccount.

By clicking each label in the opportunity header while holding down SHIFT, you 
can create a grouping of labels that you can drag to the left together, maintaining 
the distances between them and saving time.

16 Collapse the ssFrmOpportunityPage component tree.

a Expand the ssOpRowNoAddress content frame child of ssRptOpportunity.

b Subclass ssOpRowNoAddress and rename it ssOpportunityContent.

c You will now delete the account data control and reposition the other data 
controls to fill the empty space.

17 Select the ssTxtOPSTATEAccount data control and delete it.

18 Subclass each of the remaining data control children of ssFrmOpportunityRow 
and SHIFT-click each of them in the layout pane (except the name control) and 
drag them to the left to fill up the space emptied by deleting 
ssTxtOPSTATEAccount. 

19 Make sure that the data controls line up with the header labels above them.

20 Make sure that the PageBreakBefore property of the group section 
(ssGrpAccount) is TRUE and that its PageBreakAfter property is FALSE, and also 
make sure that the PageBreakBefore and PageBreakAfter properties of the 
ssRptContact and ssRptOpportunity subreport sections are all set to FALSE.

If you wanted the subreport sections on their own pages, you would set 
PageBreakBefore to TRUE in the respective subreport sections. With the FALSE 
settings in all four subreport page break properties, there are no page breaks 
except between accounts.

21 Open the Properties window for the top-level report design component, 
Acopcon, and set the ssReportTitle property to Account - Opportunities/Contacts 
Detail.
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Compiling and Testing the Report
The report is built, compiled, and run in Actuate e.Report Designer Professional. 
Then it can be debugged locally in Actuate e.Report Designer Professional and, 
when it is ready to be deployed, the executable version of the report is moved to the 
folder where Siebel applications obtain their report executables.

To compile and install the report

1 Open Siebel Sales. 

2 From the application-level menu, choose View > Site Map > Accounts > My 
Accounts. 

Make sure that the desired query is active.

3 In Actuate e.Report Designer Professional, click the run button.

The report appears in the browser window. 

4 Make corrections as necessary to the report design and recompile as often as 
required.

5 Use Windows Explorer to copy the Acopcon.rox file from C:\Siebdev\rptsrc\enu 
(or equivalent) to C:\Siebel\reports\enu (or equivalent).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

6 In Siebel Sales, choose View > Reports from the application-level menu. 

7 From the drop-down list in the Reports window, select Account - Opportunity/
Contact Detail.

The report should appear in the browser window. If there are problems, check 
the configuration of report and view report object definitions in Siebel Tools.
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Example—Creating a Report with Multiple Hierarchies
In this example, an account report is created that provides a list of opportunities and 
associated competitors for each opportunity, and a list of contacts for each account. 
Notice that this report displays three levels of hierarchy (parent > child > 
grandchild) relationship. It is possible to create reports with multiple hierarchies 
using the methodology laid out in this example.

The following tasks are required to create the report:

1 Create and export a new report object definition (and children and grand 
children) in Siebel Tools.

2 Create a custom component library.

3 Create a report design in Actuate e.Report Designer Professional.

4 Add datastreams to the report design.

5 Add frame, data control, and label elements to the design.

6 Compile and test the report.

Creating a New Report Object Definition in Siebel Tools
Only Step 1 from “Example—Creating a Report with Multiple Hierarchies” is 
described in detail since all other steps are identical to those explained in “Creating 
a New Report Object Definition in Siebel Tools” on page 185 for developing a 
Master-Detail report.
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To create a new report object definition in Siebel Tools by copying

1 Open Siebel Tools. Verify that the Account business object has Opportunity, 
Contact, and Competitor detail business components relative to the Account 
(master) business component. Also verify under Account business object that a 
link is defined for the Competitor business component between Opportunity and 
Competitor business components.

This confirms the hierarchical relationship among the business components 
under Account business object. 

In this example, the Opportunity and Contact business components are at the 
child level, and the Competitor business component is at the grandchild level 
relative to Account business object.

2 Make sure that all the business components to be used in the master detail 
report are active in the associated business object. 

A master detail report can be created with multiple hierarchy levels with as 
many business components as the user needs, as long as all of these business 
components belong in the same business object and are active. Further, each 
business component below the parent level should have a link defined with a 
parent level business component.

In this example, make sure that the competitor business component (which will 
appear at the grandchild level in the report) has a link defined with Opportunity 
business component.

3 Navigate to the Report object type in the Object Explorer. Expand this object type 
to reveal the child Sub Report object type.

4 Locate and select the Account Summary object definition in the Object List 
Editor window for reports. 

Notice that this report has seven subreport components, including Opportunity, 
Contact, and Competitor. Any account report object definition with these latter 
three subreports would have sufficed. You will copy this report object definition 
and delete the unwanted subreport components.

5 Lock the Report project (choose Tools > Lock Project).
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6 Select the Account Summary object definition and choose Edit > Copy Record.

A new report object definition is created with empty Name and Menu Text 
properties and a set of children and properties otherwise matching the original.

7 Change the following property settings in the new report object definition (the 
other property settings do not need to be changed):

■ Name. Multiple Hierarchy Report

This is the name used to refer to the report structure in Siebel Tools, for 
instance when you add the report to the Reports menu for a view.

■ Access Base DB Name. MULHIER

This specifies that Mulhier.rox will be the name of the report executable 
invoked when this report object definition is invoked from the Reports menu 
in a view.

■ Menu Text. Multiple Hierarchy Report

This is the text that will appear in the Reports menu for a view when this 
report is included in the view through the use of a view report object 
definition.

■ Template Name. MULHIER

Specifies the name to be used for the generated data supply library file when 
the Generate Actuate Report option is invoked for this report object 
definition.

■ Sort Specification. (blank)

By default, do not sort the account records into account name order, which 
is necessary for the group breaks to work correctly. Alternatively, you could 
specify a value of Account.

8 Navigate to the Sub Reports list in the Objects List Editor for the new report 
object definition. 
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9 Delete all the subreport object definitions (using Edit > Delete Record) except 
Opportunity, Contacts, and Competitor. 

Notice that the position field indicated for Opportunity and Contacts is 1 and 2 
respectively, while for Competitor it is 1.1. This indicates that Opportunity and 
Contacts are at hierarchical level 2 and Competitor is at level 3 under 
Opportunity.

The position is indicated relative to the main business component. Each 
hierarchy level is separated by a period, and the number indicates the relative 
position with respect to the associated parent. For example, position 2.3 
indicates that the subreport is two levels below the main business component, 
and that it is a child, 3, of the business component designated with position 2.

10 Expand the Sub Report Fields object definition for the Opportunity subreport.

11 Add the following subreport fields if they are not already present: City, Close 
Date, Description, Name, Postal Code, Rep%, Revenue, Sales Rep, and Sales 
Stage.

12 Expand the Sub Report Fields object definition for the Competitor subreport. 
Add the subreport fields Threat Value, and Vendor if they are not already present.

13 Export to a data supply library file by choosing Tools > Utilities > Generate 
Actuate Report.

This generates a data supply ROL file, named according to the value in the 
Template Name property, in the C:\Siebeldev\rptsrc\enu\lib folder (or 
equivalent on your system).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

14 Unlock the Report project.
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15 Navigate to the View object type in the Object Explorer.

a In the Object List Editor, locate the Account List View object definition. 

b In the Object Definition, expand View and click on View Report. This is the 
My Accounts view in the Accounts screen.

c Add a view report object definition in the Object List Editor. 

d Enter the name Multiple Hierarchy Report (match the spelling and spacing 
exactly) and a sequence number that is one higher than any other sequence 
number in the list.

16 Choose Tools > Compile and recompile the repository. Move the resulting SRF 
file to C:\Siebel\objects (or the equivalent location on your system).

Creating a Report Design in Actuate e.Report Designer Professional
In Creating a Master–Detail Report example, you first created a custom component 
library and then a new report design in Actuate e.Report Designer Professional. In 
this example, you will create a report design by first copying an existing design and 
making changes to the copy.

To create a report design with multiple hierarchy

1 Open the Acopcom.rod (Account – Opty/Contact Detail) report design in Actuate 
e.Report Designer Professional and choose File > Save As and save the report 
design as Mulhier.rod.

2 Highlight the Report at root level in the design editor and double-click to open 
the Component Editor. In the Properties tab, change the title by entering Multiple 
Hierarchy Report for the ssReportTitle parameter.

3 Choose Tools > Library Organizer to open the Library Organizer window. 

In the Libraries Included in Your Report frame, highlight Acopcom.rol and click 
the down arrow. If Mulhier.rol is available in the Available Libraries frame, click 
the up arrow to add to the included libraries. 

a If Mulhier.rol is not in the Available Libraries frame, browse through the file 
system clicking More and navigate to the directory that contains Mulhier.rol 
library. 
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b Select this library in the Available Libraries frame and click the up arrow to 
add to the included libraries.

c Click the library browser button and select the Mulhier.rol library to open the 
datastreams of Account (ssAccountQuery), Opportunity 
(ssOpportunityQuery_1), Contacts (ssContactsQuery_2), and Competitor 
(ssCompetitorQuery_1_1) business components. 

d Only include the datastream of Competitor business component.

4 Expand the ssRptOpportunity report component in the design editor. 

5 Drag and drop the ssSeq library component from the Structure icon into the 
content section. 

This provides the sequential section that causes the subreports to execute in 
sequence.

6 Subclass the sequential section and rename it ssSeqOpty.

7 Drag and drop the ssRpt library component on the sequential section. 

a Subclass it and rename it ssRptCompetitor. 

b Expand this report component.

8 Drag and drop data stream object ssCompetitorQuery_1_1 into the DataStream 
node of ssRptCompetitor.

9 Close the Library Browser Window.

Adding Frame, Data Control, and Label Elements to the Design
See “Adding Frame, Data Control, and Label Elements to the Design” on page 194 
to add frame, data control, and label elements to the Threat Value and Vendor fields 
in the Competitor section (the other sections already have the controls added).
Version 7.5, Rev B Siebel Reports Administration Guide 203



Master-Detail Reports

Example—Creating a Report with Multiple Hierarchies
204 Siebel Reports Administration Guide Version 7.5, Rev B



Composite Datastreams 9
This chapter is in two sections, as follows:

■ The datastream concepts that underlie all advanced reporting techniques are 
described in “Datastream Concepts.”

■ Composite datastreams, which are used to display data from multiple business 
components in a single frame, are described in “Using Composite Datastreams 
in Reports” on page 207. 

Datastream Concepts
A datastream component represents the data from one business component. 
Datastreams and report sections have a one-to-one relationship, and multiple 
datastreams are common in report designs. These relationships drive many of the 
techniques that are used in more complex reports.

Each datastream uses a data row component to store variable values and return 
formatted data in the report instance. In Siebel/Actuate, the data row component 
represents the list of fields in the report object definition. Each field in the report 
object definition maps to one variable defined in the data row. A data row object is 
created for each row of data in the report object definition.

The data row component is a class that is instantiated to create data row objects at 
run time. The datastream contains the code to extract data; the data row holds the 
values. Since data rows are almost wholly defined by their variable attributes, you 
should modify the report object definition and its children and avoid writing code 
to the data row component. 
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A data row object, however, is visible to the report section and can be intercepted 
after it is created and before it populates controls. You can create a local subclass of 
the datastream and data row components, and override the Fetch method in the 
datastream (to process the entire record) or the OnRead method in the data row (to 
process a single field).

Though a datastream component uses only one data row component in its local 
space (report section), the creation of a global data row can make fields from 
multiple data rows available to the entire report design. This technique is described 
in “Using Composite Datastreams in Reports” on page 207.

In Actuate, a datastream is a collection of components that deliver data to the 
report. Because Siebel data access is done through OLE and the OMU (the Reports 
Server interface), queries are always executed outside the Actuate environment. 

The role of the datastream is to create an interface through OLE or the OMU and 
deliver the formatted data row to the report design. Siebel Tools defines the 
variables required to execute the queries, their values being determined by the 
requirements of the report design. The datastream variables, with their types and 
functions, are described in Table 3.

The overridden datastream methods are covered in Appendix B, “Method 
Reference.”

Table 3. Siebel Datastream Class Variables

Variable Type Function

ssAppServer Integer Pointer to the object created in the ssReport::Build Report () 
method of the datastream. It identifies the active Siebel 
application server or model.

ssBO Integer Pointer to the object created in the Start method. It identifies 
the active business component.

ssBusCompName Integer Pointers to the master and child business components used 
to obtain data from the view in the Siebel application.
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Using Composite Datastreams in Reports
A report often requires a single frame to display data from multiple business 
components. Each frame gets data from its report section, and each report section 
has one datastream. Each datastream is associated with a single business 
component through the report object definition. Normally, a data control cannot see 
beyond the bounds of its report section. 

The solution is to create a data row, global in scope, that is visible to the entire 
report, not just to its report section. You do this by putting a variable on the report 
design component. It is then possible to populate the control with the proper data.

The following tasks are required to create and use a global data row:

1 Add global variables to the report design.

2 Modify the master datastream component.

3 Reference global variables in controls.

These steps are illustrated with the Quotestd.rod standard report. This report is the 
Current Quote report in the Reports menu in views in the Quotes screen.
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In Figure 16, a sample of the report displays quote master information at the top 
and provides a subreport in the middle containing the list of individual quote line 
items.

Figure 16. Current Quote Report Sample Page
208 Siebel Reports Administration Guide Version 7.5, Rev B



Composite Datastreams

Using Composite Datastreams in Reports
Adding Global Variables to the Report Design
To make the field values in the master data row available to the subreports, you 
need to define a global variable that holds the contents of the master data row. This 
is defined as a public static variable on the report design component, and its type 
is defined as having the same class as the master data row.

To create a global data row variable in the report design

1 Expand the master datastream to view its child data row and note the data row’s 
name. 

In the case of the Current Quote report (QUOTESTD), this name is 
ssQuoteDataRow, and the class is the same as the name because it has not been 
subclassed.

2 Navigate to the report design, which is the top-level component, and right-click 
it. In the pop-up menu, select Properties.

3 In the Properties window for the report design component, click the Variables 
tab.

4 Click New. The Class Variable dialog box appears.

5 Enter the following values:

■ In the Name field, enter MasterRow.

■ In the Type field, enter the previously noted data row class name.

■ Leave Externally Defined Data Type unchecked.

■ In the Storage radio button group, click Static.

■ In the Visibility picklist, select Public.

6 Click OK to save the new variable.
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Modifying the Master Datastream Component
In this step, the master datastream component is modified to obtain the data for its 
data row component from the global data row variable. This is accomplished by 
overriding the Fetch method on the master datastream.

To override the Fetch method on the master datastream

1 Navigate to the master datastream component (the datastream for the master 
report, rather than the subreport) and double-click it.

In the Quotestd.rod report, this component is ssQuoteQueryAddGlobalRow.

The Component Editor appears.

2 In the Component Editor, choose the Methods tab. 

3 Select the Fetch method and click Override.
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4 Replace the existing code in the Method Editor with the following code (using 
the relevant master data row name, if other than ssQuoteDataRow):

Function Fetch( ) As AcDataRow

Dim aMasterRow As ssQuoteDataRow

Set aMasterRow = Super::Fetch( )

If aMasterRow Is Nothing Then

Exit Function

End If

Set MasterRow = aMasterRow

Set Fetch = MasterRow

End Function

5 Click Close. 

The code in the Fetch method sets the MasterRow global variable to the contents of 
the row returned by the Super::Fetch operation, after first determining that the 
fetched record is not empty. Each time a master datastream record is obtained, the 
record in memory in MasterRow is replaced.
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Referencing Global Variables in Controls
Let’s say, for example, that the name of the account needs to be referenced in each 
line item row. 

To add the account name to line item rows

1 Navigate to the content frame QuoteItemContent1 in the subreport. 

2 Make space for an account name between two fields.

3 Open the sscustom.rol library, if it is not already open, and drag the ssTxtS 
component from the library browser window to the desired location in the 
content frame.

The Component Properties dialog box opens for the new text control.

4 In the ValueExp property in the Component Properties dialog box, enter the 
following value:

QUOTERPT::MasterRow.ssAccount

This sets the text control to display the current value of the ssAccount field in 
the MasterRow global variable, which stores the current quote.

To use a value from the global variable in a text control, use the ValueExp property 
of the control, as in the example. The expression is of the following form:

GlobalVar.FieldName 

For example:

QUOTERPT::MasterRow.ssAccount
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Debugging Tips for Composite Datastreams
The report design’s MasterRow variable must be Static with Public visibility. 

The overridden Fetch method must call Super::Fetch() before using it to create the 
global data row. If unexpected results occur, assign a breakpoint to the Fetch 
method (select the line to breakpoint and press F9) and inspect all report variables 
(Debug > Variables). Make sure that the data row variable aMasterRow is being 
populated as expected.

The BuildFromRow method on a control can also be overridden for the purpose of 
using breakpoints to check the value of the MasterRow variable (and its fields) in 
order to confirm that MasterRow is exposing itself to the control.
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Generally, it is possible to obtain the kind of sorting and grouping that is necessary 
for a report using sort specifications and group breaks, as explained in Chapter 7, 
“Reports with Group Sections.” However, when master data is sorted by the 
contents of a multi-value field, or the master is in a many-to-many relationship with 
the detail, sorting cannot be defined in a sort specification. In these situations, the 
data must be passed to Actuate as a master-detail set of datastreams, and additional 
processing must occur in Actuate through the mechanism of a sort data filter.

This chapter explains how to design reports that require merging of records rather 
than a simple sort.
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Report Sorted on a Multi-Value Field
Memory Sorting is employed when master records must be sorted by the contents 
of a multi-value field. An example of the situation is the Opportunities by Sales Rep 
report, obtained in the Opportunities screen by choosing View > Reports, then 
selecting By Sales Rep from the drop-down menu and clicking Run Now. 

Opportunity records are listed in this report, sorted by the sales representative 
responsible for working on each opportunity. If there were only one sales 
representative per opportunity, this requirement could be satisfied with a sort 
specification and a group break. However, an opportunity record is assigned to a 
sales team, rather than a single sales representative. For you to see all the 
opportunities for each sales representative, the same opportunity must be listed 
under the name of each sales representative who is on that opportunity’s sales 
team.

The relationship between an opportunity and the sales representatives assigned to 
it is a one-to-many relationship. In the Siebel business model, this is defined as a 
master-detail relationship (link) between the Opportunity and Position business 
components in the context of the Opportunity business object. The multi-value 
group displayed in Siebel Sales for opportunity records in the Sales Rep field is 
defined through the Position multi-value link.

For a report of this kind, the datastream must provide both the master and detail 
records. If only the opportunity records were sent to Actuate, it would be impossible 
to determine which sales reps were assigned to each opportunity; only the primary 
sales representative would be available for each opportunity. To send an interrelated 
set of opportunities and their detail sales representatives, the datastream must be 
defined in Siebel Tools with a report object definition for the Opportunity business 
component and a child subreport object definition for the Position business 
component. You can verify in Siebel Tools that this has been done for the 
Opportunities - By Sales Rep report. 

Based on the master and detail records in the two datastreams, a set of merged 
records is created from the two business components that represents their cross-
product, consisting of one merged opportunity record for each combination of an 
opportunity and a position in that opportunity’s Sales Rep multi-value field. It is the 
merged records, created in memory, that are sorted into sales rep order and printed 
with sales rep sort breaks.

This report is analyzed in greater detail in “Examining a Report Sorted on a Multi-
Value Field (MVF)” on page 223.
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Report Sorts Records from a Many-to-Many Relationship
Memory sorting is also employed when master and detail business components 
have a many-to-many relationship, such as between opportunities and contacts or 
between accounts and opportunities. An example of this situation is the Contacts 
By Opportunity report, obtained in the Contacts screen by choosing View > 
Reports, then selecting By Opportunity from the drop-down menu and clicking Run 
Now. 

The situation in this report is very similar to the one in the Opportunities by Sales 
Rep report, in that there are multiple detail records for each master, and the master 
records are to be sorted by a field in the detail records. You want to print contacts 
sorted by opportunity, which requires looking at the many-to-many relationship 
from the perspective of one opportunity to many contacts. 

The set of object definitions in Siebel Tools uses the Opportunity business 
component as the master and includes a contact subreport. In the report design, 
merged opportunity records are created in a memory structure with the contact 
name included as an extra field. They are then sorted into contact order and printed 
with contact group breaks.

Notice that this could easily be switched around to create a report that prints 
contacts sorted by opportunity. The exported data supply library would use Contact 
as the business component in the master report object definition, and Opportunity 
in the subreport. In the report design, the structure in memory would hold the 
contents of each contact record plus an opportunity name field. The contact records 
would sort in opportunity order, with opportunity group breaks.

This report is analyzed in greater detail in “Examining a Report Based on a Many-
to-Many Relationship” on page 233.
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This section provides background information that is necessary for understanding 
memory sort reports, then analyzes two existing standard reports that use this 
methodology.

Data Filters
A datastream consists of two types of data adapters: datasources and data filters. 
Datasources retrieve data from an input source—the COM interface in the case of 
Siebel reports—and create data rows from the incoming records. Data filters sort, 
filter, or perform other computations on data rows. While a datastream must have 
at least one datasource, it is not required to have any data filters, and in the majority 
of standard reports data filters are not used.

A data filter receives data rows from one or more datasources or other data filters. 
A data filter processes the data it receives, then passes it to the next data filter (if 
there is one) or to the report. 

Actuate provides three classes of data filters, one for accepting data from one 
datasource or data filter, one for merging data from multiple datasources and filters, 
and one for sorting. In the sscustom library, the classes for these three purposes are 
ssSingleInputFilter, ssMultipleInputFilter, and ssMemoryDataSorter, respectively. 

Sort-merge requirements go beyond the capabilities of the standard sorting and 
grouping methodology and are handled with a data filter subclassed from 
ssMemoryDataSorter. This class inherits from the baseMemoryDataSorter class in 
the sssiebel library and ultimately from AcMemoryDataSorter in the Actuate 
Foundation classes. A data filter based on ssMemoryDataSort is also called a sort 
filter. 
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Memory Structures
To sort data by the child business component, you must extract data from the 
master business component, store it, and re-sort it according to the values in the 
detail business component. The master and detail business component records are 
obtained through the master and detail datastreams. 

In the Opportunities by Sales Rep (OPSLREP) standard report, each row of the 
opportunity query is processed before the data is formatted. Because data rows are 
transient objects, they are written into a temporary structure in memory as they are 
processed. 

A global list or memory data buffer component can be used for this purpose. In the 
Opportunities by Sales Rep report, data rows from the Opportunities query are 
stored in a global list component. The AcList class, from which global list 
components are derived, is a smart array structure. A memory buffer (based on the 
AcMemoryBuffer class) is similar to a global list, but exhibits more complex 
behavior that is not required for most Siebel reports. 

The RowList variable is derived from AcList, the AFC class designed to hold an 
ordered collection of objects. AcList is set up to function globally and has several 
methods that make it easy to manage lists. Methods for AcList variables are listed 
and described in Table 4.

Table 4. Methods Available for AcList Variables

Method Class Derived From Description

AddToHead AcList Adds an item to the beginning of the list.

AddToTail AcOrderedCollection Adds an item to the end of the collection.

Contains AcList Returns TRUE if the list contains the item.

Copy AcList Copies the contents from another list to the end of 
this list.

GetAt AcOrderedCollection Returns the item at the specified location in the 
collection.

GetCount AcCollection Returns the number of objects in the collection.

GetHead AcOrderedCollection Returns the first item in the collection.
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See the Actuate Foundation Class Reference for additional information on these 
methods.

Structure of the Report Design
Structurally, a memory sort report is similar to a report with group breaks, as 
described in Chapter 7, “Reports with Group Sections,” with some additional 
components. These include:

■ A second report section

■ A sequential section to group the two report sections

■ A data filter in the new report section to reprocess data from the master and 
detail datastreams in the preceding report section 

GetIndex AcList Returns the position of the node specified in the 
list.

GetTail AcOrderedCollection Returns the last item in the collection.

InsertAfter AcList Inserts a node in the list after the specified node.

InsertBefore AcList Inserts a node in the list before the specified node.

IsEmpty AcCollection Reports whether the collection is empty or not.

NewIterator AcCollection Creates an iterator for the collection.

Remove AcCollection Removes a specified item from the collection.

RemoveAll AcCollection Removes all contents from the collection.

RemoveHead AcList Removes the first node from the list.

RemoveTail AcOrderedCollection Removes the last item in the collection.

Table 4. Methods Available for AcList Variables

Method Class Derived From Description
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Figure 17 illustrates the structure of this kind of report.

Figure 17. Memory Sort Report Structure
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The major components in this structure are as follows:

■ Sequential Section. This section groups together the outer report section, whose 
purpose is to obtain the master and detail records without generating any report 
lines, and the combined report section, which sorts and processes those records 
into a printed report. The sequential section causes these two processes to take 
place one after the other, which is necessary because the first process generates 
the stored set of records that is processed in the second process.

■ Outer Report Section. This section holds the datastream for the master report.

■ Master Datastream. This datastream obtains data records from the master 
business component. It is obtained from the data supply library file for the 
report.

■ Inner Report Section. This section holds the datastream for the subreport.

■ Detail Datastream. This datastream obtains data records from the detail business 
component for each master record. It is also obtained from the data supply 
library file.

■ Combined Report Section. This section holds the data filter that obtains the 
merged records from the datastreams in the preceding report section and 
processes them into the appropriate sort order for the report. This report section 
also holds the content nodes that define the report output.

■ Data Sort Filter. The data filter processes merged records from the datastreams in 
the preceding report section into the correct sorted order for the report output.

■ Combined Datastream. This datastream is a child component of the data sort filter. 
It obtains merged records from the global list. The merged records have a record 
structure defined in the combined datastream’s child data row component.

■ Group Section. This section implements sort breaks between groups of like 
records.
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Examining a Report Sorted on a Multi-Value Field (MVF)
A good MVF-sorted report to study is the Opportunities by Sales Rep report, which 
is invoked in the Opportunities screen (typically from the My Opportunities filter). 
You should examine the report output in Siebel Sales, and the report design in 
Actuate e.Report Designer Professional, leaving both open to compare them.

To generate the Opportunities by Sales Rep report

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities. 

3 While still in the My Opportunities view, choose View > Reports from the 
application-level menu.

4 From the drop-down list in the Reports window, select By Sales Rep, and then 
click Run Now.

To open the report design for the Opportunities by Sales Rep report

1 Open Actuate e.Report Designer Professional.

2 Choose File > Open.

3 In the Open dialog box, navigate to the C:\Siebdev\rptsrc\enu\standard folder 
(or the equivalent on your computer) and select Opslsrep.rod.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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The Opslsrep.rod report design file in Actuate e.Report Designer Professional is 
shown in Figure 18.

Explore the report design, compare design elements to the corresponding features 
in the report output, and right-click components to view their property lists.

Notice the following features of this report design:

■ There are three datastreams, corresponding to the master report, the subreport, 
and the combined report. The master report (GenerateDataStream) and the 
subreport (InnerReport) are strictly for data gathering and do not have content 
frames.

■ If you open Siebel Tools and navigate to the report object definitions for the 
Opslsrep report (Opportunities - By Sales Rep) and its children, you can see that 
opportunity records are the parent, and position records (with a limited number 
of fields exposed) are the child. This is also reflected in the report design in 
Actuate, with the master datastream obtaining opportunities and the detail 
datastream obtaining positions for each opportunity.

Figure 18. Opportunities by Sales Rep Design
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■ If you right-click the top-level report design component, choose Properties, and 
click the Variables tab, you can see that a custom variable has been defined. It 
is called RowList and is of the AcList class. This list structure variable holds the 
data rows as they are obtained from the input datastreams, for later access by 
the sort (combined) datastream. This is described in “Global List Variable” on 
page 226.

■ The Fetch method in each of the three datastreams has been locally overridden 
in order to change the record acquisition code. You can determine this by 
opening the Properties window for the datastream, clicking the Methods tab, 
and noting the dark font used for the name of the Fetch method. Double-click 
the method name to view the code.

■ The Fetch method on the master datastream (QueryOuter) moves the data in 
the current master record to a public data row variable called 
OutSideDataRow. This variable is defined on the master datastream, making 
the current master record available to the detail datastream, ssPositionQuery. 
See “Fetch Method on the Master Datastream” on page 227.

■ The Fetch method on the detail datastream (ssPositionQuery) joins the 
master and detail data rows to create a combined data row, which is 
subsequently added to the RowList global list. See “Fetch Method on the 
Detail Datastream” on page 227.

■ The Fetch method on the combined datastream (GetFromList) gets each data 
row from the global list and passes the data row to the sort filter. See “Fetch 
Method on the Combined Datastream” on page 230.

■ The combined report section, GenerateFormat, uses the GetFromList datastream 
that has been locally created and defined, rather than imported from the data 
supply library file generated by Siebel Tools. The parent component of this 
datastream, rather than the report section itself, is a data filter component. The 
datastream is created from the ssDataSource library component in sscustom.rol 
and the data filter from the ssMemoryDataSorter in the same library. 

The Compare method on the sort data filter re-sorts the data rows that have been 
sent to the filter. The sort data filter component is described in “Compare 
Method on the Sort Data Filter” on page 231.
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Global List Variable
A global list variable, based on the AcList class in the AFC library, holds the data 
rows as they are obtained from the input datastreams, for later access by the sort 
datastream. In the Opportunities by Sales Rep report, this variable is called RowList. 
You add the global list variable to the top-level component in the report design, 
namely the report design itself.

To create a global list variable in the report design

1 Navigate to the Report Design, which is the top-level component, and right-click 
it. In the pop-up menu, select Properties.

2 In the Properties window for the Report Design component, click the Variables 
tab.

3 Click the New button. The Class Variable dialog box appears.

4 Enter the following values:

■ In the Name field, enter RowList.

■ In the Class field, select AcList.

■ Leave Externally Defined Data Type unchecked.

■ In the Storage radio button group, click Static.

■ In the Visibility picklist, select Public.

5 Click OK to save the new variable.

In the Opportunities By Sales Rep example, the RowList variable holds the merged 
data rows that were created in the GenerateDataStream report section. After each 
combined data row is built, it is added to the list by calling the AddToTail method 
on the RowList variable. 
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Fetch Method on the Master Datastream
The Fetch method on the master datastream (QueryOuter in the example report) 
moves the data in the current master record to a public data row variable called 
OutSideDataRow. This variable is defined on the master datastream, making the 
current master record available to the detail datastream, ssPositionQuery. The Fetch 
method on the master datastream contains the following code: 

Function Fetch( ) As AcDataRow

Set Fetch = Super::Fetch()

' If a row is returned, then assign it to OutSideDataRow Var

If NOT Fetch Is Nothing Then

Set OutSideDataRow = Fetch

End If

End Function

Fetch Method on the Detail Datastream
The Fetch method on the detail datastream joins the master and detail data rows to 
create a combined data row, which is subsequently added to the RowList global list. 
The field structure of the combined data row is defined in the data row child 
component of the combined datastream component. In the Opportunities By Sales 
Rep example, the combined data row is CombinedDataRow, and this is a child of 
the GetFromList datastream.

The Fetch method in the detail datastream has the following code:

Function Fetch( ) As AcDataRow

Dim aInsideDataRow As ssPositionDataRow

Dim aOutsideDataRow As ssOpportunityDataRow
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Dim aCombinedDataRow As CombinedDataRow

' Initialize the List Object if it has been initialized

' This should only happen for the first time through

If RowList Is Nothing Then

Set RowList = New AcSingleList

End If

' Get the current inside row

Set aInSideDataRow = Super::Fetch( )

If aInSideDataRow is Nothing Then

Set Fetch = Nothing

Exit Function

End If

' Get a pointer to the Outside Data Row Variable, declared on the 
DataSource

Set aOutsideDataRow = OPSLSREP::QueryOuter::OutSideDataRow

If aOutsideDataRow Is Nothing Then

Exit Function

End If

' Create a new CombinedDataRow

Set aCombinedDataRow = New CombinedDataRow
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' Fill Combined Data row with entries from inner row

aCombinedDataRow.ssSales_Rep = aInSideDataRow.ssLogin_Name

aCombinedDataRow.ssPosName = aInSideDataRow.ssName

aCombinedDataRow.ssClose_Date = 
aInSideDataRow.ssOpportunity_Close_Date

aCombinedDataRow.ssClose_Date_Formatted= 
aInSideDataRow.ssOpportunity_Close_Date_Formatted

aCombinedDataRow.ssRevenue_Formatted = 
aInSideDataRow.ssOpportunity_Revenue_Formatted

aCombinedDataRow.ssRevenue= 
aInSideDataRow.ssOpportunity_Revenue

' Get values that are required from the outside data row

aCombinedDataRow.ssName = aOutSideDataRow.ssName

aCombinedDataRow.ssAccount = aOutSideDataRow.ssAccount

aCombinedDataRow.ssCity = aOutSideDataRow.ssCity

aCombinedDataRow.ssDescription = 
aOutSideDataRow.ssDescription

aCombinedDataRow.ssPostal_Code = 
aOutSideDataRow.ssPostal_Code

aCombinedDataRow.ssRep__ = aInSideDataRow.ssOpportunity_Rep__

aCombinedDataRow.ssSales_Stage = 
aOutSideDataRow.ssSales_Stage

aCombinedDataRow.ssState = aOutSideDataRow.ssState

aCombinedDataRow.ssStreet_Address = 
aOutSideDataRow.ssStreet_Address

' Handle inside row so that Fetch continues to function

Set Fetch = aInsideDataRow
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' Add the newly created combined datarow to the Global list of rows

RowList.AddToTail(aCombinedDataRow)

End Function

Fetch Method on the Combined Datastream
The Fetch method on the combined datastream gets data from the global list. For 
each row in the global list, the GetAt method on the global list variable is invoked 
to obtain the data, and the AddRow method on the parent data sort filter component 
is invoked to pass the data row to the filter.

The code for the Fetch method on the combined datastream is as follows:

Function Fetch( ) As AcDataRow

Dim curList As AcList

Dim curDataRow As CombinedDataRow

' Acquire a reference variable to the global RowList from first 
report

Set curList = RowList

If curList is Nothing then

   'MsgBox "failure to acquire Row List"

Exit Function

End If

   

' Set the data row to the Item in the list at the current position

Set curDataRow = curList.GetAt(Position)

If curDataRow Is Nothing Then
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Exit Function

End If

Set Fetch = curDataRow

AddRow (Fetch)

End Function

Compare Method on the Sort Data Filter
The Compare method on the sort data filter re-sorts the data rows that have been 
sent to the filter. A sort filter is configured primarily by overriding the filter’s 
Compare method to specify how the rows should be sorted. Compare takes two 
rows as arguments and returns one of the following values:

■ A positive number if the first row goes after the second row.

■ Zero if both rows are the same.

■ A negative number if the first row goes before the second row.

The code you define in the Compare method defines the criterion for ordering the 
records. 

The Compare method calls the CompareKeys method (in the AcDataSorter class in 
the AFC) to compare two key values obtained from the same column. The 
CompareKeys method returns one of the following values:

■ –1 if key1 is less than key2

■ 0 if key1 equals key2

■ 1 if key1 is greater than key2

In the case of the Opportunities By Sales Rep report, opportunities are being ordered 
primarily by sales rep and secondarily by revenue. That is, within each group with 
the same sales rep, the opportunities are ordered by revenue. This makes it possible 
for the group section to provide a group break at each change in sales rep, and 
within each group for the opportunities to be listed from highest to lowest in 
revenue.
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The code for the Compare method on the sort data filter is as follows:

Function Compare( row1 As AcDataRow, row2 As AcDataRow ) As 
Integer

Dim aRow as CombinedDataRow

Dim bRow as CombinedDataRow

Set aRow = row1

Set bRow = row2

' Order By Sales Reps

Compare = CompareKeys(aRow.ssSales_Rep, bRow.ssSales_Rep)

' Order by Revenue, descending

' May want to use the functional data here

If Compare = 0 Then

Compare = CompareKeys(Val(bRow.ssRevenue), 
Val(aRow.ssRevenue))

End If

End Function
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Examining a Report Based on a Many-to-Many 
Relationship

A good many-to-many report to study is the Contacts By Opportunity report, which 
is invoked from a view in the Contacts screen (typically the My Contacts view). You 
should examine the report output in Siebel Sales and the report design in Actuate 
e.Report Designer Professional, leaving both open to compare them.

To generate the Contacts By Opportunity report

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Contacts > My 
Contacts.

3 While still in the My Contacts view, choose View > Reports from the 
application-level menu.

4 From the drop-down list in the Reports window, select By Opportunity.

The Contacts By Opportunity report appears in a new web browser window.

To open the report design for the Contacts By Opportunity report

1 Open Actuate e.Report Designer Professional.

2 Choose File > Open.

3 In the Open dialog box, navigate to the C:\Siebdev\rptsrc\enu\standard folder 
(or the equivalent on your computer) and choose Cntopp.rod.

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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The Cntopp.rod report design file in Actuate e.Report Designer Professional is 
shown in Figure 19.

Notice the following features of this report design (especially in comparison to the 
Opportunities By Sales Rep report described in “Examining a Report Sorted on a 
Multi-Value Field (MVF)” on page 223):

■ The structures of the reports and the code defined on the corresponding 
datastreams and data filters are very similar between the reports. 

■ The global list variable and the master row global variable are both defined on 
the report design component Cntopp.rod. In Oppslsrep.rod, the global data row 
variable was defined in datastream Fetch code, which accomplishes the same 
result. Defining the data row variable on the report design component is 
preferable for clarity in your design.

■ The Compare method in Cntopp.rod sorts the merged records primarily on 
opportunity name and secondarily on contact last name. This is consistent with 
the sorting and grouping requirements of the final report.

Figure 19. Contacts By Opportunity Report Design
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■ If you open Siebel Tools and navigate to the report object definitions for the 
Cntopp.rod report (Contacts - By Opportunity) and its children, you can see that 
contact records are the parent, and opportunity records (with only the Name 
field exposed) are the child. This is also reflected in the report design in Actuate, 
with the master datastream obtaining contacts and the detail datastream 
obtaining opportunities for each contact.

This structure is analogous to what was done in the Opslsrep.rod object 
definitions and report design. The business component that is to be sorted and 
printed is the master. The business component that provides the sort key is the 
detail. While this may seem counterintuitive in the case of a many-to-many 
report, in which the detail business component provides the group headings and 
the master business component provides the detail report rows, it is consistent 
with the data model of the Contact business object. Since the report is invoked 
from views in the Contacts screen, where the Contact business object is active, 
it is not possible to obtain records through a master-detail relationship in which 
Opportunity is the master. To do so would provide no benefit in any case because 
the records of the two business components are merged before sorting.
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This chapter explains the techniques for incorporating graphics, such as bar charts 
and pie charts, in reports. The overall methodology is described, the 
correspondences between Siebel chart types and Actuate graph types are detailed, 
and the property settings for a graph are explained. For more information about 
creating graphs, see the “Presenting data in graphs” chapter in Actuate’s Designing 
e.Reports manual on the Siebel eBusiness Third-Party Bookshelf.

One existing standard report that incorporates graphics, the Opportunities Pipeline 
report, is analyzed. An example is also provided in which you create a customized 
version of a standard report containing group breaks. The customized report 
includes a summary bar chart at the end of each group of detail records.
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A graph is a control that is positioned in a content frame. A graph control in a 
content frame in Actuate e.Report Designer Professional is shown in Figure 20.

The graph in this figure uses the data supplied by a datastream to the current report 
section in the same way as detail report rows the data. A graph control can occupy 
the same frame as other controls. 

In a report that provides only a graph and no textual data, the graph control 
occupies the entirety of the main content frame in the report section. An example 
of this design is shown in “Sample Report—Opportunities Pipeline” on page 253. 
Another option is to place a graph control in the After frame in a report that has a 
group break, in which case the graph appears after each group of text rows. An 
example of this design is shown in “Example—Creating a Report with Graphics” on 
page 258.

Graphs used in reports fall into two categories, depending on the relationship 
between bars or curve points and the underlying data, as follows:

Figure 20. Design Editor Displaying a Graph Control in a Frame
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■ Detail graphs. Each data point is plotted individually as a curve point or a bar. 
Both the x- and y-axes must be numeric. Detail graphs have limited utility and 
are generally used only for scatter charts. Detail graphs are based on the 
acDetailGraph class in the Actuate Foundation Class (AFC) library. 

NOTE: The use of a component from the AFC library, rather than the sscustom 
library, is an exceptional situation and applies only to detail graphs. AFC 
components should not be used directly in Siebel reports except in this specific 
situation.

■ Summary graphs. All data points in a given classification are combined, and an 
aggregate value is plotted for each curve point or bar. Summary graphs support 
plotting data series, in which one set of bars or line graph points is provided for 
each legend label. They also support text label and date values on the x-axis. 
Summary graphs are based on the ssSummaryGraph class in the sscustom 
library. 

In either case, the component is dragged onto an empty frame, and the properties 
are set to configure the use of data. A detail graph control can be added from the 
Graph button. A summary graph must be added from the Library Browser window 
for the sscustom library. 

NOTE: A third graph type, HLC (high-low-close), is also available, but is not 
described in this chapter. An HLC graph is added using the graph button, and you 
select the AcHLCGraph class when prompted.
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Actuate-Supplied Chart Types
Actuate provides many of the same chart (or graph) types as Siebel eBusiness 
Applications. This makes it possible to duplicate these kinds of graphics in Siebel 
views and the reports for those views. All the chart types listed in Table 5 are 
available for both detail and summary graphs, but many will work correctly only in 
summary graphs. Table 5 shows supported chart types in Siebel applications and 
Actuate and the correspondences between them.

 

Table 5. Siebel Chart Types and Corresponding Actuate Graph Types

Siebel Chart Type Actuate Graph Type

2dBar Graph2dBar (vertical)

2dHorizBar Graph2dBar (horizontal)

2dLine GraphLine

2dPie Graph2dPie

2dScatter GraphScatter

2dSpline

2dStackedBar Graph2dBar (vertical, stacked)

3dBar Graph3dBar (vertical)

3dClusteredBar Graph3dBar (vertical, clustered)

3dHorizBar Graph3dBar (horizontal)

3dLine

3dPie Graph3dPie

3dSpline GraphTape

3dStackedBar Graph3dBar (vertical, stacked)

Combo Graph2dArea

Graph3dArea

GraphHLC (High-Low-Close)

GraphOHLC (Open-High-Low-Close)

GraphCandleStick
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The property settings for a graph control are set in the Component Editor. To access 
this, right-click the graph, choose Properties from the pop-up menu, and click the 
Properties tab. Summary and detail graphs have the same set of available 
properties, with the exception of the properties in the Expressions category, which 
differ between the two types.

The properties for a graph control, arranged by property category (the folder you 
must expand to view the property), are described in Table 6.

Table 6. Graph Properties by Property Category

Category Property Description

TargetWindow Name The name of the target window in which the 
contents of a hyperlink appear. 

Advanced LinkExp The expression defining a hyperlink for this 
graph object. 

ObjectVariable The name of an optional method in the frame that 
will point to this graph object. 

Data DataSetCount The number of data series. This value is 
computed when the graph is displayed. When 
you are designing the graph, this property 
contains the number of sample points to show.

PointCount The number of points in each data series. This 
value is computed when the graph is displayed. 
When you are designing the graph, this property 
contains the number of sample points to show.

PointLabelColor The color of the labels displayed for each point.

PointLabelStyle The style of the labels displayed for each point. 
Options are GraphNoPointLabels, 
GraphCustomLabels, GraphNumericLabels, 
GraphColoredNumericLabels, and 
GraphColoredCustomLabels.

SampleMax Maximum for the sample values.

SampleMin Minimum for the sample values.

ValuesColorList A comma-separated list of color names or RGB 
values to identify different data series.
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Expressions (in AcDetailGraph only) LabelValueExp Contains a data row variable, in square brackets, 
from which a text x-axis label can be obtained for 
each point. Note that values are not aggregated 
for each label.

XValueExp Contains a data row variable, in square brackets, 
that supplies the X value for each data point. For 
example, in a scatter graph that plots revenue on 
the y-axis against sales stage on the x-axis, the 
setting for this property would be 
[ssSales_Stage].

YValueExp Contains a data row variable, in square brackets, 
that supplies the Y value for each data point. For 
example, in a scatter graph that plots revenue on 
the y-axis against sales stage on the x-axis, the 
setting for this property would be [ssRevenue].

ZValueExp Contains a data row variable, in square brackets, 
that supplies the Z value (series) for each data 
point.

Table 6. Graph Properties by Property Category

Category Property Description
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Expressions (in ssSummaryGraph only) CategoryKey Contains a data row variable or expression that 
specifies the category, that is, the x-axis value 
that groups data. This should normally evaluate 
to an integer. For example, in a summary graph 
that groups opportunities by month, the category 
key would be:

Year([ssClose_Date]) * 12 + 
Month([ssClose_Date]) –1

CategoryLabel Contains a data row variable or expression that 
provides the text label for each category. For 
example, in a summary graph that groups 
opportunities by month, the category label 
expression would be:

[ssClose_Date_ Formatted]

SeriesKey Contains a data row variable or expression that 
specifies the series (z-axis) for the data point, 
that is, the value that determines which bar color 
or line graph curve the point appears in. This 
should normally evaluate to an integer. 

SeriesLabel Contains a data row variable or expression that 
provides the text label to appear in the legend for 
each series.

ValueExp Contains a data row variable or expression that 
supplies the Y value for each data point. For 
example, in a summary graph that displays 
opportunity revenue by month, the value 
expression would be:

Sum(Val([ssRevenue]))

Table 6. Graph Properties by Property Category

Category Property Description
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General AxisColor Color of the axis lines.

BackgroundColor Background color of the graph. Ignored if 
BackgroundIsClear is TRUE.

BackgroundIsClear TRUE if the background of the graph is clear.

GraphBackground. Color Color of the rectangle around the graph.

GraphBackgroundIsClear TRUE if the rectangle around the graph itself (not 
including titles or the legend) is clear.

GraphBorderStyle Style for the border around the graph. Options are 
GraphNoBorder, GraphSolidBorder, 
GraphDropShadow, GraphShadowAndBorder, 
GraphRaisedBorder, and GraphLoweredBorder.

GraphType Specifies the graph type. Options are 
Graph2DPie, Graph3DPie, Graph2DBar, 
Graph3DBar, GraphLine, Graph2DArea, 
Graph2DScatter, GraphHLC, GraphTape, 
GRaphOHLC, Graph2DArea, and Graph3DArea.

GridColor Color of the grid lines superimposed on the 
graph.

Graph-Specific BarGrouping Specifies that a bar chart is clustered, stacked, or 
without clustering or stacking. Ignored for charts 
other than bar charts. Options are 
GraphBarNoGrouping, GraphBarCluster, 
GraphBarClusterZ (3D only), GraphBarStack, and 
GraphBarStackPercentage.

BarOrientation Specifies that a bar chart has horizontal or 
vertical bars. Ignored for charts other than bar 
charts. Options are GraphBarVertical, 
GraphBarHorizontal, and 
GraphBarHorizontalReversed.

Table 6. Graph Properties by Property Category

Category Property Description
244 Siebel Reports Administration Guide Version 7.5, Rev B



Using Graphics in Reports

Graph Control Properties
Graph-Specific
(continued)

HLCBarStyle HLC and OHLC graphs only. Determines how the 
graph displays high, low, and close tick marks. 
Options are GraphHLCAllBars, 
GraphHLCThickBars, GraphHLCNoClose, and 
GraphHLCNoBars.

LineStyle Specifies that a line graph has solid lines of 
default thickness, broken lines of a particular 
pattern, or thick lines. Applies to line graphs only. 
Options are GraphDefaultLines, 
GraphPatternLines, and GraphThickLines.

LineStylesList Line graphs only. A comma-separated list of line 
styles, one style for each data set. Options are 
SingleLine, DashLine, DotLine, DashDotLine, 
DashDotDotLine, and NullLine. 

LineThickness Line and scatter graphs only. Specifies the 
thickness of lines in graph-specific units.

PointsArePercent Area graphs only. TRUE indicates that the 
numbers on the data points are percentage 
figures. FALSE indicates that the points are 
absolute numbers.

ShowAsPercent Area graphs and pie charts only. Draws the graph 
showing the percentage of each data point as the 
sum of all points in that dataset. The area always 
fills the full graph height.

ShowLines Line, log/lin, lin/log, and log/log graphs only. 
TRUE shows lines connecting the points.

ShowSticks Line, log/lin, lin/log, log/log, and scatter graphs 
only. TRUE shows lines from the y-axis to each 
point.

ShowSymbols Line, log/lin, lin/log, log/log, and scatter graphs 
only. TRUE shows symbols for each point.

Table 6. Graph Properties by Property Category

Category Property Description
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HTML Alignment Specifies the alignment of the graph window 
within the flow of text in the report.

AlternateText In browsers that do not support Java applets, 
specifies the text that appears in place of the 
graph.

BorderWidth The number of pixels of thickness of the border 
around the graph.

Margin The number of pixels of horizontal and vertical 
space between the window and the surrounding 
text.

UseDefaultSize Determines whether to use the default image size 
computed by the browser. If it is set to TRUE, the 
system does not generate the height and width 
HTML attributes. If FALSE, the system generates 
these attributes from the Size property.

Legend LegendBackgroundColor Background color for the legend.

LegendBackground IsClear TRUE if the legend is transparent.

LegendBorderStyle The style of the box to draw around the legend. 
Options are GraphNoBorder, GraphSolidBorder, 
GraphDropShadow, GraphShadowAndBorder, 
GraphRaisedBorder, and GraphLoweredBorder.

LegendColorText TRUE if the legend entries are the same color as 
the lines, points, or bars they identify. FALSE if 
they are all the color given by 
Legend.LegendFont.Color.

LegendFont A group of properties that defines the font of the 
legend labels, including Bold, Color, FaceName, 
Italic, and so on.

LegendPosition The position of the legend. Options are 
GraphLegendNone, GraphLegendTop, 
GraphLegendTopRight, GraphLegendTopLeft, 
GraphLegendLeft, GraphLegendRight, 
GraphLegendBottomLeft, GraphLegendBottom, 
and GraphLegendBottomRight.

LegendSize The relative size of the legend, from 0 (smallest) 
to 100 (largest). This value controls the spacing of 
legend entries.

Table 6. Graph Properties by Property Category

Category Property Description
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Titles AxisTitleFont A set of properties that defines the font of the x- 
and y-axis titles.

LabelFont A set of properties that defines the font for the x- 
and y- axis values labels, and that of the data 
labels adjacent to each point.

TitleBackground Color Background color for the rectangle enclosing the 
title.

TitleBackgroundIsClear TRUE indicates that the area under the title 
should be transparent.

TitleBorderStyle Style for the border around the title. Options are 
GraphNoBorder, GraphSolidBorder, 
GraphDropShadow, GraphShadowAndBorder, 
GraphRaisedBorder, and GraphLoweredBorder.

TitleFont A set of properties that defines the font for the 
graph title.

TitleText Title that appears above the graph.

TOC TocAddComponent Determines whether the component name is 
added to the report's table of contents. The 
values are:

TOCAlwaysAdd. Always add the component to 
the table of contents.   

TOCIfAllVisible. Add component name to the 
table of contents only if the user can view at least 
one page generated from the component based 
on page security. This is the default.

TOCIfAnyVisible. Add component to table of 
contents even if the user cannot view any pages 
generated from the component based on page 
security.

TOCSkip. Never add the component to the table 
of contents. Use this to hide components such as 
parallel or sequential sections or detail frames 
from the user.

TocAddContents Determines whether the component’s contents 
are added to the report’s table of contents.

TocValueExp Returns a string to show as the table of contents 
entry for this object.

Table 6. Graph Properties by Property Category

Category Property Description
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Viewing CursorShape The kind of cursor to show when the mouse 
cursor passes over the graph object. 

HelpText The text to show for this graph object when the 
user asks for help. 

Searchable Specifies whether the graph object can be 
searched in the Viewer. 

SearchAlias The name to display to the user when building a 
search for this graph object. 

Selectable TRUE if the user can select this graph object in 
the Viewer. 

Visual Position The position of the graph object in its enclosing 
frame.

Size The size of the graph object. 

Table 6. Graph Properties by Property Category

Category Property Description
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X-Axis XAxisPosition The position of the x-axis. Options are 
GraphXAxisAuto, GraphXAxisTop, and 
GraphXAxisBottom. 

XAxisStyle The location of the graph origin. Options are 
GraphZeroOrigin, GraphAutoOrigin, and 
GraphCustomOrigin.

XLabelFormat The format string used to create custom x-axis 
labels.

XLabelsList A comma-separated list of quoted x-axis values.

XLabelStyle The kind of labels to show along the x-axis. 
Options are the following:

GraphNoLabels. Displays no labels.

GraphAutoLabels. Displays labels computed 
automatically.

GraphCustomLabels. Displays custom labels 
based on the information you enter in the 
XLabelsList property.

GraphExpressionLabels. Displays labels 
computed from an expression you specify in the 
LabelExp property.

XMajorGridStyle The style of line to draw for the major grid lines. 
Options are SingleLine, DashLine, DotLine, 
DashDotLine, DashDotDotLine, and NullLine.

Table 6. Graph Properties by Property Category

Category Property Description
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X-Axis
(continued)

XMajorTickCount The number of ticks to display. For graphs with X 
values, this is the number of ticks to display. For 
graphs without X values, this is the frequency of 
the ticks (that is, points per tick).

XMajorTickStyle The kind of tick marks to include. Options are 
GraphNoTicks, GraphAutoTicks, and 
GraphCustomTicks.

XMax Sets the maximum x-axis limit. This value is 
computed when the graph is displayed. When the 
graph is being designed, this value is used for 
displaying sample data.

XMin Sets the minimum x-axis limit. This value is 
computed when the graph is displayed. When the 
graph is being designed, this value is used for 
displaying sample data.

XMinorGridStyle The style of line to draw for the minor grid lines.

XShowMinorTicks TRUE indicates that the graph displays minor tick 
marks. If so, there will always be five minor tick 
marks between two major tick marks.

XTitle The text of the label to show for the x-axis.

XTitleBackGround Color The background color of the x-axis title.

XTitleBackgroundIsClear TRUE specifies that the x-axis title background is 
transparent.

XTitleBorderStyle The style of the rectangle that encloses the x-axis 
title. Options are GraphNoBorder, 
GraphSolidBorder, GraphDropShadow, 
GraphShadowAndBorder, GraphRaisedBorder, 
and GraphLoweredBorder.

XValueSet Indicates how the system should determine how 
many x-axis values are available.

GraphDefaultXValues. No x-axis values are 
available; the graph should provide default 
spacing along the x-axis. 

GraphXValuePerDataSet. There is one set of x-
axis values provided in the points for the first (or 
only) data set that apply to all points. 

GraphXValuePerPoint. Each point has its own X 
value.

Table 6. Graph Properties by Property Category

Category Property Description
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Y-Axis YAxisPosition The position of the y-axis. Options are 
GraphYAxisAuto, GraphYAxisLeft, and 
GraphYAxisRight.

YAxisStyle The location of the graph origin. Options are 
GraphZeroOrigin, GraphAutoOrigin, and 
GraphCustomOrigin.

YLabelFormat The format string used to create custom y-axis 
labels.

YLabelsList A comma-separated list of quoted y-axis values. 

YLabelStyle The kind of labels to show along the y-axis. 
Options are the following:

GraphNoLabels. Displays no labels.

GraphAutoLabels. Displays labels computed 
automatically.

GraphCustomLabels. Displays custom labels 
based on the information you enter in the 
XLabelsList property.

GraphExpressionLabels. Displays labels 
computed from an expression you specify in the 
LabelExp property.

YMajorGridStyle The style of line to draw for the major grid lines. 
Options are SingleLine, DashLine, DotLine, 
DashDotLine, DashDotDotLine, and NullLine.

YMajorTickCount The number of ticks to display. For graphs with y-
axis values, this is the number of ticks to display. 
For graphs without y-axis values, this is the 
frequency of the ticks.

YMajorTickStyle The kind of tick marks to include. Options are 
GraphNoTicks, GraphAutoTicks, and 
GraphCustomTicks.

Table 6. Graph Properties by Property Category

Category Property Description
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Y-Axis
(continued)

YMax Sets the maximum y-axis limit. This value is 
computed when the graph is displayed. When the 
graph is being designed, this value is used for 
displaying sample data.

YMin Sets the minimum y-axis limit. This value is 
computed when the graph is displayed. When the 
graph is being designed, this value is used for 
displaying sample data.

YMinorGridStyle The style of line to draw for the minor grid lines. 
Options are GraphDefaultLines, 
GraphPatternLines, and GraphThickLines.

YShowMinorTicks TRUE indicates that the graph displays minor tick 
marks. If so, there will always be five minor tick 
marks between two major tick marks.

YTitle The text of the label to show for the y-axis.

YTitleBackGround Color The background color of the y-axis title.

YTitleBackgroundIsClear TRUE means the y-axis title background is 
transparent.

YTitleBorderStyle The style of the rectangle that encloses the y-axis 
title. Options are GraphNoBorder, 
GraphSolidBorder, GraphDropShadow, 
GraphShadowAndBorder, GraphRaisedBorder, 
and GraphLoweredBorder.

YTitleOrientation Determines how the text appears for the y-axis 
title. The default is GraphYLabelUp, which 
rotates the text 90 degrees counterclockwise. 
Options are GraphYLabelHoriz, GraphYLabelUp, 
and GraphYLabelDown.

YVerticalLabels TRUE to show x-axis labels rotated 90 degrees.

Table 6. Graph Properties by Property Category

Category Property Description
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Sample Report—Opportunities Pipeline
The Opportunities Pipeline standard report is provided in your 
C:\Siebdev\rptsrc\language\standard directory, but is not currently used in Siebel 
Sales. However, it can be invoked from Actuate e.Report Designer Professional 
when Siebel Sales is running with an active filter in the Opportunities screen.

To display the Opportunities Pipeline report

1 Open Siebel Sales.

2 From the application-level menu, choose View > Site Map > Opportunities > 
My Opportunities.

3 Open Actuate e.Report Designer Professional.

4 Open the Oppipe.rod design file, located in C:\Siebdev\rptsrc\enu\standard, in 
Actuate. 

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

5 Hide all toolbars except the Viewer toolbar, using the View > Toolbars option.

6 Build and run the report.
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The Opportunities Pipeline report, displayed in Actuate e.Report Designer 
Professional, is shown in Figure 21.

This is a single-page report containing a bar graph. This graph aggregates the 
revenue (anticipated or actual) by the month in which the close date occurs.

Figure 21. Opportunities Pipeline Report
254 Siebel Reports Administration Guide Version 7.5, Rev B



Using Graphics in Reports

Sample Report—Opportunities Pipeline
Report Structure
The Opportunities Pipeline report has a very simple structure. It obtains its data 
from a single datasource without subreports (because only opportunities are being 
graphed). The only unique feature is a graph component placed in the content 
frame. The structure is illustrated in Figure 22.

The graph component has been dragged onto the content frame from the Library 
Browser window of the sscustom library. The ssSummaryGraph component has 
been dragged onto the frame, causing the structure tree to display a graph child 
component of the content frame. 

Figure 22. Opportunities Pipeline Report Structure
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Property Settings
Table 7 lists the significant property settings of the graph component in the 
Opportunities Pipeline report.

Table 7. Significant Property Settings for the Graph

Property Setting Explanation

Data.DataSetCount 1 Specifies that there is only one bar series.

Data.PointLabelStyle GraphNoPointLabels This setting specifies that values do not 
display at the top of each bar.

Expressions.CategoryKey Year([ssClose_Date]) * 12 + 
Month([ssClose_Date]) –1

This expression assigns an integer value to 
the month in which each opportunity 
occurred. Opportunities with the same 
month have their revenue summed to 
generate one bar.

Expressions.Category Label [ssClose_Date_ Formatted] Value from which each x-axis label is 
generated.

Expressions.ValueExp Sum(Val([ssRevenue])) Expression for obtaining the y-axis value to 
plot for each bar.

General.GraphType Graph2dBar Specifies that the graph is a 2d bar chart.

Graph-Specific.BarGrouping GraphBarNoGrouping Specifies that there is a single series of 
bars, not multiple series.

Graph-Specific.BarOrientation GraphBarVertical Specifies that the bars in the bar graph are 
vertical rather than horizontal.

X-Axis.XAxisStyle GraphZeroOrigin Specifies that the x-axis starts at the value 
zero.

X-Axis.XLabelFormat mm ’yy Specifies a format mask for the x-axis date 
values, used to generate x-axis labels.

X-Axis.XLabelStyle GraphExpressionLabels Specifies that x-axis labels are present and 
are derived from the CategoryLabel 
expression.

X-Axis.XTitle Time (By Month) Text to appear beneath the x-axis.

X-Axis.XValueSet GraphXValuePerDataSet There is one set of x-axis values that 
applies to all data series. 
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Y-Axis.YAxisPosition GraphYAxisLeft Specifies that the y-axis is displayed and 
appears on the left side.

Y-Axis.YAxisStyle GraphAutoOrigin Specifies that the y-axis origin is 
determined automatically from the data.

Y-Axis.YLabelFormat #,### Format mask for the values displayed next 
to y-axis tick marks.

Y-Axis.YLabelStyle GraphCustomLabels Displays custom labels based on the 
information you enter in the YLabelsList 
property.

Y-Axis.YTitle Revenue The title to appear alongside the y-axis.

Y-Axis.YMajorGridStyle SingleLine Specifies that horizontal lines appear, 
rather than a grid.

Y-Axis.YMajorTickCount 5 Specifies how many tick marks are 
displayed on the y-axis.

Y-Axis.YVerticalLabels False Specifies that y-axis labels are horizontal 
rather than vertical.

Table 7. Significant Property Settings for the Graph

Property Setting Explanation
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Example—Creating a Report with Graphics
You can add a summary graph to the After section in a report containing a group 
break. The graph will appear at the end of each page, following the detail records. 
The graph summarizes the information on each page. 

In this example, the standard Opportunities - by source report—which lists 
opportunities for each source on a separate page—is modified to include a bar graph 
at the end of each page. The bar graph aggregates the opportunities by month. This 
is essentially the same bar graph that appears in the Opportunities Pipeline report 
described in “Sample Report—Opportunities Pipeline” on page 253. The custom 
report you create will provide such a graph for each group of opportunities with the 
same source, rather than once for the entire report.

You will subclass the existing OPSRC report for the sake of keeping the example 
simple. Normally you would create a new report design.

To create an Opportunities By Source report with graphics

1 In Actuate e.Report Designer Professional, choose File > Open, and then in the 
dialog box that appears, choose Opsrs.rol.

2 Save this file as OpSrsTest.rol.

3 Double-click the root object. Change the following property values in the 
component editor:

■ Title. Optys By Source With Graphic

■ Report Root Name. OPSRCGRPH

4 In the structure tree, navigate to the group section (ssGrp1) and subclass it 
following the instructions in “To create a report design file in Actuate e.Report 
Designer Professional” on page 141.

5 Set View > Options > Show Empty Slots to TRUE if it is not already set.

6 Open the Library Browser window for the sscustom library and drag the ssFrm 
component from the Library Browser window to the child After slot of the group 
section, then right-click the resulting After frame and subclass it.
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7 Drag the ssSummaryGraph component from the Library Browser window to the 
Content child slot of the After frame, then close the Library Browser window and 
turn off the display of empty slots.

8 Enlarge the After frame vertically by dragging its bottom handle. 

It should be a few inches in height on your screen.

9 Enlarge the graph control by dragging its lower-right handle so that it nearly fills 
the After frame.

10 Select the group component in the structure tree, right-click, and click 
Properties, then change the Page.PageBreakBefore property setting to TRUE. 

11 Close the Component Editor window.

12 Select the summary graph component in the structure tree, right-click, and click 
Properties. 

13 Set the properties to match the values in Table 7 on page 256, set the 
Titles.TitleText value to blank, and close the Component Editor window.

14 Make sure that Siebel Sales is open, with an active view in Opportunities 
displayed.

15 Build and run the report.
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The resulting report should look like Figure 23. The Opportunities - by source report 
reflects a listing of opportunities by a sales representative at the end of the second 
quarter. The accompanying graph shows the revenue possibility against the number 
of months the opportunity has been active.

Figure 23. Modified Opportunities - By Source Report
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This chapter describes the essential components of Smart Reports, which include 
specialized graphical elements and formatted summary information. In addition to 
the specialized graphical information and formatted summary, Smart Reports 
provide relevant detailed information. This chapter describes the implementation 
process, and provides examples to walk you through the process of creating them. 
This chapter is intended to allow you to configure and extend special graphical 
components, such as thermometers.

Smart Reports Overview
Siebel Smart Reports are reports designed to serve the needs of senior managers. In 
this section their purpose is explained, the standard Smart Reports are listed and 
described, and the typical visual features are illustrated.

Purpose of Smart Reports
Typical reports generated from application software tend to be operational/
transactional data spanning multiple pages. While this is generally appropriate for 
operations personnel, senior managers often need reports that go beyond the mere 
presentation of data and help extract the key information for decision making by 
bringing it into high visual relief. 

In some organizations, high-level executives use reports as their primary form of 
interaction with Siebel eBusiness Applications, and reports provide their typical 
means of accessing an application’s data. It is important to provide such users with 
reports that include summary information and performance metrics in graphical 
form in a concise and intuitive format. Siebel Smart Reports help senior managers 
users characterize a situation, analyze various issues, and take appropriate action. 
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For example, sales representatives, sales managers, and call center managers can 
use Smart Reports to measure their performance against recommended best 
practices, analyze trends, identify exceptions, and take appropriate action. Smart 
Reports are organized to start with summary information and proceed to the most 
detailed information. The contents fall into three sections or categories of 
information:

■ Dashboard section. The first section in a Smart Report is a dashboard. The 
dashboard provides intuitive graphical indicators for the key measures of utility 
and an order of merit. This helps the reader gauge the situation being studied: 
whether an opportunity is worth pursuing, whether the pipeline is healthy, and 
so on. 

■ Summary sections. When the reader has identified the key issues, the reader can 
proceed to the summary sections and analyze them. These sections contain 
charts and diagrams that aid analysis. For example, a summary section may 
include a Pipeline versus Quota chart that helps pinpoint the region that is in 
danger of missing targets.

■ Detail sections. Having analyzed the issue, the reader can drill into the 
underlying detail sections and take appropriate action. These tend to present 
information in a format similar to those of conventional standard reports. The 
manager can target key decision makers with activities that address their main 
decision issues, or identify the opportunities in the pipeline that need attention.
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Standard Smart Reports
Table 8 describes the standard Smart Reports provided with Siebel applications.

Table 8. Standard Siebel Smart Reports 

Name Description Hierarchy of Data

Opportunity Detail Describes the relevant details 
pertaining to the opportunity. It 
contains information about the 
relative importance of the 
opportunity, the likelihood of 
closing, the steps taken to date, and 
planned actions.

The dashboard summarizes Deal 
Size, Buying Influence, Probability 
of Closing, Competitive Activity, 
and Stage/Milestone. 

Summary and detail sections are 
provided for the following areas: 
Contacts, Products, Competitors, 
Decision Issues, Key Activities, All 
Activities, and Notes.

Account Summary Describes the relevant details 
pertaining to the account. It 
contains information about the 
account's historical and future 
revenue, satisfaction, 
organizational hierarchy, and 
service requests.

The dashboard summarizes Past 
Revenue, Pipeline Revenue, 
Customer Satisfaction, and 
Competitive Activity.

Summary and detail sections are 
provided for the following areas: 
Revenue Over Time (closed and 
pipeline), Current Opportunities, 
Contact Detail, Products Installed, 
Customer Satisfaction, Open 
Service Requests (by severity), and 
Campaigns/Activities. 

Pipeline Analysis An analysis of the current pipeline. 
It uses historical information to 
determine the revenue that is 
expected to be generated over the 
next four quarters and how it 
compares to the quota for that 
period. 

The dashboard summarizes 
Expected Revenue Current Quarter 
and Expected Revenue Next Four 
Quarters.

Summary and detail sections are 
provided for Pipeline Revenue and 
Opportunities Detail.
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Quota Summary Measures performance relative to 
quota for the current period and 
year-to-date. It tracks closed as well 
as pipeline revenue to determine 
whether the goal for the quarter can 
be met.

The dashboard summarizes 
Revenue Current Quarter and 
Revenue YTD.

Summary and detail sections 
include Revenue by Direct Report, 
Opportunities (closed), and 
Opportunities (open).

Service Request Aging Analysis Analyzes the aging of the currently 
open service requests. It tracks 
three metrics that may explain 
performance, the number of open 
service requests, call volume, and 
average resolution time during the 
past months.

The dashboard summarizes Time 
Open (current SRs), Number of 
Open SRs, Call Volume, and 
Average Resolution Time.

Summary and detail sections 
include Open Service Requests (by 
severity) and Closed Service 
Requests (by severity).

Account Service Detail Summarizes the service-related 
information pertaining to the 
account. It contains information 
about currently open service 
requests, customer satisfaction, and 
the historical service request 
resolution for the account. 

The dashboard summarizes 
Revenue, Open SRs, and Customer 
Satisfaction.

The first summary section includes 
summary graphics for Severity 
Distribution, Aging by Severity, SR 
Substatus, and Customer 
Satisfaction. There is also a Closure 
Times by Severity summary section.

There is one detail section listing 
Open Service Requests by severity. 

Table 8. Standard Siebel Smart Reports 

Name Description Hierarchy of Data
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Visual Features
Smart Reports are labeled as such in the Reports drop-down list in particular views. 
For example, from the Opportunities screen tab navigate to the My Opportunities 
view. Choose View > Reports from the application-level menu, and expand the 
drop-down list of reports. The Smart Report - Opportunity Detail selection appears 
in the listing, as shown in Figure 24.

 

Two important graphical elements specific to Smart Reports are described as 
follows:

■ Order of Merit indicator. Reflected in Figure 25, an up, down, or right arrow that 
indicates the merit of the opportunity, account, and so on, based on one or more 
criteria being analyzed in the report. The direction of the arrow depends on 
whether the values measured by the thermometers are above or below their 
triggers. A right arrow indicates that two of the three thermometers are above 
their triggers. The up arrow represents that all three thermometers are above 
their triggers.

Figure 24. Reports Menu in My Opportunities View

Figure 25. Order of Merit Indicators
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■ Thermometer. The vertical and horizontal partially filled rectangle graphs are 
called thermometers. Figure 26 shows the past revenue for an average account.

A thermometer is defined by four parameters:

■ Measure. The quantity being measured by the thermometer. The value of this 
quantity determines the height of the shaded area within the rectangle.

■ Minimum. The value represented by the bottom part of the rectangle.

■ Maximum. The value represented by the top part of the rectangle.

■ Trigger. A benchmark to which the value of the measure is compared. The 
order-of-merit indicator depends on whether the value of the measure is 
above or below the trigger.

For information on the configuration of thermometers, see “Thermometers” on 
page 273.

Figure 26. Thermometer
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Report Structure and Major Components
Smart Reports have a fairly complex structure relative to other standard Siebel 
reports. The hierarchy of high-level report design components in a Smart Report is 
illustrated in Figure 27.

Figure 27. Smart Report Component Hierarchy
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The design components in Figure 27 on page 267 are as follows:

■ Main Sequential Section. This is the parent component for all the major report 
sections. It causes its child sections to execute sequentially.

■ LOV Loading Report Sections. This is the first set of report sections executed. The 
purpose of these report sections is to obtain high, low, and average (or trigger) 
values for each of the thermometers from records in the List of Values (LOV) 
table. For example, in the Account Summary Smart Report, there is one LOV 
loading section each for the Past Revenue, Pipeline, and Customer Satisfaction 
thermometers. Each of these report sections obtains a record from the List of 
Values table corresponding to a particular LOV type. For more information, see 
“Obtaining the Minimum, Maximum, and Trigger Values” on page 275. 

■ Main Report Section. This report section holds all the design components for the 
Smart Report, other than the initial data collection sections and the pagelist. Its 
children are the main report datastream, the page header for the Smart Report, 
and the sequential section that processes the dashboard and various subreports.

■ Main Report Datastream. This datastream is the master datastream for the report, 
providing opportunity records for the opportunity Smart Report, account records 
for the account Smart Report, and so on. It uses the data row from the master 
datastream in the data supply library file.

■ Page Header. This component defines the page header for the Smart Report. In 
the page header, the name of each major entity (account, opportunity, and so 
on) appears, as it does in other standard reports. Certain summary values for the 
entity may be displayed as well. The unique feature of the page header in a 
Smart Report is that it also displays the order-of-merit indicator for that entity. 
The configuration of the order-of-merit indicator is discussed in “Order-of-Merit 
Indicator” on page 271.

■ Subreports Sequential Section. This section contains and sequentially processes 
the various report sections for the main report and subreports. These include 
data sorting sections, the dashboard section, and sections for the subreports that 
follow the dashboard in the report.
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■ Data Loading and Sorting Report Sections. These report sections are the first to 
appear in the sequential section, before sections that actually generate report 
lines and graphics. The data loading and sorting sections obtain and manipulate 
detail data for the current master record. The data is obtained from the various 
detail datastreams in the data supply library file. 

The detail datastreams accessed at this stage are those that must store data in 
global memory structures, often with some sorting or merging before storage. 
Detail datastreams without a global memory storage requirement (such as the 
contact, product, and activity datastreams in the Account Summary report) do 
not need to be included before the report sections in which they are used.

■ Dashboard Parallel Section. A parallel section contains multiple report sections 
displayed in different flows on the same page, often side by side. To create a 
dashboard section displaying thermometers and other graphics and text side by 
side, a parallel section is required. The children of the parallel section are the 
report sections for graphics and text that appear in the dashboard. 

■ Dashboard Graphics Report Sections. These report sections correspond to 
individual graphic elements in the dashboard. Each has a datastream, and some 
have a data filter as well. Each also has a content frame. Included as a child of 
the content frame is either a graph component or a thermometer frame. 

A thermometer frame is derived from the ssThermometer component in the 
ssSmart.rol library. The OnRow method in a thermometer frame calculates 
values for, and passes four parameters to, the corresponding method in the 
parent library thermometer: MinimumValue, MaximumValue, TriggerDataValue, 
and DataValue. The thermometer is drawn based on these four values. The 
thermometer label, trigger label, and fill color are specified in properties in the 
thermometer frame. For information on thermometer configuration, see 
“Thermometers” on page 273.

When a graph is displayed instead of a thermometer (such as the Competitive 
Activity graph in the Opportunity Detail and Account Summary reports), the 
content frame holds an AcDetailGraph or ssSummaryGraph control, configured 
as described in Chapter 11, “Using Graphics in Reports.”
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■ Dashboard Text Report Section. This section includes the datastream and content 
frame for the textual master report information. The report text in the dashboard 
is from one master record; for example, in the Account Summary report, the 
fields for the account record are printed in the dashboard text report section. The 
datastream for this section is the master datastream in the data supply library 
file. The content frame provides blank space for the thermometers and other 
dashboard graphics, although these are positioned using the dashboard subpage 
rather than this content frame. 

■ Dashboard Subpage. A subpage establishes the physical layout of visual elements 
in a section. The dashboard subpage specifies the layout of the dashboard 
parallel section. The locations of the thermometers, dashboard graphs, and text 
report section are determined here by defining and positioning a flow for each 
in the subpage. Generally, the flow for the text report section occupies the entire 
subpage, and the other flows each occupy some portion of this area.

■ Nondashboard Subreport Sections. The subreports that make up the summary and 
detail sections appear sequentially in the report following the dashboard parallel 
section. These are configured as typical subreports, each with a datastream and 
a content section. However, the data may be obtained from a memory structure 
(previously loaded in the data loading and sorting sections) and sorted or 
merged using a data filter.
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The order-of-merit indicator appears at the top right of the first page in a Smart 
Report and is configured in the page header. It consists of an up, down, or right 
arrow that indicates the merit of the opportunity, account, and so on, based on one 
or more criteria being analyzed in the report. The direction of the arrow depends 
on whether the values measured by the thermometers are above or below their 
triggers. Figure 28 shows the three order-of-merit indicators. A right arrow indicates 
that two of the three thermometers are above their triggers. The up arrow represents 
that all three thermometers are above their triggers.

The order-of-merit indicator is derived from one of three predefined image 
components in the ssSmart.rol library: ssOrderOfMeritUpImage, 
ssOrderOfMeritDownImage, or ssOrderOfMeritPushImage. Code in the Finish 
method of the page header component determines, from the status of all 
thermometers relative to their targets, whether the arrow direction to display is up, 
down, or right. 

For example, in the Account Summary report, the page header component is 
ssOrderOfMeritHeader1. The following code appears in the Finish method:

ArrowDirection = "DOWN"

If CustomerSatisfactionAboveTarget And 
PipelineThermometerAboveTarget Then

ArrowDirection = "UP"

End If

If PastRevenueThermometerAboveTarget And Not 
PipelineThermometerAboveTarget Then

ArrowDirection = "PUSH"

End If

Figure 28. Up, Right, and Down Order-of-Merit Indicators
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In the case of this report, the order-of-merit indicator direction is based on the status 
of two thermometers, Past Revenue and Pipeline. If both are above target, the arrow 
direction is up. If Past Revenue is above target and Pipeline is not, the direction is 
right (called PUSH in the code example). If Past Revenue is below target, regardless 
of Pipeline, the direction is down.

The code that generates the Boolean values for the two xxAboveTarget variables is 
located in the OnRow methods of the respective thermometers, as described in 
“Obtaining the Data Value” on page 277. 

Code in the Finish method of the page header determines the arrow direction to use 
and passes a value of UP, DOWN, or PUSH (the right arrow) in the ArrowDirection 
variable. Code in the Finish method of the page header’s parent library component 
(ssOrderOfMeritHeader) loads and generates the arrow image for the correct 
direction, using image components in the ssSmart.rol library and bitmap files saved 
in C:\Siebdev\rptsrc\enu\lib.

NOTE: If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in the 
appropriate language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.
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A thermometer is a partially filled rectangle graph in the dashboard section of a 
Smart Report. Figure 29 shows the parts of a typical thermometer. The parts are the 
trigger label, the mercury level, and the thermometer label.

A thermometer frame is derived from the ssThermometer component in the 
ssSmart.rol library by subclassing. Most of the functionality required for 
implementing a thermometer is already defined in the ssThermometer library 
component. A custom thermometer can be defined by adding an ssThermometer 
component to a frame in a report section; configuring three properties; and writing 
code to calculate four values and pass them, by way of global variables, to methods 
in the parent component. 

The three properties to configure in the thermometer component are the following:

■ Color. Color of the mercury in the thermometer. Each thermometer in a 
dashboard should use a different mercury color.

■ Thermometer Label. The text of the label that appears beneath the thermometer.

■ TriggerLabel. The text of the label that appears to the left of the trigger tick mark 
on the left side of the thermometer.

The four parameters that are passed to the ssThermometer library component are 
the following:

Figure 29. Parts of a Thermometer

Trigger
Label

Mercury

Thermometer Label
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■ DataValue. The value of the parameter being displayed. This determines the 
height of the mercury. For example, in a thermometer displaying past revenue 
for an account, the value of the past revenue of the current account would be 
displayed as a height relative to the minimum and maximum values for all 
accounts. Unlike the other three parameters, this one is calculated for the 
specific entity being reported on—in this case, one account rather than all 
accounts.

■ MinimumValue. The minimum value for this entity among all like entities 
(accounts, opportunities, and so on). Determines the value associated with the 
bottom edge of the thermometer frame. 

■ MaximumValue. The maximum value for this entity among all like entities. 
Determines the value associated with the top edge of the thermometer frame.

■ TriggerDataValue. The value that determines whether the data value for this entity 
is above, is below, or meets the target established for this kind of entity. In the 
Past Revenue example, the trigger data value establishes the height, relative to 
the maximum and minimum values, of the trigger tick mark. 

These four values are passed in the OnRow method in the thermometer component. 
They are passed, by way of global variables defined in the report design (top-level) 
object, to the corresponding method in the parent library thermometer, 
ssThermometer. The thermometer is drawn based on these four parameters and on 
the text and color properties specified in the thermometer component.

Much of the effort in configuring a thermometer lies in obtaining values for the 
minimum, maximum, and trigger from all records, and for the data value from the 
current record. The thermometer must also be positioned as a flow in the dashboard 
subpage. These configuration issues are explained in separate subsections.
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Obtaining the Minimum, Maximum, and Trigger Values
Various techniques are employed to determine the minimum, maximum, and 
trigger values for a thermometer. These values are constant through the entire 
report and all entities of the same type. For example, the minimum, maximum, and 
trigger values for the Past Revenue thermometer in the Account Summary report are 
constant for all accounts.

For many thermometers, the constant values are administered in List of Values 
Administration in a Siebel application. In the case of the Past Revenue thermometer, 
the three constants are set in the TARGET_ACCNT_LIFE_REV type. The minimum 
is set in the Target Low field, the maximum in the Target High field, and the trigger 
in the Order field. For information on configuring lists of values, see Applications 
Administration Guide. 

Settings in the List of Values table in a Siebel application are communicated to 
Actuate reports through a datastream, similarly to the passing of business 
component records by way of the data supply library file. In the case of an LOV 
datastream, the appropriate datastream is subclassed from the 
ssList_Of_ValuesQuery datastream component in the ssSmart.rol library, rather 
than from a data supply library file. 

The ssList_Of_ValuesQuery datastream component is subclassed for all LOV 
datastreams. The only differences between LOV datastreams lie in the name, the 
search specification—which is the means through which the desired LOV type is 
accessed—and the logic in the Fetch method. 

The LOV report section for the Past Revenue thermometer provides a good example. 
The structure of this report section is illustrated in Figure 30.

Figure 30. Structure of an LOV Data Loading Report Section
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This report section consists of the following components:

■ Report section. The LOV data loading report section—rptPastRevenuListOfValues 
in this case—serves no purpose other than to contain the LOV datastream. One 
such report section is provided for each LOV datastream to be defined. There 
will be one LOV datastream for each set of minimum, maximum, and target 
values to be obtained from an LOV record, generally one set of values per 
thermometer.

■ Datastream. The LOV datastream—qryPastRevenuListOfValues in this case—is 
subclassed from the ssList_Of_ValuesQuery component in the ssSmart.rol 
library. The datastream is configured in the SearchSpec property and in the code 
in the Fetch method.

■ SearchSpec property. The text in this property specifies how to obtain the LOV 
record that provides the set of constants. This is based on the Type field in 
the LOV record. In the case of the Past Revenue thermometer, the search 
specification expression in the data loading datastream is the following:

[Type] = 'TARGET_ACCNT_LIFE_REV'

■ Fetch method. The code in the Fetch method specifies which fields provide the 
maximum, minimum, and target values in the LOV record and perform any 
necessary computations and conversions. The values obtained are passed to 
the global variables in the report design object that have been defined for the 
set of constants for one thermometer. For the Past Revenue thermometer, the 
Fetch method includes the following lines of code:

PastRevenueAverage = Val( aRow.ssOrder_By )

PastRevenueHigh = Val( aRow.ssTarget_High )

PastRevenueLow = Val( aRow.ssTarget_Low )

■ Data row. The data row component is always ssList_Of_ValuesDataRow. It is 
included in the datastream component when the datastream component is 
created in the report design by subclassing. The data row contains the set of 
input variables corresponding to the record structure of the LOV table in the 
Siebel application. 
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Obtaining the Data Value
The Past Revenue thermometer example (in the Acsum.rod [Account Summary] 
report) uses a total of past revenue for opportunities for the current account as its 
data value. The components and logic for deriving this data value are described 
here.

The components for deriving the data value occur in two areas in the report 
structure:

■ An array of opportunity records is loaded in one of the data loading report 
sections for later access.

■ A dashboard report section totals the relevant opportunity records and passes 
the total in the DataValue parameter to the thermometer component.

The components for loading the opportunity record array are in the 
rptCollectOpportunitiesAndThreats report section, near the beginning of secMain, 
as shown in Figure 31.

This report section loads two global arrays (attached as variables to the top-level 
report design object), PastOpportunityArray and PipelineOpportunityArray. These 
both hold opportunity records for the current account, but meet different criteria. 
The former of these is used later in the report logic to derive the data value for the 
thermometer of interest (the latter is used for another thermometer, 
thermoPipeline).

Figure 31. Components for Loading the Opportunity Array
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The datastream that supplies this report section, ssOpportunityQuery_1, is a 
subreport datastream in the data supply library file for the report.

The processing logic for the report section is in the Start and Fetch methods for the 
filter component, ftrCollectOpportunities. The Start method empties the two arrays. 
The Fetch method sorts records from the opportunity datastream that match 
specified criteria into the two arrays. Records for PastOpportunityArray are those 
that have a Rep% (percentage) of 100; those for PipelineOpportunityArray have a 
Rep% lower than 100 and a close date later than the date the report is run.

The components and logic for determining the past revenue for the current account, 
based on the opportunity records stored in memory, are in the 
rptPastRevenueThermometer report section in the dashboard parallel section 
(parDashboard). This report section and its child components are illustrated in 
Figure 32.

Figure 32. Thermometer Report Section Components
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The components in Figure 32 on page 278 are as follows:

■ Report section. The thermometer report section, rptPastRevenueThermometer, 
contains datastream and data row components for extracting a past revenue total 
for the account from opportunity records in memory. It also contains a container 
frame, frmPastRevenue, that holds the thermometer component, 
thermoPastRevenue. The thermometer component generates the thermometer 
based on the values passed to it in property settings and parameter variables.

■ Data row. The data row component, rowPastRevenueThermometer, holds one 
variable: PastRevenue. A single row containing this value is all that the data row 
and datastream need to generate for the thermometer. 

■ Datastream. The Start and Fetch methods in the datastream component process 
the opportunity records in the PastOpportunityArray memory structure. An 
iterator, PastRevenueIterator, is set up for this array, and the 
ssFunctionalRevenue value in each opportunity record is accumulated in the 
PastRevenue variable. It is the value of this variable that the datastream provides 
to the thermometer as the DataValue parameter.

■ Content Frame. The frmPastRevenue frame is a standard content frame, allowing 
the thermometer component to be included in the report structure. It serves no 
other purpose.

■ Thermometer. The thermoPastRevenue component is a thermometer, derived 
from the ssThermometer library component in the ssSmart.rol library. The Color, 
Label, and TriggerLabel properties are set in thermoPastRevenue to configure 
these features of the thermometer. The OnRow method (in code located both in 
thermoPastRevenue and in its parent, ssThermometer) retrieves the one row 
generated by the datastream and passes the PastRevenue value as the method’s 
input parameter, DataValue. The other input parameters, MinimumValue, 
MaximumValue, and TriggerDataValue, are obtained from previous logic, as 
described in “Obtaining the Minimum, Maximum, and Trigger Values” on 
page 275.

An additional role of the OnRow method is to compare DataValue with 
TriggerDataValue in order to obtain a TRUE or FALSE value for 
PastRevenueThermometerAboveTarget. This Boolean variable and 
corresponding ones for the other thermometers are collectively used to 
determine the direction of the order-of-merit indicator arrow at the top of the 
account’s page.
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Positioning a Thermometer on the Dashboard Subpage
A page is a component that specifies the visual design of a page in the report. A 
page component primarily consists of flows, which determine the printable area of 
the page and may also contain graphics, labels, and various controls. When you run 
a report, Actuate builds frames to display the data. As each frame is created, Actuate 
places it in the flow on the current page, starting from the top of the flow and 
aligning each frame with the left edge of the flow. If a frame is too long to fit in the 
current flow, Actuate places it at the top of the next flow, which may be on the same 
page or another page. The main page layout for a Siebel report is specified in the 
PageStyle child component of the PageList component. 

Every section in a report design can optionally have an associated subpage. A 
subpage is just like a page, except that it fits into a flow on the active page. The 
active page is the page in the report currently being generated when the subpage 
starts. Like a page, a subpage contains one or more flows and can contain frames 
and controls.

You usually use a subpage when you want to change the page style for the contents 
of a section in the middle of a page. In the case of Smart Reports, a subpage is used 
to position thermometers, graphics, and report text within the dashboard. In a 
parallel section such as the one used to implement the dashboard, each flow in the 
subpage corresponds to one of the report sections in the parallel section. This 
correspondence is implemented by entering the name of the flow in the FlowName 
property of each report section component in the parallel section. Normally this 
property is not used except to pair up report sections and subpage flows in a parallel 
section.
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Figure 33 illustrates the report sections and subpage flows in the dashboard parallel 
section in the Account Summary report.

 

Figure 33. Dashboard Parallel Section Structure
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The standard subpage and flow components are used, rather than specialized 
ssSmart.rol components. A subpage component is dragged from the Pages toolbar 
to the section to which it will be added. You then manually resize it by dragging the 
sizing handles. A flow is dragged from the Pages toolbar onto the subpage area and 
then resized and positioned. The size of the flow should be sufficient to hold the 
thermometer, the graph, the report text, or whatever is to be included, and any 
associated labels. Also, the flows should not overlap, although the text report flow 
in standard Smart Reports is often the size of the entire subpage for optimal use of 
space.

Passing Siebel-Generated Graphics to a Smart Report
Some specialized graphics in Smart Reports are too complex to be defined using 
AFC and sscustom graph classes. These must be generated in the Siebel application 
and transferred to the Actuate report as bitmaps by way of OLE automation (or 
similar application-to-application object communication). Some examples of passed 
graphics in Smart Reports are the three charts in the Account Service Detail Report: 
Severity Distribution, Service Request Substatus, and Aging By Severity.

Because creation and modification of specialized classes in Siebel Tools are not 
supported, Siebel Systems does not support creation and modification of passed 
graphics in Smart Reports by customers. If you have a requirement of this kind, 
contact Siebel Technical Services.
282 Siebel Reports Administration Guide Version 7.5, Rev B



Smart Reports

Designing a Smart Report
Designing a Smart Report
This section will explain how the Smart Reports are designed beginning with the 
Smart Report - Opportunity Detail report.

Opportunity Detail Report
The Opportunity Detail report presents each opportunity with graphical information 
including order-of-merit indicator, Competitive Activity, Deal Size Thermometer, 
Buying Influencers Thermometer, Probability Thermometer, Sales Stage Slider, 
Contacts/Influence Map, and other details in the dashboard section and detail 
sections on contacts, products, competitors, activities, and notes. First a functional 
description of the components in this report is provided, followed by the report 
design in Actuate e.Report Designer Professional.

Functional Detail
The functional detail includes a high-level description of all the components of the 
Opportunity Detail report. This section also describes the properties of the 
specialized graphical components.

Graphical Components
Order-of-merit indicator. The order-of-merit indicator indicates the overall measure for 
the opportunity and is calculated based on the following logic:

All three Thermometers above target = Up

Two of the Three Thermometers above target = Right

Otherwise = Down

Sales stage slider. This indicates how close the opportunity is in terms of closing the 
deal.

Deal size thermometer. This thermometer displays the deal size of the opportunity 
relative to the average across all opportunities. The minimum value is taken as zero, 
the trigger value is calculated to be the average across all opportunities, and the 
maximum is twice the trigger value.
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Competitive activity. The competitive activity depicts the top four competitors in 
descending order; the value indicates the relative threat, which is determined by the 
sales representative or the status of each competitor. The value displayed in the 
graph is obtained from the List of Values table under type = 
‘TARGET_COMP_THREAT’ and Value = Threat.

Buying influencers thermometer. The Buying Influencers thermometer depicts the 
buying influence based on the weighted average of the contacts involved with the 
opportunity (TASOrgStatusArray, ContactRoleArray, and TASPolitical 
AnalysisArray).

Probability thermometer. This thermometer shows an amount between 0 and 100, the 
percentage probability of converting the opportunity into an order.

Contacts influence map. The map shows the contacts associated with the 
opportunity, highlighting the decision makers.

Other Components
Page header. The page header includes a snapshot of the opportunity and shows the 
name of the opportunity, the revenue, the probability, and the order-of-merit 
indicator.

Dashboard. In this section, the graphical and textual information for the opportunity 
is displayed. The thermometers described earlier are all in the dashboard, along 
with opportunity summary text.

Contact detail. This is one of the detail sections (or a subreport section) of the 
opportunity master section. The details of the contacts associated with this 
opportunity are shown in the form of a list report.

Products. The product offerings relevant to the opportunity are listed in this detail 
section.

Competitors. This section lists all the competitors for this opportunity.

Decision issues. In this section, the decision issues for the opportunity are listed in 
order of priority.

All activities. This section lists all the activities undertaken for this opportunity.

Notes. This section shows the email messages, correspondence, and proposals sent 
for this opportunity.
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Technical Detail
The Opportunity Strategy Detail Report consists of two report sections. The first is 
the data collection section and the second is the main section, as shown in 
Figure 34.

The purpose of the data collection section is to obtain and manipulate data for the 
current master record (which is a record from the Opportunity business 
component). Specifically, the data from the List_of_Values of Opportunity object is 
obtained in the Fetch method for determining the values for the Buying Influencers 
thermometer.

Data Collection Section
List of Values data collection is required for weighting factors used in the Buying 
Influencers thermometer. Three types of weighting factors, CONTACT_ROLE, 
TAS_POLITICAL_ANALYSIS, and TAS_ORG_STATUS, are stored in separate static 
arrays defined in the OpportunityDetail component. Also, minimum and maximum 
weighting factors are stored in separate static variables for each of the three types. 

Data rows are collected by a component subclassed from the ssList_Of_ValuesQuery 
class defined in ssSmart.rol. The SearchSpec property is set to [Type] = 
'CONTACT_ROLE' or [Type] = 'TAS_POLITICAL_ANALYSIS' or [Type] = 
'TAS_ORG_STATUS'; DefaultWeightingFactor is a local property set to 1; 
NeutralTAS_ORG_STATUS is a local property set to Neutral. The Fetch method of 
ssList_Of_ValuesQuery3 decodes the type of weighting factor and populates the 
variables described above.

Figure 34. Opportunity Strategy Report Main Section
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The data collection section can be created using the following procedure. The 
contents of this section appear in Actuate e.Report Designer Professional, as shown 
in Figure 35 and explained in the procedure.

To create a data collection section

1 Drag and drop a reference to the ssRpt class from the sscustom.rol into the 
Content slot of ssSeq1.

2 Right-click the reference and subclass it following the instructions in “To create 
a report design file in Actuate e.Report Designer Professional” on page 141.

3 Right-click again and choose Rename from the menu. Then type 
rptDataCollection in the box.

4 Drag and drop the Query button from the main toolbar into the DataStream 
component of the report section. 

5 Click the library button in the menu bar and then double-click ssSmart.rol 
library. 

Figure 35. Data Collection Section
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6 Drag and drop a reference to the ssList_Of_ValuesQuery class from the 
ssSmart.rol library into the DataStream slot of rptDataCollection. 

7 Subclass this component and rename it ssList_Of_ValuesQuery3.

8 Open the Component Editor window for ssList_Of_ValuesQuery3 by double-
clicking.

9 Click the Variables tab and add two new properties: DefaultWeightingFactor 
(type=Integer) and NeutralTAS_ORG_STATUS (type=String).

10 Under the Properties tab set the DefaultWeightingFactor property to 1, set the 
NeutralTAS_ORG_STATUS property to Neutral, and set the SearchSpec to [Type] 
='CONTACT_ROLE' or [Type] = 'TAS_POLITICAL_ANALYSIS' or [Type] = 
'TAS_ORG_STATUS’. The resulting Component Editor Properties tab window is 
illustrated in the following figure.

11 Click the Methods tab (shown in the figure following Step 10), choose the Fetch 
method and click Override. Include the following Actuate VB script in the Fetch 
method. This correctly changes the Fetch method from a Sub to a Function.

Function Fetch( ) As AcDataRow

Dim aRow As ssList_Of_ValuesDataRow

Set aRow = Super::Fetch( )

Do While Not aRow Is Nothing

If Trim$(aRow.ssWeighting_Factor) = "" Then 
aRow.ssWeighting_Factor = Str$(DefaultWeightingFactor)

If aRow.ssType = "CONTACT_ROLE" Then 
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ContactRoleArraySize = ContactRoleArraySize + 1

If MaxContactRole < Val( aRow.ssWeighting_Factor ) 
Then MaxContactRole = Val( aRow.ssWeighting_Factor )

If MinContactRole > Val(aRow.ssWeighting_Factor) Then 
MinContactRole = Val(aRow.ssWeighting_Factor)

ContactRoleArray( 2, ContactRoleArraySize ) = 
aRow.ssWeighting_Factor

ContactRoleArray( 1, ContactRoleArraySize ) = 
aRow.ssName

ElseIf aRow.ssType = "TAS_POLITICAL_ANALYSIS" Then

TASPoliticalAnalysisArraySize = 
TASPoliticalAnalysisArraySize + 1

If MaxTASPoliticalAnalysis < Val( 
aRow.ssWeighting_Factor Then MaxTASPoliticalAnalysis = 
Val(aRow.ssWeighting_Factor)

If MinTASPoliticalAnalysis > 
Val(aRow.ssWeighting_Factor) Then MinTASPoliticalAnalysis = 
Val(aRow.ssWeighting_Factor)

TASPoliticalAnalysisArray( 2, 
TASPoliticalAnalysisArraySize = aRow.ssWeighting_Factor

TASPoliticalAnalysisArray( 1, 
TASPoliticalAnalysisArraySize = aRow.ssName

ElseIf aRow.ssType = "TAS_ORG_STATUS" Then

TASOrgStatusArraySize = TASOrgStatusArraySize + 1

If MaxTASOrgStatus < Val( aRow.ssWeighting_Factor ) 
Then MaxTASOrgStatus = Val( aRow.ssWeighting_Factor )

If MinTASOrgStatus > Val(aRow.ssWeighting_Factor) 
Then MinTASOrgStatus = Val(aRow.ssWeighting_Factor)

If aRow.ssName = NeutralTAS_ORG_STATUS Then 
NeutralWeightingFactor = Val(aRow.ssWeighting_Factor)

TASOrgStatusArray( 2, TASOrgStatusArraySize ) = 
aRow.ssWeighting_Factor
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TASOrgStatusArray( 1, TASOrgStatusArraySize ) = 
aRow.ssName

Else

ssDisplayMessage("Invalid LOV Type" & aRow.ssType )

End If

Set aRow = Super::Fetch( )

Loop

Set Fetch = Nothing

End Function

This method requires variables to be defined in the OpportunityDetail report 
component (the topmost component) as shown in Table 9.

Table 9. OpportunityDetail Report Components 

Variable Name Type Storage Visibility Comment

ContactRoleArray(2,10) String Static Public Stores contact roles and weighting factors

ContactRoleArraySize Integer Static Public Used in array integration loops

TASOrgStatusArray(2,10) String Static Public Stores organization status identifiers and 
weighing factors

TASOrgStatusArraySize Integer Static Public Used in array integration loops

TASPoliticalAnalysisArray (2.10) String Static Public Stores political analysis identifiers and 
weighing factors

TASPoliticalAnalysisSize Integer Static Public Used in array integration loops

MaxContactRole Integer Static Public Maximum weighting factor

MinContactRole Integer Static Public Minimum weighting factor

MaxTASOrgStatus Integer Static Public Maximum weighting factor

MinTASOrgStatus Integer Static Public Minimum weighting factor

MaxTASPoliticalAnalysis Integer Static Public Maximum weighting factor

MinTASPolitical Analysis Integer Static Public Minimum weighting factor
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Main Report Section
The Main Report section provides the structure for gathering and displaying all the 
data for each opportunity available from the Opportunity business component. 
Making the Opportunity data row available to detail sections (or subreports) 
requires static data row storage. OpportunityRow is a static variable of type 
ssOpportunityDataRow, defined in the OpportunityDetail component. The OnRow 
method of the rptMain report section assigns this variable equal to the current row 
from the ssOpportunityQuery as shown below.

Sub OnRow( row As AcDataRow )
Super::OnRow( row )
Set OpportunityRow = row

End Sub
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The Main Report section contains components in the DataSource, PageHeader, and 
Content slots, as shown in Figure 36.

■ The DataStream section obtains data from the main business component, 
Opportunity, for this report.

Figure 36. Main Report Section
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■ PageHeader contains the information displayed in the header section of the 
report: the name of the opportunity, the revenue, the probability, and the order-
of-merit indicator.

■ The Main Content section consists of the components (data collection sections, 
dashboard parallel section, and detail sections).

■ The Data Collection section consists of the Competitive Activity and Contacts 
sections. (The Data Collection sections are needed because this data is 
required in multiple report sections for each opportunity, but it is only 
possible to query the linked subreport business components once for each 
opportunity.)

■ The Dashboard parallel section contains sales stage slider graphics, a Main 
Dashboard section, a Competitive Activity section, a Deal Size thermometer, 
a Buying Influencers thermometer, and a Probability thermometer.

■ The Detail section consists of subsections on the contacts influence map, 
contact detail, products, competitors, decision issues, activities, and notes.

Creating the Sequential Report Section
Create the main report section by subclassing from ssRpt into the content slot of 
ssSeq1. Rename this Report Section to rptMain. The rptMain section appears in 
Actuate e.Report Designer Professional as shown in Figure 37.

Figure 37. rptMain Section 
292 Siebel Reports Administration Guide Version 7.5, Rev B



Smart Reports

Designing a Smart Report
Defining the DataStream Section
Click the library button and double-click opdet.rol to open the library. Drag and 
drop ssOpportunityQuery into the DataStream section under rptMain. It is not 
necessary to subclass.

Defining the Page Header Section
The PageHeader frame provides the Order Of Merit graphic display because it is 
subclassed from the ssOrderOfMeritHeader class defined in ssSmart.rol library. The 
direction of the order-of-merit indicator is determined by assigning the 
ArrowDirection class variable in the Finish method before calling the superclass 
Finish method. In this method, the arrow direction is determined by the variable 
NumberOfThermometersAboveTarget, which is a static integer variable defined in 
the OpportunityDetail component. 

If all three thermometers display data values higher than their trigger values, the up 
arrow is displayed. If only two of the thermometer data values exceed their trigger 
values, the right arrow is displayed. If one or none of the thermometer data values 
exceeds its trigger value, the down arrow is displayed.

To create a Page Header section

1 Click the library button and double-click ssSmart.rol to open the library. Drag 
and drop the ssOrderOfMeritHeader frame into the Page Header section under 
rptMain. Subclass this frame and rename it ssOrderOfMeritHeader1.

2 Override the Finish method as follows:

Sub Finish( )

If NumberOfThermometersAboveTarget = 3 Then

ArrowDirection = "UP"

ElseIf NumberOfThermometersAboveTarget < 2 Then

ArrowDirection = "DOWN"

Else

ArrowDirection = "PUSH"

End If

Super::Finish( )

End Sub
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3 Define the NumberOfThermometersAboveTarget variable (Type=Integer, 
Storage=Static) in the OpportunityDetail component.

4 Create the contents of the Page Header section by dragging and dropping the 
appropriate text control and label controls. First click the library button and 
double-click sscustom.rol to open the library.

5 Drag and drop the ssTxt text control from this Library Browser into the 
ssOrderOfMeritHeader1 frame. Rename the ssTxt control ssTxtSectionHead1. 
Then highlight ssTxtSectionHead1, right-click, and choose Properties from the 
menu. Select the value in ValueExp to be the [ssName] variable as reflected in 
the following figure.

6 Repeat Step 5 two more times and rename the ssTxt control ssTxtSectionHead2 
and ssTxtSectionHead3, respectively. Select the ValueExp in these text controls 
to be [ssRevenue_Formatted] and [ssRep__] & “%”, respectively.
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7 Drag and drop the ssLblBlueBlack label control from the sscustom.rol Library 
Browser into the ssOrderOfMeritHeader1 frame. Rename the label control 
ssLblSectionHead1. Then select this label, right-click and choose Properties from 
the menu. In the Properties tab, enter Revenue: in the field against Text as 
shown in the following figure.

8 Repeat Step 7 and rename the label ssLblSectionHead2. Enter Probability: in 
the field against Text Property.

Defining Content Main Section
Subclass from ssSeq to create secMain in the Content slot of rptMain.

rptCollectCompetitiveActivity
The rptCompetitiveActivity and rptCompetitors sections require Competitor data 
collection. The results of ssCompetitorQuery_3 query in Opdet.rol are stored in 
CompetitorDataList, a static variable defined in the OpportunityDetail component. 

CompetitorIndexArray, an array of list position numbers, is maintained to facilitate 
retrieval of the four competitors with the highest threat value. The array is defined 
in the OpportunityDetail component. 

The sifCompetitiveActivity component is subclasssed from the ssSingleInputFilter 
class in sscustom. The Start method of the sifCompetitiveActivity filter initializes 
the array values to zero for each opportunity. The Start method of the 
rptCollectCompetitiveActivity report section initializes the list for each opportunity. 
The Fetch method of the filter populates the list and the array.
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To create a rptCollectCompetitiveActivity section

1 Place, subclass, and rename the components for the 
rptCollectCompetitiveActivity section.

2 Define the CompetitorDataList variable (Type=AcList, Storage=Static) in the 
OpportunityDetail component.

3 Override the Start method in sifCompetitiveActivity to initialize the 
CompetitorIndexArray for each opportunity.

Function Start( ) As Boolean

Dim i As Integer

Start = Super::Start( )

For i = 0 To 3

CompetitorIndexArray(i) = 0

Next

End Function

4 Override the Fetch method in sifCompetitiveActivity to obtain the top four 
competitors and the associated threat values as entered by the sales 
representative and to build the CompetitorDataList.

Function Fetch( ) As AcDataRow

Dim aRow As ssCompetitorDataRow

Dim bRow As ssCompetitorDataRow

Dim i As Integer

Dim j As Integer

Set aRow = New ssCompetitorDataRow

Set aRow = InputAdapter.Fetch()

If Not aRow Is Nothing Then

CompetitorDataList.AddToTail(aRow)

For i = 0 To 3
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If CompetitorIndexArray(i) > 0 Then

Set bRow = 
CompetitorDataList.GetAt(CompetitorIndexArray(i))

If Val(aRow.ssThreat_Value) >= 
Val(bRow.ssThreat_Value) Then

For j = 3 T o i Step - 1

CompetitorIndexArray(j + 1) = 
CompetitorIndexArray(j)

Next

CompetitorIndexArray(i) = 
CompetitorDataList.GetCount()

Exit For

End If

Else

CompetitorIndexArray(i) = 
CompetitorDataList.GetCount()

Exit For

End If

Next

Set Fetch = aRow

End If

End Function

rptCollectContacts
The rptBuyingInfluencersThermometer, rptContactsInfluenceMap and 
rptContactDetail sections require Contact data collection. The results of 
ssContactQuery_1 query defined in Opdet.rol, are stored in the ContactDataList, a 
static variable defined in the OpportunityDetail component.
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To create a rptCollectContacts section

1 Place, subclass, and rename the components for the rptCollectContacts section.

2 Define the ContactDataList variable (Type=AcList, Storage=Static) in the 
OpportunityDetail component.

3 Include code under the Fetch method in ftrContacts to obtain the contacts list.

Function Fetch( ) As AcDataRow

Dim aRow As ssContactDataRow

Do

Set aRow = InputAdapter.Fetch()

If aRow Is Nothing Then Exit Function

ContactDataList.AddToTail(aRow)

Loop

End Function

parDashBoard
See the general Smart Reports documentation for a general description of 
DashBoard parallel sections (“Report Structure and Major Components” on 
page 267).

To create a parDashBoard section

1 Subclass from ssParallelSection to create parDashBoard in the Content slot of 
secMain.

2 Set up subDashBoard in the SubPage slot. 

Defining the Subpage Layout. 
In the subpage layout, set up a flow for each of the report sections described in the 
sections that follow.
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rptSalesStageSlider. The frmStageSlider component simulates a horizontal bar graph 
by dynamically instantiating a dark-background control and sizing it based on the 
value of the Sales Stage Win Percent field for the current opportunity. Other 
elements of the graphic, such as ticks and label, are placed in the 
frmStageSliderHolder frame.

rptMainDashboard. The MainDashboard report section displays details for this 
opportunity and a general functional description of this report.

rptDealSizeThermometer. The DealSizeThermometer component is a subclass of the 
ssThermometer defined in ssSmart.rol. The four thermometer control variables, 
TriggerDataValue, DataValue, MinimumValue, and MaximumValue, are set in the 
OnRow method. TriggerDataValue is set from the Order By LOV field, 
MaximumValue is set from the Target High LOV field, and MinimumValue is set 
from the Target Low LOV field. DataValue is set from the Functional Revenue field 
of OpportunityRow, which was stored earlier. The OnRow method also adjusts the 
NumberOfThermometersAboveTarget variable to have the appropriate effect on the 
OrderOfMerit image.

rptCompetitiveActivity. The Competitive Activity chart is a standard Actuate 
horizontal-bar-chart summary graph. The data rows that feed the graph are pulled 
from the CompetitorDataList using the list row numbers saved in 
CompetitorIndexArray. The list and the array were saved earlier in the 
rptCollectCompetitiveActivity report section. The number of rows fed to the graph 
is limited to a maximum of four, and they are ordered so that the most threatening 
competitor is shown at the top.

rptBuyingInfluencersThermometer. The BuyingInfluencersThermometer graphic 
display is driven by scores calculated from values stored in arrays by the 
rptDataCollection section.

The ssContactQuery_2 data source component iterates through the 
ContactDataList, feeding the data rows to the ftrCalculateWeightedScore single 
input filter. The Fetch method for ssContactQuery_2 follows.

Function Fetch( ) As AcDataRow

Dim aRow As ssContactDataRow

If Position <= ContactDataList.GetCount() Then

Set aRow = ContactDataList.GetAt(Position)
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Set Fetch = aRow

AddRow(Fetch)

End If

End Function

The Fetch method of the ftrCalculateWeightedScore single input filter calculates a 
score for an opportunity by averaging the scores for each contact associated with 
that opportunity. The score for each contact is the product of three weighting factors 
collected earlier and stored in static arrays.

The first weighting factor is retrieved from the TASOrgStatusArray by matching the 
‘Org Status’ field with a TAS_ORG_STATUS type LOV value stored in the array. The 
second weighting factor is retrieved from the ContactRoleArray by matching the 
‘Role’ field with a CONTACT_ROLE type LOV value stored in the array. The third 
weighting factor is retrieved from the TASPoliticalAnalysisArray by matching the 
‘Political Analysis’ field with a TAS_POLITICAL_ANALYSIS type LOV value stored 
in the array. The script for ftrCalculateWeightedScore follows.

Function Fetch( ) As AcDataRow

Dim aRow As ssContactDataRow

Dim finalRow As OpportunityDetail::rowBuyingInfluencers

Dim i As Integer

Dim score As Integer

Dim totalScore As Integer

Dim numberOfContacts As Integer

Set aRow = Super::Fetch( )

If aRow Is Nothing AND Position > 1 Then Exit Function

Do While Not aRow Is Nothing

If Not Trim$(aRow.ssOrg_Status) = "" Then

For i = 1 to TASOrgStatusArraySize

If aRow.ssOrg_Status = TASOrgStatusArray( 1, i ) Then
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score = Val( TASOrgStatusArray( 2, i ) )

Exit For

End If

Next

For i = 1 to ContactRoleArraySize

If aRow.ssRole = ContactRoleArray( 1, i ) Then score =

score * Val( ContactRoleArray( 2, i ) )

Exit For

End If

Next

For i = 1 To TASPoliticalAnalysisArraySize

If aRow.ssPolitical_Analysis =

TASPoliticalAnalysisArray1, i ) Thenscore = score *

Val( TASPoliticalAnalysisArray( 2, i ) )

Exit For

End If

Next

totalScore = totalScore + score

numberOfContacts = numberOfContacts + 1

End If

Set aRow = Super::Fetch( )

Loop

Set finalRow = New OpportunityDetail::rowBuyingInfluencers

If numberOfContacts = 0 Then

finalRow.Score = 0
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Else

finalRow.Score = totalScore / numberOfContacts

End If

Set Fetch = finalRow

AddRow( Fetch )

End Function

rptProbabilityThermometer. The ProbabilityThermometer component is a subclass of 
ssThermometer, defined in ssSmart.rol. As usual, the four thermometer control 
variables, TriggerDataValue, DataValue, MinimumValue, and MaximumValue, are 
set in the OnRow method.

TriggerDataValue is set from the Order By LOV field, MaximumValue is set from the 
Target High LOV field, and MinimumValue is set from the Target Low LOV field. 
DataValue is set from the Rep% field for the opportunity. The OnRow method also 
adjusts the NumberOfThermometersAboveTarget variable so it will have the 
appropriate effect on the OrderOfMerit image. The script for the OnRow method 
follows.

Sub OnRow( row As AcDataRow )

Dim aRow As ssList_Of_ValuesDataRow

Super::OnRow( row )

Set aRow = row

DataValue = Val( OpportunityRow.ssRep__ )

TriggerDataValue = Val( aRow.ssOrder_By )

MaximumValue = Val( aRow.ssTarget_High )

MinimumValue = Val( aRow.ssTarget_Low )

If DataValue > TriggerDataValue Then

NumberOfThermometersAboveTarget = 
NumberOfThermometersAboveTarget + 1

End If

End Sub
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rptContactDetail. Instructions on creating the rptContactDetail section follow.

To create a rptContactDetail section

1 Define the rptContactDetail report section, add a Query DataStream, and rename 
it dsTransferContactList. 

a In Properties, make DataRow ssContactDataRow. 

b Add a Before section by dragging and dropping a frame from the main toolbar 
into the rptContactDetail section. 

Similarly, define the PageHeader and Content sections. 

The Before section includes the labels in the header for the Contacts child 
section. 

c Drag and drop the ssLblSectionHead control from sscustom.rol into the 
frmContactsHeadings1 frame to create the headings for the Contacts child 
section. 

These include lblName, lblJobTitle, lblAccount, lblSite, lblWorkPhone, 
lblWorkFax, and lblRole, and correspond to the titles Name, Job Title, 
Account, Site, Work Phone, Work Fax, and Role.

2 In the PageHeader section (frmContactsContinuedHeader frame), drag and drop 
the ssLabelSectionHeadContinued control from sscustom.rol to create 
lblContacts and lblContinued titles. 

Also, drag and drop ssLineControlP from sscustom.rol and rename it 
LineControlP2.

3 In the content frame (frmMainContactData), drag and drop lblBlueBlack control 
from sscustom.rol to create the contents lblName, lblJobTitle, lblAccount, 
lblSite, lblWorkPhone, lblWorkFax, and lblRole, which correspond to the 
contents Name, Job Title, Account, Site, Work Phone, Work Fax, and Role, 
respectively. 

These appear as list columns under the child report section Contacts and get 
values from ssFull_Name, ssJob_Title, ssssAccount, ssAccount_Location, 
ssWork_Phone_, ssFax_Phone__, and ssRole, respectively, by setting the 
ValueExp property.
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rptProducts. Instructions on creating the rptProducts section follow.

To create a rptProducts section

1 Define the rptProducts report section and drag and drop the 
ssOpportunity_ProductQuery2 data source from the opdet.rol library.

2 Drag and drop a frame into the Page Header section and rename it 
frmHeaderAndTitleforProducts, and include the necessary control as part of the 
Page Header for the Products child report. This includes the headings Product, 
Expected Delivery Date, Quantity, and Comment.

3 Include the Contents section to appear as list columns under the child report 
section Products and get values from ssVendor, ssStatus, and ssComment by 
setting the ValueExp property.

rptCompetitors section. Instructions on creating the rptCompetitors section follow.

To create a rptCompetitors section

1 Define the rptCompetitors report section and drag and drop the 
ssCompetitorQuery_3 data source from the opdet.rol library.

2 Drag and drop a frame into the PageHeader section and rename it 
frmHeaderAndTitleforCompetitors1. Include the necessary control as part of the 
Page Header for the Competitors child report section.

3 Include the Contents section to appear as list columns under the child report 
section Competitors and get values from ssProduct, ssExpectedDeliveryDate, 
ssQuantity, and ssComment from ValueExp. Status, and ssComment by setting 
the ValueExp property.

rptDecisionIssues section. Instructions on creating the rptDecisionIssues section 
follow.

To create a rptDecisionIssues section

1 Define the rptDecisionIssues report section and drag and drop the 
ssDecision_IssueQuery_4 data source from the opdet.rol library.

2 Drag and drop a frame into the PageHeader section and rename it 
frmHeaderAndTitleforDecisionIssues, and include the necessary control as part 
of the Page Header for the DecisionIssues child report section.
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3 Include the Contents section to appear as list columns under the child report 
section Decision Issues and get values from ssName, ssComment, and the 
ssRank product by setting the ValueExp property.

rptAllActivities section. Instructions on creating the rptAllActivities follow.

To create a rptAllActivities section

1 Define the rptAllActivities report section and drag and drop the ssActionQuery_5 
data source from the opdet.rol library.

2 Drag and drop a frame into the PageHeader section and rename it 
frmHeaderAndTitleforAllActivities1. Include the necessary control as part of the 
Page Header for the All Activities child report section.

3 Include the Contents section to appear as list columns under the child report 
section All Activities and get values from ssFull_Name, ssStart_Date-Formatted, 
ssType, ssDescription, and ssStatus. Drag and drop the Red Dot control from 
ssSmart.rol and include the OnRow method to indicate incomplete activities in 
red.

rptNotes section. Instructions on creating the rptNotes section follow.

To create a rptNotes section

1 Define the rptNotes report section and drag and drop the 
ssOpportunity_NoteQuery_6 data source from the opdet.rol library.

2 Drag and drop a frame into the PageHeader section and rename it 
frmHeaderAndTitleforNotes1. Include the necessary control as part of the page 
header for the DecisionIssues child report section.

3 Include the Contents section to appear as list columns under the child report 
section Notes and get values from ssNote, ssCreated_By_Name, and 
ssCreated_Formatted by setting the ValueExp property.
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Account Service Detail Report
The report summarizes all the service-related information pertaining to the account. 
It contains information about currently open service requests, customer 
satisfaction, and the historical service request resolution for the account. 

Here, the specialized graphical components and the related sections (including the 
data collection section) in Account Service Detail report are described. Except for 
specialized graphical elements and the related data collection sections, the contents 
of all Smart Reports are very similar and therefore are not described in remaining 
reports.

Order Of Merit
The Order Of Merit graphic is determined in the Finish method of the 
ssOrderOfMeritHeader1 frame according to the following logic. Add values 
according to Table 10.

If the result is greater than 4, then the arrow direction is up. If the result is 3 or 4, 
then the arrow direction is facing right (push). Otherwise, the arrow direction is 
down.

Data Collection And Calculation
All service requests for an Account are collected and stored in memory lists in the 
rptAllServiceRequests report section. Open Service Requests are stored in a separate 
list for use in the ensuing detail sections. Closure times for closed service requests 
are divided up into an array of lists that will be used in the 
rptClosureTimesBySeverity section to feed the line graphs, traffic lights, and 
calculated summary data. 

Table 10. Thermometer Variables for Order of Merit Graphic

Thermometer Variable Value If Above Target (Trigger)

Customer Satisfaction 3

Open Service Request 2

Revenue 1
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As the arrays are populated, totals and counts are maintained to facilitate 
calculation of averages and standard deviations. High and low closure times are also 
stored for each severity, as determined by the Status field of the Service Request 
data row.

Dashboard
The thermometers in this dashboard function are like other Smart Report 
thermometers. They are, however, different in that they reside as frames within a 
single frame instead of in separate flows belonging to a subpage in a parallel 
section. The Start method of each thermometer sets the data, trigger, maximum, 
and minimum variables from report-level variables calculated or collected earlier in 
the report. 

Revenue Thermometer
Table 11 reflects the variables for use with the Revenue Thermometer.

Table 11. Variables for the Revenue Thermometer

Thermometer Report-level Variable Calculation Point Comment

MaximumValue revenueHigh dsRevenueLOV Collected once per report.

MinimumValue revenueLow dsRevenueLOV Collected once per report.

TriggerDataValue revenueAverage dsRevenueLOV Collected once per report.

DataValue totalRevenue sifAllOpportunities The sum of the revenues 
for all opportunities 
associated with this 
account.
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Open Service Request Thermometer
Table 12 reflects the variables for use with the Open Service Request Thermometer.

Customer Satisfaction Thermometer
Table 13 reflects the variables for use with the Customer Satisfaction Thermometer.

Table 12. Variables for the Open Service Request Thermometer

Thermometer Variable
Report-Level 
Variable Calculation Point Comment

MaximumValue NA Local TriggerDataValue * 
1.5.

MinimumValue NA Local Fixed at zero.

TriggerDataValue avgOpenSRs dsTargetOpenSRsLOV Collected once per 
report.

DataValue countOpenSRs sifAllServiceRequests The count of open 
service requests for 
this account.

Table 13. Variables for the Customer Satisfaction Thermometer

Thermometer 
Variable Report-level Variable Calculation Point Comment

MaximumValue CustomersatisfactionHigh ssList_Of_ValuesQuery1 Collected once per 
report.

MinimumVales CustomerSatisfactionLow ssList_Of_ValuesQuery1 Collected once per 
report.

TriggerDataValue CustomerSatisfactionTarget ssList_Of_ValuesQuery1 Collected once per 
report.

DataValue TotalSatisfactionScore, 
countSurveys

local The ratio of the 
total satisfaction 
score to the 
number of 
surveys.
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rptAllServiceRequests
The method overrides of the sifAllServiceRequests (single input filter class) perform 
list storage, array storage, and calculations. Table 14 shows the methods that can be 
overridden for sifAllServiceRequests.

Closure Time Summary Data Display
The following section describes the Closure Time Summary Data display.

rptClosureTimesAllSeverities
This is an outer report section that produces one blank data row for each Service 
Request Severity. This makes possible the reuse of rptClosureTimesBySeverity 
report section for a variable number of severities. Table 15 shows the relevant 
variables for rptClosureTimesAllSeverities.

Table 14. Methods Overrides for sifAllServiceRequests

Method Scope Comment

Fetch sisAllServiceRequests Stores a list of data rows for open service requests. 
Calculates the closure time for closed service 
requests and stores them in an array of lists, one list 
for each severity. Accumulates total closure time 
and a count for each severity. Tracks high and low 
closure time for each severity and stores them in 
arrays.

Finish sifAllServiceRequests Calculates average closure time and standard 
deviation for each severity and stores the values in 
arrays.

Table 15. Relevant Variables for rptClosureTimesAllSeverities

Variable Name Scope Type Storage Visibility Comment

MaxSeverity AccountServiceDetail Integer Static Public Total number of 
possible service 
request severities.

currentSeverity AccountServiceDetail Integer Static Public Used by the inner 
report section.
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The Fetch method overrides to result in subreport executing once for each severity. 
Table 16 shows the scope for this method.

rptClosureTimesBySeverity
This is an inner report section that produces identically formatted closure time 
summary information for each service request severity. Service request data was 
collected earlier and stored in an array of lists. The data list used for an instance of 
this report section is specified by the currentSeverity variable. The components in 
this report section are described below.

dsGatherOneList. The code in dsGatherOneList class sorts the list by resolution time 
so that the medium closure time can be determined. The rows are then pulled from 
the list in correct sort order and passed to sifClosureTimes class. Table 17 explains 
how the Start and Fetch methods affects each class.

Table 16. Fetch Method Override

Method Scope Comment

Fetch dsOneBlankRowPerSeverity Produces one blank row per service request 
severity.

Table 17. Methods for dsGatherOneList

Method Scope Comment

Start dsGatherOneList Sorts the list of service requests by resolution time.

Fetch dsGatherOneList Pulls the service request data rows from the list in 
proper sort order.

Start sifClosureTimes Establishes graph horizontal boundaries as plus or 
minus 2 standard deviations from the mean. 
Establishes the median position in the data list.

Fetch sifClosureTimes Produces a data row for each of a predetermined 
number of buckets that correspond to a time 
increment. The time increments are represented by 
the x-axis of the graph. The count of service requests 
with closure times falling within the time increment 
is represented on the y-axis.
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Before frame. Code in the Before frame produces and positions the graph target 
closure time marker. Table 18 reflects the method that needs changing to produce 
the closure time marker.

Summary data values. Summary data values are calculated in code. Table 19 reflects 
the method to use to calculate the summary data values.

Table 18. Method to Produce the Closure Time Marker

Method Scope Comment

Finish ssFrmP1 Dynamically produces the visual line element 
representing the closure time goal.

Table 19. Methods for Calculating Summary Data Values

Method Scope Comment

Finish txtSeverityLabel From currentSeverity variable.

Finish txtGoal From targetResolutionTime array.

Finish txtMedian From medianResolutionTime array.

Finish txtHigh From highResolutionTime array.

Finish txtLow From lowResolutionTime array.

Finish txtMean From meanResolutionTime array.

Finish tstStdDeviation FromstdDevResolution Time array.

Finish txtTotal From countClosedSRs array.
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Traffic lights. Traffic lights are resized, repositioned, and colored in code. Table 20 
shows how code is used in methods to change Traffic lights.

Closure time. Closure time graph y-axis labels are customized in code. Table 21 
shows the method to use to produce better performance for the Closure Time class.

sifClosureTimes. Code in the sifClosureTimes class initializes the graph boundaries, 
establishes the sorted list position of the median closure time and counts service 
requests for each time increment, or bucket. One data row represents each bucket 
on the graph. Table 22 shows the variables for use with this class.

Table 20. Methods Used for Traffic Lights

Method Scope Comment

Finish dotTop Green light. Mean closure time is faster than the 
target.

Finish dotMiddle Yellow light. Mean closure time is slower than the 
target, but not by more than one standard deviation.

FInish dotBottom Red light. Mean closure tine is slower than target by 
more than one standard deviation.

Table 21. Method Used for Closure Time

Method Scope Comment

CustomYLabels ssSummaryGraph1 Produces improved graph performance over a 
wide range of sample sizes.

Table 22. Variables for Use With sifClosureTimes Class

Variable Name Scope Type
Stora
ge

Visibili
ty Comment

graphMax sifClosureTimes Double Static Public Closure time for right edge 
of graph.

graphMin sifClosureTimes Double Static Public Closure time for left edge of 
graph.
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meanResolutionTime() AccountServiceDetail Double Static Public Array populated in 
sifAllServiceRequests.

stdDevResolutionTime() AccountServiceDetail Double Static Public Array populated in 
sifAllServiceRequests.

targetResolutionTime() AccountServiceDetail Double Static Public Set from LOV for each 
severity.

targResTimeUnits() AccountServiceDetail Double Static Public Used to scale summary data 
to hours, days, or weeks.

targResTimeGraphPercent AccountServiceDetail Double Static Public Scales position of target 
indicator.

currentSeverity AccountServiceDetail Integer Static Public Set by outer report section. 
Used as an index into all 
arrays sized to 
MaxSeverities.

maxBuckets sifClosureTimes Integer Static Public Determines horizontal 
resolution of graphs.

bucketIncrement sifClosureTimes Double Static Public Width in minutes of closure 
time bucket.

ResolutionTimeList() sifLCsureTimes AcList Static Public Array of data lists populated 
in sifAllServiceRequests.

countClosedSRs() AccountServiceDetail Integer Static Public Array populated in 
sifAllServiceRequests.

Table 22. Variables for Use With sifClosureTimes Class

Variable Name Scope Type
Stora
ge

Visibili
ty Comment
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Account Summary Report
The report describes the relevant details pertaining to the account. It contains 
information about the account's historical and future revenue, satisfaction, 
organizational hierarchy, and service requests.

Order of Merit
The Order Of Merit graphic is determined in the Finish method of the 
ssOrderOfMeritHeader1 frame according to the following logic:

■ If the Customer Satisfaction thermometer is above the target line, and the 
Pipeline thermometer is above the target line, then the arrow direction is up. 

■ If the Past Revenue thermometer is above the target line, and the Pipeline 
thermometer is below the target line, then the arrow direction is right. 

■ In all other cases, the arrow points down.

Past Revenue Thermometer
Table 23 shows the variables for use with the Past Revenue Thermometer.

Table 23. Variables for Past Revenue Thermometer

Thermometer 
Variable Report-Level Variable Calculation Point Comment

MaximumValue PastRevenueHigh qryPastRevenueLostOfValues Collected once per report.

MinimumValue PastRevenueLow qryPastRevenueLostOfValues Collected once per report.

TriggerDataValue PastRevenueAverage qryPastRevenueLostOfValues Collected once per report.

DataValue PastRevenue qryPastRevenue Sum of the revenues for all 
opportunities associated with this 
account with 100% probability.
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Pipeline Thermometer
Table 24 shows the variables for use with the Pipeline Thermometer.

Customer Satisfaction Thermometer
Table 25 shows the variables for use with the Customer Satisfaction Thermometer.

Table 24. Variables for Pipeline Thermometer

Thermometer 
Variable

Report-Level 
Variable Calculation Point Comment

MaximumValue PipelineHigh qryPiplineListOfValues Collected once per report.

MinimumValue PipelineLow qryPiplineListOfValues Collected once per report.

TriggerDataValue PipelineAverage qryPiplineListOfValues Collected once per report.

DataValue PipelineRevenue ftrPipelineThermometer Sum of the revenues for all of the 
opportunities associated with this account.

Table 25. Variables for Customer Satisfaction Thermometer

Thermometer 
Variable Report-Level Variable Calculation Point Comment

MaximumValue CustomerSatisfactionHigh qryCustomerSatisfactionList_Of_Values Collected once 
per report.

MinimumValue CustomerSatisfactionLow qryCustomerSatisfactionList_Of_Values Collected once 
per report.

TriggerDataValue CustomerSatisfactionTarget qryCustomerSatisfactionList_Of_Values Collected once 
per report.

DataValue AverageScore qryCustomerSatisfactionThermometer The ratio of the 
total satisfaction 
score to the 
number of 
surveys.
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Products Installed Graphic
The Products Installed graphic consists of controls generated dynamically in code 
overrides in the frmTimeLineAndHeader class. The OnRow method builds an array 
of unique install dates form the Install Date field of the Customer Product Business 
Component. The Finish method positions line and label controls along a time line 
based on the values in the array. 

Two kinds of markers exist: year markers and install markers. Year markers are 
determined by iterating through the arrays, finding the oldest and newest install 
dates. The chart is scaled horizontally from these dates, and the individual install 
markers are placed proportionally.

Pipeline Analysis Report
This report analyzes the current pipeline. Historical information is used to 
determine the revenue that is expected to be generated over the next four quarters 
and how that revenue compares to the quota for that period. 

Order of Merit
The Order of Merit graphic is determined in the Finish method of the 
ssOrderOMeritHeader1 frame according to the following logic:

■ If the Revenue versus All Current Quotas thermometer is above the target line, 
then the arrow direction is up.

■ If the thermometer is between the target line and the acceptable revenue line, 
then the arrow direction is right.

■ If the cementer is below the acceptable revenue line, then the arrow direction is 
down.
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Revenue versus All Current Quotas Thermometer
This thermometer has added functionality compared to standard thermometers. A 
dashed line is added at a point below the trigger to indicate a revenue level that is 
below the target but still acceptable. The position of the dashed line is based on the 
value of the AcceptableRange variable. Table 26 shows the variables for use with 
this thermometer.

Quota Summary Report
This report measures performance relative to quota for the current period and year-
to-date. Closed revenue, as well as pipeline revenue, are tracked to determine 
whether the goal for the quarter can be met.

Order of Merit
The Order of Merit graphic is determined in the Finish method of the 
ssOrderOfMeritHeader1 frame according to the following logic:

■ If the Revenue versus All Current Quotas thermometer is above the target line, 
then the arrow direction is up.

■ If the thermometer is between the target line and the acceptable revenue line, 
then the arrow direction is right.

■ If the thermometer is below the acceptable revenue line, then the arrow direction 
is down.

Table 26. Variables for Revenue Versus All Current Quotas Thermometer

Thermometer Variable Report-Level Variable Calculation Point Comment

MaximumValue NA local TriggerDataValue * 1.5.

MinimumValue NA local Always zero.

TriggerDataValue totalQuota sifQuota Based on Prorated Target Amount 
field of Quota Objective 
Assignment Business Component.

DataValue ExpectedRevenueNext4Q frmDashboard Based on the Probability Matrix 
derived from LOV.

AcceptableRange targetQuotaRange dsTargetQuotaRange Based on value from LOV.
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Revenue versus All Current Quotas Thermometer
This thermometer has added functionality compared to standard thermometers. A 
dashed line is added at a point below the trigger to indicate a revenue level that is 
below the target but still acceptable. The position of the dashed line is based on the 
value of the AcceptableLevel variable. Table 27 shows the variables for use with this 
thermometer for the Quota Summary Report.

Revenue By Direct Report Section
This section contains special graphic components generated dynamically in the 
OnRow method of the frmDirectReportData component. The code sizes the Pipeline 
Revenue bar based on the sum of pipeline revenue and actual revenue. The Actual 
Revenue bar is sized according to the actual revenue value. The Quota Indicator line 
is superimposed in a position based on the quota value. The code also calculates 
the percent difference between the actual revenue and the quota and determines 
whether or not the under-quota indicator will be displayed.

Table 27. Variables for Revenue Versus All Current Quotas Thermometer

Thermometer Variable Report-Level Variable Calculation Point Comment

MaximumValue NA local TriggerDataValue * 1.5.

MinimumValue NA local Always zero.

TriggerDataValue totalThermQuota txtTotalQuota Based on Quota field of the 
Opportunity Rollup.

DataValue totalThermActualRevenue txtActualRevenue Based on ActualRevenue field 
of the Opportunity Rollup.

AcceptableLevel acceptablePercentageOfQuota frmDashboard Based on value from LOV.

DataValue ExpectedRevenueNext4Q frmDashboard Based on the Probability 
Matrix derived from LOV.

AcceptableRange targetQuotaRange dsTargetQuotaRange Based on value from LOV.
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Service Request Performance Report (Service Request Aging Analysis)
This report analyzes the aging of the currently open service requests. Three metrics 
are tracked that may explain performance: the number of open service requests, call 
volume, and average resolution time during the past months.

Data Collection and Calculation
All service requests are collected and stored in a memory list in the 
rptAllServiceRequests report section. Later, in the rptServiceRequestDetail section, 
the service requests are pulled from the list, grouped by status and severity, and 
displayed in detail. As the service requests are collected, calculation are made and 
values stored in arrays for use in the TimeOpen, OpenServiceRequests, 
NewServiceRequests, and ResolutionTime sections.

rptAllServiceRequests
List storage, array storage, and calculations are accomplished in method overrides 
of the sifAllServiceRequests single input filter class. Table 28 shows the method 
overrides used for this class.

Table 28. Method Overrides for rptAllServiceRequests

Method Scope Comment

Fetch sifAllServiceRequests Stores a list of data rows for all Service Requests.

GetTimeOpenData sifAllServiceRequests Ignores closed service requests.

Calculates time in days the service request was 
open.

Categorizes the service request based on how 
many weeks it was open.

Adds to the running count and total resolution 
time of service requests severity.

Tracks high and low resolution times for severity.

GaetOpenSRData sifAllServiceRequests Calculates call volume by month and severity.

GetNewSRData sifAllServiceRequests Counts service requests that are less than six 
months old.

GetAverageResolutionTimeData sifAllServiceRequests Determines average resolution time by month and 
severity.
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This chapter describes creating parameterized reports in Siebel Tools and Actuate 
e.Report Designer Professional. The majority of steps for creating parameterized 
reports are the same as those for creating any other report. Therefore, both in Siebel 
Tools and Actuate, only the steps specific to parameterized reports are described in 
this chapter.

Parameterized reports allow users to pass data into a report executable at runtime 
and customize the output of that report. The user may narrow the query, sort 
specification, or grouping by a field at the report’s execution time. A parameterized 
report can produce different reports from the same report executable. The 
administrator defines the parameters and the attributes of a report during design 
time in Siebel Tools. For more information on report parameters, please see the 
“Designing report parameters” section in the Developing Advanced e.Reports 
manual on the Siebel eBusiness Third-Party Bookshelf under Actuate.

Siebel eBusiness Applications include several parameterized reports. Most of the 
parameterized reports are available in the Forecasting, Opportunity, and eAuction 
modules. When requesting a parameterized report, the parameters window appears 
after selecting the report from the drop-down menu and clicking Run Now. If the 
report is run using the Schedule option, the parameters window appears after the 
parameters on the Schedule window are specified.

NOTE: Some applications may not include parameterized reports.
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Creating Parameterized Reports
Like all Siebel reports, parameterized report objects are first defined in Siebel Tools, 
and the corresponding ROL file is generated. As a prerequisite to creating a 
parameterized report, a specialized business component and an applet based on 
that business component are created. The business component contains fields that 
correspond to the report parameters. The applet contains the parameters and 
standard controls (such as Submit and Cancel). The reports created are included in 
the views that need to display them.

At the next step, the report design (ROD file) is created in Actuate e.Report Designer 
Professional referencing the parameters created in the ROL file. The report design 
file is then compiled with the Siebel libraries to create the report executable (ROX 
file). This report executable is deployed in the appropriate location (on the Siebel 
Reports Server or Siebel Mobile Web Client or both). When a parameterized report 
is run, the options on the parameter window allows the user to select or enter the 
values for the parameters included in the report design. The parameter variables 
and schedule variables (if any) are included in a report parameter file (ROV file) and 
submitted to the Reports Server. The report executable obtains these variables from 
the ROV file at report execution time. If the user runs the report interactively (using 
the Run Now option), the report is displayed in a DHTML viewer (in Siebel Web 
Client or Siebel Dedicated Web Client modes) or Siebel Report Viewer (in Siebel 
Mobile Web Client mode).

Siebel eBusiness Applications include out-of-the box parameterized reports. As part 
of customizing these reports, the reports administrator may add or delete the 
parameters in these reports. The administrator may also create custom 
parameterized reports. Parameterized reports are created and customized in Siebel 
Tools and Actuate e.Report Designer Professional as described in the following 
sections using the creation of the Revenue Analysis Summary report as an example.
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Siebel Tools
This section describes how to create and customize reports in Siebel Tools.

To create and customize parameterized reports in Siebel Tools

1 Create a business component object Revenue Report Parameters. 

Specify the properties of this business component as follows:

Class and Name properties are required:

Class = CSSBCVReportParameters.

Name = Revenue Report Parameters. It is recommended that the business 
component be named to easily recognize that it forms the basis for the 
parameter applet for a specific report.

Accept the default properties for all other properties of this business component, 
and any other business component created for a custom parameterized report.

2 Create the picklists to be used with the field object. 

In the Object Explorer select the Pick List object type and create picklists with 
the following properties:

Picklist = Revenue Report By PickList; Revenue Report Show PickList; 
Revenue Report then PickList

Business Component = PickList Generic for all picklists
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3 Expand the business component in the Object Explorer and select Field. Create 
as many fields as the number of parameters in the report. The fields can be 
created as entry fields or picklists. For entry fields, the creation and association 
of picklists to business component fields can be skipped. 

There are three parameters in the Revenue Analysis Detail report that allow 
filtering data at three levels. Therefore, create three fields with the following 
properties:

Name and picklist properties are required:

Name: By In Revenue; Show In Revenue; Then In Revenue.

PickList: Revenue Report By PickList; Revenue Report Show PickList; 
Revenue Report Then PickList.

4 Create an applet for the business component. The applet is the pop-up window 
that appears as the second or third screen when requesting a parameterized 
report. 

Set the applet properties as follows:

Class: CSSSWEFrameReportParam. This class contains the logic for 
translating the selected parameters into the ROV file in Actuate.

HTML Popup Dimension: 200 x 200. This is the default size of the pop-up 
window, but this can be changed depending on the number of parameters.

Title: Revenue Parameter Applet. Set this property appropriately to represent 
the parameter applet for a custom parameterized report.

Business Component: Revenue Report Parameters. This is the name of the 
business component created for parameter applet in Step 1 on page 323.

5 Create an applet Web template to associate with the parameter applet.

a Highlighting the applet created in Step 4, expand the Applet object in the 
Object Explorer. 
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b Select Applet Web Template object and add two applet Web templates with 
the following required properties:

Type: Edit. This property specifies the mode in which this applet is rendered 
at run-time. Type should always be set to Edit since users need to select or 
enter values for parameters at run-time.

Web Template: Applet Popup Form. You may select any other Web template 
that has the desired layout for the parameter pop-up window.

6 Create the necessary controls for the Parameter pop-up window. These controls 
include labels, text, parameter fields, and standard controls. The properties for 
the controls for Revenue Parameter Applet are shown below:

For standard controls:

Name: Submit Button; CancelButton. This property can be set to any 
meaningful name, but it is recommended that they indicate the function of 
the control.

Method Invoked: Submit; CloseApplet. This property is required for standard 
controls and should be left blank for all other controls.

HTML Type: MiniButton for both of the controls. This property should be set 
appropriately depending on the type of control. For example, set this value 
to FieldLabel for the label controls ByLabel, ReportLabel, ShowLabel, and 
ThenLabel.

For parameter field controls:

Name: ByInRevenue; ShowInRevenue; ThenInRevenue. This property can be 
set to any meaningful name, but it is recommended that they indicate the 
function of the control. In Control User Prop make Name equal to 
SHOWNONE.

HTML Type: Field, for all three parameter field controls.

Field: By In Revenue; Show In Revenue; Then In Revenue. Recall that these 
are the fields created in Step 2 on page 323. This property should be left 
blank for all other controls.
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7 Create a report object to associate with the parameter applet. Set the Parameter 
Applet property of this report object to the name of the applet previously 
created.

8 Include the report object created in Step 7 in the views that should display this 
report.

9 Create the Actuate ROL file using Tools > Utilities > Generate Actuate Report. 

The configuration in Tools is complete. The next steps involve creating the design 
in Actuate for the parameterized report.

Actuate
Make sure that you have installed Actuate e.Report Designer Professional from the 
CD-ROM. Since the report design process is similar to any other report, only the 
design specific to a parameterized report is described here. The description of 
creating parameterized report design in Actuate e.Report Designer Professional is 
described in the Designing report parameters chapter of Actuate’s Designing 
Advanced e.Reports manual. The general process in designing a parameterized 
report includes two main steps:

■ Creating parameters and referencing the parameters where they are used.

■ Additionally, certain report methods to be modified using Actuate e.Report 
Designer Professional to pass the parameter values selected or entered by the 
Siebel applications user.

The first step is generic to all parameterized reports and described in Actuate’s 
Designing Advanced e.Reports manual. The second step is specific to Siebel 
parameterized reports and is described here for the Revenue Analysis Summary 
report.

When Revenue Analysis Summary report is run from a Revenue screen, the 
parameter screen appears after the Run Now option is selected or after the schedule 
parameters are entered with the Schedule option. The user needs to select a value 
for each of the three parameters from the drop-down lists before clicking Finish. 
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The report is then generated and displays the first parameter field (which is the 
grouping field) in a cross tab format with the second parameter in aggregated date 
scale along columns, and the third parameter as rows. Therefore, this report is 
essentially a cross tab report (for more details, see Chapter 7, “Reports with Group 
Sections” in this book and the “Presenting data in crosstabs” section in the 
Developing Advanced e.Reports Actuate manual) with the displayed field selected by 
the user at run time. The second parameter defines the columns and the third 
parameter defines the rows.

To set report parameters

The report process parameters are set by the user in the client in the following order.

1 Store language dependent parameters fetched from the report ROV file (in the 
Start() method of root node ‘revd’) as global variables.

Sub Start()

………………………

' get language values from user entered parameters

ThenParameterV=ThenInRevenue

ValueParameterV=ShowInRevenue

ByParameterV=ByInRevenue

…………………………………………

End Sub
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2 Get the language independent codes for the parameter values selected by the 
user from the LOV table.

ThenParameter = represents a group key.

ValueParameter = represents a metric key.

ByParameter = represents a date key.

These values are necessary to support internal report logic that is language 
independent. The parameter retrieval is based on the ssSmart.rol library custom 
DataStream control ssList_Of_ValuesQuery (select ssSmart.rol from Library 
Organizer menu, double click on ssList_Of_ValuesQuery, and select Class tab). 

Modify the control methods Start() and Fetch() to set a search specification 
dynamically and store retrieved parameter language independent values.

Function Start() As Boolean

Dim DateSt as String

Dim ValueSt as String

Dim ThenSt as String

‘ create Search Spec date portion based on LOV or default ‘

‘ value

if revdet::ByParameterV <> "" Then

DateSt = "[Value] = '" & revdet::ByParameterV & "'"

else

DateSt = "[Name] = 'Month'"

end if

‘ create Search Spec Value portion based on LOV or default ‘

‘ value
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if revdet::ValueParameterV <> "" Then

ValueSt = "[Value] = '" & revdet::ValueParameterV &"'"

else

ValueSt = "[Name] = 'Revenue'"

end if

‘ create Search Spec Then portion based on LOV or default ‘

‘ value

if revdet::ThenParameterV <> "" Then

ThenSt = "[Value] = '" & revdet::ThenParameterV & "'"

else

ThenSt = "[Name] = 'Account'"

end if

' dynamic search spec

SearchSpec="[Type] = 'REVN_FUNCTIONCAPTIONS' AND " & ValueSt

+ & " OR [Type] = 'REVN_SERIESCAPTIONS' AND " & ThenSt

+ & " OR [Type] = 'FCST_INTVL_PERD_TYPE' AND " & DateSt

Start = Super::Start( )

End Function

Function Fetch( ) As AcDataRow

Dim aRow As ssList_Of_ValuesDataRow

Set Fetch = Super::Fetch( )
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If Fetch Is Nothing Then

Exit Function

End If

set aRow = fetch

Select Case aRow.ssValue

case revdet::ByParameterV

revdet::ByParameter=aRow.ssName

case revdet::ValueParameterV

revdet::ValueParameter=aRow.ssName

case revdet::ThenParameterV

revdet::ThenParameter=aRow.ssName

End Select

End Function

3 Use date parameter ByParameterV to set a search specification for ssPeriodQuery 
data stream from revper.rol. As a result Period business component returns only 
period record of specified type (day or month or quarter or year).

Sub Start( )

Super::Start( )

' set search spec to get only needed period type records

ssReport::ssSearchSpec = "[Period Type]='" &

revdet::ByParameterV & "' "

End Sub
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4 Use ByParameter and ValueParameter parameter values to fill out revenue Line 
Item record dynamically. The purpose here is to create a list of revenue records 
that are independent of user parameters to make sure that general logic works 
correctly. Later, line item records are stored in a memory list for further 
aggregation.

Function CreateUListRow(Rec as acDataRow ) as uListRow

Dim uRec as uListRow

Dim aRec as ssRevenueDataRow

dim CurrentSection as integer ' put into root

' calculate section key and UnitKeyStat

CurrentSection=GetGroupKey()

Set aRec = rec

set uRec = New uListRow

' filter ByParameter

Select Case LCase(revdet::ThenParameter)

case "account"

uRec.uThen=aRec.GetValue("ssAccount")

case "campaign"

uRec.uThen=aRec.GetValue("ssCampaign")

case "opportunity"

uRec.uThen=aRec.GetValue("ssOpportunity")

case "project"

uRec.uThen=aRec.GetValue("ssProject")

case "partner"
Version 7.5, Rev B Siebel Reports Administration Guide 331



Parameterized Reports

Creating Parameterized Reports
uRec.uThen=aRec.GetValue("ssPartner")

case "product"

uRec.uThen=aRec.GetValue("ssProduct")

case "product line"

uRec.uThen=aRec.GetValue("ssProduct_Line")

case "description"

uRec.uThen=aRec.GetValue("ssDescription")

case "revenue type"

uRec.uThen=aRec.GetValue("ssRevenue_Type")

case "revenue class"

uRec.uThen=aRec.GetValue("ssRevenue_Class")

case "win probability"

uRec.uThen=aRec.GetValue("ssWin_Probability")

case "sales rep"

uRec.uThen=aRec.GetValue("ssSales_Rep")

case "contact last name"

uRec.uThen=aRec.GetValue("ssContact_Last_Name")

case "Quote"

uRec.uThen=aRec.GetValue("ssQuote")

Case Else

if gErrorMsg = "" then gErrorMsg =

"'Then' parameter is invalid"

Exit Function

End Select
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' filter ValueParameter

Select Case LCase(revdet::ValueParameter)

case "revenue"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Revenue_

Formatted"))

case "margin"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Margin_

Formatted"))

case "cost"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Cost_

Formatted"))

case "upside"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Upside_

Formatted"))

case "downside"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Downside

_Formatted"))

case "average price"

uRec.uValue=toCur(aRec.GetValue("ssFunctional_Average_

Price_Formatted"))

case "quantity"

uRec.uValue=toCur(aRec.GetValue("ssQuantity_Formatted"))

Case Else ' default

if gErrorMsg = "" then gErrorMsg = "'Show' parameter
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is invalid"

Exit Function

End Select

' Get values for the remaining fields

uRec.uItem=aRec.GetValue("ssProduct")

uRec.uCommit=aRec.GetValue("ssCommitted")

uRec.uProb=aRec.GetValue("ssWin_Probability_Formatted"))

uRec.uSalesRep=aRec.GetValue("ssSales_Rep")

uRec.uRevCls=aRec.GetValue("ssRevenue_Class")

uRec.uRevTp=aRec.GetValue("ssRevenue_Type")

uRec.uCurrencyCode=aRec.GetValue("ssFunctional_Currency_Co
de")

uRec.uDate=CDate(aRec.GetValue("ssDate_Formatted"))

uRec.SectionKey = CurrentSection

uRec.uDateUnit = UnitKeyStat ' GetUnitKey(uRec.uDate)

' create key for Item grouping based on displayed attributes

' Item+Commit+Prob

uRec.ItemKey= Trim(uRec.uItem) & Trim(uRec.uCommit) &

Trim(uRec.uProb)

Set CreateUListRow = uRec

End Function

Parts of the described approach to handling the user parameters can be of general 
use for other parameterized reports. They include Parameters retrieval, filtering 
Periods, and fetching values from the LOV table. 
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In the prior versions of Siebel eBusiness applications, a separate report design was 
needed for each language due to the hardcoding of user visible, language specific 
strings in the design. The format (locale) in which the fields were displayed was 
also hardcoded in the report design. As of release 7.5, users will be able to 
externalize the visible strings, locale information, and certain properties of data 
from the report design. At report generation time, the user interface strings of the 
desired language are obtained from an external file. The locale information is 
obtained from a locale map, and the report data is formatted.
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This chapter describes how extracting user-visible strings automatically from report 
design and Siebel report libraries can greatly simplify the localization process, 
reduce the time to create translations, and lower the localization cost. You need not 
be familiar with Actuate e.Report Designer Professional. The externalized strings of 
the reports can be more easily translated and maintained separately without 
affecting the report design and the executable file.

New functions to export and import user interface strings have been implemented 
in sscustom.bas. When the report is first designed and run in the Design mode, all 
the control names, text strings, and certain user interface properties from the report 
are extracted to an external file. This external file is in plain text format and is 
referred to as an user interface file. You can then localize the text strings in this file. 
When the report is run in the Deployment mode (which is the mode in which report 
executables are deployed), the report will read the text strings from this user 
interface file. 

Previously, to translate user-visible strings in a report, you would manually open 
each report design file and modify the properties of the label controls, text controls, 
and so on. With this user interface externalization feature in release 7.5, you will 
be able to translate the texts for label controls and the search alias for text controls 
in the user interface files created by the user interface externalization feature. 
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Designing a multilingual report is essentially the same as that of any standard 
report. The only additional step is to externalize the user interface elements for 
localization in the desired languages. The same report executable obtains the 
language-specific strings from the localized text files based on user's specification. 
The following instructions will describe the details of the additional step for 
localization of user interface strings.

To design multilingual reports

1 Design a report in the default language first; for example, ENU (English).

If your installation uses a non-English version of Siebel eBusiness Applications, 
you do not have an \enu folder. Instead, you have a folder in the appropriate 
language code for your installation, such as \deu for Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

This part of the design is the same as already discussed in using Siebel Tools to 
create the ROL file and using Actuate e.Report Designer Professional to create 
the ROD and ROX files. For more information, see Chapter 6, “Creating a Simple 
List Report.”

a Run report in Design mode to externalize user interface strings and data 
properties to an external file.

b Set gExportUI to 1 in the beginning of the Start method of ssReport in 
sscustom.rol.
Version 7.5, Rev B Siebel Reports Administration Guide 337



Developing Multilingual Reports

Designing Multilingual Reports
c Compile and run by setting ssLanguage to ENU or PSE.

If your installation uses a non-English version of Siebel eBusiness 
Applications, you do not have an \enu folder. Instead, you have a folder in 
the appropriate language code for your installation, such as \deu for 
Germany.

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

d Generate the report executable, for example, ACLIST.rox and ACLIST.txt.

NOTE: This executable is for design time use only.

2 Localize the contents of ACLIST.txt into separate language specific files.

Use the contents of ACLIST.txt for localization into desired languages.

a Generate ACLIST.txt file specific to each language.

b Place each of the language specific TXT file in 
Siebdev_Root\RPTSRC\Lang\ACLIST.txt

Where:

Lang = the Siebel code for the language the report will use; for example, enu 
for U.S. English.

3 Run the report in Deployment mode to verify localization.

a Set gExportUI to 0 in the beginning of the Start method of ssReport in 
sscustom.rol.

b Recompile to create the report executable for the runtime deployment by 
setting ssLanguage to FRA (French), DEU (German), JPN (Japanese) and so 
forth as needed.

c Verify that the language specific labels are displayed in the Actuate e.Report 
Designer Professional for each user specified language parameter.

NOTE: After testing a multilingual report, make sure that the report executable is 
created in the Deployment mode; for example, set gExportUI to 0 at the beginning 
of the Start Method in ssReport in sscustom.rol.
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With the report executable completed, you will need to package the reports for 
deployment to the Siebel eBusiness application.

To deploy multilingual reports

■ Package the tested multilingual report.

■ Upload the ACLIST.ROX file (and any multilocale report) using Actuate 
Management Console into the Siebel Reports folder in the Report 
Encyclopedia.

All language specific ROX files should be uploaded into Siebel Reports\LANG 
folder in the report encyclopedia

Where:

LANG = the Siebel code for the language the report will use; for example, 
enu for U.S. English.

■ Save the ACLIST.txt files into C:\Sea\Rptsrvr\BIN\UI\Lang\ directory for 
each language in the Actuate e.Reporting Server host machine.
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At report generation time, the enhanced user interface of the report generation 
wizard in Siebel eBusiness Applications now displays drop-down lists for the user 
to select the language and locale.

To view multilingual reports

1 Select a multilingual report, which was developed previously, from a Siebel 
view.

2 Select the report, language, and locale from the drop-down lists in the Reports 
window.

3 Generate the report with the data and labels per specified language formatted to 
a specified locale.

Locale information is read from a locale map.

If no strings are found, labels and properties are defaulted to the original ROD 
file values for that report.

For more information, see “User Interface and Process Flow” on page 362.
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Some exceptions exist when developing multilingual reports since some reports are 
not amenable to this single report ROX model. The following list consists of the 
exceptions for developing multilingual reports.

■ Language specific address blocks are not adjusted automatically. For example, 
the ZIP code and telephone numbers fields are not adjusted to match the new 
language locale for the report.

■ Fields based on locale are not automatically set to be included and or suppressed 
based on the locale selected for the report; for example, the JPN name alias field.

■ Language specific search aliases are not automatically substituted.

■ Reports that contain Charts and Graphs with labels will not reflect the locale of 
the selected locale for the report.
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This chapter describes the report business service methods. These methods can be 
used in scripts or workflow processes to automate reporting related business 
processes. For example, the administrator can define workflow processes to 
automate the business processes for generating a report with a specific query, or 
saving a report in the PDF format, or emailing a report to the customer.

Most users are familiar with report generation in the Siebel eBusiness Application 
views. In this mechanism, users may run a query in the view and then generate a 
report interactively or in the batch mode against that data. Subsequently, the report 
may be printed or shared with other Siebel users. Clearly this mechanism requires 
user interaction to accomplish reporting business needs. Using the report business 
service methods, customers can generate, share, and print reports automatically 
without user interaction. Since the report is automatically generated when certain 
business rules are satisfied, there is no way for the user to pass a query. Therefore, 
the view mode applied on the report executable is used for obtaining data. 

Siebel Business Process Designer is an interactive software tool that lets you 
automate how your organization handles workflow processes.

For more information, please refer to Siebel Business Process Designer 
Administration Guide on the Siebel Bookshelf.

NOTE: Currently, the report business service methods are supported only on the 
runtime events. Therefore, a user must be logged on to trigger an event that will 
invoke these methods. 
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Knowledge of Siebel Tools, scripting, Siebel Business Process Designer and Siebel 
Reports Server is necessary to use the report business service methods. 
Understanding of running the business services is also necessary. Administrators 
can create as many workflow processes as needed to satisfy their business 
requirements and include the necessary report business service methods as steps 
(recall that workflow processes can include one or more business services as steps). 
The designers can test these workflow processes in the Business Process simulator. 
For more details on workflow processes and workflow policies, please refer to Siebel 
Business Process Designer Administration Guide on the Siebel Bookshelf. 
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The Report Business Service consists of methods that can be used in workflow 
processes or scripts. The following methods can be called in a workflow to 
automate report generation on the Reports Server. 

NOTE: The report business service methods always operate on the Reports Server. 
Therefore, the administrator should make sure that the Reports Server is installed, 
configured, and is up and running. 

Table 29 lists the available business methods.

Table 29. Report Business Service Methods Available for Reports 

Name of Business Method Purpose

ExecuteReport Runs a report on the Reports Server. See Table 30 on page 346 
for more information.

GrantRolesAccess2Report Grants access of report to roles (view only). See Table 31 on 
page 348 for more information.

GrantUserAccess2Report Grants access of report to other users (view only). See 
Table 33 on page 350 for more information.

PrintReport Prints a report to a valid printer. See Table 33 on page 350 for 
more information.

RunAndEmailReport Generates a report and sends it as an email attachment to one 
or more users. See Table 34 on page 352 for more 
information.

SaveReport2PDF Saves a report in PDF in the user folder on the Reports Server. 
See Table 35 on page 353 for more information.

ScheduleReport Schedules a report on the Reports Server. See Table 36 on 
page 354 for more information.

SyncOne Synchronizes a single user on the Reports Server. See Table 37 
on page 356 for more information.
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The following tables describe the input parameters for the Report Business Service 
methods.

ExecuteReport 
Table 30 contains the input parameters for the ExecuteReport business method.

Table 30. ExecuteReport Parameters

Input Description Examples Optional Default

reportDefName The name of the report object 
definition.

Employee 
Achievement 
Report

No None

activeBOName Name of Business Object. Incentive 
Compensation 
Employee Position

No None

reportName Access Base DB Name. EMPACH Yes Use information from 
report object 
definition.

OutputName Full path/filename of the 
output ROI file.

/SADMIN/
OPLIST.roi

Yes Default folder to
/mylogin/
reportName.roi.

viewMode View mode of report. 0, 1, 2, 3, 
and so on.

Yes 0

ssSearchSpec Search specification of the 
report.

Yes Use search 
specification on report 
object definition.

activeRowId Active record row ID. Yes None

Locale Locale enu Yes Object Manager’s 
language setting.

Language Language enu Yes Object Manager’s 
locale setting.
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ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object Manager’s 
ActuateReportServerH
ost.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.

Concerning PollRequest Loop

InitSleep Initial sleep time (in seconds). 20 Yes 10

Intvl Polling Interval (in seconds). 10 Yes 30

MaxWait Time Out. 100000 Yes 1000000

Table 30. ExecuteReport Parameters

Input Description Examples Optional Default
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GrantRolesAccess2Report 
Table 31 contains the input parameters for the GrantRolesAccess2Report business 
method.

NOTE: The roles used for the RoleList input parameter needs to be defined in the 
Actuate Management Console by the administrator prior to being used for sharing 
reports.

Table 31. GrantRolesAccess2Report Parameters 

Input Description Examples Optional Default

ReportRoiName An existing ROI filename in the 
Actuate Report Encyclopedia.

/SADMIN/
OPLIST.roi

No None

Version Version number of ROI file. Yes 0 (latest ROI file is 
used).

RoleList Comma-delimited list of roles. Director, 
President, 
Manager

No None

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object Manager’s 
ActuateReportServerHo
st.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component RS 
Employee.
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GrantUserAccess2Report 
Table 32 contains the input parameters for the GrantUserAccess2Report business 
method.

Table 32. GrantUserAccess2Report Parameters 

Input Description Examples Optional Default

ReportRoiName An existing ROI filename in the 
Actuate Report Encyclopedia.

/SADMIN/
OPLIST.roi

No None

Version Version number of ROI file. Yes 0 (latest ROI file is 
used).

UserList Comma-delimited list of users. AFOSTER, 
KCHAN, 
RGAMPALA

No None

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object 
Manager’s 
ActuateReportServer
Host.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.
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PrintReport 
Table 33 contains the input parameters for the PrintReport business method.

Table 33. PrintReport Parameters 

Input Description Examples Optional Default

OutputName An existing ROI filename in the 
Actuate Report Encyclopedia.

/SADMIN/
OPLIST.roi

No None

Version Version number of ROI file. Yes 0 (latest ROI file is 
used).

Printer A valid printer name for the 
Actuate e.Reporting Server.

No User's default printer 
or Actuate Server 
default printer.

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object 
Manager’s 
ActuateReportServer
Host.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.
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RunAndEmailReport 
Emailing a report as an attachment to another user is available in the method 
RunAndEmailReport(). The attached report will be sent as an ROI file. For viewing 
the ROI file, download the Actuate Viewer from the Actuate web site (http://
www.actuate.com/resourcecenter/index.asp) if you are using the Siebel Web 
Client. The Dedicated Web Client includes the Siebel Report Viewer that will allow 
viewing of the ROI file.

However, the following limitations do apply:

■ You can only use this method for generating and then emailing that specific 
report. In other words, you will not be able to send a report attachment for 
reports that have already been generated.

■ Related user preferences must be set manually within the Actuate Management 
Console. The report administrator has to specify how each user should handle 
report completion notification (see “Receiving Email Notifications and Adding 
Report Attachments” following this section).

■ The email message (besides the particular report) can not be customized. The 
format is as provided in the Siebel application.

To configure Actuate to send email (using RunAndEMailReport), run 
c:\Actuate6\Server\bin\mailinst.exe and setup email profile.

NOTE: To enable email notification from the Actuate e.Reporting Server, Microsoft 
Exchange Server must be used as the email Server. Email notification will not work 
if a standard SMTP email server is used. For more information, see Administering 
Actuate e.Reporting System manual on the Siebel eBusiness Third-Party Bookshelf.

Receiving Email Notifications and Adding Report Attachments
For users to receive email notifications for both successful and failed requests and 
add reports as attachments (for successful cases), the Actuate administrator needs 
to make certain changes in the Actuate Management Console.
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To receive email notifications and add report attachments

1 From the Start menu, open the Management Console and log in as Actuate 
administrator. 

2 Click the Users icon on the left hand side.

a Choose a user and move the mouse pointer over the down arrow icon next 
to it.

b Select Properties from the drop-down list. Click the Jobs tab.

3 In the section For jobs that succeed, check both Send e-mail notification and 
Attach document options.

4 In the section For jobs that fail, check Send e-mail notification option.

5 Make sure that the Create completion notice option in both sections are checked 
(this is the default). Click OK.

Table 34 contains the input parameters for the RunAndEmailReport business 
method.

Table 34. RunAndEmailReport Parameters 

Input Description Examples Optional Default

Include ALL relevant parameters in ExecuteReport( ) to specify the report to be run

UserList Comma-delimited list of users to 
receive email notices.

AFOSTER, 
KCHAN, 
RGAMPALA

No None

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object 
Manager’s 
ActuateReportServer
Host.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.
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SaveReport2PDF
Table 35 contains the input parameters for the SaveReport2PDF business method.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.

Table 34. RunAndEmailReport Parameters 

Input Description Examples Optional Default

Table 35. SaveReport2PDF Parameters 

Input Description Examples Optional Default

ReportRoiName An existing ROI filename in the 
Actuate Encyclopedia.

SADMIN/
OPLIST.roi

No Assume personal 
folder, for example 
/myfolder/
reportName.roi.

Version Version number of ROI files. Yes 0 (latest ROI is used).

PDFReportName Name of output file in PDF. OPLIST.pdf Yes Default to /mylogin/
reportName.pdf.

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object 
Manager’s 
ActuateReportServer
Host.

SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel.

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.
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Table 36 contains the input parameters for the ScheduleReport business method.

Table 36. ScheduleReport Parameters 

Input Description Examples Optional Default

reportDefName The name of the report object 
definition.

Employee 
Achievement 
Report

No None

activeBOName Name of Business Object. Incentive 
Compensation 
Employee 
Position

No None

reportName Access Base DB Name. EMPACH Yes Use information from 
report object 
definition.

OutputName Full path/filename of the output 
ROI file.

/SADMIN/
OPLIST.roi

Yes Default folder to
/mylogin/
reportName.roi.

viewMode View mode of report. 0, 1, 2, 3, 
and so on

Yes 0

ssSearchSpec Search specification of the report. Yes Use search 
specification on 
report object 
definition.

activeRowId Active record row ID. Yes None

Locale Locale enu Yes Object Manager’s 
language setting.

Language Language enu Yes Object Manager’s 
locale setting.

ActuateServerHost Actuate server host machine 
name.

bptu60s018 Yes Use Object 
Manager’s 
ActuateReportServer
Host.
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SSLoginName Siebel Login. Yes User’s login name, 
whose action triggers 
this business service.

SSPassword Siebel Password. Yes User’s password, 
whose action triggers 
this business service.

AcLoginName Actuate login name. Yes Same as Siebel

ActuatePassword Actuate password. Yes Query from the 
business component 
RS Employee.

StartDate Starting date for report generation 
schedule.

1/1/2002 No None

StartTime Starting time for report generation 
schedule.

12:00:00 No None

Repeat A Y/N flag for recurring report 
generation.

No None

Frequency Frequency of report generation, 
for Repeat = Y.

Daily, 
Weekly, 
Monthly, 
Quarterly, 
and so on

No None

UntilDate Stop date for report generation 
schedule.

12/1/2002 No None

Print A Y/N flag for report printing. No None

Printer A valid printer name for Actuate 
Report Server.

Yes None

Table 36. ScheduleReport Parameters 

Input Description Examples Optional Default
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SyncOne
Table 37 contains the input parameters for the SyncOne business method.

Following is an example script for the SyncOne business method. When this script 
is run, you are returned feedback in the variable sText.

In the script below, SyncOne is executed on users VSILVER and DRA three times 
while storing the user feedback messages in the variable msg. You can consult msg 
on the status of the SyncOne request.

In this example, the script reflects three possible outcomes:

■ The user is created.

■ The user’s password is reset.

■ The script fails. 

These outcomes are indicated in msg.

.....
var svc = TheApplication().GetService("Report Business Service");
var Inputs = TheApplication().NewPropertySet();
var Outputs = TheApplication().NewPropertySet();
var msg = "";

for(var x = 1; x < 3; x++)  {
with (Inputs) {

SetProperty ("AcAdminLogin", "administrator");
SetProperty ("AcAdminPassword", "");
SetProperty ("UserID", "VSILVER,DRA");

}
try {

svc.InvokeMethod ("SyncOne", Inputs, ExtOutputs);
}

Table 37. SyncOne Parameters 

Input Description Examples Optional Default

AcAdminLogin Actuate Administrator Login. administrator No None

AcAdminPassword Actuate Administrator Password. ““ No None

UserID User to be synchronized. SADMIN No None
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catch (e)
{

var sText = e.errText;
var nCode = e.errCode;
msg += sText;

}
}
.....

For information on enabling these business methods, see information on object 
interfaces and scripting on Siebel Tools Online Help and in Siebel Business Process 
Designer Administration Guide on the Siebel Bookshelf.

Example: Invoking a Report Business Service Method Using Scripting
Workflow processes can be invoked programatically from a script using Siebel VB 
or Siebel eScript. By using scripts, workflow processes can be invoked from 
anywhere in the Siebel application or from external programs. 

The following is a Siebel eScript code sample for scheduling the Employee 
Achievement Report to run at a specified time, one time only, using the 
ScheduleReport method.

var svc = TheApplication().GetService("Report Business Service");

var Inputs = TheApplication().NewPropertySet();

var Outputs = TheApplication().NewPropertySet();

var paramArgs  = TheApplication().NewPropertySet();

    with (Inputs) {

SetProperty ("reportDefName", "Employee Achievement Report");

SetProperty ("activeBOName", "Incentive Compensation Employee 
Position");

SetProperty ("viewMode", "3");

SetProperty ("StartDate", "05/01/02");

SetProperty ("StartTime", "10:00:00 AM");
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SetProperty ("Repeat", "N");

SetProperty ("Frequency", "");

SetProperty ("UntilDate", "");

SetProperty ("Print", "");

SetProperty ("Printer", "");

   }

   Inputs.AddChild (paramArgs);

   svc.InvokeMethod ("ScheduleReport", Inputs, Outputs);
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This chapter describes the user interaction with the Reports Server product in the 
Web Client and Dedicated Web Client (both connected and disconnected modes). 

Siebel Reports Server is an out-of-the box integration of Actuate e.Reporting Server. 
While the end user interaction with Siebel Reports Server will be completely within 
the Siebel application, the administrator still needs to administer the reports 
encyclopedia using Actuate Management Console. In order for the users to run 
reports in the Web Client and connected Dedicated Web Client, the administrator 
should have installed the Siebel Reports Server as described in either Chapter 1, 
“Installing the Siebel Reports Server for Microsoft Windows” or Chapter 2, 
“Installing the Siebel Reports Server for UNIX” depending on which operating 
system you are using.

NOTE: In the disconnected mode of the Dedicated Web Client, reports can only be 
run interactively and hence the Reports Server views will not be available.
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Reporting in the Web Client 
Siebel Reports Server allows Web Client users of Siebel eBusiness Applications to 
run reports both in interactive and batch modes. To run a report in a view, users 
first select View > Reports from the application-level menu. The report window 
appears and allows the user to select a report from the drop-down list of reports 
available in that view. This dialog also allows the user to select the Run Now option 
to run the report interactively, or the Schedule option to run the report in batch 
mode at a later time. The Schedule option displays a separate dialog for the user to 
enter the schedule parameters. 

System Architecture 
In this section, an overview of the Web Client report execution with Siebel Reports 
Server is described. The Reports Server encyclopedia consists of report executables 
and the user folders. These report executables correspond to the complete set of 
available reports among all the views. These executables run in the Reports Server 
factory process (a multi-threaded report execution process) at report execution time 
and generate the report output file (ROI) by obtaining data from the Siebel Object 
Manager. The report output (ROI) file will be stored in the user folder in the reports 
encyclopedia and can be accessed from the Reports Server views in Siebel eBusiness 
Applications. The report is executed by passing the parameter (ROV) file, which is 
generated by Siebel Object Manager when the user runs a report from a Siebel 
eBusiness Application view. 
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Figure 38 illustrates the report execution process from the Web Client. 

The following is the sequence of steps corresponding to Figure 38:

1 The request is submitted by the Web Client through the SES (Siebel Enterprise 
Server).

2 The Actuate e.Reporting Server runs the report and requests data from the SES 
through Siebel Reports Server Access.

3 The data is retrieved by the Siebel Object Manager from the database.

4 The Siebel Object Manager provides the data to the Reports Server.

5 The report is generated, and the SES retrieves the completed report status.

Figure 38. Server-Based Reporting for the Siebel Web Client
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6 The SES creates and passes the Actuate Active Portal report request to the Web 
Client.

7 The Web Client connects to Actuate Active Portal, which authenticates the user 
on the Reports Server.

8 The report in DHTML is displayed in the Web Client.

The report request submitted from the Web Client includes parameter for the 
current view, active query, sort specifications, and visibility rules. For all reports run 
in the batch mode (using Schedule option), the status of submitted report requests 
can be obtained from the Reports Server views.

NOTE: The user need not be logged into a Siebel eBusiness Application for the 
scheduled reports to be generated, since report generation by the Reports Server is 
asynchronous. The data for report generation is obtained from the Siebel Object 
Manager running under the Siebel Server.

User Interface and Process Flow
A user first chooses View > Reports from the application-level menu and selects 
the desired report to be run in the Reports window. Figure 39 illustrates the report 
window started from the Opportunities views.

Figure 39. Reports Window
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The fields of the Reports window are as follows:

■ Select a Report. From the drop-down list, select the report you wish to run. In 
this example, the report selected is Opportunities by Category.

■ Select the Language. From the drop-down list, select the language of the static 
text to be displayed in the report.

■ Locale. From the drop-down list, select the locale setting to use for formatting 
and displaying the report data.

The language and locale of the report are generated independently of the locale 
in which the user is currently running Siebel eBusiness Applications.

If no strings are found for the language and locale, labels and properties are 
defaulted to the original ROD file values for that report.

Then the user may indicate if the report should be run in interactive (Run Now) or 
batch (Schedule) mode:

■ Run Now mode: If the user has selected Run Now, there are no further dialogs. 
After Run Now is selected, the report will be displayed in the Web Client if it can 
be generated in 30 seconds or less, as defaulted in the Run Report Time Limit 
parameter. The default value of this parameter can be changed in View > User 
Preferences > Behavior. If the report generation takes longer than 30 seconds, 
the control is returned back to the Siebel Web Client and the message in 
Figure 40 will be displayed. However, the report generation will continue in the 
Reports Server irrespective of the Run Report Time Limit parameter value. In the 
Dedicated Web Client, the Run Now option is the Run option.

NOTE: The browser frame displaying the report in DHTML will automatically 
close if the user navigates to another view in the application. If the user requires 
the report to be displayed when navigating to other views, they should select the 
Download or Print option in the viewer to display the report in PDF format.

Figure 40. Run Report Time Limit Message
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To change the Run Report Time Limit parameter at the client level

1 From the application-level menu, select View > User Preferences.

2 Select the Behavior tab.

3 Enter a number in the Run Report Time Limit field to specify the number of 
seconds you are willing to wait to view the report.

The report will be generated in the Reports Server irrespective of the Run Report 
Time Limit parameter value.

■ Schedule mode: In the Web Client, this selection indicates that you wish to run a 
report in batch mode by scheduling the report for one-time or periodic 
generation. If Schedule is selected, the Schedule Report window appears, as 
shown below in Figure 41.

The Schedule Report window allows you to specify the time and date when the 
report is run, to select the option to generate the report with a recurring frequency, 
and to indicate if the report should be printed upon generation. You may also 
change the name of the report output file.

The fields of the Schedule Report dialog box are as follows:

■ Run at. The time of day for report generation.

■ On. For a one-time report, the date when the report is to be generated. For a 
periodic report, the first date the report is generated.

Figure 41. Schedule Report Window
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■ Repeat check box. Specifies whether the report is one-time or periodic. Checked 
if periodic, unchecked if one-time.

■ Until. Applies to periodic reports. This is the date after which the report is no 
longer run.

■ Print check box. If this box is checked, the report is printed to the specified system 
printer upon its generation in the Reports Server.

■ Printer name picklist. Allows the selection of a printer for report output on 
execution. The initially displayed printer name is the default printer specified in 
the user profile. The list of available printers is the set of printers administered 
for this purpose on the Reports Server.

■ Output Name. Specifies the pathname in the Report Encyclopedia for the ROI file 
to be generated each time the report runs. This pathname is of the following 
form:

/folder/reportname_language_locale.roi

Where:

folder can contain subfolders if necessary. The default value in the Report field 
is your default Report Encyclopedia folder, as specified in the Personal Profile 
view, followed by the same report name as the executable. You can specify a 
destination folder other than your own default folder, but it must be present on 
the Report Encyclopedia, and you must have access to it through a user list.

language represents the three-letter code of the language of the static text to be 
displayed in the report (for example: ENU for U.S. English).

locale represents the three-letter code of the locale setting used for formatting 
and displaying the report data (for example: ENU for U.S. English).

See Global Deployment Guide for a list of three-letter International Standards 
Organization (ISO) language extensions.

■ Report Server Date. Read-only field that indicates the equivalent Reports Server 
local date.

■ Report Server Time. Read-only field that indicates the equivalent Reports Server 
local time.
Version 7.5, Rev B Siebel Reports Administration Guide 365



Reporting in the Siebel Web Clients

Reporting in the Web Client
After a report has been generated, the report output (ROI file) is available to the user 
for viewing and printing in the Completed Request Notifications, My Reports, or 
Explorer views. These views are described in Chapter 17, “Siebel Reports Server 
Views.”

DHTML Report Viewer Keyboard Shortcuts
The generated report is viewed in the DHTML report viewer for the Web Client. For 
this viewer, the user interface functions are available as keyboard shortcuts. 
Table 38 lists the mapping of keyboard shortcuts to the buttons in the DHTML 
report viewer.

Table 38. DHTML Report Viewer Keyboard Shortcuts

Button Keyboard Shortcut

Save S

Print P

Report Navigation C

Search E

Go G

First Page F

Previous Page B

Next Page N

Last Page L
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Reporting in the Dedicated Web Client
Reports can be generated both in the connected and the disconnected mode of the 
Dedicated Web Client. In the disconnected mode of the Dedicated Web Client, 
reports can only be generated interactively by accessing data from the local Object 
Manager. Further, interactively run reports (both in connected and disconnected 
mode) are displayed in the ActiveX report viewer (not in the DHTML report viewer). 
Finally, reports can be generated in the batch mode (schedule) only in the 
connected mode of the Dedicated Web Client.

NOTE: Reports run locally in the disconnected mode of the Dedicated Web Client use 
the local Object Manager to retrieve data, while reports run on the Reports Server 
using the Siebel Object Manager. As a result, OLE interface methods are used only 
in the disconnected mode of the Dedicated Web Client.

System Architecture
In this section, the report execution in the Dedicated Web Client is described. The 
Reports Server encyclopedia and the Client consist of the report executables. These 
report executables correspond to the available reports among all the views. 

When a report is run interactively in the Dedicated Web Client (connected or 
disconnected mode), the corresponding report executable is started in the Client. 
The data for the report is obtained from the local Object Manager (see Figure 42), 
and the report is displayed in the ActiveX viewer in the Client. 

In the connected mode of Dedicated Web Client, users can submit report requests 
to be run in batch mode in the Reports Server. These requests are submitted to the 
Reports Server in the form of a parameter (ROV) file. At report execution time, the 
report executable obtains data from the Siebel Object Manager and generates the 
report output file (ROI). The report output (ROI) file will be stored in the user folder 
in the reports encyclopedia and can be accessed from the Reports Server views in 
Siebel eBusiness applications.
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Figure 42 illustrates the report execution in the Dedicated Web Client.

The following is the sequence of report generation steps (corresponding to 
Figure 42) in batch mode in the connected Dedicated Web Client:

1 The report request is submitted to the Reports Server through the SES (Siebel 
Enterprise Server).

2 The Reports Server runs the report executable and requests data from the SES 
through Siebel Reports Server Access.

Figure 42. Server-Based Reporting for the Siebel Dedicated Web Client
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3 Data is retrieved by the Siebel Object Manager from the database and provided 
to the Reports Server.

4 The Siebel Object Manager provides data to the Reports Server. The report is 
generated and saved in the Reports Server encyclopedia to be retrieved by the 
user on demand.

5 The Dedicated Web Client connects to Actuate Active Portal, which 
authenticates the user on the Reports Server.

6 The report, in ActiveX, is displayed in the Dedicated Web Client.

NOTE: The user need not be logged into a Siebel eBusiness application for the 
scheduled reports to be generated since report generation by the Reports Server is 
asynchronous and data for report generation is obtained from the Siebel Object 
Manager.

User Interface and Process Flow
The user interface and process flow section here is similar to the information in 
“Reporting in the Web Client” on page 360. The following information reflect any 
changes that are specific to the Dedicated Web Client.

Connected Mode
Dedicated Web Client reporting in the connected mode is identical to the procedures 
described in “Reporting in the Web Client” on page 360.

Disconnected Mode
Reports can be generated in the Dedicated Web Client in the disconnected mode 
also. However, the data for report generation is obtained from the local object 
manager. The report generation process in the disconnected mode differs from the 
connected mode as described below:

■ Reports are run locally by obtaining data from the local database.

■ Reports cannot be scheduled.

■ The Run Report Time Limit message is not available.
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ActiveX Report Viewer Keyboard Shortcuts
The generated report is viewed in the ActiveX report viewer (the Siebel Reports 
VIewer) for the Dedicated Web Client. For this viewer, the user interface functions 
are available as keyboard shortcuts. Table 39 lists the mapping of keyboard 
shortcuts to the buttons in the ActiveX report viewer.

Searching in the Siebel Report Viewer
In the DHTML report viewer, you can search in a report and export the results to a 
Comma Separated Value or Tab Delimited Value format.This functionality is added 
to the ActiveX report viewer in the 7.5 release. The new Search button is located 
next to the Table of Contents button. Essentially, the user interaction is the same as 
that in the DHTML report viewer.

For more information, see the “Searching in Actuate reports” chapter in Using 
e.Reports manual on the Siebel eBusiness Third-Party Bookshelf under Actuate.

Table 39. ActiveX Report Viewer Keyboard Shortcuts

Button Keyboard Shortcut

Open O

Save As S

Print P

Print Setup U

Send Report R

Table of Contents C

Search E

First Page F

Previous Page B

Next Page N

Last Page L

Go To Page G

Stop Report In Progress H
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This chapter describes the views available in the Reports Server and Application 
Administration sections of the Site Map for use by administrators and end users. 
Two of the views are used by administrators to administer user access rights and 
make changes to their own accounts. The other views are used by end users to 
obtain results of report generation jobs, to access completed reports, to grant others 
access to their reports, and to administer their passwords and defaults.
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The views described in this chapter appear in the Site Map (View > Site Map) 
under Reports Server in a Siebel eBusiness application. The only exception is the 
Reports Server Admin Profile view, which appears under Application 
Administration on the Site Map. While User Administration and Reports Server 
Admin Profile views are available only to the reports administrator, all other views 
are available to the end users.

Table 40 displays the Reports Server views available to end users and 
administrators. An “x” symbolizes that a view is available. A blank space 
symbolizes a view is not available.

Table 40. Availability of Reports Server Views

View End User Administrator

User Administration x

Reports Server Admin Profile x

Personal Profile x x

Scheduled Requests x x

Completed Requests Notifications x x

Active Requests x x

Explorer x x

My Reports x x
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User Administration View
The User Administration view is only available to an administrator. This view 
allows the administrator to automatically create and synchronize accounts for 
Siebel report users in the Actuate reports encyclopedia. The administrator can 
synchronize one account or multiple accounts at once from this view on an ongoing 
basis. It is recommended that the administrator run a query in this view to 
synchronize users in smaller buckets particularly when a large number of users 
should be synchronized.

As the result of synchronization, an account with the same user ID that appears in 
the Siebel applications is created on the Reports Server. Also, a default folder with 
this name is created on the Reports Server, and basic privileges such as read, write, 
and execute are granted to that user to access the folder. Each Reports Server 
account is created with the same user ID as the Siebel user ID and a password. This 
user ID and password are stored in an encrypted format in the Siebel database, to 
be passed to the Reports Server when needed.

The navigation path to this view is View > Site Map > Reports Server > User 
Administration. An administrator account is established in the Actuate 
encyclopedia as part of the postinstallation tasks of the Reports Server (see 
Chapter 1, “Installing the Siebel Reports Server for Microsoft Windows” or 
Chapter 2, “Installing the Siebel Reports Server for UNIX”). This account allows the 
administrator to log in to the Actuate Management Console to perform ongoing 
administration tasks such as administering the encyclopedia and cleaning up the 
encyclopedia. For more information, see “Maintaining the Actuate e.Reporting 
Server” on page 112.
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The User Administration view is shown in Figure 43.

This view has the following buttons and list columns:

■ Last Name. The last name of the user, as stored in the employee table.

■ First Name. The first name of the user, as stored in the employee table.

■ User ID. The Siebel user ID for each user, as stored in the employee table.

■ Job Title. The position of the employee.

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to generate a new form for entering the query 
criteria. The query results are displayed in the same applet from which the query 
was started.

Figure 43. User Administration View
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■ Synchronize All button. Click this button to create accounts (referred to as 
synchronization) for all displayed users in the Actuate encyclopedia. If a large 
number of users should be synchronized, please run a query to restrict the 
displayed list of users and then click Synchronize All. 

■ Synchronize One button. Click this button to transfer the currently selected user ID 
to the Actuate encyclopedia.

Reports Server Administrator Profile View 
The Reports Server Administrator Profile view is also only available to an 
administrator. This view allows an administrator to establish and change their 
password, to specify a default printer, and to select the directory in which the report 
output files are saved.

This view, unlike the others, is not under Reports Server on the Site Map (View > 
Site Map). This view is under Application Administration on the Site Map.

The Reports Server Administrator Profile view is shown in Figure 44.

This view contains the following fields:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Not used on this view.

Figure 44. Reports Server Administrator Profile View
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■ Login Name. This field displays the login name of the currently logged in user. It 
is read-only.

■ Default folder. The administrator's default Report Encyclopedia folder for storage 
of report output. By default, this folder has the same name as the administrator 
account. The administrator can specify an existing folder name other than the 
default folder name.

■ Default printer. The administrator may select the default printer to display in the 
schedule dialog.

■ Current Password. Current password of the administrator.

■ New Password. If an administrator wishes to change their password, the new 
password should be entered in this field.

Scheduled Requests View
The Scheduled Requests view displays the report requests scheduled by the user. If 
a report is frequently run, the next start time and frequency for that report are 
displayed in this view. 

The Scheduled Requests view is shown in Figure 45.

Figure 45. Scheduled Requests View
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This view contains the following buttons and list columns:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to run a query on the displayed records. The query 
results are displayed in the same applet from which the query was started.

■ Report Name. Name of the report executable to be executed.

■ Next Start Time. Date and time that the scheduled report will start running.

■ Repeat. Checked for a periodic report, and unchecked for all one-time scheduled 
reports.

■ Frequency. Not applicable if a one-time report is scheduled (the field is left 
blank). The frequency (Daily, Weekly and so on) of the scheduled report is 
indicated in this field.

Completed Request Notifications View
The Completed Request Notifications view provides information about the status of 
completed requests. All completed requests include a hyperlink to the report 
output.

The Completed Request Notifications view is shown in Figure 46.

Figure 46. Completed Request Notifications View
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This view has the following buttons and list columns:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to run a query on the displayed records in the 
view. The query results are displayed in the same applet from which the query 
was started.

■ Report Name. If the request was successful, a link to the report output (ROI) file 
appears here. Clicking the hyperlink displays the report in the DHTML Report 
viewer. If the report generation was unsuccessful, the report name field is left 
blank.

■ Version. Version number of this report output. Each time a report is run, a 
different version of that report is created. The highest-numbered version is the 
most recent.

■ Pages. Number of pages in the generated report, if it was successful.

■ Status. Success or Failure, depending on the outcome of the request.

■ Completed. Date and time that the report completed or aborted.

■ Status Detail. Explanation of the reason for failure, if this is an unsuccessful 
report run.
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Active Requests View
The Active Requests view provides a list of reports that are currently being 
generated. This view provides a means to check the status of large reports.

The Active Requests view is shown in Figure 47.

This view contains the following buttons and list columns:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to run a query on the records displayed in this 
view. The query results are displayed in the same applet from which the query 
was started.

■ Report Name. Name of the report executable that is being run.

■ Start Time. Date and time when report generation began.

Figure 47. Active Requests View
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Explorer View
The Explorer view displays a tree applet displaying the contents in the user's folder, 
and all other accessible reports in the encyclopedia, and a list applet displaying the 
related contents. Only those reports to which the user has access are shown.

In the tree applet (on the left side) of the Explorer view, the reports server folders 
are displayed hierarchically. The top-level (root) folder is identified with a slash (/
) symbol, and its top-level subfolders correspond to user account names. The top-
level folders may have administrator-defined subfolders. When a folder in the tree 
applet is selected, the list applet on the right side displays reports in that folder.

The Explorer view is shown in Figure 48.

This view contains the following buttons and list columns:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to run a query on the displayed records in the 
view. The query results are displayed in the same applet from which the query 
was started.

Figure 48. Explorer View
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■ Name. A subfolder name or a hyperlink to the report output (ROI) file. Clicking 
on the report name hyperlink displays the report in a DHTML report viewer.

■ Type. Indicates the type of contents displayed in the list applet. If reports are 
displayed, the Type field displays a ROI file extension. If a folder is displayed, 
“folder” is displayed in the Type field.

■ Pages. Number of pages in the generated report.

■ Last Updated. Date and time of the report run that generated this version.

My Reports View
The My Reports view displays the report output files that the user has access to in 
the Reports applet. This includes the reports generated by the user, and the reports 
that other users granted the user permission to view. 

The view also displays Users and Roles applets at the bottom of the view. The user 
may grant permission to other users and roles to view and print a report using these 
applets. First the user selects a report from the Reports applet. Then, users and roles 
are added by creating new records in the Users and Roles applets, respectively. 
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The My Reports view is shown in Figure 49.

This view contains the following buttons and list columns:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Query button. Click this button to run a query on the displayed records in the 
view. The query results are displayed in the same applet from which the query 
was started.

■ Report Name. The full pathname to the report output (ROI) file appearing as a 
hyperlink. Clicking the hyperlink displays the report in a DHTML report viewer.

■ Version Number. Version number of this report output. Each time a report is run, 
a different version of that report is created. The highest-numbered version is the 
most recent.

■ Pages. Number of pages in the generated report.

■ Last Updated. Date and time of the report run that generated this version.

Figure 49. My Reports View
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■ Display Roles button. Displays a list of roles that have been granted access to view 
a specific report. The button is located on the Roles applet.

■ Display Users button. Displays a list of users that have been granted access to view 
a specific report. The button is located on the Users applet.

Personal Profile View
The Personal Profile view allows a user to specify a default printer and file system 
folder for report output.

The Personal Profile view is shown in Figure 50.

The Personal Profile form contains the following fields:

■ Menu button. The menu contains actions that apply directly to the applet.

■ Login Name. This field displays the login name of the currently logged in user. It 
is read-only.

■ Default folder. The user's default folder on the report encyclopedia for storing 
report output files. By default, this folder name has the same name as the user 
ID. The user may specify a folder name other than the default folder, but it must 
already exist on the report encyclopedia, and the user must have access to it.

■ Default printer. The printer to which the report will be sent if the user selected 
print option in the schedule dialog while scheduling a report. This printer name 
appears in the schedule dialog when the user is scheduling a report. The user 
can choose a different printer at that time.

Figure 50. Personal Profile View
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This appendix presents reference information about the library components in the 
sscustom and sssiebel libraries.

sscustom Library
Components in the sssiebel library are subclassed in the sscustom library. The 
components in the sscustom library may be further subclassed within sscustom. 

All the components in the sssiebel library have a prefix of base; the corresponding 
descendent in the sscustom library start with ss. All additional descendents of ssTxt 
in the sscustom library are start with ssTxt.

This component relationship also applies to label controls, date controls, and the 
frame controls. The composite objects, ssReport and ssPageList, use slightly 
different naming conventions. The superclass for ssPage (landscape) is basePage, 
and ssPage is the superclass for ssPagePortrait. You must take care whenever you 
change the composite objects.

Text Controls
The following components are for displaying text:

■ ssTxt. Basic text control

■ ssTxtB. Bold text control

■ ssTxtBI. Bold italic text control

■ ssTxtBIueBack. Bold text control (white text on a blue background)

■ ssTxtChkBox. Check box control

■ ssTxtP. Percentage text control
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■ ssTxtS. Small text control

■ ssTxtSB. Small bold text control

■ ssTxtSBI. Small bold italic text control

■ ssTxtSectionHead. Section head text control

■ ssTxtSectionHeadM. Maroon section head text control

■ ssTxtSNoRepeat. Small text control used in calendar reports

■ space. Space control (aligns multiple text sections)

Actuate uses OLE automation to acquire data from the Siebel Application Server. In 
the first implementation of this architecture, all the data that is transferred is in the 
string data type format, including numeric and date information. The baseTxt 
control is the most appropriate method available for displaying string data.
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Actuate can implicitly convert string data to other control types; for example, String 
data will be converted to the date data type if the control being used is a date 
control. Unfortunately, the implicit conversion methods for date and numeric data 
are not appropriate under some conditions, particularly when you are providing 
multilanguage support. See Figure 51.

 

Figure 51 shows the steps that data goes through before it populates an Actuate 
control. All data that is brought through the OLE interface is placed in DataRow 
Variables as string data. Then Actuate, in the course of instantiating controls to the 
ROI page, takes the data from the row and populates the various controls.

As long as the information to be displayed is string data, no conversion takes place. 
This provides the best support for multiple languages and is the preferred method. 

Date information and revenue information are handled differently. Siebel Systems 
has developed methods that are appropriate for working with both date and revenue 
information.

Figure 51. Actuate Control Creation Process with Siebel Applications
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Display of Revenue Information
When you are creating datastreams with Siebel Tools, each field is mapped to a data 
row variable, of string data type. If the field is defined in the Siebel application as 
being a currency, then Siebel Tools will map two string variables into the data row:

■ ssFieldName

■ ssFieldName_Formatted

The standard revenue contains the value of the field, contained in a string (for 
example, “1243” or “1000000”). The formatted revenue will contain the value of 
the field with the appropriate formatting information for currency for that record 
(for example, “$1,243” or “£1.000.000”). As long as the data does not need to be 
used in a calculation, the formatted data field is the preferred display method. 
Standard revenue field (unformatted) is not used at all in reports due to its 
localization inability.

The following explains how Siebel reports handle calculated currency.

There are three steps involved in the calculation and display of currencies:

1 Convert the formatted currency string fetched from the Siebel application to a 
currency data type value that can be used in arithmetic operations, using the 
ToCur( ) wrapper.

2 Perform any calculations.
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3 Display the currency data using txtCurrency as the superclass for the layout 
field. This changes the calculated currency value back to a formatted string for 
display purposes. The details are given below.

Formatting currency string to number for calculation:

Problem: Actuate conversion functions such as CCur( ) or CDbl( ) do not 
correctly interpret a formatted currency string if any text is attached to the 
value. 

For example, CCur(DM 55,77) yields 0.

Solution: To assure proper conversion from string to number, use ToCur( ) 
defined in sssiebel.bas. This function removes any nonnumeric content from 
the string and then applies CCur( ) to the input string.

For example, ToCur(DM 55,77) yields 55,77

Formatting number to currency for display:

Problem: Actuate cannot format currency values for a specific currency code 
(Actuate can do it for the system currency only).

Solution: Use FormatSpecificCurrency( ), defined in sscustom.bas to make 
sure there is proper currency value formatting for a specified currency code.

Example: cur = FormatSpecificCurrency(55.77, USD)

One more issue to handle for currencies is multicurrency calculations.

Multicurrency processing is a long-existing issue for reports because of their 
inability to do conversion between currencies. A solution is to have two values 
(item and system currency) for any currency type field (revenue, cost, . . .). This 
way, we have a unified approach to the aggregation of different currency values. 
System currencies display line items in their item currency formats, and aggregate 
values are displayed in the system currency format. To support this idea, the 
business component that supplies a report with data must have each currency field 
in two flavors: Function-Currency-Value (system-based) and Currency-Value (item 
currency).
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If the text control represents the sum of multiple rows of data in the AFTER section, 
use the numeric revenue amount. The ValueExp property can be formulated as 
follows:

FormatSpecificCurrency(Sum(CurrencyValue),”USD”).

Actuate cannot sum formatted data, so the expression shown previously will be 
formatted by the FormatSpecificCurrency( ) function described in the sscustom.bas.

For multicurrency calculations, include the Functional Revenue (the revenue value 
in the functional currency) and the Functional Currency Code (for example, USD) 
in your report and subreport fields when you define the ROL file in Siebel Tools. For 
an example of multicurrency calculations, see the Pipeline Report By Rep (PIPEREP) 
standard report.

Display of Date Information

NOTE: The information described in this section concerning dates is for legacy Siebel 
reports. In version 7 reports, all newly created date fields must use Formatted date 
fields from Application and ssDateTimeControl from sscustom. This new Actuate 
control has verity of format options to pick including Short-Date, Long-Date and 
Medium-Date (same for time).

Date information is more complicated than revenue data. As with the currency 
information, each Report Object field is mapped to two variables in the data row:

■ ssDateFieldName. The standard field is in the format of Siebel’s internal date 
representation and is always in the format MM/DD/YY HH:MM:SS.
390 Siebel Reports Administration Guide Version 7.5, Rev B



Library Reference

sscustom Library
■ ssDateFieldName_Formatted. The formatted field comes in the format specified 
for the business component that is used to get the data, and it uses the locale 
settings of the machine. If the screen displays dates using the system short date 
format, the DataRow variable will be populated with 31/12/01, 12/31/01, or 01/
12/31, depending on the locale setting of the machine. 

The key factor is that the string does not need any additional formatting and can 
be displayed using the ssTxt control. Attempting to use the ssDate control with 
Date_Formatted information will cause a fatal error within Actuate e.Report 
Designer Professional or the Siebel application.

NOTE: Use ssTxt when using the formatted date.

To display the full month name, date, and year (November 24, 2001), use ssDate.

The ssDate control forces an explicit conversion of the string date expression using 
known settings. The string is then converted back into string format and displayed 
using the format from the Format property. If the string is an empty string, the 
control is detached from the frame so that no data is shown.

Five predefined date formats are used within the standard reports. ssDate, 
ssDateLongDate, and ssDateShortDate all use date settings from the regional locale 
settings on the machine. ssDateHNNAP and ssDateMMMMDDYYYY use hard-
coded format strings to display the information in a specialized format. The date 
library components are the following:

■ ssDate. Short date and standard time

■ ssDateHNNAP. Time with AM or PM, as in 12:55 AM

■ ssDateLongDate. Long date (regional setting)

■ ssDateMMMMDDYYYY. Date with text month, as in November 24, 2001

■ ssDateShortDate. Short date (regional setting)

You can modify the date formats in the sscustom library by changing the Format 
property of the date control. New date formats can be added by subclassing from 
ssDate. To change the Short Date or Long Date displays, change the regional settings 
on the machine.
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CanGrow Property
The CanGrow property is available to all ssTxt and ssDate controls. Presently, this 
availability is only in the Windows environment. In the UNIX environment, the 
CanGrow property is not available with the Reports Server.

Check Box Text Control
The ssTxtChkBox control displays Boolean information. A check mark is displayed 
whenever TrueCondition is TRUE. TrueCondition evaluates the DataValue of the 
control with the string expression in the TrueCondition Property; if they match, the 
condition is TRUE and the check mark is displayed.

You can adjust TrueCondition by changing the value of the TrueCondition property. 
The default property value is Y. 

The ssTxtChkBox control uses the Monotype Sorts font to display check marks. If 
the Monotype Sorts font is unavailable on the local machine, a 3 is displayed for 
TRUE conditions and “” for FALSE conditions. The code that controls this can be 
adjusted in the OnRow method of the control.

Percentage Text Control
The percentage text control is used to display string numeric data as a percentage. 
Table 41 shows the various rules for displaying the percentage strings.

The code used to format the data is in the OnRow method and can be modified to 
change the behavior for the control and its children.

Table 41. Percentage Data Conversion

Input Value Output Value

0 0

3.0 3%

3.3 3.3%
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Label Controls
The following label components are available in the sscustom library:

■ ssLblB. Bold label control

■ ssLblBI. Bold italic label control

■ ssLblHead. Header label control

■ ssLblHeadBlack. Header label control

■ ssLblQuotation. Quotation label control

■ ssLblSB. Small bold label control

■ ssLblSBI. Small bold italic label control

■ ssLblSectionHead. Section heading label control

The label control displays fixed text strings that you set at design time. To change 
the text of an individual control, you modify the text property in the component 
editor window or you modify the control directly by single-clicking the control 
twice.

The advantage of using multiple types of label controls is that it increases 
maintainability within the entire report library. For example, to change a font in all 
the text controls, you simply modify the font.FaceName property in the ssTxt 
control. To change all the row headings within the reports, you change the desired 
property in the ssLblHead control.

The controls in the sscustom library have intentionally been made generic and 
simple. The small bold label control (ssLblB) can be any font size, although the 
standard reports use a small font size of 8 points. 
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Frame Controls
The following frame components are available:

■ ssFrmRecordSeparator. Landscape frame that contains a line

■ ssFrmBlueBack. Landscape frame with blue background

■ ssFrmBlueBackP. Portrait frame with blue background

■ ssFrmGrayBack. Landscape frame with gray background

■ ssFrmGrayBackP. Portrait frame with gray background

All the ssFrm controls inherit from the baseFrm class. Any text control that is using 
the CanGrow function (CanGrow = TRUE) requires that its container frame be of 
type baseFrm or a type derived from baseFrm. If the container frame is not of type 
baseFrm, a run-time error will occur.

Use a portrait mode frame if the report is designed for portrait orientation. 

Pagelist and Child Components
The page controls are perhaps the most complicated feature in the Siebel report 
libraries. By default, Siebel reports use the ssPageList control. The pageList control 
is a container control that holds the list of all the pages. As each page is instantiated, 
it is added to the list as a persistent object.

The pageList component can add pages in landscape mode, portrait mode, or any 
custom page layout desired. Siebel reports ship with two basic page styles, the 
landscape style (ssPage) and the portrait style (ssPagePortrait).

To switch from landscape (default) to portrait, click the ssPage component, under 
the ssPageList component, and click Delete. This will drop the ssPage component 
and leave the slot blank. Then drag the ssPagePortrait component from the library 
and drop it onto the ssPageList component.

The report will now use a portrait-style page. Make sure that the frames used in the 
report have portrait dimensions. 
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To create a different page layout, you subclass from the basePage component. To 
create a new page from scratch that does not use any of the existing controls, you 
subclass directly from the AcSimplePageList control.

All the portrait style controls are inherited from the landscape controls. To modify 
the existing page layout, change the ssPage layout, then determine whether changes 
to the ssPagePortrait component are required.

All other controls on the ssPage and ssPagePortrait components descend directly 
from the sssiebel library components. Inheritance of page control components is as 
follows:

■ basePageList > ssPageList

■ basePage > ssPage > ssPagePortrait

■ baseFlow > ssFlow > ssFlow1 > ssFlowP

■ baseReportHeaderBar > ssReportHeaderBar > ssTitleBarP

■ basePrintBy > ssPrintBy > ssPrintByP

■ baseDateDisplay > ssDateDisplay > ssDateDisplayP

■ basePageNoDisplay > ssPageNoDisplay > ssPageNoDisplay

■ baseRptCreateBy > ssRptCreateBy > ssRptCreateByP

■ baseReportTitle > ssReportTitle > ssReportTitleP

■ baseLblSiebel > ssLblSiebel > ssLblSiebelP
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Miscellaneous Controls
All of the following controls have been placed in the sscustom library to allow future 
enhancements. These controls are not currently used in the standard reports:

■ ssCur. Currency control.

■ ssCurB. Bold currency.

■ ssFloat. Float control. 

■ ssInt. Integer control. 

■ ssSubPage. Subpage.

■ ssImageControl. Image control with no changes, placed for future support. The 
Image control is used to display bitmap images on the screen.

■ ssSummaryGraph. Graph control with enhanced Y-label support. The Graph 
control used in Siebel applications has been modified to allow increased control 
of the Y-labels.

Line Controls
The line controls are straightforward. Some property-level changes give the controls 
varying behavior or appearance.

■ LineControlP. Line control with portrait width

■ DblLine. Double-line control
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Section Components
The conditional and parallel sections have special roles:

■ ssConditionalSection. Conditional section. The conditional section control allows 
the selection of one of two frames based on a run-time condition. This function 
is displayed in the Quote Configuration report.

■ ssParallelSection. Parallel section. In general, frames are placed on the page 
sequentially. Parallel sections allow multiple frames to be filled on a page at the 
same time (that is, in parallel). See the Actuate product documentation for 
further information on the use of parallel sections.

The group, sequential, and report section controls inherit all their properties and 
methods directly from their superclasses in the sssiebel library without 
modification.

■ ssGrp. Group section

■ ssSeq. Sequential section

■ ssRpt. Report section
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sssiebel Library
All the commonly used components in the Actuate Foundation Class (AFC) library 
have been extended into the sssiebel library, shown in Figure 52. This section 
provides a list of the components in the sssiebel library and explains how they have 
been modified.

 

Figure 52. The sssiebel Library
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baseCur

baseDate

baseDateDisplay

Superclass AcCurrencyControl

Properties Font.FaceName 
Font.Size 

Arial
10

Methods None

Variables None

Notes Not used in existing standard reports but included in the library for 
completeness and possible future use. Components derived from baseTxt are 
used to display currency fields as described in “sscustom Library” on 
page 385.

Superclass baseTxt

Properties None

Methods OnRow

Variables None

Notes Parses the standard date string in ‘MM/DD/YY HH:MM:SS’ into a serial date 
data type. It then formats the date as a string according to the current locale 
setting. If the string is blank, the width becomes zero.

Superclass baseTxt

Properties LabelPrefix
ValueExp

“Date “
Format(Now(), 
“Short Date”

Methods Finish

Variables LabelPrefix
LabelSuffix

Property
Property

String
String

Notes Shows the report run date. The Short Date format is used as specified by the 
locale setting. baseDateDisplay concatenates the values in the LabelPrefix 
string and the labelSuffix string:

LabelPrefix & Format(Now(), “Short Date”) & LabelSuffix
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baseFlow

baseFlow1

Superclass AcTopDownFlow

Properties Position, Size

Methods AddHeader

Variables None

Notes The AddHeader method is modified to work with the CanGrow functionality.

Superclass baseFlow

Properties None

Methods None

Variables None

Notes The flow represents the area on each page in which the information from the 
data rows is displayed. baseFlow1 has been subclassed for future flexibility.
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baseFrm

baseGrp

Superclass AcFrame

Properties Size
AlternateColor
AlternateLines

Methods AdjustAssociatedControl
AdjustControlPositions
AdjustSize
BindToFlow
GrowFrame
Start

Variables AlternateColor
AlternateLines
MostRecentContainer
MostRecentFlow
OriginalSize
RowNumber
SomeThingGrew

Property
Property
Public
Public
Public
Public
Public

AcColor
Integer
AcReportComponent
AcFlow
AcSize
Integer
Boolean

Notes baseFrm has been modified to support CanGrow functions; no user-level 
adjustments should be made to the CanGrow function.

baseFrm no longer supports alternate line colors as of the Siebel 7 release.

Superclass AcTopDownFlow

Properties Page.ShowHeaderOnFirst True

Methods StartFlow
StartGroup

Variables None

Notes baseGrp has been modified to make it compatible with the CanGrow 
functionality.
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baseInt

baseLbl

baseLblSiebel

baseLineControlr
 

Superclass AcIntegerControl

Properties Font.FaceName 
Font.Size 

Arial
10

Methods None

Variables None

Notes Not used in existing standard reports.

Superclass AcLabelControl

Properties Font.Size 10

Methods None

Variables None

Superclass AcImageControl

Properties FileName “...\lib\ssLogo.bmp”

Methods None

Variables None

Notes Displays the Siebel corporate logo. Change FileName to place a different 
corporate logo on the report.

Superclass AcLineControl

Properties Position
EndPosition

Methods Start

Variables None
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basePage

Superclass AcPage

Properties Size.Height 8.27

Methods None

Variables None

Notes Determines the report’s page dimensions. Landscape mode is the default. 
Portrait mode is available in the sscustom Library. 

The basePage uses the least common denominators between A4 and 8.5x11 
so that the reports will display on a page of either size, as shown below:

If the reports will be printing on predominantly A4-size pages, you can 
modify the Position variable in the sscustom library to center the information 
on the page.

8.5 x 11 A4 Siebel Actuate Reports

Height 8.5 8.27 8.72

Width 11 11.69 11
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basePageList

basePageNoDisplay

Superclass AcSimplePageList

Properties LabelMidString
LabelPrefix
PageStyle
PageXofX
cstr_PageNoObject

“of “
“Page “
basePage
True
ssPageNoDisplay

Methods AddFrameToFlow
Finish
SetPageXofX
Start

Variables cstr_PageNoObject
LabelMidString
LabelPrefix
LabelSuffix
PageXofX

Property
Property
Property
Property
Property

String
String
String
String
Boolean

Notes The key feature of the basePageList component is the PageXofX property. If 
PageXofX is TRUE, the component specified in cstr_PageNoObject displays 
the following string: 

LabelPrefix & curPageNum & LabelMidString & TotalPages & LabelSuffix

The default display reads as Page X of Y, where X is the current page number 
and Y is the total number of pages.

NOTE: The cstr_PageNoObject variable is the name of the component 
that holds the page number. 

Superclass baseTxt

Properties None

Methods None

Variables None

Notes basePageNoDisplay is a blank control that is filled in by the 
basePageList.PageXofX code.
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basePrintBy

baseReport

Superclass baseTxt

Properties LabelPrefix “Printed By “

Methods Finish

Variables LabelPrefix
LabelSuffix

Property
Property

String
String

Notes basePrintBy uses a parameter passed by the Siebel client to show the user 
name of the person running the report. If the client fails to provide a user 
name for the report, the component displays the name of the user on the 
local operating system. As with the page number control, the basePrintBy 
control concatenates LabelPrefix, UserName, and LabelSuffix into one string, 
such as “LabelPrefix & UserName & LabelSuffix.”

Superclass AcReport

Properties Content
PageList

baseRpt
basePageList

Methods Start

Variable pubReportTitleg
ssBusObjectName
ssOLEServer
ssReportName
ssReportTitle
ssSearchSpec
ssUserName
ssViewMode

Public Variable
Parameter
Parameter
Parameter
Property
Parameter
Parameter
Parameter

String
String
String
String
String
String
String
String

Notes The baseReport component is required for all Siebel reports. The Siebel client 
passes these parameters to the report when a report is initiated. The report 
will not run if parameters are not defined correctly.

The ssReportTitle property allows the user to set the report name, 
independent of the report object definition in the repository. The report title 
is displayed in the header of the report and can be modified in the ssReport 
object for language customizations or company-specific name changes. 

The Start method moves the value in the ssReportTitle variable into the 
pubReportTitle variable so that it can be accessed from anywhere within the 
report. 
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baseReportHeader

baseReportTitle

baseRpt

Superclass baseLbl

Properties None

Methods None

Variables None

Notes baseReportHeader is the solid black bar that appears at the top of 
every report.

Superclass baseLbl

Properties None

Methods Finish

Variables None

Notes The baseReportTitle control looks up the name of the report specified in the 
ssReportTitle property of the ssReport (top object) and displays that 
information in the header of the report.

Superclass AcReportSection

Properties Page.ShowHeaderOnFirst
Page.ShowFooterOnLast

True
True

Methods BuildOnePass
StartFlow
StartGroup

Variables FirstRowFetched Public Boolean

Notes baseRpt has been modified to work with the CanGrow functionality in the 
text control.
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baseRptCreateBy

baseSeq

baseSubPage

Superclass baseLbl

Properties Text “Report Created by Siebel Software”

Methods None

Variables None

Notes baseRptCreateBy is a label string that can be used to add any text message 
that is common to every report.

Superclass AcSequentialSection

Properties TocAddComponent
TocAddContents

True
True

Methods None

Variables None

Superclass AcSubpage

Properties None

Methods None

Variables None
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baseTxt

Superclass AcTextControl True

Properties CanGrow
CharacterWrap
Font.FaceName
Font.Size
TextPlacement.MultiLine
TextPlacement.WordWrap

True
True
Arial
10
True
TextWordWrap

Method BuildFromRow
GetFormattedText
GetText
GrowControl

Variables AssociatedControl
CanGrow
CharacterWrap
ControlAdjusted
OriginalSize

Property
Property
Property
Public
Public

String
Boolean
Boolean
Boolean
AcSize

Notes By default, every Siebel text control can grow so that all the text in the control 
is displayed. You can change this function by modifying the CanGrow and 
CharacterWrap properties.

When a control grows, it adjusts its container (frame) to fit the new control 
size. In addition, it adjusts any controls that are underneath it to make room 
for the adjusted control.

You can enter the name of a label control in the AssociatedControl property 
to specify a persistent association between label control and text control.
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This appendix defines the DataStream function used when developing reports using 
Actuate. Also described are the three datastream methods used with Siebel standard 
reports. Sample code is included for each of the datastream methods. For more 
information, see Developing Advanced e.Reports, a part of the Actuate 
documentation set that is found on the Siebel eBusiness Third-Party Bookshelf under 
Actuate.

DataStream Function
In Actuate, the term datastream refers to a collection of components that deliver 
data to the report. Because Siebel data access is accomplished through the Siebel 
Object Manager, queries are executed outside the Actuate environment. The role of 
the datastream is to create the Siebel Object Manager interface and deliver the 
formatted data row to the report design. Siebel Tools defines the variables required 
to execute the Siebel Object Manager automation; their values are determined by 
the requirements of the report design. The datastream variables, with their types 
and functions, are listed in Table 42.

Table 42. Siebel Datastream Variables

Variable Type Function

SsAppServer Integer Created in the Start method of the datastream; set to the 
active Siebel application server.

ssBO Integer Created in the Start method; holds the value of the active 
business component.

SsBusCompName Integer Holds the value of the master business component for the 
active view in the Siebel client.
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Essential DataStream Methods
Three essential datastream methods are used in Siebel standard reports:

■ Start

■ Fetch

■ Delete

These are described in the sections that follow.

Start Method
The Start method has two prominent roles. It creates the Siebel Object Manager 
interface objects required to populate the data row, and it makes sure that the 
required fields are active. The Start method is called only on the master datastream. 
If a subreport uses the same business object, the subreport (child) datastream uses 
the interface created by the parent (master) datastream. Similarly, since fields are 
activated in the Start method, the master datastream activates fields for all its 
children.

NOTE: The code is written such that the user’s screen does not change while the 
report is being generated, even if a subreport uses a different business component.

The following code sample is from the Start method in the ssAccountQuery 
datastream component in the Aclist (Account List) report.

Function Start () As Boolean

   Dim bCurRowOnly  As Boolean

   Dim bReExecute   As Boolean

   Dim bUpdateLinks As Boolean

   Dim bStatus      As Boolean

   Dim mainRowId    As String
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   Dim busObjName   As String

   Dim SortSpecDyn  As String

   Dim searchSpec   As String

   Dim curViewMode  As Integer

   bCurRowOnly  = False

   baseReport::bCurRowOnly   = bCurRowOnly

   bReExecute   = False

   baseReport::bQueryExecuted = False

   bUpdateLinks = False

   errCode      = 0

   mainRowId    = ""

   busObjName   = ""

   bStatus = Super::Start ()

   If (bStatus = False) Then

      Start = False

      Exit Function

   End If

   ssAppServer = ssReport::ssiSiebelServer 

   ssModelSetPositionId (ssAppServer, ssReport::ssPositionId)
Version 7.5, Rev B Siebel Reports Administration Guide 411



Method Reference

Essential DataStream Methods
   ssBO = ssModelGetBusObject (ssAppServer, 
ssReport::ssBusObjectName)

   ssReport::ssActiveBusObject = ssBO

   ' SearchSpec is recieved depending on where it is originated

   SearchSpec = ""

If (ssReport::ssSearchSpec <> "") And (errCode = 0)  Then 
searchSpec = ssReport::ssSearchSpec 

   ' SortSpec is recieved depending on where it is originated

   SortSpecDyn = "Name"

If (ssReport::ssSortSpec <> "") And (errCode = 0)  Then 
SortSpecDyn = ssReport::ssSortSpec 

   If (errCode = 0) Then ssAccount = ssBusObjGetBusComp (ssBO, 
"Account")

   If (errCode = 0) Then ssBusCompSuppressNotification  (ssAccount)

   If (errCode = 0) And (ssType = 2) Then ssBusCompDeactivateFields 
(ssAccount)

   If (errCode = 0) Then curViewMode = ssBusCompGetViewMode 
(ssAccount)

   ' If the main report BusComp has a search or sort spec,

   ' or uses a field that isn't already active, its query

   ' must be re-executed.

   If (ssType = 2) Then bReExecute = True

   If (Not bReExecute)  Then bReExecute = (searchSpec <> "") Or 
(SortSpecDyn <> "")
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   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsExecuted", "") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Account 
Status") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "City") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Competitor") = 
"N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Country") = 
"N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Description") 
= "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Industry") = 
"N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Location") = 
"N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Main Fax 
Number") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Main Phone 
Number") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Name") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Parent Account 
Name") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Postal Code") 
= "N")
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   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "State") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Street 
Address") = "N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Synonym") = 
"N")

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "IsFieldActive", "Type") = "N")

   ' Last check if business component needs to be re-executed

   If (errCode = 0) And (Not bReExecute) Then bReExecute = 
(ssBusCompInvokeMethod (ssAccount, "ReExecuteReport", "") = "Y")

   ' Cache the current row-id so it can be re-queried

   If (bCurRowOnly) Then mainRowId = ssReport::ssActiveRowId

   If (errCode = 0) And (ssType = 1) And (bReExecute) Then

      ' To re-execute a current-row-only report, the active

      ' BusComp need not be disturbed.  Another BusObj can

      ' be constructed just for this query.

      ' This is NOT applicable for server based report generation.

      If (bCurRowOnly) And (ssReport::ssBusObjectName = "") Then

         baseReport::bQueryExecuted = True

         If Not ( ssAccount = 0 ) Then ssBusCompAllowNotification 
(ssAccount)

         If (errCode = 0) Then busObjName = ssBusObjGetName (ssBO)

         If (errCode = 0) Then ssBO = ssModelGetBusObject (ssAppServer, 
busObjName)

         If (errCode = 0) Then ssAccount = ssBusObjGetBusComp (ssBO, 
"Account")
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         If (errCode = 0) Then ssBusCompSetViewMode (ssAccount, 
curViewMode)

         If (errCode = 0) Then ssBusCompSuppressNotification  
(ssAccount)

      End If

   End If

   ' Now actually setup the main report BusComp

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Account 
Status")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "City")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Competitor")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Country")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Description")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Industry")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Location")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Main 
Fax Number")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Main 
Phone Number")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Name")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Parent 
Account Name")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Postal 
Code")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "State")
Version 7.5, Rev B Siebel Reports Administration Guide 415



Method Reference

Essential DataStream Methods
   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Street 
Address")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, 
"Synonym")

   If (errCode = 0) Then ssBusCompActivateField (ssAccount, "Type")

   If (errCode = 0) Then ssBusCompInvokeMethod (ssAccount, 
"SetIgnoreMaxCursorSize", "Y")

   If (errCode = 0) And (ssType = 2) And (bCurRowOnly = FALSE) Then

      If (baseReport::bSetForward) Then

         ssBusCompInvokeMethod(ssAccount, "GotoBookmarkT", 
ssReport::ssBookmark)

      Else

         ssBusCompInvokeMethod(ssAccount, "GotoBookmarkF", 
ssReport::ssBookmark)

      End If

   End If

   If (errCode = 0) And (searchSpec <> "") And ((Not bCurRowOnly) Or 
(ssReport::ssBusObjectName <> "")) Then

      ssBusCompSetSearchExpr (ssAccount, searchSpec)

   End If

   If (errCode = 0) And (SortSpecDyn <> "") Then

      ssBusCompSetSortSpec (ssAccount, SortSpecDyn)

   End If
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   If (errCode = 0) And (ssReport::ssBusObjectName <> "") And 
(ssReport::ssViewMode <> "") Then ssBusCompSetViewMode (ssAccount, 
CInt (ssReport::ssViewMode))

   ' Re-execute business components as necessary

   If (errCode = 0) Then

      If (bReExecute) Then

         If (bCurRowOnly) And (mainRowId <> "") Then             
ssBusCompSetSearchExpr (ssAccount, "Id = """ + mainRowId + """")

         If (errCode = 0) Then ssBusCompExecuteQuery2 (ssAccount, 
baseReport::bSetForward, True)

      Elseif (bUpdateLinks) Then 

         ssBusCompInvokeMethod (ssAccount, "UpdateLinks", "")

      End If

   End If

   ' Process errors and return

   If (errCode = 0) Then

      bStatus = True

   Else

      bStatus = False

      ssProcessLastError(ssAppServer, "", "")

   End If

   Start = bStatus

End Function
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At this point, the Siebel business component, in this case Account, has been 
exposed to Actuate, and the Siebel Object Manager interface has been called. The 
fields for the business object identified by the Siebel client’s active view have been 
activated and are available to the data row object. 

Fetch Method
The Fetch method performs three functions: 

1 Positions the Siebel Object Manager interface to a single row in the business 
object.

2 Creates a blank instance of the data row.

3 Populates the data row by calling methods on the business component Siebel 
Object Manager interface. 

The following code sample is from the Fetch method in the ssAccountQuery 
datastream component in the Aclist (Account List) report.

Function Fetch () As AcDataRow

   Dim    bStatus     As Boolean

   Dim    bCurRowOnly As Boolean

   Dim    custDataRow As ssAccountDataRow

   Dim    theBC       As Integer

   errCode = 0

   bStatus = False

   bCurRowOnly = False

   theBC = ssAccount

   If (bCurRowOnly = True) Then
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      If (Position = 1) Then

         If (baseReport::bQueryExecuted = True) Then

            bStatus = ssBusCompFirstRecord (theBC)

         Else

            bStatus = True

         End If

      End If

   Else

      If (Position = 1) Then

         bStatus = ssBusCompFirstRecord (theBC)

         If (errCode = 0) And (baseReport::bSetForward) Then 
ssBusCompInvokeMethod (theBC, "SetForwardOnly", "")

      Else

         bStatus = ssBusCompNextRecord (theBC)

      End If

   End If

   If (bStatus = True) And (errCode = 0) Then

      Set custDataRow = NewDataRow

      If (errCode = 0) Then custDataRow.ssAccount_Status = 
ssBusCompGetFieldValue (theBC, "Account Status")

      If (errCode = 0) Then custDataRow.ssCity = 
ssBusCompGetFieldValue (theBC, "City")

      If (errCode = 0) Then custDataRow.ssCompetitor = 
ssBusCompGetFieldValue (theBC, "Competitor")
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      If (errCode = 0) Then custDataRow.ssCountry = 
ssBusCompGetFieldValue (theBC, "Country")

      If (errCode = 0) Then custDataRow.ssDescription = 
ssBusCompGetFieldValue (theBC, "Description")

      If (errCode = 0) Then custDataRow.ssIndustry = 
ssBusCompGetFieldValue (theBC, "Industry")

      If (errCode = 0) Then custDataRow.ssLocation = 
ssBusCompGetFieldValue (theBC, "Location")

      If (errCode = 0) Then custDataRow.ssMain_Fax_Number = 
ssBusCompGetFormattedFieldValue (theBC, "Main Fax Number")

      If (errCode = 0) Then custDataRow.ssMain_Phone_Number = 
ssBusCompGetFormattedFieldValue (theBC, "Main Phone Number")

      If (errCode = 0) Then custDataRow.ssName = 
ssBusCompGetFieldValue (theBC, "Name")

      If (errCode = 0) Then custDataRow.ssParent_Account_Name = 
ssBusCompGetFieldValue (theBC, "Parent Account Name")

      If (errCode = 0) Then custDataRow.ssPostal_Code = 
ssBusCompGetFieldValue (theBC, "Postal Code")

      If (errCode = 0) Then custDataRow.ssState = 
ssBusCompGetFieldValue (theBC, "State")

      If (errCode = 0) Then custDataRow.ssStreet_Address = 
ssBusCompGetFieldValue (theBC, "Street Address")

      If (errCode = 0) Then custDataRow.ssSynonym = 
ssBusCompGetFieldValue (theBC, "Synonym")

      If (errCode = 0) Then custDataRow.ssType = 
ssBusCompGetFieldValue (theBC, "Type")

      ' Now retrieve the system fields

      If (errCode = 0) Then custDataRow.ssId = ssBusCompGetFieldValue 
(theBC, "Id")

      If (errCode = 0) Then custDataRow.ssCreated = 
ssBusCompGetFieldValue (theBC, "Created")
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      If (errCode = 0) Then custDataRow.ssCreated_Formatted = 
ssBusCompGetFormattedFieldValue (theBC, "Created")

      If (errCode = 0) Then custDataRow.ssCreated_By = 
ssBusCompGetFieldValue (theBC, "Created By")

      If (errCode = 0) Then custDataRow.ssUpdated = 
ssBusCompGetFieldValue (theBC, "Updated")

      If (errCode = 0) Then custDataRow.ssUpdated_Formatted = 
ssBusCompGetFormattedFieldValue (theBC, "Updated")

      If (errCode = 0) Then custDataRow.ssUpdated_By = 
ssBusCompGetFieldValue (theBC, "Updated By")

      Set Fetch = custDataRow

      AddRow (Fetch)

   Else

      Set Fetch = Nothing

   End If

   If (errCode <> 0) Then

      ssProcessLastError(ssAppServer, "", "")

   End If

End Function
Version 7.5, Rev B Siebel Reports Administration Guide 421



Method Reference

Essential DataStream Methods
In this example, the value of bStatus defines the position of the first data row. While 
bStatus is true, custDataRow continues to pass rows until no values are returned. 
The SetForwardOnly method makes sure that all rows are processed and that 
duplicate rows are not passed. 

NOTE: Because all data is returned as strings, two methods are called on the 
GetFieldValue business component Siebel Object Manager interface variable (for all 
data types) and on GetFormattedFieldValue (for date, currency, and other data types 
that require formatting). 

GetFieldValue and GetFormattedFieldValue are described in Table 43.

NOTE: These calls to the two methods are no longer done directly. Instead, these are 
called as ssBusCompGetFieldValue and ssBusCompGetFormattedFieldValue. These 
methods are implemented in sssiebel.bas and call the above mentioned methods.

Table 43. GetFieldValue and GetFormattedFieldValue

Method Comments

GetFieldValue Gets the raw data value. Dates are always mm/dd/yy 
hh:mm:ss. Numbers and currency are always strings. Can be 
used to sum numeric values.

GetFormattedFieldValue Uses the format specified in the Siebel client. Called by default 
for each currency field (“$1,234.34”). Called by default for any 
date field (“01/12/31”). Numeric values cannot be summed.
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Delete Method
The Delete method destroys the datastream object and frees system resources. In 
the example below, custom code has been added before the Delete method on the 
superclass is called. Note that ssAcount has handled the deletion duties for its child 
datastreams and has handed the calls back to the server (EnableNotify).

The following code sample is from the Delete method in the ssAccountQuery 
datastream component in the Aclist (Account List) report.

Sub Delete ()

   ssRestoreActiveRow (ssAccount)

   If Not (ssAccount = 0) Then ssBusCompInvokeMethod (ssAccount, 
"SetIgnoreMaxCursorSize", "N")

   If Not (ssAccount = 0) Then ssBusCompAllowNotification (ssAccount)

   ssAccount = 0

   Super::Delete ()

End Sub

Reports frequently have multiple report sections nested within one another to 
display detail, summary, or related data. Each report section requires a separate 
datastream component, and it is desirable that the datastreams be nested as well. 
This allows the master datastream to perform Start and Delete tasks for the child, 
enhancing efficiency. 

The roles of the master datastream are:

■ To create the Siebel Object Manager interface handling calls to the server

■ To activate all fields for itself and its children

■ To decide whether a query needs to be executed again in order to accommodate 
a sort specification

■ To delete itself and all its children
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The roles of the child datastream are:

■ To fetch DataRows

■ To format the fields as required

■ To perform sort specifications

NOTE: Master datastreams do not have numbers appended to their names.
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This appendix summarizes the List Of Values used in Smart Reports and indicates 
how they are currently used in the graphical elements. For more information see, 
Chapter 12, “Smart Reports.”

List of Values
The following tables list the List Of Values used by certain Smart Reports.

Opportunity Detail Report
Table 44 lists the List Of Values used with the Opportunity Detail report.

Table 44. Opportunity Detail Report List Of Values

Graphical 
Element List of Values Used

Thermometer 
Variable Calculation Point Comment

Buying 
Influencers 
Thermometer

NA

NA

NA

NA

Trigger Value

Max Value

Min Value

Data Value ssList_Of_ValuesQuery3

The weighted average score is 
calculated based on LOV types 
CONTACT_ROLE, 
TAS_POLITICAL_ANALYSIS, 
and TAS_ORG_STATUS.

Probability 
Thermometer

Order_By

Target_High

Target_Low

Rep_

Trigger Value

Max Value

Min Value

Data Value

Content - Probability 
Thermometer (under 
Content - frmProbability)

The probability of the 
opportunity in Rep_field of the 
opportunity displayed.

Deal Size 
Thermometer

Order_By

Target_High

Target_Low

Functional_Revenue

Trigger Value

Max Value

Min Value

Data Value

Content - Deal Size 
Thermometer (under 
rptDealSizeThermometer)

The LOV values associated 
with Functional Revenue field 
are used.
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Account Service Detail Report
Table 45 lists the List Of Values used with the Account Service Detail report.

Table 45. Account Service Detail Report List of Values

Graphical 
Element List Of Values Used

Thermometer 
Variable Calculation Point Comment

Revenue 
Thermometer

Order_By

Target_High

Target_Low

totalRevenue

Trigger Value

Max Value

Min Value

Data Value

dsRevenueLOV

dsRevenueLOV

dsRevenueLOV

sifAllOpportunities

Total Revenue for the 
account relative to the 
average of across all 
accounts is shown.

Open Service 
Request 
Thermometer

avgOpenSRs

0

countOpenSRs

Trigger Value

Max Value

Min Value

Data Value

dsTargetOpenSrsLOV

Local

Local

sifAllServiceRequests

The count of the open 
service requests for 
this account relative to 
the average across all 
accounts is shown.

Customer 
Satisfaction 
Thermometer

Order_By

Target_High

Target_Low

NA

Trigger Value

Max Value

Min Value

Data Value

ssList_Of_ValuesQuery1

ssList_Of_ValuesQuery1

ssList_Of_ValuesQuery1

Local

The ratio of total 
customer satisfaction 
score to the total 
number of surveys 
shown.
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Account Summary Report
Table 46 lists the List Of Values used with the Account Summary report.

Pipeline Analysis Report
Table 47 lists the List Of Values used with the Pipeline Analysis report.

Table 46. Account Summary Report List of Values

Graphical 
Element

List Of Values 
Used

Thermometer 
Variable Calculation Point Comment

Past Revenue 
Thermometer

Order_By

Target_High

Target_Low

totalRevenue

Trigger Value

Max Value

Min Value

Data Value

qryPastRevenueListOfValues

qryPastRevenueListOfValues

qryPastRevenueListOfValues

qryPastRevenue

Sum of revenues for 
the opportunities 
associated with an 
account is displayed.

Pipeline 
Thermometer

Order_By

Target_High

Target_Low

Pipeline Revenue

Trigger Value

Max Value

Min Value

Data Value

qryPiplineListOfValues

ftrPipelineThermometer

Pipeline revenue for all 
opportunities 
associated with an 
account is displayed.

Customer 
Satisfaction 
Thermometer

Order_By

Target_High

Target_Low

NA

Trigger Value

Max Value

Min Value

Data Value

qryCustomerSatisfactionList_Of_
Values (all)

The ratio of total 
customer satisfaction 
score to the total 
number of surveys is 
shown.

Table 47. Pipeline Analysis Report List Of Values

Graphical 
Element List Of Values Used

Thermometer 
Variable Calculation Point Comment

Revenue versus 
All Current 
Quotas 
Thermometer

totalQuota

(Calculated)

(Calculated)

0

ExpectedRevenueNext4Q

Trigger Value

Acceptable Range

Max Value

Min Value

Data Value

sifQuota

dsTargetQuotaRange

Local

Local

frmDashboard

Sum of revenues for the 
next four quarters is 
displayed. Also displayed 
is a dashed line below 
the trigger that indicates 
a revenue level that is 
acceptable, but below 
the target.
Version 7.5, Rev B Siebel Reports Administration Guide 427



Smart Reports List of Values

List of Values
428 Siebel Reports Administration Guide Version 7.5, Rev B



Index
Numerics
7.0, upgrading custom reports to 110

A
Access Base DB Name property, report 

object type 105
Account Service Detail report, described 

and hierarchy of data 262
Account Summary report, described and 

hierarchy of data 261
AcList Variables, table of 219
Active Requests view, about and screen 

example 377
Actuate Active Portal

Siebel Reports Server component 
described 57

Actuate Basic file, described 89
Actuate design files

about and screen example 94
structure and node types 94

Actuate development environment
Actuate file types 89
Actuate libraries 92
directory structure 91

Actuate e.Report Designer
about and installing 48

Actuate e.Report Designer Professional
about and installing 47
Siebel Reports Server component 

described 20
Actuate e.Report Designer, Siebel Reports 

Server component described 20
Actuate e.Reporting Server

component, about 57
installing 22

note, installing and performance 24, 60
Siebel Reports Server component 

described 19
Actuate file types 89
Actuate graph types, and corresponding 

Siebel chart type 240
Actuate libraries

data supply library file, described 92
sscustom library, described 92
sssiebel BASIC file, described and 

inheritance structure diagram 92
sssiebel library, described 92

Actuate Management Console
about and installing 26
Siebel Reports Server component 

described 19, 57
Actuate ReportCast

about 57
installing 63
note, installing and performance 24, 60
ReportCast Web server extension, 

configuring 70
Siebel Reports Server component 

described 19
ActuateDevWBDir parameter, Tools.cfg 

configuration file 110
AFC library

components, specific use in reports

B
backing up, report design and library 

files 115
bar charts. See graphs
BAS file, (BASIC source code) 

described 89
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BAS file, Actuate Basic file described 88
baseCur, sssiebel library component 397
baseDate, sssiebel library component 397
baseDateDisplay, sssiebel library 

component 397
baseFlow, sssiebel library component 398
baseFlow1, sssiebel library 

component 398
baseFrm, sssiebel library component 399
baseGrp, ssSiebel library component 399
baseInt, sssiebel library component 400
baseLbl, sssiebel library component 400
baseLblSiebel, sssiebel library 

component 400
baseLineControlr, sssiebel library 

component 400
basePage, sssiebel library component 401
basePageList, sssiebel library 

component 402
basePageNoDisplay, sssiebel library 

component 402
basePrintBy, sssiebel library 

component 403
baseReport, sssiebel library 

component 403
baseReportHeader, sssiebel library 

component 404
baseReportTitle, sssiebel library 

component 404
baseRpt, sssiebel library component 404
baseRptCreateBy, sssiebel library 

component 405
baseSeq, sssiebel library component 405
baseSubPage, sssiebel library 

component 405
baseTxt, sssiebel library component 406
BASIC source code file, described 89
Before section, component described 181
Business Component property

parent report object definition, setting 
in 139

report object type, described 105

C
CanGrow property, controls available 390
charts. See graphs
check box text controls, sscustom 

library 390
Class Property, report object type 105
Class tab, described 123
Compare method, using on the sort data 

filter 231
Completed Requests view, about and screen 

example 375
Component Editor

graph property settings, using to set 241
window properties, described 123

component naming conventions 383
composite datastreams

combined datastream, using Fetch 
method 230

concept described 205
data filters, types of for memory sort 

report 218
datastream class variables, table of 206
debugging tips 213
detail datastream, using Fetch 

method 227
global data row variable, creating in the 

report design 209
global datarow variable, creating in the 

report design 209
global variables in controls, 

referencing 212
master datastream component, 

modifying 210
master datastream, using Fetch 

method 227
reports, about using in 207

conditional section, library reference 395
content frame component, simple list report 

structure 132
content node, about 94
copying

report design 152
report object definition 151
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corporate logo
all reports, replacing on 126
baseLblSiebel library component, 

described 400
current query, restricting report data 

with 96
custom component library, using 153
Custom library. See sscustom library
custom reports, upgrading to 7.0 110

D
dashboard

Smart Reports, described 260
thermometer, positioning on 278

data definition
data row component, viewing 

contents 104
data supply ROL files, about 102
datastream component, viewing 

contents 103
object types, list of 105, 109
ROL, ROD, and ROX filenames, 

relationships between 101
data filters, types of for memory sort 

report 218
data information, about and format 388
data row component

See also datastream components
Compare method, using to resort 231
contents, viewing 104
purpose 205

data supply library file
described 92
relationships with other files 101

datastream components
about and table of variables 407
combined datastream, using Fetch 

method 230
component, described 131
composite datastreams, about using in 

reports 207
concept, described 205

data filters, types of for memory sort 
report 218

datastream class variables, table of 206
datastream object, destroying using 

Delete method 421
debugging tips 213
detail datastream, using Fetch 

method 227
Fetch method, about and code 

example 416
global data row variable, creating in the 

report design 209
global variables in controls, 

referencing 212
master datastream component, 

modifying 210
master datastream, using Fetch 

method 227
sequential report section, using same 

datastream 115
Start method, about and code 

example 408
viewing contents 103

datastream node, about 95
DataValue, ssThemometer parameter 

described 272
date

sssiebel library component that parses 
date string 397

sssiebel library component, shows 
current date 397

Dedicated Web Client
Siebel Reports Server, enabling for use 

with 38, 72
Dedicated Web Client reporting

user interface and process flow 365
Delete method, about and code 

example 421
Design Editor window, structure and 

components 94
design file. See ROD file (Report Object 

Design)
detail graphs, described 238
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Actuate file types 89
Actuate libraries 92
directory structure 91

DHTML file, described 90
directory structure

development directory, described 91
executables directory, described 91
libraries directory, described 91
standard reports directory, described 91

dynamic, versus static reports 114

E
emailing reports 116
employee records, transferring user 

IDs 371
executable file, Report Object Executable 

file, described 89
executables directory

described 91
locale-specific report executable 97

Explorer view, about and screen 
example 378

F
Fetch method

about and code example 416
combined datastream, using and code 

example 230
detail datastream, using and code 

example 227
master datastream component, using to 

modify 210
master datastream, using and code 

example 227
fonts, changing in all reports 120
frame components, available in sscustom 

library 392
Functional 281

G
GetFieldValue, Fetch method 420
GetFormattedFieldValue, Fetch 

method 420
global layout customization 119
global list variable, described and creating 

in the report design 226
global variables, referencing 212
graphics. See graphs
graphs

Actuate graph types and corresponding 
Siebel chart types, table of 240

categories of 238
defined and example 238
example, creating a report with 

graphics 256
graph properties, table of 241
HLC graph, about 239
property settings, accessing 241
sample report, Opportunities 

Pipeline 251
Siebel-generated graphics, passing to 

Smart Reports 280
group breaks in reports. See group section
group section

See also group totals
about 155
component, described 158, 181
report with group section, 

examining 158
structure diagram and components 157

group section, example creating report
See also group totals
about 162
compiling and testing the report 173
label and data elements, adding to the 

design 170
new report object definition, creating by 

copying 163
report design file, creating in Actuate 

e.Report Designer Professional 165
group totals
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example creating report

about 174
example, adding revenue totals to the 

group section 174

H
HLC graph, about 239

I
implicit conversion of string data 385
inheritance of components, diagram 93
installation, Siebel-Actuate reporting 

issues 109
installing

Actuate ReportCast 63
Siebel Reports Server 65

instance file. See ROI file (Report Object 
Instance)

K
Key property, described in group section 

component 161

L
label components, available in sscustom 

library 391
landscape, switching from portrait to 392
layout pane, Design Editor window 94
libraries directory, described 91
library component, changes to 119
library files

backing up 115
data supply, about 102

line controls, about 394
logo

all reports, replacing on 126
sssiebel library component 400

M
master datastream component

described 181
modifying using Fetch method 210

master report section, component 
described 181

master-detail reports
described and example 177
existing master-detail report, 

examining 182
multiple subreports, example 178
structure diagram and components 180

master-detail reports, example creating a 
report

about 185
compiling and testing the report 197
custom component library, creating 188
datastreams, adding to the report 

design 194
frame, data control, and label elements, 

adding to the design 194
master-detail report design, creating in 

Actuate e.Report Designer 
Professional 190

new report object definition, creating by 
copying 185

MaximumValue, ssThermometer parameter 
described 272

memory data buffer component, using to 
sort data 219

memory sort report, how it works
AcList variables, methods available 

about 219
data filters, about 218
report design, structure of 220

memory sorting
many-to-many relationship, examining 

report based on 233
multi value field, examining report sorted 

on 223
multi value field, sorting on 216
records from a many-to-one relationship, 

sorting on 217
memory structures, AcList variables, 

methods available 219
Menu Text property, report object type 106
Methods tab, described 123
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migration
sssiebel BASIC file, considerations 115
upgrading custom reports to 7.0 110

MinimumValue, ssThermometer parameter 
described 272

multi value field
report, examining report sorted on 223
sorting on 216

multiple subreports, example in master-
detail reports 178

My Reports view, about and screen 
example 379

N
nodes types, described 95

O
object types, list of 105
Opportunities Pipeline report

displaying report 251
property settings, table of 254
report structure 253

Opportunity Detail report
described and hierarchy of data 261
report sections 281

order-of-merit indicator, about and 
example 269

P
page

defined and positioning thermometer 
on 278

layout, creating and modifying 393
sssiebel library component, determine 

page size 401
sssiebel library component, using to show 

current page and total number of 
pages 402

page header frame component, simple list 
report structure 132

pageList control, about and switching from 
landscape to portrait 392

pagelist node, about 95

pagelist section component, simple list 
report structure 132

parallel section, library reference 395
percentage text control, about and table of 

conversions 390
Personal Profile view, about and screen 

example 381
pie charts. See graphs
Pipeline Analysis report, described and 

hierarchy of data 261
portrait, switching from landscape to 392
Properties tab, described 123

Q
Quota Summary report, described and 

hierarchy of data 262

R
records, merging. See memory sorting
referencing a component 95
report design

backing up, about 115
component, described 181
component, simple list report 

structure 131
copying 152
diagram and components 220
global data row variable, creating 209
global datarow variable, creating 209
inheritance structure of components in 

file, diagram 93
Report Encyclopedia, importing Siebel 

Report files to 67
Report Field object type, described 107
Report Locale Object Type, described 107
report node, about 94
report object

copying definition 151
executable file, relationship between ROL 

and ROD filenames 101
Report Object type, used in Tools to define 

report structure 105
Report Object Design file. See ROD file 

(Report Object Design)
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Report Object Executable file, 
described 89

Report Object Instance file. See ROI file 
(Report Object Instance)

Report Object Library file
data supply, about 102
described 89

report requests
Active Reports view, using to view reports 

being generated 377
Complete Requests view, using to view 

status of requests 375
report section component, simple list report 

structure 131
report server

report output files available, about using 
Explorer view to view list 378

Report Server. See Siebel Reports Server, 
installing; Siebel Reports Server, post 
installation tasks

report, example sorted on a many-to-many 
relationship

generating report 233
report design, opening 233

report, example sorted on a multi value field
combined datastream, Fetch method 

on 230
detail datastream, Fetch method on 227
generating the report 223
global list variable, creating in the report 

design 226
master datastream, Fetch method 

on 227
report design, opening 223
sort data filter, using Compare 

method 231
Reports Server Admin Profile view, about 

and screen example 373
Reports Server views

Active Requests view, about and screen 
example 377

Completed Requests view, about and 
screen example 375

Explorer view, about and screen 
example 378

My Reports view, about and screen 
example 379

Personal Profile view, about and screen 
example 381

Scheduled Requests view, about and 
screen example 374

User Administration view, about and 
screen example 371

reports. See master-detail reports; simple list 
reports; parameterized reports; server-
based reporting; copying

revenue information, sscustom library, 
about and format 386

ROD file (Report Object Design)
about and screen example 94
about and where name is specified 101
described 89
developing directory location, about 91
structure and node types 94

ROD file. See ROD file (Report Object 
Design)

ROI file (Report Object Instance)
control not seen or disappeared, note 90
described
email, sending as 116

ROI file. See ROI file (Report Object 
Instance)

ROL file (Report Object Library)
data supply, about 102
described 89

ROL file. See ROL (Report Object Library)
ROX file (Report Object Executable) file, 

described 89
ROX file, Report Object Executable file, 

described 89

S
Schedule For Later option, about 362
Scheduled Requests view, about and screen 

example 374, 375
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type 106

sequential section, component 
described 181

server-based reporting
See also Reports Server views
user interface and process flow 358, 365

Service Request Aging Analysis report, 
described and hierarchy of data 262

Siebel application-Actuate interaction
about, screen example, and 

implementation of menu options in 
view 96

Siebel report, viewing relationship 
between Actuate and Siebel 
software 98

Siebel chart type, corresponding to Actuate 
graph type 240

Siebel corporate logo, sssiebel library 
component 400

Siebel Report files, importing to Report 
Encyclopedia 67

Siebel Report Server Access
about 57
installing 30, 64
Siebel Reports Server component 

described 19
template files, configuring 34

Siebel Reports Server
components 19

Siebel Reports Server, installing
Actuate e.Report Designer Professional, 

about and installing 47
Actuate e.Report Designer, about and 

installing 48
Actuate e.Reporting Server, installing 22
Actuate Management Console, about and 

installing 26
Actuate ReportCast, installing 63
components, list of 57
installation order, described 24, 60
installation procedure 65
Siebel Report Server Access, 

installing 30, 64

Siebel Reports Server, post-installation tasks
Siebel Reports Server files, importing 67

Siebel Reports Server, postinstallation tasks
Dedicated Web Client, enabling the 

Report Server for use with 38, 72
Siebel-generated graphics, passing to Smart 

Reports 280
simple list reports

components and structure diagram 131
custom component library, using 153
examining existing list report 132
existing report object definition and 

children, copying 151
new report creation, situations for 129
report design, copying 152
report object definition, copying 151

simple list reports, creating report example
about 136
compiling and testing the report 148
label and data elements, adding to the 

design 146
new report object definition, 

creating 137
report design file, creating in Actuate 

e.Report Designer Professional 141
Smart Reports

See also thermometer
components 266
contents of 260
graphical elements 263
order-of-merit indicator, about and 

example 269, 270
purpose of 259
Reports drop-down list, about 263
standard Smart Reports, table of 261
structure diagram 265

Smart Reports, designing example
graphical components 281
Opportunity Detail Report sections 281
other components 282

sort data filter, using Compare method 231
Sort Specification Property, report object 

type 106
sort specification. See group section
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relationship 217
records from a many-to-many 

relationship, example 233
Srviewer application 116
ssAppServer datastream class variable, type 

and function 206
ssBO datastream class variable, type and 

function 206
ssBusCompGetFieldValue, calls 

GetFieldValue 420
ssBusCompGetFormattedFieldValue, calls 

GetFormattedFieldValue 420
ssBusCompName datastream class variable, 

type and function 206
sscustom library

about 383
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check box text controls, about 390
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about 395
controls not currently used 394
data information, displaying 388
described 92
frame components, list of and about 392
label controls, list of and about 391
line controls, about 394
pageList control, about and switching 

from landscape to portrait 392
percentage text control, about and table 

of conversions 390
revenue information, displaying 386
text controls, components for display of 

text 383
sscustom.rol. See sscustom library
ssDateFieldName, about 388
ssDateFieldName_Formatted, about 388
sssiebel BASIC file

described and inheritance structure 
diagram 92

migration considerations 115
sssiebel library.rol, described 92
standard reports directory, described 91
Start method, about and code 

example 408
static reports, versus dynamic reports 114
structure pane, Design Editor window 94
Sub Report Field object type 107
Sub Report object type 107
subclassing

component 95
subpage, defined and position thermometer 

on 278
subreport

content frame component, 
described 181

datastream, component described 181
defined 177
page header frame, component 

described 181
report section, component 

described 181
summary graphs, described 238
summary sections, in a Smart Report 260

T
Template Name property, report object 

type 105
TemplateDestDir parameter 110
templates

Siebel Report Server Access, 
configuring 34

thermometer
See also Smart Reports
about, properties, and parameters 271
component 277
dashboard subpage, positioning on 278
obtaining the data value 275

TriggerDataValue, ssThermometer 
parameter described 272
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example 371

V
Variables tab, described 123
View Report object type 107
virtual business components 109
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Web Client

Siebel Reports Server, testing from 
the 46

Web Client reporting
See also Reports Server views
user interface and process flow 358

Web page, DHTML file described 90
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