Overview: Siebel eBusiness Application Integration Volume I > Error Messages and Troubleshooting Tips >

Siebel Server


Error

Could not find 'Class' named 'Class Name'.

Cause

A process accessed a business service definition, which was not available in either the .srf file or in the database that the process pointed to. This could happen in a script or in a workflow process.

Resolution
Error

The SISNAPI connection was closed by the peer.

Cause

This error could happen in any Siebel Server component such as MQ or Remote Synchronization, due to incorrect installation or a time out condition.

Resolution
  1. Check whether this error happens for multiple clients on different machines or for multiple server components. Determine the steps that lead up to the error and determine if a long period of waiting or network interruption coincides with the error.
  2. Depending on the likely cause, verify the installation requirements or verify network connectivity and reattempt operation.
Error

Unable to perform Query corresponding to the integration object.

Cause

Possible causes for this error are:

Resolution
  1. Make sure that the UI specific methods like ActiveBusObject, ActiveBusComp, ActiveApplet, and MsgBox are not in the business service.
  2. Make sure that the .srf file is the latest .srf file on both the client and the server.

 Overview: Siebel eBusiness Application Integration Volume I 
 Published: 18 April 2003