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Overview: Siebel eBusiness Application Integration Volume I > Error Messages and Troubleshooting Tips >
EAI Siebel Adapter
Error
Error invoking service 'EAI Siebel Adapter', method 'Upsert' at step 'XXX'.
Unable to perform Upsert corresponding to the integration object <IntObjName> Insert.
Error processing business component <Business Component Name>
Operation: NewRecord
Number of records processed: 1
Business component name: Service Request
Operation: Execute
Number of records processed: 0
Business component name: PickList Generic
Cannot find an entry in the bounded picklist PickList Generic, that corresponds to the field(s) 'Value'.
Cause
An upsert was attempted on the business component where one of the fields is based on a Bounded Picklist. However the incoming value for that field does not exist in the picklist.
Resolution
Check the data in the incoming XML file for any unacceptable values. Verify the value already exists in the picklist.
Error
The same values for 'Value Name' already exist. If you would like to enter a new record, please make sure that the field values are unique.
Cause
The same record existed in the database. Though the error showed in the EAI Siebel Adapter layer, the real error has occurred in the Object Manager layer.
Resolution
- Check the data for any duplicates in both the input XML file and in the database.
- Make sure that the user key values are unique.
Error
No valid user key found for the integration component instance 'Component Name'. (Error Symbol: IDS_EAI_ERR_SA_NO_USERKEY).
Cause
The user key of the integration component is not configured properly.
Resolution
Check the user key properties to make sure they are active. If not, activate the user key.
Error
The ability to insert records is not available in this screen or applet.
Cause
The No Insert and No Update properties are set to TRUE at the business component and the applet level.
Resolution
- Log in to Tools.
- Find the business component and change the values for No Insert and No Update to FALSE to allow insert and update to the business component through an applet.
- Compile the changes into your .srf.
Error
The selected record has been modified by another user since it was retrieved. Please continue.
Cause
The two EAI interfaces were writing to the same record concurrently.
Resolution
- If multiple EAI processes update the same data, try to partition the tasks such that the same process handles all updates to the same object.
- Modify your workflow or script to perform better error handling.
Error
The default Organization from S_ORG_INT is used as the organization for the incoming product records.
Cause
An organization is not defined on the incoming record, so the EAI Siebel Adapter pulls the default organization from the S_ORG_INT table.
Resolution
Use either eScript or the Siebel Data Mapper to set the value of the Organization field on the incoming integration object.
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Overview: Siebel eBusiness Application Integration Volume I Published: 18 April 2003 |