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What’s New in Siebel 7: A Guide for End Users
Overview 1

At first glance, the Siebel eBusiness Applications user interface has changed 
dramatically. This guide for end users has been designed to assist you with the 
transition from the 6.x to the 7.0 releases, and it works with the other books in the 
end user category as a companion guide. It provides a general overview of the new 
look and feel of the Web-based product and some quick tips for understanding 
its use.

Release 7.0 runs on a Web browser. If you are an Internet user, or have used Siebel 
applications previously, making your way around in a Release 7.0 application will 
soon seem straightforward. You can relate what you know about the Internet or 
about navigation in previous Siebel versions to the new Release 7.0 interface.

To assist you in this important transition, this guide will address several key tasks 
performed in 6.x releases and the way they have changed in the 7.0 release.

More detailed explanations of the entire user interface are provided in 
Fundamentals.
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Release 7.0 Access Information
Release 7.0 Access Information 1

You access Siebel Web Client by using a URL address provided by your organization. 
When you go to the URL, a logon page appears, prompting you to enter your user 
ID and your password. For assistance with logging on, consult your system 
administrator. A sample login screen is shown in Figure 1.

Figure 1. Sample Login Screen
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Release 7.0 Home Page 1

After you log in to Siebel Web Client, the first screen you see is your home page, 
which is similar to the one shown in Figure 2. Your home page consists of a number 
of areas that show the information that will be useful to you. For example:

■ If you are a call center agent, you may want a list of your open service requests.

■ If you are a sales representative, you may want a list of the open opportunities 
you are currently pursuing.

■ It might be useful to you to have your daily calendar available to help you 
manage your day.

The information on the home page is determined by your administrator. However, 
you can show and hide items and rearrange them.

Figure 2. Sample Home Page

Home page controls
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Release 7.0 Home Page
Using the Home Page Controls 1

The home page controls are in the top right corner of each section. These controls, 
shown in Table 1, allow you to manage what appears on the home page. For 
example, you can expand and collapse each section using the expand and collapse 
buttons. 

NOTE: If you use the hide button to remove a section from the home page, you must 
click Edit Layout to restore that section from the Edit Layout page.

Any changes you make to your home page layout will be saved and will remain in 
effect until you change them again or revert to the default layout.

Table 1. Home Page Controls

Button Name Description

Hide Allows you to hide a section and remove it temporarily from 
the home page.

Collapse Allows you to collapse the list of records in a given section. 
If the section cannot be collapsed, you will see the expand 
button instead of the collapse button.

Expand Allows you to expand the list of records in a given section. If 
the section cannot be expanded, you will see the collapse 
button instead of the expand button.
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Release 7.0 Home Page
Editing the Page Layout 1

The Edit Layout page gives you access to advanced layout features. You can show 
hidden sections, collapse or expand all sections one at a time or all at once, move 
sections up or down on the page, or revert to the default layout. The buttons on the 
Edit Layout page are shown in Table 2 and an example of the Edit Layout page is 
shown in Figure 3 on page 6. Changes you make to the layout using this page are 
saved and will apply to future sessions.

Table 2. Edit Layout Buttons

Button Name Description

Collapse Collapses the section.

Expand Expands the section.

Move Up Moves the section up on the home page.

Move Down Moves the section down on the home page.

Show Displays the section on the home page.

Hide Hides the section from view on the home page.
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Release 7.0 Home Page
Figure 3. Edit Layout Page
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6 What’s New in Siebel 7: A Guide for End Users Version 7.0, Rev. A



What’s New in Siebel 7: A Guide for End Users

Siebel Application Window
Siebel Application Window 1

The Release 6.x application window and the Release 7.0 application window look 
very different. However, if you are familiar with the Release 6.x application window, 
you will find that they are not as different as they appear.

Figure 4. Release 6.x Application Window Example

Find buttonView bar Tab bar Queries drop-down list

Form applet List applet

Query button
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Siebel Application Window
As you can see in Figure 5, the Release 7.0 interface has some familiar elements in 
common with the Release 6.x interface, shown in Figure 4 on page 7.

■ Both application windows display lists and forms.

■ You access each screen by clicking the corresponding screen tab.

■ You access each view by clicking the corresponding view name in both Release 
6.x and Release 7.0. The only difference now is their location.

■ Both application windows contain Queries drop-down lists.

Figure 5. Release 7.0 Application Window Example

Search buttonQueries drop-
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Screens and Views 1

Just as in earlier releases, screens and views are very important in your Siebel 
application. This section will discuss the use of screens, views, and other features 
in Release 7.0, such as the Show drop-down list, view tabs, and the menu button.

Release 6.x and Release 7.0 Screen Tabs
Screen tabs perform the same function in Release 7.0 as they did in Release 6.x: 
Simply click a screen tab to access the related screen. The Release 6.x screen tabs 
are shown in Figure 6; the Release 7.0 screen tabs are shown in Figure 7.

Show Drop-Down List
The Show drop-down list, shown in Figure 8 with the Release 6.x view bar, is a new 
feature in Release 7.0. It displays the names of filters—such as My Accounts, All 
Accounts, and My Team’s Accounts—which determine what you see.

For more information about filters, see Fundamentals.

Figure 6. Release 6.x Screen Tabs

Figure 7. Release 7.0 Screen Tabs

Figure 8. Release 6.x View Bar and Release 7.0 Show Drop-Down List

Clicking one of these 
views in the Release 
6.x view bar is the 
same as clicking a 
filter in the Show 
drop-down list in 
Release 7.0.
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Siebel Application Window
Release 6.x View Bar vs. Release 7.0 View Tabs
In Release 6.x applications, views were listed in the view bar, on the left side of the 
screen, as shown in Figure 8 on page 9. In the Release 7.0 interface, views are 
accessed through a set of view tabs that appear at the top of a view.

Site Map 1

The Site Map is a new feature in Release 7.0. The screen tabs that appear on your 
screen are determined by your organization and may represent only a subset of the 
screens that are available to you. To see all your screens, use the Site Map, shown 
in Figure 11 on page 11. The Site Map provides you with hyperlinks to every screen 
available to you.

To navigate to a screen using the Site Map

1 In the application-level menu, choose View > Site Map.

The Site Map appears.

2 Click the desired screen hyperlink.

The Site Map repositions to display a list of views associated with that screen.

3 Click the desired view hyperlink to jump to that screen and view.

Figure 9. Release 7.0 View Tabs - Contacts View
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Siebel Application Window
The Release 7.0 Site Map shows you the same information that was provided by the 
Screens menu in a Release 6.x application, shown in Figure 10. The Site Map shown 
in Figure 11 is a sample only. Your Site Map may look different.

.

Figure 10. Release 6.x Screens Menu

Figure 11. Release 7.0 Site Map
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Siebel Application Window
Saving Data 1

Your Siebel application allows you to save edits that you make to a record by 
clicking the menu button and then clicking Save Record. However, even if you do 
not save the record, the application automatically saves changes when you leave 
the record. In both cases, the application commits your changes to the database.

Canceling Changes 1

You can cancel unsaved edits you have made to a record.

If you want to cancel edits in a form or a list, click the menu button and choose 
Undo Record.

Show More Button 1

All forms and lists appear with the show more button in the top right corner. Use 
the show more button, shown in Figure 12, to expand or collapse the form or list. 
Expanding a form allows you to look at more or fewer fields in a record; expanding 
a list allows you to look at more or fewer records in the list, according to your needs.

NOTE: An expanded form shows all the fields of a record. Your system administrator 
determines what fields appear in the expanded form and in the collapsed form.

Figure 12. Show More Button
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Siebel Application Window
Menu Button 1

The menu button, shown in Figure 13, displays a menu of actions that apply to the 
active form or list, or to a selected record in a list. You can add, copy, edit, delete, 
query, determine the columns displayed, and change the sort order using the 
menu button. Right-clicking in a list or form will provide you with the same menu 
of actions.

Query Button 1

The Query button appears on all lists and forms. Click Query to launch a query in 
a form or a list. For more information on querying, see “Queries” on page 1-28.

Figure 13. Menu Button

Figure 14. Query Button in a List

Query button
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Siebel Application Window
Queries Drop-Down List 1

The Release 7.0 Queries drop-down list, shown in Figure 16, is equivalent to the 
Queries drop-down list in Release 6.x, shown in Figure 15. The Queries drop-down 
list stores predefined queries established by your organization and any queries you 
create and save.

History List and Thread Bar 1

The history list was used in Release 6.x to track the last 25 screens and views you 
had used. The Release 7.0 History list, shown in Figure 17, stores your most 
recently visited views, allowing you to navigate back to any of them. The History 
list is directly to the right of the Show drop-down list.

Figure 15. Release 6.x Queries Drop-Down List

Figure 16. Release 7.0 Queries Drop-Down List

Figure 17. Release 7.0 History List
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What’s New in Siebel 7: A Guide for End Users

Siebel Application Window
The thread bar, shown in Figure 18, is still available in Release 7.0. It appears below 
the Show drop-down list. It helps you keep track of your navigational path when 
you drill across to a view on another screen. You can return to a previous point in 
the path by clicking the appropriate name on the thread bar.

NOTE: When you navigate to a new screen using a screen tab or the Site Map, 
the thread bar resets and begins tracking your new path.

Field Control Buttons 1

In Release 6.x applications, clicking the ellipsis (...) button, shown in Figure 19, 
caused a dialog box to appear in many cases.

Figure 18. Release 7.0 Thread Bar

Figure 19. Ellipsis Button

Release 6.x ellipsis button
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In Release 7.0, several field control buttons, shown in Table 3, help you enter data 
into fields. When you click one of these buttons, a selection dialog box appears. 
Selection dialog boxes allow you to enter data in the field, and are specific to the 
field in which they appear. For example, if you click the calendar button, the 
Calendar dialog box appears, allowing you to enter date information in a date field.

As in Release 6.x, a field down-arrow button activates a drop-down list, similar to 
the one shown in Figure 20. A drop-down list allows you to select information to be 
entered in the field in which it appears.

NOTE: A red asterisk beside each required field is a new feature in Release 7.0. 
A required field is one that must be filled in when you add a record.

Table 3. Field Control Buttons

 Button Name/Description

The calculator button activates a dialog box to assist you with calculating 
figures.

The calendar activity button appears in the Calendar screen. This button 
activates the Calendar Detail form, which allows you to add an activity to the 
calendar.

The calendar button provides a dialog box for entering date information in a 
date field.

The select button activates a dialog box that allows you to choose from a list of 
items that are stored in the database. For example, if you click the select button 
in the Account field, you see the Pick Account dialog box, which allows you to 
choose from a list of accounts.

Figure 20. Release 7.0 Drop-Down List
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Siebel Application Window
User Preferences 1

In Release 6.x, you were able to customize your application from the Options dialog 
box, shown in Figure 21, which was launched from the View menu. In Release 7.0, 
you customize your application in the User Preferences screen. You can access the 
User Preferences screen, shown in Figure 22 on page 18, from the View menu. From 
the User Preferences screen you can set a startup screen, customize correspondence 
defaults, choose a default predefined query for a view, customize your message bar, 
and so on.

Figure 21. Release 6.x Options Dialog Box
Version 7.0, Rev. A What’s New in Siebel 7: A Guide for End Users 17
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Siebel Application Window
Figure 22. Release 7.0 User Preferences Screen - Profile Tab
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New Navigation Techniques 1

Some navigation techniques have changed with Release 7.0.

Navigating in a List 1

Navigating in a list has changed slightly in Release 7.0.

Release 6.x Record Navigation
Navigating in a list in Release 6.x was performed by using the up and down arrow 
keys on the keyboard. You could also use the scroll bar or the alphabet bar, as 
shown in Figure 23.

Figure 23. Release 6.x Alphabet Bar and Scroll Bars

Alphabet Bar Scroll bar
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New Navigation Techniques
Release 7.0 Record Navigation
You perform record navigation in Release 7.0 by using the record navigation buttons 
at the top of each list or form. When you use the record navigation buttons in a list, 
you are navigating to a new part of the list. When you use them in a form, you are 
navigating to the next record or the previous record. The two types of record 
navigation buttons are shown in Figure 24. 

NOTE: There is no longer an alphabet bar to search the list by initial letter.

Depending on your configuration, you can activate a record by clicking anywhere 
in the record. Contact your system administrator if you need more information.

Scroll Bars 1

Scroll bars are limited in Release 7.0. In Release 6.x, it was common for the user to 
scroll down through a list. In addition, a record in Release 6.x contained many fields 
to the far right of the screen, so you had to scroll to the right to see these fields. In 
Release 7.0, the detail for the selected record is shown in the form below the list.

Figure 24. Record Navigation Buttons
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What’s New in Siebel 7: A Guide for End Users

New Navigation Techniques
Keyboard Shortcuts 1

Keyboard shortcuts were available in Release 6.x and are still available in Release 
7.0. However, the keyboard shortcuts used for specific tasks may have changed. 
Table 4 compares some important Release 6.x keyboard shortcuts with the Release 
7.0 keyboard shortcuts. In Release 7.0, there are two types of keyboard shortcuts:

Basic mode. You can only use keyboard shortcuts that are not used by the Web 
browser in which your Siebel application runs, and you cannot use special keys in 
a shortcut, such as function and arrow keys.

Extended mode. There are no limitations on the keys used in the keyboard shortcuts. 
This is the default mode.

See your system administrator to determine which mode your Siebel application is 
operating in.

Table 4. Keyboard Shortcuts Compared

Action
Release 6.x 
Shortcut

Release 7.0 Shortcut 
(Basic-Mode)

Release 7.0 Shortcut 
(Extended-Mode)

New Record CTRL+N CTRL+ALT+N CTRL+N

Delete Record CTRL+D CTRL+ALT+D CTRL+D

Copy Record CTRL+B CTRL+ALT+C ALT+B

Launch Online Help F1 CTRL+ALT+H CTRL+H

New Query CTRL+Q CTRL+ALT+Q ALT+Q

Run Query ENTER CTRL+ALT+ENTER ALT+ENTER

Refine Query CTRL+R CTRL+ALT+R ALT+R

Save Query As CTRL+S CTRL+ALT+S ALT+S

Open Search (Find in 
Release 6.x)

CTRL+F CTRL+SHIFT+F CTRL+F

Logout ALT+F4 CTRL+SHIFT+X

Send Email F9 CTRL+ALT+1 F9

Send Fax CTRL+F9 CTRL+ALT+2 CTRL+F9
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Sorting a Column 1

In Release 6.x, you selected the column on which you wanted to sort, and then 
clicked the ascending button or the descending button, shown in Figure 25, to 
execute the sort.

In Release 7.0, you can sort directly on each column by using the up and down 
arrows in the column head. The up arrow indicates ascending order and the down 
arrow indicates descending order. An ascending sort organizes records from A to Z 
and from 1 to 9; a descending sort organizes records from Z to A and from 9 to 1. 
The arrow you select turns green, indicating the direction of the sort. The darker 
sort indicator shown in Figure 26 indicates an ascending sort.

Send Page SHIFT+F9 CTRL+ALT+3 SHIFT+F9

Go to Next Record CTRL+down 
arrow

CTRL+SHIFT+. CTRL+down 
arrow

Go to Previous Record CTRL+up arrow CTRL+SHIFT+, CTRL+up arrow

Table 4. Keyboard Shortcuts Compared (Continued)

Action
Release 6.x 
Shortcut

Release 7.0 Shortcut 
(Basic-Mode)

Release 7.0 Shortcut 
(Extended-Mode)

Figure 25. Release 6.x Sort Buttons

Figure 26. Release 7.0 Sorted Column Indicators
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Columns Displayed 1

A list consists of many columns, some of which may not be displayed onscreen. 
Depending on the columns you need to work with, you can add, remove, or 
rearrange them from the Columns Displayed dialog box, shown in Figure 27.

The Columns Displayed feature can still be accessed using right-click functionality. 
In Release 6.x you would right-click within the list and select Columns Displayed. 
In Release 7.0, you can right-click to access the Columns Displayed feature, or you 
can click the menu button and choose Columns Displayed.

To change the way columns are displayed

1 In the current list, click the menu button and choose Columns Displayed.

The Columns Displayed dialog box appears.

2 Use the column-ordering buttons to the right of the Selected Columns area 
to change the order in which the columns appear in the list.

3 Use the buttons in the center of the dialog box to show and hide the 
various columns.

4 Click Save to execute your changes, or click Cancel to cancel your changes.

For more information about changing the way your columns are displayed, 
see Fundamentals.

Figure 27. Columns Displayed Dialog Box
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Navigating a Chart 1

In Release 6.x, you accessed charts using the view bar. You now access charts using 
the Charts view tab. Note that charts may not be available for all screens. 

You may have used the toggle button in Release 6.x, shown in Figure 28, to switch 
between a chart and a list. Release 7.0 has no toggle button. Instead, you use the 
Show drop-down list in the Charts view, shown in Figure 29, to move among 
different kinds of charts.

Figure 28. Release 6.x Toggle Button

Figure 29. Release 7.0 Charts Show Drop-Down List

Release 6.x Toggle Button
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Searches 1

The Search Center is a new feature in Release 7.0. It replaces the Find feature used 
in Release 6.x. You can now perform a search for anything within your database, no 
matter where you are located in the application. You can find information without 
losing the screen you are currently viewing. Searching is similar to querying, except 
that it is not quite as complex. You would search to find text in the database; you 
would query to locate multiple sets of data.

Release 6.x Find Command 1

In Release 6.x, you used the find button or chose Edit > Find to find specific 
information. You used a dialog box, as shown in Figure 30, to enter the find criteria 
and you could save the search results in the Queries drop-down list.

In Release 6.x, you could perform a find for an account while you were in the 
Contacts screen. However, if the account was found, you automatically exited the 
Contacts screen and went directly to the Accounts screen. Therefore, you could no 
longer see the screen you had been viewing.

Figure 30. Release 6.x Find Dialog Box Example
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Release 7.0 Search Center 1

Siebel Search allows you to search for information and see the results, without 
leaving your current screen. You can create complex or simple searches from 
anywhere within your Siebel application using the Search Center, shown in 
Figure 31.

You activate the Search Center by clicking the search button, which looks like a pair 
of binoculars. You close the Search Center by clicking the close search button.

Figure 31. Search Center

Results list

Close search button

Search button
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You can use two wildcard operators, shown and described in Table 5, to refine 
your searches. 

To perform a search

1 In any screen, click the search button.

The Search Center appears in a frame to the right of the screen.

2 Click the Look In drop-down list and select the type of information you want 
to find.

3 Enter your search criteria and click Search.

The records matching the search criteria appear in the Search Center.

4 To preview a record in the list, select the record and click Preview. 

A dialog box containing the detail for the selected record appears.

For more information on the Search Center, see Siebel Search Administration Guide.

Table 5. Search Operators

Operator Description

* Can be used in words as a wildcard, representing any string of characters. 
For example, *rang* will return terms such as arrange, arranged, orange, 
range, and rang. Using Sho* will return words such as Show, Shout, Shore, 
and Shower.

? Can be used in words as a wildcard, representing any single character. 
For example, t?pe will return type and tape, but not tripe.

Tip: You can also drill down on the record and the information 
will appear in a frame to the left of the Search Center.
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Queries 1

Querying searches the database for a specific subset of data based on one or more 
conditions, or criteria. It is more complex than searching; searching is a powerful 
text-retrieval tool that allows you to perform text searches for data within your 
application and documents inside and outside your application structure.

The Release 7.0 query feature is similar to that in Release 6.x. Querying is a way 
to locate one or more records that meet your specified criteria. The records found 
by a query can be viewed on the screen, exported to a file, and used as data for a 
report. Release 6.x allowed you to enter query criteria in a list or form and the same 
is still true for Release 7.0.

You initiated and executed queries in Release 6.x by using the magnifying glass 
icons on the toolbar. In Release 7.0, you have several options for creating and 
executing queries.

Creating a Query 1

■ Click Query.

■ Click the menu button and choose New Query.

■ Choose Edit > Query > New from the application-level menu.

Executing a Query 1

■ Click Go.

■ Click the menu button and choose Run Query.

■ Choose Edit > Query > Run from the application-level menu.
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Saving Queries 1

Query criteria can still be saved as they were in Release 6.x. You used the Queries 
drop-down list in Release 6.x to store these saved queries. In Release 7.0, you still 
use the Queries drop-down list, shown in Figure 32, to store them.

NOTE: The Queries drop-down list consists of both predefined and user-defined 
queries.

Common Query Tasks 1

The following procedures will provide you with the information you need to 
perform common query tasks.

To create, execute, and save a new query

1 Navigate to the desired screen.

2 Click Query in the list or form.

A blank query form or blank row entry in a list appears.

3 Enter the query criteria.

4 To execute the query, click the menu button and choose Run Query.

The query is executed and the records appear.

5 In the application-level menu, choose Edit > Query > Save.

The Query Save As dialog box appears.

6 In the Query Name field, enter a name for the query and click OK.

The saved query appears in the Queries drop-down list.

Figure 32. Queries Drop-Down List
Version 7.0, Rev. A What’s New in Siebel 7: A Guide for End Users 29



What’s New in Siebel 7: A Guide for End Users

Queries
To refine a saved query

1 Navigate to the desired screen.

2 From the Queries drop-down list, select the desired query.

The records meeting the query criteria appear.

3 Click the menu button and choose Refine Query.

4 Add and edit the desired criteria.

5 Click the menu button and choose Run Query.

The query is executed and the records appear.

To delete a saved query

1 Navigate to the desired screen.

2 From the application-level menu, choose Edit > Query > Delete.

The Delete Record dialog box appears, containing all user-defined queries.

3 Select the query you want to delete in the Query Name list.

4 Click OK.

NOTE: For more information about query functionality, see Fundamentals.
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Additional Release 7.0 Features 1

The following features are new in Release 7.0.

Spell Checking 1

Spell Check functionality in Release 7.0 allows you to spell check various items in 
your Siebel application.

Wherever you see a spell checking button, you may run Spell Check against the 
text that appears in that record. You may also set up your preferences so that all 
emails, faxes, pages, or wireless messages you send from your Siebel application are 
automatically checked for spelling errors before they go out to a recipient. For more 
information on Spell Check functionality, see Fundamentals.

Data Quality 1

The Siebel Data Quality module helps you maintain the integrity of your 
information through matching and data cleansing. For more information on 
Data Quality, see Fundamentals.
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