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Version 7.0.4

General Information 0

March 8, 2002

HTML Formatting and User Preferences for Email 0

Version 7.0.4 of Siebel Call Center adds support for HTML formatting in email messages that are 
viewed or composed through the Call Center application. 

For incoming email messages that include HTML formatting, the Web browser that is used to run 
Call Center automatically determines how the HTML formatting will be displayed. For example, if 
you use a browser that supports the <BOLD> tag, Call Center displays bold text for all email text 
located between the <BOLD> tag and the </BOLD> tag.

For outgoing email that is sent using either Send Email (F9) or eMail Response functionality, a user 
preference determines whether the message will be sent in plain text or using HTML formatting. If 
the appropriate preference is set for HTML formatting, special editing controls are available in the 
form where you compose your email message. These controls allow you to use supported HTML 
formatting, and also provide some standard editing features such as cut and paste.

The following procedure describes how to set user preferences for outbound email, including how 
to enable HTML formatting. A later procedure describes how to use the related editing controls.

To set outbound email user preferences

1 From the application-level menu, choose View > Site Map > User Preferences > Outbound 
Communications. 

The Outbound Communications form appears.
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2 Complete the fields in the form; some fields are described in the following table.

Field Comments

Default Closing 
Template

Specifies a communications template (for the email channel) to use as a closing for 
an email reply sent using Siebel eMail Response. The template content is inserted 
automatically into the message. It is placed after the last text you enter, but before 
the thread ID and the original message, if the original message is included.

Default Greeting 
Template

Specifies a communications template (for the email channel) to use as a greeting for 
an email reply sent using Siebel eMail Response. The template content is inserted 
automatically at the beginning of the message.

Default Profile Specifies the default communications profile for a user to use for the Send Email and 
Send Fax commands.

The profile stores various communications settings and provides access to the 
communications driver that transfers information between the Siebel software and 
the email/fax server. For example, a profile for the Internet SMTP/POP3 Server 
driver handles outbound communications using the SMTP protocol. 

You have access to any profiles that are associated with your Siebel responsibility 
setting, and to any profiles that you create for your personal use by using the My 
Profiles view in the Communications screen. The ability to create personal 
communications profiles is not available for some responsibility settings.

The default profile information is copied to the From field in the Send Email and 
Send Fax windows. You can specify a different profile by choosing another value 
from the drop-down list for the From field.

Default Recipient 
Class

In some contexts, the Send Email and Send Fax commands let you choose email or 
fax recipients from data stored in certain fields of the current record. If you choose 
a recipient based on one of these current field values, the Default Recipient Class 
setting specifies the default choice for where recipient email or fax address 
information will be populated in the outgoing message. Choices are To, Cc, and Bcc.

For example, you might generally want to populate recipients to the To field. 
However, depending on your typical activities or workflow and on your company’s 
business needs, it may be more appropriate to populate recipients to the Cc or Bcc 
field instead of the To field.

eMail Response 
Default Message 
Format

Specifies the type of formatting to use for outbound email messages that are replies 
to inbound eMail Response messages. Available values are HTML and Plain Text.

Include Original 
Message in Reply

When selected, automatically includes the current eMail Response message in the 
body of any reply to that message. Includes source, destination and subject 
information from the header of the eMail Response message.
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3 Click Save. 

The following procedure describes how to use the special editing controls that are available for eMail 
Response replies or Send Email messages when the corresponding Default Message Format 
preference is set to HTML.

To use special editing controls for outbound email with HTML formatting

1 Set the appropriate outbound user preference to use HTML formatting, as described in “To set 
outbound email user preferences” on page 1-2.

2 Use one of the following methods to start composing an outbound email message:

■ To compose an eMail Response reply, choose View > Site Map > Communications > My 
Communications from the application-level menus, select the email message to which you 
want to respond, and click Reply.

■ To compose a Send Email message, press the F9 key or choose File > Send >Email from the 
application-level menus.

3 In the Outgoing Message form or Send Email form that appears, click the unlabelled field below 
the Body field.

The special editing controls appear at the bottom of the field.

Remain on Same 
View After Send 
(Cancel)

When selected, continues to display the Incoming Message form, Incoming 
Attachments form, and Outgoing Message form after a reply to an eMail Response 
message is sent, but populates the forms with data from the next record in the 
current Communications list.

When not selected, redisplays the Communications list after a reply to an eMail 
Response message is sent.

Send Email 
Default Message 
Format

Specifies the type of formatting to use for outbound email messages that are sent 
using the Send Email command. Available values are HTML and Plain Text. 

Upon Sending 
Messages 
Generate

Specifies activity generation for messages sent using the Send Email, Send Fax, Send 
Wireless Message, and Send Page commands. Options are:

■ Public activities. Sets the Internal flag to FALSE for activity records generated by 
sending outbound messages.

■ Private activities. Sets the Internal flag to TRUE for activity records generated by 
sending outbound messages.

The specific results of the Internal flag being set to FALSE or TRUE depend on your 
Siebel implementation. Consult your Siebel Administrator for more information.

Field Comments
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4 Compose your message using the special editing controls as needed. 

The editing controls are shown in the following graphic, and are described in the table that 
follows this procedure.

Find/Replace

Cut

Copy

Paste

Font

Font Color

Font Size

Increase Indent

Decrease Indent

Bold

Italic

Underline

Numbering Bullets

Align Left

Align Center

Align Right
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5 Complete the remaining fields in the form, and then click Send. 

Editing Control Usage

Align Center Click to center each line of selected paragraphs.

Align Left Click to left-align selected paragraphs.

Align Right Click to right-align selected paragraphs.

Bold Click to apply bold formatting to selected text, or to remove bold. 

Bullets Click to apply bulleting to selected text, or to remove bullets. Creates a list of 
bulleted paragraphs, corresponding to an HTML unordered list. Bullets appear 
differently at different levels of indenting.

Note that items that are at the same indentation level within a list must have 
the same list type, either all items bulleted or all items numbered. List items 
that are at different indentation levels can have different list types. This means 
you can nest an indented list of one type (such as a bulleted list) within a list 
of another type (such as a numbered list).

Copy Click to copy selected text to the clipboard.

Cut Click to cut selected text to the clipboard.

Decrease Indent Click to decrease the indenting for selected paragraphs.

Find/Replace Click the arrow to display the Find controls above the editing bar, or to hide 
these controls. Click the arrow on the left side of this area to toggle between 
Find controls and Find and Replace controls. 

To find specified text, enter the text to find, then click Go. 

To replace specified text, enter the text to replace and the replacement text. If 
you want to replace all instances of the specified text, select the Replace All 
check box. Then click Go.

Font Choose a font from a drop-down menu to apply to selected text. Available 
fonts include Arial (the default), Verdana, Times New Roman, and Courier.

Font Color Click the arrow to display font colors above the editing bar, then click to 
choose a color to apply to selected text.

Font Size Choose a size from a drop-down menu to apply to selected text. Point sizes 
include 8 (the default), 10, 12, 14, 18, 24, 36. 

Increase Indent Click to increase the indenting for selected paragraphs.

Italic Click to apply italic formatting to selected text, or to remove italics.
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Numbering Click to apply numbering to selected text, or to remove numbering. Creates a 
list of numbered paragraphs, corresponding to an HTML ordered list.

Note that items that are at the same indentation level within a list must have 
the same list type, either all items bulleted or all items numbered. List items 
that are at different indentation levels can have different list types. This means 
you can nest an indented list of one type (such as a bulleted list) within a list 
of another type (such as a numbered list).

Paste Click to paste text from the clipboard into the message area. Depending on the 
source, text you paste may include HTML formatting.

Underline Click to apply underlining to selected text, or to remove underlining.

Editing Control Usage
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Versions 7.0.2, 7.0.3, and 7.0.4

Chapter 1, Overview 0

March 27, 2001

Home Page Overview 0

When agents log into the Siebel application, the first screen they see is determined by the value of 
the Startup Screen user preference. If this preference has not been set, the agents see the home page. 
The home page is a combination of lists and forms that provide a snapshot of the most important 
information agents need to manage their day. This information may include the My Campaigns list 
of all active campaigns based on the defined Start and End Dates of the campaigns.

Chapter 5, Service Requests 0

July 15, 2003

The following revised information clarifies ambiguous wording in the Note.

Identifying the Customer
When a customer telephones a call center or service center, the agent must determine if the caller is 
an existing or new customer. To verify a customer, go to the Contacts or Accounts screen and perform 
a query on the information about the customer. This query may also be performed through the 
Search Center.

If the customer exists in the system, the agent can review the requests that have already been entered 
for this customer. If the customer does not already exist in the system, the agent can add the 
customer. 

NOTE: For companies using the Siebel Communications Server, this customer search can take place 
automatically when the call is received, presenting the agent with relevant contact information 
through an automated screen pop.
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Chapter 10, eMail Response 0

March 27, 2002

Setting Spell Check Preferences 0

The procedure describing how to change default spell check options should contain the following 
additional information:

When the Ignore HTML Tags preference check box is selected, spelling is not checked for any text 
enclosed in angle brackets (<>) or any text that follows an unmatched left angle bracket (<).

The Always Check Spelling Before Sending check box applies to eMail Response reply messages. It 
does not apply to Send Email messages.

Replying to an Incoming Email 0

The following additional information applies to any situation where you are preparing to reply to an 
inbound eMail Response message:

When you view information in the Communications list of the All Communications view or the My 
Communications view, you can display additional information about the selected record by clicking 
a hyperlink in any of the following fields:

■ Last Name field (displays Contact information)

■ SR # field (displays Service Request information)

■ Opportunity field (displays Opportunity information)

Adding Attachments and Literature 0

The following information about adding attachments and literature applies to outgoing email 
messages that are sent using either Send Email (F9) or eMail Response functionality:

The procedure that describes how to add an attachment refers to an Attachment button. This control 
appears as a paper clip icon to the right of the Attachments field.

You can add more than one attachment to an outgoing email message. All currently attached files 
are listed in the dialog box that appears when you click the paper clip icon. However, only the most 
recently attached file is listed in the Attachments field.
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It is also possible to attach a Web page URL to an outgoing email message. When you do this, the 
email recipient sees the URL in the body of the email message. Depending on the software the 
recipient uses to read email, the URL may or may not be an active hyperlink to the designated Web 
page. The Web page itself is not attached. The following procedure describes how to add a URL to 
an outgoing email message.

To add a URL to an outgoing email message

1 Use one of the following methods to start composing an outbound email message:

■ To compose an eMail Response reply, choose View > Site Map > Communications > My 
Communications from the application-level menus, select the email message to which you 
want to respond, and click Reply.

■ To compose a Send Email message, press the F9 key or choose File > Send >Email from the 
application-level menus.

2 Compose your email message as usual.

3 Click the paper clip icon that appears to the right of the Attachments field.

The Attachments dialog box appears.

4 Click New.

5 In the File Name field, click the select button to display the Add Attachment dialog box.

6 In the URL field, enter the URL you want to include in your email message, and then click Add 
to return to the Attachments dialog box.

7 Click Save, and then click Close. 

The URL appears in the Attachments field. The email recipient will see the URL at the end of the 
body of your email message, after your text and any thread ID or original message that you 
include. If the applicable Default Message Format user preference is set to Plain Text, “http://” 
will be added automatically to the beginning of any URL that does not already include it.
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Chapter 11, Campaigns and SmartScripts 0

December 4, 2001

SmartScript Campaigns

Step 3 in the procedure detailing how to launch a campaign should contain information on which 
campaigns are visible in the My Campaigns list.

To launch a campaign

1 Navigate to the Campaigns screen.

2 From the Show drop-down list, select My Campaigns.

3 In the Campaigns list, click the Name hyperlink of the campaign you would like to launch.

The Campaigns list displays all active campaigns based on the Start and End Dates of the 
campaigns.
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