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Who Should Use This Guide
Who Should Use This Guide Intro

This guide provides information necessary to configure, create, and distribute Siebel 
Anywhere, MidMarket Edition upgrade kits.

NOTE: All Siebel MidMarket product names include the phrase MidMarket Edition 
to distinguish this product from other Siebel eBusiness Applications.  However, in 
the interest of brevity, after the first mention of a MidMarket product in this 
document, the product name will be given in abbreviated form. For example, after 
Siebel Call Center, MidMarket Edition, has been mentioned once, it will be referred 
to simply as Siebel Call Center. Such reference to a product using an abbreviated 
form should be understood as a specific reference to the associated Siebel 
MidMarket Edition product, and not any other Siebel Systems offering.  When 
contacting Siebel Systems for technical support, sales, or other issues, note the full 
name of the product to ensure its proper identification and handling.

Although job titles and duties at your company may differ from those listed in the 
following table, the audience for this guide consists primarily of employees in these 
categories: 

This guide assumes users have an understanding of their system and network.

Database 
Administrators

Persons who administer the database system, including data 
loading, system monitoring, backup and recovery, space 
allocation and sizing, and user account management.

Siebel Application 
Administrators

Persons responsible for planning, setting up, and maintaining 
Siebel applications.

Siebel System 
Administrators

Persons responsible for the whole system, including installing, 
maintaining, and upgrading Siebel applications. 
Int ro -2 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A
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How This Guide Is Organized
How This Guide Is Organized Intro

After an overview of the product and screens, this guide discusses the server side 
of the process to create and distribute upgrade kits. Then the discussion focuses on 
the client side to explain procedures to pull down the upgrade kit from the server 
and install it properly.

The final topics include advanced usage scenarios and FAQs to help resolve 
problems.

Additional Documentation Intro

The product documentation set for Siebel eBusiness Applications is provided on the 
Siebel Bookshelf, MidMarket Edition CD-ROM. For general information about Siebel 
product documentation, see the Siebel Bookshelf, MidMarket Edition home page 
and Documentation Roadmap, MidMarket Edition.

Siebel Systems, Inc., reserves the right to modify the documentation for Siebel 
eBusiness Applications at any time. For updates to Siebel documentation, go to the 
SupportWeb site (http://ebusiness.siebel.com/supportweb/). 

If you want to order additional Siebel documentation and copies of the Siebel 
Bookshelf, MidMarket Edition CD-ROM, go to Books Online at http://
ebusiness.siebel.com/booksonline.

To access both SupportWeb and Books Online, you will need to provide the user 
name and password you received from Siebel Support Services 
(support@siebel.com).

What’s New in This Release Intro

For a list of features new in this release, see the “What’s New” books included on 
the Siebel Bookshelf, MidMarket Edition. Your Siebel implementation may not have 
all the features described in those guides, depending on which software modules 
you have purchased.

It is also strongly recommended that you read Fundamentals, MidMarket Edition so 
that you can make optimal use of your Siebel application, especially if you are new 
to Siebel software.
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition Intro -3
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Contacting Siebel Technical Support
Contacting Siebel Technical Support Intro

Do you know how to access Siebel Technical Support? It is crucial that you 
understand the requirements for getting support before you encounter technical 
issues that require Siebel Technical Support’s assistance. This will facilitate smooth 
resolution of your issues. If you have questions, please don’t hesitate to contact us.

To maximize your knowledge of Siebel products and your return on investment:

■ You must attend Siebel training to become a designated contact. 

■ Your Siebel-trained designated contacts provide technical support to your users. 
Siebel Technical Support provides support directly to your designated contacts 
only. 

To provide efficient, timely support and access to the Technical Support knowledge 
base:

■ Siebel Technical Support is primarily Web-based; it can be accessed through 
Siebel SupportWeb (http://ebusiness.siebel.com/supportweb/). Please submit 
new service requests to us through SupportWeb, where you can also search the 
knowledge base for solutions.

■ Designated contacts receive read/write access to Siebel SupportWeb. All other 
project team members at your company receive read-only accounts so that they 
can access the knowledge base.

To register for Siebel training, access http://siebeluniversity.siebel.com/and choose 
Implementation Team Training.
Int ro -4 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A
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Contacting Siebel Technical Support
Please submit your technical issues and updates to Siebel SupportWeb 
(http://ebusiness.siebel.com/supportweb/). If you do not have a SupportWeb 
account, or if you have a question, please contact us at support@siebel.com or call 
your local Siebel Support Center:

■ North America: +1 800 214 0400 or +1 650 341 0700

■ Brazil (São Paulo): +55 11 3444 0800 

■ UK (London): +44 (0) 1784 494949

■ Germany (Munich): +49 89 957 18 400

■ France (Paris):  +44 1784 494949

■ Ireland (Galway): +44 1784 494949

■ Japan (Tokyo): 0120 606 750 (toll-free, Japan domestic only), 
+81 3 5464 7948 (outside of Japan)

■ Singapore: +65 212 9266 

Outside of local support center hours, Gold and Rollout Support Option customers 
can call +1 800 214 0400 or +1 650 341 0700.

We appreciate your business and look forward to working with you.
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition Intro -5
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Siebel Systems Welcomes Your Comments
Siebel Systems Welcomes Your Comments Intro

To help us improve our products, we want to know about any corrections or 
clarifications to this guide that you would find useful. Please include in your 
message:

■ The title and version of the guide (very important)

■ The name and version number of the Siebel application you are using

■ Your name, job title or functional area, company name, phone number, and 
email address

Contact us through regular mail or email at:

Siebel Systems, Inc.
Technical Publications Department
2207 Bridgepointe Parkway
San Mateo, CA 94404-5009

doc@siebel.com 

We appreciate your feedback.
Int ro -6 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A
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About This Chapter
About This Chapter 1

This chapter presents a functional overview of Siebel Anywhere. It describes the 
screens for system administrator access, related views, and applets to create and 
manage upgrade kits. To access the system administrator’s screen (Siebel Anywhere 
Administration), you must be logged on at the system administration level. In some 
cases users may have been granted a subset of the Siebel Administrator security. 
Consequently, such users may have been given access to the Siebel Anywhere 
Administration Views as part of their limited access.

Also, this chapter describes the Product Updates view in the User Preferences 
screen. This is the single view for users of the mobile and dedicated Web clients to 
retrieve optional upgrade kits. 

About Siebel Anywhere 1

Siebel Anywhere allows the Siebel System Administrator to apply upgrades to 
dedicated Web clients, mobile Web clients, and Siebel Servers. Upgrades can 
include custom configurations, new versions of Siebel eBusiness Applications (as 
licensed), custom extensions to the database schema, custom files, or third-party 
files or applications. 

Siebel Anywhere uses pull-based technology for retrieving upgrade kits. There are 
two server components and one executable for the creation and installation of 
Siebel Anywhere upgrade kits. These are described below, along with some other 
key terminology:

■ The Siebel Upgrade Kit Wizard (UpgKitWiz) automates the administrator’s task 
of collecting information for the kit to be created. The wizard provides a user 
interface to collect all the necessary information for creating an upgrade kit.  The 
associated log file is UpgKitWiz.log.

■ Siebel Upgrade Kit Builder (UpgKitBldr) is the server component that takes the 
information collected by the Kit Wizard and creates the kit. The associated log 
file is UpgKitBldr_<task id>.log.

■ Siebel Upgrade Wizard is a standalone executable that installs the upgrade kit 
on the clients. The associated log files are UpgWiz.log (Windows).
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■ Upgrade Component defines how to version check different software modules.

■ Upgrade Configuration is a collection of upgrade components.

■ Upgrade Kit is an archived file with instructions and contents to perform specific 
actions as defined by the Kit Wizard for a particular upgrade component.

■ Subscriber is a user who belongs to an active configuration. Subscribers can also 
include servers.

It is strongly recommended enabling Siebel Anywhere on only one Siebel 
Applications Server in the enterprise—to create kits this server must be running. 
Also, in order to create an upgrade kit, the Upgrade Kit Builder must be running. 

The Upgrade Wizard automates the installation of upgrade kits on the clients, 
including restarting and recovery. 

Siebel Anywhere provides the following mechanisms:

■ Security to make sure users are connecting to a system with the predetermined 
set of prerequisites.

■ Distribution to provide users the acceptable version levels to access the system.

Keep in mind this fundamental process flow:

■ First, you must have both a requirement to distribute an upgrade and the 
components to build the upgrade kit. 

■ Next, you build the appropriate kit and distribute it to a defined set of clients or 
Siebel servers. Upgrade kits are automatically placed on the file system. Some 
kits are required, and others are optional. 

■ Last, you test the kit with a test configuration. It is recommended that you 
distribute the kit through a test configuration and have a mobile and a connected 
user attempt to download the kit through a test configuration before distributing 
the kit to the production configuration.

NOTE: Testing the kit manually does not guarantee successful download of the kit 
by production users.

For details about the software and hardware platforms supported by this release, see 
the system requirements and supported platforms documentation for your Siebel 
application.
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Siebel Anywhere Subscribers 1

A Siebel Anywhere subscriber belongs to one upgrade configuration. These include 
the following: 

■ Mobile Web clients of eBusiness Applications such as Siebel Sales, or Siebel Call 
Center.

■ Dedicated Web client, which is the standard mobile Web client in server 
connected mode.

■ Siebel Tools clients requiring version checks of Tools software. Siebel Anywhere 
is not designed to apply kits to Siebel Tools.

NOTE: Any user with Siebel administrator responsibilities should not be 
associated with Siebel Anywhere configurations. For details regarding why, see 
“Logging on as the Siebel Administrator” on page 1-6. 

■ Siebel Servers operating against the Siebel Server Database (referred to as the 
Headquarters Server).

The Siebel Administrator has full control over the upgrades distributed and applied 
by Siebel Anywhere.

When the client starts and successfully connects to a database (server or local), the 
subscribing system automatically checks the versions of its currently installed 
components. This check occurs against a component registry as part of the version 
check process. The component registry is part of the server database. Subscribers 
can see the information in the component registry from within Siebel Anywhere.
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Table 1-1 indicates when a version check occurs for each type of subscriber. 

NOTE: Version checking is done automatically only if the Required at Startup 
parameter is checked for the particular component in question.

Configurations 1

Each Siebel Anywhere subscriber requires a bundle of one or more software 
components to operate. 

Siebel eBusiness Applications provide several default configurations:

Siebel Anywhere supports global deployments by including seeded upgrade 
configurations and components for each supported language included within the 
Siebel eBusiness Applications. Consider carefully the receivers or subscribers to any 
upgrade kit you create and use the correct upgrade component based on end user 
languages. 

Table 1-1. Version Check Occurrence

Subscriber Type When Version Check Occurs

Mobile and 
dedicated users, 
including Siebel 
Tools users

Mobile and dedicated Web clients, and Siebel Tools clients perform 
the version check when the client starts up and connects to either 
the server or local database. Mobile Web clients also perform a 
version check during each synchronization session.

Headquarters servers Depends upon the parameter VersionCheck on the HQ server. A 
version check activates at start-up only when the server parameter 
Version Check is set to TRUE.  The default value for VersionCheck 
is FALSE.

■ Siebel Test Client

■ Siebel Service Client

■ Siebel Tools Client

■ Siebel Sales Client

■ Siebel Call Center Client

■ Siebel HQ Server
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Users can also create a new configuration for special situations. (See “Creating a 
New Configuration” on page 3-6.)

Each Siebel subscriber has an individual Siebel Anywhere configuration that 
includes a specific set of components. Usually, the ComponentName entry in the 
Siebel section of the CFG file specifies the configuration of a Siebel client. The Siebel 
Anywhere Administrator establishes the configurations for the Siebel 
implementation. (See “Planning an Upgrade” on page 3-3.) 

The components used by the Siebel eBusiness Application are predefined in Siebel 
Anywhere. Users can also upgrade most third party products used in conjunction 
with Siebel eBusiness Applications.

Logging on as the Siebel Administrator 1

The Siebel database installation process creates a Siebel administrator account that 
can be used to perform the tasks described in this guide. For information on this, 
see Siebel Server Installation Guide, MidMarket Edition.

Any user with Siebel administrator responsibilities should not be associated with 
Siebel Anywhere configurations. For example, a potential problem can occur if a 
Siebel Administrator user is associated to a configuration, then the RepAgent server 
component that is started using that particular LOGIN will perform version check 
against the Siebel Administrator’s dynamically associated configuration. Such a 
scenario could severely impact functionality of the system.

To log on to your Siebel eBusiness Application as the Siebel administrator

■ Start the application and log on using the user name and password assigned by 
your database administrator. 

Siebel Anywhere administrative operations should not be executed on a local 
database or in disconnected mode.

 

Caution: Do not perform system administrative functions on your 
local database. Although there is nothing to prevent you from doing 
this, it can have serious implications. Examples include:

■ Data conflicts

■ Potential for overly large local database

■ Potential for large number of additional transactions to route
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Upgrade Kits 1

A Siebel Anywhere upgrade may contain software or database schema changes 
required to upgrade a specific component. It also defines actions to make the 
changes to the subscriber. The available actions include:

■ Executing any type of program or batch script.

■ Copying, moving, or deleting files.

NOTE: The System Administrator must use the Upgrade Kit Wizard to create an 
upgrade kit. Further into this chapter, you will see that to invoke the wizard is 
simply a matter of clicking Auto Create in the Upgrade Kit view.

After the Siebel Anywhere Administrator creates an upgrade kit, it is automatically 
stored on the Siebel file system, where it is available for retrieval and installation by 
subscribers. 

Upgrade kits created for Siebel servers should always be designated as required kits. 
Database schema kits are Required kits by default.

Required Upgrade Kits
Required upgrade kits must be retrieved and installed on the intended client or 
server. Siebel Clients (Mobile and Dedicated Web) and HQ Servers behave 
differently for required kits. Table 1-2 on page 1-8 describes the behavior of each 
type of client or server during the version check process. 

This process uses information contained in the component registry for each 
subscriber’s configuration. See “Minimum and Maximum Version Fields” on 
page 4-9 and “Applying Versions of an Upgrade Kit” on page 5-5 for details about 
entering and applying appropriate version information for use during distribution 
and installation.
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The table below indicates the client and server behavior for required upgrade kits.

When a Siebel Anywhere subscriber’s version check encounters a discrepancy 
between the version in the component registry and the version of the currently 
installed components, the subscribing system automatically enters a suspended 
mode until the subscriber retrieves and installs the required version. Siebel servers 
automatically stop every task in this mode; Siebel clients can continue to log in, but 
the application will be in a read-only mode.

For a Siebel client subscriber, the system automatically prompts the user to retrieve 
the appropriate upgrade kit and upgrade the components using the Upgrade 
Wizard. For servers the sequence is different. The upgrade kits already exist in the 
file system. 

If the server parameter VersionCheck is set to TRUE and the Siebel server detects 
there is a required upgrade kit, the server shuts down automatically. If 
VersionCheck is set to FALSE, the server will not shut down automatically. However, 
it will stop merging database changes, and the administrator needs to manually 
shut down the server. 

In both cases, when the server shuts down, it prompts the administrator to 
manually install the kit in the appropriate log file using the Upgrade Wizard. The 
associated log files are repagent_<task id>.log and <enterprise 
name>.<siebel server name>.log. If the upgrade kit is not installed, the server 
will not restart.

Table 1-2. Response to Version Check Process When Machine Status Varies

Client or Server Status of Machine: Running Status of Machine: Startup

Mobile Web Client During synchronization:

Yes, upgrade will take place.

No, synchronization ends.

Yes, upgrade takes place.

No, read only mode on the 
node.

Dedicated Web Client Not applicable. Yes, upgrade takes place. 

No, read only mode on the 
node.

HQ Server Not applicable. If Version Check is TRUE, the 
HQ server will not startup until 
upgraded.

If Version Check is FALSE, the 
HQ server will start up.
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Optional Upgrade Kits
An optional upgrade kit is one that is made available to subscribers, but they are 
not required to retrieve and apply the kit. For example, optional upgrade kits are 
useful for making third-party applications, files, or other noncritical components 
available for users to retrieve at their discretion. 

When a subscribing system executes a version check, it does not automatically 
prompt the user to retrieve and install any optional kits. Optional upgrade kits are 
manually retrieved using the Product Updates view, accessible from the Siebel User 
Preferences screen, and are installed using the Upgrade Wizard. (See “Retrieval and 
Installation of Upgrade Kits” on page 6-3.)

Upgrade Kit Creation Architecture 1

The most significant change in Siebel Anywhere architecture is the upgrade kit 
creation process to support Siebel 7 Web deployment. Administrators can use an 
HTML browser without any Siebel software installed on their machines to perform 
the Siebel Anywhere administrative tasks. To accommodate this situation, the 
upgrade kit creation process has two parts:

■ The Upgrade Kit Wizard defines and validates parameters for the upgrade kit to 
be created. It uses a web-enabled user interface. This wizard also handles file 
attachment uploads for certain types of upgrade kits. At the conclusion of 
defining an upgrade kit, the Upgrade Kit Wizard submits a schedule-mode server 
request to invoke the Upgrade Kit Builder.

Caution: Be sure to use the optional kit feature as a method for 
testing every Siebel Anywhere component upgrade. By creating an 
upgrade kit first as an optional kit, the System Administrator can 
thoroughly test the retrieval and installation of the kit from the 
Product Updates view. After testing, the administrator can make the 
kit required or optional.
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■ The Upgrade Kit Builder is part of the Siebel Anywhere Component Group. The 
task of kit creation must be delegated to the server side in order to support the 
web deployment philosophy. When invoked, the Upgrade Kit Builder uses the 
information defined by the Upgrade Kit Wizard to construct upgrade kits. 

During the creation process, the Siebel Administrator can monitor the progress 
of the Upgrade Kit Builder through the Server Component Request screen or the 
Upgrade Kit Builder log file. After building the kit, the status of the newly created 
upgrade kit will be “Pending.”

Upgrade Kit Wizard
Siebel administrators can invoke the Upgrade Kit Wizard by clicking Auto Create in 
the Upgrade Kits view. You must use the Upgrade Kit Wizard to create an upgrade 
kit. 

Upgrade Kit Builder
The Upgrade Kit Builder constructs kits, on the server side, based upon definitions 
of kits collected by the Upgrade Kit Wizard.

Siebel Anywhere Component Group 1

It is strongly recommended that you enable the Siebel Anywhere component group 
on only one Siebel server in the Siebel Enterprise. During the installation of the first 
Siebel server in the Siebel enterprise, do not enable the Siebel Anywhere component 
group. Wait until every Siebel server is installed. Then enable the Siebel Anywhere 
component group on only one Siebel server. For details on how to enable a 
Component group, refer to Siebel Server Administration Guide, MidMarket Edition. 

Upgrade Wizard Recovery 1

The Siebel Upgrade Wizard is a stand-alone executable that reads and applies the 
upgrade kit. The Siebel Upgrade Wizard also tracks the upgrade process and 
automatically recovers from errors. 

During the installation of the upgrade kit, the Upgrade Wizard creates a backup of 
affected files. If an error occurs during the upgrade, the Upgrade Wizard attempts 
to roll back the changes and restore the machine to its original state. Subsequently, 
when the user starts the Siebel client, Siebel eBusiness Applications detects that an 
upgrade is either in progress or has failed and notifies the user.
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The Upgrade Wizard cannot roll back to the previous version after the upgrade has 
been installed successfully. The Siebel Upgrade Wizard also tracks the upgrade 
process and can restart after encountering errors. After a successful upgrade, the 
Upgrade Wizard cleans up (that is, deletes) the interim files in the \temp or 
\upgrade folders. Consequently, restoring to a previous configuration is not 
possible.

For More Information 1

For more information about topics and related information in this chapter, see Siebel 
Server Installation Guide, MidMarket Edition and Siebel Server Administration 
Guide, MidMarket Edition.

The next chapter describes the relationship of the single Siebel Anywhere 
Administration screen to its five views, and the forms and lists within each view.
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 1-11



Siebel Anywhere Overview

For More Information
1-12 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A



Screens and Views in Siebel Anywhere 2
About This Chapter  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-2

Using Screens and Views in Siebel Anywhere  . . . . . . . . . . . . . . . . . . . . 2-2

Configurations View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-3

Employees View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-7

Upgrade Components View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2-12

Upgrade Kits View  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .2-20

Upgrade Kit Items View  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-24

User Preferences Screen and View  . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27

Siebel Product Updates View . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-27

Product Updates Applet  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-28

For More Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2-29
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 2-1



Screens and Views in Siebel Anywhere

About This Chapter
About This Chapter 2

This chapter describes the relationship of the Siebel Anywhere Administration 
screen to its five views and the forms and lists within each view. The chapter also 
explains the relationship between the User Preferences screen, the Product Updates 
view and Product Updates applet to retrieve and install optional upgrade kits.

Using Screens and Views in Siebel Anywhere 2

This section describes the relationship between the single Siebel Anywhere 
Administration screen, its five views, and applets within each view. You must be 
logged on to the Siebel eBusiness Applications as a valid Siebel Administrator in 
order to access this screen. A view presents one or more applets at one time in a 
predefined visual arrangement and logical data relationship. For further information 
about screens, views, and applets see Fundamentals, MidMarket Edition. 

In some cases, users are granted a subset of the Siebel Administrator security. 
Consequently, such users are given access to the Siebel Anywhere Administration 
Views as part of their limited access.

To access the Siebel Anywhere Administration screen and views 

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, select one of the views listed:

■ Configurations. Displays configurations and the related components. Use this 
view to define configurations and to distribute new versions of the 
components. See “Configurations View” on page 2-3 for more information.

■ Employees. Displays the login, first name, and last name of employees 
associated with a given configuration. Use this view to dynamically assign 
employees to a specific configuration. When associating employees to 
configurations, keep in mind the following recommendations:

❏ Do not use this view to permanently assign employees to a configuration. 

❏ Do not dynamically associate the System Administrator to a 
configuration.
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❏ Do not dynamically associate Siebel Tools users to a configuration.

❏ See “Employees View” on page 2-7 for more information.

■ Upgrade Components. Displays information about the components currently 
defined in Siebel Anywhere. See “Upgrade Components View” on page 2-12 
for more information.

■ Upgrade Kits. The starting point for creating new upgrade kits. See “Upgrade 
Kits View” on page 2-20 for more information.

■ Upgrade Kit Items. Displays details about upgrade kit contents and actions. 
See “Upgrade Kit Items View” on page 2-24 for more information.

The following subsections describe each of these views in more detail.

Configurations View 2

Each Siebel Anywhere subscriber requires one or more software components to 
operate. The use of multiple components to operate is called a configuration. See 
Configurations on page 1-5 for a list of the default configurations provided with 
your license.

The Siebel Anywhere Configurations view, shown in Figure 2-1 on page 2-4, lists 
each configuration and its related components. The Active column indicates if the 
configuration is enabled. The Distribute button delivers current upgrade component 
information to the users of the configuration; the information is essential to the 
version-checking process invoked on the user’s machine.

Use this view to:

■ Define configurations. A preinstallation task that is important—especially for 
global deployments—is determining how to segregate the user base to provide 
capability to distribute upgrade kits based upon user needs. See Global 
Deployment Guide, MidMarket Edition for more details. Also see “Planning an 
Upgrade” on page 3-3.
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■ Distribute required versions of the component. Allows delivery of upgrade kits to a 
specific configuration. See “To distribute upgrade component version 
information” on page 5-7.

NOTE: The parameter ComponentName in the configuration (.cfg) file has a default 
value that matches its corresponding Siebel Anywhere configuration. For example, 
the configuration file for the English version of the Siebel Sales Client (siebel.cfg) 
contains the following default entry: ComponentName = Siebel Sales Client. The 
file’s location is {ClientRootDir}\bin\ENU\siebel.cfg. If a new configuration 
is created, a configuration is split or merged with another configuration, or the 
name of an existing configuration is changed, the ComponentName parameter on 
the corresponding Siebel clients must also be updated so that the clients can detect 
any upgrades.

Figure 2-1. Siebel Anywhere Configurations View
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Upgrade Configurations Applet
The Configurations applet lists the configurations available in Siebel Anywhere. A 
description of the fields for the Configurations applet is shown in Table 2-1.

Related Components Applet
The Related Components applet lists the components related to the configuration 
selected in the Configurations applet. A description of the fields for the Related 
Components applet is shown in Table 2-2.

Table 2-1. Fields in the Configurations Applet

Field Comment

Name This is the name of the configuration.

Active The configuration is being version-checked by subscribers.

Component Type This value is either client or server configuration.

Comments Comments can be entered here.

Table 2-2. Fields in the Related Components Applet (1 of 2)

Field Comment

Name Name of the component.  Only single-byte, alphanumeric 
characters, blank space, underscore, and dash are allowed. They 
may not include special characters like periods or other invalid 
characters such as slash, asterisk, pipe, question mark, colon, 
quotes, or angle brackets.

Required at Startup If this field is checked, the component is required on the Siebel 
subscriber and is verified during version checks. This field should be 
checked for any upgrade component that will have required 
minimum versions.

Components that are not required are not subject to version checks 
and are not automatically upgraded. However, the version checking 
for the upgrades is automatic if the user chooses to upgrade.

Min Version Minimum version required for the component on the client’s system.

If the client uses a version of the component that is less than the 
minimum, the client must upgrade or the application will appear in 
read-only mode.
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Clicking Distribute makes the minimum/maximum version information available to 
Siebel Anywhere subscribers. A new kit is not available, as either a required or an 
optional kit, until the new minimum and maximum version information is 
distributed.

NOTE: It is strongly recommended that you thoroughly test upgrade kits using Siebel 
Test Client configuration before distributing them as required or optional kits. You 
can test the retrieval and installation of the kit from the Product Updates view on 
individual client machines. 

Max Version Maximum version allowed for the component on the client’s system.

If clients use a version of the component that is between the 
minimum and maximum, they can still use the application in read/
write mode without installing an upgrade kit, even if the upgrade kit 
is required. 

Clients can access the system if their local version is higher than the 
maximum version for the component.

Comments Comments can be entered here.

Table 2-2. Fields in the Related Components Applet (2 of 2)

Field Comment
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Employees View 2

Use the Siebel Anywhere Employees view, shown in Figure 2-2, to dynamically 
move clients from one configuration to another or limit the distribution of a specific 
kit. Siebel Anywhere uses the value of ComponentName in the client’s CFG to 
determine what configuration the client is using and what component version it 
should check. This checking occurs only if the client’s name is not specified under 
a specific configuration. (See “Assigning Employees to Configurations” on 
page 3-7.)

If the login is specified under an Employees view, then Siebel Anywhere does not 
check the .cfg any further and only checks the version of the component listed 
under the associated configuration for that client. Use this only for unique 
situations—it is not recommended as a routine practice. 

NOTE: The first time a mobile Web client connects to the Remote Server to initialize 
the local database, Siebel Anywhere will do a version check for the client using the 
Upgrade Configuration as specified in the CFG file. If there is a dynamic association 
defined in the Employees view, Siebel Anywhere will not know about it at this time. 
However, after the mobile Web client successfully initializes the local database, the 
dynamic association with the Upgrade Configuration will be available for Siebel 
Anywhere to recognize. 

Figure 2-2. Siebel Anywhere Employees View
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This view is recommended for temporarily assigning employees to specific 
configurations for testing or retrieval of special kits. 

Upon synchronization (for mobile users) or login (for dedicated users), Siebel 
Anywhere first checks to determine if you are subscribing to a specific 
configuration. If this column is null, then Siebel Anywhere checks the 
ComponentName in the client’s .cfg to determine what configuration the client 
subscribes to. In other words this screen overrides the ComponentName in the .cfg 
for mobile and dedicated users alike. 

This allows you to create, activate, apply, and then limit distribution of a kit only to 
a specific configuration.  Consequently, only a few mobile and dedicated users, who 
temporarily subscribe to this configuration, can test the kits for you.

For example, you could put a user’s login name under Siebel Test Client 
configuration and, without changing the user’s .cfg, have the user receive the 
upgrade kit and test it. After the kit is successfully tested, you can remove names 
from the Employee screen and distribute the kit to every appropriate configuration 
so the intended users will receive it.

You can also use this screen to limit the distribution of a specific kit to certain users. 
For example, you might have a situation where you want to send a set of reports 
only to management. 

The following tasks are necessary to limit kit distribution for a new configuration:

■ Create, activate, and apply the kit. For details regarding these procedures, see 
Chapter 4, “Creating and Defining the Upgrade Kit” and Chapter 5, “Activating, 
Applying, and Distributing the Upgrade Kit.”

■ Create a new configuration. Associate the component you just built to a kit for this 
configuration. For details regarding these procedures, see “Creating a New 
Configuration” on page 3-6.

■ Add the login of the users. Add the login for the users you want to receive this kit 
to the Employee view for this configuration. For details regarding these 
procedures, see “Employees View” on page 2-7.

■ Distribute the configuration. This will distribute the kit to this selected group of 
users and your other users will not know about this newly distributed kit. For 
details regarding these procedures, see Chapter 5, “Activating, Applying, and 
Distributing the Upgrade Kit.”
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■ Give these clients enough time to download the kit. You need to disassociate these 
clients from this special configuration as soon as possible. This will allow them 
to continue their subscription to their original configuration and can receive kits 
targeted for those users. For details regarding these procedures, see “Employees 
View” on page 2-7.

Another approach to limiting distribution is to create a new upgrade component just 
for a special occasion. For example, you need to deliver a set of sensitive files to a 
small group through Client Customer Revisions. 

The following tasks are necessary to limit kit distribution for a new component:

■ Create a new component. Name this new component Client Customer Revisions - 
special. For details regarding these procedures, see “Creating a Custom 
Component” on page 3-16.

■ Modify the LOCATE information columns. This will help prevent confusing the kits 
for limited distribution with the regular Customer Revisions kits. For details 
regarding these procedures, see “Creating a Custom Component” on page 3-16.

For example you can specify the Locate Information as 
Siebel,ClientRootDir,bin/clntspl.cfg.

■ Create, activate, and apply the kit. Use the new component that you just created. 
For details regarding these procedures, see Chapter 4, “Creating and Defining 
the Upgrade Kit” and Chapter 5, “Activating, Applying, and Distributing the 
Upgrade Kit.”

■ Add the new component. Add the new component to the configuration that you 
want this new kit to be distributed to. For details regarding these procedures, see 
“Setting Up Configurations” on page 3-5.

Caution: This step is very important to maintain integrity of the 
limited distributions—it is a security feature. If you do not 
modify this information, you may send many users information 
intended only for a few, such as confidential reports.
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■ Distribute. This will distribute the kit to this selected group of users and your 
other users will not know about this newly distributed kit. For details regarding 
these procedures, see “Distributing Upgrade Component Version Information” 
on page 5-7.

Siebel Anywhere will not allow an Employee to be dynamically associated with 
more than one configuration. For example, if the employee JSMITH is dynamically 
associated with Configuration A and the Siebel Administrator then associates 
JSMITH with Configuration B, JSMITH will automatically be disassociated from 
Configuration A and only dynamically associated with Configuration B. 

Dynamically associating the System Administrator account with any configuration 
under the Employees view is not recommended.

The Siebel Administrator should be aware of the expected behavior in case an 
employee is accidentally associated with the incorrect configuration. When this 
situation occurs, the employee will be disassociated from the correct configuration. 

The Siebel Administrator can choose an audit mechanism (for example, a query) to 
make sure that the expected employees are dynamically associated with a 
configuration. 

The Employees view under the User Administration screen in the Configuration 
field will identify the configuration an employee belongs to if any.

If an employee will use more than one installation of the Siebel client in the same 
Siebel eBusiness implementation, do not associate that employee to a configuration. 
For example, if the Employee JSMITH chooses to install and use both Siebel Call 
Center and Siebel Sales, then that employee should not be dynamically associated 
with a Siebel Anywhere configuration. The reason is the upgrade kit for one 
configuration will likely be different than the upgrade kit for another configuration. 

Caution: Use limited distribution with extreme caution because 
this process will change your component version number 
permanently. When you create the next kit of the same type, you 
must adjust the Minimum Version Number so it does not require 
users to download the special kit.
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In this example, the CFG file (or .cfg) would be different for the Siebel Call Center 
and Siebel Sales configurations. If JSMITH were dynamically associated to the Call 
Center configuration and logged on using the Siebel Sales client, the version check 
would only detect that there was a new upgrade kit and would not differentiate 
between the two installations of the Siebel client.

The Employees view has two applets: Upgrade Configurations and Upgrade 
Employee Configuration.

Upgrade Configurations Applet
The Upgrade Configurations applet lists the configurations available in the 
Employee view. These are the same configurations that appear in the Upgrade 
Configurations view; see Upgrade Configurations Applet on page 2-5 for a 
description of the fields.

Upgrade Employee Configuration Applet
The Upgrade Employee Configuration applet lists the employees who are 
dynamically associated to the configuration selected in the Upgrade Configurations 
applet. A description of the fields for the Upgrade Employee Configuration applet is 
shown in Table 2-3.

Table 2-3. Fields in the Upgrade Employee Configuration Applet

Field Comment

Login Login for user

First Name First Name

Last Name Last Name
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Upgrade Components View 2

The Upgrade Components view, shown in Figure 2-3, lists each upgrade 
component, its related components and relevant information about each. Use this 
view to:

■ Relate one component to another. See “Relating One Component to Another” on 
page 7-7.

■ Check existing component version and location information. See “Verification of 
Existing Component Information” on page 3-4.

■ Add your own components. See “Creating a Custom Component” on page 3-16.

A Siebel Anywhere configuration contains one or more upgrade components. The 
Siebel Administrator can include any of the following upgrade components, or 
component types, in a configuration. Seeded components are available based upon 
the languages installed on the database server. These upgrade components include:

■ Siebel Call Center CFG__{language code}

■ Siebel Client Customer Revisions__{language code}

■ Siebel Client Executables__{language code}

■ Siebel Client Repository File__{language code}

Figure 2-3. Siebel Anywhere Upgrade Components View
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■ Siebel Database Schema

■ Siebel Database Schema {Version Check}

■ Siebel Sales CFG__{language code}

■ Siebel Server Customer Revisions__{language code}

■ Siebel Tools CFG__{language code}

■ Siebel Upgrade Wizard

■ Third Party – Adobe Acrobat Reader

■ Third Party – Microsoft Word

■ Custom Components

See “Creating a Custom Component” on page 3-16.

NOTE: {language code} refers to the language installed during database installation 
or added to the database.

Siebel eBusiness Applications provides several Upgrade Components out-of-the 
box. The Siebel Administrator can also register additional Siebel Anywhere 
components or other third-party software and other elements. Siebel Anywhere can 
upgrade these components, just as it does the predefined components used by 
Siebel eBusiness Applications. For example, it would be possible to create an 
upgrade component to run a batch program in the form of a .bat or .exe file. Each 
upgrade component is classified by a component type:

■ Siebel Configuration File

■ Siebel Database Extensions

■ Siebel Executables

■ Siebel Repository File

■ Third-Party Software

■ Customer Revisions

The Upgrade Components view lists each Upgrade Component and the information 
from the latest Upgrade Kit associated with it; see Table 4-1 on page 4-5.
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The Siebel Administrator must define how Siebel Anywhere will monitor and verify 
the version number for a custom upgrade component. Siebel Anywhere maintains 
an individual version number for each upgrade component. The version number 
must be maintained on a Siebel Anywhere subscriber in order to compare it to the 
version number in the component registry. The Siebel Administrator can maintain 
the version number in the application, in a file, or in the Windows registry.

NOTE: It is strongly recommended the Siebel Administrator use the Copy Record 
functionality to copy existing upgrade components and simply rename the new 
upgrade component so that the correct parameters are used for the new upgrade 
component. Make sure that you also update the Locate and Version columns 
appropriately.

The Upgrade Components view has two applets—Upgrade Components and Related 
Components. 

Descriptions of the fields in these applets are listed in the next section. For 
information on specific use of these fields, see Upgrade Components Applet on 
page 2-14 and Related Components Applet on page 2-19.

Upgrade Components Applet
The Upgrade Components applet lists the Siebel Anywhere components along with 
detailed information regarding each component’s version check. A description of 
the fields for the Upgrade Components applet is shown in Table 2-4. 

Table 2-4. Fields in the Upgrade Components Applet (1 of 2)

Name Comment

Name Name of the Siebel Anywhere subscriber or component.

Component Type The type of component kit; for example, Siebel Executables or 
third-party software.

Min Version The minimum version for which an upgrade is applied.

Max Version The maximum version for which an upgrade is applied.

Locate Method Method used by the Siebel Anywhere subscriber to locate a 
component in order to check its version.
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See “Version Information Checking” on page 2-15 for a description of how Siebel 
Anywhere uses Locate Method, Locate Information, Version Method, and Version 
Information to determine the version of a component.

NOTE: Until you click Distribute in the Siebel Anywhere Configurations view, 
changes to the minimum or maximum versions in the Upgrade Components view 
are not available to Siebel Anywhere subscribers. Usually, you should not modify 
Location Information in the Upgrade Components view. This information is 
specified through the Upgrade Kit Wizard.

Version Information Checking
The Siebel Anywhere Version Check feature combines information in the Locate 
Method, Locate Information, Version Method, and Version Information fields to 
determine how it needs to check the version of a component. Depending on the 
component, Version Check uses some or all of these. Table 1-1 on page 1-5 indicates 
when a version check occurs for each type of subscriber.

The following subsection describes Locate Method and Version Method followed by 
a few examples of each.

Locate Information Variables used by the Siebel Anywhere subscriber when invoking 
the Locate Method.

Version Method Method used by the Siebel Anywhere subscriber to check the 
component’s version.

Version Information Variables used by the Siebel Anywhere subscriber when invoking 
the Version Method.

Comments This field is available for comments.

Table 2-4. Fields in the Upgrade Components Applet (2 of 2)

Name Comment
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Locate Method
The purpose of Locate Method is to build a path to a file, or other location such as 
a registry. This value is then passed to the Version Method to read the version of the 
file. See Table 2-5 for Locate Method values.

Table 2-5. Locate Method Values

Value Comment

Siebel Root Determines location based on the client’s Siebel root directory. Locate 
Information is ignored in this case. (For example, this method would be 
used for Siebel Client Repository File components.)

Both server and client use this to retrieve the value of Siebel Root.

Registry Determines location based on information in the Microsoft Windows 
registry. Locate Information would contain the path in the registry to 
read. (For example, this method would be used for Third Party - 
Microsoft Word components.)

Environment Determines the location on the client by reading an environment 
variable. The parameter Locate Information would contain the name of 
the environment variable to read. 

Common Core 
Facility 

Determines location on server from a set of common core facility (CCF) 
parameters. Locate Information would contain the value from the CCF 
program context. (For example, this method would be used for a Siebel 
Server Customer Revision component.)

CFG Determines location based on reading the client’s active .cfg. Locate 
Information would contain the section and entry to read from the .cfg, 
plus an optional value to append to the value read from the .cfg. (For 
example, this method would be used for a Siebel Client Customer 
Revision component.)

File Name Determines location based on reading the client’s active .cfg. Locate 
Information would have the correct name of the client’s active .cfg.
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Version Method
This field provides additional information that is used in conjunction with Locate 
Method to read the version of a file. See Table 2-6 for Version Method values.

Table 2-6. Version Method Values

Value Comment

File Version Determines version based on reading the version of a file. Version 
Information would contain the name of the file to version check. This 
method is mainly used with the registry.

Registry Determines version based on reading the version from the registry. 
Version Information would contain the path in the registry to read.

Environment Determines the version based on reading an environment variable. 
Version Information would contain the name of the environment 
variable.

DLL Determines the version based on executing an entry point in a DLL 
file. Version Information would contain the name of the DLL file and 
the name of the entry point. For example, 
bin\sslcver.dll,VersionString executes the function 
VersionString in the file bin\sslcver.dll. 

Database Determines the version based on reading the Siebel Database Schema. 
Version Information is ignored in this case.

CFG Determines version based on reading the client’s active .cfg. Version 
Information would contain the section and entry to read from the 
.cfg, plus an optional value to append to the value read from the 
.cfg. (For example, this method would be used for a Siebel Client 
Customer Revision component.)

SRF Determines the version based on reading the .srf. Version 
Information would contain the section name and the entry name from 
the active .cfg to be read to determine the name of the .srf.
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Examples of the Locate and Version Methods
The following two examples explain how Version Check works.

Example: Siebel Client Customer Revision__{language code}

Given: Contents of the fields are:

Locate Method: CFG

Locate Information: Siebel,ClientRootDir,bin\enu\clntrev.cfg 

Version Method: CFG

Version Information: Siebel,Version

Locate Method: CFG that indicates to read from client’s active cfg file.

Locate Information: Siebel,ClientRootDir,bin\{language 
code}\clntrev.cfg means to read the entry ClientRootDir from the section 
[Siebel], in client’s active .cfg and append bin\{language 
code}\clntrev.cfg to it. This request can return a patch such as 
c:\siebel\bin\{language code}\clntrev.cfg. This assumes C:\siebel to 
be the value of ClientRootDir under [Siebel] section in the CFG file.

Version Method and Version Information: Indicates to read from the file identified 
above (clntrev.cfg) and retrieves version number from the [Siebel] section.

Example: Siebel Client Repository File__{language code}

Given: Content of the fields are:

Locate Method: CFG

Locate Information: Siebel,ClientRootDir,objects\enu

Version Method: SRF

Version Information: Siebel,RepositoryFile

Locate Method: CFG that indicates to read from client’s active .cfg. 
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Locate Information: Siebel,ClientRootDir,objects\{language code} which means 
to read the entry ClientRootDir from the section [Siebel], in client’s active .cfg. 
This request should return a path such as c:\siebel\objects\{language 
code}.

Version Method and Version Information: Indicates to read from the client’s active 
CFG and retrieves the value for the RepositoryFile entry under the [Siebel] 
section. 

Version Check then builds a string from the value obtained from Locate Method 
and Locate Information + “objects\{language code}” + the value obtained 
from Version Method and Version Information to locate the file for version 
checking. This will return something like 
c:\siebel\objects\enu\siebel.srf.

Related Components Applet
The Related Components applet allows you to view how components relate to other 
components. A component will have related components if one component 
depends upon another component to function properly. To control the order of 
upgrades, use the Upgrade Kits View, “Upgrade Kit Components Applet” on 
page 2-23.
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Upgrade Kits View 2

The Upgrade Kits view, shown in Figure 2-4, lists the upgrade kits and relevant 
information about each. It is where upgrade kits are defined and maintained—this 
is the default view when opening the Siebel Anywhere Administration screen.

Use the view in Figure 2-4 to:

1 Create upgrade kits. See Chapter 4, “Creating and Defining the Upgrade Kit.”

2 Activate new upgrade kits. See Chapter 5, “Activating, Applying, and Distributing 
the Upgrade Kit.”

3 Apply upgrade kit version information to the upgrade component registry. See 
Chapter 5, “Activating, Applying, and Distributing the Upgrade Kit.”

4 Deactivate kits. See “Deactivating the Upgrade Kit” on page 5-4.

Figure 2-4. Siebel Anywhere Upgrade Kits View
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The Status column indicates whether the Upgrade Kit is Request Submitted 
(awaiting for Server to pick up) or In Progress (in process of being created). The 
status column may have other values as well such as Pending, Active, Error, and so 
on. It is not limited to just Request Submitted and In Progress. Table 2-7 describes 
the values and description of the Status column.

A Siebel Anywhere upgrade kit can contain the software or database schema 
changes required to upgrade a specific component and defines the actions to apply 
the changes to the subscriber. The available actions include executing any type of 
program or batch script, copying files, moving files, or deleting files.

NOTE: The Siebel Administrator must use the Upgrade Kit Wizard to create an 
upgrade kit. Siebel Administrators invoke the Upgrade Kit Wizard by clicking Auto 
Create in the Upgrade Kits view. 

After the Upgrade Kit Wizard has been invoked, the Siebel Administrator selects the 
desired upgrade component to create an upgrade kit for it. The processes for 
creating various types of upgrade kits are outlined in the following section. It is 
important to remember that any files, scripts, and so on are not stored as is after 
they are included in an upgrade kit; instead, they are stored in a condensed, 
uniquely named file in the Siebel file system.

Table 2-7. Status Column Values and Definitions, Upgrade Kit View

Values Description

Request Submitted Request has been submitted to the server to create a new upgrade 
kit.

In Progress Creation of new upgrade kit is underway on the server.

Pending Kit successfully created and ready to be activated.

Active Kit is ready to be applied and distributed.

Inactive Kit on hold and not ready for further processing. First step to 
activate the kit is to change status to Pending. Then you can 
activate it.

Error Indicator that there was an error while creating the kit.
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The Siebel Administrator identifies the Minimum Version Number, Maximum 
Version Number, and New Version Number while creating the upgrade kit. These 
version numbers apply to the upgrade component that was selected for the upgrade 
kit. By default, Siebel Anywhere will increment the current version number for the 
upgrade component by one (1) and use this value for the New Version Number.

The Upgrade Kits view has two applets—Upgrade Kits and Upgrade Kit 
Components.

Upgrade Kits Applet
The Upgrade Kits applet displays each upgrade kit defined in the system. The 
applet’s fields are described in Table 2-8.

 

Table 2-8. Fields in the Upgrade Kits Applet

Name Comment

Name Automatically generated name of the upgrade kit. The name includes the 
component name and version in the kit. The name cannot be modified once 
the kit is created. The user can specify the name (it is called title on an 
Upgrade Kit Wizard page) when creating the kit. However, please use 
descriptive names if you do not accept the default wording. Also see 
Table 2-2 on page 2-5 for additional limitations for a name.

Status For definition of Status and the associated values and descriptions, see 
Table 2-7 on page 2-21.

File Size Size of the physical file containing the upgrade kit.

File Date Date that the upgrade kit file was created.

Comments This field is available for comments.

Caution: Deactivating a previously distributed kit could cause 
mobile users to have an unsuccessful synchronization. Also, this 
action places them unnecessarily into a read-only state.
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The Upgrade Kits applet has the following buttons:

■ Auto Create. Invokes the Upgrade Kit Wizard.

■ Activate. Gathers the specified files for the upgrade and creates a single archive 
file. 

■ Apply Versions. Invokes the Apply Upgrade Kit page. Applies the upgrade kit 
version information to the upgrade components registry. The Apply Upgrade Kit 
page allows you to make a kit required instead of optional. 

Upgrade Kit Components Applet
The Upgrade Kits Components applet displays the components associated with the 
upgrade kit. The components are automatically created by the Upgrade Kit Wizard 
when you click Auto Create on the Upgrade Kits applet. Do not delete the default 
records in the Upgrade Kit Components applet.

The Upgrade Kit Components applet displays the fields shown in Table 2-9. 

This applet also controls the upgrade kit sequence—the order of upgrades. For 
example, if Kit 1 should be applied before Kit 2, add component Kit 1 upgrades as 
Upgrade Kit Components of Kit 2. For details, refer to “Controlling the Order of Kit 
Installation” on page 7-6.

Table 2-9. Fields in the Upgrade Kit Components Applet

Name Comment

Name Name of the component.

Min Old Version Minimum component version that a subscriber must have in order to 
apply this upgrade kit.

Max Old Version Maximum component version that a subscriber may have in order to 
apply this upgrade kit.

New Version New version of the component.

Comments This field is available for comments.
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Upgrade Kit Items View 2

A Siebel Anywhere upgrade kit contains one or more upgrade kit items, which are 
the actions to be performed and the files associated with those actions. The Upgrade 
Kit Items view (Figure 2-5 on page 2-25) can be used to view the items, the defined 
sequence of events, and so on.

Siebel Administrators must use the Upgrade Kit Wizard to create upgrade kits. The 
Upgrade Kit Wizard automatically defines the upgrade kit items and sequence of 
events. When you activate the upgrade kit, the kit items you see in this view turn 
into item entries in the upgrade.ucf, which is part of every Siebel Anywhere upgrade 
kit. 

Upgrade.ucf is the driver file for the Upgrade Wizard to apply the upgrade kit. It 
contains an ordered list of action items for the Upgrade Wizard to execute during 
the installation of the upgrade kit.
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Use this view to review items and steps in an upgrade kit. See Chapter 5, 
“Activating, Applying, and Distributing the Upgrade Kit.”

The Upgrade Kit Items view has three applets—Upgrade Kits, Upgrade Kit Items, 
and Upgrade Kit Item Parameters. The Upgrade Kits applet is described in “Upgrade 
Kits Applet” on page 2-22 of this guide. 

Figure 2-5. Siebel Anywhere Upgrade Kit Items View
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Upgrade Kits Applet
The Upgrade Kits applet displays each upgrade kit defined on the system. These are 
the same kits that appear in the Upgrade Kits View described earlier in this chapter; 
see “Upgrade Kits View” on page 2-20. 

Upgrade Kit Items Applet
The Upgrade Kit Items applet displays the individual items or actions to be executed 
by the upgrade kit. Table 2-10 displays the field descriptions for this applet. 

Table 2-10. Fields in the Upgrade Kit Items Applet

Field Comment

Sequence The order in which the Upgrade Wizard executes the item. 

Title The title of the item, which is displayed in the Upgrade Wizard.

Item Type The type of item to execute.

Estimated Disk Space The disk space required to download and execute an item 
(optional). The Upgrade Wizard validates that this amount of free 
disk space is available before applying the upgrade kit. If adequate 
disk space is not available, the Upgrade Wizard returns an error 
message. 

Comments This field is available for comments.
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User Preferences Screen and View 2

This section describes the relationship between the Product Updates view and the 
Product Updates applet. This view is only available on dedicated and mobile Web 
clients.

Siebel Product Updates View 2

Siebel client subscribers use the Product Updates view of the User Preferences 
screen for retrieving and installing optional upgrade kits. This view also allows 
client subscribers to query and see their current update status. An example of the 
Product Updates view is shown in Figure 2-6 on page 2-28. 

NOTE: Configuration changes are not reflected in the Product Updates view until a 
reconnection occurs.

There are two types of upgrade kits for Siebel client subscribers: required and 
optional. Upgrade kits created for Siebel servers should always be required.

Caution: It is strongly recommended that System Administrators 
choose the proper logical settings within Siebel Anywhere to make 
sure upgrade kits created for Siebel servers are always required.
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As a Siebel Anywhere Administrator, you use the Product Updates view to test 
upgrade kits on individual client machines before making the kit required. See 
“Distributing Upgrade Component Version Information” on page 5-7 for more 
information on testing kits.

Product Updates Applet 2

The Product Updates view has one applet, of the same name. The Product Updates 
applet fields are described in Table 2-11.

 

Figure 2-6. Product Updates View

Table 2-11. Fields in the Product Updates Applet (1 of 2)

Field Comment

Upgrade Check this field to upgrade the component.

Component Name Name of the upgrade component.

Status Status of the upgrade kit. Values can include the following:

■ Upgrade Available - an upgrade kit available for you to 
retrieve, either required or optional.

■ Upgrade Required - can operate in read-only mode until kit 
is installed.

■ Version OK - versions of your software components are 
current.

■ Upgrade Not Available - the software component is out-
dated and needs to be updated; however no kit is available 
to do this. Contact your system administrator.

Current Version The version of the component on the client machine.
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The Product Updates applet has an Upgrade Selected Components button, which 
invokes the Upgrade Wizard. See “Retrieval and Installation of Upgrade Kits” on 
page 6-3 for more details.

For More Information 2

For more information about topics and related information in this chapter, see 
Fundamentals, MidMarket Edition and Global Deployment Guide, MidMarket 
Edition.

The next chapter describes the planning and preliminary tasks to prepare the 
components necessary to define upgrade kits. Make sure you allow enough time to 
plan your upgrades.

Minimum Version The minimum allowable version of the component.

Maximum Version The maximum allowable version of the component.

Upgrade Size (bytes) The size of the upgrade kit.

Download Time (mins) The estimated time to download the kit on a 28.8 modem.

Table 2-11. Fields in the Product Updates Applet (2 of 2)

Field Comment
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 2-29



Screens and Views in Siebel Anywhere

For More Information
2-30 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A



Upgrade Planning and Preliminary Tasks 3
About This Chapter  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-2

Upgrade Planning and Preliminary Tasks Process Flow . . . . . . . . . . . . . . 3-2

Planning an Upgrade  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

Test Plan Strategy  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

Upgrade Kit Requirements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-3

Verification of Existing Component Information  . . . . . . . . . . . . . . . . 3-4

Setting Up Configurations . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-5

Adding Components to a Configuration  . . . . . . . . . . . . . . . . . . . . . . 3-5

Removing Components from a Configuration . . . . . . . . . . . . . . . . . . . . . . 3-6

Creating a New Configuration . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-6

Assigning Employees to Configurations  . . . . . . . . . . . . . . . . . . . . . . 3-7

Preparation of Upgrade Kit Contents  . . . . . . . . . . . . . . . . . . . . . . . . . . 3-9

Siebel Executables  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-10

Database Schema Extensions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-13

Siebel Repository Files, Third-Party Applications, and 
Other Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-15

Creating a Custom Component  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .3-16

For More Information . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 3-17
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 3-1



Upgrade Planning and Preliminary Tasks

About This Chapter
About This Chapter 3

This chapter helps you understand how to use Siebel Anywhere to plan and 
accomplish preliminary tasks. Upgrades may include new versions of Siebel 
eBusiness applications, custom extensions to the database schema, custom Siebel 
eBusiness configurations, third-party files or applications, or the associated 
language packs for each supported language included within the Siebel eBusiness 
Applications. If necessary, you can create your own custom components or 
configurations, using the procedure described in this chapter.

Upgrade Planning and Preliminary Tasks Process Flow 3

The following list describes the tasks in this process: 

1 Understand the requirement. First, make sure you understand exactly what needs 
to be done to plan and implement the upgrade. 

2 Set up configurations. Planning includes identifying upgrade components, or 
language packs, for each end-user language. An example of a language choice 
would be one associated with a specific language such as enu_1252.dbf for 
English, deu_1252.dbf for German, and ptb_1252.dbf for Brazilian Portuguese. 
Be sure to use the correct end-user language pack (or upgrade component for 
each language included in the Siebel eBusiness Application) while creating 
upgrade kits. See “Planning an Upgrade” on page 3-3.

3 Prepare upgrade kit contents. Gather the software, files, or database schema 
updates required for the kit into the appropriate directory (remember, one kit at 
a time). The specific process to follow depends on the type of components you 
are planning to upgrade. See “Preparation of Upgrade Kit Contents” on page 3-9.

NOTE: Some kits do not require any files. For example, Database Schema kits do 
not require any files to create a kit.

You must use the Upgrade Kit Wizard to define the upgrade kit. See “Defining 
the Upgrade Kit” on page 4-3. 
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Planning an Upgrade 3

Careful planning and thorough testing are essential to avoid problems during an 
upgrade. Siebel Anywhere has the capability to distribute and apply upgrades 
across the organization, thereby underscoring the necessity for planning and 
testing.

Test Plan Strategy 3

To successfully upgrade with Siebel Anywhere, create the kit as an optional kit and 
distribute the component information to test it as an optional kit. If the kit will 
remain optional, that is the only testing that is required. If the kit will be required, 
then test the kit using the Test Client Configuration. When you are successful using 
various tests and forms of clients, release the kit to production.

Upgrade Kit Requirements 3

Before you begin the process of creating upgrade kits, you need to understand the 
requirement for the upgrade. You need to define exactly how many and what type 
of upgrade kits are required and to whom they will be distributed. 

The number and type of upgrade kits required for your upgrade depend on your 
subscribers and the components to be upgraded. For example, you may be 
preparing to upgrade to a new version of your custom Siebel configuration, 
requiring the distribution of a new .srf to every mobile and dedicated user. 

Your custom configuration may also need to apply database schema changes to your 
Siebel databases and to the local databases of Mobile Web clients. Database schema 
changes are not distributed by a kit to dedicated Web clients. Creating a database 
schema kit applies the changes from the logical schema to the physical schema. 
These changes are visible to dedicated Web clients, without distribution through a 
kit, because they connect directly to the Siebel Server Database.

You must create an upgrade kit for each component to be upgraded. In the 
preceding example, you would need to create one upgrade kit for the Siebel Client 
Repository File and a second upgrade kit for the database schema extensions. 

Caution: Any errors in an upgrade kit, whether in the files being 
distributed or in application processes defined for them, can have 
rapid and widespread impact on your production environment.
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It is a good idea to compile a list of the upgrade kits you will need and then check 
the existing component information against the new requirements. For example, 
look up the minimum and maximum version information existing on your 
production client systems. 

The remainder of this chapter describes other tasks to prepare for upgrades. Where 
a given step varies by component to be upgraded, specific instructions for each 
component are provided.

Verification of Existing Component Information 3

An important part of planning for a new upgrade kit is checking the existing 
component information. You need to make note of the current version requirements 
and any special parameters for the specific components.

To check the current minimum and maximum version information, go to the 
Upgrade Components view. This view lists the minimum and maximum version 
numbers, as well as the Locate and Version Methods.

The Siebel Remote Client Status view contains the Siebel Anywhere version 
information in the Product Versions field for mobile users only. For more 
information about this view, see Siebel Remote Administration Guide, MidMarket 
Edition. To check on special parameters, go to the Upgrade Kit Items view. This view 
provides information on item type and estimated disk space, as well as parameter 
values. Parameter values appear in the Upgrade Kit Item Parameters applet.

You should use the following approach for testing upgrades:

For Siebel client and Siebel Server upgrades, first create the upgrade in your 
development or test environment as an optional kit. Test it manually on several 
clients. Validate that the kits can be retrieved successfully and applied in this 
environment while paying close attention to the version information.

For further information on testing, see Chapter 6, “Retrieving, Installing, and 
Testing Upgrade Kits.”

Caution: Create and test kits required for the upgrade before you 
click Distribute on the Siebel Anywhere Configurations view. Each 
time you click Distribute, a transaction is added for your mobile 
users. This addition causes a new prompt to notify mobile users of 
a possible required upgrade kit.
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The Configuration view allows you to review the components in each of the defined 
configurations and make changes according to your company needs. This section 
describes how to use the Configuration view.

Adding Components to a Configuration 3

At times, you may need to add components to an existing configuration.

To add a component to a configuration

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, select Configurations.

3 In the Upgrade Configurations list, select the configuration to which you want 
to add a component.

4 In the Related Components list, click New.

5 In the Upgrade Components dialog box, select the component you want to add, 
and click the pick button. 

The component remains selected (highlighted) in the Related Components list.

6 If you want version checking to occur for the selected component when the 
client starts up, click in the Required at Startup field.

Repeat Step 3 through Step 6 for any additional components you want to add.
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Removing Components from a Configuration 3

At times, you may need to remove components from an existing configuration.

To remove a component from a configuration

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, select Configurations.

3 From the Upgrade Configurations list, select the configuration from which you 
want to remove a component.

4 On the Related Component list, select the component you want to remove. 

5 In the Related Components list, click the menu button and select Delete Record.

6 In the dialog box, confirm this is the record you want to delete.

Repeat Step 3 through Step 6 for any additional components to be removed from 
this configuration.

Creating a New Configuration 3

In most cases, the configurations provided with Siebel Anywhere are sufficient. 
However, you can create new configurations for special situations or to represent 
different installed clients within your company. 

For example, if everyone in your company uses Siebel Sales and you need to 
distribute certain upgrades to employees in remote offices separately from the rest 
of the company, you would create a new configuration to accommodate this 
situation. The employees in the remote offices would be temporarily associated 
with the new configuration in order to distribute the special upgrade just to them. 
(See “Assigning Employees to Configurations” on page 3-7 for details on associating 
specific employees with a configuration.) 

Also, you may need to create different configurations based upon language usage. 
If there is a set of the users in your company only using ENU and another set using 
both ENU and DEU, you should create two different configurations. 

If there is a need to create a new configuration for long term use (as in language 
usage), you must make sure that every client CFG file is appropriately updated. 
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To create a new configuration 

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Configurations.

3 From the Upgrade Configurations list, click menu and then New Record. 

A blank record appears.

4 Complete the necessary fields.

Limit the Name field to 91 characters or less. 

5 Add appropriate Related Components to the new configuration you just created.

To do this, see “To add a component to a configuration” on page 3-5.

Assigning Employees to Configurations 3

The purpose of assigning employees to configurations is to handle uncommon 
situations. In most cases, employees are associated with a specific configuration 
based on a ComponentName entry in the .cfg of an application. For example, in 
the Siebel Sales application the ComponentName in the default .cfg (siebel.cfg) 
would be Siebel Sales Client by default. This means that everyone using the Siebel 
Sales application is automatically associated with the Siebel Sales configuration.

Assigning employees to a configuration in the Upgrade Employee Configuration 
applet in the Employee view can be used in place of the entry in the .cfg, or as a 
method for overriding the entry in the .cfg. Again, the purpose of assigning 
employees to configurations is to handle uncommon situations.

NOTE: Do not assign System Administrator to any configuration. If, for some reason, 
you assign System Administrator to a configuration, then create a kit and distribute 
it to that configuration, System Administrator may not be able to login. 

To remedy this error, set the ComponentName entry in the CFG file to None. 

Caution: Exceeding the 91-character limit in the Name field 
causes the synchronization process to fail.
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To assign an employee to a configuration

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Employees.

3 From the Upgrade Configurations list, select the configuration to which you 
want to add an employee.

4 In the Upgrade Employee Configuration list, click New. 

5 In the Login field, click the select button. 

From the Pick Employee dialog box, select the employee you want to add, and 
click OK.

Repeat Step 3 through Step 5 to assign additional employees to this 
configuration.

NOTE: When it initializes the local database for the first time, Siebel Anywhere uses 
the configuration in the .cfg. It does not use the configuration defined in the 
Employees view under the Siebel Anywhere Administration Screen.
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Preparation of Upgrade Kit Contents 3

Preparing to create an upgrade kit involves gathering the software, files, or database 
schema updates required for the kit. The specific process to follow depends on the 
type of components you are planning to upgrade. Component types include:

■ Customer Revisions

■ Siebel Upgrade Wizard

■ Siebel Configuration File

■ Siebel Database Extensions 

■ Siebel Executables

■ Siebel Repository File

■ Third-Party Software

NOTE: Do not use the upgrade kit type Customer Revisions for upgrade kits 
containing a Siebel SRF or CFG file. Instead, use the Siebel Client Repository File 
and Siebel Client CFG kit types, respectively, for these upgrades. This will allow 
proper version checking.

Preparing for an upgrade kit could be as simple as gathering a new CFG file or a 
simple batch script. Preparation for other kits can be complex. The following 
section discusses several of the component types that entail some complexity. 
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Siebel Executables 3

You can use this component type for either new versions of Siebel eBusiness 
Applications or for Siebel patches.

New Versions of Siebel eBusiness Applications
If your upgrade includes a new version of a Siebel client installation, use the Siebel 
Packager utility. Use this utility to gather the files and information needed for a 
custom installation package for each subscriber configuration. See Siebel Web Client 
Administration Guide, MidMarket Edition for further details. 

NOTE: When creating upgrade kits to deliver a full Siebel client installation, there 
will be a separate kit for each language component plus the base. For example, 
delivery of a full upgrade with ENU and DEU components will include three 
separate Siebel Anywhere upgrade kits—one each for BASE, ENU, and DEU. 

After the package has been tested and is available for distribution to clients, you can 
create the Siebel Executables kit using that package. The following procedure 
describes how to do this.

To create a Siebel Executables kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits. 

3 From the Upgrade Kits list, click Auto Create. 

4 From the Upgrade Kit Wizard, select the appropriate upgrade component.

For example, use Siebel Client Executables for base or Siebel Client 
Executables__ENU for English language pack.

5 Click next and input the UNC path to the package just created. 

NOTE: Note that the UNC path needs to be accessible by the server. 
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6 Click next. 

Input command line arguments for install.exe. In most cases the default 
argument will be enough. 

7 Click next, and input correct version numbers. 

8 Click next, and input a title for the kit and then click finish. 

Repeat this procedure for each language pack.

Distributing a Siebel Patch
Do not use Packager for Siebel Patches. To distribute a Siebel patch, the System 
Administrator needs to first apply the patch to the master installation and test it 
before distributing it to end users. After successful testing, distribute the Siebel 
Patch using the Client Executables Kit. You must create as separate base kit and 
language package kit from respective directories—depending on the environment.

To distribute a Siebel patch

1 Copy the Siebel Client Patch to a local directory (client patches typically reside 
in a subdirectory of the patch directory). 

■ Dedicated and Mobile Web Clients — \sea

■ HTML Thin Client 

NOTE: Only mobile and dedicated Web clients can use Siebel Anywhere to 
download the kit. For other types of clients, such as Siebel Tools clients, users 
can only receive notification and then manually apply the patch. 

2 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

3 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.
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4 Click Auto Create to start the Upgrade Kit Wizard and follow the prompts to set 
these options:

a Choose Siebel Client Executables as the upgrade kit component in the Select 
Component page.

b Enter the directory where you have copied the patch on the local machine 
(from Step 1) in the UNC Path for Master Installations.

Do not check Uninstall Previous Siebel Version as this would cause a failure.

c On the File to Execute page, input command line arguments for 
install.exe. In most cases the default argument will be sufficient.

Do not change the predefined parameter.

d Enter the correct new version string of the new patch in the New Version 
entry.

You must enter the version number of the patch—including the build number 
in the bracket—and the language code—exactly.

For example, the first Siebel 7 patch New Version should be set to 7.0.x.x 
[10xxx] ENU.

e Change the title of the kit.

f Click Finish.

g Click Alt-Enter to refresh the view.

When Status of the newly created kit shows as Pending in the Upgrade Kits 
list, proceed to the next step. You may need to refresh the view several times 
for the Status to change.

Repeat the above steps for each language pack.

5 In the Upgrade Kits list, select the upgrade kit that you just created.

a Click Activate.

b Click Apply Versions.

From the Apply dialog box follow the instructions to make this a required or 
optional upgrade kit.
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6 From the Show drop-down list, select Configurations.

7 From the Upgrade Configurations list, select the configuration to which you 
want to distribute the patch.

8 For the configuration you selected, verify the following are listed in the Related 
Components list:

■ The Siebel Client Executables. 

■ Each of the relevant language packs (Siebel Client Executables__{language 
code}. 

■ Click Distribute.

After the Upgrade Wizard has successfully detected and downloaded the Upgrade 
Kit, it will proceed to install the patch on the clients. InstallShield will default the 
client installation path to c:\sea\client, which the end user should set to the 
current Siebel client installation. This installation path can be defaulted to the 
correct path by customizing the siebel.ini file for the patch and then disabling the 
dialog box for the path. For siebel.ini syntax, refer to Packager information in 
Siebel Web Client Administration Guide, MidMarket Edition.

Database Schema Extensions 3

Siebel Anywhere upgrade kits can include changes to the Siebel base tables. The 
following sequence of tasks provides the administrator an overview of how to 
implement database schema extensions:

Define custom extensions. You must define your extensions in the logical database 
schema in the Siebel Repository before creating the upgrade kit. This includes 
migrating the repository from development to production. 

Create a database schema upgrade kit. This will increment the custom schema 
version by 1 in the HQ database and apply the changes from the logical schema to 
the physical schema on the HQ database. Then, the entire schema definition is 
distributed to mobile Web clients. 

Install the upgrade kit. The Upgrade Wizard synchronizes the logical and physical 
schemas on the local databases of mobile Web clients.

For more information regarding the tasks above, see Siebel Tools Reference, 
MidMarket Edition.
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The process for defining database schema extensions differs between the 
development and production environments. You must first create schema 
extensions in the development environment before proceeding with either the test 
or production environment upgrades. See Siebel Tools Reference, MidMarket Edition 
for details.

For Siebel client configurations schema upgrade kits and the related Siebel 
Repository File kits should always be distributed at the same time to avoid upgrade 
errors that result when the SRF upgrade kit arrives on the client system before the 
Schema upgrade kit. Be sure that both kits are activated and applied before you 
click Distribute on the Components view. You should set the SRF kit to be 
dependent on the Schema kit for best results. See “Controlling the Order of Kit 
Installation” on page 7-6 for more details.

During database schema upgrades, new and changed objects are identified by 
comparing the current physical schema with the new virtual schema. Based on this 
comparison, Upgrade Wizard adds new objects and alters existing objects by using 
the following:

■ To create  the new objects: create table, create index, and so forth. 

■ To alter the existing objects: alter  table, alter index, and so forth.

Normally, the database does not allow downsizing a column that already contains 
data that could not fit into a new smaller column. If you downsize a column, the 
column representation in the repository would be different from the physical 
schema. This may cause an error. In addition, Siebel Remote would fail under these 
conditions. 

For example, after downsizing existing columns, one of the columns in the new 
database is shorter (it is created from the representation in the repository). Then a 
local database is re-extracted (this includes a new schema). After the Remote user 
synchronizes, initialization occurs. Upgrade Wizard first applies the new local 
database (including a new schema) to a Remote user’s machine. Next, Upgrade 
Wizard applies any server transactions downloaded during synchronization. If 
these transactions were generated before the schema changed, Upgrade Wizard 
tries to insert data that does not fit into the new column. This will cause an error. 

Caution: Downsizing existing columns is not recommended as it 
may cause an error.
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Development Environment
In the development environment, you make changes directly to the logical database 
schema in the Siebel Repository using Siebel Tools. Refer to Siebel Tools Reference, 
MidMarket Edition for instructions regarding database extension implementation.

You do not need to apply the logical schema changes to the physical schema on the 
server database. They are applied automatically when you create the upgrade kit. 

Test or Production Environment
To extend the database schema in your test or production environment, you migrate 
the entire Siebel Repository containing the desired database extensions from the 
development environment, rather than making changes directly to the repository in 
the test or production environment. Use the Configuration Utility to do this. See 
Siebel Tools Reference, MidMarket Edition for more information about this utility.

Siebel Tools Reference, MidMarket Edition details the procedure for moving 
repositories between your development and test or production environments. As in 
the development environment, you do not need to use Siebel Tools to apply the 
logical schema changes in the repository to the physical database. These changes 
are automatically applied when you create the upgrade kit.

Siebel Repository Files, Third-Party Applications, and Other Files 3

In order to prepare for creating an upgrade kit for a Siebel repository file, third-party 
application, or other non-Siebel file, copy the files to a directory accessible from the 
Siebel Server from which you will run the Upgrade Kit Builder server component.

NOTE: The SRF upgrade kit must contain the entire SRF file. SRF upgrade kits for 
servers are not supported in Siebel Anywhere.

Siebel Anywhere can install third-party applications or other files using one of the 
following methods:

■ Executing a batch script or installation program.

■ Copying files to a specified location.

Before deploying a kit through Siebel Anywhere, make sure that any files, scripts, 
or other programs required to install third-party applications contain the necessary 
data and are fully tested.
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Creating a Custom Component 3

Siebel Anywhere functionality allows you to define your own custom components, 
if necessary. 

To define a custom component

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Components.

3 In the Upgrade Component list, click New.

A blank record appears. 

4 Complete the necessary fields.

Use a meaningful name to describe the function of the component. Limit the 
Name field to 91 characters or less. 

Make sure the Minimum and Maximum version fields are blank. This 
information is filled in when the kits are applied. 

5 Click New on the Related Components list, and select a related component for 
the new custom component you just created.

6 Click the pick button.

Repeat steps Step 5 and Step 6 for as many related components you want to 
relate to the new custom component.

7 Add the new custom component to a configuration, by following the procedure, 
“To add a component to a configuration” on page 3-5.

Caution: Exceeding the 91-character limit in the Name field 
causes the synchronization process to fail.
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For More Information 3

For more information about topics and related information in this chapter, see Siebel 
Web Client Administration Guide, MidMarket Edition and Siebel Tools Reference, 
MidMarket Edition.

This chapter discussed the planning and preliminary tasks for an upgrade kit. The 
next chapter discusses how to use the results of these tasks to define the upgrade 
kit. 
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About This Chapter 4

This chapter outlines the four-step process for creating an upgrade kit. This process 
includes defining, activating, applying and distributing an upgrade kit. The chapter 
then describes the first step, defining the upgrade kit, in detail. The remaining three 
steps in the kit creation process are discussed in the next chapter.

Creation of the Upgrade Kit 4

After you prepare the contents for an upgrade kit, you are ready to create the kit. 
Upgrade kits are defined and maintained in the Siebel Anywhere Upgrade Kits view. 
For a description of this view, see “Upgrade Kits View” on page 2-20.

Creation of an upgrade kit is a four-step process to take the component, prepared 
earlier, and make it available to subscribers in the form of a kit. The remainder of 
this chapter describes the first step in the process, defining the upgrade kit. Then 
the following chapter discusses the other three steps in the process: activating, 
applying and distributing the upgrade kit.

Before defining an upgrade kit, it is essential to understand the difference between 
the Upgrade Kit Wizard and the Upgrade Kit Builder server component. 

■ The Upgrade Kit Wizard provides a means to identify the component type and 
required parameters for building a new kit on the Siebel Server. The status of 
this component group must be Online for the Siebel Administrator to be able to 
create upgrade kits. 

■ The Upgrade Kit Builder component on the Siebel Server receives the 
information from Upgrade Kit Wizard to build the kit and place it on the server 
file system.
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Defining the upgrade kit is the first of four steps required to create a kit. In this step, 
you identify the components of the kit and enter version information—through a 
series of seven tasks shown in Figure 4-1. After completion of these tasks, an 
upgrade kit record is added to the database.

The process of defining an upgrade kit begins with the Upgrade Kit view that allows 
you to invoke the Upgrade Kit Wizard. Always Click Auto Create in this view to 
invoke the Upgrade Kit Wizard to define your upgrade kit. This wizard helps you 
correctly define the necessary information and components for your kits.

NOTE: It is recommended that you do not add, update, or delete any records in the 
following lists on the Upgrade Kit Items view: Upgrade Kit Items list and Upgrade 
Kit Item Parameters list.

Figure 4-1. Defining the Upgrade Kit

Task 1:
Choose the

Upgrade Kit View.

Task 2:
Invoke the

Upgrade Kit
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Task 3:
Select a

Component to
create a kit.

Task 4:
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Task 6:
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Task 7:
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The Upgrade Kit Wizard leads you through a series of pages to gather the 
information. 

■ Click Next when you have specified the necessary options for a page. 

■ If you need to change any selections, click Previous to return to the appropriate 
page. 

■ Click Cancel to cancel the upgrade kit creation.

NOTE: There are two Database schema kits available—Siebel Database Schema and 
Siebel Database Schema (Version Check). Choose Siebel Database Schema, not the 
other one that contains (Version Check). 

To invoke the Upgrade Kit Wizard

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.

3 Click Auto Create to invoke the Upgrade Kit Wizard.

The Upgrade Kit Wizard - Upgrade Component page appears.

4 Follow the prompts to specify all parameters necessary to define your upgrade 
kit.

See “Upgrade Kit Wizard Tips” on page 4-11 for assistance while using the 
Upgrade Kit Wizard.
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Predefined Siebel Anywhere Components 4

You can choose one of the predefined Siebel Anywhere upgrade components or any 
additional custom components. See “Creating a Custom Component” on page 3-16 
for more information about components you may have added to the Upgrade 
Components view. 

For examples of predefined components, see Table 4-1.

NOTE: An upgrade kit is retrieved and applied only by Siebel Anywhere subscribers 
that use the specified component. 

Table 4-1. Predefined Examples of Siebel Anywhere Components (1 of 2)

Siebel Component Type Siebel Anywhere Component Comment

Customer Revisions ■ Siebel Client Customer Revision

■ Siebel Client Customer 
Revisions__{language}

A nonspecific component for 
distributing any customer-revised 
files, such as Online Help files, Siebel 
Report files, Siebel Help Files, Siebel 
Sample Database Files, third-party 
files or applications on the Siebel 
client.

■ Siebel Server Customer Revisions

■ Siebel Server Customer 
Revision__{language}

A nonspecific component for 
distributing any customer-revised 
files on the Siebel server.

Siebel Upgrade Wizard ■ Siebel Upgrade Wizard The Siebel Upgrade Wizard. It is 
automatically associated with every 
upgrade kit to make sure the client 
uses the current version of the 
wizard.

Siebel Configuration 
File

■ Siebel Sales CFG__{language} A component for distributing a 
customized .cfg for client systems.

Siebel Database 
Extensions

■ Siebel Database Schema The database schema used by the 
Siebel server and Siebel Remote user 
databases.

Siebel Executables ■ Siebel Client Executables

■ Siebel Client Executables__{language}

The Siebel eBusiness Applications 
client executables.
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If you select a new customized component, you must add the component as a 
related component on any Siebel Anywhere configuration that you want to upgrade 
with the component. To relate components, see “Adding Components to a 
Configuration” on page 3-5.

Siebel Repository File ■ Siebel Client Repository 
File__{language}

The file used by Siebel eBusiness 
Applications (.srf).

Third-Party Software ■ Third Party - Microsoft Word

■ Third Party - Microsoft SQL Server 
Driver

■ Third Party - Microsoft Internet 
Explorer

■ Third Party - Adobe Acrobat Reader

■ Third Party - Adobe Acrobat

Third-Party Software, as used on the 
Siebel client. 

These Upgrade Components are for 
version checking only. Siebel 
Anywhere is not intended to deliver 
entire Third Party software as an 
upgrade kit. 

For smaller and simpler software 
such as Adobe Acrobat and Winzip, 
you can use Siebel Anywhere to 
deliver them as a Third-Party 
upgrade kit.

Table 4-1. Predefined Examples of Siebel Anywhere Components (2 of 2)

Siebel Component Type Siebel Anywhere Component Comment
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Siebel Database Extension Component 4

The Siebel Database Extensions component identifies the database schema used by 
the Siebel server and Siebel remote databases.

Make sure the ODBC data source correctly points to the server database that has the 
extended database definition.

Table 4-2 includes the parameters to create a database schema kit, both required 
and optional. The parameters are specific to your database platform. They can be 
obtained by running some SQL queries on the server database. 

Table 4-2. Database Schema Kit Parameters

Parameter Comment

ODBC Data Source 
(required)

Points to the server database.

User Name (required) Siebel Administrator’s login.

User Password (required) Siebel Administrator’s password.

Table Owner (required) Database platform dependent: dbo user login for MS SQL.

Table Owner Password 
(required)

Database dependent.

Table Space (required) Database table space or segment for new tables.

Index Space (optional) Database table space or segment for new indexes.

16K Table Space (optional) Obtain the optional parameter through a SQL query on the 
server database. This is specific to the database platform.

32K Table Space (optional) Obtain the optional parameter through a SQL query on the 
server database. This is specific to the database platform.

Table Group File (optional) Obtain the optional parameter through a SQL query on the 
server database.
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Siebel Client Repository File 4

Make sure the file is accessible from the Siebel server where Upgrade Kit Builder 
will be running.

File Attachments 4

To understand how Siebel Anywhere handles file attachments to upgrade kits 
requires a short description of the overall process. 

Basically, you identify the file attachments you want associated with a kit. When 
you finish the Upgrade Kit Wizard, the Upgrade Kit Builder goes to work and creates 
the upgrade kit. When the server component is done, the newly created record in 
Upgrade Kits view will show the status Pending. At this point, you should have 
S_UPG_KIT_IARG_*.SAF files created in your file system for each of your 
attachments, plus the associated Siebel Anywhere Component, which is specific to 
the type of Siebel Component type.

Click Activate to collect every file attachment and the associated Siebel Anywhere 
Component to form one single file attachment, 
S_UPG_KIT_<ROW_ID>_<VER_NO>.SAF, again in your file system. This is the 
file that end users will download. If you deactivate and reactivate the kit, a new 
S_UPG_KIT_<ROW_ID>_<VER_NO>.SAF will result with the same ROW_ID but 
different VER_NO.

Select File to Execute 4

The Upgrade Wizard Kit’s Select Execute File page is an extra action required only 
for the following components:

■ Customer Revisions

■ Third-Party Software

For the Customer Revisions kits, select any single file depending on the kit’s 
contents—it can be a custom batch script or executable. For Third Party software 
kits, select the file that runs the software installer on the subscriber (for Siebel 
Packager custom installations and patch upgrade kits, this is INSTALL.exe). For this 
kit (and other types of kits for which this is applicable) only one file can be selected 
for execution.
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NOTE: Do not select a file that cannot be executed. For example, if a .txt or .cfg is 
selected (highlighted), then the kit will not be successfully applied, because Siebel 
eBusiness Applications will try to run a file that is not an executable.

Add any required command-line arguments. For example, if you need to pass the 
Siebel root directory to the application being invoked, in the command line field 
enter: $SiebelRoot. 

Minimum and Maximum Version Fields 4

When you define a Siebel Client Executables Kit with a full install package produced 
by Packager, the Minimum and Maximum version fields must be blank. Copy the 
new version information in the exact format as seen in the base file included with 
the path. For example, for 7.0 [107xx-1] full release, remove the full release part and 
copy only the version string.

Generally, you should keep the version numbers (Min and Max version) for Siebel 
Client Customer Revision kits as defaults when creating the kit. Your users will 
download every kit of this type without skipping any of them. When you know a 
kit that you distributed is invalid, then you can deactivate the kit and create another 
one with the exact same version numbers (that is, Min, Max, and New). In this case 
you need only to activate the kit; you do not need to apply or distribute.

If you want to allow clients, regardless of what version of the component they 
currently have, to be able to use the upgrade kit to upgrade to the new version, leave 
the Minimum and Maximum field values blank. This blank field indicates to Siebel 
Anywhere that the client does not need any specific version of the component in 
order to install this kit. (In the case of mobile Web clients, if you create a new kit 
after distributing and deactivating a prior kit, make sure the new version number is 
the same as the one used before.)

Caution: When implementing major upgrades, preserve the version 
numbers for every component. Siebel Anywhere assigns increasing 
version numbers. Never reset any of these version numbers to zero.
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Be careful when using this feature. For example, if you create a kit for a customer 
revision, the only time you can leave the Minimum and Maximum fields blank is 
when you either do not care if your clients have received the previous kits of the 
same type, or you are able to include every file required by the component in this 
kit or kits you are going to create after this one. 

For example, there are two reports with the following:

■ report1 min null, max null new 1

■ report2 min null, max null new 2

If the user logs in after Kit 2 has been distributed, only report 2 will be retrieved. 
Therefore, in this model, make sure that client customer revision kits are cumulative 
rather than collective. Otherwise, users can use the following version mechanism:

■ report1 null null 1

■ report2 1 1 2

You should always leave the Minimum and Maximum version fields blank when 
you are creating a Siebel Repository File component upgrade kit.

Caution: Make certain that minimum, maximum, and new versions 
are correctly set before finishing your upgrade kit, using the default 
numbering system, if possible. Incorrectly specifying the version 
information can prevent subscribers from upgrading successfully.
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Upgrade Kit Wizard Tips 4

Some features of the Upgrade Kit Wizard require additional explanation. Table 4-3 
provides tips on using these features successfully.

Table 4-3. Upgrade Kit Wizard Tips (1 of 2)

Siebel Component Type or Topic Comment

Siebel Client Customer 
Revisions

■ Choose Siebel Client Customer Revisions to 
distribute generic files.

■ Choose Siebel Client Customer Revisions__{language 
code} to distribute language specific files. 

Siebel Configuration File ■ If you are not sure you selected the right file to create 
the CFG kit, click Cancel and restart by clicking Auto 
Create.

SRF ■ To specify files for these components, enter the 
Universal Naming Convention (UNC) path—
browsing is not available.

■ The upgrade kit also sets the version of the .srf in 
the file itself. When creating SRF kit, the new version 
MUST be an integer. This type of kit must contain the 
entire SRF file. 

■ If you want to delete the upgrade kit files when the 
kit is applied, check the Delete destination file when 
done check box.
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Siebel Client Executables ■ When specifying the UNC path, you must choose the 
directory where the package was created:

■ \seaw folder on the Siebel CD

■ {ClientRootDir}\temp\{PackageName} (for 
Siebel Client Executables)

■ {ClientRootDir}\temp\{PackageName}\{Lan
guage Code} (for Siebel Client 
Executables__{Language Code}). 

■ Check Uninstall Previous Siebel Version check box 
only when you are performing a new installation of 
Siebel Executables.

■ If you are creating a kit for a Siebel client patch, do 
not select the Uninstall Previous Siebel Version check 
box. When selected, this check box determines 
whether the Upgrade Wizard automatically 
uninstalls the existing Siebel Executables before 
proceeding with installation of the upgrade.

■ If you want to delete the upgrade kit files when the 
kit is applied, check the Delete destination file when 
done check box.

Third-Party Software ■ The Client Destination Directory field specifies where 
the files of the upgrade kit are to be placed on the 
client machine. $SiebelRoot refers to the Siebel client 
root directory, and $KitName refers to a subdirectory 
with the name of the upgrade kit. Both of these 
variables are case-sensitive.

Min and Max Version Fields ■ The component and version information is read-only 
on this page; should you need to change either of 
these items, you must click Previous to return to the 
appropriate wizard page.

Table 4-3. Upgrade Kit Wizard Tips (2 of 2)

Siebel Component Type or Topic Comment
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Finish Defining the Upgrade Kit 4

When you click Finish, the Upgrade Kit Wizard exits. You remain in the Upgrade 
Kits View and it displays the new upgrade kit record added to the database. The 
Status is set to Request Submitted. 

NOTE: The status of this request can be monitored in My Component Request view 
in the Server Component Requests screen. The Systems Administrator should check 
the log file every time UpgKitBldr creates a database schema kit—make sure that 
error messages or warnings, if any, are nonfatal. 

If the upgrade kit includes database schema extensions, these extensions are 
applied to the server database at this point. 

After defining the upgrade kit, the status should be Request Submitted. When the 
server component picks up the request, the status will be In Progress. After the 
server component successfully registers the request, the status becomes Pending. 
This status indicates the kit has been defined but has not been physically created. 
It is not available to subscribers. 

If you select the new upgrade kit in the Upgrade Kit applet, you will notice that two 
records appear in the Upgrade Kit Components applet. The first record is the 
component to be upgraded. The second is the Siebel Upgrade Wizard. Including the 
Upgrade Wizard as a component reinforces using the correct version of the Upgrade 
Wizard for the upgrade.

See “Controlling the Order of Kit Installation” on page 7-6 for details on making one 
kit dependent on another.

If your complete upgrade includes other components, repeat the process of using 
the Upgrade Kit Wizard described in this section to define an upgrade kit for each 
additional component. If this is the last component, continue to the procedures in 
Chapter 5, “Activating, Applying, and Distributing the Upgrade Kit.” 
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For more information about topics and related information in this chapter, see 
Chapter 2, “Screens and Views in Siebel Anywhere,” and Chapter 3, “Upgrade 
Planning and Preliminary Tasks.”

This chapter discussed creating and defining an upgrade kit. Defining an upgrade 
kit is the first of four steps in the kit creation process. Before you can distribute it, 
you must activate and apply it. The next chapter discusses activating, applying, and 
distributing the kit—the remaining steps to create a kit. 
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About This Chapter 5

This chapter discusses the remaining three steps in the process of creating an 
upgrade kit—activating, applying and distributing the kit. These steps involve the 
following tasks:

1 Activating the upgrade kit. This step gathers all the files for the upgrade and 
creates a single archive file. This step also addresses deactivating an upgrade kit. 
See “Activating the Upgrade Kit” on page 5-3.

2 Applying the upgrade kit. This step updates the upgrade component registry with 
the new version information. During this step, you indicate whether or not a kit 
will be required. See “Applying Versions of an Upgrade Kit” on page 5-5.

3 Distributing the upgrade kit. This step makes the upgrade kit available to 
subscribers as either a required kit or an optional kit, depending on your 
selection in Step 2 above. See “Distributing Upgrade Component Version 
Information” on page 5-7.

This chapter explains each of these tasks in detail.
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Activating the Upgrade Kit 5

After you define the upgrade kits for an upgrade, you need to activate each kit. The 
status of a kit must be Pending before activating it. Activating a kit gathers the files 
to be included in the upgrade kit and compresses them into a single archive on the 
Siebel File System. It also sets the status of the upgrade kit to Active.

To activate an upgrade kit 

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.

3 Select the kit you want to activate. 

The Status field must show that it is Pending. 

4 Click Activate. 

A dialog box appears indicating activation is in progress. 

The Status field should change to Active. 

Repeat Step 3 and Step 4 to activate each kit required for your upgrade.

NOTE: Activating the upgrade kit does not affect the version information stored in 
the component registry. Activating a kit populates the File Size field for that kit. The 
kit is not available to subscribers until it has been applied and distributed.

After a kit is activated, use the Upgrade Kits view to test the kit on the local system. 
See “Distributing Upgrade Component Version Information” on page 5-7 for more 
information.
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Deactivating the Upgrade Kit 5

There are times when you may need to deactivate an active kit—perhaps there was 
a last minute decision to delete a kit. Basically, this is the reverse of the procedure 
“To activate an upgrade kit” on page 5-3.

Keep in mind, you must first deactivate a kit before deleting it.

You need to understand the implications of deactivating upgrade kits. You should 
only deactivate kits:

■ If you are sure that every user who needs this upgrade kit has already applied it. 

■ If there was a problem with this kit, then the kit can be deactivated and a 
replacement kit should be created to upgrade the users who had problems with 
the kit.

To deactivate an upgrade kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.

3 Select the kit you want to deactivate. 

The Status field should show that it is Active.

4 Click the menu button and select Deactivate.  

A warning message will ask you to confirm. If appropriate, click OK.

The Status field should change to Inactive. 

Repeat Step 3 and Step 4 for each kit that you want to deactivate.

Caution: If you have new users to the system and their installation 
does not include deactivated kits, this situation can cause a 
problem. Therefore, new client installations should be cloned from 
existing up-to-date clients to prevent problems when prompting for 
kits that have been deactivated.
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Applying Versions of an Upgrade Kit 5

After you activate the upgrade kits for an upgrade, you need to apply each kit. 
Applying a kit updates the component registry with the component version 
information. This is an essential step in creating an upgrade kit. This is also the step 
where you indicate whether a kit is a required upgrade kit.

NOTE: When applying a full product upgrade kit, the user needs Windows NT 
Administrator privileges because the upgrade will uninstall the old client and install 
the new client. For other types of kits, the user does not need to have Windows NT 
Administrator privileges.

To apply an upgrade kit

1 Navigate to the Anywhere Administration screen, and from the Show drop-down 
list, click Upgrade Kits.

The Upgrade Kits view appears.

2 Select the kit you want to apply. 

The Status field must show that it is Active.

3 Click Apply Versions. 

The Apply Upgrade Kit Version Information dialog box appears. Review the 
information in this dialog box.
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■ The Minimum and Maximum version numbers in this dialog box apply to the 
version of the component that can be used to bring up the application. If 
users have a version below the minimum and choose not to install the 
upgrade, they can only access the application in a read-only mode.

■ If you click OK without clicking Require Upgrade Kit, you are making it an 
optional kit (that is, after the kit is distributed, your subscribers can use 
Siebel eBusiness Applications without upgrading—provided their version is 
between the minimum and maximum). 

NOTE: Server upgrade kits should always be required.

■ If you click Require Upgrade Kit, the minimum version changes to match the 
maximum version, which is the new version. In this case, the subscribers will 
have to upgrade after the configuration is distributed; otherwise, they can 
only bring up the application in a read-only mode.

NOTE: You are strongly advised to create upgrade kits as optional and then 
test to make sure the kit is functioning properly. After you thoroughly test a 
kit using retrieval and installation, you can return to the Upgrade Kits view 
and reapply and distribute the kit as a required kit. See “Distributing Upgrade 
Component Version Information” on page 5-7 for more information.

4 Click OK if the version information is correct or click Cancel to exit the dialog 
box without applying the upgrade kit.

If you click OK, a prompt reminds you that you need to distribute the kit in order 
to make it available to subscribers. For information on distributing kits, see “To 
distribute upgrade component version information” on page 5-7.

Repeat Step 2 on page 5-5 through Step 4 on page 5-6 for each kit in this upgrade. 

If you want to relate one component to another so that they are distributed together, 
see “Relating One Component to Another” on page 7-7. Otherwise, continue to 
“Distributing Upgrade Component Version Information” on page 5-7 for distributing 
updated registry information for upgrade kits.
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After applying the upgrade kit, you need to distribute it. Distributing the upgrade 
kit makes the version information in the component registry available to Siebel 
Anywhere subscribers.

If the kit is required, subscribers that use any of the components are automatically 
prompted to retrieve and apply it. 

If the kit is optional, subscribers use the Product Updates view and Upgrade Wizard 
to locate and install the kit.

The following procedure provides the steps to distribute a kit from the 
Configurations view. The same procedure can also be accomplished from the 
Employees view.

To distribute upgrade component version information

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Configurations.

The Configurations view appears. For more information, see “Configurations 
View” on page 2-3 or “Employees View” on page 2-7.

3 In the Configurations view, select the appropriate Anywhere subscriber 
configuration. 

Verify that the components in the upgrade kit are included in the configuration 
as related components.

The related components for the configuration are listed in the Related 
Components list.

Caution: Before you distribute a kit, you must define, activate, and 
apply it.
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4 Click Distribute.

This action makes the registry version information available to subscribers with 
that particular configuration. 

A dialog box appears to confirm the intent to distribute the related components 
to the configuration.

Repeat Step 3 and Step 4 for other configurations, as applicable.

For More Information 5

For more information about topics and related information in this chapter, see 
“Configurations View” on page 2-3, “Employees View” on page 2-7, and “Relating 
One Component to Another” on page 7-7.

The chapter discussed the last three steps in the creation process for an upgrade kit. 
The next chapter discusses the retrieving, installing, and testing of upgrade kits.
5-8 Siebel Anywhere Administration Guide MidMarket Edition Version 7.0, Rev. A



Retrieving, Installing, and Testing
Upgrade Kits 6
About This Chapter  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-2

Retrieval, Installation, and Testing Process Flow  . . . . . . . . . . . . . . . . . . 6-2

Retrieval and Installation of Upgrade Kits . . . . . . . . . . . . . . . . . . . . . . . 6-3

Retrieving Optional Upgrade Kits—Dedicated Web Client  . . . . . . . . . . . . . 6-4

Retrieving Optional Upgrade Kits—Mobile Web Client  . . . . . . . . . . . . . . . 6-5

Retrieving Required Upgrade Kits  . . . . . . . . . . . . . . . . . . . . . . . . . . 6-6

Upgrade Wizard Launch . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-8

Client Upgrade Error Recovery  . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-9

Retrieving Siebel Server Upgrade Kits . . . . . . . . . . . . . . . . . . . . . . . . . 6-10

Testing Upgrade Kits . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-11

Using the Siebel Test Client Configuration for Testing . . . . . . . . . . . . . . . .6-12

Converting an Optional Kit to a Required Kit  . . . . . . . . . . . . . . . . . 6-13

For More Inform;ation  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 6-14
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 6-1



Retrieving, Installing, and Testing Upgrade Kits

About This Chapter
About This Chapter 6

After you distribute upgrade kits, the users must retrieve and install them. This 
chapter discusses retrieval and installation of the kits. The chapter also discusses 
the testing of upgrade kits.

Retrieval, Installation, and Testing Process Flow 6

The following tasks occur in the retrieval, installation, and testing process flow.

1 Retrieve required and optional upgrade kits. The procedure for retrieving an 
upgrade kit depends on its type. See “Retrieval and Installation of Upgrade Kits” 
on page 6-3.

2 Install with the Upgrade Wizard. The process for invoking the Upgrade Wizard 
depends on the subscriber type. See “Upgrade Wizard Launch” on page 6-8.

3 Test the upgrade kit. Test the retrieval and installation of kits prior to release to 
users—this is critical. See “Testing Upgrade Kits” on page 6-11.

If you encounter errors in this process, you may also need to:

■ Recover from client upgrade errors. “Client Upgrade Error Recovery” on 
page 6-9.

■ Retrieve required Siebel server upgrade kits. “Retrieving Siebel Server Upgrade 
Kits” on page 6-10.
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Retrieval and Installation of Upgrade Kits 6

The procedure for retrieving an upgrade kit depends on its type:

■ Optional upgrade kits can be manually retrieved and applied by Siebel client 
subscribers through the Product Updates view. 

■ Required upgrade kits are automatically retrieved by Siebel Anywhere 
subscribers with configurations using the specific components in the kit.

It is a common misunderstanding that mobile Web clients retrieve kits directly from 
the file system. Instead:

■ Mobile Web clients request the files from the Siebel Remote Server. The Remote 
Server retrieves the files from the file system.

■ Dedicated Web clients retrieve kits (.saf files) directly from the file system or 
through the help of the File System Manager depending on the settings defined 
in the active CFG file.

Subscribers use the Siebel Anywhere Upgrade Wizard to install upgrade kits after 
they are retrieved. The process for invoking the Upgrade Wizard varies by 
subscriber type. For client subscribers, the Upgrade Wizard is invoked 
automatically after an upgrade is retrieved. For Siebel server subscribers, the 
Upgrade Wizard is invoked manually (see “Retrieving Siebel Server Upgrade Kits” 
on page 6-10).

The process for retrieving and installing upgrade kits by Siebel client and Siebel 
server subscribers is described in subsequent sections.

NOTE: Before installing a Siebel Anywhere schema upgrade, be sure to synchronize 
mobile Web clients. Synchronization will keep any changes to local databases since 
the last synchronization. These clients must not make any changes to their local 
databases until the upgrade is complete. 
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Optional upgrade kits are only for client subscribers. Upgrade kits for server 
subscribers should always be required by explicit action from the System 
Administrator. 

The retrieval and installation of an optional upgrade kit begins on the Product 
Updates view, which is part of the User Preferences screen. See “User Preferences 
Screen and View” on page 2-27 for an example of the Product Updates view. 

The Status field indicates the status of the upgrade kit. For a listing of values, see 
Table 2-11 on page 2-28.

As a Siebel Anywhere Administrator, you use the Product Updates view to test 
upgrade kits on individual client machines before making the kit required. See 
“Distributing Upgrade Component Version Information” on page 5-7 for more 
details.

NOTE: Web clients are not Siebel Anywhere subscribers even though the Product 
Updates view may be accessible to them.

Dedicated Web clients can retrieve optional upgrade kits as described in the 
procedure below. 

To retrieve an optional kit for a dedicated Web client 

1 Invoke the dedicated Web client.

2 From the application-level menu, select View > Site Map > User Preferences 
screen > Product Updates.

3 In the Product Updates list, select the desired upgrade component and check the 
checkbox under the Upgrade column of the desired upgrade component.

A check appears. The upgrade status should be Upgrade Available for those 
components where optional kits are available.

4 Click Upgrade Selected Components.

This will download the upgrade kit, shutdown the dedicated Web client, and 
launch the Upgrade Wizard. After the Upgrade Wizard completes, it will 
automatically restart the dedicated Web client.

5 Log in, and from the Product Updates list verify the Status is Version OK for the 
desired upgrade component.
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Retrieving Optional Upgrade Kits—Mobile Web Client 6

Mobile Web clients can retrieve optional upgrade kits as described in the procedure 
below. 

To retrieve an optional kit for a mobile Web client 

1 Invoke the mobile Web client.

NOTE: Make sure that Transaction Processor and Transaction Router are up and 
running. Verify the Status of the process. 

2 From the application-level menu, select File > Synchronize > Database.

3 In the Siebel Remote dialog box, click Synchronize.

Synchronization takes place and is complete when the opposing arrows (red and 
blue) in the lower right corner of the screen disappear.

4 From the application-level menu, select View > Site Map > User Preferences 
screen > Product Updates.

5 In the Product Updates list, select the desired upgrade component and check the 
checkbox under the Upgrade column. 

A check appears. The upgrade status should say Upgrade Available for those 
components where optional kits are available.

6 Click Upgrade Selected Components. 

a A dialog box appears. Follow the instructions in the dialog box to start a 
Siebel Remote session and retrieve the Upgrade Kit necessary to upgrade 
your system.

b Click OK, and the dialog box closes.

7 Synchronize again as in Step 2 and Step 3 to retrieve the corresponding upgrade 
kits.
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8 Click Upgrade Selected Components again to invoke the Upgrade Wizard for the 
desired upgrade component.

After the Upgrade Wizard completes, it will automatically restart the mobile Web 
client.

9 Log in, repeat Step 4, and from the Product Updates list verify the Status is 
Version OK for the desired upgrade component.

Retrieving Required Upgrade Kits 6

Both mobile and dedicated Web clients perform a version check during login. 
During version checks, required client upgrade kits are retrieved only if you click 
Yes to Download Kit. The following procedures for both the dedicated and mobile 
Web clients illustrate this point.

Upgrade kits are not automatically retrieved upon version check. They are 
downloaded only if you click yes to download kit.

To retrieve required upgrade kits for mobile Web clients

1 Invoke the mobile Web client.

NOTE: Make sure that Transaction Processor and Transaction Router are up and 
running. Verify the Status of the process. 

2 From the application-level menu, select File > Synchronize > Database.

A dialog box appears indicating there is a required upgrade available. 

3 In the dialog box, click OK.

4 From the application-level menu, select File > Synchronize > Database.

A dialog box appears providing the option to upgrade now or later. If you choose 
not to upgrade at this time, you can only operate in read-only mode.

5 From the dialog box, click Yes and follow the prompts to invoke the Upgrade 
Wizard.

The Upgrade Wizard will shut down the Siebel client, apply the upgrade kit, and 
automatically restart the client unless there is an error while applying the kit.
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6 Log in, and from the application-level menu, select View > Site Map > User 
Preferences > Product Updates.

7 Verify that the Status and Current Version columns contain the updated 
information.

The version check for mobile Web clients occurs during synchronization. If the 
version check detects the need for an upgrade, the user receives a prompt indicating 
a possible upgrade. The remote user logs in again to synchronize the server and 
local database. 

A prompt appears, asking if the user would like to retrieve the upgrade kit.

The version check verifies the components used by the client configuration; 
multiple required components can be displayed in the dialog box. Mobile Web 
clients will detect a new required upgrade when merging changes from the first 
synchronization session following distribution of the upgrade kit.

If the user answers Yes, every required upgrade kit for the components used by the 
client configuration is automatically retrieved and the Upgrade Wizard is launched.

If the user answers No, the user’s session continues in read-only mode against 
either the local or server database, until the upgrade has been completed. A prompt 
notifies the user of this status.

While operating in read-only mode, both dedicated and mobile users can view 
screens, views and data as usual, but they cannot make changes. Mobile users can 
synchronize, but can only download files; they cannot send, receive, or apply 
database changes. Read-only mode prevents users from corrupting data with an 
outdated or invalid Siebel configuration.

If the mobile user starts the Siebel client in read-only mode, the user is again 
prompted to upgrade at each synchronization session. Both dedicated and mobile 
users exit read-only mode when the Siebel eBusiness Application is restarted 
following a successful upgrade. At that point, a mobile user can perform a full 
synchronization, sending to the Siebel Server any local database changes that 
predate the upgrade.
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To retrieve required upgrade kits for dedicated Web clients

1 Invoke a dedicated Web client.

Login will trigger a version check and will prompt for retrieval of a required 
upgrade kit. If you choose not to upgrade at this time, you can only operate in 
read-only mode.

2 Click Yes.

The Siebel client will download the appropriate upgrade kits. 

After the retrieval is complete, it will invoke the Siebel Upgrade Wizard before 
exiting. 

After the client exits, the Siebel Upgrade Wizard takes over and applies the 
upgrade kits and automatically restarts the client when it is done.

3 Log in, and from the application-level menu, select View > Site Map > User 
Preferences > Product Updates.

4 In the Product Updates list, verify that Status is Version OK. 

Upgrade Wizard Launch 6

After an upgrade kit has been retrieved, the Upgrade Wizard is launched. It 
automatically shuts down the Siebel client. It then displays a progress page as it 
completes the upgrade kit items for the upgrade kits that were retrieved. 

NOTE: The items displayed on the Upgrade Wizard page vary, depending on the 
number and type of kits.

When the Upgrade Wizard has successfully installed the upgrade kit, the Siebel 
client is automatically restarted.
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Client Upgrade Error Recovery 6

Before beginning the upgrade process, the Upgrade Wizard makes a backup copy of 
every file affected by the upgrade. If errors are encountered in the upgrade process, 
the Upgrade Wizard stops processing, and Siebel Anywhere displays error 
information in the Error dialog box, as shown in Figure 6-1. 

 

Click OK to exit the Upgrade Wizard.

The next time the user restarts the Siebel client, a prompt appears that states there 
had been an upgrade in process.

After the user clicks OK, another prompt appears where the user can cancel the 
upgrade or restart the upgrade from the point of failure. Canceling the upgrade 
restores the client configuration to its status before the upgrade.

The Siebel Upgrade Wizard functionality includes error recovery for upgrades on 
individual files, such as database schema extensions, client configurations or SRFs. 
However, upgrades cannot easily be rolled back without manual intervention.

NOTE: If you plan to delete any old kits, make sure there is an installation where 
each new kit has been applied. Then, create a package based upon this installation 
for any new users so that new users have the kits that were already distributed. (See 
the last example in the FAQ, “Deleting Old Upgrade Kits” on page A-10.)

Figure 6-1. Error Dialog Box

Caution: For Siebel client executable upgrades, which first install the 
Siebel client version before installing the new version, recovery is 
much more difficult because a backup of the entire client 
configuration is not made. 
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For a Siebel client upgrade, you must have an existing Siebel client installation. 
Alternatively, you can install the new version of the Siebel client into a separate 
subdirectory and not specify that the Upgrade Wizard should uninstall the existing 
version when creating the upgrade kit. This allows the new client installation to be 
replaced by the previous version should it fail. 

You can distribute a second upgrade kit later that uninstalls the previous client 
version. If you do this, set the minimum version for applying this second kit to the 
version of the first kit so that only the users who successfully upgraded will 
uninstall the previous client version.

Retrieving Siebel Server Upgrade Kits 6

Upgrade kits for Siebel server configurations are retrieved automatically by the 
Siebel server. These upgrade kits may include a database schema or user-defined 
files to be installed with version tracking.

With the Siebel server and all tasks stopped, the Siebel Administrator must 
manually invoke the Upgrade Wizard.

To manually invoke the Upgrade Wizard on Windows

1 Open a command prompt window on the Windows server where the Siebel 
server is installed.

2 Navigate to the SIEBSRVR_ROOT\BIN directory, where SIEBSRVR_ROOT is the 
root directory of the Siebel server installation.

3 Copy the file siebupg.exe to siebupg1.exe.

4 Execute siebupg1.exe to launch the Upgrade Wizard.

Follow the prompts on the wizard pages.

Caution: There are other implementation and deployment issues that 
the Administrator must consider but are outside the scope of this 
guide. Consult the Upgrade Guide for Microsoft Windows, 
MidMarket Edition for further information.
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5 Restart Siebel server.

See Siebel Server Administration Guide, MidMarket Edition for details.

Repeat the process from Step 1 on any other Siebel server as appropriate.

Should the Upgrade Wizard fail, there will be an error message to that effect.

A common failure is not being able to retrieve a kit. You should exit the Upgrade 
Wizard, correct the condition that caused the error, and restart the Upgrade Wizard 
using the SIEBUPG1.exe file. Upon restarting, Upgrade Wizard prompts you either 
to cancel the upgrade, restoring the Siebel server to its preupgrade state (if 
possible), or to retry the upgrade from the point of failure. You will need to restart 
the Siebel server to initiate a version check to restart the upgrade process. If you 
want to restart, you should choose Retry.

After a successful installation of an upgrade, it will take manual intervention to roll 
it back.

Testing Upgrade Kits 6

There is one point at which an administrator can test a client upgrade kit—as a 
limited distribution kit. 

When testing new upgrade kits, it is highly recommended that you perform tests 
using both dedicated and mobile Web clients. If for any reason mobile Web clients 
experience problems applying or downloading the new kit, the problems will be 
significant.

The recommended method for testing kits is to create and distribute a kit to a 
limited and controlled number of users. In this method, you can assign specific 
testing accounts to the Test Client configuration so your regular subscribers will not 
be allowed to apply any kits in the testing phase. Distribute the kit only to the Siebel 
Test Client configuration. See “Using the Siebel Test Client Configuration for 
Testing” on page 6-12.

After a kit has been thoroughly tested under the Siebel Test Client configuration, 
you can then distribute it to the appropriate configurations.

NOTE: For dedicated users, there are no database schema upgrades. Database 
extensions should be tested in the development environment.
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Using the Siebel Test Client Configuration for Testing 6

Siebel Anywhere provides a special configuration called Siebel Test Client to serve 
as your test user. By default, the Siebel Test Client configuration is representative of 
the other out of the box subscriber configurations, but it can be modified to reflect 
your active configuration.

To test an upgrade kit

1 Create a user and assign this user with the Siebel Test Client configuration in 
either of the following ways:

■ Assign the user to the configuration. See “Assigning Employees to 
Configurations” on page 3-7 for information about assigning an employee 
with a configuration.

■ Install a client. Install a client and set ComponentName = Siebel Test Client 
in the active CFG file.

2 Define, activate and apply as an optional or required kit and distribute to the 
appropriate configuration—distribute the upgrade kit as an optional or required 
kit, as appropriate.

NOTE: Do not click Require Upgrade Kit in the Apply dialog box if you are dealing 
with an optional kit.

3 Verify that the Siebel Test Client configuration contains the components being 
upgraded with the kit.

Notify the selected users assigned to the Siebel Test Client configuration to log 
on. Instruct them to use the procedures described in “Retrieval and Installation 
of Upgrade Kits” on page 6-3 to retrieve and install the upgrade kit.

NOTE: If you want to change your optional kit to a required kit after testing, refer 
to the following section, “Converting an Optional Kit to a Required Kit” on 
page 6-13.

If the test is unsuccessful, refer to Chapter 7, “Advanced Usage and Problem 
Solving,” or Appendix A, “Frequently Asked Questions,” for possible solutions.
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Converting an Optional Kit to a Required Kit 6

After thoroughly testing an optional kit, you can reapply the kit to convert it to a 
required upgrade kit if you wish to.

To convert an optional kit to a required kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.

3 From the Upgrade Kits list, select the optional kit you want to convert.

The current status should be Active.

4 Click Apply Versions. 

The Apply Upgrade Kit dialog box appears. Review the information in this dialog 
box.

5 Click Require Upgrade Kit to make the upgrade kit required. 

The Minimum and Maximum Version numbers are now the same because it is 
a required kit.

6 Click OK if the version information is correct or click Cancel to exit the dialog 
box without applying the upgrade kit.

If you click OK, a prompt reminds you that you need to distribute the kit in order 
to make it available to subscribers. See “Distributing Upgrade Component 
Version Information” on page 5-7.
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For More Information 6

For more information about topics and related information in this chapter, see 
Chapter 7, “Advanced Usage and Problem Solving,” or Appendix A, “Frequently 
Asked Questions.”

The next chapter discusses Siebel Anywhere advanced usage and problem solving.
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About This Chapter 7

Siebel Anywhere offers advanced techniques that can help you solve problems that 
can arise after the upgrade kit is created and distributed.

This chapter discusses some of these techniques and the problems you can solve by 
using them.

Global Deployment with Siebel Anywhere 7

This section provides an example of a global deployment using Siebel Anywhere. 
The objective is to allow users to access and use the same application in different 
languages.

You have upgrade components for the languages you installed with your database 
server. You will map these to the applicable configurations. These configurations 
will be based upon the languages different set of users require to access the same 
application.

Assumptions 7

This example makes the following assumptions:

■ You have five sets of users for five different languages.

■ You will base your application on Siebel Call Center.

■ You will have five SRFs compiled, one for one each language.

■ You will have customer revisions (reports for example) depending on the 
language.

■ You will use the same database.

■ Each user only uses the application in one language.
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Requirements 7

You will need:

■ Five components for the Siebel Repository Files (SRF)

■ Five components for the CFG files

■ Five components for Client Customer Revisions

■ Five configurations to distribute the upgrade kits 

■ Six components for Client Executables: 1 for Client Executables (base), Five are 
Client Executables__$Language (language pack)

The language pack component has same locate method, locate information, and 
version method as the base Client Executables component, but with different 
Version Information: bin\sslcver.dll,VersionString,$Language

Records Available 7

For the records available, use the values in the following tables.

 

Table 7-1. Example CFG Records in the Upgrade Components View Files

Field Comment

Name CFG XXX

Component Type Siebel CFG File

Min Version 100

Max Version Should be blank

Locate Method CFG

Locate Information Siebel,ClientRootDir,bin\$Language\uagent.cfg

Version Method CFG

Version Information Siebel,Version
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Table 7-2. Example SRF Records in the Upgrade Components View

Field Comment

Name  Siebel Client SRF XXX

Component Type  Siebel Repository File

Min Version  Should be blank

Max Version  Should be blank

Locate Method  CFG

Locate Information  Siebel,ClientRootDir,objects\$Language

Version Method  SRF

Version Information  Siebel,RepositoryFile

Table 7-3. Example Client Customer Revision Records in the Upgrade Components 
View

Field Entry

Name  Customer Revision XXX

Component Type  Customer Revision

Min Version  Should be blank

Max Version  Should be blank

Locate Method  CFG

Locate Information  Siebel,ClientRootDir,bin\clntrev.cfg

Locate Information - language 
dependent component

 Siebel,ClientRootDir,bin\$Language\clntrev.cfg

Version Method  CFG

Version Information  Siebel,Version
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NOTE: You must create a configuration for each language combination. For example, 
if a user installed both ENU and FRA on a system, create a configuration with the 
components related to these two languages. For more information regarding multi-
lingual deployments, see Global Deployment Guide, MidMarket Edition.

Table 7-4. Example Client Configuration Records in the Siebel Anywhere 
Configurations View 

Field Comment

Name  Siebel Call Center XXX

Component Type  Siebel Client Configuration

In the related components applet, add the following records:

Siebel Call Center CFG__XXX  Required

Siebel Client Customer Revisions  Required

Siebel Client Customer Revisions__XXX  Required

Siebel Client Executables  Required

Siebel Client Executables__XXX  Required

Siebel Client Repository File__XXX  Required

Siebel Database Schema  Required

Siebel Upgrade Wizard  Required

Third Party - File Attachment  Not Required
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Controlling the Order of Kit Installation 7

Usually, when you distribute upgrades to a configuration requiring several related 
components, the order in which kits are installed is undefined. If you need to 
control the installation order of kits, you can do this by making one kit dependent 
upon another. An example of this type of situation would be when you have one 
Siebel Repository File kit (Kit 1) and another Siebel Client Customer Revision kit 
(Kit 2), and you need Kit 1 to be installed first. 

To set the order of kit installation

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits list appears.

3 In the Upgrade Kits list, select the kit you need installed second.

In the example above, this would be Kit 2, the Siebel Client Customer Revision 
kit.

4 If it is already activated, manually set the status to Pending or deactivate the kit 
and change the status to pending.

5 In the Upgrade Kit Component applet (lower applet in the same view), click 
New.

6 Select the component Kit 1 upgrades.

In the example above, this would be Siebel Client Repository__$Language.

7 In the new record, set the Min Old Version to the New Version of the kit (the 
Siebel Repository File).

8 Click to activate the Upgrade Kits applet.

9 Select the kit you need installed second again and click Activate.

This procedure forces first the installation of Kit 1 (Siebel Repository File), followed 
by Kit 2 (Siebel Client Customer Revision). This interlinked series can be extended 
to three or more kits.
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Relating One Component to Another 7

In some instances, you may want to relate one component to another in order to 
make sure that the components are distributed together. 

To relate one component to another

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration. 

2 From the Show drop-down list, click Upgrade Components.

The Upgrade Components view appears.

3 Select the first component.

4 Click the Related Components list to make it the active applet.

5 Click New.

6 Select the component that you want to relate to the first component and click 
the Pick icon.

7 Click to check the Required at Startup field for the related component.

Repeat Step 3 through Step 7 to add other related components.
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Using the Priority Configuration to Deliver an Upgrade 7

There are two situations in which the Priority Upgrade can be useful:

■ When you want to deliver a kit to your mobile users immediately. 

■ When your mobile Web clients are unable to synchronize due to an incorrectly 
defined upgrade kit. 

In both cases, you can use the Priority Configuration to deliver a new kit that would 
correct the situation.

Suppose you are the Siebel Administrator. It has come to your attention that many 
mobile users are taking an unusually long time to apply database changes during 
the synchronization process. After investigating the situation, you determine the 
correct solution is to increase the memory allocation for the local database engine. 
You can change this allocation by modifying the ConnectString parameter under the 
Local section in the appropriate CFG file. Therefore, you decide to send down a 
required CFG kit to your end users to correct the problem.

However, it would be beneficial for the mobile users to immediately retrieve and 
apply the CFG kit during the next synchronization. This approach would reduce the 
waiting time, especially for those users who do not synchronize very often. To allow 
immediate retrieval, you will distribute the CFG kit under the Priority configuration.

For example, create a priority configuration with the word Priority appended to it. 
Do this by copying the current configuration (that is, Siebel Sales Client) and 
append - Priority as such: Siebel Sales Client - Priority. Then, create the upgrade kit 
or kits and distribute these under the Priority configuration. Finally, test the 
upgrade thoroughly before making it available to your end users.
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Recovering from a Required Kit That Cannot Be Installed7

If you create and distribute a required upgrade kit that, for some reason, cannot be 
installed on the client or server, you need to create and distribute a new upgrade kit 
that functions properly.

A new upgrade kit alone will not work because the nonfunctioning kit prevents 
users from downloading the repair kit from the Siebel Server. To allow mobile users 
to download the new kit, you have the option of creating a priority configuration to 
distribute the new upgrade kit.

A priority configuration has the word Priority at the end of its name. For example, 
if the original configuration (under which the nonfunctioning kit was distributed) 
is called Client, then the priority kit must be called Client Priority (exactly).

Creating a Priority Kit 7

Distribution of the new kit under this priority configuration upgrades the user’s 
installation from the last known good version, skipping the nonfunctioning version 
number. The mobile Web client is thus able to bypass the nonfunctioning kit. 

NOTE: Dedicated users need exactly the same repair kit, but it can be distributed 
under the regular configuration; the priority configuration is necessary only for 
mobile users.

To create a priority configuration

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Configurations.

The Configurations view appears.

3 In the Upgrade Configurations list, select the configuration under which the 
nonfunctioning kit was distributed.

For example, if the original configuration is called Siebel Call Center Client, then 
find and select the configuration with that name.
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4 From the Upgrade Configurations list menu, choose Copy Record.

A duplicate configuration record appears.

5 Edit the name of the new record by adding Priority (one space, followed by the 
word Priority) to the end of its name.

For example, the correct name for the Siebel Call Center Client priority 
configuration is Siebel Call Center Client Priority (exactly).

Defining and Distributing a Repair Kit 7

This section begins by discussing the overall process of defining a repair kit. Then 
it includes a procedure describing how to distribute the kit. 

■ To define a repair kit, use the Upgrade Kit Wizard to create the new kit.

■ Make sure the version information in the repair kit differs from the version 
information in the nonfunctioning kit in the following ways:

■ If the minimum version is editable, make sure that its value is set to the last 
known good version for this upgrade component. 

For example, if the minimum version of the nonfunctioning kit was 5, the 
minimum version of the priority kit should be no higher than 5.

■ The new version is at least one version number higher than the new version 
of the nonfunctioning kit. 

For example, if the new version of the nonfunctioning kit was 6, make the 
new version of the priority kit 7. Then, Siebel Anywhere can upgrade the 
user’s setup from the last good version, skipping the nonfunctioning version.

■ After you’ve defined your priority kit, treat it as you would any required kit: 
activate it and test it. 

For additional information about defining, activating and testing upgrade kits, 
see Chapter 5, “Activating, Applying, and Distributing the Upgrade Kit.”

■ Distribute it as appropriate for dedicated or mobile users, as described in the 
following procedure.
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To distribute the repair kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration. 

2 From the Show drop-down list, click Configurations.

The Configurations list appears.

3 Prepare the kit for distribution. 

For dedicated users, perform the following tasks:

a In the Upgrade Configurations list, select the configuration under which you 
distributed the nonfunctioning kit. 

b Verify that the components in the repair kit are included in the configuration 
as related components.

c With this configuration selected, click Distribute.

For mobile users, perform the following tasks:

a In the Upgrade Configurations list, select the priority configuration you 
created earlier (the one ending in Priority). 

b Verify that the components in the repair kit are included in the configuration 
as related components.

c With this configuration selected, click Distribute.
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Creating Multiple Kits of the Same Type 7

If you need to distribute multiple files to different directories, you should create a 
kit of the appropriate type Client Customer Revision for each destination directory. 
You should use the Min and Max version of the upgrade kits so that they create an 
unbroken sequence.

This following example uses the Customer Revision kit type. Keep in mind that the 
same logic can be used for other types of kits when there is a need to distribute 
multiple kits of the same type.

Create the first kit as usual (for example, Min Old Version and Max Old Version 
should be set to blank, New Version = 1).

For the next kit set Min Old Version = 1, Max Version = 1, New Version = 2, and 
so forth.

If you have to skip a version number for some reasons, then set the Min and Max 
old versions appropriately. Always set the Min Old version so that it matches the 
New version of the previous active kit.

You need three Kits, but Kit 2 was skipped because it contained one wrong file.

The version information would be the following:

Kit 1: 

■ Min Old Version = Null, Max Old version = Null, New Version = 1

Kit 2: (This is the kit which was never activated and has to be skipped.)

■ Min Old Version = 1, Max Old version = 1, New Version = 2

Kit 3:

■ Min Old Version = 1, Max Old version = 2, New Version = 3

Kit 4:

■ Min Old Version = 3, Max Old version = 3, New Version = 4

For more information about the version numbers used by Siebel Anywhere, see 
“Upgrade Kit Wizard and Apply Upgrade Kit Version Numbers” on page A-12.
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Performing Database Schema Updates
Performing Database Schema Updates 7

Often upgrades are required to deploy database extensions. For example, Siebel 
developers may decide to add extension columns to existing Siebel tables. 
Sometimes it is also necessary to create or modify views and applets to display the 
extension data. See Siebel Tools Reference, MidMarket Edition for detailed 
information regarding database extensibility.

After thorough testing at the developer’s local database, the changes are then 
applied to the developmental database. At this point, you need to test the schema 
changes thoroughly in a test environment. When ready to move into a production 
environment, you should apply schema changes to the server database using the 
Siebel Configuration Utility—specifically option Migrate Repository which takes one 
repository definition from a source database and imports it into a target database. 
This synchronizes the logical and physical schemas.

At this point, you need to propagate these changes to any local databases on mobile 
Web clients. The remainder of this section explains how to propagate changes.

To propagate schema changes to mobile client databases, do one of the following:

■ Re-extract

■ Distribute Database Schema changes via Siebel Anywhere

The use of Siebel Tools to apply schema changes should only be done in a 
development environment. For more information see Siebel Tools Reference, 
MidMarket Edition.

If you are using Siebel Anywhere to distribute incremental schema changes, you do 
not need to re-extract mobile users. Generate New Database must be run to generate 
the new database template based upon the incremental schema changes. This will 
then only be used by future extracts, as needed.

NOTE: Do not use Siebel Tools to activate the new extensions if you plan to use 
Siebel Anywhere. 

Caution: Have all mobile users perform a synchronization session 
before propagating schema changes to promote proper operations. 
The new schema will ignore previous transactions against the old 
schema.
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To create a database schema upgrade kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits View.

The Upgrade Kits view appears.

3 Click the Auto Create.

The Upgrade Kit Wizard - Upgrade Component page appears.

4 Follow the prompts to specify all information necessary to define your upgrade 
kit. Use the following on the appropriate pages:

■ Choose Siebel Database Schema as the upgrade component.

■ In the ODBC Information form, complete the necessary fields.

For details about these fields, see Table 4-2 on page 4-7.

■ Verify that the New Version information is appropriate before clicking Finish.

■ Wait for the Status in the Upgrade Kits list to change to Pending. You may 
need to refresh the view several times to see Status change.

5 Activate the newly created Database Schema upgrade kit.

6 Apply the upgrade kit, as required, to the component registry.
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Performing Database Schema Updates
To distribute a kit for mobile Web clients

■ For mobile Web clients assigned to the HQ Server, distribute the kit under the 
appropriate configurations so each mobile Web client can receive the kit during 
synchronization.

NOTE: The Database Schema kit will only be downloaded by mobile users.

The mobile Web clients should be able to synchronize and perform the Schema 
Upgrade kit in much the same manner as any other kits by using the Siebel Upgrade 
Wizard.

If the Siebel Developer created or modified applets or views to display data in new 
extension columns, it is necessary to create and distribute the accompanying Siebel 
Repository File upgrade kit. This allows users to view these data after the schema 
upgrade.

After the Database Schema upgrade is finished, distribute the new SRF kit to its 
corresponding mobile Web clients.

For the dedicated Web clients connected to the HQ Applications Server, you can 
distribute the SRF upgrade kit and the schema upgrade kit at the same time. But be 
sure that both kits are activated and applied before you distribute the configuration. 

After the new database schema has been retrieved by and applied to the new 
databases, normal operations can begin.

NOTE: It is important to distribute a new SRF kit when needed. Running with an old 
SRF file on the new schema can cause data integrity issues in your Siebel database.

Caution: Do not make any kits dependent upon the database schema 
component.  If you create this type of dependency, you will receive 
an error when first time mobile users initialize their local databases.  
The error will indicate the system was unable to check initialization 
status.
Version 7.0, Rev. A Siebel Anywhere Administration Guide MidMarket Edition 7-15



Advanced Usage and Problem Solving
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Updating Specific Lines in the CFG File 7

It is recommended that you have uniform client installations across a Siebel 
deployment. But if for some reasons, some of your Siebel clients are installed in 
different locations than others, the traditional CFG Upgrade Kit will not work for 
every client in the deployment. The reason for this failure is that certain parameters 
(for example, ClientRootDir) in a CFG file are directly tied to the installation 
directory.

To address this issue in Siebel 7, we have provided a standalone executable 
(cfgedit.exe) that is capable of modifying specific lines in a CFG file. We 
recommend using a kit of the type Customer Revisions to deliver and execute 
cfgedit.exe. You may create a separate Upgrade Component of the type Customer 
Revisions to keep track of the version history as well.

Below is a simple example of a procedure. In this example you use cfgedit.exe to 
modify a specific line in the client’s ENU uagent.cfg.

To update specific lines in the CFG file

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits view appears.

3 Click Auto Create to invoke the Upgrade Kit Wizard.

The Upgrade Kit Wizard - Upgrade Component page appears.

4 Follow the prompts to specify all necessary information to define your upgrade 
kit. Use the following on the appropriate pages:

■ For Siebel Component Type, pick Customer Revisions.

■ Add the following to the kit: cfgedit.exe and source.cfg.

Sample file for source.cfg

[Siebel]
ComponentName= New Component Name
[New Section]
NewKey = New Value
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■ Change the Destination Directory from the default to $SiebelRoot\bin\ 

■ Select to execute, cfgedit.exe

■ For command line arguments, use “/s source.cfg /d 
$SiebelRoot\bin\enu\uagent.cfg.”

NOTE: To keep track of the changes to specific configuration files, it is 
recommended to create a new upgrade component, such as Client Customer 
Revision-CallCenterCFG__ENU.

■ For more information about version information, see “Minimum and 
Maximum Version Fields” on page 4-9.

5 Activate, apply, and distribute the upgrade kit you built in previous step.

For More Information 7

For more information about the topics covered in this chapter see Global 
Deployment Guide, MidMarket Edition and Siebel Tools Reference, MidMarket 
Edition.

Appendix A describes FAQs to help administrators solve some situations that can 
arise while fulfilling their responsibilities.
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About This Appendix
About This Appendix A

This appendix includes FAQs to help administrators resolve some problems that can 
arise while performing their responsibilities.

Unlocking Administrator’s Locked Account Due to Failed 
Upgrade Kit A

Question What should I do if the Siebel Administrator’s account is locked out due to a failed 
upgrade kit?

Answer The following procedures will help you recover from lockout because of a failed 
upgrade kit.

To unlock the Siebel Administrator - Option one 

■ The System Administrator logs in as a Web Client (which does not have version 
checking or upgrades). 

■ Take corrective measures to resolve the issue related to the failed upgrade.

To unlock the Siebel Administrator - Option two

1 Edit the Siebel Administrator’s CFG file by changing the ComponentName 
parameter to None. This change will prevent the Siebel client from performing 
any version checking. If you dynamically associated the System Administrator 
account to a configuration by means other than using the applets in the 
Employees view, contact Siebel Technical Support for assistance to help resolve 
this issue.

NOTE: Dynamically associating the System Administrator account with any 
Configuration under the Employees view is not recommended.

2 If the upgrade kit failed while the Siebel Upgrade Wizard was running, then 
delete the file upgwiz.ucf in the \bin directory. 

The Siebel client always checks for the existence of the file upgwiz.ucf in the 
\bin directory to find out if it was in the middle of an upgrade.
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Version Numbers on Upgrade Kit Wizard Page
3 Log in to the system to determine the reason for the failed upgrade, and take 
corrective measures. 

Presumably, the other subscribers to your original configuration are also 
affected.

4 Test your solutions using the Siebel Test Client configuration.

5 After testing the upgrade kit thoroughly, you may then distribute the correct 
upgrade kit to every appropriate configuration. Do not forget to change the value 
of the ComponentName parameter to its original value in the .cfg.

Version Numbers on Upgrade Kit Wizard Page A

Question Why are there two different version numbers in the Upgrade Kit Wizard page? 

Answer The Min and Max versions on this page apply to the version of the component 
required to apply this upgrade kit. The Min and Max version numbers work together 
creating a range of version numbers for the component being upgraded that a client 
can have in order to upgrade to the new version by applying this upgrade kit. 

■ Min version. Indicates that a client with this version or higher for the component 
being upgraded by this kit can use this upgrade kit to upgrade to the New version 
indicated in the New version box. 

■ Max version. Indicates that a client must have this version or lower for the 
component being upgraded by this kit in order to upgrade to the New version 
indicated in the New Version box. 

Now, if you want to allow any client, regardless of what version of the component 
they have applied previously, to be able to use the upgrade kit to upgrade to the new 
version of that component, then you need to blank out Minimum and Maximum 
version numbers on this screen. This will indicate to Siebel Anywhere that the client 
does not have to be on any specific version of the component in order to apply this 
kit. (If you create a kit after distributing a previous kit to mobile Web clients, the 
mobile Web client will use the kit provided that the new version for this new kit has 
the same new version as the bad kit that was created and deactivated.)
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Distributing Different CFG Files to Different Users
NOTE: Please use the above option with caution. For example, if you are creating a 
kit of type Customer Revision, then the only times you can leave Min and Max 
Version fields blank are the following: (1) you do not care if your clients have 
received the previous kits of the same type, or (2) you are able to include the files 
that were sent previously, in this kit or kits you are going to create after this one. 
Also again keep in mind that the new version should stay the same as the kit that 
you have deactivated so that mobile Web clients can use this newly created kit in 
place of the one that has been deactivated.

It is best to always leave Min and Max version blank when you are creating a kit of 
type Siebel Repository File or Siebel CFG File.

Distributing Different CFG Files to Different Users A

Question How do I distribute different CFG files to different sets of users?

Answer Assume that you have two different sets of users (Sales users and Engineer users) 
and each one of these groups uses a different .cfg (Sales.cfg and Eng.cfg) to 
bring up the Siebel Application. Now you need to send a new .cfg to each group 
through Siebel Anywhere. 

To distribute different CFG files to different sets of users 

1 Prepare the files Sales.cfg and Eng.cfg files.

2 Launch the Siebel Application.

3 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

4 From the Show drop-down list, click Upgrade Components.

The Upgrade Components list appears.
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5 Create a component for each language, such as Sales CFG__ENU, similar to the 
Siebel Call Center CFG component. Use the Copy Record option. Set the values 
for the columns for each record as shown in the tables below.

Example values for Record 1:

Example values for Record 2:

Field Comment

Name  Sales CFG

Component Type  Siebel CFG_ENU File

Min Version  100 

Max Version  Leave this blank for now

Locate Method  CFG

Locate Information  Siebel,ClientRootDir,bin\enu\sales.cfg

Version Method  CFG

Version Information  Siebel,Version

Field Comment

Name  Engineering CFG

Component Type  Siebel CFG_ENU File

Min Version  100

Max Version  Leave this blank for now

Locate Method  CFG

Locate Information  Siebel,ClientRootDir,bin\enu\eng.cfg

Version Method  CFG

Version Information  Siebel,Version
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6 Create a configuration for each language combination for both sets of users 
(Sales and Engineering) and add the appropriate CFG components you just 
created as related components.

See Chapter 3, “Upgrade Planning and Preliminary Tasks” for details.

7 Go to Siebel Anywhere Administration > Upgrade Kits and use Auto Create to 
create two kits. 

■ One for Sales users (using Sales CFG component and Sales.cfg).

■ The other is for Engineering users (using Engineering CFG component and 
Eng.cfg). 

8 Apply the kits, and be sure to click on the Require Upgrade Kit button in the 
Apply Upgrade Kit dialog box.

To test distributing CFG files to different sets of users

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration > Configuration.

2 Add the new CFG components (Sales CFG and Engineering CFG) to the Siebel 
Test Client configuration.

3 Add two or more users to the Employee list for Siebel Test Client.

4 Distribute the Siebel Test Client to verify that you can retrieve the kit 
successfully.

5 Make sure that your users’ CFG files reflect the correct ComponentName in their 
CFG. 

Sales users should have this parameter set to Sales Configuration while 
Engineering users should have this parameter set to Engineering Configuration. 
Also, users should verify an exact match between the ComponentName in .cfg 
and Configuration name in the Anywhere Administration > Configuration view.

6 Distribute the Sales Configuration and Engineering Configuration to send the kit 
to all users.
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New Upgrade Kit Status “In Progress” A

Question Why does my new upgrade kit status remain In Progress for a long time?

Answer There may be times when the upgrade kit takes a long time to build. If this is the 
case, consider the following information to help troubleshoot the situation.

Some of the reasons for this include: 

■ The upgrade kit is still being built.  To monitor the progress of the upgrade kit, 
you have three options to check the latest status:

■ Go to the My Component Requests view and look for the latest status.  

■ In the server manager line-mode utility, enter:

list task for comp UpgKitBldr

■ Look for the component log file for Upgrade Kit Builder 
(UpgKitBldr_<taskno>.log) in the log directory.

■ If you conclude that Upgrade Kit Builder is indeed not responding, check two 
other Server Components that support Upgrade Kit Builder: File System Manager 
(FSM) and Service Request Broker (SRBroker). Be sure these components are 
running correctly.

■ Sometimes a file system error or a network connection error interrupts the 
operation of Upgrade Kit Builder. Edit the record, set the status to error (from In 
Progress), save, and then delete the record before trying to rebuild. Delete the 
failed record to avoid a naming conflict.

■ Then, rerun Upgrade Kit Builder to build the kit.
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Unable to Download Upgrade Kit A

Question My client is getting Unable to Download the Upgrade Kit... message. Why?

Answer There are times when the following error messages appear when attempting to 
download an upgrade kit.

■ Unable to select required upgrade kits to upgrade your system. Please contact 
your Siebel Administrator or try again. 

■ The file ‘XXX_XXX.arc’ could not be found on any specified file system.

■ Upgrade wizard did not complete successfully. Restart Siebel application to 
attempt the upgrade again.

■ Unable to open compressed file (<Sublevel directory 
patch>\S_UPG_KIT_IARG_XXX_XXXX.saf).

■ Unable to download the Upgrade Kit ‘%1’ required to upgrade your system.

These errors can be caused by the following conditions: 

■ A previously required kit has been deactivated or deleted. The client is trying to 
find an active kit with a certain New Version number, but there is no such kit 
because it was deactivated or deleted. 

To solve this problem, have your mobile Web client first synchronize using an 
invalid Configuration (set the Component Name in the CFG file to none). This 
action will get the recent transactions routed to the mobile web client and pass 
the transaction regarding the nonfunctioning or inactivated kit. 

Have users change the Component Name back to the original value and 
synchronize again. You can make this process transparent to your users by 
sending them a batch file that synchronizes for them from the command line 
using a different .cfg that was sent to them with the batch file. Use 
siebsync.exe and specify the .cfg with the /c option.

■ The kit you have created is of type Siebel Client Customer Revision and when 
you were creating the kit, you selected a nonexecutable file to be executed. You 
need to deactivate the kit and recreate it with the same version number. Activate 
the kit, but do not apply or distribute it.
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■ The user’s connection to File System is not set correctly. 

■ For dedicated users. Check the dedicated users’ CFG files and make sure that 
the File System parameter under Server section is set to the appropriate 
location and that your user has read/write access to that directory. One test 
for this would be to have the user open an attachment and if that is 
successful then the connection to File System is set correctly. 

■ For mobile users. Because mobile users are connected to the File System 
through the Siebel Server, make sure the Siebel File System parameter of 
Synchronization Manager is set to the correct location—the same location as 
the File System parameter in the CFG file (of the user who has created the 
kit). In other words, make sure that the File System Manager is working 
properly.

■ There is not enough space on the machine to download the kit. Free some space 
and try to retrieve and apply the upgrade kit again.

■ An upgrade that the System Administrator intends for the end users to retrieve 
may depend on another kit that has either been deactivated, deleted, or not 
created yet. The Siebel Client will make sure that all kits are ready before 
invoking the Upgrade Wizard.
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Deleting Old Upgrade Kits A

Question Can I delete old upgrade kits?

Answer Yes, but be sure you understand the consequences of your actions before you begin.

Sometimes you may want to purge older upgrade kits to free up some space used 
by these kits. When you purge old kits, however, you must make sure that new 
users will not encounter errors when they retrieve the kits expecting to use 
information in the older kits.

Two groups of users can be adversely affected when old kits are deleted, new users 
and infrequent users. For example, assume that your end users belong to the same 
configuration. Also assume they are currently using version 3 of Client Customer 
Revisions and version 4 of SRF. 

If you were to delete all the previous Client Customer Revisions and SRF kits, a new 
user may have trouble with Client Customer Revisions if starting from version 0. 
This situation occurs because Client Customer Revisions kits often depend on the 
previous versions. Siebel Anywhere will not be able to find an upgrade path for 
Client Customer Revisions if say version 2 is needed in order to get to version 3 
when the kit for version 2 is deleted. However, the new user would not have any 
trouble with the SRF kit because SRF kits do not depend on any version history.

The correct way to handle this situation is to keep an updated installation for new 
users where each of the kits has been applied. You do this by creating a package 
periodically and make the most current package available to new users. This 
method will address the problem for new users, because they will always install a 
client with up-to-date configurations.

However, do not delete old kits as soon as a new package is created, either. There 
may be infrequent users in your organization who have not logged in for months. 
While the rest of the company is using version 3, they may still be on version 1. In 
this case, it is up to the individual Siebel Administrators to assess the situation and 
determine how old is old enough before deletion.

Sometimes you have a few kits of the type Customer Revision that were distributed 
long ago. Use the following procedure to delete them.
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To delete old Customer Revision kits

1 Establish one installation that includes all the Customer Revision kits ever 
applied.

2 Create a package from that installation.

3 Set up each new user with the package prepared in Step 1. This will provide the 
new clients the files that were distributed through the old Customer Revision 
kits, and also provides the new clients the correct version of the clntrev.cfg. 

Use the same logic if you are planning to delete any other kits.

Differences Between siebupg.exe and siebupg1.exe A

Question What is the difference between siebupg.exe and siebupg1.exe? 

Answer Both siebupg.exe and siebupg1.exe are stand-alone executables for the Siebel 
Upgrade Wizard. The Siebel Upgrade Wizard is a stand-alone program that is 
invoked to carry out the application of the upgrade kits for a Siebel Client as well 
as a Siebel Server. It is also used to carry out the initialization process for local 
databases of mobile users. 

In most cases, siebupg.exe and siebupg1.exe are identical. But during an 
upgrade, the Siebel Client always calls siebupg1.exe to carry out the job. In the 
case of a Siebel Server upgrade, the Siebel Administrator should manually copy 
siebupg.exe to siebupg1.exe before invoking siebupg1.exe.

The reason there are two stand-alone executables is that the upgrade may contain 
an upgrade kit that upgrades the Siebel Upgrade Wizard itself. When that happens, 
the new Siebel Upgrade Wizard executable is copied to siebupg.exe. If you were 
using siebupg.exe, this copy action would not be possible because the Siebel 
Upgrade Wizard would still be running. As soon as the Siebel Upgrade Wizard 
detects that it is upgrading itself, it will accomplish the upgrade and restart 
immediately. During restart, it would automatically copy the new siebupg.exe to 
siebupg1.exe and run siebupg1.exe to resume the upgrade process.
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Upgrade Kit Wizard and Apply Upgrade Kit Version 
Numbers A

Question Why are the version numbers different in the “Upgrade Kit Wizard” pages and 
“Apply Upgrade Kit” dialog boxes?

Answer The following section explains the differences in the version numbers you 
encounter on wizard pages when creating an upgrade kit and on dialog boxes when 
applying it.

Upgrade Kit Wizard Pages
The Minimum and Maximum Version numbers specified in the Upgrade Kit Wizard 
pages define a range of version numbers for the specific component that the client 
must have in order to upgrade to the new version. The minimum version is 
defaulted from the current version in the component registry.

■ Minimum version. This value indicates that a client with this version or higher, for 
the component being upgraded, can use this upgrade kit to upgrade to the new 
version indicated in the New Version field.

■ Maximum version. This value indicates that a client must have this version or 
lower, for the component being upgraded, in order to upgrade to the new version 
indicated in the New Version field.

If you want to allow clients to use the upgrade kit to upgrade to the new version— 
regardless of their current version of the component—leave the Minimum and 
Maximum field values blank. These blanks indicate to Siebel Anywhere that the 
client does not need any specific version of the component in order to install this 
kit. (In the case of mobile Web clients, if you create a new kit after distributing and 
deactivating a kit, make sure that the new version number is the same as the 
previous one.) 

NOTE: Use this feature with caution. For example, if you create a Customer Revision 
upgrade kit, the only time you can leave the Minimum and Maximum fields blank 
is when you either don't care if your clients have received the previous kits of the 
same type or you are able to include every file required by the component in this 
kit or kits you are going to create after this one. 
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Apply Upgrade Kit Version Information Dialog Box
After you activate each upgrade kit for an upgrade, you need to apply each kit. 
Applying a kit updates the component registry with the component version 
information. This step is essential in creating an upgrade kit and is also the step in 
which you indicate whether a kit is required or optional. 

When you click Apply Versions, in the Upgrade Kits view, the Apply Upgrade Kit 
Version Information dialog box appears. (See “Applying Versions of an Upgrade Kit” 
on page 5-5 for a screen shot of this page.) The Minimum and Maximum Version 
numbers in this dialog box refer to the version of the component that can be used 
to bring up the application. If you click OK (within this dialog box) without clicking 
Require Upgrade Kit, you make it an optional kit—after the kit is distributed, your 
subscribers can use Siebel eBusiness Applications without upgrading if their version 
is between the minimum and maximum values. 

If users have a version below the minimum version and choose not to install the 
upgrade, they can only bring up the application in read-only mode.

Clicking Require Upgrade Kit changes the minimum version to match the maximum 
version, which is the new version. In this case, the subscribers will have to upgrade 
after the configuration is distributed.

See Chapter 2, “Screens and Views in Siebel Anywhere” for more details regarding 
topics in this FAQ.
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Converting a Required Kit to an Optional Kit
Converting a Required Kit to an Optional Kit A

Question How do I convert the most recently distributed required kit to an optional kit?

Answer If you distribute a required kit and realize it should have been optional, use this 
procedure to make the change.

NOTE: This procedure only applies to dedicated users. Kits for mobile users cannot 
be changed from required to optional.

To convert a required kit to an optional kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Components.

The Upgrade Components list appears.

3 From the Upgrade Components list, select the name of the Upgrade Component 
for which you distributed the upgrade kit. 

4 Modify the Min Version field with the minimum value that is acceptable, or 
change it to null.

5 Step off the record, or choose Save Record from the applet menu, to save the 
record.

6 Go to the Anywhere Administration screen. 

7 From the Show drop-down list, click Configurations.

The Upgrade Configurations and Related Components list applets appear.

8 On the Upgrade Configurations list applet, select the configurations you had 
previously distributed the component information to. 

Caution: Perform this step carefully, because the wrong 
minimum value could cause some users to skip a related 
required kit.
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Resetting Min and Max Information After Distribution
9 Click Distribute.

These steps make the upgrade kit optional and allow the users to log in to the 
Product Updates view—if the client version they are using is between the minimum 
and maximum for the upgrade component in the Upgrade Components view.

Resetting Min and Max Information After Distribution A

Question How do I reset the Min old and Max old version information after distribution?

Answer The following steps outline how to change minimum and maximum versions of a 
kit that has been distributed.

To change minimum and maximum versions of a kit after distribution

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration. 

2 From the Show drop-down list, click Upgrade Kits.

The Upgrade Kits list appears.

3 From the Upgrade Kits list, select the target upgrade kit.

4 If the status is Active, change the status to Pending. 

5 Change Min Old Version and Max Old Version per your requirement. 

If you want it to be available for every client, you should set both Min and Max 
to blank.

6 While the kit is selected, click Activate. Do not change status to Active manually. 

7 You do not need to apply or distribute.
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Testing for Upgrade Kit Component Consistency
Testing for Upgrade Kit Component Consistency A

Question What should I do to make sure Siebel Anywhere upgrade kits are consistent after I 
upgrade my Siebel application?

Answer Version numbering should continue across releases for Upgrade Components in 
each Siebel Anywhere Configuration. Upgrading to a new release of Siebel 
eBusiness Applications upgrades the Siebel Anywhere table definitions. However, it 
does not reset the Upgrade Component information for Siebel Anywhere 
Configurations. 

As a result, Siebel Anywhere will resume version checking against the existing 
component versions in the new release of Siebel eBusiness Applications. If required 
upgrade kits for Siebel Client Repository File, Siebel Client Customer Revisions, or 
Siebel CFG File were distributed in the previous release, newly upgraded Production 
clients will be prompted for upgrade kits when they synchronize with the server.

Before upgrading Production users, test the upgrade kit using the Packager Client 
machine with version checking enabled. Verify that this client passes version check, 
so that after the upgrade kit is packaged and distributed, it will function correctly 
for the remainder of your Production users. 

To accomplish this testing, verify that Administrator Client has the latest versions 
for Siebel Client Repository File__{language code}, Siebel Client Customer 
Revisions, and Siebel CFG__{language code} in advance of running the Siebel 
Packager utility. For the purposes of this example, SIEBEL_CLNT_ROOT will be the 
Packager Client root directory and Siebel Call Center will be the application.

The following procedure describes how to test for Siebel Client Repository File 
component consistency.

To test Siebel Client Repository File component consistency

1 Use the sfrstamp.exe utility to read the current version of the SRF file and 
compare it to the component version.

You can find this utility in SIEBEL_CLNT_ROOT\bin.

2 Use the srfstamp.exe to stamp a new version to the SRF file, as required.
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Testing for Upgrade Kit Component Consistency
The following procedure describes how to test for Siebel Client Customer Revisions 
component consistency.

To test Siebel Client Customer Revisions component consistency

■ Copy the clntrev.cfg file from one of your previous release Production Clients 
to the SIEBEL_CLNT_ROOT\bin directory of the Administrator Client.

The following procedure describes how to test for Siebel CFG File component 
consistency.

To test Siebel CFG File component consistency

■ Edit the appropriate CFG file under SIEBEL_CLNT_ROOT\bin\{language code} 
and increment the Version parameter in the [Siebel] section to the Maximum 
Version of the Upgrade Component Siebel Call Center CFG for the previous 
release.

Test with the Administrator Client until this client passes version check. Run the 
Siebel Packager Utility to create the custom installer. Distribute the custom installer 
through Siebel Anywhere (as described in Upgrade Guide for Microsoft Windows, 
MidMarket Edition) or through a shared network location.
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Creating Kits That Check DLL File Versions
Creating Kits That Check DLL File Versions A

Question How do I create an upgrade kit that checks DLL file versions?

Answer Sometimes you need to upgrade third-party software based upon the version of a 
particular DLL file. An example would be an ODBC upgrade on a client based upon 
the version of odbcint.dll. 

In order to achieve this functionality, first create a new Upgrade Component and 
then an Upgrade Kit. 

To create an upgrade component and kit for DLL version check

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration. 

2 From the Show drop-down list, click Upgrade Components.

The Upgrade Components list appears.

3 Create an Upgrade Component and specify the following field values:

In this table, the value for Locate Information points to the registry hkey, subkey 
and a specific value that points to the DLL file you wish to version check. 

For example:

HKEY_LOCAL_MACHINE,SOFTWARE\ODBCFileDSN\DefaultIcon,Driver

Field Comment

Name Upgrade Component Name

Component Type Third-Party Software

Locate Method Registry

Locate Information <hkey>,<subkey name>,<value 
name>

Version Method FileVersion
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Constructing Third-Party Upgrade Kits
If the registry value is DefaultIcon, then the <value name> must be omitted. 
This value in the registry will then point to the specific DLL file.

For example:

C:\WINNT\System32\odbcint.dll

4 After creating the above custom component, define the upgrade kit as shown in 
Chapter 4, “Creating and Defining the Upgrade Kit.” 

When defining the Upgrade Kit, remember to select the name of the custom 
upgrade component (created above) when the Upgrade Wizard page appears.

Constructing Third-Party Upgrade Kits A

Question How do I construct a third-party upgrade kit?

Answer Third-Party Software components are meant to be used to create kits only for 
version checking and not to upgrade the software on the users’ machines. The 
example below uses WinZip as the third-party software to illustrate this. 

There are two procedures to this process described below: 

■ To create a new upgrade component Third-Party WinZip.

■ To define a Third-Party WinZip upgrade kit. 

To create a new upgrade component Third-Party WinZip 

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, click Upgrade Components.

The Upgrade Components list appears.

3 On the Upgrade Components list, click New.

A blank record appears.

Enter the necessary information. 

As an alternative, Copy Record on an existing Third Party component and then 
edit the fields as required.
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4 Enter the following:

5 From the Show drop-down list, click Configurations.

The Configurations list appears, along with the Related Components list.

6 On the Configurations list, select the desired clients such as Siebel Sales Client.

7 On the Related Components list, click New.

The Upgrade Components pick list appears.

8 On the Upgrade Components Selection dialog box, select Third Party-WinZip.

The Configurations list appears, along with the Related Components list.

The new record (Third Party-WinZip upgrade component) is highlighted in the 
Related Components list, which indicates it is selected.

9 On the Related Components list, click the Required at Startup field and click the 
checkbox. 

This step completes the procedure to create a new upgrade component, Third-
Party WinZip.

Field Comment

Component Name Third Party-WinZip.

Component Type From the pick list, choose Third Party Software.

Locate method From the pick list, choose Registry.

Locate info - 
'HKEY_CLASSES_ROOT, 
WinZip\shell\open\command'

Locate Info has the following structure when Locate 
Method = 'Registry': 
<HKEY>,<Subkey>,<Name>. If <Name> is 
equal to the default, that is, '(Default)' as seen in the 
Registry Editor, then leave <Name> as blank in 
Locate info.

Version method From the pick list, choose FileVersion.
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To define a Third-Party WinZip upgrade kit

1 From the application-level menu, select View > Site Map > Siebel Anywhere 
Administration.

2 From the Show drop-down list, select Upgrade Kits.

The Upgrade Kits view appears.

3 Click Auto Create to invoke the Upgrade Kit Wizard.

The Upgrade Kit Wizard - Upgrade Components page appears.

4 Choose Third-Party WinZip in the list and click Next.

The Upgrade Kit Wizard - Add Files page appears.

5 Click browse to select WinZip installer files or enter the path and file name in 
the Files to Add field.

Click Add.

Repeat this step to add all WinZip installer files. These are the install files in the 
WinZip folder (Install.exe, Setup.wz, wzbetact.exe, wzinet95.exe). Since 
the Client Destination Directory field specifies where the upgrade kit will be 
placed on the subscriber, verify the following string is there:

$SiebelRoot\upgrade\$KitName. 

$SiebelRoot refers to the Siebel Root Directory and $KitName refers to the name 
of the upgrade kit in a subdirectory. 

6 Click Next.

The Upgrade Kit Wizard - Select Execute File page appears. 

7 Select the executable file such as Install.exe, and follow the prompts to:

a Review and verify the information.

b Specify the new version number.

c Change title, if you want to do so.
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Turning Off the Prompt for Upgrade Kits
This step completes the procedure to define an Upgrade Kit for Third-Party WinZip 
(the example third-party software used to demonstrate this procedure).

Follow the procedures in Chapter 5, “Activating, Applying, and Distributing the 
Upgrade Kit” to activate, apply, and distribute the kit.

Turning Off the Prompt for Upgrade Kits A

Question When end users login, how do I prevent prompting to apply upgrade kits?

Answer There may be times when you do not want your users to be prompted to apply 
upgrade kits. To do this, use one of the methods below, depending upon the type of 
client:

■ For Connected Clients, do one of the following on Siebel Anywhere 
Administration > Configurations view. 

■ Rename the appropriate configurations.  For example, rename the Siebel 
Sales Client as Old Siebel Sales Client, and so forth. Then re-distribute this 
information to the configuration.

■ Delete all the related components in a configuration and re-distribute this 
information to the configuration.

■ Remove all the check marks in the Required at Start Up Flag field in the 
Upgrade Configurations view, Upgrade Components list.  Then re-distribute 
this information to the configuration.

■ For Mobile Web Clients, in addition to the above process, do one of the 
following: 

■ Change ComponentName parameter in CFG file to None.

■ Re-extract local database.

If mobile Web clients are associated with a particular configuration through 
Siebel Anywhere Administration > Employee view, this is the only choice. 
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For More Information
For More Information A

For more information about topics and related information in this chapter, see 
Upgrade Guide for Microsoft Windows, MidMarket Edition and Siebel Web Client 
Administration Guide, MidMarket Edition.
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