Skip Headers

Oracle® Warehouse Builder Scripting Reference
10g Release 1 (10.1)

Part Number B12152-01
Go to Documentation Home
Go to Book List
Book List
Go to Table of Contents
Go to Feedback page
Contact Us

Go to previous page
Go to next page
View PDF

A Running OMB Plus in Oracle JDeveloper

This appendix outlines the steps to install and run OMP Plus in Oracle Database JDeveloper. For more information, see the Oracle Database JDeveloper documentation.

This appendix includes the following topics:

Installing OMB Plus in Oracle JDeveloper

Use the following steps to install OMB Plus in Oracle JDeveloper. You must install Oracle JDeveloper and Warehouse Builder client on the same machine.

To install OMB Plus in JDeveloper:

  1. Drop shiphome/owb/lib/int/OMBPlus_jdev.jar in the JDeveloper installation directory/lib/ext directory.

  2. Start JDeveloper.

  3. From the Tools menu, select Preferences, OMBPlus, and then OMBPlus Installation to set the Warehouse Builder installation directory. For example, c:\oracle\ora81. Do not include the Warehouse Builder directory at the end of this path.

  4. Restart JDeveloper.

    Repeat steps 3 and 4 each time you change the Warehouse Builder installation directory.

Opening the Syntax Highlighting Editor in JDeveloper

To open the syntax highlighting editor:

  1. From the File menu, select New and then OMBPlus, if you want to create a new OMBPlus script. To open an existing OMBPlus script, select File, and then Open.

  2. From the Tools menu, select Preferences, then Editor, and then Syntax Colors.

  3. Select the OMBPlus Category to configure the syntax highlight styles.

Invoking Keyword Auto Completion

Use any of the following methods to invoke keyword auto completion:

Invoking the OMBPlus Interpreter

To invoke the OMBPlus Interpreter:

  1. From the View menu, select Log Window to view the OMBPlus Log.

  2. From the Run menu, select Run OMBPlus to run the current OMBPlus script.

    You can also invoke Run OMBPlus by right-clicking a specific script node on the system navigator and selecting Run OMBPlus.

    You can terminate the OMBPlus program by selecting Run, then Terminate, and then OMBPlus.

  3. If you want to provide input to the OMBPlus script, select Project, then Project Settings, then Runner, and then Options to set Allow Program Input.

Viewing the OMBPlus Console

To open the OMBPlus Console:

  1. Select OMBPlus Console to open the OMBPlus Console window.

  2. From the Tools menu, select Preferences, then OMBPlus, and then OMBPlus Console to configure the display in the console window.

Viewing Help Documentation

Use any of the following methods to invoke the help documentation: