
H Y P E R I O N ®  S Y S T E M ™  9  B I + ™

WORKSPACE™
R E L E A S E  9 . 2

G E T T I N G  S T A R T E D  G U I D E



Copyright 1989–2006 Hyperion Solutions Corporation. 
All rights reserved.

“Hyperion,” the Hyperion logo, and Hyperion’s product names are trademarks of Hyperion. References to other 
companies and their products use trademarks owned by the respective companies and are for reference purpose only.

No portion hereof may be reproduced or transmitted in any form or by any means, electronic or mechanical, including 
photocopying, recording, or information storage and retrieval systems, for any purpose other than the recipient’s personal 
use, without the express written permission of Hyperion.

The information contained herein is subject to change without notice. Hyperion shall not be liable for errors contained 
herein or consequential damages in connection with the furnishing, performance, or use hereof.

Any Hyperion software described herein is licensed exclusively subject to the conditions set forth in the Hyperion license 
agreement.

Use, duplication or disclosure by the U.S. Government is subject to restrictions set forth in the applicable Hyperion license 
agreement and as provided in DFARS 227.7202-1(a) and 227.7202-3(a) (1995), DFARS 252.227-7013(c)(1)(ii) (Oct 
1988), FAR 12.212(a) (1995), FAR 52.227-19, or FAR 52.227-14, as applicable.

Hyperion Solutions Corporation 
5450 Great America Parkway 
Santa Clara, California 95054

Printed in the U.S.A.



Contents   iii

Contents

Preface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  vii

Purpose  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  vii

Audience  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  vii

Document Structure  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  vii

Where to Find Documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  viii

Help Menu Commands  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  viii

Conventions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  ix

Additional Support . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . x

Education Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . x

Consulting Services . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . x

Technical Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . x

Documentation Feedback  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . x

CHAPTER 1 Using Workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

Preparing to Use Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

Workspace Documentation Set . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14

Deployment Workflow . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16

Workspace . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17

Workspace Capabilities  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Modules Used to Perform Tasks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Accessing Modules . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20

Using View Pane Buttons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

User Types and Tasks . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

Module Tasks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24

Workspace User Interface  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28

Repository . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Actions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

Locations  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30

File Permissions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Logging on to Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31

Setting Preferences  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32

Using Data Source Elements  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32



iv  Contents 

Web Analysis Studio . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34

Financial Reporting Studio  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  34

Interactive Reporting Studio . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

Production Reporting Studio  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

Analytic Services Features Available to the Studios . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  35

Financial Management Features Available to the Studios . . . . . . . . . . . . . . . . . . . . . . . . . .  36

Planning Details as a Database Connection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  36

SAP BW Data Sources  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  36

Relational Access Methods . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  37

Starting Tasks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  38

Creating Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  39

Accessing Modules  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Opening and Printing Documents or URLs  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  40

Setting File Properties and Moving Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41

Renaming Files  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41

Adding and Removing Documents from Favorites . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  41

Using Explore  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  42

Using Schedule  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  43

Using Viewer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44

Using Hyperion System 9 Smart View for Office  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  44

Personalizing Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

Using the Desktop  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

Subscribing to Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  45

Working with Favorites  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  46

Using Personal Pages  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  46

Toolbars  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  48

Viewer, Web Analysis Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49

Viewer, Financial Reporting Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49

Viewer, Book Editor Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  49

Viewer, Batch Editor Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

Viewer, Interactive Reporting Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  50

Viewer, Performance Scorecard Toolbar . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Batch Scheduler Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Explore Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  52

Administer Toolbar  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  53

Production Reporting Toolbar Buttons  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  54

Menus . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  54

File Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  54

Edit Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  56

View Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57

Favorites Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  57

Actions Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  58

Format Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  61

Tools Menu  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  63



Contents   v

Help Menu . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64

Shortcut Menu Commands . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Shortcut Keys  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66

CHAPTER 2 Viewing Documents in Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69

Viewing Web Analysis Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Web Analysis Clients . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Web Analysis Client Interfaces . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71

Web Analysis Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72

Opening Web Analysis Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74

Showing and Hiding Web Analysis Document Components  . . . . . . . . . . . . . . . . . . . . . . . 74

Resizing Web Analysis Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Navigating Web Analysis Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75

Distributing Web Analysis Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 77

Passing Web Analysis Document to Web Analysis Studio . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Viewing Financial Reporting Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78

Making Reports and Books Available to Workspace Users  . . . . . . . . . . . . . . . . . . . . . . . . . 78

Navigating in Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Financial Reports Functionality . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Batch and Book Editor, Batch Scheduler . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79

Opening Reports  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Viewing Snapshot Reports and Books . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Creating Database Connections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Viewing a Production Reporting Document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80

Using Interactive Reporting Documents in Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

How Interactive Reporting Works . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Viewing Interactive Reporting Documents in Workspace . . . . . . . . . . . . . . . . . . . . . . . . . . 81

Using Enterprise Metrics to Manage Business Performance  . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

How Enterprise Metrics Manages Data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83

Analysis Framework  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84

Understanding the Enterprise Metrics Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85

Enterprise Metrics Charts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86

Security Restrictions . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

Getting Started with Scorecard Studio . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87

CHAPTER 3 Designing Documents in Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89

Designer Tasks  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Planning . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

User Preferences . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Designer Resources  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90

Designer Capabilities in Workspace  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91

Designing Web Analysis Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92

Creating Web Analysis Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 92



vi  Contents 

Modifying Queries  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  94

Selecting Dimension Members  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  95

About Advanced Member Selection . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  96

Managing Analysis Tools  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  98

Creating Traffic Lighting Definitions  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  99

Saving Web Analysis Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  100

Setting File Permissions for Web Analysis Documents . . . . . . . . . . . . . . . . . . . . . . . . . . .  100

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  101

Designing for Financial Reporting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  101

Production Reporting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  102

Production Reporting Client . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  102

Production Reporting Server . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  103

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  105

Overview of Design Features in Interactive Reporting  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  105

Understanding Interactive Reporting Documents . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  106

Creating an Interactive Reporting Document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  106

Accessing a Document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  107

Saving Documents  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  107

Working with Document Sections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  108

Section Pane  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  109

Selecting Document Sections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  109

Adding Sections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  109

Moving Between Sections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  110

Duplicating Sections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  110

Renaming Sections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  110

Deleting Sections  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  110

Dashboard Home . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  111

Refreshing Document Sections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  111

Printing Sections . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  111

Exporting Data  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  111

Exporting a Section as a PDF  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  112

Exporting Sections to Excel (.XLS) . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  112

Exporting Documents in Native File Format . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  113

 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  113

Glossary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  115

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .  129



Preface   vii

Preface

Welcome to the Hyperion System 9 BI + Workspace Getting Started Guide. This preface 

discusses the following topics:

● “Purpose” on page vii

● “Audience” on page vii

● “Document Structure” on page vii

● “Where to Find Documentation” on page viii

● “Help Menu Commands” on page viii

● “Conventions” on page ix

● “Additional Support” on page x

● “Documentation Feedback” on page x

Purpose
This guide provides information that you need to use with Workspace. It explains Workspace 
features and options and contains the concepts, processes, procedures, formats, tasks, and 
examples that you need to use the software.

Audience
This guide is for authors and consumers who are responsible for viewing and creating 
documents.

Document Structure
This document contains the following information: 

● Chapter 1, “Using Workspace,” which introduces the functionality that Workspace 
provides

● Chapter 2, “Viewing Documents in Workspace,” which describes how a consumer can view 
documents from Workspace
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● Chapter 3, “Designing Documents in Workspace,” which shows how to design reports from 
Workspace and from the studios

● Glossary

● Index

Where to Find Documentation
All Workspace documentation is accessible from the following locations:

● The HTML Information Map is available from Workspace Help for all operating systems 
and from the Start menu for Microsoft Windows systems.

● Online help is available from within Workspace. After you log on to the product, you can 
access online help by clicking the Help button or selecting Help from the menu bar.

● The Hyperion Download Center can be accessed from the Hyperion Solutions Web site.

➤ To access documentation from the Hyperion Download Center:

1 Go to the Hyperion Solutions Web site and navigate to Services > WorldWide Support > Download Center.

Note: Your Login ID for the Hyperion Download Center is your e-mail address. The Login ID and Password required for 
the Hyperion Download Center differ from the logon ID and password required for Hyperion Support Online 
through Hyperion.com. If you are not sure whether you have a Hyperion Download Center account, follow the 
on-screen instructions.

2 For Login ID and Password text boxes, enter your e-mail address and password.

3 For Language list box, select the appropriate language and click Login.

4 If you are a member on multiple Hyperion Solutions Download Center accounts, select an account.

5 To access documentation online, from the Product List, select a product and follow the on-screen 
instructions.

Help Menu Commands
The following commands are available from the Workspace Help menu

Table i Help Menu Commands 

Command Description

Help on This Topic Launches a help topic specific to the window or Web page

Contents Launches Workspace help

Information Map Launches Workspace Information Map, which provides the following assistance.

● Online help in PDF and HTML format

● Links to related resources
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Conventions
The following conventions are used in this document:

Technical Support Launches the Hyperion Technical Support site, where you submit defects and contact 
Technical Support.

Hyperion Developer’s 
Network

Launches the Hyperion Developer Network site, where you access information about 
known defects and best practices. This site also provides tools and information to 
assist you in getting starting using Hyperion products:

● Sample models

● A resource library containing FAQs, tips, and technical white papers

● Demos and Webcasts demonstrating how Hyperion products are used

Hyperion.com Launches Hyperion’s corporate Web site, where you access information about 
Hyperion:

● Office locations

● The Hyperion Business Intelligence and Business Performance Management 
product suite

● Consulting and partner programs

● Customer and education services and technical support

About Hyperion System 9 
BI + Workspace

Launches the About Hyperion System 9 BI + Workspace dialog box, which contains 
copyright and release information, along with version details.

Table ii Conventions Used in This Document  

Item Meaning

Arrows indicate the beginning of procedures consisting of sequential steps or 
one-step procedures.

Brackets [ ] In examples, brackets indicate that the enclosed elements are optional.

Bold Bold in procedural steps highlights user interface elements on which the user 
must perform actions.

CAPITAL LETTERS Capital letters denote commands and various IDs. (Example: CLEARBLOCK 
command)

Ctrl+0 Keystroke combinations shown with the plus sign (+) indicate that you should 
press the first key and hold it while you press the next key. Do not type the plus 
sign.

Ctrl+Q, Shift+Q For consecutive keystroke combinations, a comma indicates that you press the 
combinations consecutively.

Example text Courier font indicates that the example text is code or syntax.

Courier italics Courier italic text indicates a variable field in command syntax. Substitute a value 
in place of the variable shown in Courier italics.

ARBORPATH When you see the environment variable ARBORPATH in italics, substitute the 
value of ARBORPATH from your site.

Table i Help Menu Commands (Continued)

➤
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Additional Support
In addition to providing documentation and online help, Hyperion offers the following 
product information and support. For details on education, consulting, or support options, 
click the Services link at the Hyperion Solutions Web site.

Education Services
Hyperion offers instructor-led training, custom training, and e-Learning covering all Hyperion 
applications and technologies. Training is geared to administrators, end users, and information 
systems professionals. 

Consulting Services
Experienced Hyperion consultants and partners implement software solutions tailored to 
clients’ particular reporting, analysis, modeling, and planning requirements. Hyperion also 
offers specialized consulting packages, technical assessments, and integration solutions.

Technical Support
Hyperion provides enhanced telephone and electronic-based support to clients to resolve 
product issues quickly and accurately. This support is available for all Hyperion products at no 
additional cost to clients with current maintenance agreements.

Documentation Feedback
Hyperion strives to provide complete and accurate documentation. Your opinion on the 
documentation is of value, so please send your comments by going to 
http://www.hyperion.com/services/support_programs/doc_survey/index.cfm.

n, x Italic n stands for a variable number; italic x can stand for a variable number or a 
letter. These variables are sometimes found in formulas.

Ellipses (...) Ellipsis points indicate that text has been omitted from an example.

Mouse orientation This document provides examples and procedures using a right-handed mouse. 
If you use a left-handed mouse, adjust the procedures accordingly.

Menu options Options in menus are shown in the following format. Substitute the appropriate 
option names in the placeholders, as indicated.

Menu name > Menu command > Extended menu command 

For example: 1. Select File > Desktop > Accounts. 

Table ii Conventions Used in This Document  (Continued)

Item Meaning

http://www.hyperion.com/services/support_programs/doc_survey/index.cfm
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C h a p t e r

1
Using Workspace

BI+, a modular business intelligence platform, provides management reporting, query, and 
analysis capabilities for a wide variety of data sources in a single coordinated environment.

BI+ includes:

● Workspace–a zero-footprint thin client that provides access to the following content:

❍ Hyperion System 9 BI+ Enterprise Metrics–for management metrics and analysis 
presented in easy-to-use, personalized, interactive dynamic dashboards

❍ Hyperion System 9 BI+ Financial Reporting –for scheduled or on-demand highly 
formatted financial and operational reporting from almost any data source, including 
Hyperion System 9 Planning and Hyperion System 9 Financial Management

❍ Hyperion System 9 BI+ Interactive Reporting –for ad hoc, relational query, self-service 
reporting and dashboards against any ODBC data source 

❍ Hyperion System 9 BI+ Production Reporting–for high volume, enterprise-wide 
production reporting 

❍ Hyperion System 9 BI+ Web Analysis–for interactive ad hoc analysis, presentation, 
and reporting of multidimensional data

● Hyperion System 9 BI+ Essbase Analytics and Hyperion System 9 BI+ Enterprise Analytics 
(collectively called Analytic Services)—providers powerful OLAP capabilities for high 
performance multidimensional reporting, analysis, and modeling 

Note: Studio refers to Java or Windows components that have a rich authoring environment. Workspace refers to 
Hyperion System 9 BI+ Workspace, the user thin client (UTC) or common user interface of the product.
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Preparing to Use Workspace
Prior to using Workspace, familiarize yourself with your documentation set. Table 1 lists each 
high-level task typically associated with deploying Workspace and reference guide for each 
task. For each task, reference documentation is available as specified in Table 4. 

Additional information that you need:

● Browser information– See the Hyperion System 9 BI + Installation Guide.

● Workspace URL and domain

● User account – the user name and password assigned to you. See your system administrator.

● Logon information – “Logging on to Workspace” on page 31

● Access Control – “Toolbars” on page 48

● Preferences – “Setting Preferences” on page 32

● Hyperion System 9 Shared Services user name and password

● Database information

For Financial Reporting, Adobe Acrobat Reader must be installed on your computer. Before 
you can view reports in PDF, a PDF writer (Adobe Acrobat Distiller, GNU Ghostscript or 
AFPL Ghostscript) must be installed with your print server. If a PDF viewer is not available, 
only report names are listed.

➤ To enable the use of Microsoft Internet Explorer (IE) for viewing PDF reports on Workspace:

1 Open Internet Explorer.

2 Select Tools > Internet Options.

3 In the Internet Options dialog box, select the General tab, and then in the Temporary Internet Files topic, 
select Settings.

4 In the Settings dialog box, in the Check for newer versions of stored pages topic, select Every visit to the 
page.

Note: Hyperion recommends that you add Workspace to the exceptions for your Web pop-up blocker. When you perform 
some Workspace tasks on the Web such as loading data, a status window pops up showing the task status. If you 
have a pop-up blocker enabled on your computer, the status window is not displayed. 

Note: The first time you access a database connection, you may be prompted to log on. This occurs if the user name and 
password you use to log on to the Web application differs from the user name and password for the database 
connection. Your administrator can provide you with the required database connection logon information.

For Internet Explorer, status information is displayed in the browsers status bar while 
interacting with Workspace. For Firefox, the status bar is disabled by default.

➤ To enable the status bar for Firefox for additional progress information:

1 Select Tools > Options.



14  Using Workspace 

2 Select Web Features.

3 Select Advanced. 

4 From the Advanced Javascript Options dialog box, select Change status bar text.

Workspace Documentation Set
Workspace guides, online help, and reference material are listed and described in Table 1. All 
getting started documents are available on the Download Center or product CD.

Table 1 Documentation Set 

Deliverable Description

Getting Started Documents

Hyperion System 9 Installation Start Here 
(Read First)

Lists high-level tasks for multiple-product installations

Enterprise Metrics, Financial Reporting, 
Interactive Reporting, Production 
Reporting, and Web Analysis readmes

Contain late-breaking information about BI+

Hyperion System 9 Shared Services User 
Management Guide

Describes how to set up and administer Hyperion users

Hyperion System 9 Shared Services 
Installation Guide 

Describes how to install and set up Hyperion License Server, install 
and configure the Hyperion Shared Services server, and set up 
external authentication providers for use with Hyperion products

Financial Reporting, Interactive Reporting, 
Production Reporting, and Web Analysis 
Installation Guide for Windows

Describes how to install Financial Reporting, Interactive Reporting, 
Production Reporting, and Web Analysis on Windows.

Financial Reporting, Interactive Reporting, 
Production Reporting, and Web Analysis 
Installation Guide for UNIX

Describes how to install Financial Reporting, Interactive Reporting, 
Production Reporting, and Web Analysis on UNIX

Enterprise Metrics Installation Guide Describes how to install Enterprise Metrics

Enterprise Metrics, Financial Reporting, 
Interactive Reporting, Production 
Reporting, and Web Analysis New Features

Describes new features available in Enterprise Metrics, Financial 
Reporting, Interactive Reporting, Production Reporting, and Web 
Analysis. Available on the Download Center or on the product CD.

Enterprise Metrics, Financial Reporting, 
Interactive Reporting, Production 
Reporting, and Web Analysis Transition 
Guide

Describes UI, feature, and functionality differences between prior 
releases and the current release

Enterprise Metrics, Financial Reporting, 
Interactive Reporting, Production 
Reporting, and Web Analysis Migration 
Guide

Describes how to use the Migration Utility

Hyperion System 9 BI+ Workspace Getting 
Started Guide

Helps new users use BI+
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Online Help

Hyperion System 9 BI+ Workspace User's 
Online Help

Describes how to use Workspace

Hyperion System 9 BI+ Workspace 
Administrator's Online Help

Describes how to administer Workspace, Enterprise Metrics, Financial 
Reporting, Interactive Reporting, Production Reporting, and Web 
Analysis

Financial Reporting Studio Online Help Describes how to create, view, and print reports in Financial 
Reporting Studio

Web Analysis Studio Online Help Describes how to create, view, and print reports in Web Analysis 
Studio

Web Analysis API Javadoc Describes the Web Analysis Java API

Interactive Reporting Studio Online Help Reviews the user interface and basic commands and explains how to 
retrieve data, query new data, query relational and multidimensional 
databases, and work with query results

Dashboard Studio Online Help Describes Dashboard Studio, the wizard-driven application builder 
that enables you to develop dashboards without programming, 
significantly reducing development and maintenance

Dashboard Architect Online Help Describes Dashboard Architect, an integrated development 
environment for Interactive Reporting Studio

Dashboard Studio Javadoc Describes the Dashboard Studio Java API

Interactive Reporting Web Client Online 
Help

Reviews the user interface and basic commands and explains how to 
retrieve data, query new data, query relational and multidimensional 
databases, and work with query results

Reference Material

Hyperion System 9 BI+ Workspace User's 
Guide

Describes how to use Workspace

Hyperion System 9 BI+ Workspace 
Administrator's Guide

Describes how to administer Enterprise Metrics, Financial Reporting, 
Interactive Reporting, Production Reporting, and Web Analysis

Financial Reporting Studio User's Guide Describes how to create, view, and print reports in Financial 
Reporting Studio

Web Analysis Studio User's Guide Describes how to create, view, and print reports in Web Analysis 
Studio

Interactive Reporting Studio User's Guide Reviews the user interface and basic commands and explains how to 
retrieve data, query new data, query relational and multidimensional 
databases, and work with query results

Table 1 Documentation Set (Continued)

Deliverable Description
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Deployment Workflow
Table 2 lists the high-level tasks typically associated with deploying Hyperion products and 
identifies the task deployment phases and references. For deployment-phrase information, see 
Hyperion Business Performance Management Deployment Guidelines.

Interactive Reporting Object Model and 
Dashboard Development Services 
Developer's Guide, Volume 1, Volume 2, 
Volume 3, Volume 4, Volume 5, and Volume 
6

Describes how to use Dashboard Development Services to create 
custom dashboards, use JavaScript to script and control Hyperion 
Intelligence client and Web client documents, and interpret and use 
Impact Reporting Object Mode to control dynamically an impact 
reporting document

Dashboard Component Reference Guide Provides information needed to configure and use plug-and-play 
Dashboard Development Services components (designed for 
dashboard developers responsible for creating, using, and extending 
the functionality of Dashboard Studio templates and dashboards)

Table 2 Deployment Workflow  

Deployment Phase Deployment Task Reference

Analyze Examine Hyperion Business 
Performance Management and how it 
impacts your deployment

Hyperion Business Performance 
Management Deployment Guidelines

Examine your domain and determine its 
impact on deployment

● Installation guide and checklist for 
your Hyperion product

● Third-party documentation

Plan ● Determine technical and business 
goals

● Develop checklist of deployment 
planning tasks

● Review system requirements

● Review system architecture

● Review data and metadata 
integration requirements

● Review requirements for third-party 
components

● Create a deployment timeline

● Create an infrastructure plan

● Create an integration plan

● Create a capacity and performance 
testing plan

● Hyperion Business Performance 
Management Deployment Guidelines

● For detailed, product-feature 
information, the product 
documentation set

Table 1 Documentation Set (Continued)

Deliverable Description
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Workspace
Workspace, the user thin client framework, features five modules:

Design Develop key performance drivers:

● Analyze product components and 
their impact on performance and 
scalability

● Determine how your company 
compares to a typical use case

● Determine application design and 
security suggestions

● Evaluate hardware decisions, 
performance impact, and scalability

● Hyperion Business Performance 
Management Deployment Guidelines

● Installation Guide and checklist

● Third-party documentation

● For detailed, product-feature 
information, the product 
documentation set

Build Develop an application that meets 
business, performance, and reporting 
needs and develop reports

● Hyperion Business Performance 
Management Deployment Guidelines

● Documentation set for your Hyperion 
product

Test Validate application and report design 
in a test environment:

● Perform tests on certain hardware, 
design, and user loads

● Verify test results against Key 
Performance Drivers

● Modify and update application and 
report design to achieve optimal 
performance

Hyperion Business Performance 
Management Deployment Guidelines

Rollout Create a plan to migrate applications 
and reports to a production 
environment

Documentation set for your Hyperion 
product

Review ● Post rollout review

● Ongoing performance and 
maintenance monitoring

● Future implementation phases

Documentation set for your Hyperion 
product

Change 
Management

● Define a process for handling 
changes related to your Business 
Performance Management solution

● Track and monitor change requests 
and implemented changes

Documentation set for your Hyperion 
product

Table 2 Deployment Workflow  (Continued)

Deployment Phase Deployment Task Reference
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● Viewer enables you to display many kinds of repository documents and Hyperion System 9 
Performance Scorecard and Enterprise Metrics documents. Documents are displayed in the 
content area. Explore enables you to list and navigate repository contents; manage and 
control files and folders; and use elements, like the Open dialog box, that present the 
repository as a file management system.

● Schedule enables you to manage jobs and schedule batches and events for automated 
processing.

● Administer enables you to manage users, user groups, user preferences, roles, and 
authentication methods.

● Impact Manager enables you to update Interactive Reporting documents when database 
structures, database connections, or links to external data sources change.

● Applications enables you to access Hyperion System 9 Financial Management and 
Hyperion System 9 Planning applications. Applications is only displayed when a user has 
rights and applications are available. See Hyperion System 9 BI + Workspace User’s Guide.

You can switch between modules in a work area without losing context. For example, use 
Viewer to view documents and Explore to view a list of repository files. For detailed 
information on the Workspace modules, see “Module Tasks” on page 24.
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Figure 1 Workspace - Author and Consumer Overview

Workspace can also be installed with the following thin client modules: Financial Reporting, 
Interactive Reporting, Production Reporting, Web Analysis, Enterprise Metrics, and 
Performance Scorecard. You use these additional modules to create documents and modify 
document elements. These installed components determine your available features. For 
example, the Web Analysis module must be installed to view Web Analysis documents. For 
information on tasks performed in these modules, see“Module Tasks” on page 24. 
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The main function of the repository is to store files. Every repository file features properties 
that identify the file and control user and user group access. Your access privileges, set by your 
system administrator, determine which repository items you can view, modify, run, and delete. 
See “Repository” on page 30.

Workspace Capabilities
Tasks with which Workspace assists you:

● Viewing documents, Enterprise Metrics reports, Performance Scorecard scorecards and 
maps, and dashboards

● Scheduling batches, jobs, or events to automatically execute reports or create notifications

● Create Web Analysis and Interactive Reporting documents, books, or batches

● Personalizing Workspace and thus manage information delivery by using a start page, 
personal pages, favorites, and a desktop folder

From Workspace, you use menus, buttons, and modules to perform tasks. Based on the 
following criteria, menus and toolbar buttons are updated as you use the system:

● The roles granted you by the administrator. Roles determine which modules are displayed 
in the view pane and toolbar.

● The module being used and the task being performed. For example, if you useViewer, the 
menu contains active-document tasks. If you use Explore, the menu contains file tasks.

Note: Generally, module buttons are displayed in the middle of the toolbar.

Modules Used to Perform Tasks
You use Workspace modules to perform user tasks:

● Viewer– view documents, scorecards, maps 
Explore– view, manage, and secure documents or document groups (called collections)

● Schedule– automatically run and manage documents, such as batches, jobs, and events

Note: The Administer and Impact Manager modules are used only by administrators. See the Hyperion System 9 BI+ 
Workspace Administrator’s Guide.

Accessing Modules
To access a module, perform an action:

● From the view pane, click the <module name>.

● From the menu, select Tools > < sub module name>.

● From the toolbar, select the <module name> button.

The variable <module name> is replaced by Viewer, Schedule, or Explore.
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Using View Pane Buttons
Module features are accessed by the buttons displayed on the top right of the view pane.

User Types and Tasks
Table 4 describes user types and tasks and lists references.

Table 3 View Pane Buttons 

Name Description

Navigate, 
Switch between modules

Document, 
Access current-document information 
or sections 

Note: Available only for certain 
modules; for example, used to display 
the user POV for Financial Reporting 
documents

Folder, 
Display repository folders from the 
view pane

Note: Available only for Explore 

Search, 
Display the Search dialog box, which is 
used to search for files and folders by 
character string and file type. The 
search is not case sensitive and starts 
in the folder specified in the Look in: 
text box and searches all sub-folders 
recursively.

Note: Available only for Explore

Tips, 
Access another button:

● Tasks—Displays a list of tasks 
relevant to the content pane

● Tips– Displays a list of Help topics

Note: Details– Displays a list of 
properties and details (available only 
when in Explore, desktop, search, or 
listing)
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Table 4 User Types and Tasks 

User Type Task Reference .

Author– Creates 
documents and 
conducts and 
distributes analysis to 
consumers

● Create, design, and edit documents

● Create books using Book Editor

● Use the Batch Scheduler and Batch Editor 
to create a batch

● Select Members

● Set preferences

● Import and export

● Change the database connection

● Create e-mail links

● Set up user and grid POVs

● Customize charts and grids

● Format reports

● Set browse preferences

● Subscribe to documents

● Import documents to the repository

● Run and schedule BQY jobs

● Run and schedule SQR jobs

● View job output

● Use SQR custom parameter forms

● Create BQYs

● Work with Query Options

● Encrypt documents

● Process queries

● Query

● Work with documents, tables and results

● Work with pivots, charts, OLAP data, 
reports, limits, variables, sorts, and 
computed items

● Create dashboard sections

For Hyperion Intelligence advanced users:

● Working with OCEs, connections, and data 
models

● Working with metatopics and metadata

● Managing document repositories

● Creating audit tables

● Registering and administering documents 
to IBM Information Catalog

● Running dbgprint

● Hyperion System 9 BI+ Workspace 
User’s Guide

● Hyperion System 9 BI+ Workspace 
Getting Started Guide

● Web Analysis Studio User’s Guide

● Financial Reporting Studio User’s 
Guide

● Hyperion System 9 BI+ Workspace 
Administrator’s Guide
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Consumer– Views and 
modifies limited 
content in a document

● Viewing reports, snapshot reports, books, 
and snapshot books

● Viewing scorecards and Accountability 
Strategy, and Cause and Effect maps

● Use Print, Web, and PDF Preview

● Respond to prompts

● Hyperion System 9 BI+ Workspace 
User’s Guide

● Hyperion System 9 BI+ Workspace 
Getting Started Guide

● Web Analysis Studio User’s Guide

● Financial Reporting Studio User’s 
Guide

Administrator–
configures and 
maintains Workspace 
and its supporting 
platforms and 
administers user 
provisioning and other 
administrative and 
system settings

● Change passwords

● File Permissions

● Register with Shared Services

● Maintain users, groups, and roles

● Create or modify printers or directories for 
job output

● Configure and modify system properties

● Create or modify a MIME type

● Create custom calendars

● Define database servers

● Configure, modify, and delete services

● Configure servlets

● Add hosts

● Hyperion System 9 BI+ Workspace 
Administrator’s Guide

● Web Analysis Studio User’s Guide

● Financial Reporting Studio User’s 
Guide

Table 4 User Types and Tasks (Continued)

User Type Task Reference .
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Module Tasks
Table 5 lists module tasks. The available tasks depend on the roles and permissions assigned to 
you by the system administrator. For information on roles, see the Hyperion System 9 Shared 
Services User Management Guide.

Installer– installs and 
deploys Hyperion 
products

● Install Workspace, default or custom

● Configure Workspace, automatically or 
manually

● Install diagnostics

● e-licensing

● Hyperion System 9 BI+ Workspace 
for Windows or UNIX Installation 
Guide

Developer– Uses 
Hyperion APIs or 
coding techniques 
(Javascript) to create 
custom solutions

● Use APIs

● Customize e-mail notifications

● Customize templates

● Understand JSPs

● Customize SmartCuts

● Integrate extended services

● Configure the architect environment

● Create projects

● Create BQYs

● Edit JavaScript Code in BQYs

● Edit using Find, Replace, Match Brace, 
Print, Auto-code, macros, and Import 
sections

● Test and debug code

● Use breakpoints

● Add and remove objects

● Resychronize to incorporate new objects

● Document code

● Update dashboard sections

● Hyperion System 9 BI+ Workspace 
Developer’s Guide

Table 4 User Types and Tasks (Continued)

User Type Task Reference .
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Table 5 Modules and Tasks 

Modules Permissions Granted by Roles Tasks

Web Analysis ● Access the Design 
Documents interface

● Create Web Analysis 
documents

● Open Web Analysis 
documents

● Save Web Analysis 
documents

● Create and manage 
database connections

● Send edited Analytic 
Services data values back 
to the database

● Lay out data, then specify 
and submit queries

● Define Point of View 
definitions for a database 
connection

● Define Personal Variables 
for a database connection

● Create links

Users assigned a role can log on to any client.

All roles:

● Access User Preferences

● Use Favorites Manager to access own 
Favorites folder

● Access presentations on own desktop

● Access own personal pages

● Print content that can be accessed

Viewer role: review Web Analysis documents

Explorer role: list and access repository content

Data Editor role: write data values back to 
Analytic Services

Personal Parameter role: define point of view 
and personal variables for database 
connections

Favorites Distributor role: distribute content to 
other users’ Favorites folders

Analyst role: lay out data and specify queries.

Content Publisher role: create and save Web 
Analysis documents

Data Source Publisher role: create and manage 
database connections

Report Designer role: access Design Documents 
interface

Content Manager role: create and manage all 
content

Production Reporting ● Content Publisher

● Explorer

● Scheduler

● Global Administrator

● Any Role

● Working with query options

● Encrypting documents

● Processing queries

● Querying
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Interactive Reporting ● Viewer

● Explorer

● Data Editor

● Favorites Distributor

● Interactive Reporting Viewer

● Dynamic Viewer

● Analyst

● Content Publisher

● Report Designer

● Data Source Publisher

● Content Manager

● BI+ Administrator

● BI+ Global Administrator

● Review static content

● List repository content

● Write data values back to Analytic Services

● Distribute content to Favorites folders

● Review and print static BQY content

● Review, re-query, and print static BQY 
content

● Review full interactive analytical content for 
Interactive Reporting, Web Analysis, and 
Financial Reporting

●  Edit queries

● Modify interactive WA, FR, EM and static IR, 
PR content and save back to the repository

● Create custom documents and use 
advanced Financial Reporting features

● Distribute connectivity files

● Create and manage all content

● Use conditional administrative access and 
functionality

● Use universal, unrestricted access and 
functionality

Table 5 Modules and Tasks (Continued)

Modules Permissions Granted by Roles Tasks
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Financial Reporting ● Any role

● Explorer

● Scheduler

● Content Publisher

● Report Designer

● Global Administrator

● Previewing report in HTML

● Previewing report in PDF

● Previewing current user POV settings for 
reports or books

● Setting Preview preferences

● Previewing in Web browsers

● Previewing printed reports from Report 
Designer

● Printing reports and books

● Using Batch Editor:

❍ Define batches

❍ Schedule batches to run

● Using Batch Scheduler:

❍ View scheduled batch status

❍ Open batches

❍ Schedule batches to run

❍ Delete batches

● Assigning or removing access to snapshots 
and snapshot books

● Setting up e-mail notifications

● Retrieving exported output

● Viewing scheduled batch status

● Preparing batch files for Command Line 
Scheduler

● Using Book Editor:

❍ Creating books

❍ Previewing and printing books and 
snapshot books

❍ Saving books and snapshot books

● Previewing books in HTML

● Previewing books in PDF

● Opening books or snapshot books

● Previewing and printing books and snapshot 
books

Table 5 Modules and Tasks (Continued)

Modules Permissions Granted by Roles Tasks



28  Using Workspace 

Workspace User Interface
When you log on, the default Workspace start page is displayed. Here you can open and work 
with Workspace elements.

Enterprise Metrics

Note: You can access 
Enterprise Metrics 
Personalization 
Workspace through the 
Tools menu. See the 
Hyperion System 9 BI+ 
Enterprise Metrics User’s 
Guide.

Metrics Viewer ● Monitor section

❍ Viewing the section

❍ Zooming in on section charts

❍ Using hyperlinks

❍ Viewing chart and mini report 
descriptions

● Investigate section

❍ Viewing the section

❍ Zooming in on charts

❍ Using chart hyperlinks

❍ Changing the point of view

❍ Sorting chart columns

❍ Using drill buttons

❍ Searching and using fast scroll

● Report section

❍ Viewing the section

❍ Using report hyperlinks

❍ Changing the point of view

❍ Sorting report information

❍ Viewing report descriptions

● Dictionary section

❍ Viewing the section

❍ Displaying chart information

❍ Displaying report information

❍ Using section links

Scorecard Studio ● User, as authorized

● Designer

● View employee scorecards

● View Accountability maps and scorecards 
for map elements 

● View Strategy maps and scorecards for map 
elements

● View Cause and Effect maps, associated 
perspectives, and strategy elements

Table 5 Modules and Tasks (Continued)

Modules Permissions Granted by Roles Tasks
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Table 6 Workspace Elements 

Number Name Description

1 Masthead Area that includes the Hyperion logo, product name, user name, identifies the current Hyperion 
product, and enables companies to customize and co-brand part of the user interface

2 Menu Bar Commands and sub-commands that organize tasks and modules (See “Menus” on page 54.)

3 Standard toolbar Buttons for performing tasks (See “Toolbars” on page 48.)

4 Module toolbar Buttons for accessing modules (See “Toolbars” on page 48.)

5 View pane Area that provides buttons that enable jumps between panels (each panel having a specific use and 
corresponding controls) and displays the list of documents and modules (Hiding this pane provides 
a larger content frame in which to use Workspace. Select View > View Pane to hide and display.)

6 ViewPane or 
Content Area 
Adjuster

Setting to adjust the size of the view pane and content area

7 Content area Area in which you view active-module documents, tasks, or files

8 Buttons Buttons for performing module tasks

9 Modules Names that you select to access module functionality; see “Workspace” on page 17.

1

2

7

8

6

9

11

3 34

5

10
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Repository
The repository is used to store, access, and share documents and files. You can access items 
such as documents, files, and folders in various ways, including browsing or searching for 
documents, subscribing to folders, and using dashboards. You make documents, files, and 
folders available to others by importing documents to the repository.

Documents show information and data in a predefined format. You can use jobs and batches to 
generate documents automatically. You can run jobs and batches at any time or schedule them 
to run automatically.

Note: Your file permissions determine which repository items you can view, modify, run, and delete.

Actions
● Documents, files, and folders can be opened in four formats:

❑ Interactive HTML

❑ Portable Document Format (PDF), displayed by Adobe Reader

❑ Text files

❑ Operation messages, which are generated by applications or services and stored in 
logs

● Interactive Reporting, Production Reporting, and Financial Reporting users can subscribe 
to documents. When the documents are changed or updated, the users are informed.

● Interactive Reporting, Production Reporting, and Financial Reporting users must import 
documents before the documents can be accessed by other users. Importing distributes 
previously private information for public consumption.

Locations
User preferences specify default startup options:

● The Content area can be Explore, documents, repository locations, or Enterprise Metrics or 
Scorecard documents. Startup options are loaded and displayed when users log on to 
Workspace.

10 Process bar Location of the current folder, document, or step (The orange end of the bar indicates the current 
Workspace module.)

11 Document tab bar Information bar specific to the current module (If multiple documents are open, the current 
document tab is highlighted.)

Table 6 Workspace Elements (Continued)

Number Name Description
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● The Desktop folder, the content of which is displayed in the user interface, contains 
frequently sought repository content. 

● A Favorites folder contains a user’s most frequently sought repository content. All user 
profiles feature Favorites folders, the files of which are accessed through the Favorites menu. 
Favorites Publisher can push content to users’ Favorites folders, providing one access point 
for certain content.

File Permissions
Workspace file permissions determine who has access to what files or folders and what 
operations can be performed. You obtain access items as a user, as a group member, or through 
a role given you by the system administrator. For information on roles, see the Hyperion System 
9 BI+ Workspace Administrator’s Guide. The level at which you can access items and perform 
tasks is called access privilege.

Access to specific repository items is controlled by the document owner. Access to operations, 
such as importing, running jobs, or updating document POV, is controlled through roles. For 
example, the owner gives you the modify and run access privilege to Job A, but you can run the 
job only if you have the Job Runner role. The owner gives you the full control access privilege 
to Document B, so you can open and update the file. For information on setting file 
permissions, see the Hyperion System 9 BI + Workspace User’s Guide.

When you import a file, you become the file owner, and you specify the access level of other 
users. You might specify that all users can read the file, your group can modify the file, and only 
you can delete, change access for, and move the file. 

Logging on to Workspace
You can access Workspace in two ways: through a URL provided by your administrator and 
through a Hyperion application link.

Note: Access through Hyperion application links requires that single sign-on be enabled.

➤ To start a Workspace session:

1 In your Web browser, go to Workspace Web page.

2 Enter user name and password.

Tip: The user name and password are case sensitive.

3 Click Log On.

Your start page is displayed. For more information on setting your start page, see the Hyperion 
System 9 BI + Workspace User’s Guide.
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Setting Preferences
As a designer, you can set defaults for the general appearance of Workspace user interface, 
Explore, studios, and authentication for changing user passwords. Default startup options can 
be set for the view pane and content area. Some settings can be overridden through menu 
options. For example, from Preferences, you set not to show the masthead, and then, from the 
View menu, you select to display the masthead. See the Hyperion System 9 BI+ Workspace 
User’s Guide.

Note: Your e-mail address, which you cannot update, defaults to the e-mail address registered in your user security 
settings.

Using Data Source Elements
Data sources (generic data storage mechanisms) can be multidimensional databases, relational 
databases, or files. Database connections, portable files stored in the repository, define the 
terms, conditions, and methods for connecting to data sources. In Workspace, you cannot 
create or modify database connections; rather, you must use the applicable studio. You see only 
database connections that you own and to which you are granted permissions. Multiple 
permissions are needed to read, write, edit, and change database-connection file properties. 
For permission descriptions, see the Hyperion System 9 BI + Administrator’s Guide.

Database servers typically use server, application, and database names to create unique 
identifiers. Such identifiers make database references not readily portable. The studios use 
database aliases, instead of long identifiers. Aliases are easier to remember and more 
economical to employ and enable a database to be maintained on multiple servers.
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Repository documents are dependent on a database-connection file to query data sources for 
values. A document can use only one database connection but can use any of several data 
sources.

Table 7 Supported Data Sources and Relational Databases by Studios 

Web Analysis 
Studio

Interactive 
Reporting 
Studio

Financial 
Reporting 
Studio

Production 
Reporting 
Studio

Data Source

Analytic Services x x x x

IBM DB2 OLAP 
Server

x x x

MS Analysis 
Server

x x

SAP BW x x x x

SAP R3 x

Financial 
Management

x x

Planning x x

Relational Database Connection

IBM DB2 x x x

Microsoft SQL 
Server

x x x

Oracle x x x

Teradata x x x

Informix x x x

Sybase x x x

Sybase IQ x Note:  
Supported by 
Production 
Reporting, not 
by Production 
Reporting 
Studio

Red Brick x x

XML x

ODBC(DB2, SQL 
Server, Oracle, 
Informix, 
Sybase)

x x
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● Different data sources have different system requirements. See the Hyperion System 9 BI+ 
Financial Reporting, Interactive Reporting, Production Reporting and Web Analysis 
Installation Guide for Windows or UNIX for descriptions of system requirements.

● The view pane Information tab displays the database connection used by the current data 
object. The tab features two database connection segments for Web Analysis:

● The Database segment displays the database connection name for the current data object.

● The Database User Name segment displays the user name by which access to the database 
connection was granted.

Web Analysis Studio
Web Analysis Studio users can construct seamless liaisons between OLAP data and relational 
data sources. Navigation from OLAP to relational data is typically called relational drill-
through.

After relational drill-through is configured, users can navigate to level 0 (the bottom) of the 
OLAP database and drill down to relational data. Relational drill-through, a client-based 
integration solution, is comparable to the server-based Analytic Integration Services drill-
through.

Relational drill-through supports an array of JDBC relational data sources but does not 
support queries by level, generation, or previously selected member. Relational drill-through 
definitions are saved as a property of the database-connection file.

Financial Reporting Studio
For Financial Reporting Studio, you must be defined as a user, with a user name and password, 
in the data source that your document uses. For example, if you want to view documents that 
use Analytic Services, you must log on to the database connections with a user account defined 
in Analytic Services. Logging on usually occurs automatically. However, if you are not 
registered in the database, you are prompted for logon credentials.

JDBC (DB2, SQL 
Server, Oracle, 
Informix, 
Sybase)

x

MySQL x

Table 7 Supported Data Sources and Relational Databases by Studios (Continued)

Web Analysis 
Studio

Interactive 
Reporting 
Studio

Financial 
Reporting 
Studio

Production 
Reporting 
Studio
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Interactive Reporting Studio
Interactive Reporting documents can contain multiple Query sections, each of which can 
access a range of data sources (relational databases, OLAP servers, imported data sets, and local 
joins). Each section can reference zero (if using only local joins) or one database-connection 
file. The file can reference only one data source. When a query section associated with a 
relational-database connection or using only local joins is processed, a corresponding Results 
section is produced. If the database-connection file is associated with a multidimensional 
database connection, results are shown in the Query section.

Production Reporting Studio
With Production Reporting Studio, users can easily develop a range of reports, from small ad 
hoc reports to mission-critical operational reports. Various data sources can be used; for 
example, relational databases, OLAP servers, and transactional systems.

After you create a data source connection, you can use the Production Reporting Studio 
wizard, layout editor, and explorers to design and customize enterprise reports. You can also 
insert and update database tables to incorporate data transformations into report processing.

Whether you are creating budgets, building exception reports, producing invoices from 
millions of records, or distributing Web-based reports to help end-users make quick, effective 
decisions, Production Reporting manages the secure delivery of content across the enterprise.

Analytic Services Features Available to the Studios
Analytic Services integrates data from multiple sources, meets user needs across an enterprise, 
adds value to previously inaccessible data, and transforms data into actionable information.

Analytic Services features available to studios:

● Data restriction

● Top and bottom only retrieval

● Data edits

● Suppression of rows that contain #MISSING values, zero values, and shared members

● Label mode and alias tables

● Drill settings specific to Analytic Services

● Linked reporting objects

● Relational drill-through

● Analytic Integration Services drill-through

● Advanced member selection

● Attribute dimensions and attribute calculations

For feature details, see the Hyperion System 9 BI + Workspace User’s Guide.
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Financial Management Features Available to the Studios
Hyperion System 9 Financial Management is a centralized, scalable, financial management and 
reporting solution. Financial Management features that are extended through Workspace:

● Organization by period 

● Advanced member selection specific to Financial Management

● Cell text – related content 

● Line item, detail-related content

● Advanced member selection

● User–defined fields

● Entity currency display

For Financial Management convention and feature information, see the Hyperion System 9 BI 
+ Workspace User’s Guide.

Planning Details as a Database Connection
After you install the Planning Details ADM driver, you can choose Planning Details as a 
database connection for Financial Reporting Studio. The Planning Details ADM driver is 
optimized as a data source to provide Hyperion System 9 Planning features such as supporting 
details, planning unit annotations, and metadata filtering. If your report grid does not use 
Planning features, for optimal performance, choose Analytic Services as the database 
connection. See the Hyperion System 9 BI+ Financial Reporting Studio User’s Guide.

SAP BW Data Sources
You can use the studios to access SAP BW data sources. Using the custom-report, free–form 
grid component, you can present OLAP, relational, and manually entered data on a data object 
and leverage all data sources in integrated dynamic calculations. The studios offer visually 
compelling SAP BW reports that satisfy the presentation, reporting and distribution 
requirements of information consumers.

SAP BW Prerequisites
To access SAP BW data sources, you must install the SAP BW client on the server. After 
installation, you must define the SAP Logon parameters used to communicate with the SAP 
data source.

SAP BW Conventions
SAP data sources differ from other data sources. For example, level 0 is the highest ancestor in 
SAP and the lowest descendant in Analytic Services. SAP member properties are analogous to 
Analytic Services attribute dimensions.
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SAP InfoProviders supported by BI+:

● InfoCubes

● ODS objects

● InfoSets

● BEx query cubes

● Multiproviders

SAP BW offers a smaller set of advanced member selection methods than does Analytic 
Services. 

SAP BW features:

● Variables

● Period-to-date values

● Top and bottom retrieval

● Member properties

● Searches for SAP BW characteristic values

● Currency conversion

● Unit of measure conversion

See the Hyperion System 9 BI + Workspace User’s Guide.

Relational Access Methods
Some documents, such as Web Analysis documents, can access OLAP, Hyperion, and 
supported relational databases.

 Methods for accessing relational data from Web Analysis:

● Custom document SQL spreadsheet 

● Custom document free-form grid 

● Relational drill-through

● Relational database connection

● Analytic Integration Services drill-through

● Repository

For feature information, see the Hyperion System 9 BI + Workspace User’s Guide.

Controlling the Size of the Query Result Set
Query governors vary for relational access methods. Custom document SQL spreadsheets and 
relational drill-through methods enable users to declare query governors as they create SQL 
queries or relational drill-through definitions.
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When you drill from OLAP to relational data, passing only the drilled OLAP dimension 
member to the relational data source may result in a large query result set. To reduce and 
simplify the query result set, you can pass the page and filter dimensions specified in the OLAP 
document.

In Interactive Reporting documents, Query section properties can govern the number of rows 
returned from relational data sources and impose time limits on queries. Users can cancel 
queries through the keyboard in some cases.

Starting Tasks
Most tasks in Workspace start the same way.

Note: The following procedure describes how to use modules to perform tasks. Tasks can also be performed using the 
toolbar, menus, and shortcut menus. For a list of all toolbars, menus, and shortcut menus, see “Toolbars” on 
page 48.

➤ To begin a task:

1 From the view pane, select a module and then a button or item.

● The view pane displays module information such as, depending on the module, a list of 
folders or document sections. The Content pane displays information that corresponds to 
the view pane, such as a file list or document content. 

2 Perform one of three actions:

● If the content area displays a document, change the POV or view a section. 

In the following example, you can change the POV: 

Figure 2 View module showing sample Financial Reporting document.
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● If the content area displays a list, locate and double-click the item with which you want to 
work.

Figure 3 Explore showing a list of files in the repository

● If a dialog box is displayed in the content area, view or modify the information.

Creating Documents
With Workspace, you can use the new document wizard to create a Web Analysis or Interactive 
Reporting document, Financial Reporting book or batch.

➤ To create a Web Analysis or Interactive Reporting document, or a Financial Reporting book or 
batch:

1 Select File > New Document.

Step 1: Select a Task, of the new document wizard is displayed.

2 Select an option:

● Create a document

● Collect reports into a book

● Batch reports for scheduling

See the Hyperion System 9 BI+ Workspace User’s Guide. 
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Selecting a Data Source for a Document
To create a document, you must specify a data source. The data source determines the 
document type.

● To create a Web Analysis document, specify a Web Analysis database connection.

● To create an Interactive Reporting document based on an existing document, specify the 
existing document.

See the Hyperion System 9 BI+ Workspace User’s Guide. 

Note: In the following procedures, <module name> is Viewer, Explore, or Schedule.

Accessing Modules

➤ To access a module, perform an action:

● From the view pane, click the <module name> button.

● In a module, click , and then click the <module name> button.

● From the menubar, select Tools > < module name>.

● From the toolbar, click the <module name> button.

Opening and Printing Documents or URLs

➤ To open a document:

1 Select File > Open > Document.

The Open dialog box is displayed.

2 Select the document.

The list of open documents is displayed in the view pane and in tabs at the bottom of the 
document in the content area. You can toggle between open documents.

➤ To open a URL:

1 Select File > Open > URL.

The URL dialog is displayed.

2 Enter the URL name.

3 Select Ok.

➤ To print a document:

Note: This procedure applies only to Financial Reporting, Web Analysis, or Production Reporting documents.
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1 From the view pane, select Explore.

2 Open a document, for example, a Financial Reporting document.

Note: You may need to open the document as HTML or PDF.

3 Select File > Print > HTML or File > Print > PDF.

Setting File Properties and Moving Files

➤ To set file properties:

1 From Explore, select a document.

2 Select File > Properties.

The Properties Dialog is displayed. The General Properties option is selected by default.

You can modify the file name and description and set user permissions (select Edit 
Permissions). See the Hyperion System 9 BI+ Workspace User’s Guide.

➤ To move files or folders in Explore:

1 From Explore, select a document or folder.

2 Select Edit > Cut.

3 Select a repository location, and select Edit > Paste.

Renaming Files

➤ To rename files:

1 From Explore, select a document or folder.

2 Select Edit > Rename.

The Rename dialog is displayed.

3 Enter a name.

4 Select Save.

Adding and Removing Documents from Favorites

➤ To add a document or folder to favorites:

1 From Explore, select a document or folder.

2 Select Favorites > Add to Favorites.
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3 Select Favorites.

The document or folder that you added is displayed as a menu option.

➤ To remove a document or folder from Favorites:

1 Select Favorites > Manage Favorites.

The Favorites Manager dialog box is displayed.

2 Clear Show, or select Remove.

➤ To create a shortcut to a Production Reporting document:

1 From Explore, select the document.

2 Right-click the document, and select Create Shortcut.

3 Complete the General Properties dialog box, and select OK

For instructions, see the Hyperion System 9 BI +Workspace User’s Guide.

Using Explore
In Explore, you organize, search for, or assign access privileges to files. When you select 
Explore, the view pane shows folders, and the content pane shows files and folders. The 
following figure shows the Explore page and an example of the options available for Financial 
Reporting documents.

Note: To display additional options, the highlighted document was selected along with the right-click option.
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Explore features:

● Folder tree—Navigate through Workspace folders 

● View File Properties—View file information, such as type, author, creation date, access 
control, modified date, and description

● Search—Search for files and folders by character string and file type

Using Schedule
Use Schedule to manage and schedule batches, jobs, and events and to view status. Schedule is 
primarily used by Financial Reporting, Interactive Reporting, and Production Reporting. The 
following Batch Scheduler example is used by Financial Reporting.

Schedule features:

● Batch Scheduler

● Manage Jobs

● View Job Status

● Manage Events

● Consolidated Job Status

See “Scheduling Jobs and Batches” in the Hyperion System 9 BI+ Workspace User’s Guide.
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Using Viewer
Viewer displays many types of documents and maintains a list of opened documents, so you 
can quickly switch between documents.

Viewer features:

● View pane—Use buttons along the top to jump between panels

● View pane list—Select a desktop or document to access

● Content area—View, interact with, and modify documents

● Content area tab bar—View the names of the contents of the open document

Using Hyperion System 9 Smart View for Office
Smart View provides a common Microsoft Office interface for Analytic Services, Financial 
Management, Planning, and four Workspace components:

● Financial Reporting

● Production Reporting

● Web Analysis

● Interactive Reporting (Smart View export options not enabled)

The centralized interface enables simultaneous use of multiple Hyperion products and 
improves integration with Microsoft Office (2000, 2002, and 2003). The Smart View 
implementation provides the following Workspace functionality:
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● Exports the current page of the current data object to Excel, Word, or PowerPoint

● Exposes Financial Management and Analytic Services functions in Excel, Word, and 
PowerPoint content

● Notifies you when you can upgrade to new releases of Smart View

Smart View enables two export options:

● You can export the current page of the current data object to Word, PowerPoint, or Excel as 
an image, and, later, re-query the Web application to refresh the image.

● You can export documents to Excel as query-ready or formatted HTML.

When you export content as query-ready HTML, the current page of the current data object is 
converted to HTML, and Hyperion-specific formatting is removed. Thus, Smart View can re-
query the data source independent of the Web application.

When you export content as formatted HTML, the current page of the current data object is 
converted to HTML, and Hyperion formatting definitions and calculated members are 
retained. Thus, Smart View cannot directly query the data source, but Hyperion content can be 
leveraged by Microsoft Office applications. Not all export options are supported by all data 
sources and Web applications. See the Hyperion System 9 BI + Workspace User’s Guide.

Personalizing Workspace
You can use Workspace desktop, favorites, and personal pages to personalize the process of 
organizing, accessing, and viewing documents. See the Hyperion System 9 BI + Workspace 
User’s Guide.

Using the Desktop
You set up desktop folders in user preferences, where desktop items are displayed as buttons. 
You can view desktop folders in Explore; however, desktop folders and documents are listed 
without the name Desktop. You access the desktop in Viewer, where desktop items are displayed 
as icons. For desktop set-up instructions, see the Hyperion System 9 BI + Workspace User’s 
Guide.

Subscribing to Documents
When documents are changed or updated, subscribing users can be informed: 

● By e-mail notifications with attached files

● By bookmarked personal pages

● By images that represent bookmarks
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Figure 4 Subscribe Dialog Box

For information on Subscribe, see the Hyperion System 9 BI + Workspace User’s Guide.

Working with Favorites
Favorites provide quick access to frequently used items and documents. With appropriate 
access privileges and permissions, you can add items (push items) to other users’ favorites.

Using Personal Pages
Personal pages provide a way to view frequently used information. You can have multiple 
personal pages and can choose a default personal page, which is displayed when you start the 
Personal Pages module. You can customize personal page content and layout, create personal 
pages, and copy and customize imported personal pages. 

The following figure shows the types of content that can be displayed on personal pages. A 
personal page can have some or all of these types.
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Personal page features:

● Broadcast Messages—A link to a folder, the contents of which are set up and managed by 
the administrator. Folder contents are displayed as one or more content windows, which are 
displayed to every user. The Broadcast Messages folder contains two sub-folders:

❍ Personal Page Content —published personal pages

❍ Sample Personal Page—content set up by the administrator and content added by 
subscription

● My Bookmarks—Links to Web pages or repository items.

● Image bookmarks—Graphic links to Web pages or repository items. 

● HTML file or job output displayed as a file content window—Workspace HTML items and 
URLs

● Exceptions Dashboard—Traffic light indicators. If the traffic light is red, the item is flagged 
as an exception or the job generated an exception. If the traffic light is green, the job did not 
generate an exception.

● Displayable Q&R sections—Sections from Q&R documents and job output that you can 
access. 

For details on the following tasks, see the Hyperion System 9 BI + Workspace User’s Guide:

● Adding personal page contents

● Modifying personal page layout

● Changing personal page colors

● Displaying HTML content on personal pages

● Creating bookmarks

● Using exception notifications

● Embedding Interactive Reporting document sections in personal pages
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Toolbars
Toolbars provide quick, context-sensitive access to commonly used features. Button availability 
is determined by the content-area module.

Note: Your role determines which toolbars, menus, shortcut menus, and modules are displayed on the user interface. 
For example, if your role enables you to create documents, the toolbar menu item File > New is displayed.

Table 8 Standard Toolbar Buttons  

Button Menu Command Description

File > New Document Create documents, such as books, batches, analysis documents, and 
scheduled batch jobs

File > Open Select, open, and use repository documents

File > Logoff End the current session

Tools > Viewer > Desktop Display the desktop in the content area

NA Displays the default startup option for content area

View > Masthead Display or hide the masthead

View > view pane Display or hide the view pane, while resizing the content area

Tools > Viewer Display Viewer, used to review query, reporting, analysis, KPI, and 
scorecard content

Help > Help on This Topic Displays help for the page displayed in the content area

Tools > Schedule Display Schedule, used to define and schedule events, jobs, and 
batches

Tools > Explore Display Explore, to display the repository as a file management 
system

Tools > Administer Display Administer, used to define users, groups, roles, and 
preferences

Tools > Impact Manager Display Impact Manager, used to modify and update groups of 
documents
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Viewer, Web Analysis Toolbar
The Viewer, Web Analysis toolbar displays standard buttons and buttons specific to it.

Viewer, Financial Reporting Toolbar
The Viewer, Financial Reporting toolbar displays standard buttons and buttons specific to it.

Viewer, Book Editor Toolbar
The Viewer, Book Editor toolbar displays standard buttons and buttons specific to it.

Table 9 Viewer, Web Analysis Toolbar Buttons  

Button Menu Command Description

View > Data Layout Display the Data Layout dialog box, used to redefine queries and 
dimension member selections

View > Filters Show and hide the Filter area, which indicates filter member 
selections

View > Pages Show and hide the Page Control area, which indicates the number of 
pages for the current data object and the current page

File > Save Save documents to the repository

File > Save As Save documents to the repository under new names or to new 
locations

File > Print HTML Display the browser Print dialog box, used to define print parameters 
and options

View > Refresh Update the document display

Table 10 Viewer, Financial Reporting Toolbar Buttons  

Button Menu Command Description

File > Open in > PDF 
Preview

Open documents in the browser in PDF

File > Open in > HTML 
Preview

Open documents in the browser as HTML
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Viewer, Batch Editor Toolbar
The Viewer, Batch Editor toolbar displays standard buttons and buttons specific to it.

Viewer, Interactive Reporting Toolbar
The Viewer, Interactive Reporting toolbar displays standard buttons and buttons specific to it.

Table 11 Viewer, Book Editor Toolbar Buttons  

Button Menu Command Description

Edit > Add Report or 
Snapshot

Add reports and snapshots to books

Edit > Delete Remove reports and snapshots from books

Edit > Member Selection Open the member selection dialog box

Edit > Move Up Move reports or snapshots up in the list

Edit > Move Down Move reports or snapshots down in the list

Table 12 Viewer, Batch Editor Toolbar Buttons  

Button Menu Command Description

Edit > Add Item(s) Adds reports, snapshots, books, or snapshot books to batches

Edit > Delete Removes reports and snapshots from batches

Edit > Member Selection Opens the member selection dialog box

Edit > Schedule Batch Opens the Schedule Batch dialog box
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Table 13 Viewer, Interactive Reporting Toolbar Buttons  

Button Description

Displays the Dashboard Home section. Dashboard sections are 
streamlined, push button approaches to viewing business intelligence 
reports.

Moves to the first page of the section.

Moves one view left in Chart and Pivot sections. To move to the first 
view on the left, select [Shift] + Click + left arrow.

Moves one view up in Chart and Pivot sections and one page up in 
Results, Table, and Report sections. To move to the top view or page, 
select [Shift] + Click + Up. 

Moves one view down in Chart and Pivot sections and one page down 
in Results, Table, and Report sections. To move to the bottom view or 
page, select [Shift] + Click + Down arrow.

Moves one view right in Chart and Pivot sections. To move to the first 
view on the right, select [Shift] + Click + right arrow. 

Refreshes the current section against the database server to 
dynamically retrieve the most current data set (except for Dashboard 
and Report sections). When Refresh is selected in Dashboard and 
Report sections, all queries are refreshed. Queries are refreshed in 
the order in which they are displayed in the section catalog of the full 
client. For example, in a document with three queries, Query1, 
Query2, and Query3, queries are executed in numeric order when 
Refresh All is selected. You must have at least View access privilege 
on the Interactive Reporting database connections with which you are 
working to use Refresh.

Exports a section to Portable Document Format (PDF) and launches it 
inside your browser if the PDF MIME type is set in the browser. If the 
PDF MIME type is not set in the browser, the browser Save As dialog 
box is invoked. 

Exports a section to Excel and launches it inside your browser if the 
mime type is set to recognize the XLS file extension. Thereafter, you 
save the file locally or manipulate the file in the Excel application. If 
the mime type is not set to recognize the XLS file extension, you are 
prompted with a Save As dialog box and must specify a local 
destination to which to save the XLS file. 

Tip: Saves files locally and launches documents in the Interactive 
Reporting Web client so you can view and save the documents to your 
desktop for offline viewing. Documents can be viewed only in the full 
desktop or the Web client. If the Web client is not installed, the browser is 
launched automatically.

Tip: If you want to save to the repository, use the File >Save or File >Save 
As command.
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Viewer, Performance Scorecard Toolbar
The Viewer, Performance Scorecard toolbar displays standard buttons and buttons specific to 
it. 

Batch Scheduler Toolbar
The Batch Scheduler toolbar displays standard buttons and buttons specific to it.

Explore Toolbar
The Explore toolbar displays standard buttons and buttons specific to it.

Table 14 Viewer - Performance Scorecard Toolbar Buttons 

Button Menu Command Description

File > Print Print scorecards or maps to a designated printer

File > Export to Microsoft 
Excel

Export scorecards for employees or measures to an Excel worksheet

Tools > Link > 
Performance Scorecard

Launch the Performance Scorecard application to access additional 
functionality, such as data entry, measure scorecard details, and 
object creation

Table 15 Batch Scheduler Toolbar Buttons  

Button Menu Command Description

File > New Scheduled 
Batch

Opens the Schedule Batch dialog box

Edit > Properties Displays the details for scheduled batches; for example, the time for 
which a batch is scheduled

Edit > Delete Deletes scheduled batches

View > Refresh Updates the desktop with changes to scheduled batches

Action > Retrieve Output Retrieves results for the latest batch job

Action > Show Details Displays batch details; for example name, start time, and destination
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Administer Toolbar
The Administer toolbar displays standard buttons and buttons specific to it.

Table 16 Explore Toolbar Buttons  

Button Menu Command Description

File > New Folder Creates folders

NA Navigates up to the repository location that contains the current 
folder

File > Search Displays the Search dialog box, used to search for files and folders by 
character string and file type

Edit > Cut Marks repository files to be moved

File > Properties Open the Properties dialog box, used to set file properties; for 
example, file permissions

Edit > Paste Pastes files to the current repository location

Table 17 Administer Module Toolbar Buttons 

Button
Manage Menu 
Command Description

General Define general system and user interface properties

User Management  Provision users, groups, and roles

Physical Resources Specify printers and output directories for job output

MIME Types Create, modify, and delete Workspace MIME types

Notifications Define mail server properties and how end users receive e-mail 
notifications about jobs

SmartCuts Specify how to construct SmartCuts (shortcuts to imported 
documents in Workspace) for inclusion in e-mail notifications
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Production Reporting Toolbar Buttons
When you view Production Reporting documents in Workspace, you see no buttons in the 
toolbar area. However, you see the navigation bar, which provides options for navigating 
among HTML-report pages and for viewing reports in multiple output formats. The 
navigation buttons are dynamic, based on job output. For button descriptions, see the 
Hyperion System 9 BI + Workspace User’s Guide.

Menus
● From Workspace, the standard menus are File, View, Favorites, Tools, and Help. Action 

and Format menus are displayed for some modules. A Manage menu is displayed for 
Administer.

● Menus and buttons in the masthead are updated as you use the system, based on the 
following criteria:

● The roles granted to you. Role determines which modules are displayed in the view pane.

● The module being used and the task being performed. For example, if you use Viewer, the 
menu contains active-document tasks. If you use Explore, the menu contain file or folder 
tasks.

File Menu
The File menu is available for all Workspace modules. Option availability depends on the 
content of the current window and the module from which the menu is accessed.

Row-Level Security Manage row-level security settings in data sources used by Interactive 
Reporting documents

Usage Tracking Track system usage and define related properties

Event Tracking Track events, such as document opens, documents closes for 
selected MIME types, and jobs run

Table 17 Administer Module Toolbar Buttons (Continued)

Button
Manage Menu 
Command Description
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Table 18 File Menu  

Command Description

New Document Create documents, such as books, batches, or analysis documents.

Open

> Document

> Desktop

> Scorecards

> Enterprise 
Metrics

Select, open, and use repository documents

Open in >PDF 
Preview

For Financial Reporting, open your PDF reader and display the report

Open in > HTML 
Preview

For Financial Reporting, open your Web browser and display the report as HTML

Open in > New 
Window

Open documents in separate windows

Close All Close all open documents

Save Save changes, overwriting the current document

Save As Saves documents to the repository under new names or to new locations

Print > PDF or 
HTML

From Financial Reporting, open reports in PDF or HTML for printing

Print PDF For Financial Reporting, Web Analysis, and Interactive Reporting, open reports in PDF for printing

Print HTML For Financial Reporting, Web Analysis, and Interactive Reporting, open reports in HTML for 
printing

Print For Performance Scorecard, print scorecards or maps displayed in the Contents pane

Export to Excel For Performance Scorecard, export maps or employee scorecards to Excel worksheets

Export Map For Performance Scorecard, if a Cause and Effect map is being viewed, export an image of the 
maps

Import

> File

> URL

> File as Job

> Financial 
Reports

Open the Import dialog box, used to import documents, URLs, files, files as jobs, and financial 
reports to Hyperion System 9

Export Open the Export dialog box, used to export native file formats in XML, Excel as fully formatted or 
query-ready grid and text, Word, or PowerPoint

Properties Open the Properties dialog box, used to set file properties; for example, file permissions

E-mail Link Send URL links of objects or folders by e-mail

Subscribe Inform subscribing users when documents are changed or updated
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Edit Menu
The Edit menu is available for all Workspace modules. Option availability depends on the 
content of the current window and the module from which the menu is accessed.

Run Job For Interactive Reporting jobs, set job parameters and run jobs

Print Opens the browser Print dialog box, used to specify printers and print reports

Page Setup For Financial Reporting, opens the Page Setup dialog box, used to specify page size, page 
margins, and workspace size

Print Preview For Financial Reporting, view reports as they look printed

Preferences Opens the Preferences dialog box, used to change your password (using native authentication) 
and e-mail address and set the default for opening snapshots (PDF Preview or HTML Preview)

For Financial Reporting, you can also change your language selection and enable XBRL editing.

Logoff End the session

Exit Exit Workspace

Table 19 Edit Menu  

Command Description

Cut Removes objects from the repository

Paste Pastes objects from the repository

Delete From Explore, deletes repository files or folders; from Book Editor or Batch Editor in Financial 
Reporting, removes reports and snapshots from books

Rename Changes name of file or folders

Move Up From Book Editor for Financial Reporting, moves reports or snapshots up in the list

Move Down From Book Editor for Financial Reporting, moves reports or snapshots down in the list

Add Items From Batch Editor and Book Editor for Financial Reporting, adds documents to batches or books

Member 
Selection

From Book Editor or Batch Editor for Financial Reporting, opens the member selection dialog 
box

Display 
Members in 
Table of 
Contents

From Book Editor in Workspace, displays members in the tables of contents of books

Copy Member 
Selection to

From Book Editor for Financial Reporting, copies members from one document to another

Schedule Batch From Batch Editor for Financial Reporting, opens the Schedule Batch dialog box

Table 18 File Menu  (Continued)

Command Description
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View Menu
The availability of View menu options depends on the content of the current window and the 
module from which the menu is accessed.

Favorites Menu
Use the Favorites menu to set up personal pages and favorites and to select from a list of 
favorite documents.

Section > Delete For Financial Reporting and Web Analysis documents, deletes sections

Section > 
Rename

For Financial Reporting and Web Analysis documents, changes the document name

Section > 
Duplicate

For Financial Reporting and Web Analysis documents, duplicates documents by saving them 
with a different name

Data For Web Analysis documents only

Table 20 View Menu  

Command Description

Masthead Show or hide the masthead

View pane Show or hide the view pane

Filters and POV Display or disable filters and POV options for Web Analysis documents

Pages For Web Analysis documents, maintain the dimensions on the row and column axes while 
changing their intersections on the Page axis

Display Items of Type In the repository, limit document lists by type

Show Columns Display the Show Columns dialog box, used to select and deselect columns for displaying

Show Hidden Display hidden files

Refresh Refresh the repository

Table 21 Favorites Menu  

Command Description

Add to Favorites Adds the selected document from the repository to Favorites list. Displays only when the 
current tab can be added to the favorites--when the current view is either repository 
content or Explorer.

Manage Favorites Opens the Favorites Manager dialog box

Table 19 Edit Menu  (Continued)

Command Description
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Actions Menu
The Actions menu is displayed in View mode for the following sections of BQY documents:

● Query–Table 22

● Results–Table 23

● Pivot–Table 24

● Chart–Table 25

● Table–Table 26

Scorecards

Enterprise Metrics

Displays in alphabetical order a list of favorite documents or folders defined by you or 
pushed to you

My Personal Page Opens your personal page

Table 22 Actions Menu - Query Section  

Command Description

Insert Insert Query, Results, Table, Pivot, or Chart sections. If Query, you can select a query to 
modify, or you can link to a distributed, predefined data master.

Add to Request Add Catalog List items to the Request pane

Add to Filter Add Catalog List items to the Filter pane

Modify Filter Modify Filter pane items (using the Filter dialog box)

Add to Sort Add Request pane items to the Sort pane, in ascending or descending order

Add Computed Item Use Request pane or Catalog list items to calculate data items (based on functions, data 
items, and operators in the Computed Items dialog box). Data items can be included in 
reports or used to calculate other data.

Add Data Function Aggregate and compute values for Request pane or Catalog list items. Data function 
computations include averages, maximums, counts, and other statistics that summarize 
data groups.

Table 23 Actions Menu - Results Section  

Command Description

Insert Insert Query, Table, Pivot or Chart sections. If 
Query, you can select a query to modify or link to 
a distributed, predefined data master. If Table, 
Pivot, or Chart, the data set is based on the 
current Results section

Sort Sort columns in ascending or descending order

Table 21 Favorites Menu  (Continued)

Command Description
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Filter Add or modify filters on columns

Auto-size column width Resize columns to content width

Grand Total Calculate column grand totals

Break Total Calculate break totals

Add/Modify Computed 
Item

Use columns to calculate data (based on 
functions, data items, and operators provided in 
the Computed Item dialog box). Computed items 
can be included in reports or used to calculate 
other data.

Delete Delete columns

Table 24 Actions Menu - Pivot Section 

Command Description

Insert Insert Query, Table, or Chart sections. If Query, 
you can select a query to modify or link to a 
distributed, predefined data master.

Drill Up Collapse the data view (see less detail)

Focus Update the pivot table to include only selected 
data

Hide Hide columns

Show Hidden Display hidden columns

Show All Update the pivot table to include all items

Group/Ungroup Group labels so that, when labels are combined, 
their associated data is aggregated, creating a 
summary label category. With grouping, only the 
data view changes. Use ungroup to return views 
to original label values.

Data Functions Aggregate and compute values for selected 
columns. Data function computations include 
averages, maximums, counts, and statistics that 
summarize data groups.

Add/Modify Computed 
Item

Use items to calculate data items (based on 
functions, data items, and operators in the 
Computed Items dialog box). Data items can be 
included in reports or used to calculate other 
data.

Add Totals Adds totals for columns, according to next higher 
dimension items.

Table 23 Actions Menu - Results Section  (Continued)

Command Description
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Delete Totals Delete column totals.

Use Surface Values Apply calculations to values displayed in the pivot 
table or to underlying values, rather than to 
values from the original Results section

Auto-size Column Width Resize columns to content width

Table 25 Actions Menu - Chart Section 

Command Description

Insert Insert Query, Table, or Chart sections. If Query, you 
can select a query to modify or link to a 
distributed, predefined data master.

Drill Up Collapse the data view (see less detail)

Focus Update tables to include only selected data

Hide Hide items

Show Hidden Display hidden items

Show All Update to include all items

Group/Ungroup Group labels so that, when labels are combined, 
their associated data is aggregated, creating a 
summary label category. With grouping, only the 
data view changes. Use ungroup to return views to 
original label values.

Data Functions Aggregate and compute item values. Data 
function computations include averages, 
maximums, counts, and statistics that summarize 
data groups.

Add/Modify Computed 
Item

Use items to calculate data items (based on 
functions, data items, and operators in the 
Computed Items dialog box). Data items can be 
included in reports or used to calculate other 
data.

Chart Type Select chart types

Set Legend on Set the chart legend on the x, y, or z axis

Show Bar Values Display bar values

Show Pie Values Display pie-slice values

Show Negative Values Display positive and negative values (rather than 
only positive values)

Table 24 Actions Menu - Pivot Section (Continued)

Command Description
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Format Menu
The Format menu is available for Web Analysis and Interactive Reporting. Option availability 
depends on the content of the current window and the module from which the menu is 
accessed.

Show Pie Percentages Display pie slices as percentages (rather than as 
values)

Show Line Values Display values for all lines

Table 26 Actions Menu - Table Section 

Command Description

Insert Insert Query, Table, Pivot, or Chart sections. If 
Query, you can select a query to modify or link to a 
distributed, predefined data master. If Table, Pivot, 
or Chart, the data set is based on the current 
Results section.

Sort Sort columns in ascending or descending order

Filter Add or modify column filters 

Auto-size column width Resize columns to content width

Grand Total Calculate column grand totals

Break Total Calculate break totals

Add/Modify Computed 
Item

Use items to calculate data items (based on 
functions, data items, and operators in the 
Computed Items dialog box). Data items can be 
included in reports or used to calculate other data.

Delete Delete selected columns

Table 27 Format Menu  

Command Description Submenu

Font Change the appearance of characters Ariel

Style Change the appearance of characters ● Plain

● Bold

● Italics

● Underline

Table 25 Actions Menu - Chart Section (Continued)

Command Description
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Numbers Set the appearance of numerical values ● Currency

● Percentage

● Date

● Time

Justify Adjust text position ● Left

● Center

● Right

● Top

● Bottom

● Horizontal

● Vertical

● Vertical_Rotated_Up

● Vertical_Rotated_Down

Auto-size Width Size columns to fit the text of their widest 
column value. By default, Interactive 
Reporting truncates columns evenly, without 
regard to data-value length.

NA

Swing Re-orient pivot-table axes to view data in 
new ways. When you swing dimensions, you 
move them up, down, or to the opposite 
axis.

NA

Chart Types Determine chart type. Chart types are 
defined by how they represent data 
graphically and how they plot values and 
labels along the X, Y, and Z axes.

● Vertical Bar

● Horizontal Bar

● Vertical Stacked Bar

● Horizontal_Stack_Bar

● Vertical Cluster Bar

● Line

● Stacked Area

● Area

● Ribbon

● Bar-Line

● Pie

3-D Display charts in three-dimensions NA

Set Legend On Do or do not display chart legends ● X

● Y

● Z

Show Bar Values Do or do not display bar values NA

Table 27 Format Menu  (Continued)

Command Description Submenu
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Tools Menu
The Tools menu is always available. Command availability is determined by product and roles.

Display Type

(Web Analysis 
documents)

Determine display type. Documents display 
data values returned from the data source 
in data objects. Web Analysis documents 
can have multiple data objects, each one 
with a different display type.

● Spreadsheet

● Chart Types

❍ Default

❍ Vertical Bar

❍ Horizontal

❍ Bar

❍ Line

❍ Spline

❍ Area

❍ Curved Area

❍ Pie

❍ Marks

❍ Pareto

❍ Box

● Pinboard

Auto-Resize

(Web Analysis 
documents)

Resize Web Analysis documents in the 
content area (usually accompanied by re-
sizing of Workspace)

NA

Table 28 Tools Menu  

Command Description Submenu

Viewer Display many types of documents and 
maintain a list of open documents

● Desktop

● Enterprise Metrics

● Scorecards

● <<List of Open documents>>

Schedule Manage jobs, batches, and events for 
automated processing

● Batch Scheduler

● Manage Jobs

● View Job Status

● Manage Events

● Consolidated Job Status List

Explore List and navigate through repository 
contents and manage and control files 
and folders

Opens Explore

Table 27 Format Menu  (Continued)

Command Description Submenu
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Help Menu
You use the Help menu to access Workspace Help, PDF files and information about 
Workspace.

Administer Manage users, user groups, user 
preferences, roles, and authentication 
methods

● General

● User Management

● Physical Resources

● Mime Types

● Notifications

● Smartcuts

● Usage Tracking

● Event Tracking

● Manage HSS Modules

● Manage HSS Projects

Impact Manager Update Interactive Reporting documents 
when database structures or connections 
or external, data-source links change

● Synchronize Metadata

● Data Model Updates

● Show Task Status

● Show Impact of Change

Personalize Display documents to which you are 
subscribed and manage personal pages

● Show Subscribed Items

● Manage Personal Pages

Links Connect to Web Analysis documents or the 
Enterprise Metrics workspace or launch 
applications or custom links from the Tools 
menu

● Web Analysis Studio

● Metrics Personalization Workspace

● For Performance Scorecard, launch the 
Performance Scorecard application.

Change Related Content 
Links

Select Financial Reporting documents and 
change related content links

NA

Change Database 
Connections

For Financial Reporting documents, open 
Database Connection Manager, used to 
change database connections for reports

NA

Database Connection 
Manager

For Financial Reporting documents, open 
Database Connection Manager

NA

Search Search within Explore NA

Install Install the Interactive Reporting Web client 
or Smart View

● Interactive Reporting Web Client

● SmartView

Table 28 Tools Menu  (Continued)

Command Description Submenu
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Shortcut Menu Commands
To perform tasks, you can use shortcut menu commands, which are displayed when you right-
click in the repository for a module document. Option availability depends on the content of 
the current window and the module from which the menu is accessed.

Table 29 Help Menu  

Command Description

Help on this Topic Displays help for the current topic

Contents Opens the online help Contents tab, from which you can search for specific topics

Information Map Opens the Hyperion System 9 information map, which contains links to documents

Technical Support Opens the Hyperion Technical Support home page

Hyperion Developer’s 
Network

Opens the Hyperion Developer Network home page

Hyperion.com From Workspace, opens the Hyperion home page

About Hyperion System 
9 BI+ Workspace

Opens the About Hyperion System 9 BI+ Workspace window, which contains information 
about Workspace, including UI and Server versions and version details

Table 30 Shortcut Menu: Repository  

Repository - Right Click Menu

Menu Command Description

New Folder Add folders to the repository

New Document From the New Document wizard, create documents, such as books, batches, 
analysis documents, or scheduled batch jobs

Open Select, open, and use repository documents

Open In > 
HTML Preview

PDF Preview

View documents in browsers as HTML or PDF

Import

> File

> URL

> File as Job

> Financial Reports

Open the Import to Repository dialog box, used to import reports, books, 
snapshot reports and books, report objects (grid, text, image, and chart) and 
row and column templates into the repository

Expand From the view pane, display sub-folders under selected folder

Collapse From the view pane, collapse selected folder

Export Open the Export dialog box, used to export saved reports, snapshot reports 
and books, and report objects (grids, text, image, and chart) from the 
repository
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Shortcut Keys
To toggle the masthead and view pane, you can use shortcut keys.

E-mail Link Display the E-mail Editor dialog box, used to indicate recipient names and e-
mail message subjects. E-mail Links Editor creates hyperlinks to files so 
recipients can view the files in Web browsers. Only Financial Reporting users 
can view hyperlinked files.

Cut Remove repository items and place copies on the clipboard

Paste Place cut and copied items in reports

Delete Remove files from the repository upon confirmation

Delete with Outputs For Interactive Reporting documents, delete items with job outputs, if there are 
outputs

Rename Changes name of file or folders

Properties Display scheduled batch detail; for example, the time for which a batch is 
scheduled

Run Job For Interactive Reporting jobs, set job parameters and run jobs

Subscribe Inform subscribing users of document changes

Explore Opens Explore.

Search Search for repository files

Create Shortcut Create document shortcuts, for example, create shortcuts to Interactive 
Reporting, PDF, and HTML documents

Retrieve Download and save an Interactive Reporting document

Schedule Job Schedule Interactive Reporting Job

Add to Favorites Add files to the favorites list

Refresh Refresh the repository to include new folders and files

Table 31 Shortcut keys 

Shortcut Keys Description

Alt+1 Toggles the 
masthead

Table 30 Shortcut Menu: Repository  (Continued)

Repository - Right Click Menu

Menu Command Description
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Ctrl+1 Toggles the view 
pane

Alt+Ctrl+1 Toggle masthead 
and view pane

Table 31 Shortcut keys (Continued)

Shortcut Keys Description
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C h a p t e r

2
Viewing Documents in 

Workspace

With Workspace, you can use the Explore and Viewer modules to view available documents. 
With Explore, you can list and navigate the contents of the repository and manage and control 
files and folders. With Viewer, you can view, interact with, and modify document content. The 
Navigate panel within the Viewer module displays a list of items: 

● Desktop—View contents, displayed as icons in the content area

● Performance Scorecard—View and print all scorecards and maps that you are authorized to 
access, export employee and measure scorecards to Excel worksheets, export cause and 
effect maps as image files

● Enterprise Metrics—Access metric data, dynamic charts and reports, daily updates, 
hyperlinks from charts and reports, personalized data displays, and filtering and sort 
options

● Document list —Select from a document list, to view a document in the contents pane

You use the following features and functionality to customize how you view documents in 
Workspace:

● Desktop folder—Set up desktop folders, each with selected documents

● Favorites—Create a list of favorite documents (System administrators can push items to 
users’ favorites.)

● Subscriptions—Set up e-mail notifications:

❍ For document, URL, shortcut, or file modifications

❍ For job runs

❍ For exception generations

❍ For changes to folder contents

You can attach a modified item to an e-mail notification. You can add subscriptions to 
your default personal pages as a bookmark.

● Personal Pages—Organize Workspace items and Web content on a Web page
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Viewing Web Analysis Documents
Web Analysis enables you to query a wide variety of multidimensional and relational data 
sources. Through an easy-to-use interface, you create queries that are based on hierarchical 
relationships, discrete attributes, or advanced filtering (based on data limits and comparison 
criteria). You can then choose, based on actual or what-if scenarios, visual cues and display 
mediums that reveal exceptions, trends, and variances. 

Web Analysis Clients
To conduct Web Analysis, use one of three clients:

● Workspace, a modular business intelligence platform, provides management reporting and 
analysis for almost any data source in a single coordinated environment. It is a 100 percent 
DHTML thin client that is served by a Web application through a Web server.

● Web Analysis Studio is a robust Web Analysis authoring Java applet that enables advanced 
users to design sophisticated, custom Web analysis documents using a coding-free 
interface. See the Hyperion System 9 BI+ Web Analysis Studio User’s Guide.

● The Web Analysis API Toolkit enables developers to incorporate Web Analysis Studio look 
and feel and functionality into their custom Web applications. See the Hyperion System 9 
BI+ Web Analysis API Toolkit.

The following descriptions focus on Web Analysis using Workspace.

Web Analysis Client Interfaces
Web Analysis tasks must be executed in specific interfaces:

View
The View module is the default interface for reviewing Web Analysis documents. Whatever 
your role, you can access the View module and review documents in the content area.

User Preferences
You customize the Web Analysis display and set behavior for new documents by setting one of 
two types of preferences.

● User Preferences— Personal Web Analysis settings, contained in a preferences file that is 
typically located in a user’s Profiles folder

● Shared Preferences—Files located anywhere in the repository and referenced by multiple 
users, thus enabling common settings and defaults for everyone using a file
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➤ To display the User Preferences dialog box, select File > Preferences.

Favorites Manager
You use Favorites Manager to access contents of your Favorites folder. You can access 
Favorites Manager from the Favorites menu, even if you do not have permission to browse the 
rest of the repository.

➤ To display the Favorites Manager dialog box, select Favorites > Manage Favorites.

Desktop Mode
The Desktop interface collects icons and presents them as your operating system desktop 
presents icons. You can quickly locate and access presentations from your Desktop, using the 
Files or Tools menu. For Workspace, the Desktop lists commonly accessed documents, which 
are identified in a folder defined in Workspace > Preferences > Explorer.

➤ To display your Desktop, select Tools > Viewer > Desktop or File > Open > Desktop.

About Presentations

Presentations, playlists of Web Analysis documents, enable documents to be grouped, 
organized, ordered, distributed, and reviewed. Presentations are lists of pointers referencing 
documents in the repository, not documents copied into sets.

Edit Data
With appropriate permission, you can edit cell values and write edits back to Analytic Services. 
You can initiate Edit Data only from the spreadsheet display type.

➤ To initiate Edit Data in a Web Analysis document, right-click the data object and select Edit 
Data.

Web Analysis Documents
Web Analysis documents can be displayed in an unlimited number of ways. However, each 
document includes four basic components:

Data Objects
Web Analysis documents display in a data object the values returned from the data source.   A 
document can have multiple data objects; each data object has one display type:

● Spreadsheet

● Chart
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● Pinboard

● SQL Spreadsheet

● Free-form grid

Each display type has numerous prerequisites.

➤ To change display type of the current document, select Format > Display Type >, and select a 
display or chart type.

Note: Web Analysis Studio users can lock display type to prevent subsequent users from altering a document.

Page Control Panel
You use the Page Control panel to jump or scroll through pages of intersections.

Paging maintains row and column dimensions on their axes, while changing their Page-axis 
intersections.

➤ To display the Page Control panel, select View > Pages.

A Page Control panel, which displays above its data object in the content area, organizes Page 
axis intersections so that each page focuses on one Page dimension member.

➤ To navigate a Page dimension, perform an action:

● Click the Page Control scroll buttons (< >). 

● From the list, select a page dimension member by name.

Filter Panel
The Filter panel lists the Filters-axis dimension selections. Despite their absence from rows, 
columns, and pages, data-object intersections are related to Filter dimension selections. Filter 
selections help to focus data-object intersections on smaller subsets.

➤ To display the Filter panel, select View > Filters (POVs).

View Pane Information Panel
The View pane extends down the left side of the content area. When you click the Information 
button, the View pane displays the Information panel, which contains segments summarizing 
the current data object of the current Web Analysis document. Different panel segments 
feature different context-sensitive controls and hyperlinks:

● Top segments list the analysis tools activated on the current data object. 

● Middle segments (spreadsheet-axis segments) list axis dimensions. 

● Last segments list the data sources serving current data values and the user profile.
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Display the Information panel to review the features influencing the current data object.

With appropriate permission, you can rearrange dimensions by dragging dimension names 
between axes. See “Moving Dimensions” on page 76.

Opening Web Analysis Documents
You can open Web Analysis documents in various ways:

● Select File > Open > Document, and, from the Open dialog box, click the Open toolbar 
button.

● Use the View Pane, Tools menu or Explore toolbar button to access the Explore module, 
and navigate to and select a document from a repository location.

● Select Favorites > Manage Favorites to access a document from Favorites Manager. 

● Select a Web Analysis document link embedded in a custom document.

➤ To open Web Analysis documents, using the Open dialog box:

1 Perform an action:

● Select File > Open > Document.

● Select the Open icon.

The Open dialog box, which lists the contents of the current folder (specified by the Look In 
list) is displayed.

2 Optional: Select All Files or select Web Analysis Document from the Type list.

3 Navigate to a presentation:

● From Look In, select a location. 

● Click the Go Up A Level button to display the contents of the parent folder in the selection 
frame.

As you navigate, the selection frame lists the files and folders that the Files of Type list 
indicates.

4 Select a document.

5 Click OK.

If the document database connection requires you to log on, the Database Login dialog box is 
displayed.

6 For the database connection, enter a valid user ID and password, select Save User ID and Password, and 
click OK.

The content area displays the selected document.

Showing and Hiding Web Analysis Document Components
You use the View menu to control the display of Web Analysis document components.
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➤ To show or hide Web Analysis document components:

● To display the Page Control panel, select View > Pages.

● To display the Filter panel, select View > Filters (POVs).

● To display the View Pane, select View > View Pane.

● To display the Data Layout panel, select View > Data Layout.

● To display the Information panel, display the View Pane by selecting View > View Pane, 
and click the Information button.

● To display the Edit Data interface, right-click the data object, and select Edit Data.

Resizing Web Analysis Documents
As Workspace is resized, you may need to resize Web Analysis documents in the content area.

➤ To auto-resize the current data object, select Format > Auto-Resize.

Navigating Web Analysis Documents
In Workspace, you use various navigation methods:

Table 32 Navigation Methods 

Navigation Description Method

Move Relocates a dimension on data 
layout axes.

Position on an axis or between axes, using the Data Layout 
dialog box, Information panel, or document wizard.

Paging Maintains dimensions on the 
row and column axes, while 
changing intersections on the 
Page axis

Click or scroll the Page Control panel. See “Paging” on 
page 76.

Keep Only For the selected dimension, 
retains the selected member 
and removes all other 
members.

Right-click a dimension member header, and select Keep 
Only. See “Keep Only” on page 77.

Remove Only Removes the selected member 
from the query result set

Right-click a dimension member header, and select Remove 
Only. See “Remove Only” on page 77

Drilling Increases or decreases 
dimension detail by including 
or excluding members 

Double-click dimension member headers. You can 
customize the drilling behavior; see “Drilling” on page 77.

Custom Controls Provides ability to use custom 
controls in custom documents 
to define Web Analysis 
navigation.

Use a custom document component to change the query. 
Web Analysis users can use custom document components, 
but components can be created only in Web Analysis 
Studio.
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Moving Dimensions
You can rearrange intersections by repositioning dimensions on or between axes.

➤ To move a dimension, using the Data Layout dialog box: 

1 Click the Toolbar Data Layout button. 

2 Drag the dimension from the current position to another position, on the same or another axis. 

Note: Document creators can lock the ability to swap and move dimensions by using Properties.

➤ To move a dimension, using the View Pane Information Panel:

1 Select View > View Pane.

2 Click the Information Panel button.

3 Scroll to the Filter tree, Page tree, Row tree, and Column tree and review the dimension placement for the 
current data object.

➤ Drag a dimension from one to another axis tree.

Note: The requirement to have at least one row and one column dimension may prevent you from dragging dimensions 
that leave an axis empty. In this case, use Data Layout to rearrange the dimension layout.

Paging
Paging maintains row and column dimensions on their axes, while changing their intersections 
on the Page axis. You can jump or scroll through pages of intersections by using the Page 
Control panel.

➤ To navigate the Page dimension, perform an action:

● Click the Page Control scroll buttons (< >).

● From the drop-down list, select a page dimension member by name.

Pages

Think of the Page axis as the Z axis of a three-dimensional graph.

Visualize a stack of spreadsheets. Traveling within the stack enables comparison of values on 
different pages.

The stack represents Page axis dimensions; each page represents a Page axis member or 
member combination.
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Keep Only
Keep Only retains the selected member and removes all other members of the selected 
dimension.

➤ To keep only one dimension member, right-click the dimension member header, and select 
Keep Only.

Remove Only
Remove Only removes the selected member from the query result set.

➤ To remove one member from the query result set, right-click a dimension member header, and 
select Remove Only.

Drilling
Drilling increases or decreases data-object detail by changing the member display.

Distributing Web Analysis Documents
You have various options, as determined by your roles and permissions, for distributing Web 
Analysis documents to other users:

● You can embed Web Analysis content into Personal Pages. When you import personal 
pages to the repository, other repository users can review the content.

● You can save documents into the Favorites Folders of other users. The users can review 
document content, even if they do not have access to Explore mode.

● You can use Smart View to export Web Analysis data to Microsoft Office applications. 

● You can right-click a file name in Explore mode and e-mail a file link to other repository 
users.

● You can right-click a data object and print a document hard copy.

● You can set file properties for documents in the repository. File properties indicate the 
access assigned to specific users.

● You can include documents in presentations that are distributed by a shared Desktop 
folder. To view the content, users must have access to the Desktop folder, presentation, and    
document. 

For distribution-method information, see the Hyperion System 9 BI+ Workspace User’s Guide.
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Passing Web Analysis Document to Web Analysis Studio
Because advanced Web Analysis functionality is not extended to Workspace, you may want to 
pass documents to Web Analysis Studio. You can save a report to the repository, log out, and 
then log on to the studio; or, you can proceed to the studio in a single click.

➤ To jump to Web Analysis Studio from Workspace, select Tools > Links > Web Analysis 
Studio.

Viewing Financial Reporting Documents
You can view documents, such as reports and books, from the Workspace Explore module in 

two ways:

● HTML Preview—view in a Web browser.

● PDF Preview—view as if printed

When you view reports or books, data is automatically refreshed; data, calculations, and 
format are updated.

Snapshot reports and books contain data retrieved when the reports or books were saved as 
snapshots. Data in a snapshot report or book is not refreshed.

After a report is saved and file permissions are set, advanced users, such as designers, or end 
users, such as viewers, can access the document in the Workspace repository.

Making Reports and Books Available to Workspace Users
Reports and snapshots are created in Financial Reporting Studio. Books and snapshot books 
are created in Workspace and saved to the repository in the Explore module. Folders are used 
to organize reports, snapshots, books, and snapshot books in the repository. From the 
Workspace Administration module, a designer specifies that reports, snapshots, books, 
snapshot books, or folders listed in the repository are available to Workspace users by creating 
users, groups, and roles and defining file permissions (by using the Properties settings of the 
documents). Users with appropriate permissions can then view the documents in Workspace. 
For report-design information, see the Hyperion System 9 BI+ Financial Reporting Studio User’s 
Guide. For information on the functionality and features of the Explore module and the 
repository, see the Hyperion System 9 BI + Workspace User’s Guide. For information on 
assigning file permissions to users and groups for reports and books, see  the Hyperion System 9 
BI + Workspace Administrator’s Guide.
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Navigating in Workspace 
Designers and viewers can perform various tasks from Workspace. See Chapter 1, “Using 
Workspace” for task information. The options that are available or enabled vary depending on 
user rights or roles. For example, Schedulers can access the Explore and Schedule modules to 
set the parameters necessary to schedule and save jobs and batches. Viewers can access the 
Viewer module to open and display documents.

Financial Reports Functionality
In the Explore module, documents (for example, reports) can be opened (reports view only), 
deleted, moved, imported, exported, and renamed. Folders can be created, opened (reports 
view only), deleted, imported, exported, and renamed. Reports and books can be previewed 
(HTML or PDF), and users can respond to prompts and change the POV.

You can sort repository items by clicking column field headers and, from the menus, can 
access various functions: 

● Import and Export

● Preferences

● Properties

● Change and Manage Database Connections

● Database Connection Manager

● Change Related Content Links

● Email Links

● Display items of type

● Favorites

● Subscribe

For feature details, see the Hyperion System 9 BI + Workspace User’s Guide.

Note: User and group administration is available from the Workspace Administer module. See the Hyperion System 9 BI 
+ Workspace Administrator’s Guide.

Batch and Book Editor, Batch Scheduler
Workspace enables Content Publishers and Schedulers to work with books and batches. 
Batches can be created, edited, saved, and scheduled, with full Batch Scheduler capabilities. 
Books can be created, edited, and saved. Advanced Member Selection provides member 
functions (for example, Children, Descendants) and lists, similar to Financial Reporting Studio 
advanced member functionality.
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Opening Reports
From Workspace, you can open reports to display the reports with current data. Data is 
refreshed when a report is opened or viewed. You can view reports in HTML and PDF, 
respond to prompts, and change the POV.

Viewing Snapshot Reports and Books
From Workspace, you can view snapshot reports and books, which you opened from the 
Workspace repository.

Creating Database Connections
You use Database Connection Manager, accessed from Workspace, to create, maintain, and 
assign database connection names—data source names, for example, MySampleBasic, assigned 
to specific data sources, for example, DevServer:Sample:Basic for a report. Thus, you can easily 
assign data sources to reports and other objects, such as books and grids.

Viewing a Production Reporting Document
You can view Production Reporting documents in Workspace. To view the output formats 
available for a job, double-click the job output. Output format availability depends on the 
output formats selected when the job was run:

● HTML file (HTML)

● Portable Document Format file (PDF)

● Comma Separated Value file (CSV)

● Interactive Reporting Data file (BQD)

● Excel file (XLS)

● Extensible Markup Language file (XML)

● Production Reporting Document (SPF)

● PostScript file (PS)

● HP Printer file (PCL)

● Line Printer file (LS)

See the Hyperion System 9 BI + Workspace User’s Guide.
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Using Interactive Reporting Documents in Workspace
Workspace enables users to query relational databases and heterogeneous sources (for 
example, SQL Server, Oracle, flat files, and Production Reporting and Web Analysis module 
content) and perform ad hoc analysis by drilling down and pivoting on the data to see patterns 
or exceptions. Various features help users analyze data to conduct sales, performance, 
financial, and forecasting analyses. 

Three methods of querying a relational data source:

● Developers with database connectivity software can use a full 32-bit application. 

● Power users without connectivity or with security concerns can use a client connected to 
the database through a server. Power users can be given permission to create content from 
scratch, using add-on software installed on their local machines and hosted by Web 
browsers.

● Information consumer users typically use a thin-client approach; no software is loaded for 
these users, who interact with a DHTML-based series of pages. 

How Interactive Reporting Works
Interactive Reporting enables you to access and analyze information stored in company data 
sources. It connects you to data and supplies a set of tools that enable you to build queries 
quickly and intuitively—by clicking icons and manipulating objects. Interactive Reporting 
builds a query to your specifications, sends it to the database, and displays the retrieved data as 
a results table. 

Interactive Reporting information is stored in documents, files that you create and use to 
retrieve and analyze database information and build reports. Because Interactive Reporting is 
an integrated query, analysis, and reporting tool, Interactive Reporting documents (.bqys) 
have multiple sections, each of which governs one part of the query and reporting process. You 
create sections progressively as you query a database, retrieve results, and generate reports. 

Interactive Reporting documents (can contain data from multiple relational and 
multidimensional database queries and from imports. Documents usually include one or more 
of the following items:

● A query or multiple queries for retrieving a data subset from the database 

● A results set displayed in a table-style format

● Reports presenting customized, hierarchical data views

● Multidimensional pivot tables that permit drill-down analysis of data results

● Charts that graphically display query results and present varied data perspectives

Viewing Interactive Reporting Documents in Workspace 
All Interactive Reporting documents have at least one Query and one Results section. From the 
Results section, you can create multiple Pivot, Chart, Table, and Report sections. Developers 
can create Dashboard sections, which provide users an automated, push-button interface.
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Queries
Queries, which request information from a database, use a command language that enables 
you to select, insert, update, determine data location, and so forth. 

The standard command language for retrieving information from and updating relational 
databases is Structured Query Language (SQL). SQL statements are used for interactive, 
relational-database queries and report, data-collection queries. 

With Interactive Reporting, you do not need to know SQL to create powerful database queries. 
You build queries by choosing data from topics that represent database tables and by 
refreshing the data.

Analysis and Reporting
After a query is processed and data results are returned to Workspace, you can use powerful 
reporting and analysis tools to create custom views and cross-sections and to drill-down to 
slice and dice data and view multidimensional relationships. 

You can create as many views as you want and display information in any form and from any 
angle possible. At any time, you can reconnect to the server and update reports and charts with 
fresh data.

You can work autonomously with data after disconnecting from Workspace, continuing to 
analyze data and produce reports. You can save results for additional refinement in Interactive 
Reporting Studio or Interactive Reporting Web Client and export data to other applications 
for further analysis.

Interactive Reporting enables you to create a wide variety of reports:

● Tables—Columnar arrangements of data, used as building blocks in other reporting 
sections. You can apply filters to tables, add computed items, and include subtotals, grand 
totals, and summary totals such as sum, count, or average.

● Pivot tables—Interactive tables that summarize or cross-tabulate large amounts of data. 
You can rotate rows and columns to see different data summaries or to display details. A 
pivot table summarizes data by using a summary function that you specify, such as Sum, 
Count, or Average. You can include subtotals and grand totals automatically or use your 
own formulas by adding computed items. 

● Charts—A visual display of information (fully interactive, three-dimensional views of 
data). In charts, Interactive Reporting Studio displays data from results sets as bars, lines, 
columns, pie slices, or other shapes. When you create charts, worksheet values are 
automatically represented. Charts are linked to the data from which they are created and are 
updated when data changes.

● Custom reports—Free-form, presentation-quality reports with graphic objects, predefined 
fields, band-style report data from multiple data sources, and computed fields, charts, and 
pivots. In Smart reports, you can embed charts and pivot tables and show only data that is 
relevant to the section in which it is placed.
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● Dashboards—A customized, front-end report used for a variety of purposes. Each button 
and item selection and navigation sequence can invoke a script. Behind the scenes, 
Workspace refreshes Dashboard script commands, which perform actions such as retrieve 
data, populate controls, hide objects, navigate between sections, and specify report 
parameters.

Using Enterprise Metrics to Manage Business Performance
Enterprise Metrics retrieves essential performance and trend metrics and thus enables you to 
monitor business performance. 

Metrics, numeric measurements computed from business data, help you assess business 
performance and analyze company trends. To enable immediate and intuitive understanding, 
Enterprise Metrics metrics are displayed in charts and provide the following features:

● Access to metric data, based on customized views for business models and input from 
business analysts

● Dynamic charts and reports that provide up-to-date visual data so you can identify 
performance, events, and trends that indicate a need for action and areas in which 
profitability can be increased

● Daily updates that enable you to act on a timely basis

● Chart and report hyperlinks that enable you to navigate to more detailed and focused data

● Personalized data display, which filters and sorts options

For details on personalizing Enterprise Metrics using the Enterprise Metrics Personalization 
Workspace, see the Hyperion System 9 BI+ Enterprise Metrics User’s Guide.

How Enterprise Metrics Manages Data

Your company’s database experts and business analysts ensure that data from various sources 
(databases, order-entry systems, and desktop data sources such as spreadsheets) is 
consolidated into one Application Data area. An Application Data area, running on a 
relational or multi-dimensional database, provides a rich set of metrics that are based on your 
business models and data framework. 

Behind the scenes:

● Data is cleansed when it is loaded into the Application Data area to ensure rollup accuracy, 
despite such factors as subsidiaries, order-entry inconsistencies, and typographical errors.

● Automated load processes provide nightly updates and check for exceptional conditions to 
ensure high-quality data and minimize administration costs.

● A sophisticated data model ensures high query performance and analytical flexibility, 
reduces user errors, integrates related data from different sources, and provides extensibility 
for future data sources.
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● Libraries, which include business rules, analytical methods, metric hierarchies, and layouts, 
are applied.

● A history of multiple years is normally held for business metrics, enabling trend analysis and 
year-over-year comparisons.

Thus, metrics are ready for you to use daily to manage your business.

Analysis Framework
The Enterprise Metrics framework is based upon unique business metrics that optimize your 
ability to find business-model issues: 

● Identify significant and relevant anomalies

● Diagnose anomalies

● Access key information so you can evolve your business based on trend analysis

● Evolve applications by personalizing data to reflect information pertinent to business 
decisions

● Use timely and accurate information to manage business-operation performance.

Figure 5 KPI Management Workspace Process

Enterprise Metrics Workspace provides four sections with pages that help with analysis: 

● Monitor—Survey overall performance, look for anomalies, and start a decision process

● Investigate—Narrow a problem or opportunity spotted in the Monitor section

● Pinpoint—Identify details that enable action, such as customer names, order details, events, 
shopping cart contents, and problem histories

● Dictionary—Find detailed information about the data that metrics and charts use in the 
Monitor and Investigate sections. 

  



Understanding the Enterprise Metrics Workspace   85

Understanding the Enterprise Metrics Workspace
Enterprise Metrics provides all components necessary for analyzing your company’s latest 
business information. 

Figure 6 Enterprise Metrics Window

Enterprise Metrics Workspace elements: 

1 Toolbar Right of the menu

2 Menu Access other documents and online help (top of window—below the masthead) 

3 View Pane Navigate between sections

4 Page Selector Select pages in the Monitor, Investigate, and Pinpoint sections

5 Console View options and page point of view—context-sensitive (Change the width of the Console by dragging the 
vertical divider.) 

6 Process bar View (below the title bar) security restrictions, the As of data date on the right and the page on the left (It is 
very important that you periodically view security restrictions, so you can interpret results displayed in 
Enterprise Metrics. See “Security Restrictions” on page 87.)

7 Content Area View (right side of window) information specific to the current page (For example, the Investigate section 
displays charts, and the Pinpoint section displays a tabular report.)

5

7

2
6

1

  3

4
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Enterprise Metrics Charts
Enterprise Metrics presents information in charts and tabular reports. Enterprise Metrics 
charts (see Figure 7), display performance metrics, trended over time. The numeric value 
displayed with the chart is the chart cell value, the value of the primary metric for the current 
period.

If the point of view is sorted based on a chart metric, a symbol indicating the sort order 
(ascending or descending) is displayed in the left corner of the Summary chart. 

Figure 7 Enterprise Metrics Chart

Elements of Enterprise Metrics charts:

Enterprise Metrics charts can display one or more metrics as a time series over fiscal periods 
(days, weeks, fiscal months, fiscal quarters, and fiscal years). Charts in the Monitor section can 
display one or more metrics for one time period (such as current fiscal month), with the x-axis 
displaying slice (business hierarchy) values. For example, the x-axis might display the Sales 
Organization hierarchy divided into CAPJ, EMEA, and Americas.

1 Chart Header Displays metric names

2 As of Date Tick Mark Indicates the data date relative to the chart period above the chart; directly below the label in time 
series charts) 

3 Extrapolation of the 
Current Period

Projects the current-date value to the end of the current period—based on the fraction of the period that 
is complete (Current period extrapolation is shown with a white bar or white dotted line and may be 
applied for incomplete time periods.) 

4 Chart Cell Value Identifies the primary-metric value for the current period, defined as Metric 1 unless changed by 
Enterprise Metrics Editor.(Yellow shading indicates highlighting. Thresholds are defined— yellow 
indicates a warning, green indicates a good number, and red indicates a bad number.)

5 Sort Indicator Indicates the sort order (ascending or descending) of the chart metric information. (Figure 14 displays 
a descending sort, the top component having the largest value.)

6 Chart Legend Is displayed only on Monitor section charts, below Summary charts. (Investigate section charts have a 
color key above the Drill buttons. Colors in stacked bar charts represent component values of the total, 
as in a pie chart.

4

3

1

6

5

2
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Granularity (whether metrics are displayed by quarter, month, week, and so on), varies by 
metric type. Granularity can differ from update frequency. For example, a quarterly forecast 
can be updated monthly. 

Detail charts are displayed below Summary charts in Investigate section columns.

Security Restrictions
The information displayed in your Summary and Detail charts is based upon your security 
restrictions, which are shown on the Process Bar. Therefore, your charts may show only 
portions of data.

It is extremely important that you closely monitor your security restrictions to help ensure that 
you are interpreting Enterprise Metrics information correctly.

Getting Started with Scorecard Studio
Successful organizations are strategy-focused. Identifying and articulating strategic goals is 
central to performance management. Without a central, comprehensive, and communicated 
strategy, your organization is not properly positioned to achieve or reevaluate its goals.

Hyperion® System™ 9 Performance Scorecard ™ (Performance Scorecard) is a Web-based 
solution that provides recognized scorecarding methodologies, assists your organization to set 
goals, and measure and monitor business performance. 

Performance Scorecard enables users to formulate and communicate organizational strategy 
and accountability structures by using measures, scorecards, and maps to measure and track 
progress in key business areas:

● Performance measures or Key Performance Indicators (KPIs), are used to identify and 
create tasks or achievements that monitor progress toward key goals.

● Scorecards use measures to indicate performance for strategy elements, accountability 
teams and employees. Scorecard performance is reflected using performance indicators to 
represent good, acceptable, or poor results. 

● Strategy Maps depict how organizations translate high-level mission and vision statements 
into lower-level, actionable strategy elements.

● Accountability maps identify business areas, departments, and teams that are responsible 
for the actions that must be performed to achieve strategic goals and objectives.

● Cause and Effect maps depict how strategy elements in applications interrelate and 
support corporate or departmental strategy and enable you to identify strategy elements 
that are impacted by strategy-element changes.

To view Performance Scorecard through Workspace, you must have both applications 
running. Performance Scorecard and Workspace require the same data-access permissions. If 
you can view information in Performance Scorecard, you can view it in Workspace. 

For instructions on viewing Scorecard Studio through Workspace, see Hyperion System 9 BI+ 
Workspace User’s Guide.
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Designer Tasks
A user with designer rights has a number of tasks to consider prior to using Workspace. Tasks 
that a designer should consider are the following:

● “Planning” on page 90

● “User Preferences” on page 90

● “Designer Resources” on page 90

For task and role information, see “Module Tasks” on page 24.

Planning
When planning Workspace deployment and determining what modules to use, designers 
consider these factors:

❍ Technical and business goals

❍ Deployment planning tasks

❍ System requirements

❍ System architecture

❍ Data and metadata integration requirements

❍ Requirements for third-party components

❍ A deployment timeline

❍ An infrastructure plan

❍ An integration plan

❍ A capacity and performance testing plan

For task information, see Chapter 1, “Using Workspace.” 

User Preferences
Designers can set defaults for the appearance of the user interface, Explore module, and 
studios. Some settings can be overridden through menu options; for example, from the 
Preferences dialog box, designers can select not to show the masthead. See the Hyperion System 
9 BI+ Workspace User’s Guide.

Designer Resources
Workspace provides standard tools for creating documents. For example, the design resource 
library includes graphics, data sources, database connections, samples resources, roles a 
designer can set up, and so on.
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Designer Capabilities in Workspace
For Financial Reporting, designers can create books and batches. From Workspace, batches 
can be created, edited, saved, and scheduled, with full Batch Scheduler capabilities available; 
and books can be created, edited, and saved. Advanced Member Selection provides capabilities 
such as member functions (for example, Children, Descendants) and lists, similar to Financial 
Reporting Studio advanced member functionality. Creation and design of Financial Reporting 
documents are performed from Financial Reporting Studio. Financial Reporting documents 
that are ready for end-user viewing can be opened for viewing purposes from the Workspace 
Explore module.

You can create Web Analysis documents, in one of the following ways, only if you have 
permission to create content:

● Use the new document wizard to create a document.

● Modify a document and save it under a new name or to a new location.

Web Analysis documents display data values returned from the data source in a data object. 
Documents can contain multiple data objects, each having a display type:

● Spreadsheet

● Chart

● Pinboard

● SQL spreadsheet

● Free-form grid

You can review display types in Workspace, but you can create spreadsheets and charts only in 
the new document wizard.

To create a document, you specify three items:

● The data source—provides data values

● The data object—displays data values

● The query—retrieves data values from the data source and returns them to the data object

Administrators and Web Analysis Studio users can set properties that customize these 
elements. In Workspace, you can set only default numeric formatting and database connection 
parameters.

For Production Reporting, in addition to the stand-alone components, you can use Workspace 
to run, schedule, and view Production Reporting jobs. When you double-click the job output, 
you can view the available output formats. Depending on the output formats selected when 
you ran the job, you can select from a list of output formats. For more information, see the 
Hyperion System 9 BI + Workspace User’s Guide.

For Interactive Reporting documents, a documents is a file created by the desktop application 
and is commonly known as a BQY file. In Workspace, the query and Data Model aspects of a 
document are not visible to the end-user, but the ability to process (refresh) data that come 
from these sources is. After a document has been created by a designer, it is saved and 
published to the repository of the Explore module.
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When a Workspace user selects and retrieves a document from a document list, the emphasis 
changes from document viewing, processing, and analyzing to document query, data model, 
layout, and report building. Each Intelligence Client document consists of one or more 
sections, such as charts and pivot tables.

Designing Web Analysis Documents
Topics that describe how to create and enhance Web Analysis documents with Workspace:

● “Creating Web Analysis Documents” on page 92

● “Modifying Queries” on page 94

● “Selecting Dimension Members” on page 95

● “About Advanced Member Selection” on page 96

● “Managing Analysis Tools” on page 98

● “Creating Traffic Lighting Definitions” on page 99

● “Saving Web Analysis Documents” on page 100

● “Setting File Permissions for Web Analysis Documents” on page 100

Creating Web Analysis Documents
The new document wizard guides you through the process of creating Web Analysis 
spreadsheets and charts. The wizard requires a database connection. You must know the 
repository location of the database connection and have permissions to use the connection.

➤ To create a document by using the new document wizard:

1 Perform an action:

● Select File > New Document.

● Select the New Document toolbar button.

The Process bar displays the new document wizard in the content area. Depending on which 
modules are installed, you may be prompted to indicate a type of document.

2 Select Create a Web Analysis document, and click Next. 

The content area displays Step 2: Select a Data Source. You must select a previously defined 
database connection from the repository. Because the repository stores document definitions, 
not document data, you must identify a data source and the parameters for connecting to it.

3 Perform a task:

● In the text area, enter the path from the root directory (/) to a database connection, 
including the filename.

● Click Browse, select a database connection file from the Open dialog box, and click OK.
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4 Optional: Select Use my active POV on the data source as the starting point for all subsequent steps to 
populate the query from a predefined point of view definition, and click Next.

Completing this step enables you to load member selections from predefined point of view 
definitions and thus use one click to insert dimensions and members into documents. You can 
define many point of view definitions, but only the definition set in user preferences as the 
currently active point of view is applied.

5 Optional: Select Automatically select one dimension in both rows and columns to populate and display a 
simple spreadsheet, and click Finish.

If you complete this step, you skip the remaining steps. This option uses the highest aggregate 
members of the time and measures dimensions to populate the row and column axes of 
spreadsheets and provides the quickest document-wizard method for displaying a simple 
spreadsheet.

6 Click Next to proceed to Step 3: Select Row Dimensions.

You are required to have at least one Row axis dimension and one Column axis dimension.

7 Move a dimension name from the Filters frame to the Rows frame by clicking first the name and then the 
right arrow. 

The dimension name is displayed in the Rows frame. If no point of view definition was applied 
in Step 1, the highest aggregate member is used. If a point of view definition was applied, 
member selections are used.

8 Optional: To select dimension members, in the Rows frame, double-click the dimension name.

The Dimension Browser dialog box presents the dimension as a node tree in the Browse 
frame. You must select members from the Browse frame and move them to the Selections 
frame: 

● To expand or contract the hierarchy, click the plus (+) or minus (-) sign nodes, or double-
click a dimension name.

● To select a member, right-click the member, and select Select Member.

 The Selections list displays the member name.

● To select a member dynamically, right-click the member, and select an advanced member 
selection method from the list.

● You can set the label mode for each dimension to the default label, an ID label, or the alias 
table description set in database connection properties.

For descriptions of Dimension Browser options, see “Selecting Dimension Members” on 
page 95.

● Click OK to dismiss Dimension Browser and return to the wizard.

9 After you indicate and define member selections for all Rows axis dimensions, click Next.

10 Using the methods that you used to define the Rows axis, move a dimension from the Filters frame to the 
Columns frame.

11 Optional: To select dimension members, double-click the dimension name in the Columns frame.

12 Using dimension browser methods, select members, set options, and click OK.



94  Designing Documents in Workspace 

13 Click Next.

In Step 5, you can select dimensions to be used on the Page axis. Because all document 
intersections are relative to all member selections, you can organize row and column 
intersections by page dimension members.

14 Optional: Using the methods that you used to define the Rows and Columns axes, move a dimension from 
the Filters frame to the Pages frame.

15 Optional: Using Dimension Browser methods, select page members. 

16 Click Next.

In Step 6, you can select dimension members for the Filters axis.

All dimensions participate in every spreadsheet intersection, regardless of the axes to which 
dimensions are assigned. The Rows, Columns, and Pages axes define intersection arrangement, 
and member selections determine which data values are displayed at each intersection.

All data-object intersections are relative to Filter member selections. Filter member selections 
focus intersections, data values, and, consequently, data-object analysis.

Dimensions in the Filter axis are by default represented by the highest aggregate dimension 
member defined in the data source outline. If a point of view definition was applied, its 
member selections are used. If you select Filter members, all intersections are relative to the 
selections.

17 Optional: To display Dimension Browser for Filter axis dimensions, double-click a dimension name.

18 Optional: Using Dimension Browser methods, select Filter axis members, and click OK.

19 Click Next.

20 Optional: Select a result-set, layout option:

Spreadsheet—spreadsheet data object

Chart—chart data object

Vertical Combination —chart and spreadsheet data objects stacked vertically

Horizontal Combination—chart and spreadsheet data objects arranged side-by-side

You can change the display types of objects in the Vertical Combination and Horizontal 
Combination layouts; for example, you can convert a spreadsheet to a chart. The objects, 
however, are linked and maintain a coordinated context.

21 Click Finish to submit the query to the data source.

The data source is queried. The result set is displayed as a data object (or objects) on a Web 
Analysis document.

Modifying Queries
After you create Web Analysis documents, you modify queries by using the Data Layout panel, 
which displays the dimensions returned by the database connection, as arranged on four axes:

● Rows
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● Columns

● Pages

● Filters

Database connections can return three types of dimensions:

Every query must have at least one dimension assigned to the Rows axis and at least one 
dimension assigned to the Columns axis, but you can nest multiple dimensions on one axis. 
You can organize Row and Column dimensions by assigning dimensions to the Page axis. 
Dimensions not assigned to Rows, Columns, and Pages remain in the Filter axis.

All dimensions, regardless of their assigned axes, participate in every data-object intersection.

➤ To redefine the query and dimension layout of the current data object of the current 
document, click the toolbar Data Layout button.

➤ To move a dimension between axes, drag the dimension from its current axis to another axis.

➤ To select members, double-click the dimension name.

Dimension Browser is displayed. See “Selecting Dimension Members” on page 95. 

Selecting Dimension Members
Dimension Browser, a graphical interface for selecting members and refining database queries, 
can be used with the new document wizard, Data Layout dialog box, or Information Panel or 
by itself.

Dimension Browser presents a dimension as a node tree in the Browse frame. You select 
members in the Browse frame and move them to the Selections frame.

You can select members individually, by familial relationships, by data-source-specific option, 
or from predefined selection lists.

➤ To access Dimension Browser, perform an action:

● Right-click a member label on a data object, and select Browse.

Table 33  Dimension Type Icons

Icon Dimensions

Dimensions

Attribute Dimensions

Attribute Calculations
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● Click the toolbar Data Layout button, and double-click a dimension name.

● In the New Document wizard, double-click a dimension name.

➤ To expand or collapse the Dimension Browser hierarchy, click the plus (+) or minus (-) sign 
nodes, or double-click the dimension name.

➤ To select a member, right-click the member, and select Select Member.

The member is displayed in the Selections list. You cannot select the database connection 
name at the top of the node tree.

➤ To select members dynamically in Dimension Browser, right-click a member, and select an 
advanced member selection method from the list.

See “About Advanced Member Selection” on page 96.

➤ To remove members from the selection list, perform an action:

● Right-click a member in the Browse or Selection list and deselect the selection method.

● Select a member in the Selection list and click Remove. 

➤ To remove all members from the selection list, click Remove All.

➤ To preview members returned by advanced member selections, before you quit Dimension 
Browser, click Preview.

➤ To set the label mode for a dimension, select Dimension Labels, and specify a label option:

● Use Default

● Descriptions (uses the alias table specified by database connection properties)

● IDs

● Both (uses ID and Description simultaneously—only for Financial Management)

The label displayed by the Description label mode is drawn from the alias table specified by the 
active user’s database preferences. You can set the alias table for each Active Preferences user or 
user group ID.

Users can specify label mode, using Dimension Browser.

About Advanced Member Selection
In dimensions with large member sets, users can select members by using the Dimension 
Browser right-click menu and then selecting by familial relationship or data-source-specific 
options:
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Table 34 Dimension Browser Right-Click Menu 

Icon
Right-Click Menu 
Command Description

Select Member Selects the current member.

Also Select Children Selects the current member and its children.

 
Also Select Descendants Selects the current member and its descendants.

 
Select Parent Selects the parent of the current member.

 
Also Select Ancestors Selects the current member and its ancestors.

Also Select Siblings Selects the current member and all members with the level and parent 
of the current member.

Select Dim Bottom Selects all level 0 members of the current dimension.

 
Select Dim Top Selects the highest ancestor.

 
Also Select Level Selects the currently selected dimension member and all dimension 

members on the same level.

 
Also Select Generation Selects the currently selected dimension member and all dimension 

members in the same generation.

 
Also Select Previous Displays the Previous Selection dialog box, used to select previous 

members at the same dimension level.

 
Also Select Subset Displays the Subset dialog box, used to select an Analytic Services 

member subset.

Substitution Variables Displays the Substitution Variables dialog box, used to set a 
substitution variable as the dimension selection.

User Defined Fields When Financial Management is used as a data source, displays the 
User Defined Fields dialog box, used to specify one of three pre-
defined attribute values. (You can select members that feature the 
attribute values and compose compound selection statements with 
AND and OR operators.

Dynamic Time Series Displays the Analytic Services Dynamic Time Series menu (for 
example: History To Date, Quarter To Date).

Search Displays the Search dialog box, used to locate members in large 
dimensions. (Uses search criteria and adds found members to the 
Selection list.)

Find In Tree Locates members in large dimensions. (Find In Tree expands the 
dimension hierarchy, but does not add found members to the 
Selection list.)
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Managing Analysis Tools
You can use analytical formatting tools and data-source-specific tools to enhance Web 
Analysis documents. Analysis tools expedite comparisons, visually organize data, and promote 
structures and conclusions.

Analysis tools are data-source-specific; not all analysis tools are available in all data objects.

Analysis Tools Manager, accessed through the data-object, right-click menu, organizes and 
applies analysis tools. The Ordered By panel of Analysis Tool Manager shows the number and 
order of analysis tools definitions activated on the current data object. The following analysis 
tools are available in Workspace:

Activating and Deactivating Analysis Tools Definitions
By activating and deactivating analysis tool definitions without removing them from Analysis 
Tools Manager, you enable use of various analysis tool combinations.

➤ To deactivate an analysis tool definition, select the appropriate Active in the Ordered By panel.

Table 35 Analysis Tools 

Analysis Tool Description

Traffic Lighting Displays the Traffic Lighting dialog box, used to color-code 
dimension member values based on fixed limits or a comparison of 
values.

Traffic Lighting visually associates member values whether or not 
they are sorted or ranked.

Sorting Displays the Sorting dialog box, used to order the query result set.

Retrieve Only Top/Bottom Displays the Analytic Services Retrieve Only Top/Bottom dialog box, 
used to limit and rank the query result set.

Restrict Data Displays the Analytic Services Restrict Data dialog box, used to 
restrict the query result set based on criteria.

Calculations Displays the Calculations dialog box, used to create calculated rows 
and columns.

Show/Hide Only Displays the Show/Hide dialog box, used to filter data by color, 
value and member.

Data Formatting Displays the Data Formatting dialog box, used to format data values 
based on member or value criteria.

Currency Conversion Displays the SAP BW Currency Conversion dialog box, used to 
convert currency denominations using specified exchange rates.

Unit of Measure Conversion Displays the SAP BW Unit of Measure Conversion dialog box, used 
to convert units of measure using known and custom conversion 
rates.
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Creating Traffic Lighting Definitions
Traffic Lighting color-codes data cells based on member values. You can color-code by 
comparing two dimension members or by placing fixed limits on one dimension member. 
Colors graphically associate member values, whether they are sorted or ranked. Traffic 
Lighting definitions are maintained as the document is pivoted and changed.

Note: Setting traffic lighting colors to the colors used by Spreadsheet Options may obscure member color-coding.

➤ To create a traffic lighting definition:

1 Right-click a dimension member header and select Analysis Tools > Traffic Light.

The Traffic Lighting dialog box is displayed.

2 Select the dimension member to which traffic lighting is to be applied, from the Apply To panel.

3 From the Comparing To, select the dimension member to which the preceding dimension member is to be 
compared.

● Compare to a fixed limit by either disabling the % Differences check box in the Assign 
Limits group box, or by selecting Fixed Value from the Comparing It To panel.

● Select the Advanced check box to separate dimension members into combinations. Click it 
again to select from aggregated dimension members.

The Assign Limits group box contains three default set points and colors. Set points divide all 
possible values, into ranges of values that are identified by color.

4 For each set point, indicate a set point operand.

The first drop down list, prompts you to specify whether the setpoint value is in the range. You 
can choose from greater than (>) or greater than and equal to (>=).

5 Enter a set point value in the text entry box, to specify the threshold separating traffic lighting ranges.

The second drop down list, prompts you to specify the setpoint value. You can enter positive 
or negative decimal values.

6 Optional: To change the color of the traffic lighting range, click the color button and select another color 
square.

The Color button displays a palette of color squares. Clicking a color square assigns it to the 
corresponding traffic lighting range, and displays the hexidecimal value of that color in the 
neighboring text entry field.

7 Optional: To change the opacity of the color, enter another value in the last text entry box for each range.

The last text entry field specifies the opacity of the color. You can specify a percentage of 
opacity for the color from zero to a hundred. Zero indicates that the color is completely 
transparent. This is sometimes used to reveal background graphics by means of traffic lighting.

8 Optional: To add another set point to the ranges, click the Add to End button, then repeat steps 4 through 
7 for the new range.

9 Click OK.
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Saving Web Analysis Documents

➤ To save a Web Analysis document, perform an action:

● Select File > Save.

● Select the Save icon.

If your Web Analysis document is not saved, you must indicate the filename and location 
under which the file is saved.

The Web Analysis message box, indicating that the document is saved, is displayed.

Setting File Permissions for Web Analysis Documents
When you set file permissions for Web Analysis documents, you specify users, user groups, or 
users of a particular role who have access to the documents. You can also specify in detail the 
kind of access assigned to each user, group, or role.

Before you set file permissions, you must save your Web Analysis document to the repository.

➤ To set file permissions for a Web Analysis document:

1 Access Explore mode by clicking the View Pane Navigate button and selecting the Explore tab.

The Content area displays the Explore mode interface.

2 Navigate to the Web Analysis document file name in the repository hierarchy:

● To expand or collapse a folder, click the plus or minus button.

● To display the contents of a folder in the Content area, select the folder.

● To select a repository document, click the file name.

3 Right-click the file or folder name and select Properties.

The Properties dialog box, with content-sensitive panels, displays current file properties.

4 Click the General icon.

The General panel specifies the file name, description, and owner and grants access to the Edit 
Permissions interface.

5 Optional: To rename the file, for Name, enter a name.

6 Optional: To modify the file description, in the text area, enter a description.

7 Click the Edit Permissions button.

Another Properties dialog box, which lists users, groups, and roles that are assigned 
permissions and the kinds of permissions that are granted, is displayed. 

8 To populate the Available Users, Groups and Roles list with a search result set:

a. Select begin with, contain, or are in group. 

b. Select Users, Groups, or Roles.

c. Enter letters or a string to be used to search the list of available users, groups, or roles.
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d. Click the Get List button.

A search is conducted for results that satisfy the specified criteria. Results are displayed in the 
Available Users, Groups and Roles panel.

9 Select the users, groups, or roles to which to grant access.

10 Click the Add (>>) button.

The appropriate panel displays the selected users, groups, or roles, and the Privileges column 
indicates access.

11 Select one record from the Selected User, Groups and Roles panel, and click Edit.

The Edit Permissions panel is displayed. You can grant the current record four kinds of access:

● No access—Cannot review the file, but the global administrator can access the content

● View—Can read the file

● Modify—Can modify the file and save it under another name

● Full Control—Has unlimited access to the file

12 Select one option from the Edit Permissions list, and click OK.

The Properties dialog box is redisplayed.

13 To remove a record from the Selected User, Groups and Roles panel, select the record and click the 
Remove (<<) button.

14 Repeat steps 7 through 10, until you define all users, groups, and roles with access and the kind of access 
granted.

15 Optional: If you typically specify the current list of users and access, select Make these the default access 
privileges for all file I publish.

16 Click OK.

17 Optional: Click the Advanced icon, and specify auto-delete or show/hide file parameters.

18 Click OK to exit the dialog box.

File permissions are set as specified.

Designing for Financial Reporting
Reports are created in Financial Reporting Studio. You design reports in Report Designer by 
using a blank report layout to specify report contents, including grids, charts, images, text 
boxes, headers, and footers. You view completed designs from the Explore module in 
Workspace. A designer can perform additional design functions (creating books and batches, 
scheduling batches, and setting preferences) through Workspace. Setting preferences includes 
setting the default language, specifying numeric format, providing a default e-mail address, 
and specifying default file permissions. For information on creating books and batches and 
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scheduling batches from Workspace, see the Hyperion System 9 BI + Workspace User’s Guide. 
For an overview of designer tasks in Financial Reporting Studio, see the Hyperion System 9 BI+ 
Financial Reporting Studio User’s Guide 

Production Reporting
Production Reporting, a powerful enterprise reporting system:

● Provides data access, data manipulation, and report generation capabilities for scheduled 
and on-demand reports from various data sources

● Is optimized for high-volume reporting

● Provides browser-based management for secure delivery of reporting content in Web-
based and printed formats to large numbers of users

●  Consists of two stand-alone components—Production Reporting Client and Production 
Reporting Server

You use the stand-alone components and Workspace to run, schedule, and view Production 
Reporting jobs. (See the Hyperion System 9 BI+ Workspace User’s Guide.)

Production Reporting Client
Production Reporting Client components include:

● Production Reporting Studio

● Production Reporting Activator

● Production Reporting Viewer

● Production Reporting Remote

Production Reporting Studio
You use Production Reporting Studio, the graphical report design and layout tool, to design 
reports on Windows systems. This interactive report builder combines a visual, easy-to use 
report development environment with the underlying power of Production Reporting.

Note: See Volume 1 of the Production Reporting Client User’s Guide.

Production Reporting Activator
You use Production Reporting Activator, a set of ActiveX controls, to run Production 
Reporting programs launched from within your application and to view and print output from 
within your application.
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Note: See Volume 2 of the Production Reporting Client User’s Guide. 

Production Reporting Viewer
Production Reporting Viewer, by providing a printer-independent output file created with 
Production Reporting Compiler or Production Reporting Studio, shows you how reports look 
on the printed page. A file viewed in Production Reporting Viewer must be in SPF format, 
which normally has an SPF or Snn extension.

➤ To run Production Reporting Viewer, perform an action:

● Select Start > Programs > Hyperion System 9 BI+ > Production Reporting Viewer.

● Enter this command:

SQRV [SPF Filename] 

Note: See the online help accessed from within Production Reporting Viewer, a Windows-only product.

Production Reporting Remote
Production Reporting Remote enables an application to connect to a server, submit and run 
Production Reporting programs remotely, receive report output, and transfer files. Production 
Reporting Remote, useful for running Production Reporting programs that contain large 
amounts of data, provides these benefits:

● Reduced network traffic

● Server execution that frees the PC for other applications

● Server-system processing power that typically exceeds the power of a local PC

Note: See “Using the Production Reporting ActiveX Control Remote” in Volume 2 of the Production Reporting Client 
User’s Guide.

Production Reporting Server
Production Reporting Server, a high-performance, server-based reporting environment, can 
handle high-volume reporting jobs and highly interactive reports. Using Production Reporting 
Server, you can publish information to the corporate intranet or extranet, process production 
reports, or populate a data warehouse or other large-scale database environment. 

Table 36 Production Reporting ActiveX Controls

 ActiveX Control Run Production Reporting programs on the local PC or on remote servers.

 Viewer ActiveX Control View and print reports and send reports to other people.

 Print ActiveX Control Print report output.
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Production Reporting Server includes three components:

● Production Reporting Language

● Production Reporting Engine

● Production Reporting DDO

Production Reporting Language
You use Production Reporting language to access, manipulate, and report enterprise data. You   
build complex procedures that execute multiple calls to multiple data sources and implement 
nested, hierarchical, or object-oriented program logic.

Note: See Volume 2 of the Production Reporting Server Developer’s Guide.

Production Reporting Engine
The Production Reporting engine includes three components:

● Production Reporting Compiler

● Production Reporting Execute

● Production Reporting Print

Production Reporting Compiler

Production Reporting Compiler translates source code written in Production Reporting 
language into a byte-code, machine-independent representation of the report code (SQT file) 
that can be transferred to any machine with Production Reporting Execute. Thus, with one 
compile, a report can run on any platform.

➤ To run Production Reporting Compiler, perform an action:

● Select Start > Programs > Hyperion System 9 BI+ > Production Reporting for 
[database] > Server.

● Enter this command. 

SQR [program][connectivity][flags...][args...][@file...]

Note: See the online help accessed from Production Reporting Compiler. 

Production Reporting Execute

You use Production Reporting Execute, a runtime program, to run previously compiled 
Production Reporting programs. The results generated by Production Reporting Execute (SPF 
files) are output-independent. Thus, one report execution can produce multiple outputs.
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➤ To run Production Reporting Execute, perform an action:

● Select Start > Programs > Hyperion System 9 BI+ > Production Reporting for 
[database] > Execute.

● Enter this command.

SQRT [program][connectivity][flags...][args...][@file...]

Note: See the online help accessed from Production Reporting Execute and see Volume 1 of the Production Reporting 
Server Developer’s Guide.

Production Reporting Print

You use Production Reporting Print to convert portable, printer-independent files (SPF) into 
printer-specific files for all file types supported by Production Reporting.

➤ To run Production Reporting Print, perform an action:

● Select Start > Programs > Hyperion System 9 BI+ > Production Reporting for 
[database] > Print.

● Enter this command:

SQRP [spf-file] [flags...]

Note: See the online help accessed from Production Reporting Print.

Production Reporting DDO
Production Reporting DDO (Direct Data Objects) provides an open interface for data access, 
allowing applications to extract data from vastly different data sources. The KPI Management 
Workspace Software Development Kit (SDK) provides the technical resources for building 
drivers with the special interface knowledge to access data sources.

Note: For detailed information on Production Reporting DDO, see Volume 3 of the Production Reporting Server 
Developer’s Guide.

Overview of Design Features in Interactive Reporting

Interactive Reporting provides an easy-to-navigate environment for data exploration and 
decision making in a Web-server-based reporting system. A consistent design paradigm for 
query, pivot, charting, and reporting enables users at any level to move fluidly through 
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cascading dashboards—finding answers fast. Trends and anomalies are highlighted, and users 
use robust formatting tools to build free-form, presentation-quality reports for broad-scale 
publishing across their organization.

 Features of Interactive Reporting:

● Cross-platform and cross-browser support

● Secure and centralized source for distribution and updates of Interactive Reporting 
documents (.bqys)

● Ad-hoc or “on the fly” querying of business data

For information about Interactive Reporting features, see the Hyperion System 9 BI + 
Workspace User’s Guide. For information about in-depth, Interactive Reporting Studio tasks, 
see the Hyperion System 9 BI + Interactive Reporting Studio User’s Guide.

Understanding Interactive Reporting Documents
Documents created in Workspace, Interactive Reporting Studio, or Interactive Reporting Web 
Client are known as Interactive Reporting documents (.bqys). The documents focus on data 
from queries (either relational or OLAP) or imports. Any number of queries and data models 
can supply document data. Documents can contain multiple queries, with queries retrieving 
their data from different databases (relational databases, local files, imported files and OLAP 
servers). 

In Workspace, end users cannot see data-models, but they can refresh data that comes from 
data model sources. End users can duplicate queries and create queries based on master data 
models.

After documents are created, they are saved and imported to the repository on the server. 

When the Interactive Reporting user selects and retrieves a document from a document list, 
the emphasis changes from document viewing, refreshing, and analyzing to document query, 
data model, layout, and report building. Each Interactive Reporting document can consist of 
one or more sections, such as charts or pivot tables. 

Creating an Interactive Reporting Document 

➤ To create a document:

1 From Workspace, select File > New Document.

The Step 1: Select a Task wizard is displayed.

2 Select Create a document. 

The Step 2: Select Data Source wizard is displayed.

3 Enter the data-source name or browse to locate the data source, and click Next.

Verify that the object type is Interactive Reporting by changing Type to Interactive Reporting 
document. 
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To go to the Preference setting, which determines the default directory for data-source files, 
select Explore > New Document Folder.

If you cannot locate the folder, ask your administrator where in the repository it is located.

4 Click Finish.

Accessing a Document

➤ To open a Workspace document:

1 Specify the Workspace URL in your Web browser.

The Hyperion System 9 BI+ Workspace login dialog box is displayed. 

2 Enter your user name and password, and select Login.

3 Open a document:

● From the Explore module, by navigating to the document and double clicking it

● By selecting the document and clicking Open on the shortcut menu

● By selecting File > Open

● By selecting Favorites and selecting the document (if the document is in Favorites)

The document opens in Workspace. If the document includes a Dashboard section, the 
document is displayed in creation-date order. Typically, a Dashboard section is shown first. If 
no Dashboard section is included, the document opens to the section in creation-date order. If 
the last saved section is a query or data model or fails for some reason, the document attempts 
to open the next section from Section pane, working from the top to the bottom of Section 
pane until a section can be displayed.

➤ To close a document, select File > Close.

If you modify a document, you are prompted to save changes.

Saving Documents
To ensure that document changes, subsequent to analysis, are preserved, use the Save features 
to save documents to the repository (importing). To save documents locally, see Exporting 
Documents in Native File Format.

Saving an Interactive Reporting Document to the Hyperion System 9 BI + 
Repository
You can save modified Interactive Reporting documents and jobs to the repository. The 
repository is an efficient way to manage documents and distribute documents over a wide 
network for end-user query and reporting. 
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You save modified documents to the repository by simply saving the documents (Save) or by 
saving the documents as new documents (Save As). If you do not have permission to overwrite 
a document, you must use Save As.

➤ To save to the repository, select File > Save.

You can also click the Save icon on the Interactive Reporting toolbar.

➤ To save as to the repository:

1 Select File > Save As.

The Save As dialog box is displayed.

2 For Name, enter a document name.

3 Optional: For Description, enter a document description. 

4 Click the Save icon.

Working with Document Sections
Because Interactive Reporting documents are integrated query, analysis, and reporting tools, 
they have multiple sections, each of which governs one part of the query and reporting refresh. 
You create sections progressively as you query a database, retrieve results, and generate reports. 

Each section occupies an independent window and performs distinct operations. You can 
move between sections at any time to rebuild your query or alter result data. 

Interactive Reporting end-users do not need a strong technical understanding of databases. 
Data Model sections are not available and not visible in the Section pane. Each visible section 
occupies an independent window in the browser and shows discrete data views. For example, 
the Pivot section resembles a spreadsheet or crosstab report and enables drill-down, data-
relationship analysis. The Chart section graphically depicts data summaries, trends, and 
relationships.

The default home page of a document is the Dashboard section. For information on using 
document sections

● Section Pane

● Selecting Document Sections

● Adding Sections

● Moving Between Sections

● Duplicating Sections

● Renaming Sections

● Deleting Sections

● Refreshing Document Sections

● Printing Sections

● Dashboard Home
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Section Pane 
The Section pane shows the sections available in the current document:

● Dashboard—Provides commands that perform actions such as retrieve data, populate 
controls, hide objects, navigate between sections, and specify report parameters

● Report—Enables viewing of high-quality, professionally designed reports that range from 
complex, critical operational reports to Results sets, charts, and pivot tables and that help 
you evaluate your business, expand communications, and make decisions

● Query— Enables a relational-database connection and download of a prebuilt query or 
data model (foundation of the Interactive Reporting document)

● Results—Displays in table columns data that Workspace retrieves in response to a query 
refresh.

● Pivot—Summarizes, or cross-tabulates large amount of data (You can rotate rows and 
columns to see data-source summaries and to display data details.

● Chart—Provides a fully interactive, two- or three-dimensional data view that provides 
powerful ways to visually analyze data 

● Table—Displays data in columns (as a single-dimension report), often used in other 
sections as a building block

● OLAPQuery—Used to connect to multidimensional databases

By default, an Interactive Reporting document has at least one Query and one Results section.

Selecting Document Sections
The Section pane displays sections associated with the document.

➤ To select a section, select it from the Sections pane.

➤ To scroll through a section, use the scroll bar on the right side of the browser.

Adding Sections
Section additions are based on query and results sets.

➤ To insert a section into a document, select Actions > Insert > (New Section).

For example, to insert a chart, select Actions > Insert > Chart; to insert a table, select Actions > 
Insert  > Table.

Workspace inserts the section and adds a section label (based on the type of section) to the 
Section pane. Workspace appends a sequence number, if needed to prevent duplicate names.
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Moving Between Sections
You can easily navigate between sections to work on queries, results, and reports.

➤ To move between sections, select the target section from the Section pane.

If necessary, use the scrollbar to move vertically through the Section pane.

Duplicating Sections
A duplicated section retains all content and formatting of the original section. The new section 
label, which is added to the Section pa ne, is the original section label with an appended 
sequence number. For example, if you duplicate a section named SalesChart three times, the 
Section pane shows SalesChart, SalesChart2, SalesChart3, and SalesChart4.

➤ To duplicate a section:

1  In the Section pane, select the section.

2 From the shortcut menu, select Duplicate; or, select Edit > Section > Duplicate.

Renaming Sections
The first section of a type is given the default section name, for example, Query or Results. 
Additional sections of a type are numbered sequentially, for example, Query2, Results2, and so 
on. To assign unique names, use the Rename command.

➤ To rename a section:

1 In the Section pane, select the section to be renamed.

2  On the shortcut menu, select Rename; or select Edit > Section > Rename. 

The Input Section Name dialog box is displayed.

3 Enter the new name, and click OK.

Deleting Sections
You can delete sections. However, some sections are dependent on other sections, so you may 
delete sections that you do not want to delete. You cannot restore deleted sections.

➤ To delete a section:

1 In the Section pane, select the section.

2 On the shortcut menu, select Delete; or select Edit > Section > Delete.

The Confirm Deletion dialog box is displayed.

3 Click OK.



Exporting Data   111

Dashboard Home
A customized Dashboard section can be displayed as a document home page. Each dashboard 
button and item selection and navigation sequence can invoke a script. Behind the scenes, 
Workspace refreshes Dashboard script commands that perform actions such as retrieve data, 
populate controls, hide objects, navigate between sections, and specify report parameters. 

➤ To go to Dashboard home, click Dashboard Home on the Interactive Reporting toolbar.

Refreshing Document Sections
You refresh document sections to retrieve the most current data from the database. The 
Refresh command can be used in any query reporting section. When data is refreshed in one 
section, it is refreshed in all sections.

By default, Workspace uses the Refresh Current command (refreshes the current object) in all 
sections except Dashboard and Report. In some cases, multiple queries may be refreshed, if, for 
example, a report references results sets from multiple queries. 

In Dashboard and Report sections, Workspace uses the Refresh All command to refresh all 
queries. Although queries are not visible to end-users, they are executed in the order in which 
they are displayed in the section catalog in the full client version. For example, in a document 
with three queries, Query1, Query2, and Query3, the queries are executed in numeric order. 

If a variable filter is set for a query, filter selections must be resolved before the query is 
refreshed. The user is prompted to select or enter filter values and complete the constraint.

➤ To refresh a section, click the Refresh icon on the Interactive Reporting toolbar.

Printing Sections
Sections are printed to PDF files and launched inside your browser if the PDF MIME type is set 
in the browser. If the PDF MIME type is not set in the browser, the browser Save As dialog box 
is invoked. PDF files can be viewed online or hard-copy printed.

Note: A Query section cannot be printed.

➤ To export a document to PDF, select File  > Print via PDF, or click the Export to PDF icon.

Tip: Printing and exporting to PDF are equivalent features.

Exporting Data
You can save Interactive Reporting documents as PDF or Excel files or in native file format.
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Exporting a Section as a PDF
Exporting sections to Portable Document Format (.PDF) provides several benefits:

● Preserve layout and format

● Transfer layout and format across multiple platforms (such as Windows, Unix, and the 
Macintosh)

●  Save, print, and distribute files easily and effectively 

To display and print PDF files, you must have Adobe® Acrobat® Reader™ installed. Acrobat 
Reader is a self-contained application that can behave as an Internet Browser plug-in or a 
stand-alone application. 

Acrobat Reader enables you to view, print, and share PDF files but not to create or modify files. 
Acrobat Reader is free and can be downloaded from Adobe’s Web site. 

You may need to configure your browser to use Acrobat Reader. For example, you may need to 
associate Acrobat Reader as the application to read PDF files or display PDF files in a separate 
window. You open PDF files by double-clicking them in Explore. 

To save a PDF to your desktop for offline viewing, click the Acrobat Reader Save as Copy icon 
on the Acrobat Reader toolbar, and, when prompted, specify the directory in which to save the 
file. 

To print a PDF, click the Acrobat Reader Print icon, and, when prompted, specify print 
parameters and print.

If Acrobat Reader is not installed, the File Download dialog box is displayed. You can save the 
file to disk and open it from a specified location. 

➤ To export a document to PDF, select File > Print via PDF or click the Export to PDF icon.

Exporting Sections to Excel (.XLS)
You can export a section to Excel and launch it inside your browser if the mime type is set to 
recognize the XLS file extension. Then, you can save the file locally and work with the data 
directly in Excel. If the mime type is not set to recognize the XLS file extension, you are 
prompted to specify a local destination to which to save and from which to use the XLS file. 

➤ To export a document to Excel (XLS):

1 Click the Export to XLS icon.

If the mime type is set to recognize .XLS, the section is launched in Excel. Otherwise, the Save 
As dialog box is displayed.

2 If the Save As dialog box is displayed, for File Name, enter a name. 

3 Select Microsoft Excel Workbook (.XLS) in the Save as Type field.

4 Select Save.
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Exporting Documents in Native File Format
When a document is exported in native file format, Workspace determines whether Interactive 
Reporting Web Client is installed and, if so, launches the document in a browser. Interactive 
Reporting Web Client is an application file located in a Web browser plug-in direction. Plug-
ins add seamless functionality to Web browsers, enabling browsers to open plug-in file types as 
if they were HTML files. 

Document changes are not replicated to the original Interactive Reporting document, which 
was selected from the document list in the repository, resides on the server, and can be 
changed only by re-importing.

➤ To export a file in native file format, select File > Export > Native File Format.

If Interactive Reporting Web Client is installed, it is launched. You can make changes and save 
the document to the repository. If you do not permission to overwrite the document, you can 
use the Save To Repository As command to rename and save it. 

If Interactive Reporting Web Client is not installed, the File Download dialog box is displayed. 
You can open the document from its current location or export the file to disk and open the 
document from a specified location.
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Glossary

access control A security mechanism that manages a 

user’s privileges or permissions for viewing, modifying, 

and importing files or system resources. 

access privileges The level of access-for example, view, 

modify, run, full control-that the importer of an item 

grants to others. 

accountability map A visual, hierarchical representation 

of the responsibility, reporting, and dependency structure 

of your organization. An Accountability map depicts how 

each accountability team in your organization interacts to 

achieve strategic goals. An accountability team is also 

known as a critical business area (team, department, office, 

and so on. 

action A task or group of tasks executed to achieve one or 

more strategic objectives. In a Hyperion Performance 

Scorecard application, each action box represents an 

activity or task that helps to accomplish a strategic 

objective. Each action is usually assigned measures. 

actions Job output definitions for an Interactive 

Reporting job is defined in terms of a series of actions. 

active group A group that is entitled to access the system. 

active service A service whose Run Type is set to Start 

rather than Hold. 

active user A user who is entitled to access the system. 

active user/user group The user or user group identified 

as the current user by user preferences. Determines default 

user preferences, dynamic options, access, and file 

permissions. You can set the active user to your user ID or 

any user group to which you belong. 

adaptive states Interactive Reporting level of permission. 

There are six levels of permission: view only, view and 

process, analyze, analyze and process, query and process, 

and datamodel and analyze. 

aggregate cell A cell comprising several cells. For example, 

a data cell that uses Children(Year) expands to four cells 

containing Quarter 1, Quarter 2, Quarter 3, and Quarter 4 

data. 

aggregate limit A limit placed on an aggregated request 

line item or aggregated metatopic item. 

alias An alternative name. 

Analysis Server Web Analysis Server. An application 

server program that distributes report information and 

enables Web client communication with data sources. 

Analyze The main Web Analysis interface for analysis, 

presentation and reporting. 

appender A Log4j term for destination. 

application A program running within a system. 

application server A middle-tier server that is used to 

deploy and run Web-based application processes. 

asymmetric analysis A report characterized by groups of 

members that differ by at least one member across groups. 

The number and names of members can differ. 

attribute Characteristics of dimension members that are 

not stored in the data source but calculated on demand. 

You can select, group, or calculate members that have a 

specified attribute. For example, an Employee Number 

dimension member may have attributes of Name, Age, or 

Address.

attribute dimension A type of dimension that enables 

analysis based on the attributes or qualities of dimension 

members. 

authentication service A core service that manages one 

authentication system. 
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authentication service repository (ASR) A database that 

contains a complete model of users/groups in an external 

system. 

authentication system A security measure designed to 

validate and manage users and groups. 

axis A two-dimensional report aspect used to arrange and 

relate multidimensional data, such as filters, pages, rows, 

and columns. 

bar chart A chart that can consist of one to 50 data sets, 

with any number of values assigned to each data set. Data 

sets are displayed as groups of corresponding bars, stacked 

bars, or individual bars in separate rows. 

batch POV A collection of all the dimensions on the user 

POV of every report and book in the batch. While 

scheduling the batch, you can set the members selected on 

the batch POV. 

book A container that holds a group of similar Financial 

Reporting documents. Books may specify dimension 

sections or dimension changes. 

book POV The dimension members for which a book is 

run. A book is a collection of Financial Reporting 

documents that may have dimensions on the User POV. 

Any dimension on a report’s user POV is added to the 

book POV and defined there. The member for a 

dimension on the book POV can be one of the following 

items: (a) User POV. This means the member is set by the 

end user just before the book is run. (b) A specific 

member. If a specific member is chosen, then the selection 

is stored in the book definition and can only be altered in 

the Book Editor. (c) A set of member selections. A 

dimension left on the user POV of a report may be iterated 

over within the book. For example, a report may be run for 

four entities within one book. 

bookmark A link to a reporting document or a Web site, 

displayed on a personal page of a user. The two types of 

bookmarks are My Bookmarks and image bookmarks. 

bounding rectangle The perimeter that encapsulates the 

Interactive Reporting document content when embedding 

Interactive Reporting document sections in a personal 

page. It is required by the Interactive Reporting to generate 

HTML and is specified in pixels for height and width or 

row per page. 

calculation The process of aggregating data, or of running 

a calculation script on a database. 

calculation script A set of instructions telling Hyperion 

Essbase how to aggregate and extrapolate the values of a 

database. 

Catalog pane A pane displaying a list of elements available 

to the active section. For example, if Query is the active 

section, the Catalog pane displays a list of database tables. 

If Pivot is the active section, the Catalog pane displays a list 

of results columns. If Dashboard is the active section, the 

Catalog pane displays a list of embeddable sections, 

graphic tools, and control tools. 

categories Groupings by which data is organized (for 

example, month). 

cause and effect map A map that depicts how the 

elements that form your corporate strategy are interrelated 

and how they work together to meet your organization’s 

strategic goals. A Cause and Effect map tab is 

automatically created for each of your Strategy maps. 

cell A unit of data representing the intersection of 

dimensions in a multidimensional database; the 

intersection of a row and a column in a worksheet. 

chart A graphical representation of spreadsheet data. The 

visual nature of charts expedites analysis, color-coding, 

and visual cues that aid comparisons. There are many 

different chart types. 

chart cell value Appears in the lower right corner of a 

chart on pages in the Monitor and Investigate Sections. 

The Editor defines the chart cell value that you see in 

Enterprise Metrics. The chart cell value might display a 

metric on the chart, such as Booking $, or a calculation 

based on the metrics displayed on the chart, such as ratio 

of Booking $ to Forecast $.

chart column Enterprise Metrics Detail charts are 

displayed in columns below each Summary chart. 

Chart section With a varied selection of chart types, and a 

complete arsenal of OLAP tools like group and drill-down, 

the Chart section is built to support simultaneous graphic 

reporting and ad hoc analysis. 

Chart Spotlighter A feature that enables you to color-code 

charts based on some condition in Interactive Reporting 

Studio. 

chart template A template that defines the metrics to 

display in Workspace charts. 
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child A member that has a parent above it in the database 

outline. 

choice list A list of members that a report designer can 

specify for each dimension when defining the report’s 

point of view. A user who wants to change the point of 

view for a dimension that uses a choice list can select only 

the members specified in that defined member list or those 

members that meet the criteria defined in the function for 

the dynamic list. 

client A client interface, such as Web Analysis Studio or a 

workstation on a local area network. 

clustered bar charts Charts in which categories are viewed 

side-by-side within a given category; useful for side-by-

side category analysis. Clustering is only done with vertical 

bar charts. 

column A vertical display of information in a grid or 

table. A column can contain data from a single field, 

derived data from a calculation, or textual information. 

column heading A part of a report that lists members 

across a page. When columns are defined that report on 

data from more than one dimension, nested column 

headings are produced. A member that is listed in a 

column heading is an attribute of all data values in its 

column. 

computed item A virtual column (as opposed to a column 

that is physically stored in the database or cube) that can 

be calculated by the database during a query, or by 

Interactive Reporting Studio in the Results section. 

Computer items are calculations of new data based on 

functions, data items, and operators provided in the dialog 

box and can be included in reports or reused to calculate 

other data. 

connection file A file used to connect to a data source.

console The console is displayed on the left side of the 

Enterprise Metrics workspace. The console is context 

sensitive, depending on the page displayed. 

content Information stored in the repository for any type 

of file. 

content area The Contents pane appears on the right side 

of the Workspace and provides specific information for the 

page that you are using. 

cookie A small piece of information placed on your 

computer by a Web site. 

correlated subqueries Subqueries that are evaluated once 

for every row in the parent query. A correlated subquery is 

created by joining a topic item in the subquery with one of 

the topic items in the parent query. 

critical business area (CBA) An individual or a group 

organized into a division, region, plant, cost center, profit 

center, project team, or process; also called accountability 

team or business area. 

critical success factor (CSF) A capability that must be 

established and sustained to achieve a strategic objective. A 

CSF is owned by a strategic objective or a critical process 

and is a parent to one or more actions. 

cube The query result set from a multidimensional 

(OLAP) data source; a logically organized subset of OLAP 

database dimensions and members. 

custom calendar Any calendar created by an 

administrator. 

custom report A complex report from the Design Report 

module, composed of any combination of components. 

cycle A Interactive Reporting job parameter that is used 

when scheduled Interactive Reporting jobs need to process 

and produce different job output with one job run. 

Dashboard A collection of metrics and indicators that 

provide an interactive summary of your business. 

Dashboards enable you to build and deploy analytic 

applications. 

Dashboard Home A button that returns you to the 

Dashboard section designated as the Dashboard Home 

section. If you have only one Dashboard section, 

Dashboard Home returns to that section. If you have 

several Dashboard sections, the default Dashboard Home 

is the top Dashboard section in the Catalog pane. In 

Design mode, you can specify another Dashboard section 

to be the Dashboard Home section. 

data The values (monetary or non-monetary) associated 

with the query intersection. 

data function A function that computes aggregate values 

including averages, maximums, counts, and other 

statistics, that summarize groupings of data. You can use 

data functions to aggregate and to compute data from the 

server before it reaches the Results section, or compute 

different statistics for aggregated totals and items in the 

other analysis sections. 



118  Glossary 

data layout The data layout interface is used to edit a 

query, arrange dimensions, make alternative dimension 

member selections, or specify query options for the 

current section or data object. 

data model Any method of visualizing the informational 

needs of a system. 

data object A report component that displays the query 

result set. The display type of a single conventional data 

object can be set to spreadsheet, chart, or pinboard, and it 

displays OLAP query result sets. A SQL spreadsheet data 

object displays the result set of a SQL query, and the free-

form grid data object displays the result set of any data 

source included in it. 

data source 1. A data storage application. Varieties include 

multidimensional databases, relational databases, and files. 

2. A named client-side object connecting report 

components to databases. Data source properties include 

database connections and queries. 

database A repository within Essbase Analytics that 

contains a multidimensional data storage array. Each 

database consists of a storage structure definition 

(outline), data, security definitions, and optional scripts. 

database connection A file that stores definitions and 

properties used to connect to data sources. Database 

connections enable database references to be portable and 

widely used. 

database function A predefined formula in a database. 

default folder A user’s home folder. 

descendant Any member below a parent in the database 

outline. For example, in a dimension that includes years, 

quarters, and months, the members Qtr2 and April are 

descendants of the member Year.

Design Report An interface in Web Analysis Studio for 

designing custom reports, from a library of components. 

Desktop An interface that presents the icons to open 

items. 

detail chart A chart that provides the detailed information 

that you see in a Summary chart. Detail charts appear in 

the Investigate Section in columns below the Summary 

charts. For example, if the Summary chart shows a Pie 

chart, then the Detail charts below represent each piece of 

the pie. 

dimension A data category used to organize business data 

for retrieval and preservation of values. Each dimension 

usually contains a hierarchy of related members grouped 

within it. For example, a Year dimension often includes 

members for each time period, such as quarters and 

months.

dimension tab In the Pivot section, the tab that enables 

you to pivot data between rows and columns. 

dimension table 1. A table that includes numerous 

attributes about a specific business process. 2. In 

Enterprise Metrics, a table in a star schema with a single 

part primary key. 

display type One of three Web Analysis formats saved to 

the repository: spreadsheet, chart, and pinboard. 

dog-ear The flipped page corner in the upper right corner 

of the chart header area. You can click the dog-ear to 

display a shortcut menu. The dog-ear is displayed only on 

charts in the Investigate Section. 

drill Allows you to investigate results reflected by a chart 

in the Investigate Section. You can click a chart that 

hyperlinks to a lower (more detailed) level in the 

Investigate Section. This concept is called “drilling.” 

drill anywhere A feature that enables you to drill into and 

add items to pivot reports residing in the Results section 

without returning to the Query section or trying to locate 

the item in the Catalog pane. Drill Anywhere items are 

broken out as new pivot label items. 

drill target The data to which you are drilling. Specifying 

a drill target automatically creates a hyperlink enabling you 

to click the chart to obtain additional detail. 

drill to detail A feature that enables you to retrieve items 

from a data model that are not in the Results section 

without rerunning the original query. This feature 

provides the ability to query the database interactively and 

filter the data that is returned. Drill-to-detail sets a limit on 

the query based on your selection and adds the returned 

value as a new pivot label item automatically. 
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drill-down Navigation through the query result set using 

the organization of the dimensional hierarchy. Drilling 

down moves the user perspective from general aggregated 

data to more detailed data. While default drill down 

typically refers to parent-child navigation, drilling can be 

customized to use other dimension member relationships. 

For example, drilling down can reveal the hierarchical 

relationships between year and quarters or between 

quarter and months.

drill-through The navigation from a data value in one 

cube to corresponding data in another cube. For example, 

you can access context-sensitive transactional data. Drill 

through occurs usually from the lowest point of atomicity 

in a database (detail) to a next level of detail in an external 

data source.

dynamic report A report containing current data. A 

report becomes a dynamic report when you run it. 

Edit Data An interface for changing data values and 

sending edits back to Essbase Analytics. 

employee Users responsible for, or associated with, 

specific business objects. Employees do not necessarily 

work for an organization, such as an analyst or consultant. 

An employee must be associated with a user account for 

authorization purposes. 

ending period The ending chart period allows you to 

adjust the date range shown in the chart. For example, an 

ending period of “month” produces a chart that shows 

information through the end of the current month.

exceptions Values that satisfy predefined conditions. You 

can define formatting indicators or notify subscribing 

users when an exception has been generated. 

external authentication Logging on to Hyperion 

applications by means of user information stored outside 

the application, typically in a corporate authentication 

provider such as LDAP or Microsoft Windows NTLM. 

externally triggered events Non-time-based events that 

are used to schedule job runs. 

Extract, Transform, and Load Data source-specific 

programs that are used to extract and migrate data to an 

application. 

extrapolation A means of showing projected figures. 

Extrapolation from the current date to the end of the 

current period is displayed on Enterprise Metrics charts 

with a white area of the bar. If a line chart shows 

extrapolation, the line that is extrapolated is dotted. 

fact table The central table in a star join schema, 

characterized by a foreign key and elements drawn from a 

dimension table. This table typically contains numeric 

data that can be related to all other tables in the schema. 

filter A filter is used to limit data. While every dimension 

in the cube must participate in every intersection, you can 

make filter selections that focus the intersections on a 

smaller portion of the cube. For example, in Interactive 

Reporting Studio use a filter to exclude certain tables or 

data values. In Enterprise Metrics Studio implement a 

filter by adding a where clause on a join statement. 

folder A file that contains other files for the purpose of 

ordering and structuring a hierarchy. 

footer The text or images that are displayed at the bottom 

of each page in a report. A footer can contain a page 

number, date, company logo, document title or file name, 

author name, and so on. Footers can contain dynamic 

functions as well as static text. 

format The visual characteristics of a document or a 

report object. 

free-form grid A data object that present OLAP, 

relational, and manually entered data together and enables 

you to leverage all these data sources in integrated dynamic 

calculations. 

generic jobs Jobs that are neither Production Reporting 

nor Interactive Reporting jobs. 

grid POV A means for specifying members for a 

dimension on a grid without placing the dimension on the 

row, column, or page intersection. A report designer can 

set the POV values at the grid level, preventing the user 

POV from affecting that particular grid. If a dimension has 

only one value for the entire grid, the dimension should be 

put into the grid POV instead of the row, column, or page.

group A construct that enables the assignment of users 

with similar system access requirements. 
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grouping columns A feature in the Results and Table 

sections that creates a new column in a dataset by grouping 

data from an already existing column. Grouping columns 

consolidate nonnumeric data values into more general 

group values and map the group values to a new column in 

the dataset. 

header The text or images that are displayed at the top of 

each page in a report. A header can contain a page number, 

date, company logo, document title or file name, author 

name, and so on. Headers can contain dynamic functions 

as well as static text. 

highlighting Depending on your configuration, you may 

see highlighting applied to a chart cell value or ZoomChart 

detail values. A value can be highlighted in red (indicating 

the value is bad), yellow (indicating that the value is a 

warning), or green (indicating the value is good). 

host A server on which applications and services are 

installed. 

host properties Properties pertaining to a host, or if the 

host has multiple Install_Homes, to an Install_Home. The 

host properties are configured from the LSC. 

hyperlink A link to a file, Web page, or an HTML page on 

an intranet. 

Hypertext Markup Language A programming language 

of tags that specify how Web browsers display data. 

image bookmarks Graphic links to Web personal pages or 

repository items. 

implied share A member with only one child, or a 

member with multiple children of which only one child is 

consolidated. For this reason the parent and child share the 

same value. 

inactive group A group that cannot access the system 

because an administrator has inactivated it. 

inactive service A service that has been placed on hold or 

excluded from the list of services to be started. 

inactive user A user who cannot access the system because 

an administrator has inactivated the user account. 

Install_Home A variable name for the path and directory 

where Hyperion applications are installed. Refers to a 

single instance of a Hyperion application when multiple 

applications have been installed on the same machine. 

Interactive Reporting document sections Divisions of a 

Interactive Reporting document that are used to display 

and analyze information in different formats (such as 

Chart section and Pivot section). 

Interactive Reporting files or jobs Files created by 

Interactive Reporting and published into the repository as 

files or as jobs. Files and jobs have different capabilities. 

intersection A unit of data representing the intersection of 

dimensions in a multidimensional database; also, a 

worksheet cell. 

Java Database Connectivity A client-server 

communication protocol used by Java based clients and 

relational databases. The JDBC interface provides a call-

level API for SQL-based database access. 

job output Files or reports produced from running a job. 

job parameters The compile time and runtime values 

necessary to run a job. 

job parameters Reusable, named job parameters that are 

accessible only to the user who created them. 

jobs A collection of documents that have special 

properties and can be executed to generate output. A job 

can contain Interactive Reporting documents, Production 

Reporting documents or generic documents. 

join A link between two relational database tables based 

on common content in a column or record or a relational 

database concept indicating a link between two topics. A 

join typically occurs between identical or similar items 

within different topics. Joins enable row records in 

different tables to be linked on the basis of shared 

information in a column field. For example, a row record 

in the Customer table is joined to a related record in the 

Orders table when the Customer ID value for the record is 

the same in each table. This enables the order record to be 

linked with the record of the customer who placed the 

order. If you request items from unjoined topics, the 

database server has no way to correlate the information 

between the two tables and leads to awkward datasets and 

run-on queries.

join path A predetermined join configuration for a data 

model. Administrators create join paths for users to select 

the type of data model needed in a user-friendly prompt 

upon processing a query. Join paths ensure that the correct 

tables in a complex data model are used in a query. 
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JSP Java Server Pages

layer Stack a single object in relative position (sends back 

and front, or brings forward or backward) to other objects. 

legend box An informative box containing color-keyed 

labels to identify the data categories of a given dimension. 

level A hierarchical layer within the database outline or 

tree structure. 

line chart A chart that displays one to 50 data sets, with 

automatic, uniform spacing along the X-axis. Each data set 

is rendered by a line. A line chart can optionally shows 

each line set stacked on the preceding ones, using either 

the absolute value or a normalized value from 0 to 100 

percent. 

link Link files are fixed references to a specific object in 

the repository. Links can reference folders, files, shortcuts, 

and other links using unique identifiers. Links present 

their targets in the current folder, regardless of where the 

targets are located or how the targets are renamed. 

linked data model Documents that are linked to a master 

copy in a repository. When changes are made to the 

master, users are automatically updated with the changes 

when they connect their duplicate copy to the database. 

linked reporting object A cell-based link to an external 

file in the Analytic Services database. Linked reporting 

objects can be cell notes, URLs, or files that contain text, 

audio, video, or pictures. Note that support of Analytic 

Services LROs in Financial Reporting applies only to cell 

notes at this time (by way of Cell Text functions).

local report object A report object that is not linked to a 

Financial Reporting report object in Explorer. 

local results Results of other queries within the same data 

model. These results can be dragged into the data model to 

be used in local joins. Local results are displayed in the 

catalog when requested. 

locked data model Data models that cannot be modified 

by a user. 

logger Log4j term for where the logging message 

originates; The class or component of the system in which 

a log message originated. 

LSC services The services that are configured with the 

Local Service Configurator. They include Global Services 

Manager (GSM), Local Services Manager (LSM), Session 

Manager, Authentication Service, Authorization Service, 

Publisher Service, and in some contexts, Data Access 

Service (DAS) and Interactive Reporting Service. 

Map Navigator A feature that displays your current 

position on a Strategy, Accountability or Cause and Effect 

map. Your current position is indicated by a red outline on 

the Map Navigator. 

master data model A data model that exists 

independently and has multiple queries that reference it as 

a source. When you use a master data model, the text 

“Locked Data Model” is displayed in the Content pane of 

the Query section. This means that the data model is 

linked to the master data model displayed in the Data 

Model section, which may be hidden by an administrator. 

MDX (multidimensional expression) The language used 

to give instructions to OLE DB for OLAP- compliant 

databases (MS Plato), as SQL is the language used for 

relational databases. When you build the OLAPQuery 

section’s Outliner, Intelligence Clients translate your 

requests into MDX instructions. When you process the 

query, MDX is sent to the database server. The server 

returns a collection of records to your desktop that answer 

your query. 

measures Numeric values in an OLAP database cube that 

are available for analysis. Measures may be margin, cost of 

goods sold, unit sales, budget amount, and so on. 

member A discrete component within a dimension. A 

member identifies and differentiates the organization of 

similar units. For example, a time dimension might 

include such members as Jan, Feb, and Qtr1.

member list A named group that references members, 

functions, or other member lists within a dimension. A 

member list can be system- or user-defined. 

metadata A set of data that defines and describes the 

properties and attributes of the data stored in a database or 

used by an application. Examples of metadata are 

dimension names, member names, properties, time 

periods, and security.
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metric A numeric measurement computed from your 

business data. Metrics help you assess the performance of 

your business and analyze trends in your company. For 

immediate and intuitive understanding, Enterprise 

Metrics metrics display visually in charts. 

MIME Type (Multipurpose Internet Mail Extension) An 

attribute that describes the format of data in an item, so 

that the system knows which application to launch to open 

the object. A file’s mime type is determined either by the 

file extension or the HTTP header. Plug-ins tell browsers 

what mime types they support and what file extensions 

correspond to each mime type. 

minireport A minireport is a component of a report, and 

includes layout, content, hyperlinks, and the actual query 

or queries to load the report. Each report can include one 

or more minireports. 

missing data A marker indicating that data in the labeled 

location either does not exist, contains no meaningful 

value, or was never entered. 

model In Shared Services, a file or string of content 

containing an application-specific representation of data. 

Models are the basic data managed by Shared Services. 

Models are of two types: dimensional hierarchies, and 

nondimensional application objects. Dimensional 

hierarchies include information such as entities and 

accounts. Nondimensional application objects include 

security files, member lists, calculation scripts, and web 

forms. 

multidimensional database A method of organizing, 

storing, and referencing data through three or more 

dimensions. An individual value is the intersection of a 

point for a set of dimensions. 

multithreading A client-server process that enables 

multiple users to work on the same applications without 

interfering with each other. 

native authentication The process of authenticating a user 

ID and password from within the server or application. 

note Additional information associated with a box, 

measure, scorecard or map element. 

null value A value that is absent of data. Null values are 

not equal to zero. 

OLAPQuery section A document section that analyzes 

and interacts with data stored in an OLAP cube. When you 

use Intelligence Clients to connect to an OLAP cube, the 

document immediately opens an OLAPQuery section. The 

OLAPQuery section displays the structure of the cube as a 

hierarchical tree in the Catalog pane. 

online analytical processing (OLAP) A 

multidimensional, multiuser, client-server computing 

environment for users who analyze consolidated enterprise 

data in real time. OLAP systems feature drill-down, data 

pivoting, complex calculations, trend analysis, and 

modeling. 

Open Catalog Extension Files (OCE) files Files that 

encapsulate database connection information. OCE files 

specify the database API (ODBC, SQL*Net, etc.), database 

software, the network address of the database server, and 

your database username. Administrators create and 

publish OCE files. 

origin The intersection of two axes. 

page A display of information in a grid or table often 

represented by the Z-axis. A page can contain data from a 

single field, derived data from a calculation, or text. 

page member A member that is displayed on the page 

axis. 

palette A JASC compliant file with an extension of PAL. 

Each palette contains 16 colors that complement each 

other and can be used to set the color elements of a 

dashboard. 

performance indicator An image file used to represent 

measure and scorecard performance based on a range you 

specify; also called a status symbol. You can use the default 

performance indicators or create an unlimited number of 

your own. 

period A time interval that is displayed along the x-axis of 

a chart. Periods might be days, weeks, months, quarters or 

years. 

personal pages Your personal window to information in 

the repository. You select what information to display, as 

well as its layout and colors. 

personal recurring time events Reusable time events that 

are accessible only to the user who created them. 

personal variable A named selection statement of 

complex member selections. 
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perspective A category used to group measures on a 

scorecard or strategic objectives within an application. A 

perspective can represent a key stakeholder (such as a 

customer, employee, or shareholder/financial) or a key 

competency area (such as time, cost, or quality). 

pie chart A chart that shows one data set segmented in a 

pie formation. 

pinboard One of the three data object display types. 

Pinboards are graphics, composed of backgrounds and 

interactive icons called pins. Pinboards require traffic 

lighting definitions. 

pins Interactive icons placed on graphic reports called 

pinboards. Pins are dynamic. They can change images and 

traffic lighting color based on the underlying data values 

and analysis tools criteria. 

plot area The area bounded by the X, Y, and Z axes; For 

pie charts, the rectangular area immediately surrounding 

the pie. 

predefined drill paths Paths that enable you to drill 

directly to the next level of detail, as defined in the data 

model. 

presentation A playlist of Web Analysis documents. 

Playlists enable reports to be grouped, organized, ordered, 

distributed, and reviewed. Presentations are not reports 

copied into a set. A presentation is a list of pointers 

referencing reports in the repository. 

primary measure A high-priority measure that is more 

important to your company and business needs than many 

other measures. Primary measures are displayed in the 

Contents frame and have Performance reports. 

private application An application for the exclusive use of 

an product to store and manage Shared Services models. A 

private application is created for a product during the 

registration process. 

Production Reporting A specialized programming 

language for data access, data manipulation, and creating 

Production Reporting documents. 

property Characteristics of an object, such as size, color, 

type. 

proxy server A server that acts as an intermediary between 

a workstation user and the Internet to ensure security. 

public job parameters Reusable, named job parameters 

created by an administrator and accessible to users who 

have the requisite access privileges. 

public recurring time events Reusable time events created 

by an administrator and accessible through the access 

control system. 

range A set of values that includes an upper and lower 

limit, and the values that fall between the limits. A range 

can consist of numbers, amounts, or dates. 

reconfigure URL URL used to reload servlet 

configuration settings dynamically when a user is already 

logged in to the Workspace. 

recurring time event An event that specifies a starting 

point and the frequency for running a job. 

relational database A database that stores its information 

in tables related or joined to each other by common pieces 

of information called keys. Tables are subdivided into 

column fields that contain related information. Column 

fields have parents and children. For example, the 

Customer table may have columns including Name, 

Address, and ID number. Each table contains row records 

that describe information about a singular entity, object, 

or event, such as a person, product, or transaction. Row 

records are segmented by column fields. Rows contain the 

data that you retrieve from the database. Database tables 

are linked by Joins. (See also join.) 

report footer See footer.

report header See header.

report object A basic element in report designs. Report 

objects have specific properties that define their behavior 

or appearance. Report objects include text boxes, grids, 

images, and charts.

Reports section A dynamic, analytical report writer, that 

provides users with complex report layouts and easy-to-

use report-building tools. Pivot tables and charts can be 

embedded in a report. The report structure is divided into 

group headers and body areas, with each body area 

containing a table of data. Tables are created with 

dimension columns and fact columns. These tables are 

elastic structures. Multiple tables can be ported into each 

band, each originating from the same or different result 

sets. 
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request line A line that holds the list of items requested 

from the database server and that will appear in the user’s 

results. 

request line items Columns listed in the request line. 

resources Objects or services that the system manages. 

Examples of a resource include a role, user, group, file, job, 

publisher service, and so on. 

result A value that an application collects for measures. If 

you have the required permissions, you can use the Result 

Collection report to enter or modify measure results. 

result frequency The algorithm used to create a set of 

dates for either the collection of data (collection 

frequency) or the display of data (result frequency). The 

result frequency’s algorithm is defined by: Major type (for 

example, weekly, monthly, and so on.) Minor type (for 

example, first, last, last Friday, 5th day of period, and so 

on.) Interval (for example, every one, every two, every 5, 

and so on.)

Results section A section in an Interactive Reporting 

document that contains the dataset derived from a query. 

Data is massaged in the Results section for use in the 

report sections. 

role A construct that defines the access privileges granted 

in order to perform a business function; for example, the 

job publisher role grants the privilege to run or import a 

job. 

row heading A report heading that lists members down a 

report page. The members are listed under their respective 

row names. 

RSC services The services that are configured with the 

Remote Service Configurator. They include Repository 

Service, Service Broker, Name Service, Event Service, and 

Job Service. 

scale The range of values on the Y axis of a chart. 

scale code Specification of how an individual metric or 

minireport field is scaled. It may be displayed in 

thousands, or multiplied by 100 in conjunction with a 

percent format. 

schedule Specify the job that you want to run as well as 

the time and job parameter list for running the job. 

score The level at which specified targets are being 

achieved. It is usually expressed as a percentage of the 

target for a given time period. 

scorecard Business Object used to represent the progress 

of an employee, strategy element, or accountability 

element toward specific goals. Scorecards ascertain this 

progress based on the data collected for each measure and 

child scorecard you add to the scorecard. 

scorecard report A report that presents the results and 

detailed information about scorecards attached to 

employees, strategy elements, and accountability elements. 

secondary measure A low-priority measure that is less 

important to you than primary measures. Secondary 

measures do not have Performance reports but can be used 

on scorecards and to create dimension measure templates. 

Section pane Lists all the sections that are available in the 

current Intelligence Client document. 

security agent A Web access management solutions 

provider employed by companies to protect Web 

resources; also known as Web security agent. The Netegrity 

SiteMinder product is an example of a security agent. 

security platform A framework enabling Hyperion 

applications to use external authentication and single sign-

on using the security platform driver. 

security rights Rights defined by a user’s data access 

permissions and activity-level privileges as explicitly 

defined for a user and as inherited from other user groups. 

services Resources that provide the ability to retrieve, 

modify, add, or delete business items. Some services are 

Authorization, Authentication, Global Service Manager 

(GSM). 

servlet A piece of compiled code executable by a Web 

server. 

Servlet Configurator A software utility for configuring all 

of the locally installed servlets. 

shortcut A pointer to an actual program or file that is 

located elsewhere. You can open the program or file 

through the shortcut, if you have permission. 

shortcut menu A menu that is displayed when you right-

clicks a selection, an object, or a toolbar. A shortcut menu 

lists commands pertaining only to that screen region or 

selection. 
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sibling A child member at the same generation as another 

child member and having the same immediate parent. For 

example, the members Florida and New York are both 

children of East and siblings of each other.

Single Sign-On A feature that enables you to access 

multiple Hyperion products after logging on just once 

using external credentials. 

SmartCut A link to an item in the repository in the form 

of a special URL. 

snapshot Read-only data from a specific point in time. See 

snapshot report.

snapshot report A report that has been generated and that 

stores static data. Any subsequent change of the data in the 

data source does not affect the report content. A snapshot 

report is portable and can be stored on the network, 

locally, or e-mailed. See snapshot.

sort Reorder or rank result sets in ascending or 

descending order. 

sort order An indicator specifying the method by which 

you want your data to be presented. Data is typically 

shown in one of two sort orders. Ascending sort order 

presents data from lowest to highest, earliest to latest, first 

to last, A to Z, and so on. Descending sort order presents 

data from highest to lowest, latest to earliest, last to first, Z 

to A, and so on.

SPF files Printer-independent files created by an 

Production Reporting server that contains a representation 

of the actual formatted report output, including fonts, 

spacing, headers, footers, and so on. 

spreadsheet One of the three data object display types. 

Spreadsheets are tabular reports of rows, columns, and 

pages. 

SQL spreadsheet A data object that displays the result set 

of a SQL query. 

stacked charts A chart where the categories are viewed on 

top of one another for visual comparison. This type of 

chart is useful for subcategorizing within the current 

category. Stacking can be used from the Y and Z axis in all 

chart types except pie and line. When stacking charts the Z 

axis is used as the Fact/Values axis. 

Start in Play The quickest method for creating a Web 

Analysis document. The Start in Play process requires you 

to specify a database connection, then assumes the use of a 

spreadsheet data object. Start in Play uses the highest 

aggregate members of the time and measures dimensions 

to automatically populate the rows and columns axes of 

the spreadsheet. 

strategic objective (SO) A long-term goal defined for an 

organization that is stated in concrete terms whose 

progress is determined by measuring results. Each strategic 

objective is associated with one perspective in your 

application, has one parent, the entity, and is a parent to 

critical success factors or other strategic objectives. It also 

has measures associated with it. 

Strategy map A detailed representations of how your 

organization translates its high-level mission and vision 

statements into lower-level, constituent strategic goals and 

objectives. 

structure view A view that displays a topic as a list of 

component items allowing users to see and quickly select 

individual data items. Structure view is the default view 

setting. 

Structured Query Language The language used to give 

instructions to relational databases. When you build the 

Query section’s Request, Limit, and Sort lines, Interactive 

Reporting translate your requests into SQL instructions. 

subscribe Register an interest in an item or folder, in order 

to receive automatic notification whenever the item or 

folder is updated. 

subset A group of members selected by specific criteria. 

substitution variable A variable that acts as a global 

placeholder for information that changes regularly. You set 

the variable and a corresponding string value; the value 

can be changed at any time. 

Summary chart A chart that is displayed at the top of each 

chart column in the Investigate Section and plots metrics 

at the summary level, meaning that it rolls up all of the 

Detail charts shown below in the same column. All colors 

shown in a stacked bar, pie, or lines Summary chart also 

appear above each Drill button of the Detail charts and 

extend across the row, acting as the key. 

super service A special service used by the 

startCommonServices script to start the RSC services. 
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table The basic unit of data storage in a database. 

Database tables hold all of the user-accessible data. Table 

data is stored in rows and columns. 

Table catalog A display of the tables, views, and synonyms 

to which users have access. Users drag tables from the Table 

catalog to the Content pane to create data models in the 

Query section. 

Table section The section used to create tabular-style 

reports. It is identical in functionality to the Results 

section, including grain level (table reports are not 

aggregated). Other reports can stem from a Table section. 

target The expected result for a measure for a specified 

period of time, such as a day, quarter, month and so on. 

You can define multiple targets for a single measure. 

time events Triggers for execution of jobs. 

time scale A scale that enables you to see the metrics by a 

specific period in time, such as monthly or quarterly. 

token An encrypted identification of one valid user or 

group existing on an external authentication system. 

toolbar A series of shortcut buttons providing quick 

access to the most frequently used commands. 

top and side labels In the Pivot section, the column and 

row headings on the top and sides of the pivot. These 

define categories by which the numeric values are 

organized. 

top-level member A dimension member at the top of the 

tree in a dimension outline hierarchy, or the first member 

of the dimension in sort order if there is no hierarchical 

relationship among dimension members. The top-level 

member name is generally the same name as the 

dimension name if a hierarchical relationship exists. 

trace level A means of defining the level of detail captured 

in the log file. 

traffic lighting Color-coding of report cells, or pins based 

on a comparison of two dimension members, or on fixed 

limits. Traffic lighting definitions are created using the 

Web Analysis Traffic Light Analysis Tool. 

transparent login A mechanism that enables users who 

have been previously authenticated by external security 

criteria to log in to a Hyperion application, bypassing the 

login screen. 

trend How the performance of a measure or scorecard has 

changed since the last reporting period or a date that you 

specify. 

trusted password A password that enables users who have 

been previously authenticated in another system to have 

access to other applications without reentering their 

passwords. 

trusted user A user authenticated by some mechanism in 

the environment. 

Uniform Resource Locator The address of a resource on 

the Internet or an intranet. 

variable A value that can be modified when you run a 

report. String variables are useful for concatenating two or 

more database columns. Numeric variables can calculate 

values based on other values in the database. Encode 

variables are string variables that contain nondisplay and 

other special characters. 

variable limits Limits that prompt users to enter or select 

limit values before the queries are processed on the 

database. 

Web server Software or hardware hosting intranet or 

Internet Web pages or Web applications. This term often 

refers to the Interactive Reporting servlets’ host, because in 

many installations, the servlets and the web server software 

reside on a common host. This configuration is not 

required, however; the servlets and the web server software 

may reside on different hosts. 

weight A value assigned to an item on a scorecard that 

indicates the relative importance of that item in the 

calculation of the overall scorecard score. The weighting of 

all items on a scorecard accumulates to 100%. For 

example, to recognize the importance of developing new 

features for a product, the measure for New Features 

Coded on a developer’s scorecard would be assigned a 

higher weighting than a measure for Number of Minor 

Defect Fixes. 

ws.conf A configuration file for Windows platforms. 

wsconf_platform A configuration file for UNIX 

platforms. 
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Y axis scale The range of values on the Y axis of the charts 

displayed in the Investigate Section. You can use a unique 

Y axis scale for each chart, the same Y axis scale for all 

Detail charts, or the same Y axis scale for all charts in the 

column. Often, using a common Y axis improves your 

ability to compare charts at a glance. 

Zero Administration A software tool that identifies the 

version number of the most up-to-date plug-in on the 

server. 

zoom A feature that sets the magnification of a report. 

The report can be magnified to fit the whole page, page 

width or a percentage of magnification based on 100%. 

ZoomChart A feature that makes it easy to view detailed 

information by enlarging a chart displayed on a page in the 

Monitor or Investigate Section. Zooming in on a chart 

enables you to see detailed numeric information on the 

metric that is displayed in the chart. You can click the + 

(plus sign) in the lower right corner of the chart or right-

click anywhere on the chart to enlarge it. 
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Index

Symbols
.bqy, 106

A
accessing modules, 40

accessing relational data, 37

Actions Menu, commands defined, 58

adding

sections, 109

adding documents to favorites, 41

Administer Module toolbar, buttons defined, 53

advanced member selection

overview

analysis framework, 84

analysis tools

definitions

disabling, 98

enabling, 98

overview, 98

Traffic Lighting, 99

Analysis Tools Manager

toolbar, 98

api toolkit, 71

audience for this guide, vii

B
basics, Personal Pages, 42

basics,Personal Pages, 42

Batch Editor toolbar, buttons defined, 50

Book Editor toolbar

buttons defined, 49

bookmarks

defined, 47

My, 47

BQY files, 106

Broadcast Messages, Personal Page element, 47

browsers

Dimension Browser, 95

C
charts

As of Date tick marks, 86

chart cell values in, 86

Enterprise Metrics, 86

command line

running Production Reporting, 104

running Production Reporting Execute, 105

running Production Reporting Print, 105

running SQR Print, 103

commands, Help menu, viii

connectivity, 104

consulting services, x

contents, document, 81

Controlling the size of the query result set, 37

creating documents, in Workspace, 38 to 39

D
data

accessing relational, 37

time series, 86

data management, 83

data source

elements, 32

overview, 32

SAP BW, 36

selecting for a document, 40

database connections, Planning Details, 36

deleting sections, 110
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Designer

capabilities, 91

creating new reports, 101

preferences, 90

resources, 90

Dimension Browser

overview, 95

dimension members

selecting with Dimension Browser, 95

dimensions

browsing, 95

moving, 76

swapping, 76

document sections. See sections.

documents

accessing, 107

contents of, 81

conventions used, ix

feedback, x

processing, 111

saving, 107

structure of, vii

understanding, 106

documents, accessing

Hyperion Download Center, viii

Hyperion Solutions Web site, viii

Information Map, viii

online help, viii

drilling

overview, 77

E
Edit Menu

commands defined, 56

education services, x

EIS Home, 111

Enterprise Metrics

charts, 86

managing business with, 83

managing data with, 83

workspace, 85

Exit command, 56

Explore Module toolbar

buttons defined, 52

F
favorites

adding documents, 41

overview, 46

removing documents, 41

Favorites Menu,commands defined, 57

features

Financial Management, 36

File Menu,commands defined, 54

file properties, 41

Financial Management

features extended through Web Analysis, 36

overview, 36

studio features, 36

Financial Reporting Studio

database connections, 36

overview, 34

Financial Reporting toolbar,buttons defined, 49

Firefox

status bar, 13

folder tree, defined, 43

Format Menu,commands defined, 61

framework, analysis, 84

G
granularity, 87

guide, Quick Start, 31

H
Help menu commands, viii

Help Menu defined, 64

Help menu,commands defined, 64

Home Page See start page

Hyperion Consulting Services, x

Hyperion Download Center

accessing documents, viii

Hyperion Education Services, x

Hyperion product information, x

Hyperion support, x

Hyperion Technical Support, x

I
image bookmark, Personal Page elements, 47

Intelligence Client sections See sections.
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Intelligence Clients

analysis and reporting, 82

Interactive Reporting Studio, overview, 35

Interactive Reporting toolbar,buttons defined, 50

interface, described, 79

intersections, paging through, 73, 76

L
links, graphic, 47

locally saving documents, 107

M
managing business, 83

managing data, 83

member selection

advanced. See advanced member selection.

moving between sections, 110

moving files, 41

My Bookmarks

defined, 47

N
Native File Format, 113

navigation

methods, 75

O
opening

documents, 30, 40

files, 30

folders, 30

opening reports, 80

P
Page Setup options, 56

paging through intersections, 73, 76

Performance Scorecard toolbar,buttons defined, 52

Personal Pages, basics of, 42

personal pages, overview, 46

planning

designer, 90

Planning Details ADM driver, 36

plug-in, 107

prerequisites for using this guide, vii

prerequisites, SAP BW, 36

Print Preview, described, 55

printing documents, 40

Production Reporting

Print ActiveX Control, 103

Viewer ActiveX Control, 103

Production Reporting Execute, 105

Production Reporting Print, 105

Production Reporting Studio, overview, 35

products

designing, 89

Q
query, definition, 82

Quick Start Guide, 31

R
relational data, access, 37

removing documents to favorites, 41

renaming sections, 110

report menu commands, 55

reporting, 82

reports

changing display types for, 73

creating, 101

designing new, 101

drilling to detail, 77

opening, 80

setting options, 80

viewing snapshot, 80

repository

overview, 30

user preferences, 30

role, access control, 31

S
SAP BW

conventions, 36

data source, 36

prerequisites, 36

saving documents, 107

saving files locally, 113

schedule module, using the, 43



132  Index T

A  B  C  D  E  F  G  H  I  J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

Scheduler Module toolbar,buttons defined, 52

Section Navigation drop-down menu, 108

sections

adding, 109

deleting, 110

moving between, 110

renaming, 110

security restrictions, 87

selecting

dimension members, 95

Selecting Dimension Members, 96

server tools

Production Reporting Execute, 104

Production Reporting Print, 105

setting file properties, 41

setting preferences, user interface, 32

Smart View, usage with Microsoft Office, 44

SmartCuts

e-mail notifications, 53

snapshot reports

viewing, 80

SQL

definition, 82

SQRT, 104

standard query languages, 82

Standard toolbar, 48

start page

overview, 79

starting tasks, 38

status bar

Firefox, 13

Structured Query Language (SQL), 82

system toolbars, described, 48

T
task, starting, 38

tasks

designer, 90

technical support, x

time series data, 86

toolbars

buttons defined, 48

buttons, defined, 48

Standard, 48

Tools Menu,commands defined, 63

Traffic Lighting analysis tool

overview, 99

U
UI, overview of, 79

user interface

defined, 28

setting preferences, 32

user interface, overview of, 79

user types and tasks, Workspace, 21

using data source elements, 32

V
View Menu,commands defined, 57

view pane, buttons defined, 21

viewer module, using the, 44

Viewer, snapshot reports, 80

viewing, PDF reports, 13

W
Web Analysis Studio,overview, 34

Web Analysis toolbar,buttons defined, 49

window, described, 79

Workspace

accessing modules, 20

author overview, 19

capabilities, 20

consumer overview, 19

creating documents, 38 to 39

deployment tasks, 16

documentation set, 14

file permissions, 31

fundamental tasks, 20

logging on, 31

module tasks, 24

module usage, 20

modules, 17

personalizing, 45

setting preferences, 32

starting tasks, 38

user interface, 28

user types and task, 21

viewing PDF reports, 13

workspace, 85

modules, 11
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