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Welcome

This guide provides installation instructions for installing all of the products in the BEA AquaLogic
®
 BPM 6.0 Suite.

This guide is written for the user responsible for installing AquaLogic BPM. The AquaLogic BPM Suite includes the
following products:

• BEA AquaLogic BPM Studio
• BEA AquaLogic BPM Enterprise Server - Standalone
• BEA AquaLogic BPM Enterprise Server - BEA WebLogic
• BEA AquaLogic BPM Enterprise Server - IBM WebSphere

To install an Enterprise edition, and especially the WebLogic and WebSphere editions, you should have strong knowledge
of the platform operating system and the database and directory service systems required for installation.
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BEA Documentation and Resources

This section describes other documentation, resources, support, and training information provided by BEA.

The table below lists a number of BEA Documentation and Resources which will help you get started with AquaLogic
BPM. The latest version of all documentation is always available at http://edocs.bea.com/albsi/docs60/index.html

DescriptionResource

This guide describes how to configure AquaLogic BPM. It is available in three versions:Configuration Guide

• Standalone Edition
• WebLogic Edition
• WebSphere Edition

These files are written for AquaLogic BPM administrators. They include information about
new features and known issues in the release. They are available at
http://edocs.bea.com/albsi/docs60/relnotes/rel_notes_AquaLogic_BPM_6_0_0.htm.

Release Notes

The online help is written for all levels of users. It describes the AquaLogic BPM user interface
and gives detailed instructions for completing tasks in AquaLogic BPM. To access online
help:

Online Help

• In Studio, select Help ➤ Help Contents to access the complete ALBPM Studio help.
Context help is also available by pressing the F1 key, or by selecting Help ➤ Dynamic
Help from the menu.

• In WorkSpace, click on Help in the title bar, or click on the help icon (  ) in the title
bar of any panel for help about that panel.

The AquaLogic BPM Support Center is a comprehensive repository for technical information
on AquaLogic BPM products. From the Support Center, you can access products and

AquaLogic BPM Support Center

documentation, search knowledge base articles, read the latest news and information, participate
in a support community, get training, and find tools to meet most of your AquaLogic BPM
related needs. The Support Center encompasses the following communities:

Technical Support Center

Submit and track support incidents and feature requests, search the knowledge base, access
documentation, and download service packs and hotfixes. If you do not see the Support Center
when you log in to http://support.plumtree.com, contact ALBPMsupport@bea.com for the
appropriate access privileges.

User Group

Visit the User Group section to collaborate with peers and view upcoming meetings.

Developer Center

The BEA AquaLogic BPM Suite Developer Center features articles, blogs, and newsgroups
which will help you make the most out of ALBPM.

Product Center

Download products, read Release Notes, access recent product documentation, and view
interoperability information.

BEA Education

Find information about available training courses, purchase training credits, and register for
upcoming classes.

Download developer tools and documentation, get help with your development project, and
interact with other developers via BEA's dev2dev Newsgroups.

dev2dev.bea.com
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DescriptionResource

If you cannot resolve an issue using the above resources, BEA Technical Support is happy to
assist. Our staff is available 24 hours a day, 7 days a week to handle all your technical support
needs.

E-mail: ALBPMsupport@bea.com

Technical Support

Phone Numbers:

U.S. and Canada: +1 415 263 1696 or +1 866 262 7586

EMEA (Europe, Middle East, and Africa): +44 1494 559127

Australia / New Zealand: +61 2 9923 4030

Asia Pacific: +61 2 9931 7822

Singapore: +1 800 1181 202
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Installation Prerequisites

Before you run the BEA AquaLogic BPM installer, you should complete the steps described here.

1. Read the product release notes for information on compatibility issues, known problems, and workarounds that
might affect how you proceed with your deployment.

2. Provision host computers and configure software dependencies for your deployment. For details, see Hardware and
Software Requirements.

3. If you will be integrating ALBPM with the AquaLogic User Interaction suite, see AquaLogic User Interaction Support
on page 11 for specific requirements.

Supported Operating Systems
Operating system support is specific to each product in the AquaLogic BPM suite. A table for each product is presented
in this section.

Studio

• Microsoft Windows XP SP2 (x86-32)
• Microsoft Windows 2003 Server SP1 or R2 (x86-32), and SP2
• Novell SUSE Linux 10.0 (x86-32)
• Red Hat Enterprise Linux 4 (x86-32)

Enterprise Standalone

• Microsoft Windows Server 2003 SP1 or R2 (x86-32), and SP2
• Novell SUSE Linux 10.0 (x86-32, x86-64, IA-64)
• Red Hat Enterprise Linux 4.x (x86-32, x86-64, IA-64)
• IBM AIX 5.3
• Sun Solaris 9 and 10 (SPARC)
• HP-UX 11.23 and 11.31 (IA-64)

Enterprise for WebLogic

• Microsoft Windows Server 2003 SP1 or R2 (x86-32), and SP2
• Novell SUSE Linux 10.0 (x86-32, x86-64, IA-64)
• Red Hat Enterprise Linux 4.x (x86-32, x86-64, IA-64)
• IBM AIX 5.3
• Sun Solaris 9 and 10 (SPARC)
• HP-UX 11.23 and 11.31 (IA-64)

Enterprise for WebSphere

• Microsoft Windows Server 2003 SP1 or R2 (x86-32), and SP2
• Novell SUSE Linux 10.0 (x86-32, x86-64, IA-64)
• Red Hat Enterprise Linux 4.x (x86-32, x86-64, IA-64)
• IBM AIX 5.3
• Sun Solaris 9 and 10 (SPARC)
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Supported Virtualization Systems
AquaLogic BPM Enterprise supports virtualization systems in several architectures.

The following systems are supported:

• VMware ESX
• Solaris 10 Containers (Zones) *
• AIX Dynamic Logical Partitioning (LPAR) *
• Microsoft Windows Virtual Server

* Denotes configurations where there is a parallel, non-virtualized system requirement for full support. We will answer
support questions through normal channels for customers running portal systems under these virtualization configurations,
but should we be unable to replicate an issue on a non-virtualized platform, and the issue is not otherwise known, the
customer will be requested to reproduce the problem on a parallel, non-virtualized system.

Required Java Virtual Machines
32-bit Windows and Linux versions of all ALBPM components include the JVM. In other versions, however, you need
to make sure a compatible JVM is installed.

The following Java Virtual Machines are required for each component and platform combination:

Studio

JVMPlatform

Sun JVM 1.5.0_11 (included)Windows XP SP2 and Windows 2003
Server (x86-32) SP1 or R2

Sun JVM 1.5.0_11 (included)Novell SUSE Linux 10.0, Red Hat
Enterprise Linux 4 (x86-32)

Enterprise Standalone

JVMPlatform

Sun JVM 1.5.0_11 (included)Windows 2003 Server (x86-32) SP1 or
R2

Sun JVM 1.5.0_11 (included)Novell SUSE Linux 10.0 (x86-32), Red
Hat Enterprise Linux 4 (x86-32)

Sun JVM 1.5.0_11Novell SUSE Linux 10.0 (x86-64), Red
Hat Enterprise Linux 4 (x86-64)

JRockit 1.5Novell SUSE Linux 10.0 (IA-64), Red
Hat Enterprise Linux 4 (IA-64)

Sun JVM 1.5.0_06 (or above)Sun Solaris 9 and 10 (SPARC)

HP-UX JVM 1.5.0_05HP-UX (IA-64)

1.5.0 SR2 64 bitsIBM AIX 5.3
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Enterprise WebLogic

JVMPlatform

Sun JVM 1.5.0_11x (included)Windows 2003 Server (x86-32) SP1 or
R2

Sun JVM 1.5.x (included)Novell SUSE Linux 10.0 (x86-32), Red
Hat Enterprise Linux 4 (x86-32)

Sun JVM 1.5.0_06 (or above)Sun Solaris 9 and 10 (SPARC)

HP-UX JVM 1.5.0_05HP-UX 11.23 (IA-64)

IBM 1.5.0 SR2 64 bitsIBM AIX 5.3

Enterprise WebSphere

JVMPlatform

IBM 1.5.0 SR2Windows 2003 Server (x86-32) SP1 or
R2

IBM 1.5.0 SR2Novell SUSE Linux 10.0 (x86-32), Red
Hat Enterprise Linux 4 (x86-32)

IBM 1.5.0 SR2Sun Solaris 9 and 10 (SPARC)

IBM 1.5.0 SR2IBM AIX 5.3

Required Database
All ALBPM Enterprise editions require a database to store directory information and process execution engine data.
This database can be accessed over the network or locally installed. Studio uses a built-in database and does not have
this requirement.

The following database systems are supported:

• Oracle 9i and 10g
• Oracle 9i and 10g with RAC (Real Application Clusters) Option
• Microsoft SQL Server 2005
• DB2 UDB 8.1 and 9.1

Note: You do not need to use the same database provider for directory information and process execution engine
data.

Database Drivers

You do not need to provide the JDBC database drivers for the databases above. All ALBPM Enterprise editions include
BEA certified JDBC drivers in the installation. You do not need to install them manually.

Users of ALBPM for WebLogic should note that BEA WebLogic server also includes the required JDBC drivers.

IBM WebSphere does not include the JDBC drivers, but the drivers in the ALBPM installation can be manually installed
in WebSphere. See the Configuration Guide for further information.

Distributed Transactions with WebLogic Server and Microsoft SQL Server

Support for distributed transactions, also referred to as XA support, is not enabled by default with Microsoft SQL Server.
In order to enable JDBC distributed transactions through JTA (Java Transaction API), you must install Microsoft SQL
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Server JDBC XA stored procedures. To do this, follow the instructions found in the Installing Stored Procedures for
JTA section within the MS SQL Server Driver topic of the BEA WebLogic Server 9.2 Documentation.

Database Character Sets

ALBPM uses Unicode in order to support multiple languages.

If you are using a DB2 database, make sure it is configured for Unicode, using either the UTF-8 or UTF-16 encoding
forms.

No special configuration is needed for Oracle and Microsoft SQL Server databases because, in these cases, ALBPM
explicitly defines its table column types to use Unicode.

Required Hardware
The tables in this section summarize the hardware requirements for BEA AquaLogic BPM.

Most current systems can run both the Studio and Enterprise BPM products. The following are minimum recommended
configurations intended for development or simple low-volume production configurations.

For sizing information with more complex configurations, such as clusters, WebSphere and WebLogic support, high
numbers of concurrent users, or different processor architectures such as Itanium, consult with ALBPM Professional
Services.

RequirementConfiguration

Recommended:Studio

• 2 GB RAM or more
• 4 GB or greater free disk space
• 1.8 GHz or faster Pentium Core Duo CPU or similar

Minimum:

• 1 GB RAM
• 2.5 GB or greater free disk space
• 1.5 GHz Pentium M CPU or similar

Recommended:

For high-volume deployment (more than 500 concurrent users), consult with ALBPM
Professional Services.

Enterprise Standalone

For testing and low volume deployment (up to 500 concurrent users):

• 4 GB RAM or more
• 5 GB or greater free disk space
• 2.0 GHz or faster Pentium Dual-Core Xeon CPU or similar

Minimum (testing only):

• 2 GB RAM
• 3 GB or greater free disk space
• 1.5 GHz Pentium M CPU or similar

See WebLogic or WebSphere sizing documentation.Enterprise WebLogic or WebSphere
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Supported Directory Services
AquaLogic BPM Enterprise can access directory information from a directory service, or can handle its own directory
information in a database. This section lists the supported directory services.

Note:  Remember that even if you use a directory service, a database is always required for ALBPM-specific
organization information such as roles and business parameters. See Required Database on page 8 for the list of
databases which can be used.

The following directory services are supported:

• Sun ONE System Directory Server 5.2
• MS Active Directory 2000 and 2003
• Hydrogen Service (for use with the AquaLogic User Interaction Portal)

Supported Application Servers
AquaLogic BPM Enterprise supports three different application servers, as described in this section. Note that the
Standalone Edition supports, but does not require, an external Web server.

Enterprise Standalone

The Standalone edition of ALBPM supports the built-in Tomcat application server, as well as WebLogic and WebSphere
servers by generating Web Archive (.war) files. The following versions are supported for all Enterprise applications
except Process Administrator, which runs only in the built-in Tomcat Servlet/JSP Container:

• Tomcat Servlet/JSP Container 5.5.15 (included with Enterprise)
• BEA WebLogic Server 9.2 (MP1 or MP2)
• BEA WebLogic Server 10.0
• IBM WebSphere 6.1.0.5 and 6.1.0.13

Note: ALBPM WorkSpace may not work with other 6.1.0.x versions of WebSphere due to the following IBM
WebSphere APARs:

• PK31883: JSF MyFaces navigation does not work correctly.
• PK50311: A NullPointerException is thrown due to the inability of the class loader to read META-INF/

directory resource.

Enterprise for BEA WebLogic

The following versions are supported for all Enterprise applications except Process Administrator, which runs only in
the built-in Tomcat Servlet/JSP Container:

• BEA WebLogic Server 9.2 (MP1 or MP2).
• BEA WebLogic Server 10.0.

ALBPM Engine can be deployed to the Advanced and Premium editions of WebLogic Server. BEA WebLogic Express
is not supported.

Enterprise for IBM WebSphere

The following versions are supported for all Enterprise applications except Process Administrator, which runs only in
the built-in Tomcat Servlet/JSP Container:
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• IBM WebSphere 6.1.0.5 and 6.1.0.13

Note: ALBPM WorkSpace may not work with other 6.1.0.x versions of WebSphere due to the following IBM
WebSphere APARs:

• PK31883: JSF MyFaces navigation does not work correctly.
• PK50311: A NullPointerException is thrown due to the inability of the class loader to read META-INF/

directory resource.

Supported Web Browsers
A Web browser is required to use the Web application components of AquaLogic BPM, such as WorkSpace and Process
Administrator. The most popular browsers are supported.

The following web browsers have been tested and are officially supported by ALBPM.

On Microsoft Windows:

• Microsoft Internet Explorer 6.0 and 7.0
• Mozilla Firefox 2.0

On Linux:

• Mozilla Firefox 2.0

On Apple Mac OS X

• Apple Safari 3.0.
• Mozilla Firefox 2.0

Required Plug-ins

Some of ALBPM WorkSpace functionality requires the Adobe Flash Plugin installed in your browser.

Screen Resolution

We recommend a minimum screen resolution of 1024 x 768 pixels.

Other considerations

You must disable any Pop-up Window blocker feature of your browser.

AquaLogic User Interaction Support
All editions of ALBPM Enterprise support integration with the BEA AquaLogic

®
 User Interaction suite. Specific ALUI

product versions are required.

Two components are required for ALUI integration, supported in the versions shown:

• AquaLogic Interaction 6.1 MP1
• AquaLogic Interaction Collaboration 4.2 MP1
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Studio

Studio is easy to install under most conditions. To avoid any difficulties, make sure your system complies with the
pre-requisites before you begin.

In general, Studio can be installed in a current Windows XP or 32-bit Linux system with no further requirements.
However, before installing Studio, you should check compliance with the following:

• Installation Prerequisites on page 6
• Required Hardware on page 9
• Supported Operating Systems on page 6

Note that Windows Vista is not supported for this version.

If using a platform other than Windows or 32-bit Linux, also check Required Java Virtual Machines on page 7.

Studio does not require a database or an application server to function, so you can ignore the requirements for those,
which apply to the Enterprise versions.

Installing Studio
This topic describes the steps required to install Studio.

To install Studio:

1. Obtain the installation file from the BEA AquaLogic BPM downloads page, and download AquaLogic BPM Studio
6.0 for your platform. If you are not registered, you will need to register with BEA in order to proceed with the
download.

2. Execute the installation file.
The installation program will prepare to proceed with the installation, and display the Introduction page of the
installation utility.

3. At the Introduction page, click Next.
The Choose Install Folder will appear.

4. In the Choose Install Folder, enter the path or select a folder where you will install Studio. If you've entered a path
but wish to use the installer's default, click on Restore Default Folder to obtain it. Click Next to proceed.

We recommend using the default folder path whenever possible, as this will help simplify support.

The Pre-Installation Summary page appears.

5. Verify the settings shown in the summary. If you need to make any changes, click Previous to go to the page where
you need to make the change. Once you are ready to proceed, click Install.
The installation is performed.

General Studio Installation Notes
This section contains information to help you avoid common problems when running Studio.

Web Application Port compatibility with ALBPM 5.7

By default, ALBPM Studio 6.0 uses port 8585 for Web Applications such as WorkSpace, while on Enterprise port 8686
is used, to avoid conflict. This means you can run Studio and Enterprise on the same machine at the same time with the
default configuration.
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However, In ALBPM 5.7, both Studio and Enterprise use port 8585. So if you are running Studio 6.0 and Studio or
Enterprise 5.7, a conflict will result. To avoid this situation, do the following:

1.
In Studio, in the Project Navigator, right-click on the project you will run and select Engine Preferences (  )
from the context menu.

2. In the Category list, select Engine.
3. In the General tab of the Engine properties, set the port in the Classic WorkSpace Port field. Make sure the value

does not conflict with other service ports in your system.
4. You must do this for each project you will run from Studio. Alternatively, you can change the ports in the ALBPM

5.7 component you are running.

Note: A port value between 8585 and 8599, such as 8586, will usually work. The port numbers page at the Internet
Assigned Numbers Authority Web site lists commonly used port numbers you should avoid. You can also avoid
ports being used in your system by listing them at the command line. Use netstat -a under Windows and netstat
-l under Linux.

Studio Installation Notes for Linux
This section provides additional information for running Studio under Linux.

Launching Studio

To start Studio from the command line execute the file .../albpm6.0/studio/eclipse/eclipse.

Additional Installation Steps

Depending on your Linux Distribution and version, you might need to complete the following additional steps to have
a fully functional installation of ALBPM Studio:

• You need to have Mozilla Firefox (version 1.5 or above) installed in your system. You must set the environment
variable MOZILLA_FIVE_HOME to your Firefox installation directory. In addition, you may need to prepend this
same directory to the LD_LIBRARY_PATH variable. Example, from a bash shell:

export MOZILLA_FIVE_HOME=/usr/lib/firefox export
        LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME:$LD_LIBRARY_PATH

• ALBPM Studio may not display process Activity icons correctly. This is due to a bug in the SWT libraries (Eclipse
bug: 150357). You can avoid this issue by editing the .../albpm6.0/studio/eclipse/eclipse.ini file,
adding the following line at the end of the file:

-Dfuego.ui.peer.swt.graphics.noAdvanced=true

Updating Studio
Follow this procedure to apply Maintenance Packs or Hotfixes to ALBPM Studio.

You initiate the Studio update procedure from within the Studio application.

Before updating Studio, check which version you currently have. On the main menu, click Help ➤ About BEA
AquaLogic BPM Studio.

To update Studio:

1. Using a Web browser, go to the BEA Downloads page and click AquaLogic BPM Patches. Download the update file
from the page, and save it to a local drive. Once downloaded, verify that the file has a .upd extension.
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2. In Studio, save all your changes using File ➤ Save All ( )

3. In the main menu, click File ➤ Updates > Studio Local Update
Studio displays a dialog box indicating that Studio will close in order to execute the update, and asks if you want to
continue.

4. Click Yes.
Studio closes and the Open dialog box is displayed.

5. Specify the update (.upd) file you downloaded in step 1, and click Open.
The update process will execute. When the update procedure is complete, Studio will restart.

6. Verify that you have updated to the expected revision by clicking Help ➤ About BEA AquaLogic BPM Studio.
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Enterprise

AquaLogic BPM Enterprise has additional requirements in comparison to Studio. You should make sure your environment
complies with the pre-requisites before you begin.

Enterprise can usually be installed in a current Windows XP or 32-bit Linux system, with no further requirements if it
will be used for testing and development. However, Enterprise is available in three editions, each of which has different
requirements. When an Enterprise edition is put into production, it can also serve a large number of users.

Before installing Enterprise, you should check compliance with the following:

• Installation Prerequisites on page 6
• Required Hardware on page 9
• Required Database on page 8
• Supported Operating Systems on page 6
• Supported Application Servers
• Supported Web Browsers on page 11

Note that Windows Vista is not supported for this version.

If using a platform other than Windows or 32-bit Linux, also check Required Java Virtual Machines on page 7.

Installing Enterprise
This section describes the steps required to install any edition of Enterprise.

To install any Enterprise edition:

1. Obtain the installation file from the BEA AquaLogic BPM downloads page, and download your desired edition of
AquaLogic BPM Enterprise 6.0 for your platform. If you are not registered, you will need to register with BEA in
order to proceed with the download.

2. Execute the installation file.

Note: To use an already installed Java VM, specify the full path to the java command passing the LAX_VM
parameter to the installer. You must always specify the location to an existing Java installation if a JVM is not
included with the installer (refer to Required Java Virtual Machines on page 7 for details). Example:

ALBPMEnterpriseSA603_sol.bin LAX_VM /usr/jdk1.5/bin/java

The installation program will prepare to proceed with the installation, and display the Introduction page of the
installation utility.

3. At the Introduction page, click Next.
The Choose Install Folder will appear.

4. In the Choose Install Folder, enter the path or select a folder where you will install Enterprise. If you've entered a
path but wish to use the installer's default, click on Restore Default Folder to obtain it. Click Next to proceed.

We recommend using the default folder path whenever possible, as this will help simplify support.

In Windows or 32-bit Linux, the Pre-Installation Summary page appears, and you should go to step 7. Otherwise,
the Choose J2SE 1.5 SDK page appears.

5. In the Choose J2SE 1.5 SDK page, select the Java 1.5 SDK installed in your system that you want Enterprise to
use. The installer will list those SDKs that it has detected. If you wish to specify a JDK that is not on the list, you
can click on Search for Others for an automatic search, or on Choose Another... to look for the SDK manually.
When you have selected the Java 1.5 JDK that you want, click Next.
The Pre-Installation Summary page appears.
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6. Verify the settings shown in the summary. If you need to make any changes, click Previous to go to the page where
you need to make the change. Once you are ready to proceed, click Install.
The installation is performed. Once it has finished, the Install Complete page appears.

7. In the Install Complete page, you can choose to exit the installer, to launch the Admin Center program, or to launch
the Configuration Wizard. If you exit, you can run the Admin Center at a later time. You can also execute the
Configuration Wizard from Admin Center.
In all cases, the installation utility will exit.

Enterprise is now installed in your system.

See the Admin Center Guide and the applicable Configuration Guide edition (Standalone, BEA WebLogic, or IBM
WebSphere), for further information on Enterprise configuration options.

Updating Enterprise
Follow this procedure to apply Maintenance Packs or Hotfixes to ALBPM Enterprise.

You perform the Enterprise update procedure from Admin Center.

Before updating Enterprise, check which version and edition you currently have. On the upper right corner of the main
window, click About.

To update Enterprise:

1. Using a Web browser, download the update file from the BEA Downloads page, and save it to a local drive. Once
downloaded, verify that the file has a .upd extension.

2. You cannot update Enterprise while BPM Web Applications are running. If the BPM Web Applications are running,

click Stop BPM Web Applications ( ).

Note:  If any process execution engines are running, you must also stop them in order to perform the upgrade.
First stop the engines from Process Administrator, and then stop the Web Applications from Admin Center.

Note:  If the updater service is running, you must also stop this service. In the Windows Services console, this
is called the ALBPM 6.0 DatawareHouse Service. In UNIX you must execute the following:

$ALBPM_HOME/bin$ ./albpmwarehouse.sh stop

Where ALBPM_HOME is the folder where Enterprise is located.

3. In the Admin Center main window, click Configuration ( ).
The Configuration dialog box will appear.

4. Click the rightmost tab, Service Pack Updates. You may need to click on the right arrow button so this tab comes
into view.

5. Click Local Update. If this button is disabled, you need to stop the BPM Web Applications.
The Open dialog box is displayed.

6. Specify the update (.upd) file you downloaded in step 1, and click Open.
The update process will execute, and Admin Center will automatically restart for the update to take effect.

7. If you have chosen to deploy ALBPM to an application server, the Engine, WorkSpace and other deployed ALBPM
J2EE applications will need to be re-generated and re-deployed to the application server container.

This is needed since these ALBPM applications use libraries that may have been patched on the installed Hotfix or
Maintenance Pack.

You can automate the generation of the ALBPM Application archives using ALBPM Ant Tasks scripts.

Follow this procedure to generate the ALBPM application archives manually:

a) Login to ALBPM Process Administrator. By default, it runs on http://host:8686/webconsole.
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b) Click on Engines and then click on the name of your J2EE ALBPM Engine.
You should see the configuration properties for your Engine.

c) Click on the Basic Configuration tab and then on J2EE Application Server Files.

This page allows you to (re)create the .ear files of those ALBPM applications associated with this Engine.

Note: When you access this page, the Process Administrator gets the status of each of the applications by
contacting ALBPM Deployer. You will get a warning message at the bottom of the page if there was any
problem contacting ALBPM Deployer. If this is the case, make sure the BPM Application Deployer URL
(within the Application Server tab) is correct and that ALBPM Deployer is up and running on your J2EE
server.

d) Click on the "new" icon ( ) next to each of the applications you want to install.
e) Click on the "install" icon ( ) next to each of the applications you want to install.

Attention: This may take several minutes. Do not click any link on the page and do back in your browser
until the page is automatically reloaded. When you click on the icon, ALBPM Process Administrator transfers
the file over to the J2EE server (by means of ALBPM Deployer) and the server goes through the application
installation process.

Once the update is complete, you may have to perform additional steps, particularly if you have deployed to an application
server. These steps will be described in the Release Notes.
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ALBPM Updates

ALBPM updates are available in two forms, Maintenance Packs and Hot Fixes.

Maintenance Packs

Each Maintenance Pack is numbered, and the number of the Maintenance Pack corresponds to the ALBPM revision
number. Maintenance Pack 1 is known as MP1, Maintenance Pack 2 is known as MP2, and so on. For ALBPM 6.0, the
software version that corresponds to each of these Maintenance Packs is 6.0.1, 6.0.2, and so on.

You must always apply a Maintenance Pack to the immediately previous version of the product. For example, you can
apply MP3 to ALBPM 6.0.2, but not to 6.0.1.

Hot Fixes

Hot Fixes are smaller than Maintenance Packs, and are released whenever an important issue must be corrected as soon
as possible. Hot Fixes are cumulative within a given Maintenance Pack revision, so there is always one current Hot Fix
for a given revision. You do not need to install previous Hot Fixes before installing the latest one.
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