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Purpose 

This document includes important, late-breaking information about this release of the Oracle® 

Hyperion Financial Data Quality Management, Fusion Edition (FDM) adapter for Oracle Hyperion 

Financial Management, Fusion Edition (Financial Management) and the FDM Intercompany adapter for 

use with Financial Management. Review this information thoroughly before installing the adapter. 
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Overview 

Standard Adapter 

The FDM adapter for Financial Management is a target adapter that allows users to load data from FDM 

into Financial Management. 

Intercompany Adapter 

FDM supports the loading of intercompany detailed transactions to Financial Management 

Intercompany Transaction Module. The FDM Intercompany adapter allows you to import, map, and 

load intercompany transactions at the invoice level. 

Date Created: 08/05/2011 

Adapter Versions: FM11X-G5-D1.xml (Financial Management) 

 FM11I-G5-D1.xml (Intercompany) 

Compatibility: See the FDM 11.1.1.4 Readme for FDM and Financial Management 

compatibility information. 

Key Features of the Intercompany Module 

 Imports, maps, and loads detailed intercompany transactional data to the Financial Management 

Intercompany Transaction Module. 
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 Supports all Financial Management Intercompany Transaction Module fields. 

 Automatically attaches scanned invoices as memo items to detailed lines when importing A/R 

extracts. 

 Employs the FDM standard validation reporting to verify that the intercompany transactions posted 

by the Intercompany Module match the ledger intercompany balances. 

 Uses all of the FDM standard features: 

- User interface 

- Workflow process 

- Mapping capabilities 

- Validation reporting 

- Audit trail features 
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Installation 

This section includes important information about installing this release of the FDM Adapter for 

Financial Management. 

> To add the Financial Management adapter to an FDM application: 

1. From FDM Workbench, open an FDM application. 

2. Select the Adapters tab. 

3. Select File > Import. 

The Open Metadata Import File dialog box is displayed. 

4. Perform an action: 

 To install the Financial Management adapter, browse to find the file named 

and click Open. 

 To install the Intercompany adapter, browse to find the file named  and 

click Open. 

5. Click OK. 

The FDM adapter for Financial Management or Intercompany is displayed in the list of imported 

target adapters. 

6. Select File > Register Adapter. 

 The Register Adapter dialog box is displayed. 

7. Browse to find the file named  and click Open. 

8. Click OK. 

9. Right-click on the adapter and select Configure. 

The FDM Adapter COM Admin screen is displayed. 

10. In the User Name, Password, Confirm Password, and Domain fields, enter the appropriate 

information for the FDM service account. 

This should be the same user used to configure the other FDM components. 

11. Click OK. 
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If the FDM application server component is installed on a machine without the FDM Workbench 

component, you must then set the identity on the COM+ adapter object to the service account 

being used for FDM by performing the following steps: 

12. Open the Windows Run window and enter . 

The Component Services window is displayed. 

13. Expand Component Services. 

14. Expand Computers. 

15. Expand My Computer. 

16. Expand COM+ Applications. 

17. Within COM+ Applications, find the adapter component (FM11xG5D1), right-click on the 

adapter object and select Properties. 

18. Select the Identity tab. 

19. Under Account, select This user. 

20. Enter the username and password of the service account used by FDM. 

21. Click OK. 
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Configuration 

> To configure the adapter: 

1. In FDM Workbench, from the Adapters tab, select the adapter. 

2. Right-click and select Options. 

 The Adapter Options dialog box is displayed. The Options menu enables you to select any of 

the options and change the option settings. 

3. Set the adapter options per the guidelines in the following table: 

 

Option Name Information Required 

Application Name 

(required) 

Name of Financial Management application in which to load data. 

Must be a valid name in the Financial Management Win32 Client. 

Logon Method Select 1-Unified or 2-Global. Default setting is 1 – Unified.  

When set to Global, the UserID and Password values in the Global 

Logon Information Integration Setting will be passed to Financial 

Management every time. 

When set to Unified, the UserID, Password, and Domain values used 

to log into FDM are passed to Financial Management. 

Global Logon Information UserID and password for that is passed to Financial Management 

(format UID;PW). Only used if Logon method is set to 2 – Global. 

Use SSO On/Off switch to enable Hyperion Single Sign-On. Enable this option 

if logging on to FDM from a Financial Management link. Because the 

Financial Management link does not pass a user name and 

password, this indicates to FDM to retain the token in memory to 

pass back to Financial Management when the Logon Method 

integration setting is set to 1 – Unified. Default setting is off. 

Note: SSO is required to enable drill through from Financial 

Management. 
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Option Name Information Required 

Use Sticky Server On/Off used to force usage of one server for Load, Consolidate, and 

Check. This enables the Financial Management application server 

cache delay. 

Enable this option to help circumvent the Financial Management 

Application Server Cache Delay. When enabling this option, each 

Financial Management application server that participates in the 

cluster found in the machine profile must to be registered as an 

individual cluster in the Financial Management Win32 Client 

consisting of the server name as the cluster name with the Use One 

Server Only option checked on all FDM Application Servers. Default 

setting is off. 

Enable Intersection 

Validation 

On/Off switch used to enable Financial Management intersection 

validation report during the Validation step of the FDM workflow. 

Default setting is on. 

FDM Web Server Name Name of Web server on which FDM Web client is running (required 

only when the Intersection Validation Report is enabled). 

Use SSL On/Off switch to enable FDM the Web server SSL indicator. Only 

required if FDM Web Server uses SSL.. Default setting is Off. 

Enable Load On/Off switch used to enable Load action (occurs when running 

Export of the FDM workflow) Default setting is on. 

Enable Line Item Detail 

Loading 

On/Off switch used to enable the loading of Line Item Detail into 

Financial Management. See the Financial Management 

documentation for additional information on Line Item Detail. 

Enable Drillable Region 

Load 

On/Off switch used to enable or disable the loading of drillable 

region data to the target application. Disabling this option can 

improve performance. If drillable region data is not loaded to the 

target application, then you must set the drillable region manually 

in the target application to enable drill-through functionality. 

Enable Multi-Load Zero 

Loading 

(standard adapter only) 

On/Off switch used to allow zeros to be exported during Multiload. 

Enable Journal Loading On/Off switch used to enable loading of journals into Financial 

Management. Default setting is off. See the Financial Management 

Documentation for additional information about Journals. 

Enable Cell Text Loading Used to enable and disable the information contained in FDM 

memos to be sent to Financial Management as Cell Text. See the 

Financial Management documentation for detailed information 

regarding Cell Text. Default setting is off. 

Enable Consolidation On/Off switch used to enable automatic consolidation of data in 

Financial Management. Consolidations are based on the information 

set up in the FDM Validation Entities. The default setting is on. 

Additional information regarding consolidations is included in the 

Financial Management documentation. 

Enable Validation Report Used to enable and disable the automatic publication of the final 

report during the Check step of the FDM process flow. Publication is 

based on the rules defined in the FDM validation rules. Default 

setting is on. 

Enable Controls Review On/Off switch used to enable Controls Review Integration action. 

Default setting is off. 
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Option Name Information Required 

Enable Process Mgmt On/Off switch used to enable Financial Management Process 

Promotion following the FDM Controls Submit action. Default setting 

is off. 

Enable Chain Load On/Off switch used to enable FDM Chain Load Integration action. 

Default setting is off. 

Enable Data Protection Used to enable and disable the FDM functionality that assists in 

protecting data values currently stored in Financial Management 

loaded from other sources which could potentially be deleted by 

means of the Replace option. Other data entry methods for Financial 

Management and Replace functionality design is included in the 

Financial Management documentation. Default setting is off. 

Protection Value The value that is to be protected during the Load stage when Enable 

Data Protection is enabled. The value in this field is to be a 

dimension value inside of Financial Management across any 

dimension. 

Protection Operator Select operator (= or <>). This is used only when Enable Data 

Protection is enabled. The option allows you to state that the data to 

be protected is equal (=) or not equal (<>) the “Protection Value.” 

Force Calculate On/Off switch used to enable calculation of cell prior to 

consolidation. Default setting is off. 

Force Translate On/Off switch used to enable Translation call prior to consolidation. 

Default setting is off. 

Translation Level Select Parent Currency, Parent Currency Total, Parent Currency Adj, 

Entity Currency, Entity Curr Total, or Entity Curr Adj). This option is 

only used when Force Translate is turned on.  Default setting is 

Parent Currency. 

Consolidation Type Select 0-Impacted, 1-All With Data, 2-All, 3-Entity Only, or 4-Force 

Entity Only.  Default setting is 0-Impacted. 

Line Item Detail Load 

Type 

Select 1-Summarized or 2-Load Detail.  This option is only used 

when Line Item Detail Loading is turned on.  Default setting is 2-

Load Detail. 

Journal Status This option is only used when Loading Journals. Select 1-Working, 

2-Submitted, 3-Approved, 4-Posted, or 5-Rejected. Default setting 

is 4-Posted. 

The value of Journal Status is the level the journals enter Financial 

Management. Detailed journal status information is included in the 

Financial Management documentation. 

Journal Default Data 

Value 

Select Contribution Adjs, Parent Adjs, Entity Curr Adjs, Parent Curr 

Adjs). This option is only used when Loading Journals. Default 

setting is <Entity Curr Adjs>. 

Journal Enable JV ID Per 

Entity 

On/Off switch used to control journal numbering (On = One ID for 

each entity in the POV, Off=One ID for all data in the POV). This 

option is only used when Loading Journals. Default setting is on. 

Journal Load Balancing 

Attribute 

Select B-Balanced, U-Unbalanced, or E-Balanced By Entity. This 

option is only used when Loading Journals. Default setting is U-

Unbalanced. 
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Option Name Information Required 

List All Periods Use this switch to enable and disable the listing of all periods from 

Financial Management into FDM to be used by the FDM Control 

Tables. By default (turned off), FDM only returns base-level periods 

for the FDM Control Tables. 

Load Method Select 0-Replace, 1-Merge, 2-Accumulate, or 3-Replace by 

Security). Default setting is 0-Replace. 

Load Operation Select 0-Load, or 1-Scan. Default setting is 0-Load. 

List2 (Not Used) n/a 

List3 (Not Used) n/a 

Calc Switch (Not Used) n/a 

Accumulate in File On/Off switch used to enable Calculate in File option. Default setting 

is on. 

File Has Ownership Data On/Off switch used to enable File Has Ownership Data option. 

Default setting is off. 

Status3 (Not Used) n/a 

Note: The order of items listed in the preceding table may not display in the same order in the 

FDM UI for the Intercompany adapter. 
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Single Sign-On Setup 

Important: This procedure is only required if you are running FDM and Financial Management without 

Shared Services. 

1. Create a Link to FDM in Financial Management  

a. From Hyperion Workspace, log in to a Financial Management application. 

b. Select Administration > Manage Documents. 

c. Click the Links tab. 

d. Click New. 

 The New Link page is displayed. 

e.  In the Link field, enter the following:  

AuthorizedPages/LogonPage.aspx?AppName=<xxxxxxxx>, where:  

•  is the web server address.  

•  will be HyperionFDM for 9.3.1 and higher. 

•  is the FDM application name (optional). 

f. Clear Tasklist opens link within same page. 

g. Check Include the Single Sign On information in page request. 

h. Click Save. 

i. Enter a name and description for the link and click OK. 

The New Link screen closes and returns to the previous screen. 

j. Click Cancel. 

The link to FDM now appears on the Manage Documents–Links screen. 
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2. Enable the FDM Load Balancer SSO Authentication Script 

a. From the FDM server, open the Load Balance Manager Configuration tool by selecting Start > 

All Programs > Oracle EPM System > Financial Data Quality Management > Load Balance 

Manager > Load Balance Configuration. 

b. From the Authentication Providers tab, click Add. 

The Add Authentication Provider dialog box is displayed. 

c. From the Add Authentication Provider dialog box, select Visual Basic Script SSO 

Authentication and click OK. 

The Visual Basic Script SSO Provider screen is displayed. 

d. In the Description field, enter a description. 

e. Delete the existing script contents and replace with the following: 

 

f. Add more statements as necessary. 

g. Click OK. 

The authentication providers are updated. 

h. From the General tab, re-enter the service account password and click OK. 

3. Enable FDM to Pass Back the SSO Token to the Target System 

a.  From FDM, select Administration > Integration Settings. 

The Integration Settings screen is displayed. 
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b.  From Options, select Use SSO. 

c.  Select On/Off. 

d.  Click Save. 
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Setting Up an Intercompany Location 

1. Log in to the FDM Workbench and import in the FDM intercompany adapter (xml file).*  

2. Configure machine profiles and integration settings using the same procedure for configuring the 

standard Financial Management adapter.* 

3. Redefine custom 1-4 dimensions as they are defined in the main Financial Management adapter. 

Disable the intercompany dimensions that will not be used (optional).  

 The intercompany adapter contains all the pre-defined Financial Management intercompany 

fields. 

4. Designate a FDM location as an intercompany detail location. 

 In the Locations screen, create a new location, and specify from Target Adapter the 

Intercompany adapter from the list. 

 When the Intercompany adapter has been assigned to a location, the location data will load to 

the Financial Management Intercompany Transaction Module upon export. 

5. Change the FDM POV to the intercompany location and build an import format to read in all the 

Financial Management intercompany fields from the source extract files.**  

 Multiple import formats may be required for the same location depending on source file format 

(A/P file and A/R file, for example) and an event script is required to switch import formats 

before the import event fires. 

 Assign the import format to the intercompany location. 

6. Build mapping tables for the intercompany location. 

 Mapping is also required for the pre-defined Financial Management intercompany fields. In most 

cases this would require a * to * map for the intercompany fields. 

7. Modify the existing  event script. This script attaches scanned invoices to the detail 

AR imported data by matching the invoice file names with the imported Transaction ID (optional). 

1. Import, validate, and export intercompany-detailed data to the Financial Management 

Intercompany Transaction Module. 
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Intercompany Module Process Overview 

1. Import detailed intercompany data files into a FDM intercompany location. 

2. Automatically attach scanned detail invoices to the imported source A/R intercompany detail lines. 

3. Validate and fix mapping errors. 

4. Export and load intercompany data into Financial Management Intercompany Transaction Module. 

5. Perform matching and posting process within the Financial Management Intercompany Transaction 

Module for specified entities. 

6. Investigate any non-matching transactions by reviewing details in the offsetting intercompany FDM 

location. Can review attached invoices if they were linked to the A/R intercompany source data 

lines during the import process. 
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Optional Steps 

7. Perform normal GL import and load for associated non-intercompany FDM location.  

8. Map general ledger intercompany accounts to Financial Management statistical accounts. 

9. Run FDM validation report to verify that the intercompany account balances loaded using the 

Financial Management Intercompany Transaction Module tie out to the GL intercompany account 

balances loaded to statistical accounts. 
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Known Issues 

HFM Intercompany Adapter XML  

Problem: Data records contain the transaction amount and all required fields, but the  

line in the file header is missing the  field.  

Solution: The Export Action needs to be modified with the following: 

1. From within the FDM Workbench, locate the FM11I-G5-D1 adapter. 

2. Expand the adapter, then expand Actions. 

3. Double click the Export Action and Find the “Current Code”. 

4. Replace it with the "Modified Code”. 

“Current Code” 

Remove the last: 

“Modified Code” 

Insert TransAmt: 

Financial Management Phased Submissions 

Problem: Using the Phased Submissions feature in Financial Management when loading data from 

FDM can cause issues with audit trails and also result in failed loads. This is because after phase one is 

submitted, any subsequent loads of the same data will fail because of locked intersections. In addition, 

reloading of data in FDM to the same location will erase the audit trail of the previous export to 

Financial Management.  

Solution: In order to preserve the audit trail and to avoid failed exports, Oracle recommends that you 

create a separate FDM location for each Financial Management phase. For example, a location named 

Texas would have locations named Texas1, Texas2, and Texas3 to load Texas for Phase 1, Phase 2, 

and Phase 3 respectively. Oracle also recommends separating the source data and the FDM maps by 

these phased locations. 
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Notes 

 Dimension names in FDM must be named exactly as they are named in Financial Management for 

the drill-through functionality to work correctly. 
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 Custom dimensions should never be disabled. If a custom dimension is not used in Financial 

Management, it must still be mapped to [None] so that FDM contains that information in the 

database. In order to map a dimension, it must be included in the import format.  

 This adapter is compatible with 32-bit operating systems and 64-bit operating systems running in 

32-bit emulation mode. 

 #7704822 (enhancement request)—The adapter now honors the Financial Management user 

preference for the decimal symbol. During the Export action, the adapter retrieves the user’s 

decimal preference from Financial Management and formats the Amount field accordingly. 

 See the Oracle Hyperion Enterprise Performance Management System Certification Matrix 

(http://www.oracle.com/technology/products/bi/hyperion-supported-platforms.html) for 

information about localization for this adapter. 

 See the FDM 11.1.1.4 Readme for additional information. 
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