
Oracle® Hyperion Financial Data Quality Management, Fusion 
Edition ERP Source Adapter for SAP Financials 

Release FIN-A 

Readme 

Purpose................................................................................................................................. 1 
Overview............................................................................................................................... 1 
Installation ........................................................................................................................... 1 
Configuration ........................................................................................................................ 2 

Company Codes................................................................................................................... 3 
Logging Options .................................................................................................................. 3 
File Separators .................................................................................................................... 4 

Using the Adapter ................................................................................................................. 4 
Known Issues........................................................................................................................ 6 
Notes .................................................................................................................................... 6 
 

Purpose 

This document includes important, late-breaking information about this release of the Oracle® 
Hyperion Financial Data Quality Management, Fusion Edition (FDM) ERP Source Adapter for SAP. 
Review this information thoroughly before installing. 
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Overview 

The FDM ERP Source Adapter for SAP allows users to import data from SAP R/3 4.6c or ECC 6.0. The 
adapter also allows the user to drill through from FDM to SAP to view the source data. 
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Installation 

The FDM ERP Source Adapter for SAP is comprised of several components. Two components are 
included in the FDM Adapter Suite. The remaining components must be downloaded and installed per 
the instructions available from Bristlecone. 

> To add the FDM ERP Source Adapter for SAP to an FDM application: 

1. From FDM Workbench, open an application. 

2. Click the Adapters tab. 

3. Select File > Import. 



 The Open Metadata Import File dialog box is displayed. 

4. Browse to find the file named SAP-FIN-A.xml and click Open. 

5. Click OK. 

 The adapter is displayed in the list of imported source adapters ((SAP-FIN-A) Oracle Hyperion 
Financial Data Quality Management ERP Source Adapter for SAP). 

6. Select File > Register Adapter. 

 The Register Adapter dialog box is displayed. 

7. Browse to find the file named fdmSAP_FIN.dll and click Open. 

8. Click OK. 

> To add the Bristlecone components: 

1. Go to http://www.bristleconelabs.com/edel/edel_login.asp and log in. 

 Note: You may need to create a new account to gain access. 

2. Download edel_fdm_download.asp/SAP Adapter Installation.zip. 

3. Unzip the file to access the FDM SAP Integration Bcone Components Installation Guide. 

4. Follow the instructions contained in the installation guide to complete the installation and 
configuration of the Bristlecone components. 
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Configuration 

 > To configure the adapter: 

1. In FDM Workbench, from the Adapters tab, select the adapter. 

2. Right-click the adapter and select Options. 

 The Adapter Options dialog box is displayed. The Options menu enables you to select any of 
the options and change the option settings. 

3. Set the adapter options per the guidelines in Table 1: SAP Configuration Settings 

Table 1: SAP Configuration Settings 

Option Name Information Required Required for… 

SAP Version SAP Financials Version number from 
which to pull data. 

Pulling data 

SAP UserID/Password SAP Financials database UserID and 
Password from which to pull data. 

Pulling data 

SAP Company Code SAP Company Code from which to pull 
data. See the section titled Company 
Codes for additional information. 

Pulling data 

SAP Language Code SAP Language Code from which to pull 
data. 

Pulling data 

SAP Server IP Address SAP Server IP Address from which to pull 
data. 

Pulling data 

SAP System Name SAP System Name from which to pull 
data. 

Pulling data 

SAP System Number SAP System Number from which to pull Pulling data 
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Option Name Information Required Required for… 
data. 

FTP IP Address FTP IP Address of the server which will 
receive the file from SAP. 

Pulling data 

FTP UserID/Password FTP UserID/Password. Pulling data 

File Data Separator Data field separator within the SAP data 
file. 

Pulling data 

Enable Drill-Back Enables drill through to SAP WIN or Web 
Client. 

Drill through 

Use SSL Indicates whether SAP is on SSL server. Drill through 

SAP Host Name Name of SAP ITS Server. Drill through 

SAP Server Port SAP ITS Server Port Number. Drill through 

SAP Internet Service Drill through specific URL information. Drill through 

SAP Client Number Defines the SAP client to use. Drill through 

Use Web or Win 
Drillback 

Drill through to Web or Win client. Drill through 

Prompt for File Enables FDM to prompt user for file. This 
is not used. 

Optional 

Company Codes 

When data import to FDM requires a company code or codes, use either of the following options: 

• Global company code support—From the FDM Workbench, enter the company code in the 
corresponding SAP adapter option. Separate multiple company codes with a comma (,). 

• Location-specific company code support—In FDM, enter the company codes in the Options field of 
the Locations > Integration Options screen. Separate multiple company codes with a comma (,). 

Logging Options 

By default, the adapter does not log the transfer of files from SAP to the FDM inbox. To enable logging, 
in the GetData action of the adapter, change ‘False’ to ‘True’ in the following line of code: 

objSAP.bolFTPLog = RES.FDMFalse 

> To access the GetData action: 

1. From the FDM Workbench, click the Adapters tab. 

2. Select the adapter and expand the directory (+ icon). 

3. Expand the Actions directory. 

4. Right-click GetData and select Properties. 
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File Separators 

The adapter default for the field separator in the source files is a pipe (|). If the field separator of the 
SAP source file is not pipes, then the GetAccount import script must be modified. 

> To change the field separator: 

1. In Workbench, select the Scripts tab. 

2.  In the left pane, expand the Import directory. 

3. Double-click GetAccount.uss. 

 The GetAccount script is displayed in the right pane of the Script Editor. 

4. Change the three instances of pipes to the delimiter used in the SAP source files. 

5. On the Script Editor toolbar, click Save. 
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Using the Adapter 

Using the FDM ERP Adapter for SAP involves the following steps: 

1. To configure FDM Control tables for the adapter: 

a. In FDM, select Metadata > Control Tables. 

The Control Tables screen is displayed. See the FDM Administrator’s Guide for information 
regarding control tables. 

b. Period Setup 

i) From the Adapters drop-down menu, select the adapter. 

ii) Be sure the Control Table drop-down menu is pointing to Periods. Update the 
Periods table with the corresponding SAP Periods (source periods). The source period 
must be entered in the Target Per (M) column. 

iii) The SAP Year (source year) must be entered in the Year Target column. 

c. Scenario Setup 

i) From the Control Table drop-down menu, select Categories. 

ii) Click the drop-down menu for Adapters and then select the adapter. 

iii) Update the FDM Categories table with the corresponding SAP Scenarios (source 
scenarios). 

The source scenario must be entered in the Target Category column. 

2. To generate the data from SAP Financials: 

a. In FDM, create an import format group and set the Type to Adapter. Then, assign the 
newly created import format to the desired SAP Location. See the FDM Administrator’s 
Guide for information regarding import formats. 

b. In FDM, select Workflow > Import. 

 The Import screen is displayed. 

c. Click Import to generate the source file from SAP Financials. You will use this file to create 
the import format in the next step. Be sure that all of the options are set correctly. See 
Table 1: SAP Configuration Settings. 

3. To set up an import format in FDM to enable FDM to import the data file generated by the adapter: 
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Ensure that the required fields (to allow drill through to SAP Financials) are defined in this import 
format. Those fields are: 

-  Account – Must contain the ACCOUNT (field #7) if Scenario is “A”. Must contain 
COMMITMENT ITEM (field #9) if Scenario is “B”. An Import Script (GetAccount.uss) is 
included in the XML of the adapter to handle this requirement. 

-  Attribute 1 – Must contain the SCENARIO field value from the file (field #1). 

-  Attribute 2 – Must contain the VERSION field value from the file (field #14). 

-  Attribute 3 – Must contain the PERIOD field value from the file (field #6). 

-  Attribute 4 – Must contain the YEAR field value from the file (field #5). 

-  Attribute 5 – Must contain the FM AREA field value from the file (field #4). 

- Attribute 6 – Must contain the COMPANY CODE field value from the file (field #2). 

Note: Set Attribute 6 this way even if field #2 is assigned to FM ENTITY. 

Drill Through to SAP Financials 
Users can drill through to SAP Financials from FDM to view source data. 

> To view the SAP Financials source document or source system from FDM: 

1. In FDM, navigate to the Import screen. 

2. Right-click an amount from the Amount column and perform an action: 

 ● To view the source file created by FDM, select Open Source Document. 

 ● To view the source system, select Open Source System. 

If Open Source Document was selected, the file created by FDM upon import is displayed. 

If Open Source System was selected, the source system is displayed. Then, a new session 
of Oracle SAP Financials is opened (Login screen). Log in to SAP Financials and you will be 
directed to the Account Balances screen or Budget screen (depending on which was used to 
load FDM). From there you can drill down for more detail. 

 
The following lists the fourteen fields that are pulled from SAP Financials. Any of these fields can 
be mapped to the target system. 

1.  SCENARIO 8.  GL ACCOUNT DESCRIPTION 
2.  COMPANY CODE 9.  COMMITMENT ITEM 
3.  COMPANY CODE DESCRIPTION 10.  PERIOD BALANCE 
4.  FM AREA 11.  YEAR TO DATE PERIOD BALANCE 
5.  YEAR 12.  CURRENCY 
6.  PERIOD 13.  CURRENCY DESCRIPTION 
7.  GL ACCOUNT 14.  VERSION 

 

4. Assign the Import Formats to a location: 

a.  Select Metadata > Locations. 

b. From the Locations screen, select the location into which you want to import the SAP 
Financials data. 

i) Select the Workflow Behaviors tab. 

ii) Select the Import Format created in step 1 and select Save. 

c. Select the Integration Options tab. 
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d. In the Option 1 field, enter the name of the import format defined in Step 2 and choose 
Save. 
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Known Issues 

Drill Through to SAP 4.6c Budget Scenario 
When using SAP 4.6c as a source, drill through to the Budget scenario values fails during the initial call 
to SAP 4.6c Web client. The initial call prompts the user to authenticate with the SAP 4.6c system. All 
subsequent drill through requests will work as expected. 

Load Action Defaults to Bulk Insert 
Problem: The SAP adapter does not honor the location's Data Load Type attribute when triggering the 
import of the data file. The adapter defaults to using bulk insert even when SQL insert is selected on 
the Locations page. 

Solution: Set the SQL Insert Data Load attribute in the GetData action. 

> To Set the SQL Insert Data Load attribute: 

1. In Workbench, on the Adapters tab, select the SAP adapter. 

2. Open the GetData action and search for fImportTextFile. 

 The last parameter passed in to this function is RES.FDMFalse. 

3. Change RES.FDMFalse to RES.FDMTrue. 

4.  Click Save. 
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Notes 

• This adapter allows the user to customize the contents of the SAP extracted file. See the adapter 
GETDATA action for an example. Also, note that corresponding customizations are required in SAP 
components. 

• The adapter has been localized for French, German, and Danish. 

• See the FDM 11.1.1.3 Readme for additional information about the FDM ERP Source Adapter for 
SAP Financials. 
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