
Oracle® Enterprise Repository
Compliance Templates Guide  

10g Release 3 (10.3) 

July 2009

Copyright (c) 2008, 2009, Oracle and/or its affiliates. All rights reserved. 1 of 24



Oracle Enterprise Repository Compliance Templates Guide, 10g Release 3 (10.3) 

Copyright © 2008, 2009, Oracle. All rights reserved.

Primary Author:  Vimmika Dinesh

Contributing Author: Jeff Schieli, Sharon Fay

The Programs (which include both the software and documentation) contain proprietary information; they 
are provided under a license agreement containing restrictions on use and disclosure and are also protected 
by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, 
or decompilation of the Programs, except to the extent required to obtain interoperability with other 
independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in 
the documentation, please report them to us in writing. This document is not warranted to be error-free. 
Except as may be expressly permitted in your license agreement for these Programs, no part of these 
Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any 
purpose.

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on 
behalf of the United States Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and technical data 
delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" 
pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As 
such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation 
and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license 
agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial 
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The Programs may provide links to Web sites and access to content, products, and services from third 
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You bear all risks associated with the use of such content. If you choose to purchase any products or services 
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Overview

The term Compliance Template describes a particular family of Oracle Enterprise 
Repository artifacts. Compliance Templates are only available in some product 
configurations. Examples of specific compliance template types include:

●     Project Profiles 

●     Architecture Blueprints 

Compliance Templates are used to communicate asset requirements or asset solution 
sets to internal or outsourced project teams. Project Profiles are usually created for 
individual projects, whereas Architecture Blueprints are reusable solution sets that can be 
leveraged by multiple projects.

Compliance Templates are typically generated by individuals or teams responsible for 
asset and project portfolios:

●     Project Planners might generate a Project Profile for each project in the portfolio, 
outlining the planning and estimating assumptions. 

●     Project Architects might generate a Project Profile to identify assets that fulfill a 
project's business requirements. 

●     Enterprise Architects might generate an Architecture Blueprint that specifies 
the standard frameworks and servers that are to be used by new projects. 

●     Those responsible for Service Oriented Architectures might generate an 
Architecture Blueprint to identify the services that orchestrate a particular 
business function. 

●     Product Line Architects might generate an Architecture Blueprint that specifies 
the assets that are to be used on a specific product line. 
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If upgrading from earlier product versions, compliance templates and examples may be 
obtained by installing the appropriate datapacks using the Import/Export Tool. For more 
information about the Import/Export tool, see Oracle Enterprise Repository Import/
Export Tool Guide. Project Profiles are included in the Compliance Template and Policy 
Management Datapack. Architecture Blueprints are included in the Enterprise 
Architecture Solution Pack.
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Creating a Compliance Template Type

This procedure is performed in the Type Manager, which is only available in some 
product configurations.

This example illustrates the creation of a Project Profile compliance template type.

Caution: Adding a compliance template constitutes a permanent change to the 
Oracle Enterprise Repository system.

In order to preserve database integrity, only Compliance Templates to which no assets 
are currently associated may be deleted.

If a Compliance Template Type is available in the Type Manager:

1.  Select New in the File menu.

The Create New Type pop-up opens.
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2.  Enter the appropriate information in the Type Name text box. 

3.  In the Type for Defaults drop-down, select a Compliance Template Type from 
the list. 

4.  Click OK.

The Create New Type pop-up closes and the new Type appears in the tree in the 
Type Manager sidebar.

If no Compliance Template Type is available in the Type Manager:

Compliance templates and examples may be obtained by installing the appropriate 
datapacks using the Import/Export Tool. Project Profiles are included in the Compliance 
Template and Policy Management Datapack. Architecture Blueprints are included in the 
Enterprise Architecture Solution Pack.

If an alternative method is preferred, a new Compliance Template Type may be 
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manually generated:

1.  Select New in the File menu.

The Create New Type pop-up opens.

2.  Enter the appropriate information in the Type Name text box. 

3.  In the Type for Defaults drop-down, select any Type from the list. 

4.  Click OK.

The Create New Type pop-up closes and the new Type appears in the tree in the 
Type Manager sidebar.

5.  Open the new compliance template type in the Type Manager. 

6.  Click the Editor tab of new compliance template type. 

7.  Select Compliance Template Type in the Archetype drop-down in the General 
section of the Editor tab.
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8.  Click Save in the File menu. 

9.  Select one of the of the tabs listed in the Tabs section.

The elements assigned to that tab appear in the list in the Elements section.
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10.  Click the Add button in the Elements section.

The Select an Element Type to Add pop-up opens.

11.  Select Project(s) to Which Template is Applied from the drop-down in the Select 
an Element Type to Add pop-up. 

12.  Click OK.

The Select an Element Type to Add closes.

13.  Follow the prompt to enter a label for the new element.
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14.  Click OK.

The new elements appears in the list in the Elements section.

15.  Click Save in the File menu. 

16.  Click the Viewer tab of new compliance template type. 

17.  Locate the new element in the list of Hidden Elements.

18.  Select (single-click) the new element. 

19.  Click the Display in Group button.

The Move Element pop-up opens.

20.  Use the drop-down in the Move Element pop-up to select a location for the new 
element. 
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21.  Click OK.

The new element appears in the list in the Elements section of the Viewer tab.

22.  Click Save in the File menu. 
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Creating a Compliance Template

This procedure is performed in the Asset Editor, and is very similar to Advanced Asset Submission, 
as described in the Oracle Enterprise Repository User Guide.

1.  Select New in the File menu.

The Create a New Asset pop-up opens.

2.  Enter the appropriate information in the Name and Version text boxes.

3.  Select the appropriate Type template from the drop-down. 

4.  Click OK.

The new compliance template appears in the Asset Editor.
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5.  Click the Taxonomy tab, and under Relationships section, click Add to add relationships. 

6.  Select the assets that are required to be used by the project. 

7.  Assign the appropriate relationships: Prescribed Assets, Prescibed Processes, and Prescribed 
Environments, as appropriate. 

8.  Click Save in the File menu in the Asset Editor.

The asset is submitted for review and registration. (See The Registration Process in the Oracle 
Enterprise Repository Registrar Guide.)

Follow this procedure to create Project Profiles, Architecture Blueprints, or other variations of the 
Compliance Template.
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Apply a Compliance Template to a Project

This procedure begins on the Oracle Enterprise Repository Assets screen.

1.  Use Search or other means to locate the compliance template to be applied to the 
project. (Select the desired compliance template in the Type drop-down in the 
Search section to filter search results.) 

2.  Click .

The Apply to Projects pop-up opens.
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3.  Click List All Projects or use Search to locate the project to which the profile will 
be applied.

A list appears in the Available Projects column.

4.  Select (highlight) the project to which the profile will be applied. 

5.  Click  to move the project from the Available Projects column to the Projects 
Applied to column.

The project moves from Available Projects to Projects Applied to.

6.  Click Save.

A confirmation pop-up opens.

7.  Click Close. 

8.  Click the Projects link in the Oracle Enterprise Repository menu bar.

The Projects screen opens.
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9.  Use Search or other means to locate the project to which the project profile was 
applied. 

10.  Click the Compliance Templates tab in the Project Detail.

The applied compliance template is listed in the Compliance Templates tab.

Note: If the enterprise repository plugin for Eclipse or .Net is installed, the assets 
identified in the compliance templates will also appear in the project's development 
environment.
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Using Assets Associated with Compliance Templates (Prescribed 
Assets)

Overview

A Compliance Template may be used to prescribe specific assets for use in any projects 
to which the compliance template is applied. This document outlines the process for 
consuming prescribed assets.

This procedure begins on the Oracle Enterprise Repository Projects screen.

1.  Use Search or other means to locate the project.

2.  Any compliance templates applied to the project will be listed in the Compliance 
Templates section of the project detail.

Copyright (c) 2008, 2009, Oracle and/or its affiliates. All rights reserved. 18 of 24



3.  Click  to the right of the name of the listed compliance template.

�❍     Note: The Use Assets button will appear only to users who are assigned to 
the project. 

The Use / Download pop-up opens.

4.  Use the checkboxes in the Use column to select the assets to be downloaded. 

Copyright (c) 2008, 2009, Oracle and/or its affiliates. All rights reserved. 19 of 24



5.  Click the Next button.

The Use / Download pop-up confirms the asset selections.

1.  Click  to download the payloads for the selected assets. 

2.  Click Close when finished.
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The downloaded assets are listed on the Consumed Assets section of the project 
detail.
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Running a Project Compliance Report

Overview

Project Compliance reports, if enabled in your product configuration, provide the means 
for verifying project adherence to the assets prescribed for use in compliance templates.

This procedure is performed on the Oracle Enterprise Repository Reports screen.

1.  Click the Project Compliance link in the Reports sidebar.

The Project Compliance report form opens in the main pane.
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2.  Use the Date Range, Sort Order, and Output Format drop-downs to set the 
report parameters.

NOTE: Date Range is based on the project creation date.

3.  Click the Run Report button.

The report appears in the selected format, listing each project, and indicating 
compliance templates in use, prescribed assets, usage status of prescribed assets, 
and any additional assets consumed by the project.
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