What's New in ALBPM 6.0 Studio

This topic provides an overview of the main new features, improvements and changes in this release of AquaLogic BPM Studio.

Standards Support


  • Process models in ALBPM are now compliant with the XPDL 2.0 standard.
  • Support for BPEL 1.1. You can import BPEL 1.1 models into an ALBPM Project, and new models can be designed within ALBPM Studio. The Process Execution Engine is now capable of executing BPEL 1.1 natively.
  • ALBPM Studio application is now built on top of the Eclipse platform.

Studio IDE


  • Studio now includes a software agent for automatic problem reporting and feedback. In case of unexpected errors in Studio, an automatic report will be sent to BEA for analysis. Studio will prompt you for approval before enabling this feature. We also encourage you to send us feedback using the Help > Feedback... menu option.
  • When you first start ALBPM Studio, you have to select one of the available profiles according your skill set: Business Analyst, Business Architect, Developer. ALBPM Studio presents a different subset of features depending on the selected profile. This keeps the user interface uncluttered, hiding what you don't need. All available features are visible under the Developer profile. The on-line documentation in Studio is also filtered depending on the active profile. To switch profiles go to Help > Welcome.
  • This new release introduces the concept of Project Variables, replacing the External and Business Variables of previous versions. Project Variables are functionally equivalent to the old External Variables but are simpler to use: they are available to all processes in the project, with no need to "promote" them from External to Instance. When the new property Business indicator is enabled, Project Variables behave as the old Business Variables (they are used for BAM reporting).
  • ALBPM project directories do not use the .fpr extension anymore.
  • The Organization data and Simulation definitions are now accessed as nodes in the project tree.
  • On previous version of Studio the Business Parameters of the project were accessible from the Variables panel on right. Now you access them from the Business Parameters node under the Organization node of the project tree.
  • Integration with Version Control System feature (VCS) was re-implemented to leverage the Eclipse platform. This paves the way for supporting virtually any Source Control systems compatible with Eclipse.
  • Each resource that is independently stored as part of an ALBPM Project is modified using an "Editor" tabbed panel, and you must explicitly save your changes on each resource with File > Save . For example, on earlier versions of Studio you add or modify a Participant using a separate dialog window. Now a special Participants editor opens in a new tab of the edition area. This makes it easier to work with Version Control systems, as each resource is managed and saved independently.
  • Some editors may open nested editors (accessible via smaller tabs at the bottom of the editor). For example, the editor for Process models uses independent sub-tabs for the process diagram and for each opened process method.

Process Designer


  • You can now open several projects at the same time. Before opening a project, you first need to add it to your Studio workspace.
  • Incremental compilation: There is no need for Publish&Deploy anymore. Once you start Studio's Process Execution Engine, the project is running. While it is running, the Execution Engine immediately applies changes you make to your project design and code.
  • A new type of Interactive activity: Decision activities. This type of activity allows the end user to decide the next path a process instance will take (one of the possible outgoing transitions), based on the value of certain instance variables. The Process Execution Engine keeps track of those decisions over time and presents the end user with recommendations on what decision to take based on past experience.
  • Business Rules: ALBPM Studio now provides a way of defining business rules using a graphical rules editor, without requiring any coding. After the project is deployed, authorized end users can also modify these rules on-the-fly, while the processes are executing. They can do so right from the ALBPM WorkSpace UI.
  • Round-trip Simulation: You can now create Simulation models from the actual execution of the processes during a given period of time. This makes it easier to create realistic Simulation models.

User Interface


  • ALBPM WorkSpace has been re-designed and re-implemented from the ground up. It is based on a modern modular architecture which makes it easier to customize and integrate naturally with AquaLogic UI and WebLogic Portal. The old WorkSpace is still provided for backward compatibility but may be removed in future versions.
  • Dashboards provide better quality graphics and end user interaction (i.e. rotation, detaching of pie sections).

Integration


  • Native integration with ALSB. You can now easily consume ALSB services from ALBPM and also register a business process in ALSB.
  • Web Services in ALBPM now include support for WS-Security, Document-Literal style and WS-I compliance.
  • ALBPM Studio now includes JDBC drivers for the most popular DBMS. This means you can integrate with Oracle, DB2 and Microsoft SQL Server right out of the box.
  • PAPI has deprecated several methods in favor of new ones which follow a new naming convention. PAPI methods which where deprecated in ALBPM 5.7 have been deleted from the API.
  • PAPI WebService 1.0 has been deprecated in favor of the new PAPI WebService 2.0. PAPI-WS 1.0 is accessible through ALBPM WorkSpace while PAPI-WS 2.0 is accessible through its own new Web Application (papiws). This new version is functionally equivalent to the native Java PAPI, and adheres to the WS-Security specification using the UserNameToken Profile implementation as well as HTTP Basic Authentication.