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CHAPTERa

Guide to Building Business Processes

WebLogic Integration’s business process management (BPM) functionality enables the
integration of diverse applications and human participants, as well as the coordinated exchange
of information between trading partners outside of the enterprise. Business Processes allow you
to orchestrate the execution of business logic and the exchange of business documents among
back-end systems, users and trading partners (systems and users) in a loosely coupled fashion.

This guide introduces the tools in BEA WorkSpace Studio that allow you to create Business
Processes graphically, allowing you to focus on the application logic rather than on
implementation details as you develop.

The first step in the design of your business process is to build a graphical representation of the
business process that meets the business requirements for your project. You create a graph of
component nodes in your business process by dragging components from the Node Palette pane
and dropping them onto the Design view pane. Program control is represented visually by these
nodes (or shapes) and the connections between them. Effectively, you create a graphical
representation of your business process and its interactions with clients and resources, such as
databases, JMS queues, file systems, and other components.

Topics Included in This Section

Chapter 2, “Creating a Business Process Application”
Describes how to start BEA WorkSpace Studio, and provides step-by-step instructions for
creating a business process project in BEA WorkSpace Studio. Describes how some of the
high-level components you create as you build your business process application
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(specifically, the names you choose for these components) surface in the finished
application.

Chapter 3, “Starting Your Business Process”
Describes how to design the trigger that starts your business process. You can design your
business process to start as the result of receiving a request from a client, as the result of
receiving a message from a message broker channel to which the business process is
subscribed, or as the result of receiving any one of the former types of messages, via an
Event Choice node.

Chapter 4, “Interacting With Clients”
Provides step-by-step instructions for creating nodes in your business process that handle
interactions with client applications. A business process must be able to receive messages
from clients and send messages to clients.

Chapter 5, “Interacting With Resources Using Controls”
Describes how to create nodes in your business process that manage the interactions with
external resources, such as databases, EJBs, Web services, and so on. BEA WorkSpace
Studio Controls represent the interface between a business process and these external
resources.

Chapter 6, “Receiving Multiple Events”
Describes how to create nodes at which your business process waits to receive multiple
events, from clients or controls. Event Choice nodes handle the receipt of multiple events.
Event Choice nodes, in turn, contain Client Response or Control Receive, or both.

Chapter 7, “Creating Parallel Paths of Execution”
Describes how you can design your business process to execute tasks in parallel.

Chapter 8, “Defining Conditions For Branching”
Describes how to design a Decision node and its associated conditions in your business
process. A Decision node is used to select exactly one path of execution based on the
evaluation of one or more conditions.

Chapter 9, “Creating Case Statements”

Describes how to design Java-like case statements through using Switch nodes. A Switch
node is used to select one path of execution based on the evaluation of an expression
specified on a condition node. A Switch node contains one condition node, one or more
case paths, and one default path.

Chapter 10, “Writing Custom Java Code in Perform Nodes”
Describes the Perform nodes, which you can customize with Java code.
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Topics Included in This Section

Chapter 11, “Creating Looping Logic”
Describes how you can design logic in your business process in which the activities
enclosed in a loop are performed repeatedly while a specific condition is true.

Chapter 12, “Looping Through Items in a List”
Describes how to design For Each nodes in a business process, that is, how to create the
logic that allows your business process to perform a set of activities repeatedly, once for
each item in a list.

Chapter 13, “Specifying Endpoints in Your Business Process”
Describes how to design the final node in your business process.

Chapter 14, “Grouping Nodes in Your Business Process”
Describes how to combine business process nodes into a group, for which you can specify
properties, such as exception, message, and timeout paths.

Chapter 15, “Handling Exceptions”
Describes exception handlers: global exception handlers, exception handlers on a block or
group of nodes, exception handlers for individual nodes, and unhandled exceptions.

Chapter 16, “Adding Message Paths”
Describes how to use Message Paths to execute process nodes in a parallel path to a node
or group of nodes after a certain message is received from a client or a resource (via a
control). Message paths can be associated with individual nodes, a group of nodes, or with
the process (global).

Chapter 17, “Adding Timeout Paths”
Describes how to use timeout paths to execute process nodes in a parallel path to a node
or group of nodes after a certain amount of time has lapsed. Timeout paths can be
associated with individual nodes, a group of nodes, or with the process (global).

Chapter 18, “Running and Testing Your Business Process”
Describes how you can compile and test a business process using the Test Browser tool.

Chapter 19, “Business Process Variables and Data Types”
Describes the data types supported in your business process application and how to create
business process variables.

Chapter 21, “Versioning Business Processes”
Describes how you can make changes to your business process without interrupting any
instances of the process that are currently running by using the BEA WorkSpace Studio
versioning feature.
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Chapter 20, “Validating Schemas”
Describes the different methods you can use to validate your schemas.

Chapter 22, “Building Stateless and Stateful Business Processes”
Describes the differences between building Stateless and Stateful business processes.

Chapter 23, “Building Synchronous and Asynchronous Business Processes”
Describes the differences between building Synchronous and Asynchronous business
processes. Also includes information on enabling synchronous clients to interact with
business processes that have asynchronous interactions with resources.

Chapter 24, “Transaction Boundaries”
Describes the rules for implicit and explicit transaction boundaries and how to create
explicit transaction boundaries.

Chapter 25, “Business Process Source Code”
Describes the source code BEA WorkSpace Studio writes to a business process file (a
Process.java file), in keeping with your business process design in the graphical design
environment.

Chapter 26, “Building ebXML Participant Business Processes”
Describes the template that you can use to build an ebXML participant business process
in BEA WorkSpace Studio.

Chapter 27, “Building RosettaNet Participant Business Processes”
Describes how to build public participant business processes for RosettaNet conversations
using the RosettaNet participant business process file in BEA WorkSpace Studio.

Chapter 28, “Building and Deploying Integration Applications”
Describes how to work in iterative development mode and deploy applications in EAR
format.

Chapter 29, “Calling Business Processes”
Describes how Business Processes can expose their functionality to clients in several
ways, including through WSDL files, Process Controls, Service Broker Controls, and JPD
Proxies.

Related Topics

Workshop For WebLogic Platform User’s Guide
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Creating a Business Process
Application

WebLogic Integration extends the BEA WorkSpace Studio graphical design environment to
allow the building of integrated enterprise applications. A WLI application in turn contains
projects and files. A project can contain several components including, business processes,
controls, Web services, and XML files.

This section describes the components of a WLI application, the steps you follow to create an
application in BEA WorkSpace Studio, and how to incorporate a business process in your
application. It includes the following topics:

e Components of Your Application

e Designing Your Application

Components of Your Application

This section outlines some of the high-level components you create as you build your business
process application and how they appear in the deployed application based on the names that you
choose for these components.

Application—The components of the application you are creating are represented in a tree
structure on the Package Explorer pane in your BEA WorkSpace Studio environment. If the
Package Explorer pane is not visible in BEA WorkSpace Studio, choose Window > Show View
> Other > Java > Package Explorer from the BEA WorkSpace Studio menu. An example of
Package Explorer pane is shown in Figure 2-1.
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Figure 2-1 Sample Package Explorer
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A WLI application will have the following projects (For example, the preceding figure represents
an application named Tutorial_Process_Application and includes an Enterprise Application
Project, Web Project, and Utility Project):

— Enterprise Application (EAR) Project— A project that contains JAR files and
deployment descriptors build files and auto-generated files. J2EE Applications and their
components are deployed on the WebLogic Server as EAR files.

— Utility Project— An optional project that contains the XML Schemas and the Message
Broker channel file. When you create your process application through the wizard or
using a template, the Utility project is created as part of the business process
application folder .The Utility Project has a schemas folder in it. When you add XML
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Schemas and MFL files to the schemas folder in your business process project, they
are compiled to generate XML Beans. In this way, BEA WorkSpace Studio generates a
set of interfaces that represent aspects of your XML Schemas. XML Bean types
correspond to types in the XML Schema itself. XML Beans provides Java counterparts
for all built-in Schema types, and generates Java counterparts for any derived types in
your Schema.

To learn more, see Importing Schemas.

— Web Project— A project that contains the WebLogic Server Web applications. In other
words, when you create a project, you are creating a Web application. The name of
your project "Tutorial_Process_Application_Web” which in turn contains a business
process named RequestQuote.java. Clients can access your business process via the
following URL.:

http://host:port/Tutorial_Process_Application_Web/requestquote/RequestQ
uote. jpd

In the preceding URL, host and port represent the name of your host server and the
listening port.

When a project is created, various information is assembled to specify the type of project,
add standard libraries, set compiler options, control publishing tasks, set build path, and/or
add an annotation processor. This information is specified by choosing facets during
project creation. Facets can also be added and deleted from a project after its initial
creation. To edit a project facets, select Project > Properties > Project Facets. For the
business process (Process.java) and Worklist application, the Project facets has already
been configured.

Note: A process can be created only in a WEB project which has Weblogic Integration
Process facet (process-enabled) added to it. Similarly a Worklist task plan can be
created in an EAR project which has Worklist Integration Worklist Application
Module facet (worklist-enabled) added to it.

Schemas folder exported as a jar needs to be added to a Web Project or a Util project and
not to an EAR project. Due to Eclipse and WTP restrictions, schema, channel builders, and
controls are associated only with Web or Util project and not with EAR project. If you
export or add the Schemas folder as a jar, into the module dependencies of the EAR
project, the channel files will not be declared and the controls of the business process will
not be availabe in the Data Palette.
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You build your application in BEA WorkSpace Studio by adding projects to an application. A
project contains components of your application such as business processes, Web services,
control files, and XML files.

Creating a Business Process Application

To quickly get started designing business processes, you can create an application that contains
a basic business process file, which you can customize with your business process logic. To do
so, complete the following procedure:

To Create a New Application
1. From the BEA WorkSpace Studio menu, click File > New > Other....
The Select a wizard dialog box is displayed.
2. Expand WebLogic Integration and select Process Application and click Next.
3. Inthe Process Application dialog box, type the details as shown in the following example:
a. Inthe EAR Project Name field, enter Process_Application_EAR.
b. Inthe Web Project Name field, enter Process_Application_Web.
c. Inthe Utility Project Name field, enter Process_Application_Utility.

4. Select Add WebL ogic Integration System and Control Schemas in Utility Project check
box.

This adds the system schemas to the Utility Project/schemas folder.

5. Click Finish.

This creates an application that contains a basic business process project, which includes a
business process file that contains only a Start and Finish node (process. java).

Note: If you select Tutorial: Process Application instead of Process Application,
WebLogic Workshop creates an application containing components for the Business
Process. To learn about taking the tutorial, see Tutorial: Building Your First Business
Process.You can also build an ebXML or RosettaNet participant business process in
WorkSpace Studio by using specially created templates. For more information about
how to create these participant processes, see Building ebXML Participant Business
Processes and Building RosettaNet Participant Business Processes.
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6. In the displayed Open Associated Perspective? dialog box, click Yes to switch from J2EE
Perspective to Process Perspective.

Note: The Open Associated Perspective? dialog box appears when creating a Business
Process for the first time in a Workspace.

7. The Process Application is created and displayed in the Package Explorer pane, as shown in
Figure 2-2.
Figure 2-2 Package Explorer
B X = -Sa =

+ % Process_Application_EAR
+ IEJ Process_Application_Ukility
B Process_application_web

The Tutorial:Getting Started with Workshop briefly describes the components and tools you use
to design your business process in the BEA WorkSpace Studio graphical design environment.

Subsequent topics in this guide describe in detail how to design specific business process
patterns, including tasks such as:

e Adding methods and callbacks to client nodes in your business process to create the
interface between your business process and its clients.

e Adding controls to represent the interfaces with resources such as Web services, databases,
and EJBs.

e Mapping disparate data types in your business process, using XML Schemas, and
constructing sequences of XML elements over which your business process can iterate to
perform specified activities.

e Viewing and editing the Process.java file in the Source view.
To learn about these tasks and others, see Topics Included in This Section.
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Setting the Business Process Properties

There are several properties which you can view and configure for your business process in the
JPD Configuration pane.

To Set the Business Process Properties

1.
2.

Select the Start node of the business process for which you want to configure the properties.

If the JPD Configuration pane is not visible in BEA WorkSpace Studio, choose Window >
Show View > JPD Configuration from the BEA WorkSpace Studio menu bar.

In the JPD Configuration pane the following properties are displayed: general and
process.

general

e name—This is the name of your business process, which is displayed throughout the BEA

WorkSpace Studio application, including the WebLogic Integration Administration
Console. You can change the name to anything you would like by clicking this property
and entering a new name.

e notes—Enter any notes that you want associated with your business process by clicking

notes and then clicking [-] to open the Notes dialog box. Enter your note and click OK.
Notes entered in the editor will be also be displayed in the WebL ogic Integration
Administration Console.

process

o freeze on failure—When a business process fails and there is no exception handler

configured to handle the exception thrown, the business process is placed into an aborted
state and no recovery is possible. However, if the business process is configured to freeze
on failure, the business process rolls back to the last commit point and the state is persisted
if it fails. The process can then be restarted from the WebLogic Integration Administration
Console. To configure a business process to freeze on failure: select true from the freeze
on failure drop-down menu.

For more information about business process exception handlers, see Handling Exceptions.
For more information about how to unfreeze business processes in the WebLogic
Integration Administration Console, see Process Instance Monitoring in Using the
WebLogic Integration Administration Console.

on sync failure—This property only applies to your process if it is configured to be a
synchronous subprocess, it is ignored for any other business processes. If a synchronous
subprocess fails, the default behavior is to mark it as rollback, which causes both the
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subprocess and the parent process to rollback. However, if the on sync failure property is
set to rethrow, only the subprocess is rolled back. To learn more about synchronous
subprocesses and the on sync failure property, see Working with Subprocesses.

persistence—This property sets how a stateful business process is persisted. More
specifically, it determines whether a conversation is maintained in memory or stored in a
database repository. Normally, stateful processes are persisted to a database. However, you
may want to use non-persistent stateful processes for the following:

— When the native communication mechanism requires it.
— When multiple send-receive operations need to be done in parallel.

— When the performance of a stateful process using a database does not meet
performance goals.

To set the type of persistence, from the persistent drop-down menu:

— Select always when you want your process conversations saved in the database
repository. These conversations can be recovered in the event of an abnormal shutdown
or crash. This setting is the WebLogic Integration default.

— Select never when you do not want your process conversations saved in the database
repository. These conversations cannot be recovered in the event of an abnormal
shutdown or crash.

— Select on overflow when you want your process conversations saved in the database
repository after reaching a certain number. Until this number is reached, conversations
are non-persistent. To set the overflow, set the Max Beans in Cache deployment
descriptor. To learn more about configuring deployment descriptors, see
EJB->Configuration->Descriptors in the WebLogic Server Administration Console
Online Help.

retry count—Specify how many times, after the first attempt, the process engine should
try to execute the business process.

If your business process contains an asynchronous Client Request node or multiple Client
Request nodes, any one of which is asynchronous, then you can set the retry count for the
business process. You cannot set the retry count property for business processes that
contain only synchronous Client Request nodes (that is, Client Request with Return
nodes).

retry delay—Specify the amount of time (in seconds) you want to pass before a retry is
attempted.

Guide to Building Business Processes 2-1
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If your business process contains an asynchronous Client Request node or multiple Client
Request nodes, any one of which is asynchronous, then you can set the retry delay for the
business process. You cannot set the retry delay property for business processes that
contain only synchronous Client Request nodes (that is, Client Request with Return
nodes).

e stateless—This property is for viewing only, it cannot be edited. It displays whether your
business process is stateless (property displays true) or stateful (property displays false).
To learn more about stateless and stateful business processes, see Building Stateless and
Stateful Business Processes.

Setting the Business Process Annotations

There are several properties which you can view and configure for your business process in the
Properties pane of your business process start node.

To Set the Business Process Annotations
1. Select the Start node of the business process for which you want to configure the annotations.

2. If the Properties pane is not visible in BEA WorkSpace Studio, choose Window > Show
View > Properties from the BEA WorkSpace Studio menu bar.

In the Properties pane, the following annotation are displayed:
BeanlInfo

e customizerclass— This annotation defines which bean properties are public, and which
getter/setter methods should be used to access them. This class must reside in the same
package and be similarly named to the tag (or bean) with BeanlInfo appended to it.

ClassReliable

e messageTimeToLive— This annotation specifies how long messages are maintained on
the server, in order to detect duplicate messages.

Ebxml

For information about ebXML annotation, see
http://edocs.bea.com/wli/docs102/wli.javadoc/com/bea/wli/jpd/EbXML.html.
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Featurelnfo

For information about Featurelnfo annotation, see
http://commons.apache.org/modeler/commons-modeler-1.0/docs/api/org/apache/commons/mod
eler/Featurelnfo.html.

Handler
e callback— This annotation specifies which handlers to run on outbound SOAP callbacks.

o file— This annotation specifies the handler configuration file to use, if handler chain is not
specified inline.

e operation— This annotation specifies which handlers to run on incoming SOAP messages.

ManifestAttribute

For information about ManifestAttribute annotation, see
http://beehive.apache.org/docs/1.0/apidocs/classref _controls/org/apache/beehive/controls/api/p
ackaging/ManifestAttribute.html.

ManifestAttributes

For information about ManifestAttribute annotation, see
http://beehive.apache.org/docs/1.0.2/controls/apidocs/javadoc/org/apache/beehive/controls/api/
packaging/ManifestAttributes.html.

Protocol

For information about Protocol annotation, see
http://edocs.bea.com/wli/docs102/wli.javadoc/com/bea/wli/common/Protocol.html.

Rosettanet

For information about RosettaNet properties, see
http://edocs.bea.com/wli/docs102/wli.javadoc/com/bea/wli/jpd/RosettaNet.html.

Schemas

e value— This annotation specifies the one or more schema files whose types are referenced
in the component class. This annotation can be added to the Process or Service Broker
Control. Multiple name value entries are defined and each entry refers to one definition of
a schema.
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Stateful

e maxAge— This annotation specifies the amount of time elapsed since a stateful process
started, the conversation may remain active before it is ended by the WebLogic Server.

e maxldleTime— This annotation specifies the amount of time a stateful process remains
idle before it is ended by the WebLogic Server.

e runAsStartUser— This annotation specifies that the continue and finish methods will be
run as the user who started the conversation.

e singlePrincipal— This annotation specifies that only the principal who started the
conversation can continue and finish the conversation.

TargetNamespace

e value— This annotation specifies the XML namespace used for outgoing XML messages
and generated WSDL files.

Version

e Strategy—This describes how to invoke sub processes when differerent versions of the
parent process exists. From the strategy drop-down menu:

— Select loosely-coupled if you want the subprocess version to be set at the time the
subprocess is invoked.

— Select tightly-coupled if you want the subprocess version to be set at the time the
parent process is invoked.

WSSecurityCallback
o file— This annotation specifies the location of the WS-Security file.
WSSecurityService

o file— This annotation specifies the path to the WS-Security policy file (WSSE file) used
by the web service.

Wsdl
e value— This annotation specifies a WSDL file that is implemented by a web service.
XmINamespaces

e Value— This annotation provide the namespace value and prefix value.
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Com.bea.wli.common.XQuery
e Prolog—This specifies the namespace and function declaration.

e Version—This specifies the XQuery version used in the Process file for inline XQueries.

Com.bea.wli.jpd.Process

e binding—This property specifies whether the business process uses the Web service,
ebXML, or RosettaNet protocol. The default value is webservice. If your business process
is an ebXML or a RosettaNet process, select ebxml or rosettanet.

e name— This is the name of you process.

e process— This is a read-only annotation and displays the content of the process
annotation.

For more information on properties, see Javadocs.

To learn about ebXML and RosettaNet business processes, see Building eb XML
Participant Business Processes and Building RosettaNet Participant Business Processes.

Note: WS-Security policy (WSSE) files are not supported for business processes (JPDs).
Therefore, the following annotations are not supported for JPD files:
com.bea.wli.common.WSSecurityCal lback and
com.bea.wli.common.WSSecurityService.

If you want to use WS-Security, then you must front-end the JPD with a JWS. The client
would invoke a JWS using WS-Security, then the JWS would locally invoke the JPD via
a Process Control.

Related Topics
Handling Exceptions

Process Instance Monitoring

Guide to Building Business Processes 2-11


http://edocs.bea.com/wli/docs102/wli.javadoc/index.html
http://edocs.bea.com/wli/docs102/adminhelp/processmonitoring.html

Creating a Business Process Application

2-12 Guide to Building Business Processes



CHAPTERa

Starting Your Business Process

This section describes how to design the first node in your business process (the Start node) to
represent the starting point of a business process.

A business process can be started as a result of receiving a request from a client or as the result
of receiving a message from a Message Broker channel to which the business process is
subscribed (a business process can subscribe to channels to receive events from for example: File
event generators, JMS event generators, and Timer Event Generators), and by a choice of one of
several events. This section includes the following topics:

e Designing Start Nodes

e Exception Handlers on Start Nodes

Designing Start Nodes

A Start node represents the starting point of a business process. Depending on the method by
which your business process starts, the Start Event of your process can contain any combination
of Client Request, Client Request with Return, or Subscription nodes. You design the Start
Event of your process by double-clicking the Start Event place holder placed just below your
Start node.

To create a new business process, complete the tasks described in Creating a Business Process
Application. When you create a new business process, it initially contains an empty Start node,
a Start Event place holder, and a Finish node, as shown in the following figure Figure 3-1.
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Figure 3-1 Start Node
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Finish
The first action in the business process is specified at the Start node. That is, you specify how
the business process is started at run time by defining a Start Event. The empty node attached to

the Start node, as well as the gray check box [, shown in the preceding figure, indicate that the
start method for this business process is not defined.

While you are building your business process by adding process nodes to it, you can go back to
the start node to check the stateless status of your process. If your process at any time becomes

stateful, the stateless property in the Start node property editor displays false. To learn more about
stateless and stateful business processes, see Building Stateless and Stateful Business Processes.

The Start Node also indicates any business-process-wide problems, such as when a control
declaration has an error or when an incorrect variable type is used for a variable. Any such

problems are indicated by an & appearing next to the Start Node. If you place your cursor over
this icon, BEA WorkSpace Studio will display a message about the problems.
To Define the Start Method for Your Business Process

You can design the start node properties by invoking the starting event node builder. Node
builders provide a task-driven interface that allow you to specify the logic required at nodes in
your business process.

1. Double-click the Start Event placeholder on the Start node in the Design view to display the
Start node builder.

The node builder displays, as shown in Figure 3-2.
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Figure 3-2 Node Builder

Y
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" Subscribe ko a Message Eroker channel and skart via an event (Timer, Email, File, Adapter, etc.)
" Subscribe synchronously ko a Message Broker channel and skart via an event

" Invoked via one of several Client Requests or Subscriptions (Event Choice)

Close

2. Inthe node builder, select the method by which you want your business process to start:

— Invoked via a Client Request

Select this option if you want your business process to start as the result of receiving a
message from a client.

— Invoked synchronously via a Client Request with Return

Select this option if you want your business process to start as the result of receiving a
synchronous request from a client. Any nodes added between the receive and send
nodes inside the Client Request with Return group will be executed within the scope of
the synchronous operation.

— Subscribe to a Message Broker channel and start via an Event (Time, Email, File,
Adapter, etc.)

Select this option if you want your business process to start as a result of receiving an
asynchronous message from a Message Broker channel. You create a static subscription
to a Message Broker channel on this node. This option also allows you to start your
business process via an event through File, JMS, Email, or Timer Event Generator,
which facilitate publishing events to Message Broker channels.

Note: In WebLogic Integration, subscriptions to Message Broker channels defined at a
Start node are referred to as static subscriptions, and subscriptions defined using
a Message Broker Subscription control are referred to as dynamic subscriptions.
See “Note about Static and Dynamic Subscriptions” in Javadocs.

— Subscribe synchronously to a Message Broker channel and start via an Event
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Select this option if you want your business process to start as a result of receiving a
synchronous message from a Message Broker channel. You create a static subscription
to a Message Broker channel on this node. This option also allows you to start your
business process via an event through File, JIMS, Email, or Timer Event Generator,
which facilitate publishing events to Message Broker channels.

— Invoked via one of several Client Requests or Subscriptions (Event Choice)

Select this option if you want your business process to start as a result of receiving one
of a number of possible events. When an Event Choice node is used at the start of a
business process, you can configure it to contain Client Request, Client Request with
Return, or Message Broker Subscription nodes.

3. To close the node builder, click Close.

The drop target on the Start node is populated with an icon representing the method by
which the business process starts.

To learn more about specifying the appropriate start node for your business process, see:

e Client Request Start (Asynchronous)

Client Request with Return Start (Synchronous)

Subscription Start (Asynchronous)

Subscription Start (Synchronous)

Event Choice Start
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Client Request Start (Asynchronous)

If you specified that your business process starts when it receives a message from a client, that is
using the Invoked via a Client Request option, your Start node is displayed as shown in
Figure 3-3.

Figure 3-3 Client Request Start Node

Process

B

Client Request

Finish
To Complete the Design of Your Client Request Node

1. Double-click the Client Request node to invoke the node builder for the Client Request
node.

2. Tocomplete the specification of events for your Client Request node, see Design Your Client
Request Node.

Related Topics
Sending Messages to Clients
Handling Exceptions

Client Operations and Control Communication Methods

Client Request with Return Start (Synchronous)

If you specified that your business process starts when it receives a message from a client and a
synchronous response is sent back to the client, that is using the Invoked synchronously via a
Client Request with Return option, your Start node is displayed as shown in Figure 3-4.
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Figure 3-4 Client Request with Return start Node
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Note the following properties for the Client Request with Return group node:

° indicates that the design of this node is incomplete. To complete the design, see To
Complete the Design of Your Client Request with Return Node Group.

e By default the name for the node is Client Request with Return. You can change the
name in the following ways:

— Right-click the node name in the Design view and select Rename from the drop-down
menu. Then enter a new name to replace Client Request with Return.

— Double-click the node name in the Design view, then enter a new name to replace
Client Request with Return.

— Double-click either of the Client Request with Return icons in your business process
to display one of the node builders. Click the name beneath the node builder icon and
enter a new name to replace Client Request with Return.

After you add any node to your business process, you can design its properties and behavior by
invoking the node builder and completing the tasks appropriate for that node. You can also add
optional nodes between the Request and Return part of the Client Request with Return node. This
allows you to process data or perform tasks after the message from the client is received and

before the return is sent back to the client. For more information on how to add optional nodes to
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your Client Request with Return node, see Adding Nodes to Your Client Request with Return
Node Group.

The following sections describe how to complete the design of your Client Request with Return
nodes:

To Complete the Design of Your Client Request with Return Node Group
To design your Client Request with Return node, you need to complete the following sections:

e Specify General Settings for the Request Part of Your Node Group

e Specify Receive Data Settings for the Request Part of Your Node Group

e Specify General Settings for the Return Part of Your Node Group

e Specify Send Data Settings for the Return Part of Your Node Group
Specify General Settings for the Request Part of Your Node Group

1. Double-click the E!'% icon (upper icon) in the Client Request with Return node group in
your business process.

The node builder is invoked. It contains two tabs: General Settings and Receive Data.
2. Inthe General Settings tab, enter a name in the Method Name field to specify the name of
the method on this Client Request with Return node.

The name you assign to the method is the name of the method that is exposed via the Web
Services Description Language (WSDL) when you make your business process available
as a Web service. To learn more about how the methods in your project are exposed to
clients, see Components of Your Application.

3. Inthe General Settings tab, click Add. A panel, which shows the data types is displayed.

4. Select the type and format of the data your Client Request with Return node expects to
receive from clients (that is, the data type for the method parameter). You can also specify a
name for the method parameter.

5. Select the type and format of your data. The options available are:
— Simple Types
Lists Java primitive and classes data types
— XML Types
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Lists the XML Schemas that are available in your business process project and the
untyped XMLObject and XMLObijectList data types. To learn how to import a Schema
into your project, see Importing XML Schema.

— Non-XML Types

Lists the Message Format Language (MFL) files available in your business process
project and the untyped RawData data type. WebLogic Integration uses a metadata
language called Message Format Language (MFL), based on XML, to describe the
structure of non-XML data. Every MFL file available in your project is listed in
Non-XML Types. Note that an XML Schema representation of each MFL file is built
by BEA WorkSpace Studio and is also available in the XML Types listing.

For more detailed descriptions of the data types, see Working with Data Types.

6. After you select the data type, click OK. The parameter specification you made is displayed
in the General Settings tab in the node builder.

Note: If you selected typed XML or typed non-XML data type in the previous step, you can
select the VValidate box to have the incoming message validated against your
specified schema before the message is received by the node. For more information
about schemas, see Validating Schemas and Creating and Importing Schema Files.

7. Inthe General Settings tab, continue clicking Add and select the type and format of your
data until you have added as many parameters as you want to use.

8. Toremove a parameter from the node builder pane, select the parameter in the list and then
click Remove.

Specify Receive Data Settings for the Request Part of Your Node Group
1. Click the Receive Data tab.

This tab allows you to define one or more variables to hold the data that your business
process receives from clients. The Receive Data tab has two modes:

— Variable Assignment- Use this mode when you want to assign the data received from
the client to a variable of the same data type. By default, the Receive Data tab opens
on the Variable Assignment panel.

— Transformation- Use this mode when you want to create a transformation between
data assigned to a variable and that expected by the method parameter.

2. If the data types of your method parameters and the data type of the variables you are going
to use match, you can map your variables to the corresponding methods directly.

a. If not already selected, select the Variable Assignment option.
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The Client Sends field is populated with the parameter(s) you specified on the General
Settings tab.

If you want to assign a variable that you have already created in your project to the method
parameters, under Select Variables to assign, click the arrow in the drop-down list and
select it from the menu. The variable you select is added to the node builder pane.

If you want to create a new variable and assign it to the method parameter, click the arrow
in the drop-down list, select Create new variable..., then follow the instructions in the To
Create a New Variable in the Node Builder section.

If the data types of your method parameters and your variables match, click OK. Your
new variable is created and displayed in the Receive Data tab.

If the data types of your method parameters and your variables are different, you can use the
XQuery Mapper Tool included in BEA WorkSpace Studio to map between heterogeneous
data types. The data transformations you create using the tool are stored in data
transformation files. When the data transformation files containing your data transformations
are built, they are built as controls. The controls expose transformation methods, which
business processes invoke to map disparate data types.

a.

To create a transformation map, select the Transformation option in the node builder.

The node builder transformation window displays the data types expected by your
method in the Client Sends pane.

In Step 1 of the Transformation option window, click Select Variable to select one or
more variables to be used.

Note: Toremove a parameter from the node builder pane, select the parameter in the list and

then click Remove. This action removes the variable from the node builder, not from
your business process. The variable is still included in your business process; it is
visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. If an instance of a Transformation control (defined by a data
transformation file) already exists in your project, then that instance is used to create
the map.

If an appropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the XQuery Mapper
tool window. This automatically applies changes to the builder and opens a transformation
editor in a new window.
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The XQuery Mapper Tool displays a representation of the source schema and target
schema in Source and Target panes. You can create a map between the data type of
the method parameter and the data type of the variable, or variables, to which you
assign the data. To learn how to create and test a map using the XQuery Mapper Tool,
see the Guide to Data Transformation.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.

d. If the appropriate instance of a Transformation control is available in your project, click
Advanced... in the node builder. The Advanced Option window opens. In this window
select the Control and Method. If the method arguments and return type matches those
as selected in the Transformation pane, click OK.

e. To close the node builder, click Close.

About Editing Node Configurations

You can edit the configuration at any node by opening the node builder and changing the existing
specifications. If you add or remove variables in a node builder that already contains a configured
transformation, you must edit or recreate the transformation. To do so, add or remove the
variables, then click Edit Transformation or Create Transformation.

Note: When selecting a variable in a node builder’s Transformation pane, and then clicking
Remove, removes the selected variable from the node builder, not from your business
process. The variable is still included in your business process; it is visible in the
Variables pane in the Data Palette.

Specify General Settings for the Return Part of Your Node Group

1. Double-click the |Qd-3 icon (lower icon) in the Client Request with Return node in your
business process.

The request part of the node builder is displayed. It contains two tabs: General Settings
and Send Data.

2. Inthe General Settings tab, enter a name in the Method Name field to specify the name of
the method on this Client Receive with Return node.

The name you assign to the method is the name of the method that is exposed via the Web
Services Description Language (WSDL) when you make your business process available
as a Web service. To learn more about how the methods in your project are exposed to
clients, see Components of Your Application.
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In the General Settings tab, click Select and select the type and format of the data your Client

Request with Return node expects to send to clients (that is, the data type for the return
value).

Select the type and format of your data. The options available are:

Simple Types
Lists Java primitive and classes data types.
XML Types

Lists the XML Schemas that are available in your business process project and the
untyped XMLObject and XMLObjectList data type.

Non-XML Types

Lists the Message Format Language (MFL) files available in your business process
project and the untyped RawData data type. WebL ogic Integration uses a metadata
language called Message Format Language (MFL), based on XML, to describe the
structure of non-XML data. Every MFL file available in your project is listed in
Non-XML Types. Note that an XML Schema representation of each MFL file is built
by BEA WorkSpace Studio and is also available in the XML Types listing.

For more detailed descriptions of the data types, see Working with Data Types.

5. After you select the data type, click OK. The return type field is populated with the parameter
types you added in the preceding steps.

Specify Send Data Settings for the Return Part of Your Node Group

1. Click the Send Data tab.

This tab allows you to define one or more variables to hold the data your business process
send to clients.

2. If the data types of your return value and the data type of the variables you are going to use
match, you can map your variables to the corresponding return value directly.

a.

If not already selected, select the Variable Assignment option. By default, the Send Data
tab opens on the Variable Assignment panel.

The Client Expects field is populated with the return type you specified on the
General Settings tab.

If you want to assign a variable that you already created in your project to the return value,
select it from the drop-down menu.
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3.

C.

If you want to create a new variable and assign it to the method parameter, select Create
new variable..., then follow the instructions in the To Create a New Variable in the Node
Builder section.

If the data types of your return value and your variables match, close the node builder by
clicking Close.

If the data types of your return value and your variables are different, you can use the XQuery
Mapper tool included in BEA WorkSpace Studio to map between heterogeneous data types.
The data transformations you create using the tool are stored in data transformation files.
When data transformation files containing your data transformations are built, they are built
as controls. The controls expose transformation methods, which business processes invoke to
map disparate data types.

a.

To create a transformation map, select the Transformation option.

The node builder transformation window displays the data types expected by your
method displayed in the Client Expects pane.

In Stepl of the Transformation option window, click Select Variable to select one or
more variables to be used.

Note: To remove a variable from the node builder pane, select the variable in the list and

then click Remove. This action removes the variable from the node builder, not from
your business process. The variable is still included in your business process; it is
visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. If an instance of a Transformation control already exists in your
project, then that instance is used to create the map.

If an appropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the XQuery Mapper
tool window. This automatically applies changes to the builder and opens a transformation
editor in a new window.

The XQuery Mapper tool displays a representation of the source schema and target
schema in Source and Target panes. You can create a map between the method
parameter and the variable, or variables, to which you assign the data. To learn how to
create and test a map using the XQuery Mapper tool, see Guide to Data
Transformation.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.
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d. If the appropriate instance of a Transformation control is available in your project, click
Advanced.... The Advanced Option window opens. In this window select the Control and
Method. If the method arguments and return type matches those as selected in the
Transformation pane, click OK.

e. To close the XQuery Mapper tool window, click Close.

Note: To learn about changing the configuration you design in the Transformation pane of
a node builder, see About Editing Node Configurations.

4. To close the node builder, click Close.

In the Design view, the [ icon indicates that you completed the configuration and design
of this node.

5. To save your work, select File > Save.

Adding Nodes to Your Client Request with Return Node
Group

The Client Request with Return node functions as a combination of a Client Request node and
a Client Receive node within a synchronous interaction. As such, you can add additional nodes
in between the request and the return part of your Client Request Node but you cannot add any
nodes that wait or block. To add a node to your Client Request with Return node, select the node
you want to add in the Palette and drag and drop it into your Client Request with Return node.

The following nodes can be added:

e Client Response (See Create a Client Response Node in Your Business Process.)

Control Send (See Create Control Nodes in Your Business Process.)

Control Send with Return (See Create Control Nodes in Your Business Process.)

Perform (See To Create a Perform Node in Your Business Process.)

Decision (See To Create a Decision Node in Your Business Process.)

Switch (See Creating Case Statements.)

While Do (See To Add A While group to Your Business Process.)

Do While (See To Add A While group to Your Business Process.)

For Each (See To Add A For Each Node to Your Business Process.)

Guide to Building Business Processes 3-13



Starting Your Business Process

Naming the Methods on Client Request with Return Nodes

The names that you assign to methods on your Client Request with Return nodes correspond to
the names of the methods that are exposed via the Web Services Description Language (WSDL)
when you make your business process available as a Web service. The name must be a valid Java
class name.

Related Topics
Sending Messages to Clients
XQuery Statements
Handling Exceptions

Client Operations and Control Communication Methods

Subscription Start (Asynchronous)

3-14

If you specified that your business process is started via the Subscribe to a Message Broker
channel and start via an Event (Time, Email, File, Adapter, etc.) option (see To Define the
Start Method for Your Business Process), your Start node is displayed as shown in Figure 3-5.

Figure 3-5 Subscription Start Node
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A static subscription to a Message Broker channel is defined on the Subscription node. Your
business process is started as the result of receiving a message from a Message Broker channel.
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Subscription Start (Asynchronous)

In WebLogic Integration, subscriptions to Message Broker channels defined at a Start
node are referred to as static subscriptions, and subscriptions defined using a Message
Broker Subscription control are referred to as dynamic subscriptions. See “Note about
Static and Dynamic Subscriptions” in
http://edocs.bea.com/wli/docs102/wli.javadoc/index.html

The following sequence concisely describes the message flow at run time:

1. A service publishes a message to a Message Broker channel, using a MB (Message Broker)
Publish control, a File event generator, Timer event generator, or a JMS event generator. To
learn more about how events are published to Message Broker channels.

2. A business process instance subscribes to, and receives messages from the Message Broker
channel via the Subscription node. To ensure scalability of your application, the inbound
messages by default are buffered on the queue for the current business process. To learn about
buffering, see Buffering Client Messages.

Note:

An asynchronous subscription start causes the subscribed business process to run in a
different transaction from the publisher’s transaction. In general, this is the recommended
design pattern to use when you want to design your business process to start when it
receives a message from a Message Broker channel. To learn about the scenarios for
which a synchronous subscription start is recommended, see About Choosing
Synchronous or Asynchronous Subscription Start Nodes.

To Complete the Design of Your Subscription Start Node

1. Double-click the Subscription node associated with the Start node in your business process
to invoke the Subscription node builder.

Tabs on the node builder include:

— General Settings
— Specify Filter

— Receive Data

The following steps describe the tasks available on these tabs.

2. Complete the following tasks on the General Settings tab:

a.

In the Method Name field, enter a name for the subscription request method.

The data type and format of the data your subscription request method (that is, the data
type for the method parameter) is specified automatically, based on the configuration of
your channel file.
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b. Select a channel name from the drop-down list of Message Broker channels associated
with the Channel Name field (see Figure 3-6).

Figure 3-6 Channel Name
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Note: If no appropriate channels are available for you to select, you must create a Channel
file that specifies the Message Broker channels for your application.

. Click the Specify Filter tab.

Specifying a filter is optional. Filters can be applied to the data type the business process
receives from the channel, or when you have specified a qualified metadata type in your
channel configuration.

The field in the Specify Filter tab is populated with the data type for the subscription
method parameter you specified on the preceding tab. If you specified your channel to be
able to receive qualified metadata, the Qualified Metadata attribute is also listed and you
can filter on that parameter instead.

To specify a filter:
a. Select the input type or schema element on which you want to filter.

b. An XQuery expression is generated, and the Filter field is populated with the XQuery
expression based on your selection in the preceding step.

Note: If you want to filter on an XMLODbject parameter, you have to enter the XQuery
statement in the Filter field or edit your source code directly.

c. Inthe Filter Value field, enter a value against which you want to match the filter.
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4. Click the Receive Data tab.

This tab allows you to define one or more variables to hold the data that your business
process receives from the channel.

5. If the data types of your method parameters and the data type of the variables you are going
to use are the same, you can map your variables to the corresponding methods directly.

a.

If it is not already selected, select the Variable Assignment option.

The Client Sends field is populated with the parameter(s) you specified on the General
Settings tab, in other words, the parameter type of the channel.

If you want to assign a variable that you already created in your project to the method
parameters, select it from the drop-down menu.

If you want to create a new variable and assign it to the method parameter, select Create
new variable..., then follow the instructions in the To Create a New Variable in the Node
Builder section.

If the data types of your method parameters and your variables match, click Close to close
the node builder.

6. If the data types of your method parameters and your variables are different, you can use the
XQuery Mapper tool included in WebLogic Integration to map between heterogeneous data
types. The data transformations you create using the tool are stored in data transformation
files. When the data transformation files containing your data transformations are built, they
are built as controls. The controls expose transformation methods, which business processes
invoke to map disparate data types.

a. To create a transformation map, select the Transformation option.

The node builder transformation screen is displayed; the data types expected by your
method are displayed in the Client Sends pane.

In Step 1 on the Transformation option window, click Select Variable to select one or
more variables to be used.

Note: Toremove avariable from the node builder pane, select the variable in the listand
then click Remove. This action removes the variable from the node builder, not
from your business process. The variable is still included in your business
process; it is visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. Your project must contain an instance of a Transformation control
defined by a data transformation files for you to create the map.
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c. Ifanappropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the transformation
tool. This automatically applies changes to the builder and opens the transformation tool
in a new window.

The transformation tool displays a representation of the source schema and target
schema in Source and Target panes. You can create a map between the data type of
the method parameter and the data type of the variable, or variables, to which you want
to assign the data.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.

d. If the appropriate instance of a Transformation control is available in your project, click
Advanced.... The Advanced Option window opens. In this window select the Control and
Method. If the method arguments and return type matches those as selected in the
Transformation pane, click OK.

e. Close the Transformation tool by clicking Close.

Note: To learn about changing the configuration you design in the Transformation pane of
a node builder, see About Editing Node Configurations.

7. To close the node builder, click the Close.

In the Design View, the ¥ icon indicates that you completed the configuration and design of this
node. To learn about buffering on your subscription node, see Buffering Client Messages.

8. To save your work, select File > Save.

Related Topics
Sending Messages to Clients
Handling Exceptions

Client Operations and Control Communication Methods

Subscription Start (Synchronous)

If you specified that your business process is started via the Subscribe synchronously to a
Message Broker channel and start via an event option (see To Define the Start Method for
Your Business Process), your Start node is displayed as shown in Figure 3-7.
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Figure 3-7 Subscription Start (Synchronous) Node
(L

Process

=87

—

r

Synchronous Subscription

Finish
A synchronous static subscription to a Message Broker channel is defined on the Synchronous
Subscription node. Your business process is started as the result of receiving a synchronous
message from a Message Broker channel.

Note: In WebLogic Integration, subscriptions to Message Broker channels defined at a Start
node are referred to as static subscriptions, and subscriptions defined using a Message
Broker Subscription control are referred to as dynamic subscriptions.

The following sequence summarizes the message flow at run time for the scenario in which you
design a Synchronous Subscription node at the start of your business process:

1. A service publishes a message to a Message Broker channel, using a MB (Message Broker)
Publish control, a File event generator, Timer event generator, or a JMS event generator.

2. A business process instance subscribes to, and receives messages from, the Message Broker
channel via the Synchronous Subscription node.

About Choosing Synchronous or Asynchronous Subscription Start Nodes

In general, an asynchronous subscription start pattern is recommended because it causes the
subscribed business process to run in a different transaction from the publisher’s transaction. In
contrast, a synchronous subscription start causes the subscribed business process to run in the
same transaction as the publisher. This type of subscription decreases loose coupling and can
associate the results of a transaction rollback of one subscriber with an otherwise independent
subscriber. However, there are two scenarios in which the synchronous subscription start pattern
is recommended:
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e JMS event generators publish to Message Broker channel which has one subscriber.

When a JMS event generator publishes to a channel that is known to have one subscriber,
it generally improves performance to use the synchronous subscription start method on the
subscriber. Note that in this case, the subscriber is doing work on the event generator
thread, so you should adjust the event generator thread count accordingly.

e JMS event generators and subscribers use the suppressible attribute.

Setting suppressible to true specifies that the static subscription is suppressed in favor of
dynamic subscriptions. In other words, you use suppressible=true to prevent specific
messages on a Message Broker channel from starting a new business process; instead the
messages can be received, using a dynamic subscription, by a business process that is
already running.

To Complete the Design of Your Synchronous Subscription Start Node

1. Double-click the Subscription node associated with the Start node in your business process
to invoke the Subscription node builder.

Note: You can configure only the node that represents the message received by the business
process. That is, you can only invoke a node builder for the first of the icons in the
pair that represents the Synchronous Subscription Start node.

Tabs on the node builder include:
— General Settings

— Specify Filter

— Receive Data

The following steps describe the tasks available on these tabs.
2. Complete the following tasks on the General Settings tab:

a. Select a channel name from the drop-down list of Message Broker channels associated
with the Channel Name field.

Note: If no appropriate channels are available for you to select, you must create a channel
file that specifies the Message Broker channels for your application.

b. Inthe Method Name field, enter a name for the subscription request method.

The data type and the format of the data your subscription request method (that is, the
data type for the method parameter) is specified automatically, based on the
configuration of your channel file.
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3. Click the Specify Filter tab.

Specifying a filter is optional. Filters can be applied to the data type the business process
receives from the channel, or when you have specified a qualified metadata type in your
channel configuration.

The field in the Specify Filter tab is populated with the data type for the subscription
method parameter you specified on the preceding tab. If you specified your channel to be
able to receive qualified metadata, the Qualified Metadata attribute is also listed and you
can filter on that parameter instead.

To specify afilter:
a. Select the data type on which you want to filter.

b. An XQuery expression is generated, and the Filter field is populated with the XQuery
expression based on your selection in the preceding step.

Note: If you want to filter on an XMLObject parameter, you will have to enter the XQuery
statement in the Filter field or edit your source code directly.

c. Inthe Filter Value field, create a value against which you want to match the filter.

4. Click the Receive Data tab.

This tab allows you to define one or more variables to hold the data that your business
process receives from the channel.

5. If the data types of your method parameters and the data type of the variables you are going
to use are the same, you can map your variables to the corresponding methods directly.

a. Ifitis not already selected, select the Variable Assignment option.

The Client Sends field is populated with the parameter(s) you specified on the General
Settings tab, in other words, the parameter type of the channel.

b. If you want to assign a variable that you already created in your project to the method
parameters, click Select Variable and select it from the drop-down menu. The variable
you select is added to the node builder pane.

c. If you want to create a new variable and assign it to the method parameter, select Create
new variable..., then follow the instructions in the To Create a New Variable in the Node
Builder section.

d. If the data types of your method parameters and your variables match, close the node
builder by clicking Ok.
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6.

If the data types of your method parameters and your variables are different, you can use the
XQuery Mapper tool included in WebLogic Integration to map between heterogeneous data
types. The data transformations you create using the tool are stored in data transformation
files. When data transformation files containing your data transformations are built, they are
built as controls. The controls expose transformation methods, which business processes
invoke to map disparate data types.

a.

To create a transformation map, select the Transformation option.

The node builder transformation pane is displayed; the data types expected by your
method are displayed in the Client Sends pane.

In Step 1 on the Transformation option pane, click Select Variable to select one or more
variables to be used.

Note: Toremove a variable from the node builder pane, select the variable in the listand
then click Remove. This action removes the variable from the node builder, not
from your business process. The variable is still included in your business
process; it is visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. If an instance of a Transformation control already exists in your
project, then that instance is used to create the map.

If an appropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the XQuery Mapper
tool. This automatically applies changes to the builder and opens the transformation tool
in a new window.

The transformation tool displays a representation of the source schema and target
schema in Source and Target panes. You can create a map between the data type of
the method parameter and the data type of the variable, or variables, to which you want
to assign the data.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.

If the appropriate instance of a Transformation control is available in your project, click
Advanced.... The Advanced Option window opens. In this window select the Control and
Method. If the method arguments and return type matches those as selected in the
Transformation pane, click OK.

To close the node builder, click Close.
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Note: To learn about changing the configuration you design in the Transformation pane of
a node builder, see About Editing Node Configurations.

In the Design view, the check box icon [# indicates that you completed the configuration and
design of this node.

7. To save your work, select File > Save.

Related Topics

Client Operations and Control Communication Methods
Message Broker

Event Generators

Event Choice Start

If you specified that your business process is Invoked via one of several Client Requests or
Subscriptions (Event Choice), (see To Define the Start Method for Your Business Process),
your Start node is displayed as shown in Figure 3-8.
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Figure 3-8 Event Choice Start Node
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By default, Event Choice nodes are created with two branches. Click [ to create additional
branches. A new branch is added on the left or right of the existing branches.

You can add additional nodes to the paths in your Event Choice node to specify the events
executed at run time after the business process starts. The Start Event targets at the start of each
branch indicate that only certain nodes are allowed at these locations: specifically, when you use
an Event Choice node at the start node in your business process, it can contain only Client
Request, Client Request with Return or Subscription nodes.

Note: When you create an Event Choice node at locations other than the Start node in your
business process, it can contain Client Request nodes and Control Receive nodes. To
learn more about designing Event Choice nodes, see Receiving Multiple Events.
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To Complete the Design of Your Event Choice Start Node

To specify the events to be executed on each branch of your Event Choice Start node, complete
the following tasks for each branch of the node:

1. Double-click the Start Event placeholder to invoke the node builder, see Figure 3-9.

Figure 3-9 Node Builder Event
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2. From the node builder, select the event for which this branch waits:

A Client Request

A Client Request with Return

A Message Broker Subscription

A Synchronous Message Broker Subscription

3. Click Close.

The drop target on your Event Choice branch is changed to reflect the event you specified.

4. To complete the specification of events, double-click the event nodes on the Event Choice
branches to invoke the associated node builder:

— To learn how to use the node builder to complete the Client Request node, see Design
Your Client Request Node.

— To learn how to use the node builder to complete the Client Request with Return
node, see To Complete the Design of Your Client Request with Return Node Group.
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— To learn how to use the node builder to complete the Message Broker Subscription
node, see To Complete the Design of Your Subscription Start Node.

— To learn how to use the node builder to complete the Synchronous Message Broker
Subscription node, see To Complete the Design of Your Synchronous Subscription
Start Node.

5. To save your work, select File > Save.

Related Topics
Business Process Source Code
Adding Message Paths
Adding Timeout Paths

Exception Handlers on Start Nodes

3-26

You can create a global exception handler for your business process by creating an exception path
for the Start node. You create the logic for the exception handler path to define the flow of
execution in the case when an exception is thrown by your business process. A global exception
handler responds to exceptions that are otherwise not handled in the business process.

To learn how to create exception handler paths on Start nodes, see Handling Exceptions.
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Clients invoke business processes to perform one or more operations. Business Processes expose
their functionality through methods.

Client Request nodes represent the points in a business process at which a client invokes a
method on the business process and possibly sends input to the business process. The names you
assign to methods on Client Request nodes correspond to the names of the methods that are
exposed via the Web Services Description Language (WSDL) when you make your business
process available as a Web service.

Note: The nodes in a business process are always communicating asynchronously with clients,
except for when you invoke a Start node of a business process by using the Client
Request with Return option or configure the starting event on a Message path to wait
for a Client Request with Return. To learn more about using the Client Request with
Return node, see Client Request with Return Start (Synchronous).

Client Response nodes represent the points in a business process at which business processes
send messages to clients.

This section describes how to add nodes to your business process and design the interactions of
business processes with clients. It includes the following topics:

e Receiving Messages From Clients—Design nodes in your business process to receive
asynchronous messages from clients. A business process can be started as a result of
receiving a message from a client.

e Sending Messages to Clients—Design nodes in your business process to send
asynchronous messages to clients.
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e Buffering Client Messages—Design your business process in such a way that the messages
sent to clients from Client Response nodes are buffered.

Receiving Messages From Clients

Client Request nodes provide a way for a client to make a request to a business process.

The tasks you must complete to design a Client Request node include:
e Create a Client Request Node in Your Business Process
e Design Your Client Request Node

e Naming the Methods on Client Request Nodes

Create a Client Request Node in Your Business Process

1. On the Package Explorer pane, double-click the business process (Process.java file) you
want to design.Your business process is displayed in the Design view.

2. If the Node Palette is not visible in BEA WorkSpace Studio, choose Window > Show View
> Node Palette from the BEA WorkSpace Studio menu.

3. Dragand drop [EF Client Request from the Node Palette onto the business process in the
Design view, placing it on the business process at the point at which you want to design the
client interaction.

Note: Asyou drag your selection onto the Design view, targets () appear on your business
process. Each target represents a location in the flow where you can place the node.
As you drag the node near a location, the target is activated () and the cursor changes

to an arrow . When this happens, you can release the mouse button and the node
snaps to the business process at the location indicated by the active target. If the
location you chose is not a valid one, an g will appear next to your node. If you place
your cursor over this icon, BEA WorkSpace Studio will display a message about the
violation.

The Client Request node is displayed in your business process in the Design view.
Note the following properties for the Client Request node:

. indicates that the design of this node is incomplete. To complete the design, see Design
Your Client Request Node.
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e By default the name for the node is Client Request. You can change the name in the
following ways:

— Double-click the node name in the Design view and enter a new name to replace Client
Request.

— Right-click the node name in the Design view and select Rename from the drop-down
menu. Then enter a new name to replace Client Request.

— Double-click the Client Request node in your business process to display the node
builder. Click the name beneath the node builder icon and enter a new name to replace
Client Request.

Design Your Client Request Node

After you add any node to your business process, you can design its properties and behavior by
invoking the node builder and completing the tasks appropriate for that node. The following
sections describe how to complete the design of interactions with clients in your Client Request
nodes:

e To Specify General Settings
e To Specify Receive Data
To Specify General Settings

1. Double-click the Client Request node in your business process.

The node builder is displayed. It contains two tabs: General Settings and Receive Data.

2. Inthe General Settings tab, enter a name in the Method Name field to specify the name of
the method on this Client Receive node.

The name you assign to the method is the name of the method that is exposed via the Web
Services Description Language (WSDL) when you make your business process available
as a Web service. To learn more about how the methods in your project are exposed to
clients, see Components of Your Application.

3. Inthe General Settings tab, click Add to select the type and format of the data your Client
Request node expects to receive from clients (that is, the data type for the method parameter).
The node builder displays the following types of data:

— Simple Types

Lists Java primitive and classes data types.

Guide to Building Business Processes 4-3



Interacting With Clients

4-4

— XML Types

Lists the XML Schemas that are available in your business process project and the
untyped XMLObject and XMLObjectList data types. To learn how to import a Schema
into your project, see Creating and Importing Schema Files.

Non-XML Types

Lists the Message Format Language (MFL) files available in your business process
project and the untyped RawData data type. WebLogic Integration uses a metadata
language called Message Format Language (MFL), based on XML, to describe the
structure of non-XML data. Every MFL file available in your project is listed in
Non-XML Types. Note that an XML Schema representation of each MFL file is built
by WebLogic Workshop and is also available in the XML Types listing.

For more detailed descriptions of the data types, see Working with Data Types.

4. Click OK.

The parameter specifications you made is displayed in General Setting tab in the node
builder.

Note: If you selected a typed XML or typed non-XML data type in the previous steps, you

can select the Validate box to have the incoming message validated against your
specified schema before the message is received by the node. For more information
about schemas, see Validating Schemas and Creating and Importing Schema Files.

To Specify Receive Data

1. Click the Receive Data tab.

This tab allows you to define one or more variables to hold the data your business process
receives from clients.

2. If the data types of your method parameters and the data type of the variables you are going
to use match, you can map your variables to the corresponding methods directly.

a.

If not already selected, select the Variable Assignment option. By default, the Receive
Data tab opens on the Variable Assignment panel.

The Client Sends field is populated with the parameter(s) you specified on the General
Settings tab.

If you want to assign a variable that you already created in your project to the method
parameters, select it from the drop-down menu.
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3.

C.

d.

Receiving Messages From Clients

If you want to create a new variable and assign it to the method parameter, then under
Select variable to assign, click the arrow and select Create new variable..., then follow
the instructions in To Create a New Variable in the Node Builder.

If the data types of your method parameters and your variables match, click Ok. Your new
variable is created and displayed in the Receive Data tab.

If the data types of your method parameters and your variables are different, you can use the
Transformation tool included in BEA WorkSpace Studio to map between heterogeneous data
types. The data transformations you create using the tool are stored in data transformation
files. When data transformation files containing your data transformations are built, they are
built as controls. The controls expose transformation methods, which business processes
invoke to map disparate data types.

a.

To create a transformation map, select the Transformation option.

The node builder transformation screen is displayed with the data types expected by
your method displayed in the Client Sends pane.

In Step 1 of the Transformation option window, click Select Variable to select one or
more variables to be used.

Note: Toremove avariable from the node builder pane, select the variable in the list and
then click Remove. This action removes the variable from the node builder, not
from your business process. The variable is still included in your business
process; it is visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. Your project must contain an instance of a Transformation control
for you to create the map.

If an appropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the Transformation
XQuery Mapper tool window. This automatically applies changes to the builder and opens
a transformation editor in a new window.

The mapping tool displays a representation of the source schema and target schema in
Source and Target panes. You can create a map between the data type of the method
parameter and the data type of the variable, or variables, to which you assign the data.
To learn how to create and test a map using the mapping tool, see Guide to Data
Transformation.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.
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d. If the appropriate instance of a Transformation control is available in your project, click
Advanced.... The Advanced Option window opens. In this window, select the Control
and Method. If the method arguments and return type matches those as selected in the
Transformation pane, click OK.

e. Close the Transformation tool by clicking Ok.
4. To close the node builder, click Close.

In the Design view, the [ icon indicates that you completed the configuration and design
of this node.

Note: To learn about changing the configuration you design in the Transformation pane of a
node builder, see About Editing Node Configurations.

5. To save your work, select File > Save.

Naming the Methods on Client Request Nodes

The names that you assign to methods on your Client Request nodes correspond to the names of
the methods that are exposed via the Web Services Description Language (WSDL) when you
make your business process available as a Web service. The name must be a valid Java class
name.

Related Topics

XQuery Statements

Handling Exceptions

Client Operations and Control Communication Methods
Adding Message Paths

Adding Timeout Paths

Sending Messages to Clients

Client Response nodes provide a way for a business process to send messages to clients. The
tasks you must complete to design a Client Response node include:

e Create a Client Response Node in Your Business Process

e Design Your Client Response Node
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Create a Client Response Node in Your Business Process

1. On the Package Explore pane, click the Process.java file you want to design.Your business
process is displayed in the Design view.

2. If the Node Palette is not visible in BEA WorkSpace Studio, choose Window > Show View
> Node Palette from the BEA WorkSpace Studio menu.

3. Click E Client Response in the Node Palette.

4. Drag and drop the Client Response node onto the business process in the Design view,
placing it on the business process at the point in your business process at which you want to
send a message to a client.

Note: Asyou drag your selection onto the Design view, targets () appear on your business
process. Each target represents a location in the flow where you can place the node.
As you drag the node near a location, the target is activated () and the cursor changes
to an arrow . When this happens, you can release the mouse button and the node
snaps to the business process at the location indicated by the active target. If the

location you chose is not a valid one, an g will appear next to your node. If you place

your cursor over this icon, BEA WorkSpace Studio will display a message about the
violation.

The Client Response node is displayed in your business process in the Design view.
Note the following properties for the Client Response node:

. indicates that the design of this node is incomplete. To complete the design, see Design
Your Client Response Node.

e By default the name for the node is Client Response. You can change the name in the
following ways:

— Double-click the node name in the Design view and enter a new name to replace Client
Response.

— Right-click the node name in the Design view and select Rename from the drop-down
menu. Then enter a new name to replace Client Response.

— Double-click the Client Response node in your business process to display the node
builder. Click the name beneath the node builder icon and enter a new name to replace
Client Response.
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Design Your Client Response Node

The following sections describe how to complete the design of interactions with clients in your
Client Response nodes:

e To Specify General Settings
e To Specify Send Data
To Specify General Settings

1. Double-click the Client Response node in your business process.

The node builder is displayed. It contains two tabs: General Settings and Send Data.

2. Inthe General Settings tab, enter a name in the Method Name field to specify the name of
the method on this Client Response node.

3. Inthe General Settings tab, click Add to specify the type and format of the data your
business process sends to clients via the Client Response node (that is, the data type for the
method parameter). The node builder displays the following types of data:

— Simple Types
Lists Java primitive and classes data types.
— XML Types

Lists the XML Schemas that are available in your business process project. To learn
how to import a Schema into your project.

— Non-XML Types

Lists the Message Format Language (MFL) files available in your business process
project. WebL ogic Integration uses a metadata language called Message Format
Language (MFL), based on XML, to describe the structure of non-XML data. Every
MFL file available in your project is listed in Non-XML Types. Note that an XML
Schema representation of each MFL file is built by WebLogic Workshop and is also
available in the XML Types listing.

4. Click OK.

After you select a data type from the list of supported types, the field is populated.
To Specify Send Data
1. Click the Send Data tab.
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This tab allows you to define one or more variables to hold the data your business process
sends to clients.

If the data types of your method parameters and the data type of the variables you are going
to use match, you can map your variables to the corresponding methods directly.

a.

If not already selected, select the Variable Assignment option. By default, the Send Data
tab opens on the Variable Assignment panel.

The Client Expects field is populated with the parameter(s) you specified on the
General Settings tab.

If you want to assign a variable that you already created in your project to the method
parameters, select it from the drop-down menu.

If you want to create a new variable and assign it to the method parameter, then under
Select variable to assign, click the arrow and select Create new variable...To Create a
New Variable in the Node Builder.

If the data types of your method parameters and your variables match, click Ok. Your new
variable is created and displayed in the Send Data tab.

If the data types of your method parameters and your variables are different, you can use the
XQuery Mapper tool included in BEA WorkSpace Studio to map between heterogeneous data
types.The data transformations you create using the tool are stored in data transformation
files. When data transformation files containing your data transformations are built, they are
built as controls. The controls expose transformation methods, which business processes
invoke to map disparate data types.

a.

To create a transformation map, select the Transformation option.

The node builder transformation screen is displayed with the data types expected by
your method displayed in the Client Expects pane.

In Step 1 in the Transformation tab, click Select Variable to select one or more variables
to be used.

Note: Toremove avariable from the node builder pane, select the variable in the listand
then click Remove. This action removes the variable from the node builder, not
from your business process. The variable is still included in your business
process; it is visible in the Variables pane in the Data Palette.

When designing a business process, you use a Transformation to create maps between
disparate data types. Your project must contain an instance of a Transformation control
for you to create the map.
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c. Ifanappropriate instance of a Transformation control is not available in your project, you
can create a new one by clicking Create Transformation to invoke the Transformation
Mapping tool window.

The mapping tool displays a representation of the source schema and target schema in
Source and Target panes. You can create a map between the data type of the method
parameter and the data type of the variable, or variables, to which you assign the data.

Note: To return to node builder, in the Package Explorer pane, double-click the
Process.java file.

d. If the appropriate instance of a Transformation control is available in your project, click
Advanced Option. The Advanced Option window opens. In this window select the
Control and Method. If the method arguments and return type matches those as selected
in the Transformation pane, click OK.

e. To close the node builder, click the Close.

In the Design view, the [ icon indicates that you completed the configuration and design
of this node.

Note: To learn about changing the configuration you design in the Transformation pane of a
node builder, see About Editing Node Configurations.

4. To save your work, select File > Save.

Adding Dynamic Callback Properties

You can set dynamic callback properties for your Client Response node by using the XQuery
Dynamic Selector. The Dynamic Selector allows you to configure a lookup property based on a
LookupControl or TPM function. You can then configure your business process in the WebL ogic
Integration Administration Console such that, at run time, the security of the callback to the client
is handled differently, based on the value of the lookup property that you specified in the
Dynamic Selector.

To Set the Dynamic Callback Property
1. Select the Client Response node for which you want to set a Dynamic Callback property.

2. Inthe Properties pane, in the xquery field under the ReturnXml section, enter the Dynamic
Selector XQuery data.

For information about how to configure the security information associated with your
dynamic callback property, see Adding or Changing Dynamic Client Callback Selectors in
Using The WebLogic Integration Administration Console.
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Buffering Client Messages

3. To save your work, select File > Save.

Buffering Client Messages

To ensure the scalability of your business process applications, incoming messages from clients
are buffered by default on the queue for the Web application.

Outgoing messages to clients are not buffered by default, but they can be configured to be
buffered on the same Web application queue.

To Buffer an Outgoing Client Message

1. Select the Client Response node that is configured with the callback method you want to
buffer.

2. Inthe Properties pane, in the message buffer section do the following:
a. From the enable attribute drop-down menu, select true.

b. Select the retry-count attribute, then enter a value for the callback method. This specifies
how many times the process engine should try to send your message to the queue.

— Select the retry-delay attribute, then enter a value for the callback method. This
specifies the amount of time (in seconds) you want to pass before a retry is attempted.

This completes the configuration of the callback method on the Client Response node; the
callback message is configured to be buffered.

Note: The business process considers a buffered operation completed when the message is
successfully enqueued, not when the message is delivered to the client.

3. To save your work, select File > Save.
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CHAPTERa

Interacting With Resources Using
Controls

BEA WorkSpace Studio controls make it easy to access enterprise resources, such as databases,
Enterprise Java Beans (EJBs), and Web services, from within your application.

When you access a resource through a control, your interaction with the resource is greatly
simplified; the underlying control implementation takes care of most of the details for you. You
add an instance of a control to your business process project and then invoke its methods.
Controls expose Java interfaces that can be invoked from your business process.

You can use controls generated from other services built with BEA WorkSpace Studio or
generate controls from WSDL files available from other services (regardless of the programming
language in which those services were implemented).

Designing Interactions Between Business Processes and
Resources

Control Send nodes represent points in business processes at which processes send
asynchronous messages to resources (via controls). Control Receive nodes represent points in
business processes at which processes receive asynchronous messages from resources (via
controls). A business process waits at a Control Receive node until it receives a message from
the specified control. Control Send with Return nodes handle synchronous exchange of
messages between business processes and resources (via controls). These three types of controls
are mutable. In other words, you can change them into another type of control by dragging and
dropping a control method of a different type.
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This section describes how to add nodes to your business process that represent the interactions
of your business process with resources. It includes the following topics:

Create Control Nodes in Your Business Process

Designing Your Control Nodes

Adding Instances of Controls to Your Business Process Project

Configuring Control Nodes

e Setting Control Properties and Annotations

Create Control Nodes in Your Business Process

To Create a Control Node in Your Business Process

In the Design view, an interaction between a business process and an external resource is
represented by one of three Control nodes: Control Send, Control Receive, or Control Send
with Return. The following steps describe how to add a Control node to your business process:

1. On the Package Explorer pane, double-click the business process (Process.java file) you
want to design.Your business process is displayed in the Design view.

2. Add a control node to your business process using one of the following methods:
— Drag and Drop a Method from a Control in the Data Palette onto the Design View
— Create a Control in the Design View First, Then Assign the Appropriate Method
Drag and Drop a Method from a Control in the Data Palette onto the Design View

a. If the Data Palette is not visible in BEA WorkSpace Studio, choose Window > Show
View > Data Palette from the BEA WorkSpace Studio menu.

b. Ifyou have already added an instance of your control to your business project (see Adding
Instances of Controls to Your Business Process Project), select the relevant method on that
control by clicking the method in the Data Palette.

c. Drag and drop the method onto the business process in the Design view at the location at
which you want to define the interaction.

As you drag your selection onto the Design view, targets () appear on your business
process. Each target represents a location in the flow where you can place the node. As
you drag the node near a location, the target is activated (1 and the cursor changes to
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an arrow . When this happens, you can release the mouse button and the node snaps
to the business process at the location indicated by the active target. If the location you
chose is not a valid one, an g will appear next to your node. If you place your cursor
over this icon, WebLogic Workshop will display a message about the violation.

The Control node is created in your business process in the Design view; it is named
according to the method you dragged and dropped from the Data Palette.

Create a Control in the Design View First, Then Assign the Appropriate Method

a.

If the Node Palette is not visible in BEA WorkSpace Studio, choose Window > Show
View > Node Palette from the BEA WorkSpace Studio menu.

If you have not yet created a control, click the control on the Node Palette that fits the
action you want to create:

< Control Send—Choose the Control Send if you want to create an asynchronous
call from your business process to a control.

M@ Control Send with Return—Choose the Control Send with Return node if you
want to create a synchronous call from your business process to a control.

.= Control Receive—Choose the Control Receive if you want to create a handler
for a callback from a control to your business process.

Drag and drop the Control node onto the business process in the Design view at the
location at which you want to define the interaction.

The Control node is created in your business process in the Design view, it is hamed
Control Send, Control Send with Return, or Control Receive, depending on which
control you dragged onto the Design view from the Node Palette.

The node in the Design view indicates only the type of interaction (asynchronous send,
asynchronous receive, or synchronous send/receive) between your business process and

a resource; it does not identify the resource. ’E is a placeholder for a type of control.

That is, it represents a location in your business process where you must specify the
type of resource (control) with which you want your business process to interact.

Specify the control for this placeholder node in one of the following ways:

— Drag a control method from an instance of a control in the Data Palette and drop it
onto the placeholder control in the Design view. (To learn how to add instances of
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controls to your project, see Adding Instances of Controls to Your Business Process
Project.)

— Double click the placeholder control E in the Design view to open the node
builder for this control and complete the specifications in the node builder.

Note the following properties for the Control nodes:

° indicates that the design of this node is incomplete. To complete the design, see
Configuring Control Nodes.

e Each node is labeled with a default name. You can change the name by clicking the name
of the node or right-clicking the node in the Design view and selecting Rename from the
drop-down menu. Then enter a new name to replace Control Send.

3. To save your work, select File > Save.

Designing Your Control Nodes

Designing the Control nodes includes adding an instance of the control with which you want
your business process to interact, then specifying the methods on the control, and the variables to
which the messages exchanged between your business process and the control are assigned. This
section describes how to design Control nodes. It includes the following topics:

e Adding Instances of Controls to Your Business Process Project

e Configuring Control Nodes

Adding Instances of Controls to Your Business Process
Project

5-4

e To Add an Instance of a Control to Your Business Process Project
e To Edit or Delete an Instance of a Control

To Add an Instance of a Control to Your Business Process Project

Before you can specify the resource with which your business process interacts at this node, you
must add an instance of the associated control to your project.

To add an instance of a control to your project:
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1. If the Data Palette pane is not visible in BEA WorkSpace Studio, choose Window > Show
View > Data Palette from the menu bar.

2. Click = onthe Data Palette. A drop-down list of controls that represent the resources with
which your business process can interact is displayed. Instances of controls already available
in your project are displayed in the Controls tab.

3. Select a control from the Integrations Controls drop-down menu.

Note: Table 5-1contains information about the standard controls used in WebLogic
Integration. Other custom and plug-in controls may be available.

Table 5-1 Controls in WebLogic Integration

Type of Control

Description

ALSB

The ALSB control enables a business process to invoke a ALSB proxy service via
RMI with security and transaction context propagation support.

Dynamic Transformation

The Dynamic Transformation control provides a business process with the ability
to dynamically select and invoke a query during run time. Specifically, this control
allows a business process to dynamically select a particular XQuery, XSLT, or
MFL file at run time. You use this control after creating and testing your XQuery
files with the Transformation control during design.

ebXML

The ebXML control enables BEA WorkSpace Studio business processes to
exchange business messages and data among trading partners via ebXML
(Electronic Business using eXtensible Markup Language). ebXML is a business
protocol that enables enterpri