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About This Document

This document explains how to use the WebLogic Integration Worklist console. 

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The document is organized as follows:

! Chapter 1, �Starting and Exiting the Worklist,� provides instructions for starting 
and exiting Worklist and disconnecting/reconnecting to the WebLogic 
Integration server.

! Chapter 2, �Working with Tasks,� describes the task functions in the Worklist.

! Chapter 3, �Working with Workflows,� describes the workflow functions in the 
Worklist.

! Chapter 4, �Customizing the Worklist,� explains how to customize the Worklist 
display and behavior.

! Chapter 5, �Working with Tools,� describes Worklist tools you can use.

What You Need to Know

This document is intended for users who complete workflow tasks.
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e-docs Web Site

BEA product documentation is available on the BEA corporate Web site. From the 
BEA Home page, click on Product Documentation or go directly to the �e-docs� 
Product Documentation page at http://e-docs.beasys.com.

How to Print the Document

You can print a copy of this document from a Web browser, one file at a time, by using 
the File→Print option on your Web browser.

A PDF version of this document is available on the WebLogic Integration 
documentation Home page on the e-docs Web site (and also on the documentation 
CD). You can open the PDF in Adobe Acrobat Reader and print the entire document 
(or a portion of it) in book format. To access the PDFs, open the WebLogic Integration 
documentation Home page, click the PDF files button, and select the document you 
want to print.

If you do not have the Adobe Acrobat Reader, you can get it for free from the Adobe 
Web site at http://www.adobe.com/.

Related Information

The following WebLogic Integration documents contain information that is relevant to 
using this product.

! Learning to Use BPM with WebLogic Integration

! Using the WebLogic Integration Studio
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Contact Us!

Your feedback on the WebLogic Integration documentation is important to us. Send 
us e-mail at docsupport@beasys.com if you have questions or comments. Your 
comments will be reviewed directly by the BEA professionals who create and update 
the WebLogic Integration documentation.

In your e-mail message, please indicate which release of the WebLogic Integration 
documentation you are using.

If you have any questions about this version of WebLogic Integration Worklist, or if 
you have problems installing and running the product, contact BEA Customer Support 
through BEA WebSUPPORT at www.beasys.com. You can also contact Customer 
Support by using the contact information provided on the Customer Support Card, 
which is included in the product package.

When contacting Customer Support, be prepared to provide the following information:

! Your name, e-mail address, phone number, and fax number

! Your company name and company address

! Your machine type and authorization codes

! The name and version of the product you are using

! A description of the problem and the content of pertinent error messages

Documentation Conventions

The following documentation conventions are used throughout this document.

Convention Item

Ctrl+Tab Indicates that you must press two or more keys simultaneously.

italics Indicates emphasis or book titles.
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monospace 
text

Indicates code samples, commands and their options, data structures and 
their members, data types, directories, and filenames and their extensions. 
Monospace text also indicates text that you must enter from the keyboard.
Examples:
#include <iostream.h> void main ( ) the pointer psz

chmod u+w *

\tux\data\ap

.doc

tux.doc

BITMAP

float

monospace 
italic 
text

Identifies variables in code.
Example:
String expr

UPPERCASE 
TEXT

Indicates device names, environment variables, and logical operators.
Examples:
LPT1
SIGNON
OR

{} Indicates a set of choices in a syntax line. The braces themselves should 
never be typed.

[] Indicates optional items in a syntax line. The brackets themselves should 
never be typed.
Example:
buildobjclient [-v] [-o name] [-f file-list]... 
[-l file-list]...

| Separates mutually exclusive choices in a syntax line. The symbol itself 
should never be typed.

Convention Item
viii Using the WebLogic Integration Worklist



... Indicates one of the following in a command line: 
! That an argument can be repeated several times in a command line.
! That the statement omits additional optional arguments.
! That you can enter additional parameters, values, or other information.
The ellipsis itself should never be typed.
Example:
buildobjclient [-v] [-o name] [-f file-list]... 
[-l file-list]...

.

.

.

Indicates the omission of items from a code example or from a syntax line. 
The vertical ellipsis itself should never be typed.

Convention Item
Using the WebLogic Integration Worklist ix
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CHAPTER
1 Starting and Exiting 
the Worklist

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The following sections describe how to start and exit from the Worklist console, and 
how to disconnect/reconnect to the WebLogic Integration server:

! Starting the Worklist

! Exiting the Worklist

! Logging Off from the WebLogic Integration Server

! Logging On to the WebLogic Integration Server

Starting the Worklist

To start the Worklist:

1. Do one of the following:

" On a Windows system, choose Start→Programs→BEA WebLogic Platform 
7.0→WebLogic Integration 7.0→Worklist. 

" On a UNIX system, go to the WLI_HOME/bin directory and run the 
worklist command. 
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1 Starting and Exiting the Worklist
For example, if WebLogic Integration is installed in the 
/home/bea/weblogic700/integration directory, enter the following: 

cd /home/bea/weblogic700/integration/bin

. ./worklist

The Logon to WebLogic Integration dialog box is displayed.

Figure 1-1   Logon to WebLogic Integration Dialog Box

2. Enter your user name in the User Name field.

3. Enter your password in the Password field.

4. In the Server [:port] field, specify the system that is running the WebLogic 
Integration server as follows:
t3://host:7001

where host is the computer name or IP address of the system that is running the 
WebLogic Integration server. Specify localhost if the server is running on the 
same computer as the Worklist.

5. Click the OK button. The Worklist is displayed.
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Exiting the Worklist
Figure 1-2   Worklist Main Window

The information displayed on the User ID and Role tabs depends on the selected 
organization. An organization can represent different business entities or geographical 
locations. Use the drop-down list to the right of the toolbar to view task information 
for all organizations to which you belong.

Exiting the Worklist

Select File→Exit from the menu bar to close the Worklist console. Unsaved changes 
are automatically saved.

Logging Off from the WebLogic Integration 
Server

Select File→Logoff from the menu bar to log off from the WebLogic Integration server. 
The toolbar icons on the main window and all menus except Tasks and Help are 
disabled. The Worklist console is disconnected from the WebLogic Integration server.
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1 Starting and Exiting the Worklist
Logging On to the WebLogic Integration 
Server

To reconnect to the WebLogic Integration server after you have logged off:

1. Select File→Logon from the menu bar. The Logon to WebLogic Integration dialog 
box displays.

2. Enter your user name in the User Name field.

3. Enter your password in the Password field.

4. In the Server [:port] field, specify the system that is running the WebLogic 
Integration server as follows:

t3://host:7001

where host is the computer name or IP address of the system that is running the 
WebLogic Integration server. Specify localhost if the server is running on the 
same computer as the Worklist.

5. Click the OK button. The Worklist window displays.
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CHAPTER
2 Working with Tasks

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The following sections explain how to work with Worklist tasks:

! Understanding Worklist Tasks

! Changing Task Properties

! Executing a Task

! Changing Task Status

! Reassigning a Task

Understanding Worklist Tasks

When a task in a workflow is first defined using the WebLogic Integration Studio, 
certain permissions are set for that task. These permissions determine what actions you 
can do with a particular task in the Worklist console. See Using the WebLogic 
Integration Studio for more information.

There are three types of task permissions in Worklist:

! User�a task is assigned to a particular user ID. Only the assigned user can 
perform the task unless the user reassigns the task to another user (reassignment 
can only occur if the user has reassign permission). 
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2 Working with Tasks
Note: The first tab on the main window is the User ID tab, which contains tasks 
assigned to your user ID.

! User who belongs to a role to which the task is assigned�a task is assigned to a 
role. A role is a common area of responsibility, ability, or authorization level 
that is shared by a group of individuals (such as a buyer or supervisor). 

Users can belong to one or more roles. In this case, each role is represented by a 
tab to the right of the User ID tab on the main window. Tasks contained within a 
role can only be done by users who are members of that role. Any user who is a 
member of that role can take a task assigned to the role and execute it.

! User in a role�a task is assigned to a user in a role. The system automatically 
assigns the task to the user in the selected role who has the least number of tasks 
to do.

Changing Task Properties

To change task properties:

1. Select the task whose properties you want to change on the User ID tab or the 
appropriate Role tab.

2. Select Task→Properties from the menu bar. The Task Properties dialog box is 
displayed.
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Changing Task Properties
Figure 2-1   Task Properties Dialog Box

3. Select the task priority from the Priority drop-down list.

4. Select one or more of the following task-permission checkboxes:

" Modify at execution�specifies whether users can change task permissions. 
If this permission is not set, users cannot select other permissions on the Task 
Properties dialog box.

" Mark done without executing�denotes whether users can change task status 
to done.

" Re-execute if marked done�specifies whether users can execute tasks even 
if the task has already been completed.

" Unmark if marked done�denotes whether users can change task status to 
pending.

" Reassign at execution�specifies whether users can reassign tasks.

5. Click the OK button to save any property changes and close the dialog box.
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2 Working with Tasks
Executing a Task

You can only execute tasks that are pending and have been assigned to you 
individually as a user, to a role of which you are a member, or to a user in a role.

To execute a task:

1. Select the task you want to execute on the User ID tab or the appropriate Role tab.

2. Select Task→Execute from the menu bar.

The actual behavior during task execution is determined by the definition of the task 
at workflow design time. See Using the WebLogic Integration Studio for more 
information.

Changing Task Status

You can change task status from pending to done or done to pending. 

Changing Task Status to Done

To change task status from pending to done:

1. Select the task you want to change on the User ID tab or the appropriate Role tab.

2. Select Task→Mark as Done from the menu bar.

Changing task status to done sets the task completion date to the current date and 
executes the actions defined for the marked done event of the task. The ability to 
change task status to done is determined by the permissions set on the Task Properties 
dialog box. See �Changing Task Properties� for more information.
2-4 Using the WebLogic Integration Worklist



Reassigning a Task
Changing Task Status to Pending

To change task status from done to pending:

1. Select the task you want to change on the User ID tab or the appropriate Role tab.

2. Select Task→Unmark Done from the menu bar.

Changing task status to pending clears the task completion date. This action does not 
affect a task that is not complete. The ability to change task status to pending is 
determined by the permissions set on the Task Properties dialog box. See �Changing 
Task Properties� for more information.

Reassigning a Task

You can only reassign a task if:

! The task is currently assigned to you individually as a user, to a role of which 
you are a member, or to a user in a role.

! The task reassign permission is set on the Task Properties dialog box. See 
�Changing Task Properties� for more information.

To reassign a task:

1. Select the task you want to reassign on the User ID tab or the appropriate Role tab.

2. Select Task→Reassign from the menu bar. The Reassign Task dialog box displays.
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2 Working with Tasks
Figure 2-2   Reassign Task Dialog Box

3. Select one of the following sets of steps depending on your reassignment target:

Reassignment to another user:

a. Click the User radio button.

b. Select another user in the Assignee drop-down list in the same organization 
associated with the workflow containing the task.

Reassignment to a user in a role to which the task is assigned:

a. Click the Role radio button.

b. Select a role in the Assignee drop-down list in the same organization associated 
with the workflow containing the task.

Reassignment to a user in a role:

a. Click the User in role radio button.

b. Select a role in the Assignee drop-down list. At execution time, the system 
performs workload balancing by automatically assigning the task to the user in 
that role who is assigned the least number of current tasks.

4. Click the OK button to save any reassignment changes and close the dialog box.
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CHAPTER
3 Working with 
Workflows

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The following sections explain how to work with Worklist workflows:

! Starting a Workflow

! Viewing Workflow Status

Starting a Workflow

To start a workflow:

1. Select Workflow→Start a Workflow from the menu bar. The Start Workflow dialog 
box displays.
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3 Working with Workflows
Figure 3-1   Start Workflow Dialog Box

2. Select the organization that contains the workflow you want to start in the Select 
the organization drop-down list. This list displays all the organizations to which 
you belong.

3. Select the workflow to start from the Select a workflow to start scroll list. The 
workflows that appear in this list represent all available workflow template 
definitions that you can start manually. Such workflows are defined as active and 
with a manual start at workflow design time.

4. Click the OK button to start the workflow. The processing that occurs during 
startup depends on the definition of the workflow created at design time. See 
Using the WebLogic Integration Studio for more information.
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Viewing Workflow Status
After the workflow starts successfully, a confirmation dialog box displays.

Figure 3-2   Confirmation Dialog Box

5. Click the OK button to close the dialog box.

Viewing Workflow Status

To view the status of all tasks associated with the workflow of the selected task: 

1. Select the task whose workflow status you want to view on the User ID tab or the 
appropriate Role tab.

2. Select Workflow→Workflow Status from the menu bar. The Workflow Status 
dialog box displays.

Figure 3-3   Workflow Status Dialog Box

Optionally, right click on any task listed in the Task column. A pop-up menu 
displays showing all the actions you can do with tasks.
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3 Working with Workflows
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CHAPTER
4 Customizing the 
Worklist

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The following sections explain how to customize the display and behavior of the 
Worklist:

! Working with Task Status

! Selecting Column Headings to Displays

! Selecting Task Sort Order

! Selecting a Display Option

Working with Task Status

You can update task status and select task status categories to display on the User ID 
and Role tabs.
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4 Customizing the Worklist
Updating Task Status

Select View→Refresh from the menu bar to update the status of all tasks shown on the 
User ID and Role tabs.

Selecting Task Status Categories to Display

To select task status categories to display on the User ID and Role tabs:

1. Select View from the menu bar. A list of checkboxes corresponding to the Pending, 
Done, and Inactive task statuses displays.

2. Select one or more of the checkboxes for the task status categories you want to 
display using Table 4-1. The User ID and Role tabs display or hide tasks based on 
the status categories you select.

Selecting Column Headings to Displays

To select column headings to display on the User ID and Role tabs:

1. Select View→Columns from the menu bar. The Columns dialog box displays.

Table 4-1  Task Status Categories to Display

Status Category Description

Pending Pending tasks have not been executed yet.

Done Done tasks have been completed

Inactive Inactive tasks have not been started in the 
workflow.
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Selecting Task Sort Order
Figure 4-1   Columns Dialog Box

2. Select a column heading in the Available columns or the Displayed columns 
scroll list.

3. Click the appropriate arrow control to move your selection from available to 
displayed or displayed to available status. 

Note: The Status column heading must be shown in order to select task status 
categories to display. See �Selecting Task Status Categories to Display� 
for more information.

4. Click the appropriate arrow control to reposition your selection up or down in the 
scroll list. The list position for displayed columns, starting from top to bottom, 
determines the ordering of column headings from left to right on the User ID and 
Role tabs.

5. Click the OK button to save any column-heading changes and close the dialog 
box.

Selecting Task Sort Order

To select task sort order on the User ID and Role tabs:

1. Select View→Sort By from the menu bar. A list of radio buttons displays 
corresponding to column headings shown on the User ID and Role tabs.

2. Select the radio button for the column heading you want to use to sort tasks. 
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4 Customizing the Worklist
Note: Select the Ascending checkbox to sort tasks in ascending order by the selected 
column heading. Otherwise, the tasks on the User ID and Role tabs are sorted 
in descending order.

Selecting a Display Option

To select a display option for the Worklist console:

1. Select View→Look & Feel from the menu bar. A list of radio buttons displays 
corresponding to the different user environments you can use.

2. Select the radio button for the user environment you want to use to display the 
Worklist console.
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CHAPTER
5 Working with Tools

Note: The Worklist client is deprecated as of this release of WebLogic Integration. 
For information about the features that are replacing it, see the BEA WebLogic 
Integration Release Notes.

The following sections explain how to use the Worklist tools:

! Displaying Logon Task Status

! Specifying Task Options

Displaying Logon Task Status

To display logon task status:

1. Select Tools from the menu bar. A checkbox for Display Logon Status appears.

2. Select the checkbox to display logon task status. When this feature is enabled, the 
Workflow Status dialog box displayed during logon shows the number of pending 
and overdue tasks you have.

Note: The ability to enable/disable the display of logon task status is set on the Task 
Properties dialog box. See �Changing Task Properties� for more information.
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5 Working with Tools
Specifying Task Options

To specify task options:

1. Select Tools→Options from the menu bar. The Worklist Options dialog box 
displays.

Figure 5-1   Worklist Options Dialog Box

2. Configure Worklist options as follows: 

" Select the Enable task notification checkbox to automatically notify you 
when you are assigned new tasks. In this case, when you receive a new task, 
the notification dialog box is displayed:

Figure 5-2   New Task Notification Dialog Box

" Specify the name of a WAV or AU file in the Play audio file field that will 
play when you receive a task notification. 

To browse audio files in your system, click the button to the right of the Play 
audio file field and select the audio file you want to use.
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Specifying Task Options
" Specify the frequency between successive task notifications in the Seconds 
between successive notifications field. For example, you may not want task 
notification more frequent than every five minutes to reduce work 
interruptions. 

3. Click the OK button to save any option changes and close the dialog.
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5 Working with Tools
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