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About This Document

This book provides step-by-step procedures to install your WebLogic Integration – Business 
Connect system. For information about configuration, testing, implementation and maintenance 
see Using WebLogic Integration – Business Connect or the online help.

This document is organized as follows:

Chapter 1, “System Requirements,” provides the basic information you need to know 
before installing WebLogic Integration – Business Connect.

Chapter 2, “Installation on Windows,” describes how to install the WebLogic Integration – 
Business Connect software on Windows systems.

Chapter 3, “Installation on UNIX,” describes how to install the WebLogic Integration – 
Business Connect software on UNIX systems.

Chapter 4, “Upgrading,” describes how to upgrade from a WebLogic Integration – 
Business Connect 2.1 installation.

Chapter 5, “Trading Tutorial,” provides a set of exercises which allow you to send test 
documents from a company to a partner in a simulated trading environment on a single 
computer.



About  Th is  Document

x Installing WebLogic Integration – Business Connect

What You Need to Know
This document is intended for use by people who oversee the installation, configuration, 
maintenance and use of WebLogic Integration – Business Connect. This book was written under 
the assumption that WebLogic Integration – Business Connect administrators have a working 
knowledge of:

Your organization’s business hardware, software and practices

A graphical user interface

The Internet, including use of a browser

In addition, your network, systems or mail administrator might find parts of this document useful 
as a guide for installation and configuration.

e-docs Web Site
BEA product documentation is available on the BEA corporate Web site. See the  “e-docs” 
Product Documentation page at http://e-docs.bea.com.

Note: BEA e-docs and dev2dev have converged. Now your favorite BEA documentation Web 
site is closely integrated with your favorite BEA developer portal 
(http://dev2dev.bea.com). The same great documentation and the same great developer 
resources converge to present you a comprehensive technical resource center. We hope 
you like it!

How to Print the Document
The document is available in HTML and PDF format from the BEA WebLogic Integration – 
Business Connect documentation home page, which is available on the documentation CD and 
on the e-docs Web site at http://e-docs.bea.com.

When viewing in HTML, you can print this document, one file at a time, by using the File→Print 
option on your Web browser.

You can open the PDF in Adobe Acrobat Reader and print the entire document, or a portion of 
it, in book format. To access the PDFs, open the BEA WebLogic Integration – Business Connect 
documentation Home page, click the PDF Files button, and select the document you want to print.

If you do not have the Adobe Acrobat Reader installed, you can download it for free from the 
Adobe Web site at http://www.adobe.com.

http://e-docs.bea.com
http://e-docs.bea.com
http://dev2dev.bea.com
http://www.adobe.com
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Contact Us!
Your feedback on the BEA WebLogic Integration – Business Connect documentation is 
important to us. Send us e-mail at docsupport@bea.com if you have questions or comments. 
Your comments will be reviewed directly by the BEA professionals who create and update the 
WebLogic Integration – Business Connect documentation.

In your e-mail message, please indicate which version of BEA WebLogic Integration – Business 
Connect you are using.

If you have any questions about this version of BEA WebLogic Integration – Business Connect, 
or if you have problems installing and running BEA WebLogic Integration – Business Connect, 
contact BEA Customer Support through BEA WebSupport at www.bea.com. You can also 
contact Customer Support by using the contact information provided on the Customer Support 
Card, which is included in the product package.

When contacting Customer Support, be prepared to provide the following information:

Your name, e-mail address, phone number, and fax number

Your company name and company address

Your machine type and authorization codes

The name and version of the product you are using

A description of the problem and the content of pertinent error messages

Documentation Conventions
The following documentation conventions are used throughout this document.

Convention Item

boldface text Indicates terms defined in the glossary.

Ctrl+Tab Indicates that you must press two or more keys simultaneously.

italics Indicates emphasis or book titles.
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monospace 
text

Indicates code samples, commands and their options, data structures and 
their members, data types, directories, and file names and their extensions. 
Monospace text also indicates text that you must enter from the keyboard.

Examples:

#include <iostream.h> void main ( ) the pointer psz

chmod u+w *

\tux\data\ap

.doc

tux.doc

BITMAP

float

monospace 
boldface 
text

Identifies significant words in code.

Example:

void commit ( )

monospace 
italic 
text

Identifies variables in code.

Example:

String expr

UPPERCASE 
TEXT

Indicates device names, environment variables, and logical operators.

Examples:

LPT1

SIGNON

OR

{ } Indicates a set of choices in a syntax line. The braces themselves should 
never be typed.

[ ] Indicates optional items in a syntax line. The brackets themselves should 
never be typed.

Example:

buildobjclient [-v] [-o name ] [-f file-list]... 
[-l file-list]...

| Separates mutually exclusive choices in a syntax line. The symbol itself 
should never be typed.

Convention Item
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... Indicates one of the following in a command line: 

• That an argument can be repeated several times in a command line

• That the statement omits additional optional arguments

• That you can enter additional parameters, values, or other information

The ellipsis itself should never be typed.

Example:

buildobjclient [-v] [-o name ] [-f file-list]... 
[-l file-list]...

.

.

.

Indicates the omission of items from a code example or from a syntax line. 
The vertical ellipsis itself should never be typed.

Convention Item
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C H A P T E R 1

System Requirements

The following topics are provided regarding the hardware, software, communications, and 
interfaces required for installing WebLogic Integration – Business Connect.

Concepts

“Windows Requirements” on page 1-2

“UNIX Requirements” on page 1-3

“Possible Port Conflicts” on page 1-5

“About the User License File” on page 1-7

“Security Considerations” on page 1-7

“Hardware Scalability” on page 1-8

Note: For supplemental information about system requirements and installation, we strongly 
recommend that you review the WebLogic Integration – Business Connect Release Notes 
at:

http://e-docs.bea.com/wlibc/docs81/relnotes/index.html

http://e-docs.bea.com/wlibc/docs81/relnotes/index.html
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Windows Requirements
The following topics provide the hardware and software requirements for running WebLogic 
Integration – Business Connect on computers with Microsoft Windows operating systems.

“Hardware on Windows” on page 1-2

“Software on Windows” on page 1-2

Hardware on Windows
A Windows computer must have the following minimum configuration.

A Pentium-class processor running at 400 MHz or faster

Random Access Memory (RAM) 

– 256MB recommended

– 128MB minimum

250MB available hard drive space

Note: We recommend at least a 1 GB hard drive for both the application and the documents 
you exchange.

SVGA monitor

CD-ROM drive (for installation)

TCP/IP network interface

Local area network (LAN) card and persistent Internet connection is required.

Software on Windows
A Windows computer must have the following minimum software configuration.

Operating System
WebLogic Integration – Business Connect supports the following Windows operating systems: 
Windows NT 4.0 and Windows 2000.

To use Windows NT 4.0, you also must have installed the domestic United States version of 
Service Pack 4 or later with the associated bug fixes.
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Note: Apache as the mediated web server is not supported when configured on Windows NT 
or Windows 2000.

Internet Browser
Internet Explorer 4.0.1 or later must be installed on your Windows computer before installing 
WebLogic Integration – Business Connect. Internet Explorer is required because the installation 
process uses IE scripts to create shortcuts. After installation you can use Internet Explorer 4.0.1 
or later or Netscape Navigator 4.0 or later as the browser.

Administrator Rights for Windows NT and 2000
For Windows NT or 2000, you must have administrator rights to successfully install the 
application. If you are not sure whether you have administrator rights for a machine, check with 
your system administrator.

Recommended Software for Windows
Although Internet Explorer 4.0.1 or later must be installed to successfully install WebLogic 
Integration – Business Connect, after installation you can use Internet Explorer 4.0.1 or later or 
Netscape Navigator 4.0 or later. You use a browser to read WebLogic Integration – Business 
Connect online help files and to obtain third-party certificates from certificate authorities such as 
VeriSign, Inc.

In addition, you need Adobe Acrobat Reader to view and print Using WebLogic Integration – 
Business Connect, which is provided in portable document format (PDF) files. The PDFs are in 
the userdoc directory on the installation CD and in the doc subdirectory after you install the 
application. Acrobat Reader is available free from Adobe Systems Inc., www.adobe.com.

UNIX Requirements
The following topics provide the hardware and software requirements for running WebLogic 
Integration – Business Connect on UNIX computers.

“Hardware on UNIX” on page 1-4

“Software on UNIX” on page 1-4
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Hardware on UNIX
Your computer must have the following minimum configuration to successfully install 
WebLogic Integration – Business Connect on a UNIX platform.

Random Access Memory (RAM)

– 256MB recommended

– 128MB minimum

250MB available hard drive space (see note)

CD-ROM drive

TCP/IP network interface

A persistent Internet connection.

Note: We recommend at least a 1 GB hard drive for both the application and the documents you 
exchange.

Software on UNIX
This topic lists the operating systems and other software necessary to install and configure 
WebLogic Integration – Business Connect on UNIX platforms.

X Windows and Operating Systems
Your system requires X Windows and any of the following UNIX operating systems:

Hewlett-Packard HP-UX 11.0

IBM AIX 4.3.3

Sun Solaris 2.7 or 2.8

OS Patches
Patches for some operating systems are required to support the Java technology that WebLogic 
Integration – Business Connect uses. For information about recommended patches, see the 
WebLogic Integration – Business Connect Release Notes at:

http://e-docs.bea.com/wlibc/docs81/relnotes/index.html

http://e-docs.bea.com/wlibc/docs81/relnotes/index.html
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Recommended Software for UNIX
You should have Internet Explorer version 4.0.1 or later or Netscape Navigator version 4.0 or 
later. You use a browser to read WebLogic Integration – Business Connect online help files and 
to obtain third-party certificates from certificate authorities such as VeriSign, Inc.

In addition, you need Adobe Acrobat Reader to view and print the Using WebLogic Integration 
– Business Connect, which is provided in portable document format (PDF) files. The PDFs are in 
the userdoc directory on the installation CD and in the doc subdirectory after you install the 
application. Acrobat Reader is available free from Adobe Systems Inc., www.adobe.com.

Notes for users of HP-UX
Default values in HP-UX 11.0 and 11i for threads and other processes are too low for a Java 
application like WebLogic Integration – Business Connect. We recommend using the SAM tool 
to adjust kernel parameters to the values in the following table. We recommend that you involve 
your organization’s UNIX administrator in making these changes.

Possible Port Conflicts
Some transports and database types have default port assignments in WebLogic Integration – 
Business Connect. It is possible a default port assignment might conflict with a port already in 
use on your system. You can execute a command to check for possible conflicts. You can use the 
command before installing WebLogic Integration – Business Connect to eliminate possible port 
conflicts or after installing if you encounter a problem.

Parameter New value Description

max_thread_proc 1024 Maximum number of threads allowed in each 
process.

maxfiles 256 Soft file limit per process.

maxusers 256 Affects other parameters.

nkthread 3635 Total number of kernel threads available.

nproc 2068 Maximum number of proc table entries.

ncallout 2084 Maximum number of pending time-outs.
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You can use the netstat command to generate a list of ports in use on your system. The command 
is executed in the following ways.

Windows
In a command prompt or DOS window, type netstat -a to display a list of ports in use. 
You can instead type netstat -a | more to page through the list.

UNIX
On a command line, type netstat - a to display a list of ports in use. Or, to find whether 
a specific port is in use, type netstat -a | grep port_number.

List of Default Ports
The following table lists the default port assignments in WebLogic Integration – Business 
Connect. The table says where you can change a port number.

If there is a conflict, you can free the port for use by WebLogic Integration – Business Connect. 
Alternately, you can configure WebLogic Integration – Business Connect to use an inactive port 
above 1024 that is not listed in the output of the netstat command.

Description Default port Where to change it

RMI 1099 Section 3 of DB.properties file. The RMI.Port property 
has a null value by default, which means 1099.

Oracle 1521 Section 2C of DB.properties file.

Sybase 2638 Section 4 of DB.properties file.

DB2 50000 Section 2C of DB.properties file.

MS SQL 1433 Section 2C of DB.properties file.

Bundled HTTP 4080 Ports tab in Tools→Preferences in Administrator.

Bundled HTTPS 1443 HTTPS Transport Options window, which is accessed 
from the Company Profile window Inbound Protocols tab 
for users of the AS2 protocol.

SOAP 4081 Ports tab in Tools→Preferences in Administrator.

SMTP 4025 Ports tab in Tools→Preferences in Administrator.

SMTP SSL 4026 Ports tab in Tools→Preferences in Administrator.
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The DB.properties file mentioned in the previous table is in the WebLogic Integration – Business 
Connect installation directory. Before editing the DB.properties file, we recommend that you 
copy the file and rename it as a backup. For example, rename the file DB.properties_old.

About the User License File
A file named license.xml contains the permissions for using specific functionality of 
WebLogic Integration - Business Connect. If you purchased WebLogic Integration – Business 
Connect, you received a production version of license.xml from BEA. Copy this file to a 
location that will be accessible during installation. You will be prompted to provide the path to 
the license file during the installation process. If you are evaluating WebLogic Integration – 
Business Connect leave the location of the license file blank when prompted; the installer will 
automatically generate a license.xml which allows you evaluate all functionality of WebLogic 
Integration - Business Connect for 30 days.

The license.xml file is installed in your WebLogic Integration – Business Connect installation 
directory. Each time you start a system component, such as Server, Administrator or Tracker, the 
system checks for the presence of this file in the installation directory. The license.xml file 
makes available the functionality you are authorized to use under your user license. You cannot 
use the application unless the file is present.

Do not delete the license.xml file from the installation directory. Do not rename the file or 
attempt to alter the contents in any way as this will make your system inoperable. The file is 
hashed and signed to protect it from tampering.

If you have purchased WebLogic Integration – Business Connect, we recommend that you keep 
a copy of the license.xml file in a secure place other than the installation directory in the event 
you need to re-install the application on the same or a different computer.

Security Considerations
To ensure the integrity of data processed by WebLogic Integration – Business Connect, we 
recommend that you adhere to the following security measures in addition to your company's 
own security policies. Although the risks are possibly remote, failure to institute minimum 
security measures may result in compromised data.

1. Install WebLogic Integration – Business Connect in the data layer behind a firewall and not 
in an area unprotected from exposure to the Internet.

2. Do not install or run WebLogic Integration – Business Connect under a privileged account. 
This includes root in UNIX and administrator or system accounts in Windows NT.
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3. Do not view a binary document in Tracker that has been received by WebLogic Integration 
– Business Connect without first scanning the document for viruses.

4. Institute a policy for periodically changing the passwords for accessing Administrator, 
Tracker and the Server Monitor web page that is viewed in a browser by selecting 
Tools→Launch Server Monitor in Administrator.

5. Control access to the computer running WebLogic Integration – Business Connect to 
authorized users. 

6. If your manually distribute your certificate to partners, do so via a secure means. Encourage 
your partners to do likewise.

7. Restrict access via the firewall to the WebLogic Integration – Business Connect SOAP port 
only to authorized clients or networks.

Hardware Scalability
Scalability is the ability to support greater data load or throughput by increasing hardware 
resources without degrading processing time or system stability. In other words, scalability is the 
system's ability to cope with an increase in the data when the increase is matched by a 
proportional increase in hardware resources. If processing time degrades, despite the addition of 
hardware resources in proportion to the increase in load, then the system is not scalable.

To meet increased load, you can increase one or more of the following: central processing units 
(CPUs), memory or the number of machines. 

Like most solutions, WebLogic Integration – Business Connect does not scale linearly with an 
increase in CPUs. A system processing 10,000 1 kilobyte transactions a day, for example, will 
not necessarily be capable of processing 20,000 1 KB transactions with the addition of another 
CPU. This characteristic must be considered before deciding to increase processing hardware.

Before adding hardware resources, tune the WebLogic Integration – Business Connect 
configuration for the best performance possible. Remember, processing power is not just adding 
processors. It is a combination of processors, memory, network speed, transport server 
performance, disk speed, database performance, and other elements that can affect your system.

For information about tuning the application to improve performance, see Using WebLogic 
Integration – Business Connect.

http://edocs.bea.com/wlibc/docs81/admin/index.html
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C H A P T E R 2

Installation on Windows

The following topics are provided for installing the WebLogic Integration – Business Connect 
server and client applications on computers with Microsoft Windows operating systems.

Procedures

“Installing on Windows” on page 2-1

“Improper Display of Icons on Windows” on page 2-3

“Configuring as a Windows Service” on page 2-4

“Next Steps” on page 2-8

“Uninstalling on Windows” on page 2-8

Installing on Windows
Use this procedure to install WebLogic Integration – Business Connect from the installation CD.

Note: If you plan to upgrade from an earlier version of WebLogic Integration – Business 
Connect, see Chapter 4, “Upgrading,” before installing.

Before installing WebLogic Integration – Business Connect, see Chapter 1, “System 
Requirements,” to ensure your hardware, software and communications are ready.

Optionally, we recommend that you create a Windows user ID and password to be used by all 
persons who work with WebLogic Integration – Business Connect. Use this user ID for all 
installation, configuration, maintenance or monitoring of the Administrator, Server and Tracker 
applications. See your systems administrator for information and assistance.
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Steps
1. Close any applications that might be running on your local machine.

2. Place the installation CD in the CD-ROM drive. When the CD menu appears, click 
Windows to launch the installation wizard.

If the CD menu does not appear after you insert the CD in the CD-ROM drive, use 
Windows Explorer and double-click the install.bat file in the windows directory on the 
CD.

3. Follow the on-screen prompts for installing the application.

If you have purchased a license from BEA, provide the complete path to the license.xml 
file you received when prompted. If you are evaluating the software, leave the path blank 
and click Next to continue. A a 30-day evaluation license will be created for you. See 
“About the User License File” on page 1-7.

You are also prompted to enter the fully qualified domain name or IP address of the 
computer where the Server application is installed. The Server application does not need to 
be running while you are installing the client.

When prompted to select an installation directory, be advised that you cannot use a 
directory name that includes blank spaces.

When you are prompted to click Install, a window appears that shows the progress of the 
installation. When the installation is completed, an installation summary window appears. 

4. Click Exit to exit the window.

The installation process adds the WebLogic Integration – Business Connect program group 
to the Start menu. The icons are shown in the following table.

Table 2-1  Program Icons

Administrator Start Server Tracker

View Server Log Stop Server Document Generator
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There also are icons for opening the PDF file for Using WebLogic Integration – Business 
Connect and the help systems for Administrator and Tracker.

5. Select Start→Programs→BEA WebLogic Integration – Business Connect 
8.1→Administrator to log on to Administrator. See “Getting Started” in Using WebLogic 
Integration – Business Connect.

Improper Display of Icons on Windows
If you are installing the application as an upgrade of an earlier version, Windows might display 
the incorrect application icons on the Start menu. Windows caches the icons from the previously 
installed application. This situation does not affect the application or impair performance in any 
way. But if you encounter this and want to remedy it, follow these steps to clear the cache so 
Windows uses the new icons.

Steps
1. On an empty area of your Windows desktop, right-click to display a pop-up menu.

2. Select Properties at the bottom of the menu to open the Display Properties window.

3. Select the Appearance tab.

4. Select Icon from the Item drop-down list.

5. See the Size field to the right of the Item field. Make a note of the value.

6. Change the Size field value. For example, change 32 to 33.

7. Click Apply. Your desktop icons will disappear momentarily while the icon cache is rebuilt.

8. Change the value in the Size field back to the original value. For example, change 33 back 
to 32.

9. Click Apply. Your desktop icons will reappear after a short delay. The application icons also 
will display correctly.

10. Click OK to close the Display Properties window.
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Configuring as a Windows Service
Running WebLogic Integration – Business Connect as a service in Windows NT or Windows 
2000 provides the following functionality:

Windows can start the Server application during the Windows system initialization process 
and stop the application when Windows is shut down.

The Windows system administrator can use Windows services to manually start or stop the 
service from the local machine that hosts WebLogic Integration – Business Connect.

Note: While the Server application is set up as an Windows service, you should not start the 
application from the Start menu.

The following topics are provided for using WebLogic Integration – Business Connect as a 
Windows service.

“Installing the ECEngine Utility to Support Configuration as a Windows Service” on 
page 2-4

“Configuring as a Windows NT Service” on page 2-5

“Configuring as a Windows 2000 Service” on page 2-6

“Starting as a Service” on page 2-6

“Removing from the List of Services” on page 2-7

“Changing the NT Service Start-Up Options” on page 2-7

Installing the ECEngine Utility to Support Configuration as a 
Windows Service
Use this procedure to install the ECEngine utility to enable you to configure WebLogic 
Integration – Business Connect as a service in Windows NT or Windows 2000.

Steps
1. Click Start in Windows and then open an MS-DOS command prompt window.

2. Use the cd command to change the current directory to the following:

installation_directory\util\NT Service
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3. Then type the following:

ECEngine.exe -i

4. Press Enter. Wait for the prompt to reappear.

5. Close the MS-DOS command prompt window.

6. Go to “Configuring as a Windows NT Service” or “Configuring as a Windows 2000 
Service” on page 2-6.

Configuring as a Windows NT Service
Use this procedure to configure WebLogic Integration – Business Connect as a service in 
Windows NT.

1. Install the ECEngine utility. See “Installing the ECEngine Utility to Support Configuration as 
a Windows Service” on page 2-4.

2. In the Windows NT Control Panel, double-click the Services icon. The Services dialog box 
opens.

3. In the Services dialog box, select ecengine and click the Startup button. The Service dialog 
box opens.

4. In the Logon As box, select the This Account option. Type Administrator, or select it 
from the list (click the More button to see the list). Type the Administrator’s password in 
the fields.

Note: Make sure the Interact with the desktop option is not selected.

5. Click OK.

You can now start the Server application. If at some time Windows NT stops and is 
restarted, Server is also restarted and runs in the background. You also can reboot the 
Windows NT server to have the Server application run in the background.

Note: The WebLogic Integration – Business Connect Windows NT service is set to 
Automatic mode as the default. If you want to start and stop the application manually, 
you should change the mode to Manual in the Windows NT Services panel. For more 
information see “Changing the NT Service Start-Up Options” on page 2-7.
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Configuring as a Windows 2000 Service
Use this procedure to configure WebLogic Integration – Business Connect as a service in 
Windows 2000.

1. Install the ECEngine utility. See “Installing the ECEngine Utility to Support Configuration as 
a Windows Service” on page 2-4.

2. Right-click on the My Computer icon on the desktop and select the Manage option. On the 
Computer Management window, expand the Services and Applications path and select 
Services.

3. Double-click the ECEngine service to open the ECEngine Properties window.

4. Make sure that Automatic displays in the Startup type field on the General tab.

5. Select the Log On tab. Select the radio button for This account. In the field following This 
account, type Administrator or click Browse and select Administrator. Type the password 
for the Administrator user in the password and confirm password fields.

6. Click Apply and OK to save your changes and close the window.

7. Close the Computer Management window.

The next time you start Windows, the WebLogic Integration – Business Connect Server 
application will start. You can use the Startup type field on the ECEngine Properties 
window to disable the service or change startup of the Server application from automatic to 
manual.

Starting as a Service
After you have installed WebLogic Integration – Business Connect as a service on Windows NT 
or Windows 2000, the Server application starts every time you reboot the computer or after every 
system outage.

Because WebLogic Integration – Business Connect runs in the background, the Server Display 
window does not display as when you start the Server application from the Start menu. To view 
transactions and other events as the system writes them to the console log, open the View Server 
Log tool.

Note: You can stop the Server application in the current Windows session by selecting 
Programs→BEA WebLogic Integration – Business Connect 8.1→Stop Server on the 
Start menu. The next time you start Windows, the Server application starts again as a 
service.
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Removing from the List of Services
Use this procedure to remove WebLogic Integration – Business Connect from the list of services 
in Windows NT or Windows 2000.

Steps
1. Click the Windows Start menu button and then open an MS-DOS command prompt window.

2. Use the cd command to change the current directory to the following:

installation_directory\util\NTService

3. Then type the following: 

ECEngine.exe -u

4. Press Enter. The message “NT Service Uninstalled” appears.

5. Close the MS-DOS command prompt window.

Changing the NT Service Start-Up Options
The WebLogic Integration – Business Connect installation process installs the application as a 
service with an automatic start-up option. This means that the service is automatically started 
during Windows NT initialization. You can change this option if necessary.

Steps
1. In Windows click Start→Control Panel to open the Control Panel.

2. Double-click the Services icon. The Services dialog box appears.

3. Select WebLogic Integration – Business Connect in the Services box and then click the 
Setup button. The Service dialog box appears.

4. Select one of the following depending on your needs:

– Automatic
Select this option to have WebLogic Integration – Business Connect start when 
Windows NT starts.

– Manual
Select this option if you want to start WebLogic Integration – Business Connect 
manually from your desktop.
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– Disabled
Select this option if you do not want to run WebLogic Integration – Business Connect 
manually or automatically. This option leaves the WebLogic Integration – Business 
Connect in the list of available NT services in a disabled state.

Note: Make sure the Interact with the desktop option is not selected. This option is located 
at Start→Settings→Control Panel →Services→Startup.

5. Click OK on the Service dialog box and then click Close on the Services dialog box.

Next Steps
After you have successfully installed WebLogic Integration – Business Connect, Using 
WebLogic Integration – Business Connect provides the information you need to configure the 
application.

To view a PDF version of Using WebLogic Integration – Business Connect, choose 
Start→Programs→BEA WebLogic Integration – Business Connect 8.1→Administrator Guide. 

Using WebLogic Integration – Business Connect is also available on the BEA corporate Web site 
at the following URL:

http://e-docs.bea.com/wlibc/docs81/admin/index.html

Uninstalling on Windows
Use this procedure to remove WebLogic Integration – Business Connect from your Windows 
computer using the installation CD.

Note: To uninstall WebLogic Integration – Business Connect manually, delete the WebLogic 
Integration – Business Connect installation directory and the Start Programs menu 
shortcuts.

Steps
1. Place the installation CD in the CD-ROM drive.

2. Click Start→Settings→Control Panel to open the Control Panel window.

3. Click the Add/Remove Programs icon to open the Add/Remove Programs Properties dialog 
box.

http://e-docs.bea.com/wlibc/docs81/admin/index.html
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4. Select the WebLogic Integration – Business Connect program you want to remove and then 
click the Remove button.

The uninstall program removes some of the application files and directories and deletes the 
folder containing the application shortcuts and the Start Programs menu shortcuts. You can 
remove the remaining components by deleting the WebLogic Integration – Business 
Connect installation directory.
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C H A P T E R 3

Installation on UNIX

The following topics are provided for installing the WebLogic Integration – Business Connect 
server and client applications on computers with UNIX operating systems.

Concepts

“Initialization and Termination UNIX Script” on page 3-1

Procedures

“Installing on UNIX” on page 3-2

“Installing on Hewlett-Packard HP-UX” on page 3-4

“Installing on IBM AIX” on page 3-5

“Installing on Sun Solaris” on page 3-6

“Next Steps” on page 3-7

“Uninstalling on UNIX” on page 3-8

Initialization and Termination UNIX Script
After you have installed the application on UNIX, tested it to your satisfaction and are ready to 
place it into production, you might want to run it automatically in the background.
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Installed with the application is a System V initialization and termination script that enables you 
to start WebLogic Integration – Business Connect when you boot your system and close it when 
you shut your system down. We recommend that you get assistance from your UNIX system 
administrator if you want to implement this script.

The script is named interchange and is installed in the following location for each UNIX 
operating system:

installation_directory/bin/interchange

Installing on UNIX
Use this procedure as the starting point for installing WebLogic Integration – Business Connect 
on the supported UNIX operating systems. 

Note: If you plan to upgrade from an earlier version of WebLogic Integration – Business 
Connect, see Chapter 4, “Upgrading,” before installing.

The default installation process is text-based, but you can use an option that activates a graphical 
user interface during installation.

The following steps are common to all UNIX operating systems. Once you perform them, you 
are directed to the procedure for your particular operating system to complete the installation.

When installing using the server installation CD you are asked to provide the location of your 
license.xml file. If you have purchased a license from BEA, provide the complete path to the 
license.xml file when prompted. If you are evaluating the software, leave the path blank. A a 
30-day evaluation license will be created for you.  See “About the User License File” on page 1-7.

Before you install WebLogic Integration – Business Connect, see Chapter 1, “System 
Requirements,” to ensure your hardware, software and communications are ready for installation 
of the application.

Steps
1. Create a user account for WebLogic Integration – Business Connect (connect, for example) 

as the home directory for the application. For example, you can use one of the following as a 
home directory:

/opt/connect

/usr/local/connect
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Note: The directory must not be automounted or on an automounted file system. WebLogic 
Integration – Business Connect cannot run correctly on an automounted file system. 
This applies to volumes mounted using the automount utility and not to volumes that 
are automatically mounted at startup. WebLogic Integration – Business Connect 
cannot be installed on automounted volumes because of automatic unmounting of 
such drives.

2. Determine the device name of your CD-ROM drive.

The installation CD has a standard ISO-9660 (High Sierra) file system with Rock Ridge 
extensions.

3. Determine how much RAM your server has. You need to enter this information during the 
installation routine.

4. See the installation procedure for your operating system:

– “Installing on Hewlett-Packard HP-UX” on page 3-4

– “Installing on IBM AIX” on page 3-5

– “Installing on Sun Solaris” on page 3-6

The following installation guidelines apply to all UNIX operating systems.

You can use the following options with the install.sh command:

Table 3-1  install.sh Options

Option Description

-g Uses a graphical user interface (GUI) for the installation routine. The default 
routine is text-based.

If you use this option, ensure you have X Windows connectivity to the server 
where you are going to install the application. This option tests for X Windows 
capability and, if the system passes, launches the GUI installation.

-s Logs screen output to the file 
installation_directory/logs/install.log

-x Prints all commands before they are executed. Used for debugging, this is a 
powerful tool when combined with the -s option.
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When using the default text-based installation, be aware of the following:

– Press Ctrl+C to cancel the installation at any time.

– When the license agreement text displays, press Enter to scroll through the text until 
you reach the accept agreement prompt or type q and press Enter to skip through the 
license and go directly to the accept agreement prompt.

– When the ready to install prompt appears, press Enter to install or type 2 and press 
Enter to cancel the installation.

When prompted to select an installation directory, be advised that you cannot use a 
directory name that includes blank spaces.

When prompted to type the path where your HTML browser is located, you can skip this 
and specify a location later by selecting Tools→Preferences in Administrator. You use a 
browser to access the online help and obtain certificates from third-party certificate 
authorities. You will not be able to access the online help until you specify a browser.

Following installation, the Terminal window provides the command for starting 
Administrator. It also provides instructions for enabling group access to the application.

Installing on Hewlett-Packard HP-UX
Use this procedure to install the application on your Hewlett-Packard HP-UX server.

Steps
1. Log in as root.

2. Insert the WebLogic Integration – Business Connect CD into the CD-ROM drive.

3. If /mnt does not exist, create it with the following command:

mkdir /mnt

4. Mount the WebLogic Integration – Business Connect CD with the following command: 

mount -o cdcase /dev/dsk/* /mnt

where /dev/dsk/* is the device name of your CD-ROM.

5. Log out as root.

6. Log in to the account you created previously.
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7. From the home directory, run the following command:

/mnt/hpux/install.sh

8. Follow the instructions in the installation process.

9. Log out from the account.

10. Log in as root.

11. Unmount the WebLogic Integration – Business Connect CD by running the following 
command:

umount /mnt

12. Eject the WebLogic Integration – Business Connect CD from the CD-ROM drive.

13. Log out as root.

Installing on IBM AIX
Use this procedure to install the application on your IBM AIX server.

The Logical Volume Manager (LVM) enables the user to specify the physical sectors of the hard 
drive, or group of hard drives, to use when creating a volume on the AIX. The sectors closest to 
the center spindle of the disk generally give the fastest, most efficient, input and output reads and 
writes. The sectors towards the edge of the disk generally give the slowest input and output 
results. Once the LVM is used to create and mount a volume on the AIX, WebLogic Integration 
– Business Connect can be installed into a directory on that mount point just as it can with a 
non-LVM volume. The WebLogic Integration – Business Connect software itself is not aware of 
whether or not this is an LVM mount point.

Steps
1. Insert the WebLogic Integration – Business Connect CD into the CD-ROM drive.

2. Log in as root

3. Run the command: 

mount -vcdrfs -r -p /dev/cd? /mnt

where /dev/cd? is the device name of your CD-ROM. Possible values are 0 through 9. If 
you have only one CD-ROM, its number is probably 0.

4. Log out as root.
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5. Log in to the account you created previously.

6. From the home directory, run the following command:

/mnt/aix/install.sh

7. Follow the instructions in the installation process.

8. Log out from the account.

9. Log in as root.

10. Unmount the CD by running the following command:

umount /mnt

11. Eject the CD from the CD-ROM drive.

12. Log out as root.

Installing on Sun Solaris
Use this procedure to install the application on your Sun Solaris server. Note that separate 
procedures are provided, depending on whether you are running the automounter.

Steps
If you are running the automounter (the Solaris default):

1. Log in to the account you created previously.

2. Insert the WebLogic Integration – Business Connect CD into the CD-ROM drive.

3. From the home directory, run the following command:

/cdrom/solaris/install.sh

4. Follow the instructions in the installation process.

5. Eject the WebLogic Integration – Business Connect CD by running the following 
command:

eject cdrom
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If you are not running the automounter:

1. Insert the WebLogic Integration – Business Connect CD into the CD-ROM drive.

2. Log in as root.

3. Run the command: 

mount /dev/sr? /mnt

where /dev/sr? is the device name of your CD-ROM. Possible values are 0 through 9. If 
you have only one CD-ROM, its number is probably 0.

4. Log out as root.

5. Log in to the account you created previously.

6. From the home directory, run the following command:

/mnt/solaris/install.sh

7. Follow the instructions in the installation process.

8. Log out from the account.

9. Log in as root.

10. Unmount the WebLogic Integration – Business Connect CD by running the following 
command:

umount /mnt

11. Eject the WebLogic Integration – Business Connect CD from the CD-ROM drive.

12. Log out as root.

Next Steps
After you have successfully installed WebLogic Integration – Business Connect, Using 
WebLogic Integration – Business Connect provides the information you need to configure the 
application.

To view a PDF version of Using WebLogic Integration – Business Connect, open 
installation_directory/doc/admin.pdf in Adobe Acrobat.
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Using WebLogic Integration – Business Connect is also available on the BEA corporate Web site 
at the following URL:

http://e-docs.bea.com/wlibc/docs81/admin/index.html

Uninstalling on UNIX

Use this procedure to remove WebLogic Integration – Business Connect from your UNIX 
computer.

Steps
1. Log in to the account you created previously.

2. Shut down all WebLogic Integration – Business Connect applications.

3. Run the following command:

rm -rf installation_directory

All program files and documents are removed from your computer.

http://e-docs.bea.com/wlibc/docs81/admin/index.html
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C H A P T E R 4

Upgrading

You can upgrade the application’s database from version 2.1 or 7.0 to version 8.1 of WebLogic 
Integration – Business Connect. Upgrading is a two-step process in which you install version 8.1 
and then copy the database information from the previous version. The migration path ensures 
that you can use the company and partner profiles, certificates, schedules and logs from the 
previous version.

The database upgrade process is aimed at preserving the directory structure between versions. 
Although the directory structure remains the same, files within the directories do not migrate to 
the new, identical structure.

The following topics are provided:

Concepts

“Upgrade Requirements and Conditions” on page 4-2

Procedure

“Upgrade the Database” on page 4-2
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Upgrade Requirements and Conditions
Review the following requirements and conditions before you upgrade the database to version 
8.1.

Do not uninstall your current version of WebLogic Integration – Business Connect. It must 
be present with its database files intact for the upgrade process to work.

After installing 8.1, you can run the 8.1 database upgrade utility only once. If you need to 
run it again, you must reinstall 8.1.

The 8.1 upgrade utility does not change the database used by the previous version.

You can upgrade on any platform WebLogic Integration – Business Connect supports, but 
only on the same platform and not across platforms. If you want to upgrade and change 
platforms (for example, Windows to UNIX) at the same time, you must install 8.1 on the 
new platform and then re-create your configuration data.

If you trade with any partners using bundled HTTP or HTTPS, you must update your 
company profile and send the updated profile to your partners after completing the 8.1 
upgrade.

Upgrade the Database
Use this procedure to upgrade the database from version 2.1 or 7.0 to version 8.1 of WebLogic 
Integration – Business Connect. Upgrading is a two-step process in which you install version 8.1 
and then copy the database information from the previous version to 8.1. Before upgrading, we 
recommend that you review “Upgrade Requirements and Conditions” on page 4-2.

Upgrading during a lull in trading is the preferred method.

If the upgrade process fails or if error messages you cannot resolve appear during the upgrade 
process, contact customer support for help.

Steps
1. Resolve all document trading for your WebLogic Integration – Business Connect 2.1 or 7.0 

system. Make sure message disposition notices (MDNs) have been received for outbound 
documents. Make sure MDNs have been sent for inbound documents.
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2. Stop the WebLogic Integration – Business Connect 2.1 or 7.0 Server application. This has 
the following effects:

– Outbound messages accumulate in the outbound directories.

– Inbound documents remain on the POP or FTP servers. HTTP or HTTPS documents 
are not received because the partner cannot connect to the internal HTTP or HTTPS 
server. (After conversion, these will be received normally.)

3. Export the configuration data from your WebLogic Integration – Business Connect 2.1 or 
7.0 Administrator.

Select File→Export Administrator Data to open the Export Administrator Data window. 
Use the default name of the file to export, Administrator.dat, or type another file name. 
Select the directory where you want to save the file and click Save. You have the option to 
type a password to secure the exported file.

4. Export the log data from your WebLogic Integration – Business Connect 2.1 or 7.0 Tracker.

Select File→Save Tracker Runtime Data to open the Export Tracker Runtime Data 
window. Use the default name of the file to export, Tracker.dat, or type another file 
name. Select the directory where you want to save the file and click Save. You have the 
option to type a password to secure the exported file.

5. Close your WebLogic Integration – Business Connect Administrator and Tracker.

6. Rename the WebLogic Integration – Business Connect 2.1 or 7.0 directory. For example, on 
Windows you could rename the directory installation_directory_old.

7. Install version 8.1. See the Chapter 2, “Installation on Windows,”or Chapter 3, “Installation 
on UNIX.”

If you want the directory structure for 8.1 to be identical to the previous version’s, make 
sure you install 8.1 in a directory of the same name as the previous version’s before you 
renamed the directory in previous step.

Ensure that the installation process runs without error.

Note: After the application is installed, do not run any version 8.1 component 
(Administrator, Server or Tracker) until you have upgraded the database.

8. Start the 8.1 database upgrade utility and open the Upgrade Database window.

In Windows, the upgrade utility is in the WebLogic Integration – Business Connect bin 
directory. Double-click Upgrade.bat.
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In UNIX, run the following command:

installation_directory/bin/upgrade

Figure 0-1   Upgrade Database window

9. Make sure the Configuration and Logs check boxes are selected. Both check boxes are 
selected by default.

10. Click Browse next to the Configuration File field to open a browse dialog box. Select the 
directory where you saved the 2.1 or 7.0 Administrator.dat file in step 3 and click 
Open.

If you set a password for the file, type the password in the Configuration Password field.

11. Click Browse next to the Logs File field to open a browse dialog box. Select the directory 
where you saved the 2.1 or 7.0 Tracker.dat file in step 4 and click Open.

If you set a password for the file, type the password in the Logs Password field.

Importing the Tracker.dat file is optional. 
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12. Click Upgrade to start the upgrade process. When the process is completed, a message 
appears confirming the success of the upgrade.

13. Click OK to close the upgrade successful dialog box.

14. Click Close to close the Upgrade Database window.

15. You can now do the following to verify a complete and error-free conversion.

Start Administrator for 8.1 (see “Starting Administrator or Tracker” in  “Getting Started” in 
Using WebLogic Integration – Business Connect).

The conversion process preserves all user passwords. If you used a password to log on to 
Administrator and Tracker in the previous version, you need to use the same one to log on 
in version 8.1.

Verify the following:

– Company profiles

– Partner profiles, especially transport and security information

– Certificates

– Any schedules you set up

– Users

– Start Tracker and verify the presence of all system logs.

Note: Document files in the former version’s backup, rejected and archive directories are 
not copied to the new directories. Neither are archived system logs in the archive 
directory copied to the new directory.

16. Do the following to resume trading. Start the WebLogic Integration – Business Connect 8.1 
Server. This results in new outbound documents being placed in the new EDI-, binary- or 
XML-out directories. Also, WebLogic Integration – Business Connect polls the POP3 
servers and processes any documents queued there.

WebLogic Integration – Business Connect can then re-establish bundled HTTP or HTTPS 
communications with partners who use those transports and receive any re-sent documents.

17. Using Tracker, monitor the exchange of documents to identify and resolve any exceptions.
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C H A P T E R 5

Trading Tutorial

After installing WebLogic Integration – Business Connect you can complete some basic tasks 
and observe the application send test documents from a company to a partner in a simulated 
trading environment on a single computer.

This tutorial can help you become familiar with the operations of related components of 
WebLogic Integration – Business Connect, including the Server, Administrator, Tracker and 
Document Generator applications.

This tutorial is for users who are licensed to use the SMTP or HTTP transport available with 
ebXML protocol. 

Note: We strongly recommend that you not engage in any real document trading with partners 
while using this tutorial. Also, if you quit this tutorial before finishing and do not plan to 
resume it, we recommend that you go to “Exercise 7. Delete the Tutorial Profiles” on 
page 5-23 and delete the profiles you have created.

The following topics are provided:

Concepts

“Tutorial Objectives” on page 5-2

“Tutorial Troubleshooting” on page 5-24
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Exercises

Complete the exercises in order. Each exercise builds on the previous one.

“Exercise 1. Create Company Profiles” on page 5-3

“Exercise 2. Export Companies and Import Partners” on page 5-12

“Exercise 3. Set Up Binary Partners” on page 5-15

“Exercise 4. Start the Server Application” on page 5-16

“Exercise 5. Start Document Tracking Tools” on page 5-19

“Exercise 6. Trade Documents” on page 5-21

“Exercise 7. Delete the Tutorial Profiles” on page 5-23

Tutorial Objectives
In this tutorial you will:

1. Log on to the Administrator application. Administrator manages company and partner trading 
profiles.

2. Create company profiles.

3. Specify a TCP/IP transport for receiving documents.

4. Create self-signed digital certificates for company profiles.

5. Export company profiles from Administrator.

6. Import partner profiles to Administrator.

7. Designate partners to whom you send binary documents.

8. Start the Server application. The Server is the trading engine for sending and receiving 
trading documents.

9. Create file system directories for outbound and inbound documents.

10. Log on to the Tracker application. Tracker is a tool for monitoring trading activity.

11. Open the Server Monitor page in a web browser. The Server Monitor is another tool for 
monitoring trading activity.
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12. Use Document Generator to create test documents for use in trading.

13. Send test documents to a partner.

14. Send and receive acknowledgments for traded documents.

15. Monitor trading activity using reporting tools.

16. Delete company and partner profiles.

17. Delete file system directories.

Exercise 1. Create Company Profiles
Use this exercise to create two company profiles to use for testing. These profiles will be 
identical, except for the name and ID. You also will create a self-signed digital certificate for each 
profile. Certificates are used to provide security in document exchanges.

This is the longest and probably most important exercise in this tutorial. Please follow the 
instructions carefully.

The two company profiles you create in this exercise will have names and IDs of sender and 
receiver, respectively. Both profiles will have as the inbound transport either Hypertext Transfer 
Protocol (HTTP) or Simple Mail Transfer protocol (SMTP).

In a real trading situation, you normally have only one company profile. However, in this tutorial 
you will create two company profiles because you will simulate a two-way trading relationship 
on a single computer. Both profiles are needed for the simulation.

Before you can begin, you must have successfully installed the application. 

Also before you begin, stop any system applications, other than Administrator, that might be 
running. This includes the Server, Tracker and Document Generator applications.
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Steps
1. Log on to the Administrator application.

If your operating system is Windows, select Start→Programs→BEA WebLogic Integration 
– Business Connect 8.1→Administrator to open the Login window (Figure 5-1).

If your operating system is UNIX, ensure you have X Windows connectivity to the system 
where WebLogic Integration – Business Connect is installed. Log in to the account you 
created during installation. Run the following command to open the Login window 
(Figure 5-1):

installation_directory/bin/admin

Figure 5-1   Login Window

If you logging on for the first time, use the default user ID Administrator and leave the 
password blank. Click OK to log on.

When you have logged on the Company Profiles information viewer is displayed 
(Figure 5-2).

Leave the Administrator running throughout the tutorial.



Exer c ise  1 .  C reate  Company  P ro f i l es

Using WebLogic Integration – Business Connect 5-5

Figure 5-2   Company Profiles Information Viewer

2. Click New to open the New Company Profile dialog box (Figure 5-3). This is the first step 
in creating a company profile.

Figure 5-3   New Company Profile Dialog Box

3. Type sender as both the name and ID of the profile you are creating.

4. Click OK to open the Company Profile window Identity tab (Figure 5-4).
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Figure 5-4   Company Profile Identity Tab

5. Complete the required fields identified by asterisks on the Identity tab. You only need to 
complete the required fields. You can type any values you want or type the following:

Do not click OK after you have typed values in the fields. You will click OK to save and 
close the profile only after you have used other tabs and completed the profile.

In this field Type this value

Address address

City city

Country code aa

Contact contact
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6. Click the Inbound Protocols tab (Figure 5-5). You do not use the Preferences tab in this 
tutorial.

Figure 5-5   Company Profile Inbound Protocols Tab

On the Inbound Protocols tab you select a business protocol and a transport method for 
receiving documents. WebLogic Integration – Business Connect supports the ebXML 
protocol and the following transports:

– POP

– SMTP

– HTTP

– HTTPS

Your user license specifies which of these your application supports.

7. Click Add to display the Add Protocol window (Figure 5-6).
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Figure 5-6   Add Protocol Window

8. Select the ebXML protocol from the protocol drop-down list. 

9. Select HTTP or SMTP from the transport drop-down list.

10. Click OK to open the configuration window for your selected transport.

11. Do one of the following, depending on whether you selected HTTP or SMTP:

If you selected HTTP, the HTTP Transport Options window opens (Figure 5-7). No action 
is required on this window. Click OK to close the window. After you click OK, the 
Inbound Protocols tab displays again. Do not click OK on this tab, but go to the next step.

Figure 5-7   HTTP Transport Options Window
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If you selected SMTP, the SMTP Transport Options window opens (Figure 5-8). Type 
sender@mail.com in the e-mail address field. (If you are creating the profile for the 
receiver profile, type receiver@mail.com instead.) Click OK to close the window. After 
you click OK, the Inbound Protocols tab displays again. Do not click OK on this tab, but 
go to the next step.

Figure 5-8   SMTP Transport Options Window

12. Review the following to determine whether you need to use the XML tab (Figure 5-9), and 
then go to step 13. You do not need to use the XML tab. A value has been selected for you 
on the XML tab based on your protocol.
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Figure 5-9   Company Profile XML Tab

13. Click OK to save and close the profile. You do not change the System Directories, 
Integration and Tuning tabs in this tutorial.

Upon clicking OK you are prompted to set up a certificate for the company. Click Yes to 
launch the certificate wizard (Figure 5-10). The default selection on the first window of the 
certificate wizard is to generate self-signed certificates. You will use the wizard to create a 
self-signed digital certificate for the profile. You will use all of the default selections in the 
wizard. Do not change anything.

If you click No when prompted to set up a certificate, the profile is saved and closed and is 
listed on the Company Profiles information viewer. To set up a certificate later, click 
Certificates on the left side to display the Certificates information viewer. Then click the 
name of the profile and click New to launch the certificate wizard.

Note: The System Directories tab shows the default paths on your file system for the 
directories where the system retrieves outbound documents and puts inbound 
documents. These directories are not created until you start the Server application. 
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This is explained in more detail in “Exercise 4. Start the Server Application” on 
page 5-16.

Figure 5-10   First Window of Certificate Wizard

14. Click Next twice to advance to the last page of the certificate wizard, then click Finish to 
generate the certificate.

When the certificate has been generated, the Company Profile information viewer is 
displayed. The new profile is listed.

Click the Certificates icon on the left side to display the Certificates information viewer. 
The viewer lists the new certificate for the new profile. Click the Company Profiles icon to 
return to the Company Profiles information viewer.

15. Create a company profile for receiver.

Make sure the Company Profiles information viewer is displayed.

Click New to open the New Company Profile window. Type receiver as both the name 
and ID of the profile you are creating. Go back and complete step 4. through step 14. to set 
up this profile and certificate.
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Alternately, you can use the clone feature as a short way to create a profile that is similar to 
an existing profile. Click Clone to open the New Company Profile window. Type 
receiver as both the name and ID of the profile you are creating. If you use SMTP as the 
transport (see step 11.), type receiver@mail.com in the e-mail address field on the SMTP 
Transport Options window. Click OK and then go to step 13. to set up the certificate.

16. To verify that you have successfully completed this exercise, check that company profiles 
for sender and receiver are listed on the Company Profiles information viewer. Also check 
that certificates for both companies are listed on the Certificates information viewer.

Exercise 2. Export Companies and Import Partners
Use this exercise to export the two company profiles you created as XML files and then import 
them as partner profiles.

A company profile is a profile that you own that contains information about your company and 
the transport you want partners to use to send you documents. When you send a partner your 
profile, it becomes a partner profile on his system.

Figure 5-11   Exporting and Importing a Profile

In this tutorial you will simulate both sides of a trading relationship, so you will export both 
company profiles and then import both as partner profiles. These profiles will exist both as 
companies and partners at the same time on your system. This is not a situation you will 
experience in real trading with actual partners. This duality is solely for the purpose of this 
tutorial. In a real trading situation, you normally have only one company profile and one partner 
profile for each partner with whom you exchange documents. Also in a real situation, you would 
not import your own company profile as a partner profile.

Steps
1. At the Company Profiles information viewer, select one of the company profiles, either sender 

or receiver.

2. Select File→Export to display the Export Company Profile window (Figure 5-12).
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Figure 5-12   Export Company Profile Window

3. Do not change anything on this window. Click OK to export the company profile as an 
XML partner profile. The file is exported to a system directory of WebLogic Integration – 
Business Connect.

Notice that you export only a copy of the profile. The original profile is still listed as an 
active profile on the Company Profiles information viewer.

4. Return to step 1. and export the other profile.

5. After you have exported both profiles, click the Partner Profiles icon on the left side of the 
window to display the Partner Profiles information viewer (Figure 5-13).



Trad ing  Tutor ia l

5-14 Using WebLogic Integration – Business Connect

Figure 5-13   Partner Profiles Information Viewer

6. Select File→Import to display the Import Partner Profile dialog box (Figure 5-14).

Figure 5-14   Import Partner Profile Dialog Box
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7. Select the XML file for one of the profiles, either sender or receiver, and click Open to 
import the file. A message box displays saying that the partner profile import succeeded. 
Click OK to close the message box. The imported profile is listed on the Partner Profiles 
information viewer.

8. Return to step 6. and import the other profile.

9. To verify that you have successfully completed this exercise, check that partner profiles for 
sender and receiver are listed on the Partner Profiles information viewer.

On the Partner Profiles information viewer, you can select one of the profiles, click Open 
and browse the profile tabs. However, do not make any changes to either profile.

Exercise 3. Set Up Binary Partners
Use this exercise to designate partners as traders of binary documents. Unlike EDI and XML 
documents, the contents of binary documents do not specify senders and receivers. WebLogic 
Integration – Business Connect parses EDI and XML documents to determine senders and 
receivers. To trade binary documents, however, you must tell WebLogic Integration – Business 
Connect the partners whom you plan to send binary documents for the documents to be properly 
routed.

Steps
1. At the Partner Profiles information viewer, select one of the partner profiles, either sender or 

receiver.

2. Click Open to open the profile and then select the Binary Directories tab (Figure 5-15).
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Figure 5-15   Partner Profile Window Binary Directories Tab

3. Next to the Companies field at the top of the tab click Add.

4. Click OK to save and close the profile.

5. Return to step 1. and set up binary trading with the other profile.

6. To verify that you have successfully completed this exercise, check that the Binary 
Directories tab for each partner shows the other partner as a binary company.

Exercise 4. Start the Server Application
Use this exercise to start the Server application, which must be running for document trading to 
occur. This action also creates the file system directories that WebLogic Integration – Business 
Connect polls for documents. The Server application gets the documents from the directories and 
then packages and sends them to partners. Starting the Server application also creates the 
directories where documents sent by a partner are put after the system receives and unpackages 
them.
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Note: When you create a company profile but before you start the the Server application, the 
Company Profile window System Directories tab shows the default paths for the file 
system directories. However, these directories are not actually created until the profile is 
saved and the Server application is running.

Steps
1. Start the Server application.

If your operating system is Windows, select Start→Programs→BEA WebLogic Integration 
– Business Connect 8.1→Start Server.

If your operating system is UNIX, run the following command:

installation_directory/bin/start_server

When you start the server on Windows, the Server Display window opens (Figure 5-16). 
This window has two tabs. The Agents tab shows active processes. The Transactions tab 
shows document activity. You can use a mouse to adjust the widths of the columns on the 
window.

Leave the Server running throughout the tutorial. On Windows, you can minimize the 
Server Display window but do not close it as that will close the Server application.

Figure 5-16   Server Display Window Agents Tab on Windows
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2. To verify that you have successfully completed this exercise, check your file system to see 
whether the system directories have been created for both company profiles (sender and 
receiver). For example, a Windows user can check using Explorer.

The directories are created under the WebLogic Integration – Business Connect data 
directory. Figure 5-17 shows a tree in Windows Explorer of these directories. Notice that 
there are a directory and subdirectories for each company profile: sender and receiver.

Figure 5-17   File system Directories Tree in Windows Explorer

The following table explains how some of the directories are used.

Subdirectory Description

backup The backup directory is where the system places backup copies of 
documents it processes. This also is a repository for message 
disposition notices (MDNs), which are messages you receive from a 
partner that acknowledge receiving documents from you.

binaryin The binary-in directory is where the system places binary documents 
that have been sent to you by a partner.
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Note: For users of the ebXML and RosettaNet protocols there is a document of particular 
importance. That is the message control document (MCD). An MCD is an XML 
document that contains a business message payload. Users of the ebXML and 
RosettaNet protocols will use test MCDs later in the tutorial.

Exercise 5. Start Document Tracking Tools
Use this exercise to start the Server Monitor web page and the Tracker application. You will use 
these tools to view document trading activity later in the tutorial.

Note: At this point the Administrator and Server applications should be running. If not, restart 
them.

Steps
1. In Administrator select Tools→Launch Server Monitor to open the Server Monitor page in 

your web browser (Figure 5-18). Take a few minutes to explore and become familiar with the 
web site.

The Server application must be running for the Server Monitor page to display.

binaryout The binary-out directory is where you place outbound binary 
documents. The system retrieves documents from the directory, 
packages them and sends them to your partner.

ediin The EDI-in directory is where the system places EDI documents that 
have been sent to you by a partner.

ediout The EDI-out directory is where you place outbound EDI documents. 
The system retrieves documents from the directory, packages them and 
sends them to your partner.

xmlin The XML-in directory is where the system places XML documents that 
have been sent to you by a partner.

xmlout The XML-out directory is where you place outbound XML documents. 
The system retrieves documents from the directory, packages them and 
sends them to your partner.

Subdirectory Description
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Figure 5-18   Partial view of Server Monitor Page

2. Log on to the Tracker application.

If your operating system is Windows, select Start→Programs→BEA WebLogic Integration 
– Business Connect 8.1→Tracker to open the Login window (Figure 5-19).

If your operating system is UNIX, ensure you have X Windows connectivity to the system 
where WebLogic Integration – Business Connect is installed. Log in to the account you 
created during installation. Run the following command to open the Login window 
(Figure 5-19):

installation_directory/bin/tracker

Figure 5-19   Login Window

If you logging on for the first time, use the default user ID Administrator and leave the 
password blank. Click OK to log on.

When you have logged on the Alerts information viewer is displayed (Figure 5-20). Take a 
few minutes to explore and become familiar with the application.
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Figure 5-20   Partial view of Alerts Information Viewer in Tracker

3. To verify that you have successfully completed this exercise, check that the Server Monitor 
page displays in your browser and that the Tracker application is running.

Exercise 6. Trade Documents
Use this exercise to send a message control document (MCD) from company sender to partner 
receiver. Use this exercise only if your protocol is ebXML.

Note: If you are coming back to this tutorial after a pause and you closed any WebLogic 
Integration – Business Connect applications, restart the Administrator, Server and 
Tracker applications, if necessary. Also, make sure the Server Monitor page is displayed 
in your web browser.

In this exercise you will configure several test MCDs and place them in the sender’s XML-out 
directory. WebLogic Integration – Business Connect will retrieve the MCD and package and send 
the payload to the receiver. After receiving the payload, the receiver will send an MDN to the 
sender that acknowledges receiving the payload.
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Steps
1. Locate the test MCD for your protocol in the WebLogic Integration – Business Connect 

directory.

For the ebXML protocol, the test MCD is at mcd\ebxml\testmcd. The file is named 
ebxml.mcd.

2. Copy the test MCD to any directory that is handy. For example, you could copy it to a temp 
directory or some other directory where you keep files. On Windows you could copy it to 
your desktop.

3. Open the copy of the test MCD with a text editor such as Notepad. Locate the sender and 
receiver elements within the routing information element. The information is near the top of 
the file.

The following is an example of this data in the ebXML test MCD:

<mcd:RoutingInfo>
<mcd:SenderId type="urn:duns.com">Company1</mcd:SenderId>
<mcd:ReceiverId type="urn:duns.com">Company2</mcd:ReceiverId>
<mcd:MarketPlace/>

</mcd:RoutingInfo>

4. Delete the text Company1 and type sender. Be careful not to change anything else.

5. Delete the text Company2 and type receiver. Be careful not to change anything else.

6. Save and close the file.

7. Make 5 or 10 copies of the test MCD and give each file a unique name. For example, name 
copies of the ebXML test MCD 1ebxml.mcd, 2ebxml.mcd, 3ebxml.mcd, and so on.

8. Place one of the uniquely named test MCDs in the sender’s WebLogic Integration – 
Business Connect XML-out directory. The directory is at data\sender\xmlout.

9. Use the Server Monitor page or Tracker to observe trading activity. Use refresh to update 
the Tracker display. On Windows you also can monitor trading on the Server Display 
window Transactions tab.

10. Try trading some more documents. We recommend that you keep the number of documents 
small. This makes it easier to monitor trading activity. It also makes it easier to trace and 
resolve problems. If you have problems trading, see “Tutorial Troubleshooting” on 
page 5-24.

11. Go to “Exercise 7. Delete the Tutorial Profiles” on page 5-23.
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Exercise 7. Delete the Tutorial Profiles
Use this exercise to stop WebLogic Integration – Business Connect processes and delete the 
company and partner profiles that you created for this tutorial. We recommend deleting the 
profiles because they have no use beyond this tutorial and should be removed.

Steps
1. Stop the Server application.

If your operating system is Windows, select Start→Programs→BEA WebLogic Integration 
– Business Connect 8.1→Stop Server.

If your operating system is UNIX, log in to the account you created during the installation 
process. Run the following command:

installation_directory/bin/stop_server

2. Delete the partner profiles sender and receiver.

At the Partner Profiles information viewer in Administrator, select a partner profile and 
click Delete. Then click Yes in the dialog box that appears to confirm you want to delete 
the profile.

3. Delete the company profiles sender and receiver.

At the Company Profiles information viewer in Administrator, select a company profile 
and click Delete. Then click Yes in the dialog box that appears to confirm you want to 
delete the profile.

4. Select File→Exit to close Administrator.

5. Select File→Clear All Runtime Logs in Tracker to delete the records of the test trading for 
this tutorial. When a dialog box appears asking whether you want to clear runtime logs that 
have not been archived, click Yes.

6. Select File→Exit to close Tracker.

7. Close your browser.

8. Delete the WebLogic Integration – Business Connect data directories for sender and 
receiver. These are data\sender and data\receiver.
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Tutorial Troubleshooting
If you are having trouble trading a document while doing the tutorial, the following are some tips 
for resolving problems.

General Guidelines
1. Is the Server application running? Documents cannot trade unless the Server is running.

2. Do you have two company profiles named sender and receiver and two partner profiles 
named sender and receiver?

3. Have you checked whether you made any mistakes when creating the company profiles for 
sender and receiver.

4. If you changed a company profile, did you export it and re-import it as a partner profile?

5. If you re-imported a partner profile and you are trading binary documents, do you set up the 
updated profile as a trader of binary documents?

6. If you are using the Document Generator, did you complete the fields correctly on the 
Document Generator window? Is the output directory correct?

ebXML Guidelines
1. Did you check the general guidelines first?

2. Are you using an MCD as the test document? You must use an MCD as the test document.

3. Have you properly set up the names of the sender and receiver in the test MCD?

4. Did you place the test MCD in the sender’s XML-out directory?

5. Have you copied and renamed the test MCD to provide a pool of uniquely named test 
MCDs? The system will reject a document that is named the same as a previously processed 
document.
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