BEA WebLogic Integration Kit for IBM VisualAge for Java

Installation Guide
Contents

. Installation Guide
  Overview ........................................................................................................... 1-2
  Hardware Requirements .................................................................................... 1-2
  Software Requirements ..................................................................................... 1-2
  Installing the Integration Kit ............................................................................. 1-3
    Considerations About the Installation ........................................................ 1-4
    Installed Components ................................................................................... 1-4
  Next Steps: VisualAge Configuration ............................................................... 1-5
  Setup for Import and Export Utilities ............................................................ 1-9
    Setup for Visual Café Import Utility ........................................................... 1-9
  New Java 2 Security .......................................................................................... 1-9
  Uninstalling the Visual Café Import Utility ..................................................... 1-10
  Uninstalling the Integration Kit ....................................................................... 1-10
  General Remarks ............................................................................................. 1-12
  Supported Configuration ............................................................................... 1-13
  Unsupported configurations ............................................................................ 1-13
  Limitations and Restrictions ........................................................................... 1-14
This guide presents information related to installation in the following sections:

- Overview
- Hardware Requirements
- Software Requirements
- Installing the Integration Kit
- Next Steps: VisualAge Configuration
- Setup for Import and Export Utilities
- New Java 2 Security
- Uninstalling the VisualAge for Java Export Utility
- Uninstalling the Visual Café Import Utility
- Uninstalling the Integration Kit
- General Remarks
- Supported Configuration
- Unsupported Configurations
- Limitations and Restrictions
Overview

IBM VisualAge for Java, Version 3.5 (Professional or Enterprise Edition), is an integrated, visual environment that supports the complete cycle of Java program development.

BEA WebLogic Server is an award-winning Java application server for developing, deploying, and managing Web applications. It simplifies the development of portable and scalable applications, and it provides interoperability with other applications and systems. BEA WebLogic Server also offers the most complete implementation of the Java 2 Enterprise Edition standard.

With the BEA WebLogic Integration Kit for IBM VisualAge for Java Version 3.5 (The Integration Kit), you can develop and debug your WebLogic Server applications from within VisualAge.

Hardware Requirements

- **Processor**: Intel Pentium or higher, or compatible processor.
- **Memory requirements**: 128MB RAM minimum; 256MB RAM or more recommended.
- **Disk space requirements**: 35MB for The Integration Kit alone. With IBM VisualAge for Java Version 3.5 and BEA WebLogic Server Version 5.1, 900MB required.

Software Requirements

- Microsoft Windows NT 4.0 with Service Pack 4 or above and Windows 2000
- IBM VisualAge for Java Professional or Enterprise Edition Version 3.5
Installing the Integration Kit

Make sure that IBM VisualAge for Java is not running.

1. If you have a previous version of The Integration Kit installed, please uninstall it by following all the instructions in “Uninstalling the Integration Kit” later in this document. Also, verify that the following directories have been deleted:
   - `VisualAge\ide\features\BEAWebLogicServerX.X.X`
   - `VisualAge\ide\features\BEAWebLogicExamplesX.X.X`
   - `VisualAge\ide\tools\weblogic-integration-visualage`
   - `VisualAge\ide\project_resources\WeblogicX.X.X`
   - `VisualAge\ide\license`
   - `VisualAge\ide\doc\Weblogic`

   **Note:** `X.X.X` represents the version number of The Integration Kit that you are deleting.

   **Note:** `VisualAge` refers to the location in which you have installed IBM VisualAge for Java.

2. Click on Start → Run. The Windows Run window appears.
   a. Locate the `setup.exe` file from the installation CD.
   b. Click OK. The installation program begins to install The Integration Kit.
   c. Follow the instructions on the screen. The installation program prompts you for the name of the directory in which The Integration Kit should be installed. Specify the IBM VisualAge for Java installation folder.

3. Select which components you wish to install. By default, all components are selected. See “Installed Components” later in this document.

4. Select whether to install the Visual Café Import Utility. The Import Utility imports the results from the Export Utility Component into Visual Café. (For details, see “Setup for Import and Export Utilities” later in this document.)
Installation Guide

**Note:** If you wish to install the Import Utility at a later time, re-run the Setup Installation. Do not de-select any components that are installed. De-selecting components causes them to be removed if they have already been installed. If the components are already installed, selecting these components will not cause files to be overwritten. Select the Visual Café Import Utility and proceed with the installation.

**Considerations About the Installation**

If you install IBM VisualAge for Java in the default location, the folder is `C:\Program Files\IBM\VisualAge for Java`.

The installation program copies The Integration Kit to the IBM VisualAge for Java root directory. As a result, the features of The Integration Kit become visible within the IDE once the IDE is restarted.

Before you can activate these features and use The Integration Kit, you must configure IBM VisualAge for Java. For instructions, see “Next Steps: VisualAge Configuration”.

**Installed Components**

During the installation, the software prompts you to choose whether or not to install the following components. The following list describes the items that are installed:

- BEA Weblogic Integration Kit for VisualAge for Java v3.5
  - Classes
    - Library classes required to run BEA WebLogic Server: most of the WebLogic Server classes plus some support libraries from Sun and other companies
  - Server classes
    - Classes needed for cleanup when starting or stopping the server from inside IBM VisualAge for Java
  - EJB Tools classes
Next Steps: VisualAge Configuration

Tools used to build EJB classes into jar files are configured for WebLogic Server from within the VisualAge IDE

- **BEA WebLogic Server Examples**
  Selection of examples shipped with BEA WebLogic Server
  - Applets, JMS, JNDI, Events
  - EJB

- **Visual Age for Java Export Utility**
  - The Export Utility allows Visual Age for Java Projects, packages, or both to be exported to the file system

Next Steps: VisualAge Configuration

Before you can use The Integration Kit tools you must configure IBM VisualAge for Java to set up the corresponding features. To do so, complete the following procedure:

1. Start IBM VisualAge. IBM VisualAge recognizes The Integration Kit as a new feature and update its configuration.

2. Delete the following packages from the workspace:
   a. Expand the Java Class Libraries project.
   b. Delete `javax.rmi` and `javax.transaction`.

   **Note:** If you are using the Enterprise Edition, you must create an open edition before you can delete any packages from Java Class Libraries.

3. Within the IDE, click on File → Quick Start (or press the Quick Start shortcut key, **F2**).

4. In the Quick Start window, select **Features** from the left-hand list.

5. Select **Add Feature** from the right-hand list. Click OK.

6. Select the following features:
   - BEA WebLogic Server 5.1.0
7. Click OK.

**Note:** IBM VisualAge for Java loads the BEA WebLogic Server packages into the workspace. This process may take a long time.

**Note:** Any errors reported on the All Problems page are due to optional CORBA; they do not cause any problems when The Integration Kit is being used. 22 errors and 1 warning are normal for VisualAge for Java 3.5 with service pack 8.

8. Verify the properties for the server by completing the following steps:

a. In the All Projects pane of the Projects tab, expand WebLogic Server.

b. Expand weblogic.integration.visualage.server.

c. Right-click the Server class and select Properties.

d. On the Program tab in the Properties window, verify that the weblogic.system.home property is set to the location of your WebLogic installation.
Figure 1  Server Properties

Note: Make sure that the “Properties” listed on your screen match those shown in the preceding figure. The properties window should contain the following entries:

- `weblogic.system.disableWeblogicClassPath=true`
- `weblogic.system.shutdownClass.VisualAge=weblogic.integration.visualage.server.Server`
- `weblogic.system.home=c:\weblogic`
- `weblogic.system.nativeIO.enable=false`
- `weblogic.system.shutdownArgs.VisualAge=`

- Ensure that the Save in repository (as default) checkbox is selected.
f. Open the Class Path tab of the Properties window. In the Extra directories path field, verify that the pathname shown points to the installation directory of your BEA WebLogic Server.

g. In the Project Path field on the Class Path tab, press the Edit... button. Verify that all the WebLogic projects except WebLogic OCI have been selected. Then press OK in the Class Path dialog box.

9. In most of the examples, WebLogic Server Classes, WebLogic Support Libraries, and WebLogic Java Enterprise Libraries must be included in the classpath of each executable class. Rather than changing the properties for each class, it is easier to add these resources to the Workspace classpath. To do so, complete the following procedure:

   a. Click on Window → Options. In the Options dialog box, select Resources.

   b. Enter the following pathname in the Class Path field:
      
      WebLogic\classes

      Here WebLogic refers to the directory in which BEA WebLogic Server has been installed.

      **Note:** If BEA WebLogic Server is installed in another location, enter the appropriate pathname in the Class Path field.

10. Click OK.

11. Obtain a proper license key from BEA and copy it into the License\BEA_IK_Lic.txt file located in the Visual Age for Java root installation directory.


13. Select the WebLogic Server installation directory (C:\WebLogic). This step makes available, to the EJB tools, the location of some required classes that have not been imported into the VisualAge workspace.

Now IBM VisualAge for Java is configured to run The Integration Kit tools.
Setup for Import and Export Utilities

This section provides setup instructions for the utilities used to import projects and packages into Visual Café and export them from IBM VisualAge for Java.

Setup for Visual Café Import Utility

2. Select Tools → Environment Options and choose the Internal VM tab.
3. Click New and select the path for VCExportUtility.jar located in the bin/components directory of the Visual Café Installation.
4. Click OK.
5. Restart Visual Café.

New Java 2 Security

Due to the Java 2 new security, the following has to be done in order to run BEA WebLogic Server within IBM VisualAge for Java. A new file BEA_IK.policy has been added by the installer into VisualAge\ide\program\lib\security. This file contains permissions to run the The Integration Kit examples within VisualAge for Java. In addition, the java.security file has been changed by the installer to include the following lines:

```
policy.url.n=VisualAge\ide\program\lib\security\BEA_IK.policy.
policy.url.n=file:Weblogic\weblogic.policy
```

Here VisualAge refers to the directory in which VisualAge for Java is installed and WebLogic refers to the directory in which BEA WebLogic Server is installed.

Note: n refers to the number of policy files you have in your java.security file.
Uninstalling the Visual Café Import Utility

2. Select Tools → Environment Options and choose the Internal VM tab.
3. In the Classpath Settings portion of the window, select the path for \VCExportUtility.jar located in the bin/components directory of the Visual Café Installation.
4. Click Del and then OK.
5. Shut down Visual Café.
6. Click Settings → Control Panel → Add/Remove Programs.
7. Select Visual Café Import Utility.
8. Click Add/Remove.

Uninstalling the Integration Kit

When you remove The Integration Kit from VisualAge, the tool base directory, features base directories, documents, and other resources are all removed. To remove The Integration Kit, complete the following procedure:

1. Copy the file Licence\BEA_IK_Lic.txt file in the Visual Age for Java root installation directory to an archive area. This is your license file and will be removed when uninstalling.

   **Note:** Follow the following steps in the order they are presented. Purging the repository before running the setup program can cause problems if re-installing the integration kit. If you have done this, restart Visual Age at least once before re-installing the integration kit.

2. Select Start → Settings → Control Panel → Add/Remove Programs.
3. Remove these WebLogic Features Projects classes from the workspace:
Uninstalling the Integration Kit

- WebLogic Examples
- WebLogic Java 2 Libraries
- WebLogic Java Enterprise Libraries
- WebLogic Server
- WebLogic Server Classes
- WebLogic Support Libraries
- WebLogic OCI

4. To purge The Integration Kit files from the repository, complete the following procedure:

a. Select Window → Repository Explorer.

b. In the Project Names window, select the projects you want to purge.

   The Integration Kit contains the following projects in the Repository Explorer:
   - WebLogic Examples
   - WebLogic Java 2 libraries
   - WebLogic Java Enterprise Libraries
   - WebLogic Server
   - WebLogic Server Classes
   - WebLogic Support Libraries
   - WebLogic OCI

   You must remove each of these projects.

c. In the Editions window, select the editions you want to purge.

   An edition is associated with each project of The Integration Kit. For each project, only one edition should be listed in the Editions window. If more than one edition exists, you might have installed BEA WebLogic Server Service Packs. To remove The Integration Kit entirely, you must remove all the editions for each project.

d. Right Click to open a menu and select Purge.

5. In the Repository Explorer, on the Package tab, remove all packages belonging to The Integration Kit using the purge command.
The names of these packages begin with the following strings:

- `example.ejb.XXX`
- `example.applet`
- `example.jms.XXX`
- `example.event.XXX`
- `example.jndi.XXX`
- `example.servlets`
- `weblogic.XXX.XXX.XXX`

(where `XXX` is a package name)

6. In the Repository Explorer, select `Java Class Libraries` under the Projects tab. In the Editions window, select `1.2.2` edition. Right click and select Add To Workspace. By doing so, you will add `javax.rmi` and `javax.transaction` back into the workspace.

7. Shut down the IBM VisualAge for Java IDE.

8. Open the `IBMVAJ\ide\program\lib\security java security` file and remove the following lines:

   ```
   policy.url.X=file:C:/weblogic/weblogic.policy
   policy.url.X=file:C:/program files/ibm/VisualAge for Java/ide/program/lib/security/BEA_IK.policy
   ```

   (X refers to a the number of `policy.url` lines in your file.)

9. Start the IBM VisualAge for Java IDE.

   After starting IBM VisualAge for Java, you should not see any projects related to BEA WebLogic Server.

10. If you have installed the Visual Café Import Utility, you may want to remove it. See the section on Uninstalling the Visual Café Import Utility.

## General Remarks

The Integration Kit gives you the ability to perform the following tasks:
Start and stop WebLogic Server from inside IBM VisualAge for Java Version 3.5 IDE

Compile, deploy, and debug EJBs running in WebLogic Server

Compile and debug servlets and applets

Unfortunately, there is no complete supported configuration (that is, a configuration that includes all the features offered for IBM WebSphere application server). This limitation is due to the fact that IBM VisualAge for Java is configured to integrate well only with WebSphere tools.

Be careful when opening or creating projects in the IBM VisualAge for Java workspace after The Integration Kit is installed.

The Integration Kit supports the following configuration:

- IBM VisualAge for Java v3.5 Professional or Enterprise Edition
- BEA WebLogic Server version 5.1 with Service Pack 8

Unsupported configurations

IBM VisualAge for Java Version 3.5 cannot be used with BEA WebLogic Server version 5.1 and Cloudscape. Cloudscape database usage is not supported because problems are caused when Cloudscape is run in the VisualAge environment. This issue is currently being investigate by IBM Support (PMR 15142,519,000).
Limitations and Restrictions

The Integration Kit has the following limitations and restrictions:

- If you configure the workspace for The Integration Kit, you cannot develop EJBs using facilities provided within IBM VisualAge for Java IDE, such as the EJB Wizard. The IBM VisualAge for Java EJB development environment (which supports the creation of EJBs, the generation of JavaBeans to access them, and database integration) is a closed system, tightly connected with IBM WebSphere. IBM VisualAge for Java Version 3.5 and WebSphere support EJB 1.0 while BEA WebLogic Server supports the EJB 1.1 specification. As a result, any code generated by the EJB wizard is different and creates compliance issues with a BEA WebLogic Server EJB 1.1 container.

- You cannot use the BEA WebLogic Server Dynamic EJB deployment (Hot deployment) feature while debugging server-side code in IBM VisualAge for Java. IBM VisualAge for Java supports its own internal dynamic class reloading; it does not support the debugging of classes that are not loaded from within the workspace.

- You cannot create JSPs using the IBM VisualAge for Java JSP wizard. IBM VisualAge for Java supports only the 0.91 and 1.0 JSP specification versus the 1.1 specification supported by BEA WebLogic Server Version 5.1.

- The Integration Kit cannot be installed in a workspace with the WebSphere Test Environment, or with other Enterprise features that require the WebSphere Test Environment.

- The WebLogic Server Native I/O Performance Pack currently cannot be used when the server is being run in IBM VisualAge for Java.

- The Integration Kit does not support remote debugging; only local debugging is supported.

- After running WebLogic Server within VisualAge for Java for two to three times, shut down VisualAge for Java so that unused memory can be released.