Previous Next vertical dots separating previous/next from contents/index/pdf

Understanding the Build Process

Before building your application, your application components must be assembled into projects. Projects and their usage are described in Applications and Projects. Review the information in Managing Project Dependencies to understand project dependencies and making JARs and J2EE libraries available to your projects.

Under normal circumstances, you will never explicitly build your projects/applications since by default, Workshop for WebLogic builds your files automatically, using the Eclipse Build Automatically feature. This feature does an incremental build whenever a program file is saved.

If you wish, you can build your files, projects and enterprise applications manually. Workshop for WebLogic uses the standard Eclipse commands for building, as described in detail in the Eclipse/JDT documentation, available by clicking Help > Contents and choosing Java Development User Guide from the Contents pane at the left.

Cleaning and Rebuilding

The clean operation (the Project > Clean command) cleans all build artifacts resulting from a previous build of a project. It's a good way to "start over" so that you know that your build output includes only the most up-to-date files based on your source code. You should clean your project before final production deployment.

Building a Production-Quality Application

Before you deploy your application to a production environment, you will probably want to perform a clean operation followed by a complete build in a controlled environment. In this way you can ensure that you have a formal, repeatable build process that you use every time you deploy an application to production.

The Build Commands

The Project menu provides the following standard Eclipse commands for building your files:

Command Description
Build All Build all open projects, including EAR projects, web projects, utility projects, EJB projects and any other open projects. This command is only available when the Build Automatically command is disabled.
Build Project Build a single project. This command is only available when the Build Automatically command is disabled.
Build Working Set Builds the current working set. A working set is a customized list of resources that you define using the pull-down menu from the Navigator view. Working sets are described in detail in the Eclipse documentation which you can view by clicking Help > Help Contents > Workbench User Guide. This command is only available when the Build Automatically command is disabled.
Clean Removes build artifacts and optionally rebuilds selected project(s).
Build Automatically This is the default setting. Clicking on this command toggles automatic build mode.

Related Topics

Creating Custom Ant Build Files for an Application

Deploying, Running, and Debugging Applications


Skip navigation bar   Back to Top