Previous Next vertical dots separating previous/next from contents/index/pdf

Overview: Upgrading from WebLogic Workshop 8.1

Workshop for WebLogic provides tools to help ease the process of upgrading applications built with version 8.1. These tools are designed to read your version 8.1 code and generate a new corresponding version 10.0 workspace. The newly generated code is a migrated, upgraded version of the 8.1 code in which all of the clearly predictable changes have been made (note that your application logic is not altered by upgrade tools). The new code supports a new annotation model, a different project model, and other component-oriented changes.

Note: The Workshop for WebLogic upgrade documentation assumes that your application was developed using WebLogic Workshop version 8.1. If it wasn't, you must migrate your code so that it builds and runs in the WebLogic Workshop IDE version 8.1 SP4, SP5, or SP6 before using the tools described here to upgrade to Workshop for WebLogic version 10.0.

This topic provides an overview of the changes from version 8.1 to version 10.0, as well as suggested high-level steps for approaching upgrade.

Differences Between the Version 8.1 and 10.0 IDEs, and the Applications Built with Them

Upgrade Process: High Level Steps

Preparing a Version 8.1 Application for Upgrade

Actions Performed By Upgrade Tools

Viewing the Upgrade Log

Differences Between the Version 8.1 and 10.0 IDEs and the Applications Built with Them

If you've been developing on WebLogic Workshop version 8.1, the most significant differences you'll notice in version 10.0 (and applications built with it) are likely to be:

You might also be interested in reading Key Differences for WebLogic Workshop 8.1 Users.

Key IDE Differences

Unlike version 8.1, in version 10.0 the IDE is built on the Eclipse Platform. This is a change that offers many benefits, including: the transparency of an open-source architecture; commonly used features that are familiar because they're available with other widely used Eclipse-based IDEs; and a widely used extensibility model via the Eclipse plug-in framework. To this open framework, Workshop for WebLogic adds many features to support iterative development of the kinds of components you built with version 8.1.

Needless to say, moving from the version 8.1 IDE to the Eclipse-based version 10.0 means that there are significant user interface changes. The following list describes how familiar version 8.1 features are (or are not) rendered in version 10.0.

Project Model Differences

Many of the changes from the version 8.1 to the version 10.0 project model are intended to align the model with broadly used Eclipse and Java conventions. If you've used other Eclipse-based IDEs, version 10.0 of Workshop for WebLogic should feel familiar. For a list of significant changes, see Changes During Upgrade from WebLogic Workshop 8.1 to Version 10.0.

Annotation Differences

Workshop for WebLogic version 10.0 supports the Java 5 annotation model. Whereas in version 8.1 the annotations in your source code were embedded in Javadoc-style comments, their version 10.0 counterparts are outside the comment block. In the abstract, however, there are more similarities than differences between the annotation model in versions 8.1 and 10.0. In other words, for most version 8.1 annotations there are version 10.0 counterparts that use the new syntax. Note that as with version 8.1, the version 10.0 IDE provides an editor (the Annotations view) through which you can view and edit annotation attribute values. For more information on the changes, see Upgrading Annotations.

Component-Specific Changes

These are changes that are specific to component types, such as web services, EJBs, controls, and so on. They primarily affect source code. You can read Changes During Upgrade from WebLogic Workshop 8.1 to Version 10.0 for a summary list, or see the individual technology-oriented topics listed at the bottom of this topic under Related Topics.

Upgrade Process: High Level Steps

These steps assume that your application was developed with WebLogic Workshop. If you wrote your code without using that IDE and you want to upgrade it using Workshop for WebLogic upgrade tools, you must first migrate your code so that it builds and runs in the WebLogic Workshop IDE.

  1. Ensure that your WebLogic Workshop version 8.1 applications have been upgraded to SP4, SP5, or SP6. The upgrade tools included in this release are designed to upgrade from those versions only.
  2. Undeploy WebLogic Workshop version 8.1 applications from your version 8.1 domain before you upgrade the server.

    Upgrading domains and upgrading WebLogic Workshop applications are separate processes, but they're interrelated. For information about upgrading version 8.1 WebLogic Workshop domains, see WebLogic Workshop Version 8.1 Domains Can Be Upgraded from Within Version 10.0.

  3. Use the topics in this documentation to determine whether it would be useful for you to do preparatory work on your version 8.1 application before using the upgrade tools to upgrade.

    For a list of suggested pre-upgraded changes, see Preparing a Version 8.1 Application for Upgrade.

    Also, see Changes During Upgrade from WebLogic Workshop 8.1 to Version 10.0 and Notes About General Issues. Those sections list upgrade-related issues, providing links to more information.

  4. Build your version 8.1 projects before upgrading them with upgrade tools. Certain version 8.1 build artifacts must be present in order for some upgrade changes to be successful.
  5. Use upgrade tools to upgrade the version 8.1 application.

    How To: Use the Import Wizard to Upgrade Version 8.1 Applications describes how to use the tool.

    You can also perform the wizard's work through the upgradeStarter Command or upgrade Ant Task.

  6. Use the upgrade log and these topics to determine how to start fixing any post-upgrade problems that might keep your upgraded application from running.

Preparing a Version 8.1 Application for Upgrade

If your applications are complex, upgrading them from version 8.1 to version 10.0 is likely to be a multi-step process. A key part of that process will be the upgrade support the IDE provides via upgrade tools. But you'll also find that some preparatory work on your version 8.1 application makes the wizard's end result much easier to work with and get running.

Take a look through the upgrade documentation provided here. Many of the notes recommend ways to edit your version 8.1 application to make your upgraded code easier to get running.

Actions Performed By Upgrade Tools

Workshop for WebLogic includes three tools that automate most parts of the upgrade process. Each tool does essentially the same thing, allowing you to specify applications and parameters for upgrade: the import wizard is available as user interface in the IDE; upgradeStarter Command exposes options from the command line; and the upgrade Ant task exposes options for use from Ant.

Note: You can also upgrade individual files once they're in the version 10.0 IDE. To do this, right-click the file, then click Upgrade Source Files. For information about the error logging and message verbosity options, see To Import and Upgrade a Version 8.1 Application.

The following briefly describes actions performed (and not performed) by the upgrader.

Viewing the Upgrade Log

Whether you use the import wizard, command-line, or Ant task to upgrade, Workshop for WebLogic will generate a log of the upgrade changes, errors, and warnings. If you use the import wizard, this log will also be displayed in a dialog you can review before completing the process.

Upgrade Preview Dialog

You can expand the node for each file to view the upgrade messages associated with that file. The following key describes the symbols displayed next to file names:

Informational message.

Warning message.

Error message.

Text Log File

Upgrade tools generate a log file containing upgrade messages. This file is available at the following location after upgrade has completed:


A log message in the file will take the following form:

!SUBENTRY 1 com.bea.workshop.upgrade81 severity_level date time
!MESSAGE Upgrade-related message.

The severity_level will be two numbers, but they have the same meaning. The date and time entries refer to when the upgrade was attempted. The upgrade-related message describes what was done, warned about, or the error that occurred. The following is a snippet that shows two log entry examples:

!SUBENTRY 1 com.bea.workshop.upgrade81 2 2 2006-02-27 17:17:53.687
!MESSAGE The 10.0 control context only supports a subset of the 8.1 control context APIs. Please see the Workshop for WebLogic upgrade documentation for more information.

!SUBENTRY 1 com.bea.workshop.upgrade81 1 1 2006-02-27 17:17:53.687
!MESSAGE The import "com.bea.control.JwsContext" needs to be updated.

Related Topics

Upgrading Web Services

Upgrading Page Flows

Upgrading Controls

Upgrading Annotations

Upgrading Enterprise JavaBeans


Skip navigation bar   Back to Top