Previous Next vertical dots separating previous/next from contents/index/pdf

Installation Instructions for BEA Workshop Studio Group of Products

This document describes how to install version 3.3 of the BEA Workshop Studio group of products, including:

Installation Notes:

To simplify installation on multiple machines, you may also configure the Workshop Studio installer for silent installation (i.e., you preset the configuration):

These installation instructions work for all of the BEA Workshop Studio products:

These instructions are for all of the Workshop Studio products, including free trials, free downloads, and purchased products. The screen shots are for the BEA Workshop Studio purchased product, but are similar for all products in the group.

Before you begin, you must have the Sun JDK/JRE (version 1.4.2 or higher for Windows, version 1.5 or higher for Linux) installed. For more information, go to the Sun web site.

When you purchase a Workshop Studio product, you receive a free subscription to all product updates for one year from the date of purchase. After the end of your subscription, you cannot install new versions of your Workshop Studio product, unless you purchase a subscription extension at

Standalone Installation

To install a BEA Workshop Studio product, do the following steps.

  1. Download free trial installers from the BEA Workshop Studio Downloads page OR use the link that was provided when you purchased your product.
  2. Uncompress the installer file.
  3. For Linux, make sure that the PATH variable is updated with the required JDK path. If the PATH variable is not correct, use the command
    export PATH=/usr/java/jdk1.5.0/bin:$PATH

    Alternatively, the JDK path can be passed to the installer using the LAX_VM argument.

  4. Run the installer
    • For Windows: run WorkshopInstaller.exe .
    • For Linux: run ./ WorkshopInstaller.bin OR if the PATH variable is not correct, run ./ WorkshopInstaller.bin LAX_VM /usr/java/jdk1.5.0/bin/java
  5. The installer opening screen provides information about the installation process. Review the information and click Next to proceed.

  6. The next screen is the license agreement. Review the terms of the license carefully before proceeding. If you do NOT accept the terms of the license agreement, you will not be able to install this Workshop Studio product at this time. Click Next to proceed.

  7. The next screen allows you to select the folder where your Workshop Studio product will be installed. You can specify a location anywhere you wish. Click Next to continue.

  8. The next screen allows you to specify whether you wish to install your Workshop Studio product as a standalone product. Click Next to continue.

  9. From the next screen, you can choose whether program shortcuts should be created and where. After you make your selection, click Next to proceed.

  10. The next screen summarizes your installation choices. If you wish to proceed, click Install and the files will be copied to your hard drive and installed.

  11. Click Done on the final screen to end the installer.

Note that if you are using Studio with any project using the Java 5.0 compiler (Compiler compliance level of 5.0), then the Eclipse instance should be launched using Java 5.0 as well.

Plugin Installation to an Existing Installation of Eclipse

If you wish to install a Workshop Studio product as a plugin to an existing installation of Eclipse,

  1. Check the supported platforms to ensure that you have a suitable version of Eclipse installed.

    Workshop Studio products require Web Tools Platform (WTP) and if you do not have WTP installed (or if your installed version of WTP is not supported), the installation procedure will install the supported version of WTP.

  2. To install as a plugin, follow the instructions in Standalone Installation except that when prompted with the following screen, choose Install Workshop Studio as a plugin to an existing Eclipse . Click Next to continue.

    You will be prompted with an additional screen to specify the location of the existing Eclipse installation files. Once you have chosen the Eclipse installation folder, click Next to continue.


As for standalone installations, note that if you are using Studio with any project using the Java 5.0 compiler (Compiler compliance level of 5.0), then the Eclipse instance should be launched using Java 5.0 as well.

Installing Japanese or Chinese Versions of the IDE

At this time, the Chinese and Japanese support is available only to users of the BEA Workshop Studio product who have valid current licenses.

To install the Japanese or Chinese version:

  1. Install your BEA Workshop Studio product in the usual way (either as a standalone application or as a plug-in to an existing copy of Eclipse).
  2. Launch the Eclipse Update Manager by clicking Help > Software Updates > Find and Install. Be sure to choose Search for new features to install. The Japanese and Chinese versions are located on the BEA Workshop update site. You must have a valid login to BEA's dev2dev club in order to get this additional support. (If you do not have a login, click here first to register.)

Upgrading from Previous Versions

To upgrade from version 3.1 and earlier to version 3.3 , use the installer. You cannot use the Eclipse Update Manager to upgrade from version 3.1 or previous versions because those versions of the Workshop Studio products work with older versions of Eclipse and the Update Manager does not do the platform component upgrades required by version from 3.2.1 onward.

To upgrade from version 3.2 to version 3.3, you may either:


License Activation

All BEA Workshop Studio products (except free trials) require license activation. Activating your license activates your subscription to product updates from BEA.

When you install any BEA Workshop Studio product, it will operate for 30 days without a license. After that time, you must provide a license. For BEA Workshop for JSP, a free license is available at For purchased products, a license is provided by email on completion of your purchase.

When your subscription expires, you may renew it at You will receive an email confirming the renewal. After your renewal, you must activate the product again, using the original Order ID and Serial Number.

To activate your license choose Help > Workshop License. You may also activate your license from the Welcome screen that is displayed when you first launch the IDE. Enter the Order ID and Serial Number and click Activate to proceed.

If you want to install a purchased BEA Workshop Studio product on a DIFFERENT machine, you must first deactivate the license on the current machine. Purchased BEA licenses can be used on only one machine at a time.


Before uninstalling, you must deactivate the license on your machine. The Workshop Studio family of products are shipped under a license that is activated on each machine where you install the product. Purchased BEA licenses can be used on only one machine at a time. To deactivate your license, click Help > Workshop License from within the product.

To uninstall BEA Workshop Studio products:

The uninstaller removes everything that was installed: If the original installation was as a plugin, only the plugin will be removed. If the original installation was as a complete Eclipse installation, then Eclipse and WTP will also be removed.

If you installed the Spring IDE with your Workshop Studio installation, that will automatically be removed as well.

Upgrading from the Free Trial to a Subscription

If you have installed a free trial version of Workshop Studio, you can upgrade to a full product and subscription:

  1. Purchase the product online at
  2. Download and install the latest version of the product.
  3. Activate the license.


Customizing the Studio Installer for Silent Installation

To simplify installation on multiple machines, you can customize the operation of the Workshop Studio installer in a variety of ways, including silent installation (i.e., preset defaults and the users are not given the option to change installation settings).

A typical BEA Workshop installer includes two parts, the installation executable (WorkshopInstaller.exe) and the configuration properties file ( When the installer is unzipped and launched, the WorkshopInstaller.exe reads configuration information from the to determine how the installation will proceed.

In order to enable silent installation, additional information should be added to the

Below is a list of supported flags to enable silent installation. Note: It is assumed that and WorkshopInstaller.exe will reside in the same directory.

# silent mode
# default is Workshop_Studio_{major}.{minor}_{build}
# Install Workshop Studio standalone or use existing Eclipse installation # Radio component - only one should be on ("1")
  # ECLIPSE_FOLDER=C://eclipse

The following example creates a silent installation and includes a full install of Eclipse.

# valid values are 0000, 0000-trial, 0001, 0001-trial, 0002, 0002-trial, 0003, 0003-trial, 0004, 0004-trial, 0005, 0005-trial


If you experience problems getting the installation to work, review the following points:

Workarounds for Unsupported Platforms

The following platforms are not officially supported by BEA but customers have reported working with them successfully with the following workarounds. This information is provided for your convenience and BEA Systems does not certify or support these procedures.

Windows Server 2003

BEA does not support installing Workshop Studio products on Windows Server 2003. However the following notes may allow you to successfully install and run on your Windows Server 2003 workstation.

Be sure to disable Active Directory before attempting to activate your Workshop Studio license. When Active Directory is enabled on Windows 2003 Server, activating your Workshop Studio license with the Help > Workshop License menu command fails with the following error: License failed. Message: Could not get Windows Host ID.

Windows Server 2003 includes a new security feature called Data Execution Prevention (DEP) which prevents malicious code from running on the system. If this is enabled, then Workshop installer will fail to launch. If launching the Workshop installer pops up a DEP window:

  1. Click Change Settings on the alert
  2. Check InstallAnywhere Self Extractor and click OK
  3. On the DEP alert, click Close Message
  4. Re-launch the Workshop Installer

JBoss 3.2.3

The Workshop Studio products do not officially support JBoss 3.2.3. However the following workaround may allow you to debug your applications:

  1. Define the server as if it were a JBoss 3.2.8 server.
  2. During the installation, when you see validation errors for missing JAR files, simply create dummy JAR files at the specified location. NOTE: Each time you create a dummy JAR, you must restart the server definition process to ensure that the JBoss installation folder is refreshed.
  3. Once you are done creating all the required dummy JAR files, complete the server definition.
  4. Add your project to the server and debug it in the usual way.

Mort Bay Jetty 6.0.2

The Workshop Studio products do not officially support Jetty 6.0.2. Creating a server configuration for Jetty 6.0.1 but running with a server that has Jetty 6.0.2 installed results in the following validation error:

Missing classpath entry D:\m7-ramv-backup\Server-Home\Jetty-Home\jetty-6.0.2\lib\jetty-6.0.1.jar

Before configuring the server in Workshop Studio, create the following dummy JAR files in the jetty-6.0.2\lib folder:

Then from the IDE, create a server configuration by selecting Jetty v6.0.1 and proceed normally.

Spring 2.0.1

Spring 2.0.1 can be used with Workshop Studio by choosing Window > Preferences > Workshop Studio Facet Libraries > Spring Library and clicking New to add the Spring 2.0.1 libraries as a facet. These libraries are not available from BEA since they were released too late for inclusion with the 3.3 release.

Hibernate 3.2.1

Hibernate 3.2.1 can be used with Workshop Studio by doing the following steps:

  1. Create a dummy JAR ehcache-1.2.jar at C:\Hibernate-Home\Core\hibernate-3.2.1\lib\ directory.
  2. Click Window > Preferences > Workshop Studio Facet Libraries > Hibernate Library and then click New to add the Hibernate 3.2.1 libraries as a facet. These libraries are not available from BEA since they were released too late for inclusion with the 3.3 release.
  3. NOTE: While adding the 3.2.1 facet, make sure to un-check the dummy JAR entry (ehcache-1.2.jar).
  4. After you create a new project that uses the 3.2.1 libraries, copy the ehcache-1.2.3.jar into the Project/WEB-INF/lib folder.

Kodo 4.1.2

Kodo 4.1.2 can be used with Workshop Studio by choosing Window > Preferences > Workshop Studio Facet Libraries > BEA Kodo Library and clicking New to add the Kodo 4.1.2 libraries as a facet. These libraries are not available from BEA since they were released too late for inclusion with the 3.3 release.


Skip navigation bar   Back to Top