Skip Headers
Oracle® Real User Experience Insight User Guide
Release 4.5.1 for 64-bit Intel Linux

Part Number E12486-02
Go to Documentation Home
Go to Book List
Book List
Go to Table of Contents
Go to Index
Go to Feedback page
Contact Us

Go to previous page
Go to next page

3 Working with the Data Browser

This chapter explains the use of the Data browser. This is at the heart of RUEI, and provides direct access to the information gathered during monitoring. Through it, you can drill down, search, and filter information in an intuitive and user-friendly interface.

3.1 Introducing the Data Browser

The information shown in each report is derived from a multidimensional data structure that contains all the information captured during monitoring. Through this structure, you can explore Web data by simply clicking down through increasing levels of detail, and view by different dimensions (such as period, referrer, visitor type, and so on). This data structure can be viewed through the Data browser.

You can use the Data browser to understand the context of the data shown in a report, and to drill down, rank, sort, and filter information to gain insight into causes, effects, and trends. To open the Data browser from within a report, select Browse from the report menu. To open the Data browser from your home page (Figure 1-2), click Browse data. A window similar to one shown in Figure 3-1 appears:

3.1.1 The Data Browser Toolbar

The toolbar icons at the top of the Data browser screen are shown in Figure 3-2, and are described in Table 3-1:

Figure 3-2 Data Browser Toolbar

Description of Figure 3-2 follows
Description of "Figure 3-2 Data Browser Toolbar"

Table 3-1 Data Browser Icons

Icon Description
Description of barcharticon.gif follows
Description of the illustration barcharticon.gif


Displays the standard graphic visualization (pie chart, line chart, or bar chart) for the data. The graphic form depends on the underlying data.

Description of barrcharthorizicon.gif follows
Description of the illustration barrcharthorizicon.gif Description of piecharticon.gif follows
Description of the illustration piecharticon.gif

Additional visualizations.

In addition to the standard graphical visualization, depending on the underlying data, additional visualizations may be available, and can be selected by clicking the appropriate icon.

You can also use the Type option from the Graph menu to select a visualization.

Description of valuelisticon.gif follows
Description of the illustration valuelisticon.gif


Shows the underlying data values for the data in the browser. See Section 3.3, "Working With Value Lists" for more information about working with value lists.

Description of rightgreenarrow.gif follows
Description of the illustration rightgreenarrow.gif Description of leftgreenarrow.gif follows
Description of the illustration leftgreenarrow.gif

Previous and Next page.

Use these controls to move between pages in the displayed data set.

Description of informscreenicon.gif follows
Description of the illustration informscreenicon.gif


Provides a brief explanation of the metrics currently shown within the browser. This includes both the dimensions shown in the graph or values table, and any filters that have been applied to it. The use of filters is explained in Section 3.6, "Working With Filters".

Description of searchicon.gif follows
Description of the illustration searchicon.gif


Allows you to search for strings within in the current data set. The use of the search facility is described in Section 3.4, "Searching in the Data Browser".

Description of zoomin.gif follows
Description of the illustration zoomin.gif Description of zoomout.gif follows
Description of the illustration zoomout.gif

Zoom in and Zoom out.

Allows you to change the level of displayed detail. When zooming in and out, you change the dimension of the viewed data. The new dimension depends on the currently selected dimension. For example, if you are viewing yearly data, zooming in will change the view to a monthly one. If you are viewing client location by country, zooming in will change the displayed dimension to providers within the client location country.

To quickly return to the original dimension, select Reset view from the View menu.

Description of openasreporticon.gif follows
Description of the illustration openasreporticon.gif

Open as report.

Opens a new window with the currently shown data in report print layout mode. The creation and customization of reports is fully described in Chapter 2, "Working With Reports."

Description of exporticon.gif follows
Description of the illustration exporticon.gif

Open as export.

Opens a new window in which you can further customize the currently shown data prior to exporting it to a wide variety of applications (such as Microsoft Excel). This facility is fully described in Section 3.7, "Exporting Data".

3.2 Understanding the Data Structure

The information available within the Data browser is divided across groups. At the highest level, there are two types of groups: application-related groups and services-related groups. Each group provides a number of perspectives or views on the collected data. These views can be selected from the View selection panel, located on the left-hand side of the Data browser window (Figure 3-1).

Each main group within the View selection panel relates to a broad category of information. There are groups available about the pages visited on the monitored Web environment, visitor sessions, transactions, and failed URLs and pages.

Within each of these groups, sub-groups offer information about a specific aspect of the selected category. More specifically, they offer information across specific dimensions. These dimensions are indicated in the name of sub-group. For example, within the all sessions group, views are available across the dimensions domain, period, user ID, and client browser, language, location, and operating system. This is shown in Figure 3-3:

Figure 3-3 Data Structure Selection Panel

Description of Figure 3-3 follows
Description of "Figure 3-3 Data Structure Selection Panel"

Individual views are grouped according to a standard classification (failure, performance, overall, and size) that reflects the type of information they provide. Within these, you can select the active dimension you want to use to explore the underlying data.

In addition to the standard dimensions discussed in this section, it is also possible to extend the information available within the Data browser through the use of custom dimensions. These are fully described in Section 3.9, "Defining Custom Dimensions".

The Session diagnostics facility is very described in Section 3.10, "Using Session Diagnostics".

3.2.1 Real-Time and Session-Based Data

Within RUEI, two types of information available:

  • Real-time data: this has a delay of five minutes associated with it, and is based on the number of currently open sessions. The delay is the configured session idle time described in Section 7.4.4, "Controlling Session Reporting", and by default is 15 minutes. This data is reported in dashboards and five of the Data browser views; the all pages, all services, failed functions, failed URLs, and slow URLs views.

  • Session-based data: this has a delay associated with it, and is derived from finished (client) sessions. The delay is the configured This data is reported in the Data browser views; all sessions, all transactions, previous pages, next pages, and failed pages.

Why are There Sometimes Differences in the Reported Data?

It is possible that small differences arise between the two different forms of reported data. For example, the number of reported visitors in the all pages view for a day may be slightly different to that reported in the sessions view. To understand why these differences can arise, it is necessary to understand how session-based data is processed.

Within the all sessions view, the client session information is reported as when the client session started. For all other views, the page view information is reported as when the page view started. Therefore, in the case of client sessions that started before, and went on after 12 PM, there will be differences in their associated reported dimensions.


Due to differences in the processing of real-time and session-based data, session-based views many indicate very slightly more (approximately 0.03%) page views than reported in real-time data for the same period.

Timeliness Versus Accuracy

Session-based data provides the most accurate information about your monitored environment. However, if you feel that more immediate data is required, you could consider using one of the real-time data views in the Data browser. For example, using the all pages view instead of the all sessions view. However, while this has the advantage that the associated delay is only 5 minutes, client-specific information (particularly User-ID) is not available.

Note that the reporting of session-based information is also influenced by a couple of advanced settings. These are fully explained in Section 7.4.4, "Controlling Session Reporting".

How are sessions reported?

Session information is written to the All sessions group when:

  • The visitor has been inactive for more than the session idle time. By default, this is 15 minutes.

  • The visitor session has lasted longer than the session flush time. By default, this is 60 minutes.

Both of these events are configurable, and are fully described in Section 7.4.4, "Controlling Session Reporting". The implications of these events are discussed below.

If, for example, a visitor session starts at 8:30 AM and ends at 5:30 PM, it will be considered closed every hour, and reported in the All sessions group every hour. However, within the session diagnostics facility, it is reported as a user record from 8:30 AM to 5:30 PM.

Similarly, if a visitor has a session in the morning from 9:00 AM to 9:45 AM, and an afternoon session from 2:00 PM to 3:15 PM, three reported sessions appear in the All sessions group. One for the morning session, and two for the afternoon (due to the session flush time). In the Session diagnostics facility, these two sessions appear as one user record from 9:00 AM to 3:15 PM.

3.2.2 Problem Analysis Groups

The Problem analysis category of views (shown in Table 1-3) provides in-depth information about failing or problematic page views and hits. It contains the following views:

  • Failed URLs

    Reports on the objects (hits) within failed pages. For example, those pages that contain broken images and unavailable downloads. Note that it logs a maximum of 5000 objects per 5-minute period. All technical errors (described in Appendix E, "Explanation of Failure Codes") for that object are reported. Because this view is does not use application information, it can still report possible reasons for failed pages when no applications have been configured.

  • Failed pages

    Reports on the site-wide, page-content, and technical errors experienced with pages inside applications.

  • Slow URLs

    Reports on the slowest 5000 objects per 5-minute period detected by the system, based on the object's end-to-end time. Note that objects must have an end-to-end time of at least five seconds to be reported in this view. Applications do need to be configured for this view.

3.2.3 Page Delivery Dimension

The page delivery dimension is available within the Failed pages, and All pages views, and reports which errors have been detected on a monitored Web site. All errors reported in the page delivery dimension are also available through the Replay viewer (see Section 3.8, "Working With the Replay Viewer").

Note If a page or object experienced several types of errors (for example, both a network and a Web server error), the page or object error is not recorded multiple times. Instead, it is reported according to the following order: Web site, server, network, and content. For example, an object that experienced both a Web site and a network error, is recorded as a Web site error rather than a network error.

The errors reported in this dimension are also available as the basis for KPIs as metrics expressed both as counters and percentages. This is shown in Figure 3-4.

Figure 3-4 Page Availability Metrics

Description of Figure 3-4 follows
Description of "Figure 3-4 Page Availability Metrics"

3.3 Working With Value Lists

When working with value lists, you can add additional columns to the displayed list. Select Show percentage or Show growth from the Values menu to add indicator columns to the displayed data. Note that availability of these options depends on the currently viewed list, and the columns are also carried forward when you view the list as a report (select Open as report from the View menu).

3.3.1 Changing the Sort Order

You can also change the sort order by selecting a column header at the top of the Values list. The view changes to reflect the selected column sorted in ascending order. Click it again, and the sort order becomes descending. The order symbol within a column heading indicates the current order. An example is shown in Figure 3-5:

3.3.2 Inclusive and Exclusive Filters

Within value lists, you can also right click items to open the menu shown in Figure 3-6:

You can select:

  • Select value: adds the selected value as an inclusive filter to the Filters panel. That is, only values that match the selected value are displayed in the browser.

  • Exclude value: adds the selected value as an exclusive filter to the filters panel. That is, only values not matching the selected value are displayed in the browser.

3.4 Searching in the Data Browser

You can use the Search facility to locate the incidence of strings in the currently displayed data set. This is shown in Figure 3-7:

The search facility will try to match any search pattern you specify either as a full match or as a substring. Hence, the search pattern "fire" will match the occurrences of "firefox", "x-fire", and "sefirewall", as well as, of course, all occurrences "fire". As mentioned earlier, the search is restricted to the currently displayed data. To extend the search further, you will need to modify the current view, or remove applied filters, and repeat the search. If the search did not find any matches, a pop-up dialog informs you that "No results were found".


The search facility does not support the use of wildcard characters. All characters are treated as literals. The results list is a values list and has the same functionality (see Section 3.3, "Working With Value Lists").

3.5 Sorting Data

To sort data in a graphic visualization, select the corresponding dimension from the legend beneath the graph. This is shown in Figure 3-8:

For information on sorting within a value list, see Section 3.3.1, "Changing the Sort Order".

In addition, you can use the Sorting option within the Data menu to undo any specified sorting specifications (Remove sorting), or swap the current sorting specification (Invert sorting).

3.6 Working With Filters

You can use the Filter panel at the top of the browser window to tighten the profile of the information you want to view. An example is shown in Figure 3-9:

Figure 3-9 Example Filter Panel

Description of Figure 3-9 follows
Description of "Figure 3-9 Example Filter Panel"

The first item shown in the filter panel is always the date or period for which information is required. In the example shown in Figure 3-9, this the year period 2007. This can be thought of as the highest-level filter, and can be changed through the calendar (explained in Section 2.4, "Using the Calendar").

After that, additional filters can be set. There are two kinds of filters: inclusive and exclusive. Inclusion filters specify that only data items that match the data value in the filter should be shown. Exclusive filters specify that only data items that do not match the data value in the filter should be shown.

For example, the filter profile in Figure 3-9 specifies that only information should be displayed for the year 2007 in which the client location was Liechtenstein, and the client browser was not Firefox.

3.6.1 Defining Filters

You can define any data item within the browser window as a filter by right clicking it to open the menu shown in Figure 3-10. After you have defined a filter, you are free to modify it by clicking it and using the pop-menu shown in Figure 3-10:

The following options are available:

  • Invert: changes an inclusive filter into an exclusive filter, and vice versa.

  • Mark as report filter: the use of this option is described in Section 3.6, "Working With Filters".

  • Remove: deletes the selected filter.


    Filters are applied in the order in which you define them. Once defined, it is not possible to change the order in which they appear in the filter panel. To re-order them, you must remove and redefine them in the required order.

3.6.2 Using Report Filters

Report filters can be used with reports that you create from the Data browser. When you specify a report filter for information you include in a report, the user opening the report can use the defined filter when viewing the report's contents.

For example, if you are viewing client location information (via the all sessions groups, and the client-location sub-group), you could create a report that allowed its users to select on client location. To define the filter, do the following:

  1. Select a value from the displayed list of locations, and define it as a filter.

  2. When displayed in the filter panel, right click it, and select Mark as report filter from the menu. An example is shown in Figure 3-11:

    Figure 3-11 Example Report Filter

    Description of Figure 3-11 follows
    Description of "Figure 3-11 Example Report Filter"


    Only one report filter can be defined for each dimension. However, it is possible to define multiple report filters across different dimensions. Care should be taken when designing reports with multiple filters because it can make the report difficult to view.
  3. Select Open as report from the View menu, and finalize the structure of the required report. Notice that the selected filter is now shown in within the report. An example is shown in Figure 3-12:

    Figure 3-12 Report With Filter

    Description of Figure 3-12 follows
    Description of "Figure 3-12 Report With Filter"

  4. Highlight the filter by placing the mouse pointer over it, and select Edit filter type from the menu. The Edit filter type(s) dialog shown in Figure 3-13 appears:

    Figure 3-13 Edit Filter Type(s) Dialog

    Description of Figure 3-13 follows
    Description of "Figure 3-13 Edit Filter Type(s) Dialog"

  5. Use the check box(s) shown in the Edit filter type(s) dialog to control which filters can be selected by a user when the report is run. There will be a check box for each defined report filter. When ready, click Apply.

  6. Save the report, as described in Section 2.9, "Creating New Reports".

Running the Report

When the report is run, and a report filter has been enabled, the value selected as the report filter becomes the default selection in a list of dimension values. An example is shown in Figure 3-14:

Figure 3-14 Report Using a Filter

Description of Figure 3-14 follows
Description of "Figure 3-14 Report Using a Filter"

3.7 Exporting Data

You can export the data currently shown in the Data browser to a wide variety of applications, such as spreadsheets. To start working with export data, open the Export window by clicking the Open as export icon, or selecting Open as export from the View menu. A new window with the current data is opened. An example is shown in Figure 3-15:

Figure 3-15 Export Window

Description of Figure 3-15 follows
Description of "Figure 3-15 Export Window"

3.7.1 Modifying the Exported Data

The Export window (Figure 3-15) shows the raw data that is available for export. However, you can customize how the data should be exported. To do so, right click within the export window, and select Edit. The Customize export dialog shown in Figure 3-16 appears:

Figure 3-16 Customize Export Dialog

Description of Figure 3-16 follows
Description of "Figure 3-16 Customize Export Dialog"

This dialog allows you to modify the order of data columns, the order in which values appear in those columns, and specify additional columns that will appear in the Microsoft Excel export.

Within the Data columns and Value columns fields, you can use the lists to add additional primary (index) columns, and the data columns that should appear within them. The exact selection of data and value columns that are available within each list depends on the view group with which you are working. For example, if you are viewing data from the All clients group, the selection of Web site/page data columns is limited to domain and Web site. However, if you are working in All pages group, additional data columns are available for such things as page-content and page-transaction. For a complete description of the data and value columns that are available for export within each view group, see Appendix D, "Summary of Data Items."

The Percentage check box allows you to specify whether an additional column, showing the percentage make up from the reported values is added to the Microsoft Excel export.

The Growth check box allows you to specify whether an additional column, showing the actual increase in the reported metric, is added to the Microsoft Excel export.

You can use the Up, Down, and Remove icons next to a data column selection to control the sort order hierarchy, or to remove a data column as an index to the data. Similarly, you can use these controls within the value column field to rearrange the order in which they appear in the export.

You can save the export to a new or existing file, or append it to an existing export.

3.7.2 Selecting the Export Format

In addition to controlling how the exported data will appear, you can also specify the format in which the data will be exported. To do so, select the Download menu. The following export formats are available:

  • Comma-separated values (CSV).

  • Tab-separated values (TSV).

  • Microsoft Excel worksheets.

  • Webquery format.

3.8 Working With the Replay Viewer

In addition to the information available through the View selection panel described in Section 3.1, "Introducing the Data Browser", RUEI offers the opportunity to track exactly what error messages visitors to the monitored Web site receive and when. With this ability to recreate application failures, you can accurately and immediately eliminate annoying and problematic parts of your Web pages.


By default, the error recording facility is disabled. You must enable it before error message information is recorded and available through the Replay viewer. For information on the procedure to do this, see Section 8.5, "Enabling and Disabling the Replay Viewer".

To start working with the Replay viewer, do the following:

  1. Select Browser data and select either the Failed URLs or Failed pages group. If these are not immediately visible, click the Applications tab.

  2. Click Replay viewer. A selection list appears of all recorded error messages received by visitors during the current day. This includes both the full request header and content, and the full response header and content. They are listed by time and client IP address. An example is shown in Figure 3-17.

    Figure 3-17 Replay Viewer Selection List

    Description of Figure 3-17 follows
    Description of "Figure 3-17 Replay Viewer Selection List"

  3. Select the required item from the displayed list. The underlaying HTML code of the message received by the client is displayed. An example is shown in Figure 3-18.

    Figure 3-18 Example Header Content

    Description of Figure 3-18 follows
    Description of "Figure 3-18 Example Header Content"

    By default, only the first header line is shown for the request and response. You can click View all headers to see the header's complete contents.

  4. Click the Preview button to view the response content of the message in a separate window. An example is shown in Figure 3-19.

    Figure 3-19 Example Error Content

    Description of Figure 3-19 follows
    Description of "Figure 3-19 Example Error Content"

  5. Click the Info button to view all properties recorded for the selected error reply. An example is shown in Figure 3-20:

    Figure 3-20 Error Property Report

    Description of Figure 3-20 follows
    Description of "Figure 3-20 Error Property Report"

Viewing Session Information

In addition to information about a specific received error message, information is also available about the visitor session within which the error message was received. This is extremely useful when you need to know the context of the error. For example, the visitor's page viewing history, or the number of times an error was repeated within a session.

To view the session information associated with a received error message, click the Session button on the toolbar (see Figure 3-18). If you working with the Failed pages group, the viewed pages in the visitor session are listed. If you are working with the Failed URLs group, the objects used with the session's pages are listed. An example is shown in Figure 3-21.

Figure 3-21 Replay Viewer Session Information

Description of Figure 3-21 follows
Description of "Figure 3-21 Replay Viewer Session Information"

For easy identification, a failed page or failed objects are shown with a cross. You can click any listed page or object to view its specific properties. An example of a page properties listing is shown in Figure 3-22.

Figure 3-22 Page Properties

Description of Figure 3-22 follows
Description of "Figure 3-22 Page Properties"

The tabs within dialog allow you view to specific aspects of the selected page or object.

3.9 Defining Custom Dimensions

Custom dimensions allow you to add your own user-defined dimensions to views in the Data browser. These new dimensions are then also available for use within KPIs, as well as reports and exports. For example, you might want to add a dimension "supplier" so that you could more easily track and analyze your organization's suppliers. Using this facility, you could determine which suppliers have the highest conversion rates associated with them within key business transactions, or which suppliers attract the most pageviews on the organization's Web site.


Custom dimensions can be page-based or session-based. Because KPIs are based on real-time data, custom dimensions cannot be used as metrics within KPIs. However, page-based custom dimensions can be used as KPI filters. For more information, see Section 3.2.1, "Real-Time and Session-Based Data".

Each custom dimension has a unique name, and is based on a source. This determines the group within which it appears, and can be page, session, or function-based. For example, page-based dimensions appear within the All pages and Failed pages groups, session-based dimensions appear in the All sessions and Failed pages groups, and function-based dimensions appear in the All functions and Failed functions groups.

Optionally, you can also define a set of translations for each unique source value reported for the dimension. For example, you could define the service-based custom dimension "server ID" with the associated translations shown in Table 3-2:

Table 3-2 Example Custom Dimension Translations

Value Translation


Business Partnerships


Newsletter and Events




Payment Handling

To define a custom dimension, do the following:

  1. For function-based custom dimensions, select Configuration, then Services, and then Custom dimensions. For application-based custom dimensions, select Configuration, then Applications, and then Custom dimensions. A list of the currently defined custom dimensions appears. Click the New dimension command button. The dialog shown in Figure 3-23 appears.

    Figure 3-23 New Custom Dimension

    Description of Figure 3-23 follows
    Description of "Figure 3-23 New Custom Dimension"

  2. Specify a unique name for the new dimension. Note that in displays (such as within the Data browser or a report) that feature the defined custom dimension, the dimension's name is appended with an asterisk (*).

  3. Use the Based on menu to specify the entity type upon which the dimension should be based. For function-based dimensions, this is automatically selected as function, and cannot be modified. For application-based dimensions, you can selected this to be page or session. Note that a maximum of five page or session-based custom dimensions, and a maximum of 10 function-based custom dimensions, can be defined.

  4. Use the Source type menu to specify the scope of the search for the dimension, and whether the search should use an XPath expression, a header, the cookie, a URL argument (request), or a custom tag. More information about using XPath queries is available in Appendix B, "Cookie Structures". More information about the use of custom tags is available in Appendix A, "Tagging Conventions". When ready, click Save. An overview of the defined custom definition (similar to the one shown in Figure 3-24) appears.

    Figure 3-24 Custom Dimension Overview

    Description of Figure 3-24 follows
    Description of "Figure 3-24 Custom Dimension Overview"

  5. Optionally, you can also define a set of translations for each unique source value reported for the dimension. To do so, click « Add new translations ». The dialog shown in Figure 3-25 appears.

    Figure 3-25 Add Translation

    Description of Figure 3-25 follows
    Description of "Figure 3-25 Add Translation"

    Specify the required source value and its translation. When ready, click Save.

Note that if the list of imported translations is very large, you can use the controls at the bottom of Figure 3-24 to scroll through the displayed. In addition, you can use the search facility to locate required translation.

Importing Lists of Translations

Instead of separately defining each translation, you can click « Upload list » (in Figure 3-24) to import a file containing a list of translations. The dialog shown in Figure 3-26 appears.

Figure 3-26 Upload Custom Dimension Translations

Description of Figure 3-26 follows
Description of "Figure 3-26 Upload Custom Dimension Translations"

Specify the name of the translation file. The file may only contain one translation per line, with source values and translations tab separated. When ready, click Merge.


You can also use the custom dimension facility to redefine the functionality of standard dimensions.

Fallback Values Reported For Custom Dimensions

Within custom dimensions, two fallback values can be reported:

3.9.1 Removing Custom Dimensions

To remove a custom dimension, do the following:

  1. For application-based dimensions, select Configuration, then Applications, and then Custom dimensions. For function-based dimensions, select Configuration, then Services, and then Custom dimensions. A list of the currently defined custom dimensions appears. Right click the required custom dimension, and select Remove from the menu.

  2. If the custom dimension is used as a filter in a KPI or a report, you are warned that deleting the custom dimension also results in the deletion of the associated KPI or report. Click Yes or No.

3.10 Using Session Diagnostics

Session diagnostics provides a powerful facility for Application Managers and IT technical staff to perform root-cause analysis of operational problems. It supports session performance breakdown, including the impact of failing pages and hits on sessions, the full content of each failed page, and the relationship between pageviews and sessions.

When problems are identified, session diagnostics offers a means to drill-down into RUEI's rich data structure and both assess the impact of the problem on your Web site's visitors, and obtain direct insight into possible causes.

Understanding Session Reporting

It is important to understand that sessions within the Session diagnostics facility are not reported in the same way as they are in the All sessions group. Sessions are only reported in the All sessions group when the session is considered finished, either because the user has been inactive for longer than the defined session idle time (by default, 15 minutes), or the session has lasted longer than the defined session flush time (by default, 60 minutes). The use of these settings is fully described in Section 7.4.4, "Controlling Session Reporting". In addition, sessions are reported for each application that a user visits.

In contrast, information about a user session is reported within the Session Diagnostics facility regardless of the events described above, and are called user records. Because these session terminating events are not taken into account when reported user records, it can happen that there are more sessions reported for a particular user session in the All sessions group than in the Session Diagnostics facility. For example, consider the scenario shown in Figure 3-27.

Figure 3-27 Example User Activity

Description of Figure 3-27 follows
Description of "Figure 3-27 Example User Activity"

The user's activity from 08:00 until logging off at 17:00 is recorded within the Session diagnostics facility as one user record, starting at 08:00, and finishing at 17:00. Within the All sessions group, this same user activity is recorded as three separate sessions.

Locating Session Information

To locate the sessions which you want to analyze, do the following:

  1. Select Browse data, and select the All sessions group. Note this is only available if you have clicked the Applications tab within the data structure selection panel (see Figure 3-3). Then click Session diagnostics. The Session diagnostics panel shown in Figure 3-28 appears.

    Figure 3-28 Session Diagnostics Panel

    Description of Figure 3-28 follows
    Description of "Figure 3-28 Session Diagnostics Panel"

  2. Use the Calendar controls (described in Section 2.4, "Using the Calendar") to select the required period. Information is only available for seven days prior to the current date. Due to the level of detail available, data can only be viewed one day at a time. When ready, click Search. The results of the search are shown in the main part of the window. An example is shown in Figure 3-29.

    Figure 3-29 Session Diagnostics Window

    Description of Figure 3-29 follows
    Description of "Figure 3-29 Session Diagnostics Window"

  3. The results of the search are shown in the window. You can use the controls in the toolbar at the top of the Session diagnostics window to scroll between result pages. A maximum of 100 user records are listed per page. You can select a user record from the displayed list by clicking it, or use the search facility to further restrict the displayed list.

    To use the search facility, specify a search pattern, and click Go. The specified search pattern can be either a user ID or a client IP address. Note the search's scope is restricted to the currently displayed user records, the search uses partial matching, and the use of wildcard characters (such as *) is not supported. All characters are treated as literals.

    After selecting a session, the View user record panel allows you to view information about the selected session. An example is shown in Figure 3-30.

    Figure 3-30 Session Information

    Description of Figure 3-30 follows
    Description of "Figure 3-30 Session Information"

  4. Use the Pages, Object, and Info buttons in the lower left-hand side of the window to view information concerning specific aspects of the selected user record. When ready, you click the Remove icon beside the selected user record. You are returned to the Session diagnostics window shown in Figure 3-29.