3 Presenting Data on a Graph

Discoverer Desktop can convert tables and crosstabs to graphs or charts so you can analyze and present data graphically. Graphs and charts of tables and crosstabs are especially effective for presentations of results.

This chapter explains how display data on a graph.

The topics covered in this chapter include:

3.1 The Features of a Graph

The following figure shows a table and its resulting graph. This sample shows a bar graph, but several other styles are also available.

Figure 3-1 A Worksheet table and Its Graph

Surrounding text describes Figure 3-1 .

Key to Figure 3-1:
a. A Worksheet in table format.
b. A graph of the data in the Worksheet. Each bar corresponds to one row on the table. In this example, each bar represents the Profit SUM for a Region for the Calendar Year 1999.
c. Graph legend. Each bar is represented in a different color.

To display Worksheet data as a graph:

  1. Display the worksheet that you want to see as a graph.

  2. Choose Graph | Show or click the Graph button on the worksheet tool bar.

    The first time you display a graph, the Graph Wizard walks you through the process of defining the graph's features. Then, a graphical representation of the worksheet appears in the Graph window.

  3. When you are finished working with the graph, click the Close button on Graph window. You can also click the Minimize button on the Graph window.

The graph retains its design features when closed. The next time you open it, the graph has the same appearance.

Figure 3-2 shows the features on a typical graph.

Figure 3-2 Graph Window

Surrounding text describes Figure 3-2 .

Key to Figure 3-1:
a. Tool Bar - click a tool to work with the graph; click a color or pattern and drag it onto the graph to change the data's color or pattern; click the arrows to scroll the colors and patterns.
b. Y-Axis Scale - shows the scale appropriate for the data in the original table or crosstab; you can reset the scale and add decimal points.
c. Titles - additional labels that you can add to the graph. Four positions for the titles are Top, Left, Right, and Bottom.
d. Top title.
e. Legend - the color and label for data.
f. Data - the graphical representation of the data (in the figure, 3D bars).

3.1.1 The Graph Tool Bar

To work with the graph, use the Graph menu on the worksheet window or the Graph tool bar on the Graph window. To show or hide the Graph tool bar, choose Graph | Toolbar. The following figure identifies the icons on the Graph tool bar.

Figure 3-3 The Graph Tool Bar

Surrounding text describes Figure 3-3 .

Key to Figure 3-3:
a. Copy Graph to Clipboard - copies the current graph to the Windows Clipboard.
b. Print - prints the graph to your computer's printer using the default settings for that printer. If the graph is too large for a single page, prints additional pages as necessary. You can also choose Graph | Print to print the current page with Discoverer Desktop's print settings.
c. New Graph Type - displays a drop-down list for choosing a new type of graph.
d. Show/Hide Labels - shows/hides a list of labels that correspond to the row numbers along the graph's x-axis. You can also choose Graph | X Labels.
e. Show/Hide Legend - shows/hides the graphs legend. You can also choose Graph | Legend.
f. Modify Graph - displays a dialog box for editing and formatting a graph; the options in the dialog box are the same ones offered in the Graph Wizard. You can also choose Graph | Edit Graph.

Figure 3-4 Graph Colors and Patterns

Surrounding text describes Figure 3-4 .

Key to Figure 3-4:
a. Scroll to see additional colors.
b. To change colors, click a color and drag it onto a portion of the graph.
c. Scroll to see additional patterns.
d. To change patterns, click a pattern and drag it onto a portion of the graph.

Note: You can also show or hide the status bar in the Graph window. Choose Graph | Status Bar.

3.2 Creating a Graph

The Graph Wizard walks you through the process of creating a graph. These dialog boxes only appear the first time you create a graph of a table or crosstab. To make any changes to a graph later, use the Modify Graph button on the Graph tool bar.

To create the initial graph with the Graph Wizard:

  1. Display the worksheet that you want to see as a graph.

  2. Choose Graph | New Graph or click the Graph button on the worksheet tool bar.

    The first Graph Wizard dialog box appears:

    Figure 3-5 New Graph: Step 1

    Surrounding text describes Figure 3-5 .
  3. Select one of the graph types. Scroll to see additional choices.

    To expand the text description at the bottom of the box, put the pointer on the text.

  4. Click Next.

    Figure 3-6 New Graph: Step 2

    Surrounding text describes Figure 3-6 .
  5. Select one of the graph formats. Scroll to see additional choices.

  6. Click Next.

    Figure 3-7 New Graph: Step 3

    Surrounding text describes Figure 3-7 .
    • To add titles to the graph, enter them in the appropriate boxes. See Figure 3-2 to see the locations of the titles.

    • To add a legend to the graph, click Show Legend.

    • To format the axes labels, click the formatting button next to each feature to see the Font dialog box for that element.

    Figure 3-8 Font Dialog Box

    Surrounding text describes Figure 3-8 .

    Select the font choices and click OK. Repeat for the other design elements that you want to format individually.

  7. Click Next on the New Graph wizard dialog box.

    Figure 3-9 New Graph: Step 4

    Surrounding text describes Figure 3-9 .
  8. Select options for the data on the graph:

    Y-Axis Scale - enter numbers in the Minimum and Maximum boxes to set the upper and lower boundaries of the y-axis; usually the Minimum value is zero. The Maximum value is normally a value higher than the maximum data point value.

    Decimals - enter a number for the number of decimal places on the y-axis scale; enter 2, for example, to display the scale numbers as 100.00.

    Show Gridlines—click each option to show gridlines on the background of the graph.

    Graph Series By—select one or the other option:

    • Column - plots the rows on the x-axis and the data for each row in the graph.

    • Row - plots the columns on the x-axis and the data for each column in the graph.

  9. Click Finish. The Graph window appears with the new graph in it.

3.2.1 Updating the Data on a Graph

You do not have to update a graph manually. As you analyze data on tables and crosstabs, additional data displayed as part of the analysis is automatically added to the graph and appears the next time you display the graph.

For example, if you display a column of percentages for the data, that column's data becomes data points on the graph. Likewise if you pivot a column to the page axis, the graph is automatically updated to reflect that change.

3.3 Modifying a Graph

To modify a graph:

  1. Click the Modify Graph tool on the Graph window's tool bar or choose Graph | Edit Graph.

    • If you choose Graph | Edit Graph, the first Graph Wizard dialog box for modifying the graph appears. It has the same options as the original Graph Wizard dialog box. You can then step through the dialog boxes modifying the graph in the same manner that you created the original graph.

    • If you click the Modify Graph tool, a dialog box appears for modifying the graph.

    Figure 3-10 Modify Graph Dialog Box

    Surrounding text describes Figure 3-10 .

    The tabs across the top of the dialog box offer the same features as the Graph Wizard dialog boxes that you initially used to create the graph.

    Here the Options tab is selected. Compare the options shown in the figure above with Figure 3-9. You can see that the two provide the same options.

  2. Use the Type, Format, Titles and Legends, and Options tabs to change the graph details as required.

  3. Click OK.

    In addition to modifying the y-axis scale with the Modify Graph dialog box shown above, you can also choose Graph | Scale. The dialog box that appears includes additional options to set the y-axis scale units, plot the scale linearly or logarithmically, and to set the size of the gap between plotted data points.

3.3.1 Selecting a New Graph Type

To select a new graph type:

  1. In the Graph window, click the New Graph Type button on the Graph window tool bar.

    The dialog box for a new graph type appears.

    Figure 3-11 New Graph Type Drop-Down List

    Surrounding text describes Figure 3-11 .
  2. Click the new graph type. The graph changes to its new type.

    If you do not want to change the graph's current type, click on the Graph window (off the drop-down list) and the list closes.

    Here are samples of two types of graph that plot the same data.

    Figure 3-12 A Horizontal Bar Graph

    Surrounding text describes Figure 3-12 .

    Figure 3-13 A Cube Chart

    Surrounding text describes Figure 3-13 .

3.3.2 Displaying the Graph Legend and X Labels

You can show or hide the legend and X labels by clicking the buttons on the tool bar.

To display the legend and X labels:

  1. Click the Show/Hide Legend and Show/Hide Labels buttons on the Graph window tool bar. You can also choose Graph | Legend and Graph | X Labels.

    Note: These buttons and commands are toggles—that is, click a button to show the data; click it again to hide the data.

    Here is a sample graph showing both the legend and X labels from the rows on the original table or crosstab.

    Figure 3-14 Graph Showing Legend and X Labels

    Surrounding text describes Figure 3-14 .

    Key to Figure 3-14:
    a. Each row in the table is represented on the Bar Graph as a bar.
    b. The X labels.
    c. The legend corresponds to the rows in the table.

3.3.3 Resizing the Window and Graph

You may need to resize the graph or its window depending on the type of graph and the amount of plotted data. You can resize most portions of the window and graph.

To select the window or graph so you can resize it:

  1. Put the pointer on the edge of the window, edge of the graph, or on one of the other resizable sections of the graph. The pointer changes to a resize arrow.

  2. Drag the mouse pointer to resize the window or graph.

    The following figure shows some of the places you can drag the pointer to resize.

    Figure 3-15 Resizable Sections

    Surrounding text describes Figure 3-15 .

    Key to Figure 3-15:
    a. Drag the edge of the graph itself to enlarge it vertically and horizontally.
    b. Drag these lines from side to side or up and down to enlarge the columns so that text can fit.
    c. When the pointer is on the edge of the window, drag the edge to resize the window. The other edges are also resizable.

3.3.4 Reference Lines and Pull-outs on a Graph

On most of the graph types, dragging on the graph produces a set of reference lines that you can use to visually correlate the graph's data points with the vertical and horizontal scales. On the pie graph and donut graph types, however, dragging pulls sections of the graph out so you can call special attention to them.

Here are some examples:

Figure 3-16 Sample Pull-Outs on a Pie Graph and Donut Graph

Surrounding text describes Figure 3-16 .

Key to Figure 3-16:
a. You can point at sections of a Pie Chart and drag out sections for emphasis. To replace a section of the Pie Chart, drag it back to its original position.
b. If you change the graph type to a Donut Graph, any pulled out sections remain emphasized. To replace a section of the Donut Graph, drag it back to its original position.

Figure 3-17 Sample Reference Lines on a Bar Graph

Surrounding text describes Figure 3-17 .

Key to Figure 3-17:
a. Drag the cursor over a graph to display reference lines. Reference lines allow you to see how points on the graph relate to the vertical and horizontal axes.

3.3.5 Rotating Graphs

You can rotate 3D graphs to view them from a different perspective.

To rotate a graph:

  1. Choose Graph | 3D View.

    A dialog box for rotating the graph appears.

    Figure 3-18 3D View Properties Dialog Box

    Surrounding text describes Figure 3-18 .

    Key to Figure 3-18:
    a. Drag these dots around the edge of the sphere rotates the graph in the corresponding x and y direction.
    b. These numbers show the amount of rotation in each axis.
    c. Drag this slider to rotate the graph in the z-axis plane.

    Hint: Before you begin to rotate a graph, write down the X Angle and Y Angle numbers and note the position of the slider so you can return the graph to its unrotated position after experimenting with rotation.

  2. Select the options for displaying the graph:

    • 3D - displays the graph with both the X Angle and Y Angle set at 45 degrees; this is the standard 3D display.

    • Full 3D View - displays the graph based on the positions of the dots and slider on the dialog box; this option must be selected to drag the dots. Turning off this option returns the graph to the standard 3D display.

    • Shadows - displays shading on the edges of the graph's features to enhance the 3D representation.

  3. Drag the dots around the x- and y-axis circles.

    • Dragging the x-axis dot rotates the graph from left to right.

    • Dragging the y-axis dot rotates the graph from top to bottom.

    As you drag the dots, the reference figure represents the amount of rotational change to the graph. The X Angle and Y Angle numbers also change as you drag the dots.

    Hint: You can also enter numbers for the X Angle and Y Angle in the respective boxes. Entering numbers instead of dragging the dots is often a good way to get the exact rotation for a series of graphs.

  4. To rotate the graph in the z-axis, drag the slider under the reference figure.

    Dragging the slider increases or decreases the amount of depth to the graph.

  5. Click Apply to rotate the graph based on the settings in the dialog box.

  6. Click OK when the graph is rotated as you want it.

    Figure 3-19 Sample Rotated Graphs

    Surrounding text describes Figure 3-19 .

3.3.6 Changing the Graph's Colors and Patterns

The tool bar on the Graph window includes a set of colors and patterns for changing the colors and adding patterns to the graph.

To change a color or pattern:

  1. Drag the color or pattern from the tool bar onto the portion of the graph you want to change.

    The pointer becomes a paint jar.

  2. Put the paint jar onto the portion to recolor, and release the mouse button.

    You can recolor the plotted data, the axes, the legend background, and the graph's background.

    Figure 3-20 Changing a Graph's Colors and Patterns

    Surrounding text describes Figure 3-20 .

    Key to Figure 3-20:
    a. Drag a color from the color bar over a section of the graph to change the color of that section. Note that the legend also changes.
    b. Drag a pattern from the pattern bar over a section of the graph to change the pattern of that section. Note that the legend also changes.

    If you apply a pattern to a graph that has a color, the black bits of the pattern become the color. A graph can be patterned or solid colors, but not both.

    If you want a colored pattern, first drag a color down to the graph, then drag a pattern down to the graph.

To remove a pattern from the graph:

  1. Drag one of the colors from the tool bar onto the pattern on the graph.

  2. The pattern is removed and the graph becomes a color. Creating Custom Patterns

To create a custom pattern:

  1. Double-click on a pattern on the tool bar.

    The Pattern Editor appears.

    Figure 3-21 Pattern Editor

    Surrounding text describes Figure 3-21 .
  2. Put the pointer on the pattern bitmap. The pointer becomes a pencil tool.

  3. Click on the squares to reverse their color. The sample on the right shows the new pattern.

  4. Click OK when you're finished.

    The new pattern replaces the original one you started with on the tool bar. Creating Custom Colors

To create a custom color:

  1. Double-click on a color on the tool bar.

    The Color dialog box appears.

    Figure 3-22 Color Dialog Box

    Surrounding text describes Figure 3-22 .
  2. Click Define Custom Colors.

    The dialog box expands to show the tools for defining a custom color.

    Figure 3-23 Color Dialog Box with Custom Colors

    Surrounding text describes Figure 3-23 .

    Key to Figure 3-23:
    a. Reference marker indicating the position of the current color in the color spectrum.
    b. Slider bar for adjusting the color hue, saturation, and luminosity.
  3. Click on one of the empty spaces in the Custom colors panel.

    To edit one of the custom colors already in the panel, click on it instead.

  4. Drag the reference marker around in the colors.

    As you drag the Reference Marker, the Color|Solid box shows the new color. Color refers a dithered color if your computer is set to show dithered colors. Solid refers to the nearest solid (undithered) color. Note that luminance remains constant as you drag the marker.

  5. Drag the slider up and down to change luminance. Hue and Saturation (Sat) remain constant.

    You can also type the color numbers directly in their boxes.

  6. When the new color is correct, click Add to Custom Colors. The new color is added to the panel of new colors.

  7. Click OK when you're finished.

    The new color replaces the original one you started with on the tool bar.