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The Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology 

Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html contains the 
latest versions of the Agile PLM PDF files. You can view or download these manuals from the Web 
site, or you can ask your Agile administrator if there is an Agile PLM Documentation folder available 
on your network from which you can access the Agile PLM documentation (PDF) files. 

 To read the PDF files, you must use the free Adobe Acrobat Reader version 7.0 or later. 
This program can be downloaded from the Adobe Web site http://www.adobe.com. 

The Oracle Technology Network (OTN) Web site 
http://www.oracle.com/technology/documentation/agile.html can be accessed through Help > Manuals 
in both Agile Web Client and Agile Java Client. If you need additional assistance or information, 
please contact support http://www.oracle.com/agile/support.html 
(http://www.oracle.com/agile/support.html) for assistance. 

 Before calling Oracle Support about a problem with an Agile PLM manual, please have 
the full part number, which is located on the title page. 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle 

Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html 

Go to the Oracle University Web page 
http://www.oracle.com/education/chooser/selectcountry_new.html for more information on Agile 
Training offerings. 

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  

http://www.oracle.com/technology/documentation/agile.html
http://www.adobe.com/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/education/chooser/selectcountry_new.html
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AutoVue for Agile Version 19.3.2 Installer updates the Agile PLM Application Server and File 
Manager components for Agile PLM version 9.3, 9.2.2.x, or 9.2.1.x on all platforms. It also installs 
the Agile PLM View Server version 19.3.2 on Windows or Linux. 

You must run the AutoVue for Agile Version 19.3.2 Installer on the Application Server and all File 
Managers as well as the machine where you wish to install the View Server. Select the Agile Viewer 
option in the installer if you wish to install the View Server and select the Upgrade Viewer 19.3 Client 
Libraries option if you are running the installer on an Application Server or File Manager. If your 
Application Server or File Manager is installed on the same machine as the View Server, then both 
the Agile Viewer and the Upgrade Viewer 19.3 Client Libraries options should be selected in the installer. 

1. Download Oracle AutoVue 19.3.2 from Oracle E-Delivery (http://edelivery.oracle.com) to a 
temporary directory. 

2. From the temporary directory, run the setup file for your platform 

Windows: setup_av_win.exe 

Solaris: setup_av_sol.bin 

Linux: setup_av_lin.bin 

AIX: setup_av_aix.bin 

Solx86: setup_av_solx86.bin 

The Install window appears. 

3. For information about any screen in the installer, click Help. 

4. Click Next to proceed through the installer. 

 If you are installing on an Application Server or File Manager, check the Upgrade 
Viewer 19.3 Client Libraries option on the Choose Install Components panel. 

5. Click Done to finish the installation. 

 

You must redeploy the application.ear file and restart the application server after you have updated 
the client libraries.  For instructions on restarting the application server, see either the Installing 
Agile PLM on Oracle Application Server or the Installing Agile PLM on Oracle WebLogic Server 
manual. 

You must redeploy the webfs.far file on the File Manager after you have updated the client libraries. 
Stop the file server and any additional Agile processes. Redeploy the File Manager: 

a. Change to the AGILE_HOME\Tomcat\webapps directory.  

http://edelivery.oracle.com/
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b. Verify there is a directory named Filemgr under the webapps directory. 

c. If the Filemgr directory exists, then perform the following: 

 

 

Windows:  

UNIX:  

d. Start Tomcat. 

A backup of the application.ear and webfs.war files is made before the client libraries are upgraded 
to version 19.3.2. If you are upgrading to version 19.3.2, the Profiles folder is also backed up and a 
new Profiles folder is created with the latest GUI files. 

You must remove the CMF files of the previous version on the file vault. To remove the CMF files, 
use the MetaFilesRemover utility located at agile_home\agileDomain\tools. The MetaFilesRemover 
utility removes metafiles from the file vault. 

Unzip the MetaFilesRemover.zip file, then run the utility to remove the previous CMF files. 

Usage: java -jar MetaFilesRemover.jar [-delete <value>] [-age <value>] [-size <value>] -basedir <value> -
prefix <value> -serverURL <value> -username <value> -password <value> 

where 

 delete deletes the metafiles. 

 age specifies the last access time (day). 

 size specifies file size (KB). 

 basedir is the file vault location where the metafiles are removed. 

 prefix is the file name prefix. 

 serverURL is the location of the DMS service, for example, 
http://server.company.com:80/Agile/services/DmsService. 

 username is the DMS service username. 

 password is the DMS service password. 

 

 

 

http://server.company.com/Agile/services/DmsService
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AutoVue for Agile allows users to view and mark up documents, drawings, and CAD files using a 
Web browser. 

AutoVue for Agile consists of three installation components: 

 AutoVue for Agile server 

 AutoVue for Agile servlet 

 AutoVue for Agile applet 

AutoVue for Agile requires no maintenance on the client computer. A Web browser downloads the 
applet from the File Manager and stores it in the browser cache. The next time the AutoVue for 
Agile is launched, the applet is loaded from the cache, unless a new version is found on the File 
Manager.         

The AutoVue for Agile servlet (VueServlet) is packaged and deployed as part of the File Manager 
installation. The VueLink Servlet is also deployed on the File Manager  and tunnels the requests to 
the Agile Application Server using HTTP protocol. Because of this communication, each File 
Manager should have an associated Viewer on the same machine or separate machines. No 
additional configuration is required except that specified for the Agile Web client and the caching 
Viewer. The VueServlet is used to access AutoVue for Agile across firewalls from external clients, 
such as the Agile Web client, on standard HTTP/HTTPS ports. 

Client computers require a Java-compatible browser running on Windows 2000 Professional with 
SP4 or Windows XP Professional. Additionally, Java Clients require JRE 5.0.  

AutoVue for Agile was designed to provide server scalability to support increasing demand for file 
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viewing and markup on intranets and the Internet. Doubling the capacity is as simple as adding one 
more computer. The servers automatically divide up the load in a ―peer-to-peer‖ fashion to avoid 
any bottlenecks.        

AutoVue for Agile embeds several different rendering schemes to accommodate multiple 
environments. These schemes allow the server to take into account issues such as network 
bandwidth, load balancing between server and client, server configuration and performance, 
intranet/extranet/Internet use, and file size and format to be viewed. However, in all rendering 
options, AutoVue for Agile keeps all necessary information for querying purposes; the ―intelligence‖ 
of drawings is preserved. For example, users can perform text searches on text and CAD files, or 
perform queries based on drawing attributes in a CAD file. 

Depending on your network configuration (for example, existing firewalls, DMZ, secure connections, 
and proxy servers), a client is able to connect to the AutoVue for Agile server using direct sockets or 
the HTTP/HTTPS protocol (through a Java servlet) and avoid any security breach in your system. 

During the viewing process, documents available for viewing are rendered on AutoVue for Agile, 
and an intelligent and displayable data stream is delivered to the client. In this way, the AutoVue for 
Agile implementation eliminates any concerns about security since the original document is not 
transferred to the client computer. While the viewable data is being transmitted, AutoVue for Agile 
uses compression and streaming algorithms to achieve a quick and responsive feedback to the 
client side for large and multi-page documents.       

The server has complete control over the functions available to clients. For example, users may be 
granted or denied rights to perform printing, redlining, or any other functions depending on their 
access permissions. 

AutoVue for Agile uses cookies to track the number of users. The cookie is a unique number 
assigned to each browser that defines a user as a single session, regardless of the number of files 
a user consecutively or simultaneously opens. 

 If you disable or refuse cookies in your browser, AutoVue for Agile will continue to 
work. However, each new instance of the browser creates a new session in 
AutoVue for Agile.   

HTTPS can be used for secure communications if you tunnel all communications between the 
viewer client and the server through HTTPS, which uses SSL. The applet must communicate with 
the AutoVue for Agile server through the AutoVue for Agile servlet. Any Agile communications that 
are tunneled are encrypted using SSL.          

The firewall on the Agile PLM side must be configured to allow: 

 Incoming HTTP/HTTPS connections from the Internet to the Web server. 

 Outgoing TCP/IP connections from the Web server in the DMZ to the Application Server inside 
the firewall on port 7001 or 7002 (SSL) for BEA WebLogic, port 7777 or 8888 (SSL) for Oracle 
Application Server, and port 8009 for the File Manager.     

 



 Chapter 2: Configuring Agile Viewer 

Version 19.3.2 11  

 After installation, the AutoVue Server service is set to Manual. To start AutoVue for Agile  
when the machine boots, set the service to Automatic. 

Start the AutoVue Server service or Choose Start > All Programs > AutoVue for Agile PLM > Start AutoVue 
Server. 

1.  In a console window, go to the AGILE_HOME/AVS/bin directory. 

2.  Type the following command to initialize the server: 

jvueserver & 

 The Agile View servlet (VueServlet) is packaged and deployed as part of the File 
Manager installation. The VueLink Servlet is deployed on the File Manager  and 
tunnels the requests to the Agile Application Server using HTTP protocol. No 
additional configuration is required. 

The VueServlet is used to access Agile Viewer across firewalls from external clients on 
standard HTTP/HTTPS ports.  

On the Application Server, you must make sure that the VueServlet has been loaded from the 
AutoVue for Agile home directory and that the VueServlet communicates with the Viewer. Open a 
browser and type the following URL in the location bar: 

http://FileManager_hostname or LoadBalancer:port/Filemgr/VueServlet

A message should appear indicating that JVueServer is up and running. The sample page should 
appear that includes information about servlet tunneling and licensing. 

 On Windows, if you receive the message ―The page cannot be displayed,‖ make sure the 
World Wide Web server service is running on the computer. If it is not running, start the service 
from the Services window. 

 If you specify this URL in the browser and receive the message ―Page not found,‖ check the 
following: 

 Make sure that the Web server is accessible. 

 Check the web proxy configuration to ensure the virtual path and port number are correct. 
On Oracle Application Server, check the 9ias.conf file. On WebLogic, check the iisproxy.ini 
file. 

 

http://filemanager_hostname/
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AutoVue for Agile is designed to provide server scalability to support increasing demand for file 
viewing and markup on intranets and the Internet. It can run in a process pool on a single computer 
that improves the responsiveness for simultaneous connections and balances the load across a 
multi-CPU computer. 

The default process pools four concurrent services. It is specified in the jvueserver.properties file 
located in the AutoVue for Agile home folder at \\AGILE_HOME\AVS\bin:   

jvueserverx.nt.processPoolSize=4 

As a general rule, you should allow approximately 50 MB for each process in the pool. A process 
pool size of four services requires approximately 200 MB of RAM. On a computer with 256 MB of 
RAM, this allows the remaining RAM to run the operating system and other services. Increasing the 
RAM on a computer allows you to increase the number of services using the process pool. 

The system allows you to add servers to support more users while the servers are online, without 
restarting or disconnecting existing servers. Doubling the capacity is as simple as adding another 
computer. When using multiple viewers, the load can be efficiently balanced across the servers by 
manually directing the viewer client requests to different viewers. 

Dynamic and static load balancing are supported. For more information, see the AutoVue Client-
Server Edition Installation and Administration Manual mentioned in Additional Agile Viewer 

Documentation on page 15. 

Multiple viewer functionality must be configured as follows:   

 Each viewer computer acts independently. 

 Each viewer computer can point to the same Agile Application Server computer or to a different 
Agile Application Server computer in a single or distributed Agile PLM system. 

 The viewers are not clustered, so there is no single entry point computer for all Java clients to 
connect into any viewer. 

For Agile Web clients outside the corporate firewall, the functionality for multiple viewers must be 
configured as follows: 

 The AutoVue for Agile client applet can communicate across firewalls on a standard 
HTTP/HTTPS port. 

 Each AutoVue for Agile computer acts independently. 

 Each AutoVue for Agile computer can point to the same Agile Application Server computer or 
to a different Agile Application Server computer in a single or distributed Agile PLM system. 

 External Agile Web clients are given different URLs that point to different Web servers hosting 
an Agile Web client with an AutoVue for Agile client and an AutoVue for Agile servlet. In turn, 
each AutoVue for Agile client and AutoVue for Agile servlet points to the different viewer to 
distribute the load. 

 The viewers are not clustered, so there is no single entry point computer for all Agile Web 
clients to connect into any viewer. 

file://AGILE_HOME/AVS/bin
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To configure AutoVue for Agile server and AutoVue for Agile client communication across firewalls 
on specific ports, you should use standard HTTP ports. 

For AutoVue for Agile, the issue of using IP addresses for client-server communication at runtime 
(rather than hostnames or DNS names) is resolved because the Application Server also hosts the 
VueServlet. The VueServlet acts as a proxy for AutoVue for Agile, and it is placed on the intranet 
with other Agile server components. In addition, since the VueServlet is running on the Application 
Server with an Agile Web client, the Web server proxies also forward external requests to the 
intranet.The VueServlet comes as part of the File Manager installation. 

Follow these instructions to remove AutoVue. 

1.  Stop the AutoVue service. 

a.  Open the Services dialog box. 

b.  Select AutoVue Server and stop the service. 

c.  Close the Services dialog box. 

2.  Choose to Start > Settings > Control Panel. 

3. Double-click Add/Remove Programs. 

The Add/Remove Programs Properties dialog appears. 

4.  Scroll down the window and select AutoVue Web Edition. 

5.  Click Change/Remove. 

6.  Click Uninstall, and Click OK to confirm the deletion. 

7.  Click Exit. 

1.  Choose Start > All Programs > AutoVue for Agile PLM > Setup > Uninstall AutoVue. 

2.  Select and delete the installation folders from the location of Agile home directory. 

1. Stop the AutoVue server by clicking Shutdown on the View Server applet or killing the jvueserver 
process. 

2. Go to the VIEWER_HOME/AVS/_uninst directory. 

3. Run the uninstall_linux2.bin file to uninstall AutoVue for Agile. 
 

This section contains information for troubleshooting your AutoVue for Agile installation.       



Installation and User Guide  

14 AutoVue for Agile PLM 

This section describes the errors that you may encounter when using AutoVue for Agile. 

If you receive the following error messages when the Java Client or the Web Client tries to start 
AutoVue for Agile PLM, follow the directions provided in the solution: 

 ―jVue not found‖ appears because of the following: 

 Viewer Content URL in Admin > Server Settings > Locations > File Manager is incorrect.  

 Incorrect client applet alias specified instead of mandatory ―jVue.‖ 

Solution: Confirm that the Viewer Content URL is accessible and the jVue.jar file is listed. 

 ―An error occurred while connecting to the server. Restart the applet?‖ appears because of the 
following: 

 AutoVue for Agile or File Manager is down. 

 Incorrect View Server URL in Admin > Server Settings > Locations > File Manager.  

 AutoVue for Agile is configured incorrectly, or is unavailable. 

Solution: Confirm that the Viewer Server URL is accessible and returns a successful connection 
status. 

If you receive the following error message when the Java Client or the Web Client tries to connect 
to a file manager, follow the directions provided in the solution: 

 ―File not found‖ appears because of the following: 

 The file manager is down. 

 The VueServer.ini file points to incorrect file manager. 

Solution: Confirm that the file manager is up and running. 

If an attachment uses special fonts, the computer where Viewer is installed must have those special 
fonts installed locally. Otherwise, a file error may occur or an incorrect font substitution may occur 
with viewing or printing the attachment. 

For fonts other than the ones used by the operating system, the user's profile should include a 
reference to the location of the fonts in the XFONTPATHS parameter. 

Some AutoVue for Agile PLM port numbers can be changed in the event of a port conflict. It is 
important to change the port number in all referenced locations. 

 Port 5099 is used for communication between AutoVue for Agile PLM and its clients. 
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For AutoVue for Agile PLM, go to the \AVS\bin folder and open the jvueserver.properties file. 
Locate the following port information: 

# * Socket port number 

jvueserver.socket.port=5099 

You can change port 5099 to another available port number. 

If you are changing the AutoVue for Agile port, update the port number in the vueservlet section 
of the web.xml file located at 
AGILE_HOME\Tomcat\Tomcat\webapps\<FilemgrVirtualPath>\WEB-INF on all viewer clients. 

 Port 2001 is used for RMI. 

For AutoVue for Agile PLM, go to the \AVS\bin folder and open the jvueserver.properties file. 
Locate the following port information: 

# * RMI Registry port number 

jvueserver.rmi.port=2001 

 

You can change port 2001 to another available port number. 

On the computer where you installed AutoVue for Agile PLM, the AutoVue Installation and 
Administration Manual (install.pdf) is installed in the following location: 

\AVS\docs 

Please refer to the AutoVue Installation and Administration Manual for the following information: 

 How to use the AutoVue Server Console. 

 How to enable debugging information (logging) for AutoVue for Agile PLM. 

 How to further configure AutoVue for Agile PLM. 
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This manual is a supplement to AutoVue online Help. It is intended to be used in conjunction with 
the viewer online help and other Oracle manuals. 

AutoVue for Agile has been integrated into the Agile system to make use of the Agile’s ability to 
manage attached files by using Agile system features. The integration also streamlines the viewer 
menus, toolbars, and shortcuts. The following table shows where you can find information about 
Agile features and concepts which you may find useful. 

Feature  o r  concept  Conta ined in  th is  document  

Java Client Navigation Getting Started with Agile PLM User Guide 

Web Client Navigation Getting Started with Agile PLM User Guide 

Relationships and rules between objects Getting Started with Agile PLM User Guide 

Attachment files 

Working with file folder objects 

File folder mass update 

Routing and reviewing file folders 

File validation (Handle Check Sum) 

Viewing and redlining file folder contents 

Getting Started with Agile PLM User Guide 

Redlining through ECOs, MCOs and SCOs Product Collaboration User Guide 

 
 

To get help at any time, choose Help > Contents in the AutoVue for Agile menu bar. The AutoVue 
online help is displayed; it includes detailed information about using viewer features. 
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 See Agile-specific Features and Functions on page 25 for a complete list of features and 
user interface details described in the viewer online Help that have been modified in 
order to integrate AutoVue for Agile with the Agile system. 

 

AutoVue for Agile can display many different file formats without their authoring applications. You 
can view files from many database, graphic, spreadsheet, word-processing, and 2D CAD 
applications. Even archived files can be listed and viewed without the need to decompress them. It 
isn’t necessary for you to identify the file type; AutoVue for Agile automatically identifies the type of 
file you are requesting it to read. An Agile administrator determines which types of files can be 
viewed by setting the Supported File Types property or, for Advanced Viewer, the Valid Model File 
Type property.       

 To view files through the Advanced Viewer, you need Agile Discovery, Read, and 
ViewFile privileges. To redline files through the Advanced Viewer, you need the 
Attachment Redlines privilege. 

The action of attaching your comments, notes, and drawings to a document is known as marking 
up, also commonly known as annotating or redlining. A markup refers to the change being made to 
a document by attaching a markup object. You can use AutoVue for Agile to mark up files as well as 
view them. 

 Agile Java Client and Agile Web Client support attachment redlining. Markups for ECOs 
can be made on the Redline Attachments tab in Java Client and Web Client. You access 
the appropriate redline tab on the Affected Items tabs of ECOs. Markups for a file folder 
object can be made on the Files tab of the file folder object in Java Client and Web Client 
and do not require an ECO (Ad Hoc Markup). 

Some of AutoVue for Agile’s features are: 

 Flexible user-defined objects — AutoVue for Agile offers a vast selection of markup objects, 
including circles, clouds, polygons, and arrows. Text can be attached to objects, and lengthier 
comments can be contained in embedded notes. 

See AutoVue for Agile online help for a detailed discussion of markup objects. Choose 
Help > Contents in the AutoVue for Agile menu bar. 

 Storage of unedited original documents — Original documents are never changed. All your notes 
and drawings are saved in a separate file called a markup file, although when viewed they 
appear to be part of the main document. You do not have to manage the storage and retrieval 
of markup files; Agile does that for you. 

 Support for non-English languages and operating systems — AutoVue for Agile works with many non-
English languages, and has been tested on Japanese, Chinese, French, German, Hebrew, and 
Swedish operating systems. 
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You can start AutoVue for Agile from either the item Attachments tab or the file folder Files tab. 

Double-click the attachment row. 

Or 

1. Select one or more rows. 

2. Click the View File(s) button’s drop-down arrow and select View  from the menu. 

 If the View icon is visible on the button, you can simply click the button. 

Click the file name link in the table. 

Or 

1. Select one or more rows. 

2. 9.2.2.x or 9.2.1.x: Click the View File(s) button’s drop-down arrow and select View  from the 
menu. 

Or 

9.3: Click the View  button’s drop-down arrow and select View from the menu. 

 If the View icon is visible on the button, you can simply click the button. 

When you start AutoVue for Agile, the main AutoVue for Agile window appears.          

 For more information about starting AutoVue for Agile, see Opening Agile Attachment 

Files in AutoVue for Agile on page 25. 

 

When viewing files from the Attachments tab of an Agile business object in version 9.2.2.x or 9.2.1.x, 
if you view a single row that refers to a multiple-file file folder, the Select Files window appears. The 
Select Files window lists the files in that file folder and allows you to select one or more files that 
you want to view. In version 9.3, you can select the link of each individual file you want to view. 

 For more information about starting AutoVue for Agile, see Opening Agile Attachment 

Files in AutoVue for Agile on page 25. 

 

The following sections describe the main AutoVue for Agile window and performance modes, plus 
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other information needed to use AutoVue for Agile. 

AutoVue for Agile has two performance modes: View and Markup. 

When a document is first opened from business object’s Attachments tab or file folder Files tab, the 
menu bar and toolbars are those of View mode. View mode is AutoVue for Agile’s default mode. 
Documents can be edited or marked up only from Markup mode, described in the next section.      

When AutoVue for Agile is in Markup mode, the currently displayed document can be marked up. 
That is, you can redline or annotate it. Available markup objects include various shapes, notes, 
symbols, and text. When you open AutoVue for Agile from the Redline Attachments tab or Files tab in 
a file folder object, AutoVue for Agile opens either in View or Markup mode, depending on whether 
the attachment has a saved markup and the privileges assigned to the user. If the attachment is 
checked out, then the redlining will not be allowed, however, you can change to Markup mode to 
display saved markup. For instructions on how to enter Markup mode from View mode, see 
Guidelines for Marking Up or Redlining Attachments on page 27. When you open a markup file, 
Markup mode starts automatically. 

 Markup mode is available only when the viewer is opened from tabs where markups are 
allowed: from a change order’s Redline Attachments tab and from the Files tab of a file 
folder. In addition, you must have the appropriate Attachment Redlines for Self privilege. 
Contact your Agile administrator if you have questions about your assigned roles and 
privileges. 
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There are a few basic components to the AutoVue for Agile work environment, shown in the 
following figure. These differ according to whether AutoVue for Agile is in View mode or Markup 
mode. 

 

 
 

The menu bar at the top of the window is the main access to all of the menu commands. The 
selection of available commands changes according to the mode the viewer is in and the task that 
you are performing.       

The tool buttons under the menu bar offer easy access to the basic commands presented in the 
menu bar. As with menu commands, the selection of available toolbar buttons changes according to 
the mode the viewer is in and the task that you are performing.       
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In both View mode and Markup mode, there is a status bar located at the bottom of the main 
window. The fields from left to right for each mode’s status bar are as follows:  markers (see the 
following list), current active file name, file type, zoom factor, current page and total number of 
pages, current active file size, date of the file’s creation, and the pointer’s coordinate position. 

The following types of markers can appear on the status bar: 

 A pen with an exclamation mark indicates that the current active file has saved markup files. While 
in View mode, choose Open from the Markup menu to view the Markup Files dialog box. Then 
select a markup file or group of markup files to open. When you open a markup file, Markup 
mode starts automatically.       

 A red exclamation mark indicates that some main resources required to properly read the current 
active document are not available (for example, missing fonts or missing CAD files). To quickly 
identify the missing resources, click the red exclamation mark, and the File Properties dialog 
box appears. 

 

You can use the left mouse button to click and drag.        

 In View mode — By default, drag to perform an autozoom of all supported file formats (including 
raster and vector files). Select the area you want to enlarge. 

 In Markup mode — If objects are selected, drag to modify and move objects. If no objects are 
selected, drag to perform an autozoom (same as in View mode). 

To select an object, click it. Selected objects are framed by a text box. Modify the size of the 
object by dragging the frame handles. To move an object, move the cursor to the borders (the 
edges) of the markup entity until the cursor turns into a hand pointer. Drag the hand pointer to a 
new location. 

The easiest and quickest way to access most of AutoVue for Agile’s functions is using the shortcut 
menus. Simply right-click with the pointer over the View window to access appropriate commands. 

In View mode, use these commands: 

 Zoom Fit — to automatically fit the document to the width of the view window. 

 Zoom Previous — to automatically return to your previous zoom level. 

 Zoom Page Width — to automatically fit the document to the width of the view window. 

 Markup/Exit Markup — to enter and exit Markup mode and open an existing markup or create a 
new one. The New Markup command is available in View mode only when markups are allowed. 

In Markup mode, use these additional commands: 

 Line Style — to select a style of line to use in your markup. 

 Line Thickness — to select a line thickness for use in your markup. 
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 Fill Type — to select the type of fill to apply to your markup object: Solid Fill, No Fill, or 
Transparent Fill. 

 Entity Color — to select a color for your markup object. 

 Order — to select the overlay order when several markups are being displayed simultaneously. 

 Markup Layers — to select which layers are visible or active, change layer color, add new layers, 
and rename existing layers. 

 
 

To cancel an operation in progress, click the right mouse button. The current operation is canceled 
immediately. For example, if while drawing a box you realize that you would prefer to draw a cloud, 
right-click while drawing the box and the box is canceled. 

If you have already drawn a box, you can either choose Edit > Undo from the menu bar or select the 
box and press the Delete key on your keyboard. What has already been drawn is erased. 
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You can view files from either the Attachments tab of a business object or from the Files tab of a file 
folder object. 

1. Go to the Attachments tab of a business object that references the file. 

2. Double-click the attachment row. 

 If the attachment row refers to a file folder with only one file, AutoVue for Agile opens and 
displays that file. 

 If the attachment row refers to a multiple-file file folder, the Select Files window appears. 
Select one or more files to view and click OK. AutoVue for Agile opens and displays the 
files you selected. 

Or, you can use the Attachment tab View File(s) button: 

3. Go to the Attachments tab of a business object that references the file. 

4. Select one or more attachment rows. 

5. Click the View File(s) button’s drop-down arrow and select View  from the menu.  

 If the View  icon is visible on the button, you can simply click the button. 
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 If you selected one attachment row that refers to a file folder with only one file, AutoVue for 
Agile opens and displays that file. 

 If you selected one attachment row that refers to a multiple-file file folder, the Select Files 
window appears. Select one or more files to view and click OK. AutoVue for Agile opens 
and displays the files you selected. 

 If you selected more than one attachment row, AutoVue for Agile opens and all the files in 
all the selected rows are displayed in the viewer. The Select Files window does not 
appear. 

1. Go to the Files tab of a file folder object containing the files you want to view. 

2. Double-click the filename in the file table. 

AutoVue for Agile opens and displays the file. 

3. Or, select one or more file rows. 

4. Click the tab menu View File(s) button’s drop-down arrow and select View  from the menu.  

 If the View  icon is visible on the button, you can simply click the button. 

AutoVue for Agile opens and displays the selected files. 

1. Go to the Attachments tab of a business object that references the file. 

2. Click the file name link in the attachments table. 

 If the attachment row refers to a file folder with only one file, AutoVue for Agile opens and 
displays that file. 

 If the attachment row refers to a multiple-file file folder in version 9.2.2.x or 9.2.1.x, the 
Select Files window appears. Select one or more files to view and click Finish. AutoVue for 
Agile opens and displays the files you selected. In version 9.3, you can select the link of 
each individual file you want to view. 

Or, you can use the Attachment tab View button: 

3. Go to the Attachments tab of a business object that references the file. 

4. Select one or more attachment rows. 

5. Click the View button’s drop-down arrow and select View from the menu.  

 If you selected one attachment row that refers to a file folder with only one file, AutoVue for 
Agile opens and displays that file. 

 If you selected one attachment row that refers to a multiple-file file folder, the Select Files 
window appears. Select one or more files to view and click OK. AutoVue for Agile opens 
and displays the files you selected. 

 If you selected more than one attachment row, AutoVue for Agile opens and all the files in 
all the selected rows are displayed in the viewer. The Select Files window does not 
appear. 
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1. Go to the Files tab of a file folder object containing the files you want to view. 

2. Click the filename link in the file table. 

AutoVue for Agile opens and displays the file. 

3. Or, select one or more file rows. 

4. Click the tab menu View button’s drop-down arrow and select View from the menu. 

AutoVue for Agile opens and displays the selected files. 

Ad hoc 2D, 3D, and EDA/ECAD markup can be done from the Files tab in the file folder object. 
Change order-controlled 2D, 3D, and EDA/ECAD markup can be done from the Redline Attachments 
tab in the ECO. When you view a markup file, the original document, also known as the base file, 
opens too. 

 Change order-controlled and ad hoc markups are independent from each other. 

To view change order-controlled markups, open the redlined file from the appropriate revision of the 
item Attachments tab or from the change order Redline Attachments tab (see Viewing ECO Redlines 

from the Attachments Tab of the Item Pending Revision on page 30). 

To view ad hoc markups, open the redlined file from the file folder object Files tab. 

Marking up refers to drawing and writing in an electronic document. With AutoVue for Agile, your 
original document remains unchanged because your markups are saved in separate markup files. 
When you view a markup file, AutoVue for Agile loads the markups into memory and lays them over 
the original document.       

There can be as many markup files as you wish for a document because each has its own unique 
filename. This allows several individuals to mark up the same document at the same time because 
a unique markup file is created for each person’s work. With the markup information attached to 
each markup file, you can even tell who created each markup. 

Markup files are divided into uniquely named layers. Create, name, and color the layers to organize 
your work as you like. For example, different colors could indicate time priorities, and each layer 
could contain markups relating to a common purpose. Markup files are stored with other attachment 
files in the file vault, part of Agile File Manager. Markup files are managed by Agile and are 
automatically retrieved and presented when you view the redlined document. 

With appropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and EDA files on 
the Files tab of a file folder object and redline 2D, 3D, and EDA files on the Redline Attachments tab, 
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accessible from the Affected Items tab of an ECO.      

 You can create and edit file markups only through the Affected Items tab of an ECO or the 
Files tab of a file folder object. Your Agile administrator must give you privileges that 
allow you to mark up or redline attachments. For more information about ECOs and file 
folder objects, see the Getting Started with Agile PLM User Guide. 

 

1. If you have not already done so, add an item with an attachment to the Affected Items tab of an 
unreleased ECO. The item now has a pending revision associated with the unreleased ECO. 

When redlining an attachment through an ECO, the pending revision attachment Folder Version 
must be set to a specific version number; if the Folder Version is set to LATEST-x, you will not be 
able to create redline markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 

 For example, if the pending revision of the item refers to Folder Version LATEST-7 of 

the file folder, select that row on the Attachments tab, click the Edit  button and use 
the Folder Version drop-down list in the Edit dialog box to select 7. Click OK to 
complete the edit process. You will now be able to create redline markups for that 
attachment. Select the added item on the Affected Items tab of the ECO. 

On the Redline Attachments tab, select the row containing the file you want to redline and click 

the Do Redlining  icon. 

2. When the AutoVue for Agile appears, click the New Markup  button. (This button is available 
only when markups are allowed.) 

3. Use the tools described in the online Help to redline the attachment. To view online Help, 
choose Help > Content in the menu bar. 

 ECO markups are saved against and associated with the pending revision of the 
item. If the ECO is released without first replacing the file, the markups appear 
against the released revision of the item.. 

1. Select the row containing the file you want to redline and click the Do Redlining  icon. 

2. When AutoVue for Agile appears, click the New Markup  button. (This button is available only 
when markups are allowed.) 

3. Use the tools described in the online Help to redline the attachment. To view online Help, 
choose Help > Content in the menu bar. 

 ECO markups are saved against and associated with the pending revision of the 
item. If the ECO is released without first replacing the file, the markups appear 
against the released revision of the item. 
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 If the item or file has already been redlined, then the Has been redlined  icon will be 
displayed. 

1. If you have not already done so, add an item with an attachment to the Affected Items tab of an 
unreleased ECO. The item now has a pending revision associated with the unreleased ECO. 

When redlining an attachment through an ECO, the pending revision attachment Folder Version 
must be set to a specific version number; if the Folder Version is set to LATEST-x, you will not be 
able to create redline markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 

 For example, if the pending revision of the item refers to Folder Version LATEST-7 of 
the file folder, select that row on the Attachments tab, click the Edit button and use the 
Folder Version drop-down list to select 7. Click Save to complete the edit process. You 
will now be able to create redline markups for that attachment. On the Affected Items 
tab, click the Do Redlining icon for that item to open the Redlines page. 

2. On the Affected Items tab, select the row of the Item you want to redline. The redline tabs for the 
selected item are displayed in the lower section of the Affected Items tab. 

3. On the Redline Attachments tab, select one or more rows and click the Redline button. 

4. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

ECO markups are saved against and associated with the pending revision of the item. If the ECO is 
released without first replacing the file, the markups appear against the released revision of the 
item. 

1. On the Files tab of a file folder object,  select one or more rows and click the Redline button. 

2. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Ad hoc markups are saved against and associated with the version of the file folder object. 

 If the item or file has already been redlined, then the Has been redlined icon  will be 
displayed in the place of the Do Redlining icon. 

1. If you have not already done so, add an item with an attachment to the Affected Items tab of an 
unreleased ECO. The item now has a pending revision associated with the unreleased ECO. 
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 When redlining an attachment through an ECO, the pending revision attachment 
Folder Version must be set to a specific version number; if the Folder Version is set 
to LATEST-x, you will not be able to create redline markups. However, you can edit 
the Folder Version on the Attachments tab of the pending revision so that it refers to 
a specific Folder Version. 

 For example, if the pending revision of the item refers to Folder Version LATEST-7 of 
the file folder, select that row on the Attachments tab, click the Edit button and use the 
Folder Version drop-down list to select 7. Click Save to complete the edit process. You 
will now be able to create redline markups for that attachment. On the Affected Items 
tab, click the Do Redlining icon for that item to open the Redlines page. 

2. On the Affected Items tab, click the Do Redlining icon  (or Has been redlined icon ) next to the 
item to open the Redlines page. 

3. On the Redline Attachments tab, click the Do Redlining icon  (or Has been redlined icon ) on the 
row of the file you want to redline. (This icon is available only when markups are allowed.) 

4. Use the tools described in the online Help to redline the attachment. To view online Help, 
choose Help > Content in the menu bar. 

 ECO markups are saved against and associated with the pending revision of the 
item. If the ECO is released without first replacing the file, the markups appear 
against the released revision of the item 

1. On the Files tab of a file folder object, click the Do Redlining icon  (or Has been redlined icon ) 
on the row of the file you want to redline. (This icon is available only when markups are 
allowed.)   

2. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

 Ad hoc markups are saved against and associated with the version of the file folder 
object. 

 

The change order redlines of 2D, 3D, and EDA files are based on the pending revision of the item. 
The markup changes are visible from either the change order’s Redline Attachments tab or from the 
pending revision item Attachments tab. 

3D features and access to 3D files are available only with AutoVue Electromechanical Pro. 
Features for schematic and PCB files, also referred to as EDA files, are available only with 
AutoVue Electromechanical Pro. For more information about purchasing or installing 
AutoVue Electromechanical Pro, contact Oracle Consulting – Agile Practice. 

You can view the change order markup redlines of the pending revision by displaying the 
Attachments tab of the item pending revision, for example, revision (C) ECO000453. The redlined file is 
indicated by the Has been redlined icon. 
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 In Java Client, select the redlined file you want to view and click the Has been redlined  icon. 

 In Web Client, click the Has been redlined (  for versions 9.2.2.x and 9.2.1.x,   for version 
9.3) icon in the row of the file you want to view. 

If you have checked out the redlined file and checked in a new version from the Attachments tab, the 
Has been redlined icon does not appear on the Attachments table. 

1. On the Attachments tab of the pending revision, select the row you want to view. 

2. Click the Show Versions button. The Versions dialog appears. 

3. On the version row for which you want to view redlines, click the Has been redlined  icon. 

1. 9.2.2.x/9.2.1.x: On the Attachments tab of the pending revision, click the Show Versions  icon in 
the row you want to view. The Versions dialog appears. 

9.3: Select View Versions from the Actions menu. 

2. On the version row for which you want to view redlines, click the Has been redlined (  for 

versions 9.2.2.x and 9.2.1.x,   for version 9.3) icon. 

 If you need to determine which file folder version is associated with the change 
order redlines, refer to the change order History tab. 

However, if the attachment file on the pending revision item is not replaced prior to the change 
order release, the redlines will be accessible from the released revision of the item. The following 
diagram shows an example of the change order attachment redlining process.  
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See also Product Collaboration User Guide and Getting Started with Agile PLM. 
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For information about working with markups, including markup layers and markup objects, refer to 
the viewer online help. Choose Help > Contents in the AutoVue for Agile menu bar. 

If you exit AutoVue for Agile without saving, you will lose any redline you have added to the 
attachment. 

In Markup mode, the Markup > Properties command displays the Markup Information dialog box with 
five information fields attached to the current active markup file.    

Object Rotate allows you to rotate symbol markup objects. 

1. Select the symbol markup object you want. 

2. Click the Rotate button, or choose Markup > Object > Rotate. 

When this feature is activated, the Rotate button appears as a recessed button (light gray) on 
the toolbar. 

3. Place the cursor on one of the corner squares that indicate the selected object. 

4. When you see the crossed-arrows cursor (pointing in four directions), hold down the left mouse 
button and adjust the rotation angle of the object. 

5. Release the mouse button when you are finished adjusting the rotation angle. 

 
 

For information about working with 2D files, including CAD views and measuring objects, refer to 
the viewer online help. Choose Help > Contents in the AutoVue for Agile menu bar. 

AutoVue for Agile EDA features include: 

 Ability to view all relevant EDA formats including artwork formats, PCB/IC layouts, schematics 
and manufacturing formats 

 Cross probe between a PCB layout and related schematics (see Cross Probing on page 36). 
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 Verify design by testing for manufacturability or design violation. 

 Generate and export Bills of Material in a variety of formats. 

For detailed information about all the EDA features, refer to the viewer online help. Choose 
Help > Contents in the AutoVue for Agile menu bar. 

 EDA features and access to EDA files are available only with 
AutoVue Electromechanical Pro. Features for schematic and PCB files, also referred 
to as EDA files, are available only with AutoVue Electromechanical Pro. For more 
information about purchasing or installing AutoVue Electromechanical Pro, contact 
Oracle Consulting – Agile Practice. 

 

For information about working with 3D files, including light settings and models, refer to the viewer 
online help. Choose Help > Contents in the AutoVue for Agile menu bar. 

 3D features and access to 3D files are available only with AutoVue Electromechanical 
Pro. For more information about purchasing or installing AutoVue Electromechanical 
Pro, contact Oracle Consulting – Agile Practice. The following AutoVue for Agile 
Actions can be used from the Cross Probing, Comparing Files, Overlaying Files, and 
Digital Mock Up functions: 

 Browse – Opens the File Open window. From this window, system files can be loaded and 
viewer actions (Cross Probing, Comparing Files, Overlaying Files, and Digital Mock Up) can be 
done. 

 Agile Browse - Opens the Bookmark window. From this window, you can do book marked 
business objects viewer actions. 

 Agile Search - Opens the Agile Search window. From this window, you can load attachments 
from business objects to do AutoVue for Agile actions. 

 
 

3D CAD assemblies are made up of many files dependent one upon another. For example, a 
SolidWorks or Pro/E CAD design consists of at least one assembly file and one or more part files. 
The 3D files are used primarily in manufacturing departments for drawing the blueprint of the new 
instrument. 3D files may be added to the Files tab in one or several file folder objects.  

 One File Folder 

All files in one CAD assembly are added to the Files tab of one file folder. When you view the 
assembly, Agile prompts you to identify the top file in the assembly and the complete assembly 
is displayed in AutoVue for Agile. 

 One Design 

Assembly Files are added to the Files tab and parts files can be referenced from the Design 
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added to the Structure tab. 

 Multiple File Folders 

The assembly file is added to the Files tab in one file folder object, and parts files can be 
referenced by adding other file folder objects containing the files as relationships with no rules 
to the Relationships tab of the assembly’s file folder object.  

3D files can be redlined both through a change order (Redline Attachments) and on the Files tab of 
the file folder object. 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Double-click the multiple-file attachment row that references the CAD assembly. The Select 
Files window appears. 

 A multiple-file attachment row is indicated by a file folder icon in the Filename field, 
followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 

a. On the business object Attachments tab, click to select the multiple-file attachment row. 

b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click OK. 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View. 

 
 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Click the multiple-file attachment row that references the CAD assembly. 

 A multiple-file attachment row is indicated by a file folder icon in the Filename field, 
followed by the filenames of all the files in the file folder. 

Use the Attachment tab View button: 
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a. On the business object Attachments tab, click to select the multiple-file attachment row. 

b. Click the View button's drop-down arrow and select View from the menu. 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View button's drop-down arrow and select View menu. 
 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Double-click the multiple-file attachment row that references the CAD assembly. The Select 
Files window appears. 

 A multiple-file attachment row is indicated by a file folder icon in the Filename field, 
followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 

a. On the business object Attachments tab, click to select the multiple-file attachment row. 

b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click Finish. 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View As Assembly from the menu. 
 

Cross probing is also described in the viewer online Help. In Agile, this feature is initiated from 
either the business object Attachments tab or the file folder Files tab rather than from the viewer 
menus. For detailed information about cross probing features, see the online help. Choose Help  
> Contents in the AutoVue for Agile menu bar. 
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 Cross probing features are available only with AutoVue Electromechanical Pro. In 
order to use these features, you must have AutoVue Electromechanical Pro. For more 
information about purchasing or installing AutoVue Electromechanical Pro, contact 
Oracle Consulting – Agile Practice. 

 Use cross probing to interrogate ECAD schematic and layout files in separate viewer 
windows. 

 The Agile administrator should specify the ECAD file extension in the Valid Model File Type 
field for you to view the ECAD files. 

You can select both needed files from the same Attachments tab or the same file folder Files tab from 
which you launch the Cross Probe action. Or, you can select one file on the current tab and then 
search for the remaining file from the attachments of any other object. 

The View > By Search > Crossprobe option allows you to find other files in the system, which you may 
want to use to cross probe, without having to select two files from the same Attachments tab or Files 
tab; that is, you can search and select one attached file from Part 234 and another attached file 
from Part 765. 

Alternatively, you can view a single ECAD file then initiate cross probing within the viewer by adding 
another file from your desktop. 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose:  

 Java Client: View File(s)  > Cross Probe. 

 9.2.2.x or 9.2.1.x Web Client: View > Cross Probe. 

Each file is displayed in a separate viewer window. 

3. Begin cross probing. 

See AutoVue for Agile online help for more information about cross probing. Choose 
Help > Contents in the AutoVue for Agile menu bar. 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose:  

 Java Client:  View File(s)  > Cross Probe. 

 9.2.2.x or 9.2.1.x Web Client: View > Cross Probe. 

 9.3 Web Client: View. The file opens in AutoVue for Agile, then choose Analysis > Cross 
Probe. 

Each file is displayed in a separate viewer window. 

3. Begin cross probing. 
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See the online help for more information about cross probing. Choose Help > Contents in the 
AutoVue for Agile menu bar. 

1. Display the Attachments tab or the Files tab. 

2. Select a file row you want to work with and choose:  

 Java Client: View File(s) > By Search > Cross Probe. 

 9.2.2.x or 9.2.1.x Web Client only: View > By Search > Cross Probe. 

The Select Files dialog appears, with three Search tabs. 

3. The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use to Cross Probe. 

Use any of the following search methods: 

 Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are 
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the related 
files for that object appear in the Related Files table. 

5. In the Related Files table, select and move attachments to the Selected Files table. 

6. You can continue to run multiple searches or shortcuts until you are finished selecting the 
attachments you want. 

7.  When you are finished, click OK. 

Each file is displayed in a separate viewer window. 

8. Begin cross probing. 

See the online help for more information about cross probing. Choose Help > Contents in the 
AutoVue for Agile menu bar. 

 

Comparing files is also described in the AutoVue for Agile online Help. In Agile, rather than initiating 
file compare from the viewer menus, you initiate file compare from either the file folder Files tab or 
the business object Attachments tab. 

For detailed information about file comparison features, see the online help. Choose Help > Contents 
in the AutoVue for Agile Menu bar. 
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Compare file features are available only with AutoVue Electromechanical Pro. For more information 
about purchasing or installing AutoVue Electromechanical Pro, contact Oracle Consulting – Agile 
Practice. 

Markups (redlines) are not supported in the AutoVue for Agile compare mode. 

You can select and compare two files from a single file folder Files tab or a single business object 
Attachments tab. 

1. Display the Attachments tab or the Files tab. 

2. Select both files you want to work with and choose: 

 Java Client: View File(s) > Compare 

 Web Client: View > Compare 

The files and the comparison results are displayed in a single viewer window. 

For more information about compare file features and options, choose Help > Contents in the 
AutoVue for Agile menu bar. 
 

The View > By Search > Compare command allows you to 

 Compare files from different released revisions of an item. 

 Compare files from different file folder versions. 

 Select any file on any business object Attachments tab or on any file folder Files tab, and then 
search for a file to use for comparison.  

Depending on your search, you can select a business object, and then select a file from the list 
of related files for that object. Or, if you have the appropriate privileges, you can search for file 
folder objects, and then select a file from the list of related files for the selected file folder. 

 For item objects, Introductory revisions and unreleased pending revisions do not 
appear in the related files list.  

1. Display the Attachments tab or Files tab. 

2. Select a file row you want to work with and choose: 

 Java Client: View File(s) > By Search > Compare 

 9.2.2.x or 9.2.2.a Web Client: View > By Search > Compare 

 9.3 Web Client: View > Compare by Search (A search dialog allows you to search for the 
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object.) 

The following steps apply to the Java Client and 9.2.2.x and 9.2.1.x Web Client only: 

3. The Compare Files by Search dialog allows you to search for any business object (for example 
items or manufacturer parts) and select the attachments of those objects to compare.  

Use any of the following search methods: 

 Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and Click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are 
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the results table, and the related 
files for that object appear in the Related Files table. 

5. In the Related Files table, select the file you want. 

 If the selected search object is a file folder, use the Version drop-down list in the Related 
Files table to select the file folder version you want. 

 If the selected search object is an item, the Related Files table displays item attachments 
for each released revision of the item (the file name followed by the revision number or 
letter, for example,  and ). 

 For item objects, Introductory revisions and unreleased pending revisions do not 
appear in the related files list.  

 If the selected search object is a business object, check the Show Matching File Types Only 
checkbox to display only the related files that are the same file type as the file with which 
you want to compare.  

6.  When you are finished, click OK. 

You can continue to run multiple searches or shortcuts until you are finished selecting the 
attachments you want. 

The files and the comparison results are displayed in a single viewer window. For more information 
about compare file features and options, choose Help > Content in the AutoVue for Agile menu bar.  

Overlaying files is also described in the viewer online Help. In Agile, this feature is initiated from the 
file folder Files tab rather than from the viewer menus. For detailed information about file overlay 
features, see the viewer online help. Choose Help  > Contents in the AutoVue for Agile menu bar. 

Overlaying files features are available only with AutoVue Electromechanical Pro. For more 
information about purchasing or installing AutoVue Electromechanical Pro, contact Oracle 
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Consulting – Agile Practice. 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose: 

 Java Client:  View File(s)  > Overlay. 

 Web Client: View > Overlay. 

The files are displayed in a single viewer window, one on top of the other. For more information 
about overlay file features (for example, File > Overlays in the menu bar) and options, choose 
Help  > Contents in the AutoVue for Agile menu bar. 

1. Display the Attachments tab or the Files tab. 

2. Select a file row you want to work with and choose: 

 Java Client: View File(s) > By Search > Overlay. 

The Select Files dialog appears, with three Search tabs. 

 9.2.2.x or 9.2.1.x Web Client: View > By Search > Overlay. 

The View Files by Search dialog appears, with three Search tabs. 

 9.3 Web Client: View.  The file opens in AutoVue for Agile, then choose File > Import File as 
Overlay. 

The following steps apply to the Java Client and 9.2.2.x and 9.2.1.x Web Client only: 

3. The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use to overlay.  

Use any of the following search methods: 

 Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are 
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the related 
files for that object appear in the Related Files table. 

5. In the Related Files table, select and move attachments to the Selected Files table. 

6. You can continue to run multiple searches or shortcuts until you are finished selecting the 
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attachments you want. 

7.  When you are finished, click OK. 

The files are displayed in a single viewer window, one on top of the other. For more information 
about overlay file features (for example, File > Import File as Overlay in the menu bar) and options, 
choose Help  > Contents in the AutoVue for Agile menu bar. 

 

 Features for schematic and PCB files, also referred to as EDA files, are available only 
with AutoVue Electromechanical Pro. For more information about purchasing or 
installing AutoVue Electromechanical Pro, contact Oracle Consulting – Agile Practice. 
For information about these features, refer to the viewer online help. Choose 
Help > Contents in the AutoVue for Agile menu bar. 

 

For detailed information about collaboration features, refer to the viewer online help. Choose 
Help > Contents in the AutoVue for Agile menu bar. The following sections discuss AutoVue for Agile 
server information and Agile privileges that affect collaboration sessions. 

Real-time collaboration features are available only with AutoVue Electromechanical Pro. For more 
information about purchasing or installing AutoVue Electromechanical Pro, contact Oracle 
Consulting – Agile Practice. 

The Collaborate feature lets multiple users team up and review documents interactively and 
simultaneously, thus shortening an otherwise lengthy review process where documents are passed 
back and forth. The Collaborate feature is available to all users who have Agile Discovery, Read, 
and Attachment Redlines privileges. 

From the Collaborate menu, anyone with the required Agile privileges can initiate a Collaboration 
session and act as host, or join a Collaboration session if invited by the host. 

 If you plan to host a Collaboration session, ensure that all intended participants have 
Discovery, Read, and Attachment Redlines privileges. If they can view and redline a 
file, they have the necessary privileges. If they cannot, contact your Agile 
administrator, who can grant them the necessary privileges, before you attempt to 

initiate the Collaboration session. 

In order to participate in the collaboration session, all the collaborators must be logged into Agile 
and viewing a file in the viewer when you start the collaboration session. They do not need to view 
the file you are going to review in the collaboration session; they can view any file. For this reason, 
they may choose to view a small file that will load quickly. 

When the host initiates a Collaboration session, a session object is created on the server, which is 
maintained for the duration of the Collaboration session. Session information is available from the 
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Collaborate menu during a Collaboration session. It displays the session subject (the name 
assigned to the Collaboration session), the session ID (each session subject is assigned a unique 
session ID), the name of the base file viewed, the host, and the list of users participating. 

A session markup file is created during the Collaboration session to which all participants can add 
markup entities. Participants are assigned different layer colors for the session so that the markup 
entity from each participant is identifiable. The host for the session owns the markup file and is the 
only one who can save it. 

 All users must connect to the same AutoVue for Agile server to use the collaboration 
feature. Remote users may have to change their preferred File Manager profile setting in 
a distributed File Manager environment. 

 

In 3D mode, you can use the Mockup feature (DMU) to test alignment and interference of multiple 
assemblies. You can save the mockup as a redline markup entity. 
 

1. Display the Attachments tab or the Files tab. 

2. Select all the file rows you want to work with and choose: 

 Java Client: View File(s) > Digital Mockup. 

 9.2.2.x or 9.2.1.x Web Client: View > Digital Mockup. 

 9.3 Web Client:  View > View. After AutoVue for Agile opens, chose File > Import file for 
Mockup. 

3. Manipulate the models using the viewer features including the features in the Analysis menu, for 
example User Defined Coordinate Systems, Manipulators, Interference Checking, and Part 
Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the 
AutoVue for Agile menu bar. 

1. Display the Attachments tab or the Files tab. 

2. Select a file row you want to work with and choose: 

 Java Client: View File(s) > By Search > Digital Mockup. 

The Select Files dialog appears, with three Search tabs. 

 9.2.2.x or 9.2.1.x Web Client: View > By Search > Digital Mockup. 

The View Files by Search dialog appears, with three Search tabs. 

 9.3 Web Client: View  > View. After AutoVue for Agile opens, choose File > Import file for 
Mockup. 

The following steps apply to the Java Client and 9.2.2.x and 9.2.1.x Web Client only: 
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3. The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use for the mockup.  

Use any of the following search methods: 

 Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents, too. 

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are 
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the related 
files for that object appear in the Related Files table. 

5. In the Related Files table, select and move attachments to the Selected Files table. 

6. You can continue to run multiple searches or shortcuts until you are finished selecting the 
attachments you want. 

7.  When you are finished, click OK. 

The files are loaded into the same AutoVue for Agile workspace. 

8. Manipulate the models using the viewer features including the features in the Analysis menu, for 
example User Defined Coordinate Systems, Manipulators, Interference Checking, and Part 
Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in 
the AutoVue for Agile menu bar. 
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The following features described in the viewer online Help have been modified or have been 
suppressed and are not available. 

 Window menu and its options for viewing multiple files (New, Cascade, Tile Horizontally, and Tile 
Vertically) are not available.  

 The ability to click and drag toolbars to move them is not available.  

 Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as underlined 
letters in the menus.  

 Tooltips Quick Menu is not available.  

 The Customize > Options menu selection does not include toolbar and tooltip settings.  
 

Because the Agile system manages and controls access to attached files and markups (redline 
files), the following features described in the viewer online Help may have been modified or are not 
available to you. 

Many of these modifications relate to how files are opened, saved, and where they are stored. 
Instead of using viewer features (for example, File > Open, as described in the viewer online Help) to 
view files, the files are selected via the Agile object Attachments tab and the file folder Files tab, and 
retrieved from the file vault, part of Agile File Manager. The files are then displayed in the viewer 
window. When you create and save markup files, they are also saved in the file vault. (See Opening 

Agile Attachment Files in AutoVue for Agile on page 25 and Guidelines for Marking Up or 

Redlining Attachments on page 27.) 

If you need more information about a viewer feature, see the viewer online Help. To view online 
Help, choose Help > Content in the AutoVue for Agile menu bar. 
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These features described in the viewer online Help are not available: 

 Viewer Startup view (empty viewer window).   

 Drag and drop files from Windows Explorer onto the viewer window to open them.  

 The following viewer File menu selections are not available in AutoVue Electromechanical Pro: 
Open, Browse, Next File, Previous File, Load File, Open URL, and Close. 

 Archive file directory displayed in viewer window. 

 Import and Export Markup files feature is not available. Import and Export 3D Models is not 
available. 

Access to all files, including markup files, is managed by the Agile system. For more 
information about markup files in Agile, see Marking Up — How It Works on page 27 and 
Guidelines for Marking Up or Redlining Attachments on page 27.  

Refer to the AutoVue for Agile online help for details about working with and creating hyperlinks. To 
view the online help, choose Help  > Contents in the viewer menu bar. 

Although you can create hyperlink markup entities, you cannot create hyperlinks to other files in the 
Agile file vault. 

The purpose of this viewer feature is to gather or link related information together. This functionality 
is provided by Agile features such as Attachments tabs (which may have multiple attached file folder 
objects) and Relationships tabs. For more information about file folder objects and attachments see 
Getting Started with Agile PLM. 

The viewer modes Startup View and Thumbnails Mode described in the online Help are not 
available. 



Version 19.3.2 47  

 Printing Documents from within the Viewer ......................................................................................................... 47 
 Headers/Footers Group in Print Properties ......................................................................................................... 47 
 Watermarks and Banners in Print Properties ...................................................................................................... 48 
 Stamps Group in Print Properties ........................................................................................................................ 49 
 Printing DGN Files ............................................................................................................................................... 49 

 
 

For detailed information about printing attachments from the file folder object Files tab, see the 
Getting Started with Agile PLM manual, Chapter 9, ―Working with Attachments", and Chapter 10, 
"Working with File Folders.‖ 

For detailed information about printing from the viewer, see the viewer online Help. To view online 
Help, choose Help > Content in the AutoVue for Agile menu bar. 

For information about how the Agile administrator can customize the AutoVue for Agile print 
options, see Viewer Administration Tasks on page 51. 

The following sections describe print features that have been modified to integrate the viewer with 
the Agile system. 

This group defines the headers and footers to be included on every printed page of the document.           

 These settings are maintained and modified by your Agile administrator. 

Select the Headers/Footers tab. 

A literal percentage mark is indicated by %%. Other codes are as follows: 

 %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF) 

 %v = document drive 

 %d = document directory (for example, D:\PICS\TIFF) 

 %b = document base name (for example, CTROK) 

 %e = document file extension (for example, TIF) 
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 %n = total number of document pages 

 %p = current page number 

 %N = total number of tiled pages 

 %P = current tile number 

 %r = newline 

 %F = Excel native print settings 

 %Y = date: year 

 %M = date: month 

 %D = date: day 

 %W = date: day of week 

 %H = time: hour 

 %U = time: minute 

 %S = time: second 
 

The Print Properties dialog box includes a Watermark tab. This tab cannot be modified in the 
AutoVue for Agile Print Properties dialog box. 

Watermark and Banner settings are defined and maintained in Agile Administrator. The Agile 
Administrator watermark and banner settings determine whether banners and watermarks appear 
on printouts of files attached to Agile objects and the content of those banners and watermarks. 
These banners and watermarks appear on files printed with AutoVue for Agile. 

Watermarks on attachments are inserted under the file. Therefore, file types that are in ―solid‖ 
formats (for example, PDF, BMP) will not show the watermark. It will show only on ―transparent‖ file 
types (for example, CAD). 

A faint and transparent watermark appears on the current document’s contents. 

 For high resolution black and white printing, the transparent watermark is printed on the 
current document’s contents. For low resolution black and white printing, the watermark 
is printed on the current document’s contents, but it is not transparent. 

The watermark settings are maintained and modified by your Agile administrator; see the 
Administrator Guide. For more information, see Viewer Administration Tasks on page 51. 
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 This feature is not available in this implementation of AutoVue for Agile. 

 

AutoVue for Agile can be configured to print files with a DGN extension in the same manner as 
MicroStation. This option must be configured on the server side; please contact your Agile system 
administrator for assistance.           
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 For information about Agile PLM Administrator settings related to AutoVue for Agile (for 
example, Supported File and Valid Model File Type settings), see Administrator Guide, 
―Viewer and Files‖ section of the ―General System Settings‖ chapter. 

 
 

Some file formats require configuring specific print settings to print properly. In general, you can 
change these settings for all users or for individual users: 

 To change the print settings for all users, you need to modify some of the parameters in the 
AVS\bin\allusers.ini file. 

 To change the print settings for individual users, you need to modify some of the parameters in 
each user's .ini file under AVS\bin\profiles. 

 When you modify options in the allusers.ini file, the existing user profiles are not 
automatically modified. Because editing every individual user profile is impractical, in 
the procedures below you are instructed to delete the existing user profiles when you 
modify allusers.ini. The next time a user opens AutoVue for Agile, a new user profile is 
created which includes the new allusers.ini options settings. You may want to notify 
your users in advance to let them know that their user profiles will be reset. 

To change the way that the watermark, border, and header (banner) appear when printed, you will 
need to modify the following .ini file parameters: 

 [OPTIONS] – HPBACKGROUND, KEEPORIGINALCOLORS, and 
SWSHOWVIEWPORTBORDER 

 [PRINTWATERMARK] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

 [PRINTHEADERS] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

The following sections describe the procedures for printing watermarks and borders, and for 
modifying the headers and watermarks. 
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To print watermarks correctly in .hpg and .plt files, you must set the background color correctly. 

 If the watermark image or the color used in the watermark image is not transparent, the 
watermark will not be visible. 

1. Shut down the JVue server. 

2. On the drive where the AutoVue for Agile Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following two lines: 

HPBACKGROUND = 0 

KEEPORIGINALCOLORS = 1 

To print viewport borders correctly in SolidWorks files, you must enable the viewing/printing of 
viewport borders. 

1. Shut down the JVue server. 

2. On the drive where the AutoVue for Agile Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following line: 

SWSHOWVIEWPORTBORDER = 1 

 The watermark may be truncated if the font size is too large or if there are too many 
characters in the watermark text. Truncation ensures that the watermark does not distort 
the image. 

1. Shut down the JVue server. 

2. On the drive where the AutoVue for Agile Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 
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5. In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update the lines for 
Fontname, Fontsize, Orientation, and Fontstyle. For example: 

FONTNAME = Serif 

FONTSIZE = 24 

ORIENTATION = 1 

FONTSTYLE = 2 

 ORIENTATION can be specified as 1 (portrait) or 2 (landscape). 

 

To ensure that specific fonts are recognized by AutoVue for Agile, you can add the font path to the 
allusers.ini configuration file. 

1. Shut down the JVue server. 

2. On the drive where the AutoVue for Agile Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, update the following line: 

XFONTPATHS = {paths} 

6. Add the full paths of the font files to the line. Separate the paths with a semicolon. 

7. Save the allusers.ini file. 

8. Clear your web browser’s cache. 

9. Restart the JVue server. 
 

When viewing Excel files in AutoVue for Agile, the number of pages listed in the viewer status bar is 
the number of Excel worksheet and the AutoVue for Agile menu command View > Page selects a 
different Excel worksheet to view. 
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