Skip Headers
Oracle® JRockit JDK Release Notes
Release R28

Part Number E15066-26
Go to Documentation Home
Home
Go to Table of Contents
Contents
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

1 Changes in Supported Configurations in Oracle JRockit JDK R28

This chapter lists the changes in the supported configurations for JRockit JDK R28.x when compared with R27.6.6.

The following are the changes in supported configurations:

Note:

JRockit JVM R28.x is not supported on Windows 2000, as was the case with R27.

For up to date supported configuration information, see Oracle Fusion Middleware Supported System Configurations at: http://www.oracle.com/technetwork/middleware/ias/downloads/fusion-certification-100350.html.

1.1 Java Version Updates

The following table lists the Java versions supported by the various Oracle JRockit JDK R28 releases:

Table 1-1 Java Versions Supported by the Oracle JRockit JDK R28.x

JRockit JDK R28.x Release Supported J2SE 5.0 Update Supported Java SE 6 Update

R28.3.2

Update 65

Update 75

R28.3.1

Update 61

Update 71

R28.2.9

Update 55

Update 65

R28.2.8

Update 51

Update 51

R28.2.7

Update 45

Update 45

R28.2.6

Update 43

Update 41

R28.2.5

Update 38

Update 37

R28.2.4

Update 36

Update 33

R28.2.3

Update 34

Update 31

R28.2.2

Update 32

Update 29

R28.2.1

Update 32

Update 29

R28.2

Update 32

Update 29

R28.1.5

Update 32

Update 29

R28.1.4

Update 30

Update 26

R28.1.3

Update 28

Update 24

R28.1.1

Update 26

Update 22

R28.1.0

Update 24

Update 20

R28.0.2

Update 24

Update 20

R28.0.1

Update 24

Update 20

R28.0.0

Update 22

Update 17


1.2 Hardware Must Support Streaming SIMD Extensions (SSE) 2

Oracle JRockit JDK R28.x does not support x87, the floating point extension to the x86 platform.

Hardware on which you intend to run the Oracle JRockit JVM must support SSE2 (Streaming SIMD Extensions): that is, Intel Pentium 4 or Pentium M; AMD Opteron or Athlon 64; or newer hardware.

1.3 J2SE 1.4.2 and JVMPI Not Supported

Oracle JRockit JDK R28.x does not support J2SE 1.4.2.

As a consequence of this change, JRockit JDK R28.x does not support JVMPI. Most tools partners use JVMTI, which continues to be supported.

1.4 Itanium Platforms Not Supported

Oracle JRockit JDK R28.x does not support the Itanium architecture.

Previous JRockit JDK releases are available and supported for Itanium platforms until all the dependent Oracle products reach end-of-life (EOL).