Skip Headers
Oracle® Fusion Middleware User's Guide for Oracle JDeveloper
11g Release 2 (11.1.2.0.0)

Part Number E17455-01
Go to Documentation Home
Home
Go to Table of Contents
Contents
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

2 Oracle JDeveloper Accessibility Information

This chapter provides information on the accessibility features of Oracle JDeveloper.

This chapter includes the following sections:

2.1 About Oracle JDeveloper Accessibility

It is our goal to make Oracle Products, Services, and supporting documentation accessible to the disabled community. Oracle JDeveloper supports accessibility features. For additional accessibility information for Oracle products, see the Oracle Accessibility Program page at:

http://www.oracle.com/accessibility/

2.2 Using a Screen Reader and Java Access Bridge with Oracle JDeveloper

In order for assistive technologies, like screen readers, to work with Java-based applications and applets, the Windows-based computer must also have Sun's Java Access Bridge installed. Please refer to the Oracle Fusion Middleware Installation Guide for Oracle JDeveloper for the screen reader setup procedure, and for the recommended minimum technology stack.

2.3 Oracle JDeveloper Features That Support Accessibility

Oracle JDeveloper provides features that are designed to support accessibility.

2.3.1 Keyboard Access

Oracle JDeveloper features support keyboard access to JDeveloper functionality; a summary is provided below. The mnemonic keys used to open menus and choose commands are included in all procedural topics. Please refer to the keyboard navigation topics for a summary of how keys are assigned within JDeveloper and the lists of accelerator keys provided for commands.

The following menu and toolbar functionality is provided through keyboard access:

  • Users can navigate to and invoke all menu items.

  • All toolbar functions are accessible through menu items.

  • All menus and menu items have unique and functioning mnemonic keys.

  • All context menus within the navigators and source editor can be invoked.

  • Frequently used menu items have unique accelerator keys.

The following functionality is available in JDeveloper IDE windows, which include the Application Navigator, Structure window, source editor, Property Inspector, Constraints, Profilers, Debugger windows, Help windows, Log windows and BC4J Tester. Users can:

  • Navigate between all open windows, to all nodes within a window or pane, and between tabs in a window.

  • Set focus in a window or pane.

  • Invoke all controls within a window or pane, and perform basic operations.

  • Navigate and update properties in the Property Inspector.

  • Use Code Insight and Code Templates in the source editor.

  • Invoke context sensitive help topics, navigate to and open all help topics, and navigate between the navigation and viewer tabs.

  • Open, close, dock, undock, minimize, restore and maximize the applicable JDeveloper window.

Tips:

  • You can press Escape to move the focus from the current dockable window to the last active editor. Press Shift+Escape to move the focus and also close the current window.
  • You can press Shift+F10 to open the context menu for any window. Use the Down Arrow and Up arrow keys to select a command and press Enter, or use the accelerators to invoke a command on the context menu.

The following functionality is available in Oracle JDeveloper dialogs and wizards:

  • Users can navigate to and invoke all controls within all wizards and dialogs.

  • The order in which the Tab key causes focus to flow is consistent and logical.

  • Mnemonic keys are provided for controls where appropriate.

Navigation and controls are available with runtime applications, which include all runnable files that are produced with Oracle JDeveloper, including Java applications, HTML applications, applets, JSF (Faces) applications, JSPs, and Servlets. With runtime applications, users can:

  • Navigate to all controls within all runtime applications.

  • Invoke all controls within all runtime applications.

2.3.2 Screen Reader Readability

Here is a summary of screen readability in JDeveloper, when it is used with a screen reader.

When used with menus and toolbars:

  • All menus and menu items are read.

  • All toolbar items, including the Navigator toolbar items, are read.

  • The hint text on all toolbar items is read.

When used with JDeveloper IDE windows:

  • All open windows are read.

  • All components within each window, including tabs, are read.

  • Status text at the bottom of the IDE, and within the source editor, is read.

When used with dialogs and wizards:

  • All controls within all wizards and dialogs are read.

  • Hint text is read.

When used with runtime applications:

  • All controls within all runtime applications are read.

2.3.3 Flexibility in Font and Color Choices

The user interface in JDeveloper improves usability for people who are visually impaired by offering flexibility in color and font choices. The following font and color features are included:

  • Users can specify both the font and the size in which the font displays for editors.

  • All features of the product have black text on a white or gray background.

  • Colored text, underlining or images are never used as the only method of conveying information.

2.3.4 No Audio-only Feedback

In JDeveloper, there is no situation in which the only feedback a user receives is audible feedback. All audible feedback is accompanied by a visual indicator. For example, a prompt accompanies the bell sound that occurs when an error or illegal action has taken place.

2.3.5 No Dependency on Blinking Cursor and Animation

JDeveloper makes minimal use of a blinking cursor and animation:

  • No features in JDeveloper use blinking indicators, with the exception of the cursor in the source editor.

  • No features rely on animated sequences.

2.3.6 Screen Magnifier Usability

The JDeveloper user interface works well with screen magnifiers. All features of the product can be magnified by a screen magnifier.

2.3.7 How to Change the Editor or Tabbed View of a File

When you press Enter on a node in the Application Navigator, you open the default editor for that file. To switch to the different editors and views available for a document; for example, to display a JSP file in source view or history view instead of design view, you can use the Alt+Page Up and Alt+Page Down accelerators to invoke the Window > Go to > Right Editor and Window > Go to > Left Editor menu commands, respectively.

2.3.8 How to Read Text in a Multi-line Edit Field

To have the text in a multi-line edit field read by a screen reader, you can select text by holding down the Shift key while moving the cursor either up or down with the Arrow keys, depending on the initial cursor position.

2.3.9 How to Read the Line Number in the Source Editor

To have the line number read by a screen reader while you are editing a file in the source editor, you can press Ctrl+G.

2.3.10 How to Access Exception Stack HTML Links and Generated Javadoc Links in the Log Window

After generating exception stack HTML links or Javadoc links in the Log window, they will not be recognized as links, but read as plain text by a screen reader. To access the links, set the cursor focus to the Log window. Right-click or press Shift+F1 and select Save As from the context menu. Save the contents of the Log window as an HTML file. Add the saved HTML file to a project or application workspace as a resource. Open the file from the Application Navigator in order to invoke the Oracle JDeveloper HTML/JSP visual editor, which will display the links correctly. Navigate the file and access the links from the HTML/JSP visual editor.

2.4 Recommendations for Customizing Oracle JDeveloper

JDeveloper provides a number of customization features that enable users to specify their requirements for keyboard usage, display attributes of the IDE, and timing where appropriate. All customization features are organized within the Preferences dialog. For maximum usability and to accommodate your needs, you should consider changing any of the following from the defaults to a more usable customized setting.

2.4.1 How to Customize the Accelerators Keys

You can add and change the default accelerator keys for Oracle JDeveloper in the Tools > Preferences > Shortcut Keys page. You can also load preset keymaps that you are accustomed to using.

2.4.2 How to Pass a Conflicting Accelerator Key to Oracle JDeveloper

In addition to changing the mapped accelerator keys, you can pass a conflicting accelerator key to JAWS by preceding the accelerator key combination with Insert+F3.

2.4.3 How to Change the Look and Feel of the IDE

You can change the default look and feel for Oracle JDeveloper in the Tools > Preferences > Environment page. The look and feel determines the display colors and shapes of objects like menus and buttons.

2.4.4 How to Customize the Fonts in Editors

You can change the font and font size that display in editors in the Tools > Preferences > Code Editor > Fonts page.

2.4.5 How to Customize Syntax Highlighting

You can change the font style, as well as the foreground and background colors used in syntax highlighting within the source editor in the Tools > Preferences > Code Editor > Syntax Colors page.

2.4.6 How to Display Line Numbers in Editors

You can display or hide line numbers in the source editor in the Tools > Preferences > Code Editor > Line Gutter page.

2.4.7 How to Change the Timing for Code Insight

You can specify the number of seconds that Code Insight is delayed, or disable Code Insight in the Tools > Preferences > Code Editor > Code Insight page.

2.4.8 How to Specify the Columns in the Debugger

You can choose the columns and types of information that display in the Debugger in the Tools > Preferences > Debugger pages.

2.5 Highly Visual Features of Oracle JDeveloper

Oracle JDeveloper includes features that are highly visual, and these features have equivalent functionality that is available to people who are blind or visually impaired:

You can add a component from the Component Palette to the UI or visual editor using keystrokes.

Oracle JDeveloper also includes modeling features. It is possible to create, edit and move elements on a diagram using only keystrokes.