Oracle® Crystal Ball

Accessibility Guide

Release 11.1.2.2


Copyright © 2012, Oracle and/or its affiliates. All rights reserved.

Authors: EPM Information Development Team

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS:

Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle America, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.


Table of Contents:

Introduction

Enabling Accessibility for Crystal Ball and Related Products

Crystal Ball Accessibility Features

Crystal Ball Keyboard Equivalents

Introduction

This guide describes the accessibility features of the following products:

  • Oracle Crystal Ball (including Classroom Faculty and Student Editions)

  • Oracle Crystal Ball Decision Optimizer

  • Oracle Crystal Ball Enterprise Performance Management

Oracle customers have access to electronic support through My Oracle Support. For information, visit http:// www.oracle.com/pls/topic/lookup?ctx=acc=info or visit http://www.oracle.com/pls/topic/lookup?ctx=acc=trs if you are hearing impaired.

Accessibility and Crystal Ball Products

You do not need to enable a minimum level of accessibility specifically for Crystal Ball; dialog controls are always accessible through tabbing and keyboard equivalents. Also, results data can be extracted to Microsoft Excel spreadsheets and pasted into Microsoft PowerPoint slides, which are accessible through Microsoft Office. For information about Microsoft Excel or Microsoft PowerPoint accessibility, refer to Microsoft Office product documentation.

For maximum accessibility for users with visual impairments, Crystal Ball can be switched into Accessibility mode. For details, see Enabling Accessibility for Crystal Ball and Related Products.

Enabling Accessibility for Crystal Ball and Related Products

Accessibility is the extent to which products, systems, and so on can be used by people with a wide range of disabilities. Specifically, accessibility is the ability of products to support the needs of users with visual impairments—including blindness, partial sight (low vision), and color blindness—and motor impairments that prevent them from using a mouse or a standard keyboard.

Crystal Ball supports accessibility at all times through keyboard shortcuts and other means mentioned in Crystal Ball Keyboard Equivalents. Crystal Ball users who require additional support can activate Accessibility mode with the following features:

  • When defining new forecast charts, the certainty grabber and certainty level marker lines are displayed by default.

  • Series or other distinctions in forecast, overlay, trend, and sensitivity charts have different patterns, not just different colors. Filtered data in scatter charts has a pattern.

  • Accessible text is provided in blank charts to indicate whether data is available or why it is not.

  • The Compare Run Modes chart now plots one series with a pattern.

  • Microsoft Excel charts are included in reports by default and values of the chart series are written out to the report spreadsheet.

  • The cell preference Add comment to cell is active and comments are added to new assumption, decision variable, and forecast cells defined in new workbooks. For additional information, see A Note About Accessible Default Cell Preferences.

  • The default size of assumption charts in reports is changed from 50% to 100%.

  • To ensure consistent progress readings, the simulation progress bar is hidden in the Crystal Ball control panel when an OptQuest optimization is running.

  • Constants to support the new Accessibility mode preference are added to the Crystal Ball Developer Kit for calls that set or return run preference settings.

Activating Accessibility Mode

  To activate Accessibility mode:

  1. Select Enable accessibility options in the Crystal Ball Welcome screen or the Options tab of the Run Preferences dialog.

  2. Select Use Crystal Ball in the Welcome screen or click OK in the Run Preferences dialog.

  To deactivate Accessibility mode, clear the Enable accessibility options selection in either the Welcome screen or the Run Preferences dialog.

A Note About Accessible Default Cell Preferences

The default Cell Preferences settings in Crystal Ball do not meet accessibility standards for differentiation by means other than color. Both pattern and color are used in Accessibility mode. When Accessibility mode is activated, new workbooks have accessible defaults as described in the bulleted list presented previously in the section.

  To apply accessible defaults to existing workbooks:

  1. Activate Accessibility mode.

  2. Open one or more existing workbooks.

  3. Select File, and then New to create a new workbook.

  4. With the new workbook selected, select Define, and then Cell Preferences. (In Microsoft Excel 2007 or later, select Define, and then Cell Prefs.)

    The Cell Preferences dialog opens with accessibility default settings selected.

  5. Click Apply To.

  6. In the Apply To dialog, select All tabs, and then All open and new workbooks.

  7. Click OK.

    The accessibility defaults are applied to all open workbooks.

  8. Save the workbooks to keep the new defaults.

This section describes specific accessibility features in Crystal Ball products that may differ from other products.

Using the Tab and Arrow Keys in the Crystal Ball User Interface

The main Crystal Ball menubar, ribbon, and menu commands are accessed with keyboard equivalents. After a menu is open, the Tab key or Down Arrow key highlights commands in a circular sequence (tabbing from the last item moves focus to the first item). Using Shift+Tab or the Up Arrow highlights commands in the opposite direction.

Default tab order in the Crystal Ball dialogs flows from left to right, top to bottom. Tab can be used to access the first item of a subwindow in a dialog, but then arrow keys are needed to move to additional items. For example, in the Distribution Gallery, Alt+b displays six basic distributions and places the focus on one of them. Using one of the arrow keys moves focus to an adjacent distribution. Tab moves focus to the OK button at the bottom of the dialog.

Accessing Charts Without a Mouse

For general information about navigating through Crystal Ball without a mouse, see Using the Tab and Arrow Keys in the Crystal Ball User Interface. The information given there about the Tab key and tab order applies to controls in Crystal Ball charts. However, additional rules apply for accessing data tables, such as statistics and percentiles, for navigating through multiple views in the same window—for example, in Split View, and for navigating through multiple charts.

Tabbing Through Data Tables

If you use the Tab key to select a data view in a chart, a cell is selected. Each time you press Tab, the next cell in that row is selected. At the end of the row, the first cell in the next row is selected. At the end of the table, the next Tab advances to an additional view or the next control.

Note:

When you use Tab to access a data table, the first cell in the table is not always selected. If you leave the table after only a few Tab key uses, press Shift+Tab several times to return to the table and test whether additional data is available.

Tabbing Through Multiple Views

If a chart displays multiple views, the default tab order changes. Initially, the first label or control at the top is selected and then the second until all labels and controls above the chart have been selected. The next time you use the Tab key, the first chart view is selected (if present), then the next chart view, and so on until all chart views have been selected. Then, the first data table is selected (if present). After navigation through all data tables, the first label or control below the chart views is selected (if present) and navigation proceeds as usual.

Except for scatter charts, you can use Ctrl+(view number) to select a chart view without tabbing. For example, suppose a chart in Split View contains a column with two chart views and a second column with two data tables. Considering tab order, the first chart view is 1, the second chart view is 2, the first data table is 3, and the second data table is 4. Then, Ctrl+2 selects the second chart view and Ctrl+3 selects the first data table. Once a data table is selected, Tab moves through rows of data as usual.

Tabbing Through Multiple Charts

If several charts are open but none are in Split View, you can use Ctrl+(chart number) to cycle through the charts. Ctrl+1 selects the first chart, Ctrl+2 selects the second, and so on.

Note:

Once a chart is selected, you can use the View menu commands (Alt+command keyboard equivalent) or the keyboard equivalents listed in Table 10, Crystal Ball General Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel to cycle through available chart views.

Tabbing Through the Crystal Ball Control Panel

You can use the Tab key to access labels and controls in the Crystal Ball Control Panel. When you select the More button and press Enter, an expanded view with simulation statistics becomes accessible. They show how fast the simulation ran and how many assumptions, decision variables, and forecasts were included in it.

In expanded view, press Ctrl+s to access the table of simulation statistics. Then, you can use Tab and Shift+Tab to move through the labels and values presented there.

User Interface Issues—Large Fonts and Screen Flicker

Some issues concerning the onscreen appearance of Crystal Ball:

  • If the Large Fonts setting is used in Microsoft Windows, screen resolution must be set higher than 1024x768 pixels.

  • Excessive screen flickering can result when Crystal Ball users resize assumption and forecast charts. To reduce flickering below the limits required by accessibility standards, open Windows Control Panel and make the following setting: Select Display, then Appearance, then Effects, and then clear the checkbox for Show window contents while dragging.

    Note:

    You need to shut down and restart Crystal Ball and Microsoft Excel to ensure that this setting is activated.

This section describes how to perform tasks in Crystal Ball without using the mouse.

Crystal Ball Keyboard Equivalents in Microsoft Excel 2003

The following tables describe Alt+key combinations in Microsoft Excel 2003 that enable you to activate Crystal Ball’s Define, Run, Analyze, and Help menu commands and chart window commands without using the mouse. For keyboard equivalents in Microsoft Excel 2007 or later, see Crystal Ball Keyboard Equivalents in Microsoft Excel 2007 or Later. For commands and keyboard equivalents used by Crystal Ball products in all supported versions of Microsoft Excel, see Crystal Ball Commands and Keyboard Equivalents in All Supported Versions of Microsoft Excel.

Note:

Oracle tries to avoid keyboard equivalent conflicts; if a key combination is the same as one on a Microsoft Excel menu, you can use the down arrow key to access the command you want. Commands are listed in the same order in which they are displayed in menus.

Keyboard equivalent tables for Microsoft Excel 2003:

Table 1. Crystal Ball Define Menu Keyboard Equivalents, Microsoft Excel 2003

Keys

Action

Alt+n, a

Define Assumption; opens the Define Assumption dialog to define a Crystal Ball assumption cell

Alt+n, d

Define Decision; opens the Define Decision Variable dialog to define a Crystal Ball decision variable cell

Alt+n, f

Define Forecast; opens the Define Forecast dialog to define a Crystal Ball forecast cell

Alt+n, m

Select All Assumptions; selects all assumption cells on the active worksheet

Alt+n, i

Select All Decisions; selects all decision variable cells on the active worksheet

Alt+n, r

Select All Forecasts; selects all forecast cells on the active worksheet

Alt+n, s

Select; selects specified Crystal Ball data cells

Alt+n, z

Freeze; excludes specified Crystal Ball data cells from a simulation

Alt+n, c

Copy Data; copies Crystal Ball cell definitions to specified cells

Alt+n, p

Paste Data; pastes copied Crystal Ball cell definitions into specified cells

Alt+n, e

Clear Data; removes Crystal Ball cell definitions from specified cells

Alt+n, l

Cell Preferences; opens the Cell Preferences dialog

Table 2. Crystal Ball Run Menu Keyboard Equivalents, Microsoft Excel 2003

Keys

Action

Alt+r, s

Start Simulation; begins running a Crystal Ball simulation

Alt+r, c

Continue Simulation; resumes a stopped simulation

Alt+r, r

Reset Simulation; clears generated simulation data (Crystal Ball data cells remain defined)

Alt+r, s

Stop Simulation; stops a running simulation

Alt+r, i

Single Step; steps through a simulation one trial at a time

Alt+r, o

OptQuest; starts OptQuest for results optimization (if available)

Alt+r, p

Predictor; starts Predictor for time series analysis

Alt+r, t

More Tools; offers the Crystal Ball general and integration tools for additional analysis and charting

Alt+r, t, f

Batch Fit tool; automatically fits selected continuous probability distributions to multiple data series

Alt+r, t, b

Bootstrap tool; addresses the reliability and accuracy of forecast statistics

Alt+r, t, c

Correlation Matrix tool; rapidly defines and automates correlations of assumptions

Alt+r, t, y

Data Analysis tool; loads data from spreadsheets directly into Crystal Ball forecast charts

Alt+r, t, d

Decision Table tool; evaluates the effects of alternate decisions in a simulation model

Alt+r, t, s

Scenario Analysis tool; displays the inputs that created particular outputs

Alt+r, t, t

Tornado Chart tool; individually analyzes the impact of each model variable on a target outcome

Alt+r, t, 2

2D Simulation tool; independently addresses uncertainty and variability using a two-dimensional simulation

Alt+r, t, m

Enterprise Performance Management tool; if available, enables Crystal Ball to run simulations on Enterprise Performance Management data using Smart View

Alt+r, t, e

Strategic Finance tool; if available, opens the Strategic Finance Setup wizard for setting up a workbook that enables Crystal Ball to run with Strategic Finance data

Alt+r, t, r

Compare Run Modes tool; compares simulation run time in Normal and Extreme speed (if available)

Alt+r, v

Save Results; saves current simulation results for later display and analysis

Alt+r, e

Restore Results; restores saved results files for display and analysis

Alt+r, u

Run Preferences; opens the Run Preferences dialog for setting trials, sampling, and other run preferences

Table 3. Crystal Ball Analyze Menu Keyboard Equivalents, Microsoft Excel 2003

Keys

Action

Alt+a, a

Assumption Charts; opens the Assumption Charts dialog so you can display or manage assumption charts

Alt+a, f

Forecast Charts; opens the Forecast Charts dialog so you can display or manage forecast charts

Alt+a, o

Overlay Charts; opens the Overlay Charts dialog so you can display existing or create new overlay charts

Alt+a, t

Trend Charts; opens the Trend Charts dialog so you can display existing or create new trend charts

Alt+a, s

Sensitivity Charts; opens the Sensitivity Charts dialog so you can display existing or create new sensitivity charts

Alt+a, s

Scatter Charts; opens the Scatter Charts dialog so you can display existing or create new scatter charts

Alt+a, q

OptQuest Charts; if OptQuest is available, displays OptQuest charts following an optimization

Alt+a, p

Predictor Charts; if Predictor is available, displays Predictor charts following a time series forecast

Alt+a, n

Open Selected Cells; opens associated charts for selected cells

Alt+a, c

Cascade; arranges open charts for easier viewing

Alt+a, l

Close All; closes all open charts

Alt+a, r

Create Report; opens the Create Report dialog so you can create a report with data and charts for the simulation and results

Alt+a, d

Extract Data; copies selected simulation data to a worksheet for additional analysis

Table 4. Crystal Ball Help Menu Keyboard Equivalents, Microsoft Excel 2003

Keys

Action

Alt+h, b, t

Technical Support; displays the main Crystal Ball Web page with a link to Crystal Ball technical support

Alt+h, b, h

Crystal Ball Help; displays online help for Crystal Ball

Alt+h, b, c

Crystal Ball Documentation; displays a list of available online documentation for Crystal Ball

Alt+h, b, d

Oracle EPM Documentation; displays the OTN index for Oracle Enterprise Performance Management documentation, including Crystal Ball

Alt+h, b, e

Examples Guide; displays a list of available example models so you can load the choice into Crystal Ball

Alt+h, b, w

Welcome Screen; displays a Welcome screen that enables you to automatically activate the process capability features for quality programs such as Six Sigma or set percentile preferences frequently used in the oil and gas industry

Alt+h, b, l

Licensing; displays the Activate a License dialog so you can enter a serial number and activate a Crystal Ball license

Alt+h, b, b

About Crystal Ball; offers version and other information about the current Crystal Ball release including the user name

Crystal Ball Keyboard Equivalents in Microsoft Excel 2007 or Later

The following tables list Alt+key combinations in Microsoft Excel 2007 or later so you can use the Define, Run, Analyze, and Help commands in the Crystal Ball ribbon without using the mouse:

For keyboard equivalents in Microsoft Excel 2003, see Crystal Ball Keyboard Equivalents in Microsoft Excel 2003. For additional commands and keyboard equivalents available in all currently-supported versions of Microsoft Excel, see Crystal Ball Commands and Keyboard Equivalents in All Supported Versions of Microsoft Excel.

Note:

Oracle tries to avoid keyboard equivalent conflicts; if a key combination is the same as one on a Microsoft Excel menu, you can use the down arrow key to access the command you want.

Table 5. Keyboard Equivalents for Crystal Ball Define Commands, Microsoft Excel 2007 or Later

Keys

Action

Alt+c, a

Define Assumption; opens the Define Assumption dialog to define a Crystal Ball assumption cell

Alt+c, d

Define Decision; opens the Define Decision Variable dialog to define a Crystal Ball decision variable cell

Alt+c, f

Define Forecast; opens the Define Forecast dialog to define a Crystal Ball forecast cell

Alt+c, c

Copy; copies Crystal Ball cell definitions to specified cells

Alt+c, p

Paste; pastes copied Crystal Ball cell definitions into specified cells

Alt+c, e

Clear; removes Crystal Ball cell definitions from specified cells

Alt+c, l

Select; offers the Select menu, to select assumption, decision variable, and forecast cells

Alt+c, l, a

Select All Assumptions; selects all assumption cells on the active worksheet

Alt+c, l, d

Select All Decisions; selects all decision variable cells on the active worksheet

Alt+c, l, f

Select All Forecasts; selects all forecast cells on the active worksheet

Alt+c, l, s

Select Some; selects specified Crystal Ball data cells

Alt+c, g

Freeze; excludes specified Crystal Ball data cells from a simulation

Alt+c, y

Cell Prefs; opens the Cell Preferences dialog to change the appearance and other properties of Crystal Ball data cells

Table 6. Keyboard Equivalents for Crystal Ball Run Commands, Microsoft Excel 2007 or Later

Keys

Action

Alt+c, s

Start; begins running a Crystal Ball simulation and resumes a stopped simulation.

Alt+c, o

Stop; stops a simulation

Alt+c, r

Reset; clears generated simulation data (Crystal Ball data cells remain defined)

Alt+c, i

Step; steps through a simulation one trial at a time

Alt+c, j

Trials; sets the number of trials for a Crystal Ball simulation; edits the Trials setting in the Run Preferences dialog

Alt+c, w, v

Save Results; saves current simulation results for later display and analysis

Alt+c, w, e

Restore Results; restores saved results files for display and analysis

Alt+c, u

Run Preferences; opens the Run Preferences dialog for setting trials, sampling, and other run preferences

Table 7. Keyboard Equivalents for Crystal Ball Analyze Commands, Microsoft Excel 2007 or Later

Keys

Action

Alt+c, v

View Charts; offers a gallery of charts and chart window management commands; use the Down arrow to select a specific chart

Alt+c, v

Assumption Charts; opens the Assumption Charts dialog so you can display or manage assumption charts

Alt+c, v

Forecast Charts; opens the Forecast Charts dialog so you can display or manage forecast charts

Alt+c, v

Sensitivity Charts; opens the Sensitivity Charts dialog so you can display existing or create new sensitivity charts

Alt+c, v

Overlay Charts; opens the Overlay Charts dialog so you can display existing or create new overlay charts

Alt+c, v

Trend Charts; opens the Trend Charts dialog so you can display existing or create new trend charts

Alt+c, v

Scatter Charts; opens the Scatter Charts dialog so you can display or manage scatter charts

Alt+c, v

OptQuest Charts; if OptQuest is available, opens OptQuest charts following an optimization

Alt+c, v

Predictor Charts; opens Predictor charts following a time series forecast

Alt+c, v, n

Open Selected Cells; opens associated charts for selected cells

Alt+c, v, c

Cascade; arranges open charts for easier viewing

Alt+c, v, l

Close All; closes all open charts

Alt+c, m

Create Report; enables you to create a report of simulation results by choosing from a gallery of predefined and custom report types

Alt+c, m, a

Assumptions Report; creates a report of only assumption results

Alt+c, m, d

Decision Variables Report; creates a report of only decision variable results

Alt+c, m, f

Forecasts Report; creates a report of only forecast results

Alt+c, m, r

Full Report; creates a report of all simulation results

Alt+c, m, i

Index Report; creates a report of only Crystal Ball data cell names and locations

Alt+c, m, o

OptQuest Report; if OptQuest is available, creates a report of selected OptQuest results following an optimization

Alt+c, m

Predictor Report; creates a report of selected Predictor results following a time series forecast

Alt+c, m, c

Custom Report; creates a report with only selected simulation results

Alt+c, m, p

Report Preferences; sets various report options

Alt+c, x

Extract Data; copies selected simulation data to a worksheet for additional analysis

Table 8. Keyboard Equivalents for Crystal Ball Tools Commands, Microsoft Excel 2007 or Later

Keys

Action

Alt+c, q

OptQuest; starts OptQuest for results optimization

Alt+c, t, p

Predictor; starts Predictor for time series analysis

Alt+c, t

More Tools; offers the Crystal Ball general tools and integration tools for additional analysis and charting

Alt+c, t, f

Batch Fit tool; automatically fits selected continuous probability distributions to multiple data series

Alt+c, t, b

Bootstrap tool; addresses the reliability and accuracy of forecast statistics

Alt+c, t, c

Correlation Matrix tool; rapidly defines and automates correlations of assumptions

Alt+c, t, a

Data Analysis tool; imports data directly from spreadsheets into Crystal Ball forecasts for further analysis

Alt+c, t, d

Decision Table tool; evaluates the effects of alternate decisions in a simulation model

Alt+c, t, s

Scenario Analysis tool; displays what inputs created particular outputs

Alt+c, t, t

Tornado Chart tool; individually analyzes the impact of each model variable on a target outcome

Alt+c, t, 2

2D Simulation tool; independently addresses uncertainty and variability using a two-dimensional simulation

Alt+c, t, m

If available, enables Crystal Ball to run simulations on Enterprise Performance Management data using Smart View

Alt+c, t, e

Strategic Finance Setup tool; if available, opens the Strategic Finance Setup wizard for setting up a workbook that allows Crystal Ball to run with Strategic Finance data

Alt+c, t, r

Compare Run Modes tool; Compares simulation run time in Normal and Extreme speed (if available)

Table 9. Keyboard Equivalents for Crystal Ball Help Commands, Microsoft Excel 2007 or Later

Keys

Action

Alt+c, h

Help; displays online help for Crystal Ball

Alt+c, n

Resources; displays menus for Crystal Ball technical support, Oracle OTN for downloads, Crystal Ball and EPM documentation, examples, the Welcome screen, and the licensing dialog

Alt+c, n, t

Technical Support; opens the Crystal Ball Web page with a link to technical support

Alt+c, n, c

Crystal Ball Documentation; displays a list of available online documentation for Crystal Ball

Alt+c, n, d

Oracle EPM Documentation; displays the OTN index for Oracle Enterprise Performance Management documentation, including Crystal Ball

Alt+c, n, e

Examples Guide; displays a list of available example models so you can load the choice into Crystal Ball

Alt+c, n, w

Welcome Screen; displays a Welcome Screen that enables you to automatically activate the process capability features for quality programs such as Six Sigma or set percentile preferences frequently used in the Oil and Gas industry.

Alt+c, n, l

Licensing; displays the Activate a License dialog for entering a Crystal Ball serial number and activating a license

Alt+c, b

About [Crystal Ball]; offers version and other information about the current Crystal Ball release including the username

Crystal Ball Commands and Keyboard Equivalents in All Supported Versions of Microsoft Excel

The tables in this topic list keyboard equivalents that apply to Crystal Ball products used in all supported versions of Microsoft Excel. For keyboard equivalents used only in Microsoft Excel 2003, see Crystal Ball Keyboard Equivalents in Microsoft Excel 2003. For keyboard equivalents used only in Microsoft Excel 2007 or later, see Crystal Ball Keyboard Equivalents in Microsoft Excel 2007 or Later.

Distribution Gallery Menus and Keyboard Equivalents

Note:

In Microsoft Excel 2007 or later, if you click the upper half of the Define Assumption icon, or if the assumption has already been defined, the Distribution Gallery opens. If you click the lower half of the icon, a list of All, Basic, or Favorite distributions opens, depending on the active category in the Distribution Gallery.

Distribution Gallery Menus

The Distribution Gallery has the following menus:

  • Edit menu — enables you to copy, paste, modify, and delete, and print distributions.

  • View menu — determines how distributions are displayed in the Distribution Gallery and shows or hides the Description pane.

  • Categories menu — enables you to create, modify, delete, reorder, and share distribution categories.

  • Help menu — displays help for the Distribution Gallery or the active distribution.

Distribution Gallery Keyboard Equivalents

You can use the keyboard to select distributions in the Distribution Gallery.

  To do this:

  1. Select Define, then Define Assumption or click the Define Assumption button to open the Distribution Gallery. Define Assumption button

  2. Type the first letter of the name of the target distribution, for example n for normal.

    If more than one distribution starts with that letter, keep pressing to cycle through the distributions.

  3. When the target distribution is highlighted, type Alt+o (for OK) to open its Define Assumption dialog.

    Or, you can press Alt+f to fit a distribution to it or Alt+c to cancel the selection and close the dialog.

  To select the description pane of the Distribution Gallery, press Ctrl+d.

  To apply a keyboard equivalent to a custom category:

  1. Open the Crystal Ball Distribution Gallery.

  2. Edit the category name:

    For a new category, select Categories, then New. In the Name text box, enter an ampersand (&) before a letter in the category name. That letter becomes the keyboard equivalent. Click OK to save.

    For an existing category, select Categories, then Properties, add the ampersand to the existing name, and click OK to save.

    Each category should use a unique keyboard equivalent. The keyboard equivalents for the default categories are: Alt+b for the Basic category, Alt+a for All, and Alt+i for Favorites.

The tables in this topic show keyboard equivalents that are used in most charts, keys used for chart preferences, and chart-specific keys for all supported versions of Microsoft Excel.

General Chart Keyboard Equivalents

Table 10 lists menu commands and keyboard equivalents that apply to most if not all Crystal Ball charts accessible through the Analyze menu or group. For chart preferences keys, see Chart Preference Keyboard Equivalents. For keys used in specific charts, see Chart-specific Keyboard Equivalents.

Table 10. Crystal Ball General Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Command Action

Alt+Tab, then Oracle Crystal Ball

Bring Crystal Ball to front; a Microsoft Windows shortcut for switching between applications

Alt+e, c

Edit, then Copy Chart; copies the active Oracle Crystal Ball chart to the clipboard

Alt+e, u

Edit, then Page Setup; defines margins, paper size, orientation, and other layout information for printing

Alt+e, v

Edit, then Print Preview; displays the active chart as it will print with the current Page Setup settings

Alt+e, p

Edit, then Print; prints the current chart to the specified printer or file

Alt+v, f

View, then Frequency; sets the current chart to show the number or frequency of values occurring in a given interval (bin)

Alt+v, c

View, then Cumulative [Frequency]; sets the current chart to show the number or proportion (percentage) of values less than or equal to a given amount

Alt+v, r

View, then Reverse Cumulative [Frequency]; sets the current chart to show the number or proportion (percentage) of values greater than or equal to a given amount

Alt+v, s

View, then Statistics; sets the current chart to show a set of descriptive statistics for charted values

Alt+v, p

View, then Percentiles; sets the current chart to show percentile information, in 10% increments

Alt+v, g

View, then Goodness Of Fit; if available, sets the current chart to show goodness-of-fit statistics for all fitted distributions

Alt+v, a

View, then Capability Metrics; if available, sets the current forecast chart to show a set of process capability metrics based on the specification limit(s) set for that forecast

Alt+v, l

View, then Split View; sets the current chart to show data, such as statistics, beside the associated chart

Alt+p, c

Preferences, then Chart Preferences; opens the Chart Preferences dialog for changing chart appearance settings

Chart Preference Keyboard Equivalents

Double-clicking in a chart area opens the Chart Preferences dialog.

Table 11, Keyboard Equivalents for Chart Preferences, All Supported Versions of Microsoft Excel lists key combinations that can be used to cycle through settings available in the Chart Preferences dialog. Most of these commands work on the primary distribution — the theoretical probability distribution for assumptions, and the generated values for forecasts and overlay charts. For general keys used in most charts, see General Chart Keyboard Equivalents. For keys used in specific charts, see Chart-specific Keyboard Equivalents.

Table 11. Keyboard Equivalents for Chart Preferences, All Supported Versions of Microsoft Excel

Keys

Action

Ctrl+d

View menu, Preferences, then chartname, then chartname Window, and then View; cycles through chart views — Frequency, Cumulative Frequency, Reverse Cumulative Frequency (for assumption and forecast charts)

Ctrl+b; Ctrl+g

Preferences, then Chart, then General, and then Density; cycles through bins or group interval values to adjust the number of data bins used to create the chart

Ctrl+l

Preferences, then Chart, then General, and then Gridlines; cycles through gridline settings: None, Horizontal, Vertical, Both

Ctrl+t

Preferences, then Chart, then Chart Type, and then Type; cycles through chart types: Area, Line, Column; for sensitivity charts: Bar (direction), Bar (magnitude), Pie (in Contribution To Variance view)

Ctrl+w

Preferences, then Chart, then General, and then 3D Chart; cycles between two-dimensional and three-dimensional chart display

Ctrl+m

Preferences, then Chart, then Chart Type, and then Marker Lines; cycles through central tendency marker lines: None, Mean, Median, Mode (except for sensitivity and trend charts)

Ctrl+n

Preferences, then Chart, then General, and then Legend; toggles the legend display on and off

Ctrl+p

Preferences, then Chart, then Chart Type, then Marker Lines, and then Percentiles; cycles through percentile markers: None, 10%, 20%,…90%

Ctrl+Spacebar

View menu; Preferences, then chartname, then chartname Window, and then View; cycles through window views when Microsoft Excel is not in Edit mode: Chart, Statistics, Percentiles, Goodness Of Fit (if distribution fitting is selected — except for trend charts), and Capability Metrics (if process capability features are activated)

Chart-specific Keyboard Equivalents

The following tables list keyboard equivalents for specific charts. For general keys used in most charts, see General Chart Keyboard Equivalents. For chart preferences keys, see Chart Preference Keyboard Equivalents.

Tables:

Table 12. Assumption-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+e, a

Edit, and then Add To Gallery; adds the active assumption to the Distribution Gallery in the specified category

Alt+m, c

Parameters, and then Show Cell References; shows cell references instead of values when cell references are entered into parameter text boxes

Alt+p, a

Preferences, and then Assumption; opens the Assumption Preferences dialog for choosing a view and controlling chart display

Alt+h, a

Help, and then Assumption Help; displays online help about assumptions

Table 13. Forecast-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+f, s

Forecast, and then Open Sensitivity Chart; creates or displays a sensitivity chart for the active forecast

Alt+f, f

Forecast, and then Fit Probability Distribution; uses the default or currently selected distributions and ranking method to fit a distribution to the active forecast chart

Alt+p, f

Preferences, and then Forecast; opens the Forecast Preferences dialog for controlling chart display, distribution fitting specifications, and more

Alt+h, f

Help, and then Forecast Help; displays online help about the forecast chart

Table 14. Overlay-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+o, c

Overlay, and then Choose Forecasts; displays the Choose Forecasts dialog to add or remove forecasts from the active overlay chart

Alt+o, r

Overlay, and then Remove All, removes all forecasts from the active overlay chart

Alt+o, f

Overlay, and then Fit Probability Distribution; uses the default or currently selected distributions and ranking method to fit a distribution to all forecasts on the active overlay chart

Alt+p, o

Preferences, and then Overlay; opens the Overlay Preferences dialog for controlling chart display and distribution fitting specifications

Alt+h, o

Help, and then Overlay Help; displays online help about the overlay chart

Table 15. Sensitivity-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+v, c

View, and then Contribution To Variance Chart; displays the sensitivity chart in terms of percentage of variance contributed by each assumption

Alt+v, r

View, and then Rank Correlation Chart; displays the sensitivity chart in terms of rank correlation of the assumptions in their effect on the forecast

Alt+v, s

View, and then Sensitivity Data; displays contribution to variance and rank correlation sensitivity measures for each assumption

Alt+s, t

Sensitivity, and then Choose Target Forecast; opens the Choose Forecast dialog so you can select a forecast for sensitivity analysis

Alt+s, a

Sensitivity, and then All Assumptions; uses all assumptions in creating the sensitivity chart

Alt+s, c

Sensitivity, and then Choose Assumptions; displays the Choose Assumptions dialog so you can select one or more assumptions for the sensitivity chart

Alt+s, g

Sensitivity, and then Group Assumptions; displays the Group Assumptions dialog so you can create and modify groups of assumptions for the sensitivity chart

Alt+s, s

Sensitivity, and then Open Scatter Chart; opens a scatter chart using the current target forecast and assumptions

Alt+p, s

Preferences, and then Sensitivity; opens the Sensitivity Preferences dialog for choosing a view, controlling chart display, and more

Alt+h, s

Help, and then Sensitivity Help; displays online help about the sensitivity chart

Table 16. Trend-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+v, m

View, and then Centered On Median; displays certainty bands centered on the median of each forecast value

Alt+v, c

View, and then Cumulative; displays certainty bands anchored at the lower end of the forecast range; shows the certainty that the forecast values will be at or below a given value

Alt+v, r

View, and then Reverse Cumulative; displays certainty bands anchored at the higher end of the forecast range; shows the certainty that the forecast values will be at or above a given value

Alt+t, f

Trend, and then Choose Forecasts; opens the Choose Forecasts dialog so you can select forecasts to use in the trend chart

Alt+t, r

Trend, and then Remove All; removes all forecasts from the active trend chart

Alt+p, t

Preferences, and then Trend; opens the Trend Preferences dialog for choosing a view and controlling chart display

Alt+h, t

Help, and then Trend Help; displays online help about the trend chart

Table 17. Scatter-specific Chart Menu Keyboard Equivalents, All Supported Versions of Microsoft Excel

Keys

Action

Alt+v, s

View, and then Scatter View (1xN); plots selected assumptions and/or forecasts against a target assumption or forecast

Alt+v, m

View, and then Matrix View (NxN); plots selected assumptions and/or forecasts against each other

Alt+s, d

Scatter, and then Choose Data; opens the Choose Data dialog so you can select assumptions and forecasts to use in the scatter chart

Alt+s, r

Scatter, and then Remove All; removes all assumptions and forecasts from the active scatter chart

Alt+p, s

Preferences, and then Scatter; opens the Scatter Preferences dialog for choosing a view and controlling chart display

Alt+h, t

Help, and then Scatter Help; displays online help about the scatter chart

Keys for Controls Without Labels or Alt Activations

Table 18 lists keyboard equivalents for controls that either have no labels or do not have a keyboard equivalent that is highlighted when you press Alt.

Table 18. Keyboard Equivalents for Controls without Labels or Alt Key Activation, All Supported Versions of Microsoft Excel

KeysAction
Ctrl+Plus keyEquivalent to pressing the More button in the Define Assumption or Define Forecast dialog; displays all settings in the dialog, basic and advanced (or preferences)
Ctrl+Minus key (hyphen or dash)Equivalent to pressing the Less button in the Define Assumption or Define Forecast dialog; hides advanced settings (or preferences) while displaying the basic settings
Alt+[Minimum truncation grabber (text box), Define Assumption dialog; truncates the distribution at the low end of the value range and sets the value in the Minimum text box
Alt+]Maximum truncation grabber (text box), Define Assumption dialog; truncates the distribution at the high end of the value range and sets the value in the Maximum text box
Ctrl+Up arrow, Ctrl+Down arrowSeries list box in charts and other similar list boxes; moves up and down through the list box so a series can be selected from the list
Ctrl+nMethods panel, Predictor wizard; selects or clears the Non-seasonal Methods group
Ctrl+sMethods panel, Predictor wizard; selects or clears the Seasonal Methods group
Ctrl+aMethods panel, Predictor wizard; selects or clears the ARIMA group
Ctrl+mMethods panel, Predictor wizard; selects or clears the Multiple Linear Regression group
Ctrl+pPredictor Results window charts; shows and hides confidence interval lines
Ctrl+w, Ctrl+Shift+wWarning footnotes in the Predictor Data Screening and Results windows; enables screen readers to read warning footnotes if present
Ctrl+zZoom control in Predictor charts; activates and inactivates the zoom control for enlarging and reducing Predictor chart display