Oracle® Essbase Studio

Accessibility Guide

Release 11.1.2.2


Copyright © 2012, Oracle and/or its affiliates. All rights reserved.

Authors: EPM Information Development Team

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS:

Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle America, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.


Table of Contents:

Introduction

Enabling Accessibility for Essbase Studio

Essbase Studio Keyboard Shortcuts

Introduction

This guide describes the accessibility features of Oracle Essbase Studio. This guide is accessible in HTML format.

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/pls/topic/lookup?ctx=acc&id=info or visit http://www.oracle.com/pls/topic/lookup?ctx=ac&id=trs if you are hearing impaired.

For information about Oracle's commitment to accessibility, visit the Oracle Accessibility Program website at http://www.oracle.com/pls/topic/lookup?ctx=acc&id=docacc.

Enabling Accessibility for Essbase Studio

Essbase Studio has accessibility features built into it. These features focus on keyboard shortcuts to some mouse actions. These features are always available, there is nothing to enable or disable in Essbase Studio for the keyboard shortcuts to work.

Keyboard shortcuts common to Microsoft Windows, such as Ctrl+S for Save, are not documented.

Oracle has certified this release of Essbase Studio on the following platform combinations:

Table 1. Supported Combinations of Screen Readers and Web Browsers

Screen Reader

Web Browser

JAWS 12

Internet Explorer 9

JAWS 12

Internet Explorer 8

Note:

If you are using JAWS® Screen Reading Software, Oracle recommends using the Microsoft Internet Explorer browser.

Essbase Studio Keyboard Shortcuts

The section contains the following topics:

Keyboard Shortcuts for Access and Navigation

The tables in this section describe keyboard equivalents that assist with accessing Essbase Studio Console elements and navigating through the interface:

Table 2. Accessing Main Areas (or View Tabs) of the Essbase Studio Interface

Keys

Action

F10

Note:

Press Esc to remove focus from the menu bar.

Access to the Essbase Studio menu bar.

Ctrl+5

Or:

Alt+V, then N

Or:

Press and hold down Ctrl, press F7, use up and down arrow keys to select Metadata Navigator, and then press Enter

Focus on Metadata Navigator.

Ctrl+3

Or:

Alt+V, then A

Or:

Press and hold down Ctrl, press F7, use up and down arrow keys to select Data Sources, and then press Enter

Focus on Data Source Navigator.

Ctrl+2

Or:

Alt+V, then C

Or:

Press and hold down Ctrl, press F7, use up and down arrow keys to select Console Messages, and then press Enter

Focus on Console Messages tab.

Shift+F10

Display the context menu appropriate to the focus of the cursor.

Esc

Close, without saving, an open dialog box or wizard.

Shift-Tab until focus in on the actual tab title.

  • Shift-Tab twice for Metadata Navigator, Data Sources, and Minischemas tabs

  • Shift-Tab once for Search and Console Messages tabs

Then, Alt+- (hyphen), use down arrow to select Close (or press C)

Close a view tab

Table 3. Accessing Elements in the Metadata Navigator and Data Source Navigator

Keys

Action

Ctrl+5 or Ctrl+3, then use up and down arrow keys

Navigate through tree structure.

Right arrow key

Open a folder.

Use the up and down arrow keys to navigate to the Root folder, Shift+F10, then E

Expand all folders in the Metadata Navigator.

Left arrow key

Close a folder.

Use the up and down arrow keys to navigate to the Root folder, Shift+F10, then C

Collapse all folders in the Metadata Navigator.

Use the up and down arrow keys to navigate to a folder, Shift+F10, then H

Refresh the contents of a folder.

Use the up and down arrow keys to navigate to the Root folder, Shift+F10, then H

Refresh all folders in the Metadata Navigator.

Shift+F10

Context menu for tree items.

Use arrow keys to navigate to element location in tree, press Enter

Launch the wizard, editor, or properties dialog box for the selected metadata element.

Alt+E, then S

Open the Search tab in the Metadata Navigator.

Alt+E, then F

Open the Find dialog box.

Ctrl+3, use arrow keys to navigate to the element, Shift+F10, then E

Launch the editor or Properties dialog box for the selected source element in the Data Source Navigator (applies to data source connection names, Oracle Essbase connection names, and minischemas).

Ctrl+3, use arrow keys to navigate to the element, Shift+F10, then O

Launch the Properties dialog box for the selected source element (applies to source table names, column names, and minischemas).

Ctrl+5, use arrow keys to navigate to the metadata element, Shift+F10, then V

Launch sample data for the selected metadata element in the Metadata Navigator.

Ctrl+3, use arrow keys to navigate to the column element , Shift+F10, then V

Launch sample data for the selected source column element in the Data Source Navigator.

Ctrl+5, use arrow keys to navigate to the element, Shift+F10, then L

Launch the lineage editor in the context of the selected metadata element in the Metadata Navigator.

Ctrl+5, use arrow keys to navigate in the Metadata Navigator, select an Essbase model, then press Enter

Launch the graphical view of the Essbase model in the work area.

Ctrl+5, use arrow keys to navigate in the Metadata Navigator, select an Essbase model, Shift+F10, then B

Launch the Essbase Model Properties dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then L

Launch the Text List dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then A

Note:

The Alias Set Manager is no longer part of Essbase Studio. This command now launches the Alias Sets dialog box.

Launch the Alias Sets dialog box.

Ctrl+5, use arrow keys to navigate in the Metadata Navigator, select an Essbase model, then:

Shift+F10, then W

Or

Alt+F, then W

Launch the Cube Deployment Wizard.

Ctrl+5, use arrow keys to navigate to a element in the Metadata Navigator, select an Essbase model, Shift+F10, then Y for Show Deployment History

Launch the deployment history in the work area.

Ctrl+3, use arrow keys to navigate to a data source connection, Shift+F10, then U

Launch the Incremental Update dialog box.

Ctrl+3, use arrow keys to navigate to a data source connection, Shift+F10, then I

Launch the Introspection Wizard.

Ctrl+3, use arrow keys to navigate to a Microsoft SQL Server data source connection, Shift+F10, then Y

Microsoft SQL Server users only: Toggle the Show Friendly Names option

Table 4. Right-Click Commands Common to Most Elements in the Metadata Navigator

Keys

Action

Shift+F10, then E

Edit an element.

Shift+F10, then C

Copy an element.

Shift+F10, then P

Paste an element.

Shift+F10, then N

Rename an element.

Shift+F10, then D

Delete an element.

Shift+F10, then H

Refresh cube schema or Oracle Essbase model

Table 5. Accessing Editors, Wizards, and Dialog Boxes to Create New Elements

Keys

Action

Alt+F, followed by N, then O

Or:

Alt+F, followed by N, then Enter (the default selection is for Connection Wizard)

Launch Connection Wizard.

Alt+F, followed by N, then I

Launch Minischema Wizard.

Alt+F, followed by N, then U

Launch the User-Defined Table dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then F

Launch the Folder Properties dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then D

Launch the Dimension Element dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then T

Launch the Derived Text Measure dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then L

Launch the Text List dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then A

Launch the Alias Set dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then H

Launch the hierarchy editor.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then M

Launch the measure hierarchy editor.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then C

Launch the Calendar Hierarchy dialog box.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then S

Launch Cube Schema Wizard.

Ctrl+5, use arrow keys to navigate to appropriate location in the tree, Alt+F, followed by N, then R

Launch the drill-through report editor.

Ctrl+5, use arrow keys to navigate in the tree to select a date column, Shift+F10, then T

Launch the Create Date Elements dialog box.

Table 6. Accessing Dialog Boxes from the Menu Bar

Keys

Action

Alt+F, then O

Launch the Export dialog box.

Alt+F, then I

Launch the Import dialog box

Alt+E, then F

Open the Find dialog box.

Alt+E, then S

Open the Search tab in the Metadata Navigator.

Alt+E, then R

Open the Properties dialog box for the select metadata or source element.

Alt+E, then E

Launch the Preferences dialog box.

Alt+T, then R

Launch the Essbase Studio Login dialog box to reconnect to Essbase Studio Server.

Alt+T, then H

Launch the Rehost Essbase Connections dialog box.

Alt+T, then U

Launch the Update Cube Linkage dialog box.

Alt+T, then E

Launch the EIS Catalog Migration dialog box.

Table 7. Working with Editors in the Work Area

Keys

Action

With focus on editor title tab text, press and hold Ctrl, then F6, use up and down arrow keys to choose editor from the context menu. You must hold the Ctrl key down for the entire operation.

Move from editor to editor

Alt+-

Invoke context menu for editor

Right or left arrow keys

Within drill-through report editor, move from tab to tab

Ctrl+F4

Or

Alt+F, then C

Or

Ctrl+W

Close an editor

Alt+F, then L

Or

Ctrl+Shift+W

Close multiple editors

Table 8. Accessing Help Menu Items

Keys

Action

Alt+H, then W

Launch the Welcome page in the work area

Alt+H, then H

Or

Within dialog boxes, editors, wizards, and main console panes, press F1.

Note:

To close the online help, press Alt+F4.

Launch the Essbase Studio online help

Alt+H, then T

Launch the Oracle Technical Support Web site

Alt+H, then E

Launch the EPMOracle Enterprise Performance Management System Documentation Library on the Oracle Technology Network Web site

Alt+H, then A

Launch the Essbase Studio About box

Keyboard Shortcuts in Dialog Boxes and Editors

The tables in this section describe keyboard equivalents found in Essbase Studio Console dialog boxes and editors.

Login

Connection Wizard and Connection Editing

Minischema Wizard and Minischema Editing

Rehosting

Preferences

Metadata Elements

Cube Schema Wizard

Essbase Model Properties

Cube Deployment Wizard

Drill-through Report Editor

Cube Linkage

Essbase Studio Catalog Export/Import

EIS Catalog Migration

Find and Search

Login

Table 9. Keyboard Shortcuts for the Essbase Studio Login Dialog Box

Keys

Element Name

Alt+S

Server

Alt+U

User

Alt+P

Password

Alt+R

Remember this user

Note:

The Essbase Studio Login dialog box is also launched when users select Tools, then Reconnect To Server (Alt+T, then R).

Connection Wizard and Connection Editing

Table 10. Keyboard Shortcuts for Connection Wizard, Define Connection Page

Keys

Element Name

Alt+C

Connection name

Alt+O

Connection Description

Alt+D

Data Source Type

Alt+L

Presentation Layer (Oracle Business Intelligence Enterprise Edition sources only)

Alt+M

Business Model (Oracle BI EE sources only)

Alt+V

Essbase Server (Essbase Server connections only)

Alt+V

Server Name

Alt+E

Default (port number)

Alt+L

Cluster (Essbase Server connections only)

Alt+I

SID

Alt+R

Service Name

Tab

If Oracle RAC is the Data Source Type:

Press the Tab key to arrive at the “Add RAC server node” button

Tab

If Oracle RAC is the Data Source Type:

Press the Tab key to arrive at the “Remove RAC server node” button

Alt+X

Pool Max Size

Alt+Z

Cache Size

Alt+H

Authentication Method

Alt+U

User Name

Alt+P

Password

Alt+A

Database Name

Alt+W

Browse (for text file location)

Alt+K

Skip records (text file sources only)

Alt+R

Column names in first row (text file sources only)

Alt+M

Comma (text file sources only)

Alt+A

Tab (text file sources only)

Alt+P

Space (text file sources only)

Alt+U

Custom (text file sources only)

Alt+T

Test Connection

Table 11. Keyboard Shortcuts for Connection Wizard, Select Tables Page

Keys

Element Name

Alt+T

Filter

Alt+A

Apply

Alt+L

Lock catalog during exploration

Table 12. Keyboard Shortcuts for Connection Wizard, Model Files Page (text file data sources only)

Keys

Element Name

Alt+S

Select all

Alt+C

Clear all

Alt+T

Filter

Alt+K

Skip records

Alt+R

Column names in first row

Alt+M

Comma

Alt+A

Tab

Alt+P

Space

Alt+U

Custom

Alt+E

Edit Column Properties

Table 13. Keyboard Shortcuts for Column Properties Dialog Box (accessed from the Connection Wizard, Model Files Page)

Keys

Element Name

Alt+M

Name

Alt+D, then use the arrow keys to select an option:

  • Text

  • Integer

  • Large integer

  • Decimal

Data type

Alt+B

Back

Alt+N

Next

Table 14. Keyboard Shortcuts for Connection Wizard, Select Minischema Page

Keys

Element Name

Alt+C

Create a new schema diagram

Alt+S

Skip minischema diagram

Alt+I

Use Introspection to Detect Hierarchies

Table 15. Keyboard Shortcuts for Connection Wizard, Populate Minischema Page

Keys

Element Name

Alt+C

Connections

Alt+D

Databases

Alt+T

Filter

Alt+A

Apply

Alt+R

Add Related Objects

Table 16. Keyboard Shortcuts for Connection Wizard, Create Metadata Elements Page or Create OBIEE Dimension Elements Page

Keys

Element Name

Alt+W

Browse

Alt+C

Create cube schema and Essbase model

Note:

This option is only available when creating an Oracle Business Intelligence Enterprise Edition data source.

Table 17. Keyboard Shortcuts for Connection Wizard, Create OBIEE Cube Schema Page

Keys

Element Name

Alt+S

Cube Schema Name

Alt+C

Comment

Alt+F

Available Fact Tables

Use the arrow keys to expand folders and navigate to a column to select as a measure. Then, tab to the “Add selected measures” button, and press Enter. The column is moved to the Measures list.

Alt+M

Measures

Use the arrow keys navigate to a column to remove from the list. Then, tab to the “Remove selected measures” button, and press Enter. The column is removed from the Measures list.

Alt+D

Available Dimension Elements

Use the arrow keys navigate to a column to select as a hierarchy. Then, tab to the “Add selected hierarchies” button, and press Enter. The dimension is moved to the Hierarchies list.

Alt+H

Hierarchies

Use the arrow keys navigate to a hierarchy to remove from the list. Then, tab to the “Remove selected hierarchies” button, and press Enter. The column is removed from the Hierarchies list.

Table 18. Keyboard Shortcuts for Refresh Data Source Tables Dialog Box

Keys

Element Name

Alt+T

Changed Tables

Alt+C

Changed Columns

Alt+D

Dependent Dimension Elements and Joins

Alt+F

Save Dependencies List as File

Alt+R

Refresh

Table 19. Keyboard Shortcuts for Delete Tables (from Data Source Connection) Dialog Box

Keys

Element Name

Alt+T

Table Status (Errors and Warnings)

Alt+A

Select All Tables

Alt+E

Dependent Dimension Elements and Joins

Alt+S

Save Dependencies List as File

Alt+D

Delete

Table 20. Keyboard Shortcuts for New Joins Dialog Box

Keys

Element Name

Alt+N

New Joins

Alt+S

Select All Joins

Alt+A

Add

Minischema Wizard and Minischema Editing

Table 21. Keyboard Shortcuts for Minischema Wizard, Name and Description Page

Keys

Element Name

Alt+N

Minischema Name

Alt+D

Minischema Description

Table 22. Keyboard Shortcuts for Minischema Wizard, Add/Remove Tables Page

Keys

Element Name

Alt+C

Connections

Alt+T

Filter

Alt+A

Apply

Alt+R

Add Related Tables

Table 23. Keyboard Shortcuts for Edit Properties of Minischema Join Dialog Box

Keys

Element Name

Alt+T

Table

Alt+C

Column

Alt+O

Outer

Alt+L

Left

Alt+F

Full

Alt+R

Right

Table 24. Keyboard Shortcuts for Create Joins by Inspection Dialog Box

Keys

Element Name

Alt+T

Table name filter

Alt+C

Column name filter

Alt+S

Select all items

Table 25. Keyboard Shortcuts for User-Defined Table Definition Dialog Box

Keys

Element Name

Alt+C

Connection

Alt+T

Table name

Alt+D

Table definition

Rehosting

Table 26. Keyboard Shortcuts for Rehost Essbase Connections Dialog Box

Keys

Element Name

Alt+D

Update the host name and port number for all deployment history

Alt+R

Replicate the last successful deployment history and update the copy only

Alt+T

Test Connection

Alt+U

Update

Alt+C

Close

Preferences

Table 27. Keyboard Shortcuts for Preferences Dialog Box, General

Keys

Element Name

Alt+C

Show Confirm Delete dialog

Alt+I

Show informational messages

Alt+W

Show warning messages

Alt+E

Show error messages

Alt+D

Restore Defaults

Alt+A

Apply

Table 28. Keyboard Shortcuts for Preferences Dialog Box, Schema

Keys

Element Name

Alt+T

Column type indicator

Alt+P

Primary Key

Alt+F

Foreign Key

Alt+G

Diagonal

Alt+R

Rectangle

Alt+O

Arrow

Alt+W

Crow's Feet

Alt+D

Restore Defaults

Alt+A

Apply

Table 29. Keyboard Shortcuts for Preferences Dialog Box, Essbase Model

Keys

Element Name

Alt+M

Ask user if the model should be tuned when setting aggregate storage to true

Alt+V

Ask user to validate a changed model before closing the Properties dialog box

Table 30. Keyboard Shortcuts for Folder Properties Dialog Box

Keys

Element Name

Alt+N

Name

Alt+D

Description

Metadata Elements

Table 31. Keyboard Shortcuts for Dimension Element Properties Dialog Box

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+F

Formula

Alt+C

Caption Binding

Alt+S

Key Binding option: Same as caption

Alt+A

Key Binding option: Advanced

Alt+Y

Key Binding option: Delayed

Alt+T

Filter

Alt+O

Sort Order

Table 32. Keyboard Shortcuts for Derived Text Measure Properties Dialog Box

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+F

Formula

Alt+E

Expression

Alt+R

Note:

Use Alt+R when rows are present in the Range table. When the Range table is empty, tab to the Add another row button to begin adding rows to the table.

Range

Table 33. Keyboard Shortcuts for Text List Properties Dialog Box

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+B

Bindings

Alt+V

Value Binding

Alt+I

ID Binding

Table 34. Keyboard Shortcuts for Hierarchy and Measure Hierarchy Editor

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+T

Data

Alt+A

Add

Alt+P+C

Preview With Caption Binding (not available for measure hierarchies)

Alt+P+K

Preview With Key Binding (not available for measure hierarchies)

Alt+A

Or

Insert

Add child

Alt+S

Or

Shift+Insert

Add sibling

Alt+C

Or

Ctrl+Insert

Add user-defined child

Alt+U

Or

Ctrl+Shift+Insert

Add user-defined sibling

Table 35. Keyboard Shortcuts for Calendar Hierarchy Dialog Box

Keys

Element Name

Alt+H

Hierarchy Name

Alt+G

Gregorian

Alt+F

Fiscal

Alt+R

Retail

Alt+I

ISO

Alt+M

Manufacturing

Alt+S

Start Date

Alt+D

End Date

Alt+W

First day of week

Alt+T

Time Depth

Alt+E

Edit

Alt+A

Day Attributes

Alt+V

Edit LVA

Table 36. Keyboard Shortcuts for Day Attributes Dialog Box

Keys

Element Name

Alt+S

Sunday

Alt+M

Monday

Alt+T

Tuesday

Alt+W

Wednesday

Alt+H

Thursday

Alt+F

Friday

Alt+U

Saturday

Alt+D

Dimension Name

Alt+A

Add

Alt+R

Remove

Table 37. Keyboard Shortcuts for Edit Linked Value Attributes Dialog Box

Keys

Element Name

Alt+L, then use the Tab key to tab through the options.

Linked Value Attributes

Table 38. Keyboard Shortcuts for Edit Labeling Rules

Keys

Element Name

Alt+U

Use 2-digit time entity

Table 39. Keyboard Shortcuts for Create Date Elements Dialog Box

Keys

Element Name

Alt+Y

Year

Alt+Q

Quarter

Alt+M

Month

Alt+D

Day of week

Table 40. Keyboard Shortcuts for Alias Sets Dialog Box

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+B

Bindings

Alt+B, Shift+F10

The Bindings popup menu has these options:

  • N—Sort by dimension element name

  • P—Sort by dimension element path

  • B—Sort by bindings

  • A—Sort ascending

  • D—Sort descending

  • F—Show full path for dimension elements

Bindings popup menu

Tab

Press Tab to move to the following buttons:

  • Create a binding

  • Create bindings by inspection

  • Edit the selected binding

  • Delete the selected bindings

Table 41. Keyboard Shortcuts for the Create Bindings Dialog Box

Keys

Element Name

Alt+S

Source selection tree

Alt+X

Binding expression

Alt+B

Binding expression tree

Cube Schema Wizard

Table 42. Keyboard Shortcuts for Cube Schema Wizard, Choose Measures and Hierarchies Page

Keys

Element Name

Alt+S

Cube Schema Name

Alt+C

Comment

Alt+A

Available Dimension Elements

Alt+M

Measures/Measures Hierarchy

Alt+H

Hierarchies

Alt+P

Preview Hierarchies

Alt+P+C

This option is not available for measure hierarchies.

Preview With Caption Binding

Alt+P+K

This option is not available for measure hierarchies.

Preview With Key Binding

Table 43. Keyboard Shortcuts for Cube Schema Wizard, Cube Schema Options Page

Keys

Element Name

Alt+O

Override default data load bindings

Alt+C

Create Essbase Model

Alt+M

Model Name

Alt+D

Account Dimension

Alt+A

Model Type: Aggregate Storage

Alt+S

Model Type: Block Storage

Table 44. Keyboard Shortcuts for Default Load Binding Dialog Box

Keys

Element Name

Alt+U

Formula

Alt+E

Expression

Alt+F

Filter

Note:

To access the Default Load Binding dialog box: In the Define data load mappings page of the Cube Schema Wizard, use the up and down arrow keys to navigate to the leaf level of a hierarchy, use the right arrow key to move to the Data Load Binding column, and press Enter to activate the cell. Press Enter again to activate the ellipsis button and launch the Default Load Binding dialog box.

Essbase Model Properties

Table 45. Keyboard Shortcuts for Essbase Model Properties, General Tab

Keys

Element Name

Alt+M

Comment

Alt+L

Last deployed

Alt+A

Aggregate storage model

Alt+D

Duplicate member name support

Alt+U

Use Unicode character set

Alt+X

XOLAP Model

Alt+S, launches the Define Data Load Settings dialog box

Custom data load settings

Alt-F

Date format

Table 46. Keyboard Shortcuts for Essbase Model Properties, Alias Tab

Keys

Element Name

Alt+A

Available Tables

Alt+S

Selected Tables

Table 47. Keyboard Shortcuts for Essbase Model Properties, Attributes Tab

Keys

Element Name

Alt+V

Value

Alt+P

Prefix/Suffix

Alt+S

Separator

Alt+D

Dimension

Alt+U

Sum member

Alt+T

Count member

Alt+M

Minimum member

Alt+X

Maximum member

Alt+G

Average member

Alt+E

True members

Alt+A

Dates are

Alt+F

False members

Alt+R

Numerics are

Table 48. Keyboard Shortcuts for Essbase Model Dimension Properties, General Tab

Keys

Element Name

Alt+N

Name in Cube

Alt+M

Comment

Alt+E

Edit Named Generations and Levels

Table 49. Keyboard Shortcuts for Essbase Model Dimension Properties, Edit Named Generational and Levels Dialog Box

Keys

Element Name

Alt+G

Named Generations

Alt+L

Named Levels

Table 50. Keyboard Shortcuts for Essbase Model Dimension Properties, Info Tab

Keys

Element Name

Alt+T

Dimension Type

Alt+Y

Dynamic series

Alt+D

Dimension Storage

Alt+P

Two Pass Calculation

Alt+S

Data Storage

Alt+V

Dimension Solve Order

Alt+M

Member Solve Order

Table 51. Keyboard Shortcuts for Essbase Model Dimension Properties, Account Info Tab

Keys

Element Name

Alt+T

Time Balance

Alt+S

Skip

Alt+V

Variance Reporting

Table 52. Keyboard Shortcuts for Essbase Model Dimension Properties, Formula Tab

Keys

Element Name

Alt+F

Formula

Table 53. Keyboard Shortcuts for Essbase Model Dimension Properties, UDAs Tab

Keys

Element Name

Alt+U

UDA value

Alt+A

Add to list

Alt+E

Existing UDAs

Table 54. Keyboard Shortcuts for Essbase Model Dimension Properties, Outline Build Tab

Keys

Element Name

Alt+H

Hierarchy settings

Alt+M

Move duplicate member settings

Alt+Z

Optimize data load by using a fact table column as data source binding

Alt+R

Reverse position of shared and actual members if shared member is located before actual member

Table 55. Keyboard Shortcuts for Essbase Model Member Properties, General Tab

Keys

Element Name

Alt+M

Comments

Alt+A

Essbase attribute for <member name>

Alt+D

Attribute dimension name

Alt+T

Attribute type

Alt+E

Edit Varying Attribute Settings

Alt+I

Edit Named Generations and Levels

Table 56. Keyboard Shortcuts for Essbase Model Properties, Edit Varying Attributes Dialog Box

Keys

Element Name

Alt+C

Create as Varying Attribute

Alt+A

Association mode

Alt+I

Independent Dimension Settings

Table 57. Keyboard Shortcuts for Essbase Model Member Properties, Info Tab

Keys

Element Name

Alt+D

Consolidation

Alt+V

Solve Order

Alt+A

Aggregate Storage Options

Alt+P

Two Pass Calculation

Alt+S

Data Storage

Table 58. Keyboard Shortcuts for Essbase Model Member Properties, Account Info Tab

Keys

Element Name

Alt+T

Time Balance

Alt+V

Variance Reporting

Alt+S

Skip

Table 59. Keyboard Shortcuts for Essbase Model Member Properties, Typed Measures Tab

Keys

Element Name

Alt+F

Member format string

Alt+A

Current Assigned Text List

Alt+L

Clear Current Assigned Text List

Table 60. Keyboard Shortcuts for Essbase Model Member Properties, Formula Tab

Keys

Element Name

Alt+F

Formula

Table 61. Keyboard Shortcuts for Essbase Model Member Properties, Alias Tab

Keys

Element Name

Alt+R

Rules for mapping text replacement

Alt+A

Create rule

Alt+E

Edit details

Alt+D

Delete

Alt+H

Change case to

Alt+L

Drop leading and trailing spaces

Alt+V

Convert spaces to underscores

Alt+P

Prefix

Alt+F

Prefix Separator

Alt+X

Custom prefix

Alt+S

Suffix

Alt+U

Suffix separator

Alt+M

Custom suffix

Table 62. Keyboard Shortcuts for Essbase Model Member Properties, Alias Tab—Search Rule Dialog Box

Keys

Element Name

Alt+S

Search for

Alt+R

Replace with

Alt+C

Case sensitive

Alt+M

Match whole word

Alt+A

Replace all occurrences

Table 63. Keyboard Shortcuts for Essbase Model Member Properties, UDAs Tab

Keys

Element Name

Alt+U

UDA value

Alt+X

External source

Alt+E

Existing UDAs

Alt+A

UDA Value—Add to list

Alt+D

External Source—Add to list

Table 64. Keyboard Shortcuts for Essbase Model Member Properties, Transformations Tab

Keys

Element Name

Alt+P

Prefix

Alt+F

Prefix separator

Alt+T

Custom prefix

Alt+S

Suffix

Alt+I

Suffix separator

Alt+X

Custom suffix

Alt+R

Rules for text replacement

Alt+U

Create rule

Alt+E

Edit details

Alt+D

Delete

Alt+A

Drop leading and trailing spaces

Alt+V

Convert spaces to underscores

Table 65. Keyboard Shortcuts for Essbase Model Member Properties, Transformation Tab—Search Rule Dialog Box

Keys

Element Name

Alt+S

Search for

Alt+R

Replace with

Alt+C

Case sensitive

Alt+M

Match whole word

Alt+A

Replace all occurrences

Cube Deployment Wizard

Table 66. Keyboard Shortcuts for Cube Deployment Wizard, Essbase Server Connection Options Page

Keys

Element Name

Alt+E

Essbase Server Connection

Alt+A

Application

Alt+D

Database

Alt+W

New Connection

Alt+S

Enable streaming mode for cube deployment

Alt+O

ODBC (Essbase dynamically creates ODBC connection string)

Alt+C

ODBC (Enter ODBC DSN name)

Alt+I

OCI (Enter OCI connection identifier)

Alt+M

Model Properties

Table 67. Keyboard Shortcuts for Essbase Login Dialog Box (accessed when creating an Essbase Server connection in the Cube Deployment Wizard)

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+S

Server

Alt+T

Port

Alt+U

User

Alt+P

Password

Alt+E

Data Encryption

Alt+C

Cluster

Alt+L

Login

Table 68. Keyboard Shortcuts for Cube Deployment Wizard, Cube Deployment Options Page

Keys

Element Name

Alt+U

Build outline

Alt+L

Load data

Alt+O

Build outline and load data

Alt+K

Build outline in background

Alt+X

Add to existing data

Alt+S

Subtract from existing data

Alt+G

Overwrite existing data

Alt+M

Delete all members first

Alt+R

Delete and restore database

Alt+I

Incremental load

Alt+C

Create and save rule file only

Alt+A

Number of records to keep: All

Alt+T

Number of records to keep: Limit

Alt+D

Error file name: Default

Alt+E

Error file name: File name

Alt+P

Stop the data load when the first record is rejected

Alt+Y

Deploy now

Alt+V

Save as MaxL load script

Alt+W

Browse

Table 69. Keyboard Shortcuts for Cube Deployment Wizard, Incremental Load Page

Keys

Element Name

Alt+H

Update all hierarchies

Alt+S

Update or rebuild selected hierarchies

Alt+U

Update

Alt+R

Rebuild

Alt+C

Clear

Alt+P

Preserve

Table 70. Keyboard Shortcuts for Drill-through Report Editor, Context Tab

Keys

Element Name

Alt+N

Name

Alt+D

Description

Alt+I

Intersections

Alt+A

Add

Alt+G

Advanced Settings (applies to recursive hierarchies only)

Drill-through Report Editor

Table 71. Keyboard Shortcuts for Drill-through Report Editor, Report Contents Tab—Report Type: Relational

Keys

Element Name

Alt+R

Report Type: Relational

Alt+A

Add

Alt+P

Show duplicate records in report

Alt+D

User user-defined SQL

Alt+Q

Template SQL

Alt+L

Filter

Alt+V

Row governor

Alt+S

Test

Table 72. Keyboard Shortcuts for Drill-through Template SQL Dialog Box

Keys

Element Name

Alt+S

Cube Schema

Alt+G

Get Standard SQL

Alt+Q

User-defined SQL

Alt+V

Validate

Alt+U

Update User-defined SQL

Table 73. Keyboard Shortcuts for Drill-through Filter Dialog Box

Keys

Element Name

Alt+F

Formula

Alt+X

Filter Expression

Table 74. Keyboard Shortcuts for Drill-through Report Testing Dialog Box

Keys

Element Name

Alt+S

Cube Schema

Alt+I

Column value for each intersection

Alt+R

Show result

Alt+M

Maximum rows to display

Alt+T

Resulting report

Table 75. Keyboard Shortcuts for Drill-through Report Editor, Report Contents Tab—Report Type: URL

Keys

Element Name

Alt+U

Report Type: URL

Alt+L

URL

Alt+S

Sample URL Template

Alt+F

FDM URL Template

Alt+O

OBI URL Template

Table 76. Keyboard Shortcuts for Drill-through Report Editor , Report Contents Tab—Report Type: Java Method

Keys

Element Name

Alt+J

Report Type: Java Method

Alt+C

Java Class Name

Alt+M

Java Method Name

Table 77. Keyboard Shortcuts for Drill-through Report Editor, Associations Tab

Keys

Element Name

Alt+A

Select all Essbase models

Alt+R

Refresh Model List

Cube Linkage

Table 78. Keyboard Shortcuts for Update Cube Linkage and Cube Linkage Dialog Boxes

Keys

Element Name

Alt+P

Update all Essbase applications and databases to link to the current Studio Server (all Essbase instances must be started)

Alt+S

Stop all Essbase applications after the update

Alt+D

Update selected Essbase application and database

Alt+U

Note:

You must first have selected an application and database, listed under Essbase Connections in the table.

Update

Alt+S

Essbase Studio Server

Alt+M

Essbase model name

Essbase Studio Catalog Export/Import

Table 79. Keyboard Shortcuts for Export Dialog Box

Keys

Element Name

Alt+N

File Name

Alt+D

File Description

Alt+W

Browse

Alt+C

File Contents

Alt+E

Export entire catalog

Alt+P

Export partial catalog (use the Add Button to select elements)

Alt+A, then M

Add, then Add Metadata

Alt+A, then D

Add, then Add Data Source

Alt+I

Include associated Essbase models with Cube Schemas

Table 80. Keyboard Shortcuts for Import Dialog Box

Keys

Element Name

Alt+W

Browse

Alt+C

Check for elements and overwrite them

Alt+K

Check for elements but do not overwrite them

Alt+E

Do not check for elements; all elements are new

EIS Catalog Migration

Table 81. Keyboard Shortcuts for the EIS Catalog Migration Dialog Box

Keys

Element Name

Alt+E

EIS Catalog ODBC DSN

Alt+U

User

Alt+P

Password

Alt+F

Fetch Models

Alt+N

New Data Source

Alt+B

Browse

Alt+F

In Select Folder dialog box: Create Folder

Alt+M

Migrate

Find and Search

Table 82. Keyboard Shortcuts for the Find Dialog Box

Keys

Element Name

Alt+F

Find

Alt+C

Match Case

Alt+W

Match Word

Alt+A

Apply to current selection

Table 83. Keyboard Shortcuts for the Search Tab

Keys

Element Name

Alt+N

Name

Alt+T

Type

Alt+L

Look In

Alt+B

Browse

Alt+S

Search

Alt+C

Clear

After clicking Search or pressing Alt+S, if there are search results returned, press Tab to move focus to the Search Result portion of the Search tab, and navigate the search results. If there are no search results, you may not tab to the Search Results portion of the tab and this message appears: No elements found in search.

Refer to Table 3, Accessing Elements in the Metadata Navigator and Data Source Navigator, which contains instructions for navigating within a tree structure.

Keyboard Shortcuts in the Minischema Editor

The tables in this section describe keyboard equivalents used in the Oracle Essbase Studio minischema editors.

Table 84. Accessing Items on the Context Menu in a Minischema Diagram

Keys

Action

Shift+F10

Activate the context menu.

Shift+F10, then S

Save the active minischema.

Shift+F10, then J

Launch the Add Join dialog box.

Shift+F10, then I

Launch the Add Joins by Inspection dialog box.

Shift+F10, then A (Add/Remove Tables command)

Or

Shift+F10, then P (Properties command)

Note:

Both of these commands access the same dialog box.

Launch the Properties dialog box for the minischema. (The Properties dialog contains one tab, the Add/Remove Tables tab.)

Shift+F10, then M

Launches the Choose Folder dialog. Perform an action:

  • Use the arrow keys to navigate to the folder where you want to add the metadata element created from the selected minischema table.

  • Alt+F to create a new folder to store the selected element.

Add the selected item to the Metadata Navigator

Shift+F10, then L

Lay out the minischema in the work area.

Ctrl+=

Zoom in on, or enlarge the view of, the minischema.

Ctrl+-

Zoom out on, or reduce the view of, the minischema

Table 85. Accessing Additional Minischema Context Menu Items When a Minischema Table is Selected

Keys

Action

Arrow keys

Move focus from one table to another in the minischema diagram

Shift+F10, then R

Remove selected table or join

Shift+F10, then N

Minimize the selected table in the minischema diagram

Shift+F10, then X

Maximize the selected minimized table in the minischema diagram

Shift+F10, then J

Add a join to the selected table

Shift+F10, then I

Add joins by inspection to the selected table

Shift+F10, then A

Or

Shift+F10, then P

Launch the Edit Properties dialog box for the minischema (this is the Add/Remove Table command on the context menu)

Shift+F10, then down arrow key to Add to Metadata Navigator

Launch the Choose Folder dialog. Use the arrow keys to navigate to the folder where you want to add the metadata element created from the selected minischema table.

Shift+F10, then C

Display a drop-down list of colors, use arrow keys then press Enter to select a color

Shift+F10, then L

Automatically arrange, or lay out, the minischema in the work area.

Ctrl+=

Zoom in on, or enlarge the view of, the minischema.

Ctrl+-

Zoom out on, or reduce the view of, the minischema

Shift+F10, then V

Launch sample data in the work area for the selected table

Shift+F10, then P

Launch the Properties dialog box for the selected table