Oracle® Essbase Studio

New Features

Release 11.1.2.2.100


Copyright © 2012, Oracle and/or its affiliates. All rights reserved.

Authors: EPM Information Development Team

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish, or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS:

Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle America, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.


Table of Contents:

Essbase Studio 11.1.2.2.100 New Features

Essbase Studio 11.1.2.2.000 New Features

Essbase Studio 11.1.2.1.102 New Features

Essbase Studio 11.1.2.1 New Features

Essbase Studio 11.1.2 New Features

Oracle Essbase Studio continues to simplify cube construction by delivering a single environment for data modeling and cube design, providing a consistent platform for building analytic applications and loading data.

The sections that follow describe the new features in Essbase Studio Releases 11.1.2.2.100, 11.1.2.2.000, 11.1.2.1.102, 11.1.2.1, and 11.1.2. For more information about these features, see the Oracle Essbase Studio User's Guide, available when you access the online help in the Essbase Studio Console, or in PDF and HTML help format on the Oracle Technology Network.

Essbase Studio 11.1.2.2.100 New Features

Hosted Online Help

Online Help content for Oracle Enterprise Performance Management System products is served from a central Oracle download location, which reduces the download and installation time for EPM System. You can also install and configure online help to run locally. For more information, see the Oracle Enterprise Performance Management System Installation and Configuration Guide.

Essbase Model Resync

With Oracle Essbase model resync, changes made to hierarchies and cube schemas can be propagated to affected Essbase models. In prior releases, changing hierarchies and cube schemas meant recreating the Essbase model and resetting any properties the Essbase properties in the model. Using the new “Update Out-of-sync Models” option, you can pick and choose which models to sync, without having to recreate them or reset properties.

For example, suppose a change was made to a hierarchy belonging to a cube schema used to build an Essbase model. When saving the hierarchy, a warning message is displayed indicating that, as a result of the change, there are Essbase models that are out of sync. In the Metadata Navigator, an icon signifies the out-of-sync models. You may right-click either the updated hierarchy or the out-of-sync model in the Metadata Navigator, and then select the “Update Out-of-sync Models” option. This launches the Sync Models dialog box, where you can choose to update selected out-of-sync models or all out-of-sync models.

Note that there are three launch points to the Resync Models dialog box:

  • Right click on an out-of-sync model.

  • Right-click on the cube schema which has an out-of-sync model under it.

    Note that this option is enabled only if there are changes in the cube schema such as adding, removing, or repositioning a hierarchy in the cube schema.

  • Right click on a modified hierarchy.

    Note that this option will sync only this particular hierarchy, regardless of how many hierarchies have been changed. Also, hierarchies added or removed from the cube schema will not be synced.

Following are the types of metadata changes which would prompt a model resync:

  • A new hierarchy is added to a cube schema

  • A hierarchy is removed from a cube schema

  • A hierarchy is replaced with a different hierarchy in a cube schema

  • A hierarchy is moved or repositioned in a cube schema

  • A chain is added to a hierarchy

  • A chain is removed from a hierarchy

  • A chain is replaced in a hierarchy

  • A chain is moved or repositioned in a hierarchy

  • A chain in a hierarchy is edited

  • A member is added to a hierarchy

  • A member is removed from a hierarchy

  • A member is replaced in a hierarchy

  • A member is moved or repositioned in a hierarchy

Whenever you perform a model resync, always be sure to validate the affected Essbase model before attempting to deploy it.

For more information, see the “Model Resync” chapter in the Oracle Essbase Studio User's Guide.

New Streaming Option in Cube Deployment Wizard

A new check box, “Enable streaming mode for cube deployment” has been added to the first page of the Cube Deployment Wizard. This new option allows users to select to deploy cubes in streaming or nonstreaming mode. The selection is made each time you deploy or redeploy.

In prior releases, the property, server.essbase.streamingCubeBuilding, was set in the server.properties file to indicate whether cube deployment would occur in streaming or nonstreaming mode. This property dictated behavior for all cube deployments.

Starting with this release, the choice to perform deployment in streaming mode can be made at deployment time in the Cube Deployment Wizard, and can be changed for each individual deployment and redeployment.

Streaming mode means that during cube deployment, Essbase Studio Server queries the external data source directly (rather than Essbase Server querying the external data source).

The “Enable streaming mode for cube deployment” check box is enabled when the Essbase model being deployed contains single or multiple relational data sources.

The check box is disabled when the data sources used in the Essbase model are one or more text file sources, one or more Dimension Server (Performance Management Architect) sources, or a mix of text file and relational sources.

For more information, see the“ Cube Deployment” chapter, “Providing Connection Information for Cube Deployment” topic in the Oracle Essbase Studio User's Guide.

Minischemas Now Part of Data Source Connection

Minischemas have been reimplemented in this release to associate them with data source connections.

To accommodate this, the Source Navigator area of the Essbase Studio Console is changed as follows:

  • The Minischema tab is removed from the Source Navigator area.

  • The Data Sources tab is renamed Data Source Navigator. This pane is now referred to as the Data Source Navigator and data source connections are listed in the physical tree in this pane.

  • In the physical tree in the Data Source Navigator, under each data source connection name, all minischemas for that connection are stored in a new folder named “Minischemas”. If there are no minischemas for a connection, then that folder is empty.

  • The tables used in a minischema are no longer displayed under the minischema in the physical tree. Double-click the minischema and display it to view the tables.

You can access all previously-available minischema functionality from the opened minischema.

Note:

If you migrated to this release from a prior release, any minischemas you previously had that were created from multiple data sources are not displayed in the Data Source Navigator.

For more information, see the “Minischemas” chapter in the Oracle Essbase Studio User's Guide.

Alias Set Enhancements

In this release, all tasks related to alias set creation and maintenance become accessible directly in the Metadata Navigator. From the File menu or the context menu, you can create alias sets in any folder in the Metadata Navigator, including the root folder. From the Edit menu or the context menu, you can also edit, copy, rename, delete, and export alias sets

Alias sets are now treated as metadata elements, on a par with hierarchies, dimension elements, cube schemas, etc. They can be created in a user-defined metadata folder or in the root folder. They can be exported as part of a catalog export or exported individually.

There are also changes to the way alias properties are handled in the Essbase Model Properties dialog box:

  • Because alias sets can have the same name under different folders in the Metadata Navigator, the new alias set “Name in Cube” field is introduced in the Alias tab for the model. It allows you to rename alias sets so that they appear with a different name in a cube, making all alias table names unique inside a cube.

    During model validation, any duplicates in the “Name in Cube” field result in a model validation error in the Validate Properties dialog box.

  • In the Alias tab for members, the “Name in Cube” is displayed for all alias sets that are included in the model.

  • In the Dynamic Time Series dialog box, for alias sets that are included in the model, the “Name in Cube” for each is displayed as column headers.

Note:

The Alias Set Manager interface is removed from the console and the Alias Set Manager option is removed from the Tools menu. Use the File menu or context menu in the Metadata Navigator to create and access alias sets.

For more information, see the “Alias Sets” chapter in the Oracle Essbase Studio User's Guide.

Streamlined Modeling of Oracle BI EE Business Model Sources

Essbase Studio now lets you create a cube schema and Essbase model during the data source connection creation process.

During Oracle Business Intelligence Enterprise Edition connection creation, when you select the Business Model option, not only are you creating dimension elements and hierarchies, you may now also choose to create a cube schema and Essbase model.

After exploring the source database for dimensions and deriving dimension elements and hierarchies, Essbase Studio then examines the source for fact table elements, from which you can specify measures. Dimensions are also displayed, from which you specify hierarchies. The measures and hierarchies you specify are the basis of a new cube schema, from which an Essbase model is automatically created.

Upon completion of this process, the dimension elements, hierarchies, cube schema, and Essbase model are stored in the Metadata Navigator. You may edit any of these elements, if required. For example, you can open the Essbase model and edit the property settings. Work with these elements as you would elements created from any other relational data source.

For more information on creating metadata elements from Oracle BI EE, see the “Data Source Connections” chapter, “Creating Oracle BI EE Dimensions” and “Creating an Oracle BI EE Cube Schema” in the Oracle Essbase Studio User's Guide.

Support for Oracle RAC Data Sources

You may now create and edit data source connections to Oracle Real Application Cluster (RAC) sources. In the Connection Wizard, you enter an Oracle Service Name, and then you can enter multiple Oracle RAC server nodes per connection.

After data source connection creation, you work with Oracle RAC connection and elements in the same manner as an Oracle connection.

Redeployment in Background Option for XOLAP Cubes

You now have the option of redeploying XOLAP cubes in the background.

If an Essbase model is enabled for XOLAP, you may, when redeploying the cube, select the Build outline in background option.

When you select this option, the Essbase cube downtime is reduced. There is a small downtime interval when the cube is stopped and the new outline is available, as opposed to the downtime of previous releases when the cube was unavailable during the entire outline build process.

For example, in Oracle Essbase Spreadsheet Add-in, users may continue performing analysis on the cube during most of the cube redeployment process while the outline build is occurring in the background. When the redeployment is finished, if the user tries to perform a retrieve (or any other operation), an error message is displayed asking the user to log in again.

The Build outline in background option is selectable only when taking these actions:

  • Redeploying XOLAP cubes

  • Building an outline only

This option is not selectable when taking these actions:

  • Performing an initial XOLAP cube deployment

  • Redeploying non-XOLAP cubes

  • Loading data

Support for Incremental Update of XOLAP Cubes

Essbase Studio now supports incremental update for XOLAP cubes. You may perform an incremental load on an XOLAP cube when any of the following operations, either singly or in combination, are performed in the Essbase model:

  • Members are added to hierarchies

  • Members are deleted from hierarchies

  • Members in hierarchies are re-parented (reorganized)

The Oracle Essbase Studio User's Guide states that incremental builds are not enabled for XOLAP models. You can ignore this statement.

Essbase Studio Server and Catalog Upgrade

This release allows you to upgrade your Essbase Studio installation from an earlier release, keeping all information in the Essbase Studio catalog intact and functional. After upgrade, all data source connections, metadata elements, Essbase models, and cube schemas are available, editable, and deployable.

If you are upgrading from Release 11.1.1.3, use the Oracle Hyperion Enterprise Performance Management System Installer and Oracle Hyperion Enterprise Performance Management System Configurator to install products in a new environment, and follow the process in described in “Upgrading EPM System Products” in the Oracle Enterprise Performance Management System Installation and Configuration Guide.

If you are moving from Release 11.1.2 to Release 11.1.2.1, use the “Apply Maintenance Release” option in Oracle Hyperion Enterprise Performance Management System Installer, and see the “Maintenance Release Installation Checklist” in Oracle Enterprise Performance Management System Installation and Configuration Guide.

Oracle BI EE Business Model Support

Essbase Studio now supports Oracle BI EE Business Model as a data source. In previous releases, Oracle BI EE support was limited to Presentation Layer.

When you create an Oracle BI EE data source connection, you are now presented with the choice of creating the connection based on Presentation Layer or Business Model. The new Business Model option in Essbase Studio allows you to create hierarchies and dimension elements from Oracle BI EE dimensions. After the Connection Wizard process is complete, you can view the hierarchies and dimension elements that were created in the Metadata Navigator.

Note that measure hierarchies and other measures are not automatically created during this process. However, the Oracle BI EE measure elements are stored in the data source connection in the Data Source Navigator. You can use drag-and-drop to add source measure elements to the Metadata Navigator.

Work with these metadata elements as you would with elements created from other data source types. Use the elements to create a cube schema and Essbase model, and then deploy the model to create an Essbase cube.

Along with other relational data source creation workflow topics, see “Creating Oracle BI EE Dimensions” in the Oracle Essbase Studio User's Guide.

Binding Rules for Oracle BI EE Business Model Dimension Elements

Hierarchies created from Oracle BI EE Business Model sources are built based on elements which are primary keys. Many of these elements have numeric values (IDs). This causes a problem in the deployed Essbase cube, where members names in the outline are only numbers , instead of meaningful member names.

Essbase Studio follows a set of rules to generate binding expressions for the dimension elements in cases where the primary key column of the element is a numeric.

For specific information, see “Rules for Generating Key and Caption Bindings for Oracle BI EE Business Model Dimension Elements” in the Oracle Essbase Studio User's Guide.

SSL Support for Essbase Studio Server Connections

Essbase can be deployed to work in Secure Socket Layer (SSL). In SSL mode, all communication between Essbase Server and Essbase Studio Server is encrypted to ensure data security. Default deployments of Essbase components install self-signed certificates to enable SSL communication, mainly for testing purposes. Oracle recommends that you use certificates from well-known third-party certification authorities (CAs) to SSL-enable Essbase in production environments. See the Oracle Enterprise Performance Management System Security Administration Guide for more information.

You specify SSL mode when setting up connections to an SSL-enabled Essbase Server and when creating data source connections to an SSL-enabled Oracle Hyperion EPM Architect server. Additionally, if you are updating references to a rehosted Essbase Server, you must specify “SSL” along with the new host name and port number. See “Creating an Essbase Server Connection”, “Defining Connection Parameters for Performance Management Architect Sources”, and “Updating References to a Rehosted Essbase Server” in the Oracle Essbase Studio User's Guide.

Essbase Studio Server as a Windows Service

Essbase Studio Server can be installed as a Windows Service. Specify Essbase Studio Server to run as a Windows service during the EPM System configuration process.

Essbase Studio Catalog Export and Import

In this release, you can replicate the Essbase Studio catalog database between different machines for various administrative purposes, such as making catalog backups, restoring the catalog, and moving the catalog from one machine to another. Essbase Studio now provides an option to export the catalog into an XML file. This file can then be imported to a new location or a different machine in order to recreate the catalog. You also have the option of selectively copying some catalog objects, exporting to an XML file, and then recreating these objects in a new location or on a different machine.

See “Exporting and Importing the Essbase Studio Catalog Database” in the Oracle Essbase Studio User's Guide.

Improved Data Source Exploration

During data source creation, Essbase Studio is required to scrape, or explore, the data source. The metadata elements derived from the scraping process are subsequently written to the Essbase Studio catalog.

Essbase Studio can now perform scraping without locking the catalog during the data source exploration process. In previous releases, other Essbase Studio users could not read objects from or write objects to the catalog during the exploration process. This could cause problems in a multiuser environment if a data source took a long time to scrape.

If you want to prevent other users from reading or writing to the catalog during data source scraping, you have the option of locking the Essbase Studio catalog. In the Select Tables page of the Connection Wizard, select the Lock catalog during exploration option.

Oracle Diagnostic Logging (ODL)

Essbase Studio logging now uses the Oracle Diagnostic Logging (ODL) framework.

For information on configuring logging for Essbase Studio and other EPM System products, see the Oracle Enterprise Performance Management System Installation and Configuration Troubleshooting Guide, available on the Oracle Technology Network.

These Essbase Studio server properties related to logging have been removed:

  • logger.file

  • logger.limit

  • logger.count

  • com.hyperion.cp.handlers=com.hyperion.cp.util.LoggerFileHandler

The property, com.hyperion.cp.level, is now set in the MIDDLEWARE_HOME/user_projects/epmsystem1/BPMS/bpms1/bin/logging.xml file, which is part of ODL; it is no longer set in the Essbase Studio server.properties file.

Support for ODBC DSN and OCI Connections

During cube deployment, you can call specific ODBC DSNs or Oracle Call Interface (OCI) connect identifiers that you have set up in your environment. Calling an ODBC DSN or OCI connect identifier allows you to take advantage of the particular parameters that are set in the DSN or in OCI. For example, during cube deployment, you may use an Oracle Wire Protocol driver that is set up to take advantage of driver performance and failover options.

The option to specify the ODBC DSN or OCI connect identifier is on the Cube Deployment Wizard, “Essbase Server connection options” page, “Data Source settings” group.

Connection Pooling

With connection pooling, the query driver in Essbase Studio provides a pool of physical connections per data source, allowing the execution of concurrent queries, and speeding up query processing. You specify the number of connections in the pool.

In previous releases, the query driver opened one physical connection per data source. If several tasks tried to run concurrent queries to the same data source, the query driver was forced to run the queries sequentially; that is, each query waited until previous query execution was finished, causing delays in query processing.

Support for Connections to Essbase Server Clusters

Essbase supports clustering of Essbase Servers to provide active-passive failover with write-back capability. Active-passive Essbase failover clusters use the service failover functionality of the Oracle Process Manager and Notification (OPMN) Server.

Essbase Studio allows you to create connections to Essbase Server clusters. When you create an Essbase connection in the Connection Wizard, you can select the new “Cluster” check box to denote that the connection is to an Essbase Server cluster.

For more information on Essbase failover clusters, see the Essbase documentation.

Enhanced Data Source Synchronization

You can keep your Essbase Studio data source connections closely synchronized with the physical data source using the Delete and Refresh table commands available in the Data Sources tab of the Data Source Navigator.

Deleting Tables

Delete tables that are no longer in use or that you do not want used with a particular data source connection.

You can delete tables from data source connections as long as no Essbase Studio metadata elements are dependent on the tables. For example, if a table is used to build a hierarchy stored in your Essbase Studio catalog, you cannot delete the table without first deleting the dependent hierarchy and its elements.

Note:

You can only delete tables from relational data sources, including Oracle BI EE data sources, and files from flat file data sources.

Refreshing Tables

Refresh tables to detect schema changes that occurred in your data source since you created the data source connection.

You can refresh tables at the connection level and the table level. Schema changes that are detected during refresh include:

  • New columns

  • Dropped columns

  • Changes in column data type; for example, varchar to integer

When you refresh at the connection level, the refresh is performed for all tables in the connection. When you refresh at the table level, the refresh is performed only on the selected tables.

Note:

You can refresh only relational data sources, including Oracle Business Intelligence Enterprise Edition data sources.

Enhanced Console Display, Messaging, and Navigation

Release 11.1.2 introduces the following usability improvements to the Essbase Studio Console interface:

  • The title bar of the Essbase Studio Console now displays the Essbase Studio Server name, the logged-in user name, and the logged-in user role.

  • In order to use the Launch Essbase Administration Console command from Essbase Studio Console, both consoles must reside on the same machine. If Administration Services Console is not installed on the same machine, then Essbase Studio Console now displays an informational message.

  • When adding children or siblings to a hierarchy in the hierarchy editor, Essbase Studio remembers the last selection made. For example, if you chose the STATEID column from the MARKET table of the TBC sample data source, then, when adding the next child or sibling, the Select Entity dialog box is launched with the MARKET table already opened.

Increased Limit for Alias Tables

Essbase Studio now supports 32 alias tables for block storage and aggregate storage databases.

Text List Mapping Support

This release introduces a new metadata element for defining text lists. Text lists enable you to map a column containing text strings to a column containing IDs for those strings. The columns you use in the text list are columns from your data source, usually from a specific data source table that contains the IDs and text strings.

Note:

You set up this ID-to-text string mapping structure in your data source before you create text lists in Essbase Studio.

Text lists are used in conjunction with text measures. Text measures extend the analytical capabilities of Essbase beyond numerical data to text-based content. Storage and analysis of textual content are useful when a cell needs to have one of a finite list of textual values.

For example, customer satisfaction may be expressed in terms of ratings such as High, Medium, and Low. These customer satisfaction ratings are a set of text strings which are mapped to corresponding numeric IDs, such as 1, 2, and 3 respectively. These mappings are contained in the text list element that you create.

Essbase Model Design Improvements

Essbase model design changes have resulted in improved Essbase model handling of specific changes to metadata elements and cube schemas. For example, in previous releases, changing a hierarchy name meant that you had to recreate or rebuild any Essbase models in which that hierarchy participated.

Starting with this release, recreating or rebuilding an Essbase model is not required when you perform the following operations on a metadata folder, dimension element, derived text measure, text list, hierarchy, measure hierarchy, or cube schema:

  • Rename

  • Move

Further, recreating or rebuilding an Essbase model is not required when you perform these operations:

  • Change the binding, filter, sort order, or alias set bindings of a dimension element

  • Change the binding, range, or alias set bindings of a derived text measure

  • Change the value binding or ID binding of a text list

  • Change an overridden data load binding in a cube schema

Note that recreating or rebuilding an Essbase model is required when you perform the following operations:

  • Reorder, add, or remove members in a hierarchy or measure hierarchy

  • Add or remove hierarchies from a cube schema

  • Add or remove any loose measures in a cube schema

  • Change the measure hierarchy in a cube schema

  • Override the default data load bindings in a cube schema

Dimension Sort Order Support

Essbase Studio supports dimension sort order. Dimension sort order determines the order that dimensions appear in the Essbase model and subsequent Essbase outline and, in turn, impacts the order that dimensions are calculated.

You use toolbar buttons on the Essbase model dialog box for dimension sort ordering.

Note that dimension order can affect performance, especially for block storage databases. Calculation of aggregate storage and block storage databases is described in the Oracle Essbase Database Administrator's Guide.

Support for Named Generations and Levels

You can now create your own names for generations and levels in an Essbase model. The name is a word or phrase that describes the generation or level. For example, you might create a generation name called Cities for all cities in the outline. You can define only one name for each generation or level.

Use generation and level names in calculation scripts and report scripts wherever you need to specify either a list of member names or a list of generation or level numbers. For example, you can limit a calculation in a calculation script to the members of a specific generation.

In a dimension that allows duplicate member names, you can specify that unique member names are required for a particular generation or level.

Automatic Placement of Actual Member Before Shared Members

For aggregate storage outlines, Essbase requires that actual members are always placed before shared members. After building your Essbase outline, you may have placed shared members before actual members in recursive dimensions. By selecting a new check box in the Outline Build tab of the Essbase Model Properties dialog box, the first instance of an outline member name becomes the actual member instance. Any other instances of that outline member name become the shared members. The check box is labeled:

“Reverse position of shared and actual members if shared member is located before actual member”

Below are examples showing the recursive hierarchy members before and after Essbase changes the shared member and actual member order. Note that the order of the parents remains the same; the position of the actual member changes.

Case 1, Before

Employees (dimension)
    Engineer
        John Smith (shared)
    Manager
        John Smith (shared)
    Director
        John Smith (actual)

Case 1, After

Employees (dimension)
    Engineer
        John Smith (actual)
    Manager
        John Smith (shared)
    Director
        John Smith (shared)

Case 2, Before

Employees (dimension)
    Engineer
        John Smith (shared)
        Paul Williams (shared)
    Manager
        John Smith (actual)
        Paul Williams (actual)

Case 2, After

Employees (dimension)
    Engineer
        John Smith (actual)
        Paul Williams (actual)
    Manager
        John Smith (shared)
        Paul Williams (shared)

MaxL Deployment Script Generation

When performing a cube deployment, you can save all the deployment parameters and options you have chosen as a MaxL script. Then, depending on the options you chose when creating the script, you can use this script in the MaxL Shell to perform member or data loads, or both.

The option to save deployment information as a MaxL script is on the “Setting Deployment Options” page of the Cube Deployment Wizard.

Note:

You may edit the script file to substitute the user name and password parameters; for example:

deploy all from model 'cs1Model' in cube schema '\CubeSchemas\cs1' login admin identified by password on host 'poplar-pc1' to application 'cs2' database 'cs2' add values using connection 'Connection1' keep 200 errors on error ignore dataload write to default;

Alternatively, enter the user name and password as parameters along with the script name at a command prompt; for example:

essmsh c:\generated_mxl_script.msh admin password

Cube Deployment Improvements

  • A window now displays when you launch a cube deployment, and stays onscreen when deployment is completed. The window includes the following information about the cube deployment:

    • Member load and data load start time

    • Status message listing member and data load details

    • Elapsed time, in minutes and seconds, of member loads and data loads

    • Number of records processed and records rejected

    • Deployment success or failure

    • Location of the error file

  • Prior to cube deployment, users are now warned if errors exist in the Oracle Essbase model. If model errors exist, then, when you click Next in the “Essbase Server connection options” page of the Cube Deployment Wizard, a dialog is displayed asking if you want to launch the Essbase Model Properties dialog box. Click “Yes” to launch the properties dialog box and correct the errors.

    You may click “No” in this dialog, but you cannot proceed with the deployment until the model errors are corrected. If you click “No,” then click the Model Properties button on the “Essbase Server connection options” page of the Cube Deployment Wizard to launch the properties dialog box and correct the errors.

Drill-through on Recursive Hierarchies

Essbase Studio now provides support for drill-through reports built on recursive hierarchies. Users can create a drill-through report that includes one or more recursive hierarchies, and then for each recursive hierarchy, specify a generation or level setting that will participate in the report. The report can be executed using Oracle Hyperion Smart View for Office.

Note:

Recursive hierarchy drill-through on Essbase Studio-built cubes is not supported on Essbase Spreadsheet Add-in.

Lineage Viewer Display Improvement

In previous releases, the Lineage Viewer would show two physical elements for each dimension element, even when the caption binding and key binding expressions were the same. For example, for the dimension element, FAMILY, two nodes showing tbc.family.FAMILY were displayed: one node for the caption binding and one node for the key binding.

Now, when the caption binding and key binding are the same, only one node is displayed for the physical element in the Lineage Viewer.

Cancellation Option for Integration Services Catalog Migration

You may cancel an Oracle Essbase Integration Services catalog migration while it is in progress. There is now a Cancel button in the EIS Catalog Migration dialog box.

Accessibility

Starting with this release, the Essbase Studio user interface adds keyboard-only support to all applicable dialog boxes and screen elements, as well as screen reader support.

Essbase Studio documentation is also accessible in this release in HTML format.

It is our goal to make Oracle products, services, and supporting documentation accessible to the disabled community. Oracle Essbase Studio supports the accessibility features described in the Oracle Essbase Studio Accessibility Guide.

EPM System New Features

  • Most EPM System products have adopted Oracle Diagnostic Logging (ODL) as the logging mechanism. The ODL framework provides uniform support for managing log files, including log file rotation, maximum log file size, and the maximum log directory size. For more information, see the “Using EPM System Logs” chapter of the Oracle Enterprise Performance Management System Installation and Configuration Troubleshooting Guide.

  • Oracle Configuration Manager (OCM) integrates with My Oracle Support and provides configuration information for Oracle software. It assists in the troubleshooting, maintenance, and diagnostics of your EPM System deployment. For more information about Oracle Configuration Manager see the Oracle Enterprise Performance Management System Installation and Configuration Guide.

  • With this release, many EPM System products support hostnames that resolve to IPv6 addresses. See the Oracle Enterprise Performance Management System Certification Matrix. IPv4 support (both hostname and IP address) remains unchanged from earlier releases.

  • Oracle Enterprise Performance Management System supports the following types of SSL configurations:

    • Full SSL Deployment (including data access)

    • SSL Terminating at the Web Server

    • SSL Accelerators (Off-loading)

    • Two-way SSL

      For more information on the SSL configurations, see the Oracle Enterprise Performance Management System Security Administration Guide.