B Troubleshooting Oracle Authorization Policy Manager

This appendix describes common problems that you may encounter when configuring and using Authorization Policy Manager and explains how to solve them.

B.1 Unable to Login

This section explains one of the reasons why logging in Authorization Policy Manager may fail.

Symptom

Authorization Policy Manager logging in fails and the system outputs a message that contains a line similar to the following:

Cannot obtain connection: driverURL = jdbc:weblogic:pool:mds-ApplicationMDSDB,
props = {EmulateTwoPhaseCommit=false, connectionPoolID=mds-ApplicationMDSDB,
jdbcTxDataSource=true, LoggingLastResource=false,
dataSourceName=mds-ApplicationMDSDB}.

Diagnosis

The above message indicates that Authorization Policy Manager cannot establish a connection with the database mds-ApplicationMDSBD. Authorization Policy Manager requires that this database be present for a successful logging in.

For the list of databases required by APM, see Section 1.1, "Audience and Prerequisites."

Solution

Verify that referenced database is up, running, and available; then retry logging in.

B.2 Need Further Help?

You can find more solutions on My Oracle Support (formerly MetaLink) at http://myoraclesupport.oracle.com. If you do not find a solution to your problem, log a service request.