2.2 Java Versions Supported

The following table summarizes what version of Java RTE is required to use Connector/J with Java applications, and what version of JDK is required to build Connector/J source code:

Table 2.2 Summary of Java Versions Required by Connector/J

Connector/J versionJava RTE requiredJDK required (to build source code)
5.11.5.x, 1.6.x, 1.7.x1.6.x and 1.5.x
5.01.3.x, 1.4.x, 1.5.x, 1.6.x1.4.2, 1.5.x, 1.6.x
3.11.2.x, 1.3.x, 1.4.x, 1.5.x, 1.6.x1.4.2, 1.5.x, 1.6.x
3.01.2.x, 1.3.x, 1.4.x, 1.5.x, 1.6.x1.4.2, 1.5.x, 1.6.x


If you are building Connector/J from source code using the source distribution (see Section 3.4, “Installing from the Development Source Tree”), you must use JDK 1.4.2 or newer to compile the package for Connector/J 5.0 or earlier. For Connector/J 5.1, you must have both JDK-1.6.x AND JDK-1.5.x installed to be able to build the source code.

Java 1.7 support requires Connector/J 5.1.21 and higher. Several JDBC 4.1 methods were implemented for the first time in Connector/J 5.1.21.

Because of the implementation of java.sql.Savepoint, Connector/J 3.1.0 and newer will not run on a Java runtime older than 1.4 unless the class verifier is turned off (by setting the -Xverify:none option to the Java runtime). This is because the class verifier will try to load the class definition for java.sql.Savepoint even though it is not accessed by the driver unless you actually use savepoint functionality.

Caching functionality provided by Connector/J 3.1.0 or newer is also not available on JVMs older than 1.4.x, as it relies on java.util.LinkedHashMap which was first available in JDK-1.4.0.

MySQL Connector/J does not support JDK-1.1.x or JDK-1.0.x.