8.1.1 Fabric Prerequisites

Fabric is designed to work with MySQL servers version 5.6.10 and later. The mysqlfabric utility requires Python 2 (2.6 or later) and Connector/Python 1.2.1 or later.

You must have a MySQL instance available to install the backing store. This server must not be a member of a Fabric group.

Note

The backing store must be a MySQL server 5.6 or later.

To utilize Fabric in your applications, you must have a Fabric-aware connector installed on the system where the application is running. For more information about using a connector with Fabric, see the appropriate connector-specific section (Section 8.8, “Using Connector/Python with MySQL Fabric”, Section 8.9, “Using Connector/J with MySQL Fabric”).

In summary, the following items indicate the prerequisites for using MySQL Fabric: