Skip Headers
Oracle® Communications Network Intelligence User's Guide
Release 7.2.2

E36059-03
Go to Documentation Home
Home
Go to Table of Contents
Contents
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

1 Using Network Intelligence

This section describes how to use Oracle Communications Network Intelligence.

Getting Started with Network Intelligence

Network Intelligence enables network planning and optimization. It reads data from your network inventory systems or other network data sources and processes that data to create useful views of your network data.

Network Intelligence is a capacity planning system used by Communication Service Providers (CSPs) for communications networks. It reads data from your network inventory systems or other network data sources and processes that data to create useful views of your network data. After loading inventory data in Network Intelligence, you manage your network assets, forecast traffic demand, plan network capacity, and optimize network traffic. Network Intelligence allows network planners to view network reports and maps, plan network build, and identify potential capacity stress points within the network in advance.

It can be used for assessing network capacity, and for carrying out network cost reduction and consolidation. It can also be used as an inventory system that offers capacity planning and reporting.

When getting started with Network Intelligence, see the following topics:

Accessing Network Intelligence

You log onto Network Intelligence using a user name and password provided to you by the Network Intelligence administrator.

To access Network Intelligence:

  1. In a supported Internet browser, enter the following URL:

    http://host_name:port/netintel-client/
    

    where host_name is either the name or IP address of the host of the application server in which Network Intelligence is installed, and port is the port number for the server.

    Ask the Network Intelligence administrator for the host name or IP address and port number.

  2. Click on the graphic on the Web page.

    A Java network launching protocol (JNLP) file downloads to your computer.

    Your browser might block the file or ask you to confirm the download. If this occurs, confirm the download.

  3. Double-click the JNLP file.

    The Network Intelligence Java client launches.

    Your computer might ask you to confirm that you want to run the application. If this occurs, confirm that you want to run the application.

    The Network Intelligence Login dialog box appears.

  4. Enter your user name and password and click Login.

Managing your Network Intelligence User Profile and Password

You can manage your user profile and change your password:

  1. In a supported Internet browser, enter the following URL:

    http://host_name:port/netintel-server/
    

    where host_name is either the name or IP address of the host of the application server in which Network Intelligence is installed, and port is the port number for the server.

    Ask the Network Intelligence administrator for the host name or IP address and port number.

  2. Enter your user name and password and click Login.

    The Network Intelligence administration Welcome page appears.

  3. Do any of the following:

    • To modify your user profile, from the My Profile menu, select My Profile.

      The User Profile page appears.

    • To change your password, from the My Profile menu, select Change Password.

      The Change Password page appears.

  4. Make any changes and click Save.

Understanding Network Intelligence and Network Intelligence Terminology

You should read Network Intelligence Concepts for full explanations of the concepts and background needed to work in Network Intelligence.

Network Intelligence Concepts also provides a full glossary of key Network Intelligence terms.

Working with the Network Intelligence User Interface

Network Intelligence has a Web-based interface with simple navigation and interface controls. The main window is divided into several regions and has a menu in the upper left corner. The region to the left contains the tree browser panel listing network entities, which you use to open work areas of various kinds. The region to the right is populated with the work areas that you open, such as object views.

When working in the Network Intelligence user interface, see the following topics:

Using the Menu

Figure 1-1 displays the Network Intelligence menu.

Figure 1-1 Network Intelligence GUI: Menu

Description of Figure 1-1 follows
Description of "Figure 1-1 Network Intelligence GUI: Menu "

Note:

The menu displays Route because the Route entity is selected in the context toolbar, as shown in Figure 1-3, "Network Intelligence GUI: Context Toolbar".

See "Using the Context Toolbar" for more information on the context toolbar.

The menu contains the following menus:

  • File:

    • Select Exit to exit the Network Intelligence GUI.

  • Tools: Provides access to Network Intelligence modules that have been licensed and installed, which may include:

  • Maps: If the optional geographic mapping module is installed, this menu item presents reports, which may include:

    • Inter Site Trail Geographic Report

    • Inter Equipment Trail Geographic Report

  • Administration: Enables the creation of addresses and locations, used in site definition; provides editable costing data; offers the ability to maintain customer contacts for sending outage reports, migration reports, or other requested application updates:

    • Create Object

      • New Address

      • New Location

    • Costing: Lists some costing, or network maintenance and buildout tasks; for example:

      • Maintain Connection Build Tasks

      • Maintain Port Build Tasks

      • Maintain Timeslot Build Tasks

      • Maintain Card Build Tasks

      • Maintain Equipment Build Tasks

      • Maintain Trail Build Tasks

      • Maintain Site Build Tasks

      • Maintain Topology Build Tasks

      • Maintain Trail Costs

      • Maintain Labor Costs

      • Maintain Equipment Costs

    • Contacts:

      • Add a Contact

      • Maintain Contacts

  • Window: Lists all open windows.

  • Dialog: Lists all open dialog boxes.

  • Help: Consists of two items:

    • Oracle Communications Network Intelligence: Provides Network Intelligence license information and software version number.

    • Online Documentation: Select to open a new browser window showing the main Network Intelligence Help page. Expand the table of contents to view the subject headings, and select the required topic. Use the search function to look for a topic.

Using the Toolbar

Figure 1-2 displays the Network Intelligence toolbar.

Figure 1-2 Network Intelligence GUI: Toolbar

Description of Figure 1-2 follows
Description of "Figure 1-2 Network Intelligence GUI: Toolbar"

Table 1-1 displays the toolbar icons.

Table 1-1 Using the Toolbar Icons

Icon Description
Trail Routing Manager icon

Display Trail Routing Manager.

Trail Routing Manager is used to route end to end trails.

Monitor Report Manager icon

Run Monitor Report Manager.

Monitor Report Manager is a web-based online analysis and reporting tool used to provide a set of specific key performance indicator (KPI) reports for technical management.

Plan creation wizard icon

Run the plan creation wizard.

The plan creation wizard is used to create a forecast, defined as a collection of service demands with expected future trail growth counts for one, or more, future time periods.

Configuration plan icon

Create a configuration plan.

Configuration plans are used to perform and record actions such as creating, editing, or deleting network resources; for example: creating sites, or deleting equipment.

Outage Manager con

Display Outage Manager.

Outage Manager is used to create an outage report for a network entity, or a group of network entities.

Migration Manager icon

Display Migration Manager.

Migration Manager is used to create a migration plan to generate network requirements changes to your network.

Configuration plan search icon

Search for a configuration plan. You can perform a quick search in the Associated Plan field.

Enter any part of the search tern, click Enter, and the field autocompletes.

The search icon is disabled if Network Modeling is selected.

Record configuration actions icon

Record configuration actions against the configuration plan selected in the Associated Plan field.

There are two modes available in the Mode field:

  • Network Modeling

  • Configuration Planning

Stop recording configuration actions icon

Stop recording configuration actions against the configuration plan selected in the Associated Plan field.


Using the Context Toolbar

To display network inventory data, use the context toolbar to select which type of data you want to see; for example, a network, site, or topology.

Figure 1-3 shows part of the context toolbar running vertically on the left of the GUI:

Figure 1-3 Network Intelligence GUI: Context Toolbar

Description of Figure 1-3 follows
Description of "Figure 1-3 Network Intelligence GUI: Context Toolbar"

To display a type of object, click the corresponding icon in the context toolbar. Network Intelligence displays a tree browser showing the entities in the system.

Related Topics

See "Using the Tree Browser".

About the Context Toolbar Entity Types

Table 1-2 displays the views and reports available in Network Intelligence.

Table 1-2 Definition and Depiction of Context Toolbar Entity Types

Object Description Icon

Network

A network consists of a series of points or nodes connected by communication paths; it may be made up of some sub-networks.

Network icon

Site

A site is any object that contains equipment entities in the network.

Site icon

Topology

A topology is a structure containing equipment and trail links. A ring is a type of topology. A topology consists of equipment, and the links between them.

Topology icon

Equipment

An equipment object is a device that terminates or transits trails.

Equipment icon

Trail

A trail is a connection between two sites or equipment entities. A trail can transport services or other trails. A trail has a given capacity.

Trail icon

Route

A route is a collection of one of more trails that have the same start site, end site, capacity and service type.

Route icon

Service

A service is a product offering that is delivered to a customer location through one or more trail entities.

For example, Metro Ethernet and IPTV are types of services.

Service icon

Policy

A policy is a container for rules and other policies.

Policy icon

Plan

A plan is a collection of network configuration tasks that must be applied to the network.

A plan normally consists of one or more service demands which are requirements for services between two network sites.

Plans can also include new proposed sites, equipment, or links.

Plans are presented in the tree browser as My Plans, that is, plans created by the current user, or Other Plans, that is, plans created by other users.

Plan icon

Configuration Plan

A configuration plan is a collection of network configuration tasks that are recorded for audit purposes, to create a report for senior management, to provide the inputs required to generate a works order for field staff, or for a variety of other uses.

Configuration plan icon

Outage Plan

An outage plan is used to create a report for an outage on a network entity, or set of network entities.

Outage Plan icon

Migration Plan

A migration plan is used to generate network requirements changes to your network.

Migration Plan icon

Forecast Plan

A forecast plan defines a collection of service demands with expected future trail growth counts for one, or more, future time periods.

Forecast Plan icon

Customer

A customer is an individual or organization that uses one or more services.

Customer icon

Capacity

Capacity is the bit rate in MB per second by which a trail is transmitted.

Capacity also applies to trail holders and ports, to indicate the type of trail carried, or terminated.

Capacity icon

Resource Group

A resource group is a collection of network entities used in outage planning, configuration planning, and bulk updates of trails.

Resource Group icon

Using the Tree Browser

When a network object is selected, a menu for the network object family is added to the main menu bar. So, for example, when the site tree browser is displayed, it lists all existing network site locations; all site collection views can be accessed from the sites tree browser. The creation of new sites is enabled.

Figure 1-4 shows part of the trail display in the tree browser; that is, a series of folders used to group different trails:

Figure 1-4 Network Intelligence GUI: Tree Browser

Description of Figure 1-4 follows
Description of "Figure 1-4 Network Intelligence GUI: Tree Browser"

Table 1-3 explains the icons available in the tree browser.

Table 1-3 Using the Tree Browser Icons

Icon Description
Entity instance creation icon

Create an instance of the entity.

An Entity Creation Wizard is displayed for equipment and trails; for example, if a route is selected in the context toolbar, a Route Creation Wizard is displayed.

For all other objects, use the object detail view to create an instance.

Tree browser search icon

Search the tree browser.

You can search for individual objects, or groups of objects. A search can be carried out on any attribute, including custom attributes that can be added to trails or equipment.

Double click the object to display a full object details view.

Object group view list icon

Display the object group views.


To see details about an entry in the tree browser, double-click it. The object details view is displayed in a tab.

Working with Object Views

The object view displays information relating to an object selected in the tree browser. The object view is the default view for every object. It presents information and attributes relevant to the object, including name, status, technology, creator, creation date, in-service date, and so on.

On the right side of the screen, the View tab displays the views available for the network object.

To display a view, click the view name in the View tab.

Displaying Object Definitions

You can display definition details for trails and equipment; for example, the name, manufacturer, and number of ports for an equipment.

To display object definitions for an equipment:

  1. Click Equipment on the context toolbar.

  2. Click the Definitions tab to display the object types.

  3. Expand the Equipment folder.

  4. Expand the individual equipment folder required; for example, Card.

  5. Double-click an object type to display the definition details.

Displaying Object Group Views

You can get views about all objects of a given type in the network, for example, views about all trails.

To display the object group views for a type of object:

  1. From the context toolbar, open the tree browser of the object type selected.

  2. Click the object group views icon:

    object group views icon

    The list of group views for that type of object is displayed. You can open the object group view only for the type of object currently in the tree browser. You can also open object group views from the menu bar.

  3. Select a view.

Working with Data Views

Network Intelligence displays data in views. A view is a set of data that has been processed to show a usable set of information; for example:

  • The trails handled by a specific piece of equipment.

  • Links between nodes in a topology.

Each type of inventory data has its own set of views; for example:

  • A network includes views for nodes, equipment, trails, and customer bandwidth.

  • A customer includes views for sites, equipment, and trails.

Views are displayed in various formats, depending on the data:

In some cases, there are multiple types of views for the same data; for example, a table view and a chart view.

Related Topics

See "Filtering View Data".

Using Table Views

Table views display data in tables. You can perform the following tasks with table views:

  • Open detail views about entities referenced in the view. For example, if a view lists trails, double-click a trail to display its details.

  • Sort the data by any column.

  • Select which columns to display.

  • Save the data as HTML, save it as CSV, copy it to the clipboard, or open it in Microsoft Excel.

To sort data by column:

  1. Click the column title.

    The table is sorted by that title.

Note:

The first click in a column title sorts in A-Z, ascending order. The second click in a column title sorts in Z-A, descending order. The third click resets the table to its original order.

To select columns to display:

  1. Right-click a column title to display a list of table columns.

  2. Deselect the check box for any column name not to show.

To export data:

  1. Right-click anywhere in the table to display data export options.

  2. Select from:

    • Save As HTML

    • Save As CSV

    • Copy

    • Open in Excel

    Note:

    To save data in PDF format, copy the data to Microsoft Excel, or to a word processing application, such as Microsoft Word, and publish the data in PDF format.

Using Mesh Views

Mesh views display data as graphical links, as shown in Figure 1-5.

You can perform the following tasks with mesh views:

  • Save the view as a JPEG file.

  • Print the view.

  • Zoom in and zoom out.

  • Drag and move nodes in the topology.

  • Double-click a node or connection to see details about equipment and trails. For example, you can click a route to display all of its trails.

  • Select what to display:

    • Nodes

    • Links

    • Map background

  • Change the layout.

    Layouts are defined using algorithms implemented using ILOG software. For further information on layouts, refer to ILOG reference documentation.

    The layout options are:

    • Circular

    • Grid

    • Random

      Note:

      The Random layout view fits the nodes and links of the view to the available screen area without the need for scrolling.
    • Spring Embedder

    • Topological

      Note:

      The topological mesh layout supports cyclic graph types only. Cyclic refers to 2-connected graphs.
    • Uniform Edges

    • Geographical

Using Modeled Views

Modeled views display data as graphical models, as shown in Figure 1-6.

Figure 1-6 Modeled View

Displays a modeled view of a particular trail.

Right-click in a modeled view to display the list of tasks that you can perform on the view. See Table 1-4 for a list of actions and the icons associated with each action.

Table 1-4 Using a Modeled View

Action Icon Description

Zoom in

Zoom in icon

Magnify the image.

Zoom out

Zoom out icon

Decrease the image.

Zoom rectangle

Zoom rectangle icon

View a specific area of the image.

Reset

Reset icon

Revert to the default view.

Show legend

Show legend icon

Display a legend for the view.

See "Displaying a Legend".

Set background color

Set background color icon

Specify the background color. The default is black.

Print

Print icon

Print the view.

Save as visible image

Save as visible image icon

Save the visible portion of the view as a JPEG image.

Save as complete image

Save as complete image icon

Save the entire view as a JPEG image.

Open in Excel

Open in Excel icon

Save the image using Microsoft Excel.

See "Saving the View in Spreadsheet Format".

Save configuration changes

Save configuration changes icon

Save the changes made to the view in the database.


Using Geographic Map Views

This section describes geographic map views in Network Intelligence. A geographic map view displays a network map, containing network nodes and network links, overlaid on a geographic map background. Geographic map views display the real-life physical placement of network nodes and links. Nodes are placed according to their geometric coordinates.

Note:

Geographic map views work correctly only if correct map data is loaded, and each site object has a correct coordinate value. A detailed explanation about configuring Network Intelligence for map display is in Network Intelligence Installation Guide and Network Intelligence Developer's Guide.

The following geographic map views are available:

Inter Site Trail Geographic Reports

Use this view to select site objects and combine them with filter criteria to specify a set of network links. Each node on the map represents a site object and each link in the map represents a collection of links between any two site objects.

To access the Inter Site Trail Geographic Report:

  1. Navigate to the site tree browser.

  2. Select the collection report icon (indicated by an arrow).

  3. Select Inter Site Trail Geographic Report.

Alternatively, from the menu bar, select Maps, and select Inter Site Trail Geographic Report.

Inter Equipment Trail Geographic Reports

Use this view to select a list of equipment objects and combine them with filter criteria to specify a set of network links. Each node on the map represents an equipment object and each link in the map represents a collection of links between any two equipment objects.

To access the Inter Equipment Trail Geographic Report, choose one of the following options:

  1. Navigate to the equipment tree browser.

  2. Select the collection report icon (indicated by an arrow).

  3. Select Inter Equipment Trail Geographic Report.

Alternatively, from the menu bar, select Maps, and select Inter Equipment Trail Geographic Report.

Trail Traversal Geographic Map Views

Use this view to see the routed path of a trail in a geographic map. The path of a trail from start node to end node is drawn with all intermediate hub nodes.

To access the Trail Traversal Geographic Map View:

  1. Select a trail of interest from the trail tree browser, or trail search window.

  2. In the view panel, on the right-hand side under Traversal, click Geographic Map View.

About Common Behaviors in Map View

The behaviors described in this section are common to all map views.

Fixed Placement of Node and Link Objects

Nodes and links are not movable: they are rendered according to geographical coordinates.

Logical graphical views, which exist elsewhere in the application, place nodes and links in a graphical view, in a non-geographical format. The nodes and views can be moved around in these views. Use the logical type views to lay out nodes and links in a custom format

Label Interactor Shows More Detail

When you move over a node or link with the mouse, more details about the node or link object appear at the top of the map panel, in the label interactor.

Object Drilldown

When you double-click a node object, the detail view of the object is displayed. For site-based nodes, double-click to display the detail view of the selected site object in the main application workbench. For equipment-based nodes, double-click to display the detail view of the selected equipment object in the main application workbench.

When you double-click a link object, its child trails are displayed in a table. Double-click a trail in the table to display the detail view of the selected link object in the main application workbench.

Map View Menu Options

The map view displays these menu options:

  • Show Legend: Displays a legend explaining the nodes and links in the current view.

  • Print: Prints the current geographic view.

  • Save As Visible Image: Saves the current geographical image as a JPEG.

  • Link Layers: Select separate layers for paths (bearers) and trails (transports.) See "Viewing Link Layers".

Geographic View Transformation Toolbar Operations

At the top right-hand corner of the graphic screen, a toolbar displays the following buttons:

  • Reset

  • Zoom in

  • Zoom out

  • Zoom rectangle

  • Pan

Note:

Clicking a button in this group defines the mouse pointer behavior until you click a different button.
Resetting the Geographic Map

Resetting the geographic map returns the map view to the initial display setting. If you zoom in or out too far, the reset button returns the map to full view.

To reset the geographic map:

  1. Click Reset. Reset icon

    After a few seconds the map resets to its default size.

Zooming and Panning

Zooming increases or decreases the scale of a map view. Panning selects a specific click point as the center of a map view.

To zoom in:

  1. Click Zoom in. Zoom in icon

  2. Click a point on the map required to be the centre of the zoom.

    After a few seconds the map is rendered on a larger scale, centered on the click point.

To zoom out:

  1. Click Zoom out. Zoom out icon

  2. Click a point on the map required to be the centre of the zoom out.

    After a few seconds the map is rendered on a smaller scale, centered on the click point.

To use zoom rectangle:

  1. Click Zoom rectangle. Zoom rectangle icon

  2. Click a starting point in the map.

    This is the start of the zoomed rectangle area.

  3. Drag the mouse until you have the rectangle required to zoom in on.

    After a few seconds, the map is rendered on a larger scale, bound by the selected rectangle.

To pan in:

  1. Click Pan. Pan icon

  2. Click a point in the map required to be the centre of the pan.

    After a few seconds the map is re-rendered, centered at the click point. There is no increase or decrease to the scale of the map.

About Route Links

The Inter Site Trail Geographic Report and Inter Equipment Trail Geographic Report each contain a Route Links tab. This tab displays the route objects between each node pair. Double-click a row to display a window containing a list of all the trails that comprise each route link.

Table 1-5 Route Links Definitions

Attribute Description

Utilization

The total cumulative bandwidth utilization of all the trails that comprise the route link.

Total Slots

The total number of aggregated slots of all the trails that comprise the route link.

Free Slots

The total number of aggregated free slots of all the trails that comprise the route link. A free slot is a path or timeslot that does not have a reference to a child trail.

Monthly Update

The monthly uptake in megabytes of the route object referenced by the route link. This value is the rate of growth per month in carried traffic on this route link. It is an average value of the individual growths of each trail making up the route link.

Exhaustion Date

This is the calculated exhaustion date of the Route object and is based on the current monthly uptake based on past time periods.


About the Trail List

The Inter Site Trail Geographic Report and Inter Equipment Trail Geographic Report each contain a Trail List tab. This tab displays the trail objects that compose the link objects in the geographic view. Double-click a row to display the trail detail view of the trail referenced in the selected row.

Filtering View Data

Some views can be filtered to display only part of the available data. For example, when displaying trails, you can select to display link or path trails, or you can display trails for a specific capacity. If you do not select any filter criteria, all data is displayed. However, in some cases, you cannot open a view without filtering.

Note:

Filter criteria change depending on the view.

To filter view data:

  1. Click a view in the View tab. If the view allows filtering, the Filter Criteria tab is displayed, as shown in Figure 1-7.

    Figure 1-7 Filtering Options

    Description of Figure 1-7 follows
    Description of "Figure 1-7 Filtering Options"

  2. Use the tabs to display the type of data you want to filter from. For example, to display a specific type of trail, click Group Type.

  3. Select the properties you want to include in the view. For example, to include links, select Link.

    To select multiple properties, use the Shift and Ctrl keys. Selected properties remain selected when you click other tabs.

    Properties in tabs are dependent on each other. For example, the type of trail you select in the Group Type tab determines the available capacities in the Capacity tab.; for example: the filter is prepopulated with all available traffic types for the selected equipment based on the known list of trails that reference the equipment.

  4. Click Apply to display the view.

Using Standard Trail View Filter Options

Links, or link trails, generally, are point-to-point links at the highest level of the logical network. Parents of links are normally cable fiber pairs. From a planning point of view, a link trail is considered a link with a capacity to be managed between two network nodes. Link trails transport child trails of group type Path.

Path trails normally refer to path trails that logically carry customer trails between two points in the network. Path trails have link trails as parents and child trails of group type Trail as children.

Circuit trails are circuits that deliver services to customer nodes. A circuit with a group type of Circuit normally has trails of group type Path as parents.

Note:

The names Link, Path, and Trail can be changed by an administrative user using the administrative web portal. For example: in the US, a link is commonly called a facility, and a path is usually known as a rider.

The standard filter options for trail views are:

  • Group Type:

    • Link

    • Circuit

    • Path

  • Group: Defines a set of trails that are of a common type within a group type. For example, you can define a Group with the name ”IP Link” that is a child of Group Type ”Link,” which enables the classification of all IP Link trails as part of the same group.

  • Service

  • Capacity

  • Date Range:

    • Creation date

    • In service date

Using Standard Link View Filter Options

The standard filter options for link views are:

  • Group Type:

    • Link

    • Circuit

    • Path

  • Group

  • Service

  • Capacity

  • Protection types:

    • Protected

    • Protection

    • Unprotected

Using Standard Equipment View Filter Options

The standard filter options for equipment views are:

  • Equipment Platform: Denotes what type of technology an equipment belongs to. Examples include IP, DWDM, SDH, Metro Ethernet.

  • Equipment Type: Sub-categorizes equipment within an equipment platform. For example, there might be an equipment platform called ”IP” that has two equipment types called ”IP Router” and ”IP Switch.”

  • Equipment Template: Defines the equipment model. For example, ”Cisco 8600" is the model type that identifies what model of equipment the equipment instance is.

Active Filtering

In Network intelligence, most reports use active filtering, where the items in the filter panel reflect the data related to the object being reported on.

For example, in a report detailing trails terminating on an equipment, the filter options offered (trail groups, capacities, and so on) are those that apply to trails that terminate on the equipment.

Some reports, for performance reasons, do not use active filtering:

  • Network Node View

  • Network All Child Trails View

  • Site All Child Trails View

  • Topology All Child Trails View

  • Equipment All Child Trails View

Saving the Data in a View

In most cases, you can save a view to its appropriate format. For example, you can save graphs as image (JPEG) files, and you can save table views in spreadsheet format or as HTML.

To save view data:

  1. Right-click anywhere in the view data display.

  2. Select to save or copy the data.

  3. Specify a file name and location, and save the file.

Editing Object Detail Data

To change object attributes in the object details view:

  1. Display the object details view.

  2. Click Edit.

  3. Make the changes.

  4. Click Save.

Changes are saved to the Network Intelligence database.

Note:

If Network Intelligence is deployed as a slave data system to a master data source whereby object attributes are updated by the master source and changes loaded into Network Intelligence, then use of this update functionality should be reviewed.

Displaying a Legend

A legend outlines the assignment of colors to entities, and the hierarchical structure of the view.

To display a legend that describes the modeled view:

  1. Right-click the background of the image.

  2. Click Show Legend.

Saving the View in Spreadsheet Format

To save the view as a Microsoft Excel spreadsheet:

  1. Right-click the background of the image.

  2. Click Open in Excel.

  3. Select a location to save the file.

Managing Windows

To manage tabs, windows, and dialog boxes, use these features:

  • To close a tab, right-click it and select Close.

  • To close multiple tabs, right-click any tab and select from:

    • Close All But This

    • Close All Tabs

To display currently open tabs, windows, and dialog boxes:

  • Click a tab to display it.

  • Use the Window menu to display a tab. This menu shows only those windows that are currently open.

  • Use the Dialog menu to display a dialog box. This menu shows only those dialog boxes that are currently open.

Searching

In addition to using the tree browser, you can search for network entities. Each type of data has its own search criteria.

To search for data:

  1. From the context toolbar, open the browser of the object type you want to search for.

  2. Click the Search icon:

    search icon

  3. The object's search window is displayed.

    • Searching is based on any main attribute, such as name, platform, in service date, or object status.

    • Check the Advanced Search box, if applicable, to use extensible attributes in the search.

      See Network Intelligence Developer's Guide for further information on creating and configuring extensible attributes.

    • Check the Case Sensitive box to render the search case sensitive.

    • Click the Ellipsis icon to open a search window for an entity; for example, service or customer:

      ellipisis icon to open a search window

    • Click the Clear icon to clear a text field:

      clear icon to clear a text field

Performing Actions on Search Results

When the object has been found, it is displayed under the Result tab. Double-click an object to display a full object details view.

  • Click Edit to configure object details.

  • Click Save to commit the object information.

  • Click Delete to remove the object.

  • Select a view to display further information about an object.