Skip Headers
Oracle® Exalogic Elastic Cloud Machine Owner's Guide
Release EL X2-2, X3-2, and X4-2

E18478-18
Go to Documentation Home
Home
Go to Book List
Book List
Go to Table of Contents
Contents
Go to Feedback page
Contact Us

Go to previous page
Previous
Go to next page
Next
PDF · Mobi · ePub

5 Adding Exalogic Machine to Your Network

This chapter discusses the factory configuration and initial network configuration for the Exalogic machine.

This chapter contains the following topics:

5.1 Default State of the Exalogic Machine Network Configuration

At the time of manufacturing in the factory, an Exalogic machine has the following network topology:

5.2 Verifying Factory Configuration

You can verify the factory configuration of your Exalogic machine by viewing the /etc/exalogic.conf file on the compute nodes.

The file provides default configuration information, such as the following:

RACK_TYPE=3
NODE_INDEX=19
RACK_NAME=el01
CNODE_PREFIX=cn
SNODE_PREFIX=sn
DNS_SERVER_LIST=
DOMAIN_SEARCH_ORDER=
DOMAIN_NAME=abc.example.com
eth0_BOOTPROTO=static
eth0_NETMASK=255.255.252.0
eth0_GATEWAY=10.11.12.13
bond0_NETMASK=255.255.255.0
has_bond1=0
SPNET0_NETMASK=
SPNET0_GATEWAY=
cnode1_host_name=el01cn01
cnode1_private_host_name=el01cn01-priv
cnode1_eth0_IPADDR=192.168.1.1
cnode1_bond0_IPADDR=192.168.10.1
cnode1_SPNET0_IPADDR=192.168.1.101
cnode2_host_name=el01cn02
cnode2_private_host_name=el01cn02-priv
cnode2_eth0_IPADDR=192.168.1.2
cnode2_bond0_IPADDR=192.168.10.2
cnode2_SPNET0_IPADDR=192.168.1.102
cnode3_host_name=el01cn03
cnode3_private_host_name=el01cn03-priv
cnode3_eth0_IPADDR=192.168.1.3
cnode3_bond0_IPADDR=192.168.10.3
cnode3_SPNET0_IPADDR=192.168.1.103
cnode4_host_name=el01cn04
cnode4_private_host_name=el01cn04-priv
cnode4_eth0_IPADDR=192.168.1.4
cnode4_bond0_IPADDR=192.168.10.4
cnode4_SPNET0_IPADDR=192.168.1.104
cnode5_host_name=el01cn05
cnode5_private_host_name=el01cn05-priv
cnode5_eth0_IPADDR=192.168.1.5
cnode5_bond0_IPADDR=192.168.10.5
cnode5_SPNET0_IPADDR=192.168.1.105
cnode6_host_name=el01cn06
cnode6_private_host_name=el01cn06-priv
cnode6_eth0_IPADDR=192.168.1.6
cnode6_bond0_IPADDR=192.168.10.6
cnode6_SPNET0_IPADDR=192.168.1.106
cnode7_host_name=el01cn07
cnode7_private_host_name=el01cn07-priv
cnode7_eth0_IPADDR=192.168.1.7
cnode7_bond0_IPADDR=192.168.10.7
cnode7_SPNET0_IPADDR=192.168.1.107
cnode8_host_name=el01cn08
cnode8_private_host_name=el01cn08-priv
cnode8_eth0_IPADDR=192.168.1.8
cnode8_bond0_IPADDR=192.168.10.8
cnode8_SPNET0_IPADDR=192.168.1.108
cnode9_host_name=el01cn09
cnode9_private_host_name=el01cn09-priv
cnode9_eth0_IPADDR=192.168.1.9
cnode9_bond0_IPADDR=192.168.10.9
cnode9_SPNET0_IPADDR=192.168.1.109
cnode10_host_name=el01cn10
cnode10_private_host_name=el01cn10-priv
cnode10_eth0_IPADDR=192.168.1.10
cnode10_bond0_IPADDR=192.168.10.10
cnode10_SPNET0_IPADDR=192.168.1.110
cnode11_host_name=el01cn11
cnode11_private_host_name=el01cn11-priv
cnode11_eth0_IPADDR=192.168.1.11
cnode11_bond0_IPADDR=192.168.10.11
cnode11_SPNET0_IPADDR=192.168.1.111
cnode12_host_name=el01cn12
cnode12_private_host_name=el01cn12-priv
cnode12_eth0_IPADDR=192.168.1.12
cnode12_bond0_IPADDR=192.168.10.12
cnode12_SPNET0_IPADDR=192.168.1.112
cnode13_host_name=el01cn13
cnode13_private_host_name=el01cn13-priv
cnode13_eth0_IPADDR=192.168.1.13
cnode13_bond0_IPADDR=192.168.10.13
cnode13_SPNET0_IPADDR=192.168.1.113
cnode14_host_name=el01cn14
cnode14_private_host_name=el01cn14-priv
cnode14_eth0_IPADDR=192.168.1.14
cnode14_bond0_IPADDR=192.168.10.14
cnode14_SPNET0_IPADDR=192.168.1.114
cnode15_host_name=el01cn15
cnode15_private_host_name=el01cn15-priv
cnode15_eth0_IPADDR=192.168.1.17
cnode15_bond0_IPADDR=192.168.10.17
cnode15_SPNET0_IPADDR=192.168.1.117
cnode16_host_name=el01cn16
cnode16_private_host_name=el01cn16-priv
cnode16_eth0_IPADDR=192.168.1.18
cnode16_bond0_IPADDR=192.168.10.18
cnode16_SPNET0_IPADDR=192.168.1.118
cnode17_host_name=el01cn17
cnode17_private_host_name=el01cn17-priv
cnode17_eth0_IPADDR=192.168.1.19
cnode17_bond0_IPADDR=192.168.10.19
cnode17_SPNET0_IPADDR=192.168.1.119
cnode18_host_name=el01cn18
cnode18_private_host_name=el01cn18-priv
cnode18_eth0_IPADDR=192.168.1.20
cnode18_bond0_IPADDR=192.168.10.20
cnode18_SPNET0_IPADDR=192.168.1.120
cnode19_host_name=el01cn19
cnode19_private_host_name=el01cn19-priv
cnode19_eth0_IPADDR=192.168.1.21
cnode19_bond0_IPADDR=192.168.10.21
cnode19_SPNET0_IPADDR=192.168.1.121
cnode20_host_name=el01cn20
cnode20_private_host_name=el01cn20-priv
cnode20_eth0_IPADDR=192.168.1.22
cnode20_bond0_IPADDR=192.168.10.22
cnode20_SPNET0_IPADDR=192.168.1.122
cnode21_host_name=el01cn21
cnode21_private_host_name=el01cn21-priv
cnode21_eth0_IPADDR=192.168.1.23
cnode21_bond0_IPADDR=192.168.10.23
cnode21_SPNET0_IPADDR=192.168.1.123
cnode22_host_name=el01cn22
cnode22_private_host_name=el01cn22-priv
cnode22_eth0_IPADDR=192.168.1.24
cnode22_bond0_IPADDR=192.168.10.24
cnode22_SPNET0_IPADDR=192.168.1.124
cnode23_host_name=el01cn23
cnode23_private_host_name=el01cn23-priv
cnode23_eth0_IPADDR=192.168.1.25
cnode23_bond0_IPADDR=192.168.10.25
cnode23_SPNET0_IPADDR=192.168.1.125
cnode24_host_name=el01cn24
cnode24_private_host_name=el01cn24-priv
cnode24_eth0_IPADDR=192.168.1.26
cnode24_bond0_IPADDR=192.168.10.26
cnode24_SPNET0_IPADDR=192.168.1.126
cnode25_host_name=el01cn25
cnode25_private_host_name=el01cn25-priv
cnode25_eth0_IPADDR=192.168.1.27
cnode25_bond0_IPADDR=192.168.10.27
cnode25_SPNET0_IPADDR=192.168.1.127
cnode26_host_name=el01cn26
cnode26_private_host_name=el01cn26-priv
cnode26_eth0_IPADDR=192.168.1.28
cnode26_bond0_IPADDR=192.168.10.28
cnode26_SPNET0_IPADDR=192.168.1.128
cnode27_host_name=el01cn27
cnode27_private_host_name=el01cn27-priv
cnode27_eth0_IPADDR=192.168.1.29
cnode27_bond0_IPADDR=192.168.10.29
cnode27_SPNET0_IPADDR=192.168.1.129
cnode28_host_name=el01cn28
cnode28_private_host_name=el01cn28-priv
cnode28_eth0_IPADDR=192.168.1.30
cnode28_bond0_IPADDR=192.168.10.30
cnode28_SPNET0_IPADDR=192.168.1.130
cnode29_host_name=el01cn29
cnode29_private_host_name=el01cn29-priv
cnode29_eth0_IPADDR=192.168.1.31
cnode29_bond0_IPADDR=192.168.10.31
cnode29_SPNET0_IPADDR=192.168.1.131
cnode30_host_name=el01cn30
cnode30_private_host_name=el01cn30-priv
cnode30_eth0_IPADDR=192.168.1.32
cnode30_bond0_IPADDR=192.168.10.32
cnode30_SPNET0_IPADDR=192.168.1.132
snode1_host_name=el01sn01
snode1_private_host_name=el01sn01-priv
snode1_eth0_IPADDR=192.168.1.15
snode1_bond0_IPADDR=192.168.10.15
snode1_SPNET0_IPADDR=192.168.1.115
snode2_host_name=el01sn02
snode2_private_host_name=el01sn02-priv
snode2_eth0_IPADDR=192.168.1.16
snode2_bond0_IPADDR=192.168.10.16
snode2_SPNET0_IPADDR=192.168.1.116

5.3 Prerequisites for Connecting Exalogic Machine to External Ethernet Network

Depending on the type of your Ethernet device, you should use cables and transceivers to connect an Exalogic machine to your existing network. For more information, see Section 6.6.6, "Connectivity Between Exalogic Machine and External LAN Through Sun Network QDR InfiniBand Gateway Switch".

5.4 Initial Network Configuration of Exalogic Machine

After you connect your Exalogic machine to the external Ethernet network using cables and transceivers, you must configure the following Exalogic components to add them to the network:

  1. Mandatory: Cisco Ethernet Switch

  2. Optional: vNICs on Sun Network QDR InfiniBand Gateway Switches for Ethernet over InfiniBand (EoIB) connectivity, if necessary

  3. Mandatory: Compute nodes

  4. Mandatory: Storage heads

  5. Mandatory: Sun Network QDR InfiniBand Gateway Switches

  6. Optional: Sun Datacenter InfiniBand Switch 36, if you are connecting your Exalogic machine to another Exalogic machine rack or to an Oracle Exadata Database Machine rack

Note:

You can use the Oracle Exalogic Configuration Utility set of tools and scripts to configure the compute nodes, storage heads, and Sun Network QDR InfiniBand Gateway Switches. For more information about Exalogic Configuration Utility, see Appendix A, "Configuring Exalogic Machine Using ECU".

You must configure the Cisco Ethernet Switch manually. For more information, see Configuring the Cisco Ethernet Switch.

For information about configuring VNICs for Ethernet connectivity, see Chapter 10, "Configuring Ethernet Over InfiniBand".

For information about configuring the Sun Datacenter InfiniBand Switch 36 manually in multirack scenarios, see Chapter 13, "Using Sun Datacenter InfiniBand Switch 36 in Multirack Configurations".

5.4.1 Configuring the Cisco Ethernet Switch

The host name, IP address, DNS and NTP configurations must be configured for the Cisco Ethernet switch. Before configuring the switch, note the following:

  • The Cisco Ethernet switch should not be connected until the running configuration has been verified, and any necessary changes have been made by the network administrator.

  • The Cisco Ethernet switch should not be connected to the network until the IP addresses on all components have been configured in the Exalogic machine. This is to prevent any duplicate IP address conflicts which are possible due to the default addresses set in the components when shipped.

The following procedure describes how to configure the Cisco Ethernet switch:

  1. Connect a serial cable from the Cisco switch console to a laptop or similar device. An RJ45 to DB9 serial cable is included in the Cisco documentation package.

  2. Ensure that the terminal session is logged on the laptop by scripting the output. The data can be used as a reference that the switch has been configured correctly. The default serial port speed is 9600 baud, 8 bits, no parity, 1 stop bit, and no handshake.

    Switch con0 is now available
    Press RETURN to get started.
    
  3. Change to enable mode using the following command. The Cisco switch prompts for the default password. For the default password, contact Oracle Support.

    Switch> enable
    
  4. Configure the network for a single VLAN. The following is an example of the configuration:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# interface vlan 1
    Switch(config-if)# ip address 10.7.7.34 255.255.255.0
    Switch(config-if)# end
    Switch# *Sep 15 14:12:06.309:%SYS-5-CONFIG_I:Configured from console by console
    Switch# write memory
    Building configuration...
    Compressed configuration from 2474 bytes to 1066 bytes [OK ]
    
  5. (Optional) Disable the default IP routing setting, and configure the default gateway as follows. This step is required if IP routing will not be used on the switch.

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# no ip routing
    Switch(config)# ip default-gateway 10.7.7.1
    Switch(config)# end 
    *Sep 15 14:12:46.309:%SYS-5-CONFIG_I:Configured from console by console
    Switch# write memory
    Building configuration...
    Compressed configuration from 2492 bytes to 1070 bytes [OK ]
    

    Note:

    If IP routing is required on the switch, then leave the IP routing setting as the default, and configure the default gateway as follows:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# ip route 0.0.0.0 0.0.0.0 10.7.7.1
    Switch(config)# end
    *Sep 15 14:13:26.013:%SYS-5-CONFIG_I:Configured from console by console
    Switch# write memory
    Building configuration...
    Compressed configuration from 2502 bytes to 1085 bytes [OK ]
    
  6. Set the host name of the switch as follows:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# hostname corxsw-ip
    burxsw-ip(config)# end
    burxsw-ip# write memory
    Building configuration...
    Compressed configuration from 3789 bytes to 1469 bytes [OK ]
    

    The system host name will be used as the prompt name.

  7. Set the password as follows:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# enable password Your_Password
    Switch(config)# enable secret Your_Password 
    The enable secret you have chosen is thesame as your enable password.
    This is not recommended.Re-enter the enable secret.
    Switch(config)# end
    Switch#write memory 
    *Sep 15 14:25:05.893:%SYS-5-CONFIG_I:Configured from console by console
    Building configuration...
    Compressed configuration from 2502 bytes to 1085 bytes [OK ]
    
  8. Set the password for telnet network access. The following is an example:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# line vty 0 15
    Switch(config-line)# login
    %Login disabled on line 1,until 'password'is set
    %Login disabled on line 2,until 'password'is set
    %Login disabled on line 3,until 'password'is set
    ...
    %Login disabled on line 15,until 'password'is set
    %Login disabled on line 16,until 'password'is set
    Switch(config-line)# password Your_Password
    Switch(config-line)# login
    Switch(config-line)# end
    Switch#write memory
    Building configuration...
    Compressed configuration from 3786 bytes to 1468 bytes [OK ]
    Switch#
    

    In the preceding example, the first login output shows the password has not been set, and telnet access is disabled. If the login command returns nothing, then the password is set and telnet access is available.

  9. Configure up to three DNS servers. The following is an example:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# ip domain-name exdm.com
    Switch(config)# ip name-server 10.7.7.3
    Switch(config)# ip name-server 129.148.5.5
    Switch(config)# ip name-server 10.8.160.1
    Switch(config)# end 
    *Sep 15 14:26:37.045:%SYS-5-CONFIG_I:Configured from console by console
    Switch#write memory
    Building configuration...
    Compressed configuration from 2603 bytes to 1158 bytes [OK ]
    
  10. Set the clock and time zone as follows. The switch keeps internal time in Coordinated Universal Time (UTC) format.

    • To use UTC use the following command:

      no clock timezone global configuration
      
    • To use a time zone, use the following command:

      clock timezone zone hours-offset [minutes-offset]
      

      In the preceding command, zone is the time zone to display when standard time in effect, hours-offset is the hours offset from UTC, and minutes-offset is the minutes offset from UTC.

    • To set summer time hours, use the following command:

      clock summer-time zone recurring [week day month hh:mm week day month \
      hh:mm [offset]]
      

      In the preceding command, zone is the time zone to be displayed when summer time is in effect, week is the week of the month (1 to 5 or last), day is the day of the week, month is the month, hh:mm is the time in 24-hour format, and offset is the number of minutes to add during summer time. The default offset is 60 minutes.

    • To manually set the clock to any time, use the following command:

      clock set hh:mm:ss month day year
      

      In the preceding command, hh:mm:ss is the time in 24-hour format, day is the day of the month, month is the month, and year is the year. The time specified is relative to the configured time zone.

    To set the local time and time zone, ordering is important. The following is an example of setting local time to US Eastern time:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# clock timezone EST -5 
    Switch(config)# clock summer-time EDT recurring
    Switch(config)# end
    Switch# clock set 21:00:00 December 09 2009
    Switch#write memory
    Building configuration...
    Compressed configuration from 3784 bytes to 1465 bytes [OK ]
    Switch# show clock
    21:00:06.643 EST Wed Dec 9 2009
    
  11. Configure up to two NTP servers. The following is an example:

    Switch# configure terminal
    Enter configuration commands,one per line.End with CNTL/Z.
    Switch(config)# ntp server 10.7.7.32 prefer
    Switch(config)# ntp server 129.148.9.19
    Switch(config)# end
    *Sep 15 14:51:08.665:%SYS-5-CONFIG_I:Configured from console by
    console
    Switch# write memory
    Building configuration...
    Compressed configuration from 2654 bytes to 1163 bytes [OK ]
    Switch# show ntp status
    <output will vary per network>
    Switch# show clock
    20:59:06.643 EST Wed Dec 9 2009
    

    The preceding should show the NTP server synchronized to local time if the Cisco switch is connected to the network and has access to NTP.

  12. Verify the configuration using the following command:

    Switch# show running-config
    

    The following is an example of the output:

    Building configuration...
    Current configuration :2654 bytes
    !
    version 12.2
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    service compress-config
    !
    hostname Switch
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$mS8h$EaJrIECUxavfGH6vLZg1T.
    enable password Your_Password
    !
    no aaa new-model
    ip subnet-zero
    ip domain-name sodm.com
    ip name-server 10.7.7.3
    ip name-server 172.16.5.5
    ip name-server 10.8.160.1
    !
    ip vrf mgmtVrf
    !
    vtp mode transparent
    !
    power redundancy-mode redundant
    !
    !
    spanning-tree mode pvst
    spanning-tree extend system-id
    no spanning-tree vlan 1
    !
    vlan internal allocation policy ascending
    !
    !
    interface FastEthernet1
    ip vrf forwarding mgmtVrf
    no ip address
    speed auto
    duplex auto
    !
    interface GigabitEthernet1/1
    !
    interface GigabitEthernet1/2
    !
    ...
    !
    interface GigabitEthernet1/44
    !
    interface GigabitEthernet1/45
    media-type rj45
    !
    interface GigabitEthernet1/46
    media-type rj45
    !
    interface GigabitEthernet1/47
    media-type rj45
    !
    interface GigabitEthernet1/48
    media-type rj45
    !
    interface Vlan1
    ip address 10.7.7.34 255.255.255.0
    !
    interface Vlan48
    no ip address
    shutdown
    !
    ip default-gateway 10.7.7.1
    ip http server
    !
    !
    control-plane
    !
    !
    line con 0
    stopbits 1
    line vty 0 4
    password Your_Password
    login
    line vty 5 15
    password Your_Password
    login
    !
    ntp server 10.7.7.32 prefer
    ntp server 172.16.9.1
    end
    

    If any setting is incorrect, then repeat the appropriate step. To erase a setting, enter no in front of the same command. For example, to erase the default gateway, the following commands would be entered:

    no ip default-gateway 10.7.7.1
    end
    write memory
    
  13. Save the current configuration using the following command:

    Switch# copy running-config startup-config
    
  14. Exit from the session using the following command:

    Switch# exit
    
  15. Disconnect the cable from the Cisco console.

    Note:

    To check the configuration, attach a laptop computer to port 48, and ping the IP address of the internal management network.