- Reverse address resolution protocol
You use the RARP protocol to map dynamically between the Internet Protocol (IP) and network interface MAC addresses. RARP is often used to boot a Solaris client. RARP clients include the SPARC boot PROM, x86 boot floppy, SunOS kernel, and ifconfig(1M). in.rarpd(1M) provides the server-side implementation.
RARP request timeout behavior in application-layer clients is governed by the /etc/inet/rarp default file. To tune the number of retries an application attempts before giving up, set the RARP_RETRIES variable in /etc/inet/rarp. If the file is not present or RARP_RETRIES is not initialized within it, applications retry a maximum of five times with a eight second wait between retries.
See attributes(5) for descriptions of the following attributes:
Reverse Address Resolution Protocol RFC 903. June, 1994 R. Finlayson, T. Mann, J.C. Mogul, M. Theimer