JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Driver Entry Points
search filter icon
search icon

Document Information

Preface

Introduction

Driver Entry Points

aread(9E)

attach(9E)

awrite(9E)

chpoll(9E)

close(9E)

csx_event_handler(9E)

detach(9E)

devmap(9E)

devmap_access(9E)

devmap_contextmgt(9E)

devmap_dup(9E)

devmap_map(9E)

devmap_unmap(9E)

dump(9E)

_fini(9E)

getinfo(9E)

gld(9E)

gldm_get_stats(9E)

gldm_intr(9E)

gldm_ioctl(9E)

gldm_reset(9E)

gldm_send(9E)

gldm_set_mac_addr(9E)

gldm_set_multicast(9E)

gldm_set_promiscuous(9E)

gldm_start(9E)

gldm_stop(9E)

identify(9E)

_info(9E)

_init(9E)

ioctl(9E)

ks_snapshot(9E)

ks_update(9E)

mac(9E)

mc_getcapab(9E)

mc_getprop(9E)

mc_getstat(9E)

mc_ioctl(9E)

mc_multicst(9E)

mc_propinfo(9E)

mc_setpromisc(9E)

mc_setprop(9E)

mc_start(9E)

mc_stop(9E)

mc_tx(9E)

mc_unicst(9E)

mmap(9E)

open(9E)

power(9E)

print(9E)

probe(9E)

prop_op(9E)

put(9E)

read(9E)

segmap(9E)

srv(9E)

strategy(9E)

tran_abort(9E)

tran_bus_reset(9E)

tran_destroy_pkt(9E)

tran_dmafree(9E)

tran_getcap(9E)

tran_init_pkt(9E)

tran_quiesce(9E)

tran_reset(9E)

tran_reset_notify(9E)

tran_setcap(9E)

tran_start(9E)

tran_sync_pkt(9E)

tran_tgt_free(9E)

tran_tgt_init(9E)

tran_tgt_probe(9E)

tran_unquiesce(9E)

write(9E)

tran_tgt_free

- request to free HBA resources allocated on behalf of a target

Synopsis

#include <sys/scsi/scsi.h>



void prefixtran_tgt_free(dev_info_t *hba_dip, dev_info_t *tgt_dip,
     scsi_hba_tran_t *hba_tran, struct scsi_device *sd);

Interface Level

Solaris architecture specific (Solaris DDI).

Parameters

hba_dip

Pointer to a dev_info_t structure, referring to the HBA device instance.

tgt_dip

Pointer to a dev_info_t structure, referring to the target device instance.

hba_tran

Pointer to a scsi_hba_tran(9S) structure, consisting of the HBA's transport vectors.

sd

Pointer to a scsi_device(9S) structure, describing the target.

Description

The tran_tgt_free() vector in the scsi_hba_tran(9S) structure may be initialized during the HBA driver's attach(9E) to point to an HBA driver function to be called by the system when an instance of a target device is being detached. The tran_tgt_free() vector, if not NULL, is called after the target device instance has returned successfully from its detach(9E) entry point, but before the dev_info node structure is removed from the system. The HBA driver should release any resources allocated during its tran_tgt_init() or tran_tgt_probe() initialization performed for this target device instance.

See Also

attach(9E), detach(9E), tran_tgt_init(9E), tran_tgt_probe(9E), scsi_device(9S), scsi_hba_tran(9S)

Writing Device Drivers