- free a previously mapped register address space
#include <sys/ddi.h> #include <sys/sunddi.h> void ddi_regs_map_free(ddi_acc_handle_t *handle);
Solaris DDI specific (Solaris DDI).
Pointer to a data access handle previously allocated by a call to a setup routine such as ddi_regs_map_setup(9F).
ddi_regs_map_free() frees the mapping represented by the data access handle handle. This function is provided for drivers preparing to detach themselves from the system, allowing them to release allocated system resources represented in the handle.
ddi_regs_map_free() must be called from user or kernel context.
See attributes(5) for descriptions of the following attributes: