JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Properties and Data Structures
search filter icon
search icon

Document Information

Preface

Introduction

Data Structures for Drivers

aio_req(9S)

buf(9S)

cb_ops(9S)

copyreq(9S)

copyresp(9S)

datab(9S)

dblk(9S)

ddi_device_acc_attr(9S)

ddi_dma_attr(9S)

ddi_dma_cookie(9S)

ddi_dmae_req(9S)

ddi_dma_lim(9S)

ddi_dma_lim_sparc(9S)

ddi_dma_lim_x86(9S)

ddi_dma_req(9S)

ddi_fm_error(9S)

ddi-forceattach(9P)

ddi_idevice_cookie(9S)

ddi-no-autodetach(9P)

devmap_callback_ctl(9S)

dev_ops(9S)

fmodsw(9S)

free_rtn(9S)

gld_mac_info(9S)

gld_stats(9S)

hook_nic_event(9S)

hook_pkt_event(9S)

hook_t(9S)

inquiry-device-type(9P)

inquiry-product-id(9P)

inquiry-revision-id(9P)

inquiry-vendor-id(9P)

iocblk(9S)

iovec(9S)

kstat(9S)

kstat_intr(9S)

kstat_io(9S)

kstat_named(9S)

linkblk(9S)

lso_basic_tcp_ipv4(9S)

mac_callbacks(9S)

mac_capab_lso(9S)

mac_register(9S)

mblk(9S)

modldrv(9S)

modlinkage(9S)

modlstrmod(9S)

module_info(9S)

msgb(9S)

net_inject_t(9S)

net_instance_t(9S)

no-involuntary-power-cycles(9P)

pm(9P)

pm-components(9P)

qband(9S)

qinit(9S)

queclass(9S)

queue(9S)

removable-media(9P)

scsi_address(9S)

scsi_arq_status(9S)

scsi_asc_key_strings(9S)

scsi_device(9S)

scsi_extended_sense(9S)

scsi_hba_tran(9S)

scsi_inquiry(9S)

scsi_pkt(9S)

scsi_status(9S)

streamtab(9S)

stroptions(9S)

tuple(9S)

uio(9S)

usb_bulk_request(9S)

usb_callback_flags(9S)

usb_cfg_descr(9S)

usb_client_dev_data(9S)

usb_completion_reason(9S)

usb_ctrl_request(9S)

usb_dev_descr(9S)

usb_dev_qlf_descr(9S)

usb_ep_descr(9S)

usb_if_descr(9S)

usb_intr_request(9S)

usb_isoc_request(9S)

usb_other_speed_cfg_descr(9S)

usb_request_attributes(9S)

usb_string_descr(9S)

gld_stats

- Generic LAN Driver statistics data structure

Synopsis

#include <sys/gld.h>

Interface Level

Solaris architecture specific (Solaris DDI).

Description

The Generic LAN Driver (GLD) statistics (gld_stats) structure is used to communicate statistics and state information from a GLD-based driver to GLD when returning from a driver's gldm_get_stats() routine as discussed in gld(9E) and gld(7D). The members of this structure, filled in by the GLD-based driver, are used when GLD reports the statistics. In the tables below, the name of the statistics variable reported by GLD is noted in the comments. See gld(7D) for a more detailed description of the meaning of each statistic.

Drivers can make no assumptions about the length of this structure, which might be different in different releases of Solaris and/or GLD. Structure members private to GLD, not documented here, should not be set or read by the device specific driver.

Structure Members

The following structure members are defined for all media types:

uint64_t   glds_speed;               /* ifspeed */
uint32_t   glds_media;               /* media */
uint32_t   glds_intr;                /* intr */
uint32_t   glds_norcvbuf;            /* norcvbuf */
uint32_t   glds_errrcv;              /* ierrors */
uint32_t   glds_errxmt;              /* oerrors */
uint32_t   glds_missed;              /* missed */
uint32_t   glds_underflow;           /* uflo */
uint32_t   glds_overflow;            /* oflo */

The following structure members are defined for media type DL_ETHER:

uint32_t   glds_frame;                   /* align_errors */
uint32_t   glds_crc;                     /* fcs_errors */
uint32_t   glds_duplex;                  /* duplex */
uint32_t   glds_nocarrier;               /* carrier_errors */
uint32_t   glds_collisions;              /* collisions */
uint32_t   glds_excoll;                  /* ex_collisions */
uint32_t   glds_xmtlatecoll;             /* tx_late_collisions */
uint32_t   glds_defer;                   /* defer_xmts */
uint32_t   glds_dot3_first_coll;         /* first_collisions */
uint32_t   glds_dot3_multi_coll;         /* multi_collisions */
uint32_t   glds_dot3_sqe_error;          /* sqe_errors */
uint32_t   glds_dot3_mac_xmt_error;      /* macxmt_errors */
uint32_t   glds_dot3_mac_rcv_error;      /* macrcv_errors */
uint32_t   glds_dot3_frame_too_long;     /* toolong_errors */
uint32_t   glds_short;                   /* runt_errors */

The following structure members are defined for media type DL_TPR:

uint32_t   glds_dot5_line_error          /* line_errors */
uint32_t   glds_dot5_burst_error         /* burst_errors */
uint32_t   glds_dot5_signal_loss         /* signal_losses */
uint32_t   glds_dot5_ace_error           /* ace_errors */
uint32_t   glds_dot5_internal_error      /* internal_errors */
uint32_t   glds_dot5_lost_frame_error    /* lost_frame_errors */
uint32_t   glds_dot5_frame_copied_error  /* frame_copied_errors */
uint32_t   glds_dot5_token_error         /* token_errors */
uint32_t   glds_dot5_freq_error          /* freq_errors */

Note - Support for the DL_TPR media type is obsolete and may be removed in a future release of Solaris.


The following structure members are defined for media type DL_FDDI:

uint32_t   glds_fddi_mac_error;          /* mac_errors */
uint32_t   glds_fddi_mac_lost;           /* mac_lost_errors */
uint32_t   glds_fddi_mac_token;          /* mac_tokens */
uint32_t   glds_fddi_mac_tvx_expired;    /* mac_tvx_expired */
uint32_t   glds_fddi_mac_late;           /* mac_late */
uint32_t   glds_fddi_mac_ring_op;        /* mac_ring_ops */

Note - Support for the DL_FDDI media type is obsolete and may be removed in a future release of Solaris.


Most of the above statistics variables are counters denoting the number of times the particular event was observed. Exceptions are:

glds_speed

An estimate of the interface's current bandwidth in bits per second. For interfaces that do not vary in bandwidth or for those where no accurate estimation can be made, this object should contain the nominal bandwidth.

glds_media

The type of media (wiring) or connector used by the hardware. Currently supported media names include GLDM_AUI, GLDM_BNC, GLDM_TP, GLDM_10BT, GLDM_100BT, GLDM_100BTX, GLDM_100BT4, GLDM_RING4, GLDM_RING16, GLDM_FIBER, and GLDM_PHYMII. GLDM_UNKNOWN can also be specified.

glds_duplex

Current duplex state of the interface. Supported values are GLD_DUPLEX_HALF and GLD_DUPLEX_FULL. GLD_DUPLEX_UNKNOWN can also be specified.

See Also

gld(7D), gld(9F), gld(9E), gld_mac_info(9S)

Writing Device Drivers